CKCameraAPI: SDK开发手册

CKCameraAPI v2.0
工业相机SDK API文档
  • 首页
  • 模块
  • 类
  • 文件
SDK开发手册

文档发布记录

2017-7-4(V1.0) 发布第一个版本

2017-8-4(V2.0) 增加了以下内容

  • 增加CameraSetDisplayMode设置显示模式函数
  • 增加CameraSetCrossLine设置十字线功能
  • 增加CameraImageOverlay图像叠加功能
  • 增加CameraSetDisplayCallbackFun显示回调函数
  • 增加CameraSetResolutionEx设置自定义分辨率功能
  • 增加CameraSetBlackLevel设置黑电平的功能
  • 增加CameraGetImageBufferEx直接获取图像格式数据的函数

概述

文件结构

在二次开发中，需要直接使用到的库文件位于安装目录的SDK文件 夹中，分为32位和64位两个开发包。其中64位的SDK开发文 件，位于SDK/X64文件夹中，相对于32位的SDK文件，64位的SDK 文件名均以_X64结尾。 SDK目录下的CKSDK.DLL是相机的SDK动态链接库，对外提供 相机所有的接口函数，VC/C++的例程都引用了该库文件。

开发环境

SDK是标准的C语言接口动态链接库，我们提供了基于VC2015/C++ Builder 5/C++ Builder 6/ Delphi/labview/QT5/VB6/VB.Net等Demo

快速开发指南

相机操作流程概述

我们建议您按照如下的流程操作相机(其中有一些步骤是可选的，已 经标明)：

一、载入SDK的动态链接库档CKSDK.DLL。您可以使用动态或者静 态加载两种方式。如果您使用C/C++进行开发，在工程引用 CKCameraInterface.h头文件(位于安装目录的SDK/include中), 然后就可以直接在工程中引用SDK中的接口函数了,但是CKSDK.DLL 必须和您的应用程序放在同一目录下或者是系统的system32目录 下，放置于其他目录时，必须设定系统的环境变量(PATH)。

二、枚举设备。调用CameraEnumerateDevice函数枚举设备，获得 当前连接到PC上的相机的总个数，调用CameraGetEnumIndexInfo 函数获得当前标号包括设备名昵称(可自己修改)、版本号、唯一序列 号、相机型号等信息。

三、初始化设备。根据第二步中获得的相机设备枚举信息，调用 CameraInit函数初始化设定的相机，得到相机的句柄。如果需要同 时打开多个相机，则利用多个相机的设备名多次调用CameraInit来 获得多个相机的句柄，后续对相机的操作，都需要此时获得的相机句 柄来指定操作的相机对象。

四、让SDK进入图像采集模式。调用CameraPlay函数，让相机进 入工作模式，SDK开始接收来自相机的图像。

五、抓取图像。SDK提供了两种获得图像数据的方式，这两种方式 的效率都是一样的，底层都使用了零拷贝机制来提高效率，您可以根 据您的开发习惯来选择其中一种。

  • 1.主动调用CameraGetRawImageBuffer来获得一帧图像句柄。同 时，该函数可以设定超时时间，在指定的时间内没有获得到图像(线 程会被挂起)，则返回回超时。通过该句柄调用CameraGetImageInfo 该函数会获得一个SDK内被部用来接收图像数据的缓冲区地址，以 及帧头信息。
  • 2.在第三步中，初始化相机以后，调用 CameraSetCallbackFunction来指定一个回调函数。这种方式是被动 的，在SDK内部接收到有效的图像数据帧后，才会调用您指定的回 调函数来传递收到的图像数据帧。

六、处理图像。上一步获得的图像帧，是相机输出的原始格式，我公 司大多数型号相机，原始输出都是Bayer格式或者YUV格式，这些 格式信息会被自动添加到帧头信息中，调用 CameraGetOutImageBuffer来获得图像处理的效果，如颜色增益调整、 白平衡校正、饱和度等，并将YUV戒者Bayer格式的原始数据转换 为24BIT或者32BIT的位图格式。

七、将图像保存或者显示图像(如果您的开发中，不需要将图像保存 成文件或者进行显示，这一步可以略过)。 如果您需要保存图像到文件中，在第六步后，调用 CameraSaveImage函数来保存图片，SDK支持BMP和原始数据两种 方式。如果要保存原始数据，您应该在第五步以后就调用 CameraSaveImage函数；如果保存成BMP格式，您应该在第六步后 调用CameraSaveImage 如果您需要显示图像，有以下两个方式：

  • 1.自己根据开发环境来实现图像显示，例如利用OpenGL、 DirectDraw、WindowsGDI等方式来实现图像的显示。
  • 2.利用我们的SDK里封装好的显示接口来显示图像。在第四步 中初始化相机后，调用CameraDisplayInit函数来初始化显示接口， 该函数需要传入显示控件的句柄(HWND类型)。

八、在退出程序前关闭相机。在关闭相机时，调用CameraUnInit函 数。

开发例程

主动获取图像数据的例程

CameraSdkStatus CameraStartDisplay()
{
CameraSdkStatus ret;
//第一步：枚举
if ((ret = CameraEnumerateDevice(&mCameraNums)) != CAMERA_STATUS_SUCCESS || mCameraNums <= 0)
return ret;
//第二步：初始化相机
if((ret = CameraInitEx(&mCKCamHandle, mCameraNums - 1, -1, -1)) != CAMERA_STATUS_SUCCESS)
return ret;
//第三步： SDK 内部显示初始化（如果用户不需要 SDK 内部提供显示功能的情况下，此步奏可以略去）
if((ret = CameraDisplayInit(mCKCamHandle, hwnd)) != CAMERA_STATUS_SUCCESS)
{
CameraUnInit(mCKCamHandle);
return ret;
}
//第四步：采用主动方式获取图像数据
m_bExit = FALSE;
m_hDispThread = (HANDLE)_beginthreadex(NULL, 0, &uiDisplayThread, this, 0, &m_threadID);
ASSERT(m_hDispThread);
return ret;
}
UINT uiDisplayThread()
{
BYTE* pbyBuffer;
stImageInfo ImageInfo;
int status = CAMERA_STATUS_SUCCESS;
FrameStatistic fstatistic;
CameraPlay(mCKCamHandle);
while (!m_bExit)
{
HANDLE hBuf;
FrameTimeCur = GetTickCount();
//获取 RAW 数据
status = CameraGetRawImageBuffer(mCKCamHandle, &hBuf, 1000);
if (status == CAMERA_STATUS_SUCCESS)
{
//获得图像缓冲区地址
pbyBuffer = CameraGetImageInfo(mCKCamHandle, hBuf, &ImageInfo);
//获得经 ISP 处理的 RGB 数据
if (pRGBFrame == NULL || dRGBBufLen < (ImageInfo.iWidth*
ImageInfo.iHeight * 4))
{
if (pRGBFrame) delete pRGBFrame;
dRGBBufLen = (ImageInfo.iWidth*ImageInfo.iHeight * 4);
pRGBFrame = new BYTE[dRGBBufLen];
}
CameraGetOutImageBuffer(mCKCamHandle, &ImageInfo, pbyBuffer, pRGBFrame);
m_iDispFrameNum++;
memcpy(&m_sFrInfo, &ImageInfo, sizeof(stImageInfo));
CameraDisplay(mCKCamHandle, pRGBFrame, &ImageInfo);
//释放由 CameraGetRawImageBuffer 获得的缓冲区
CameraReleaseFrameHandle(mCKCamHandle, hBuf);
}
}
CameraPause(mCKCamHandle);
_endthreadex(0);
return 0;
}

被动获取图像数据的例程

void CameraStartDisplay()
{
CameraSdkStatus ret;
//第一步：枚举
if ((ret = CameraEnumerateDevice(&mCameraNums)) != CAMERA_STATUS_SUCCESS || mCameraNums <= 0)
return ret;
//第二步：初始化相机
if((ret = CameraInitEx(&mCKCamHandle, mCameraNums - 1, -1, -1)) != CAMERA_STATUS_SUCCESS)
return ret;
//第三步： SDK 内部显示初始化（如果用户不需要 SDK 内部提供显示功能的情况下，此步奏可以略去）
if((ret = CameraDisplayInit(mCKCamHandle, hwnd)) != CAMERA_STATUS_SUCCESS)
{
CameraUnInit(mCKCamHandle);
return ret;
}
ret = CameraSetCallbackFunction(mCKCamHandle, GrabImageCallback, (PVOID)this, NULL);
ret = CameraPlay(mCKCamHandle);
return ret;
}
void GrabImageCallback(HANDLE handle, BYTE *pFrameBuffer, stImageInfo* pFrameInfo)
{
stImageInfo ImageInfo;
memcpy(&ImageInfo, pFrameInfo, sizeof(stImageInfo));
if (pRGBFrame == NULL || dRGBBufLen < (ImageInfo.iWidth*ImageInfo.iHeight * 4))
{
if (pRGBFrame) delete pRGBFrame;
dRGBBufLen = (ImageInfo.iWidth*ImageInfo.iHeight * 4);
pRGBFrame = new BYTE[dRGBBufLen];
}
CameraGetOutImageBuffer(mCKCamHandle, &ImageInfo, pFrameBuffer, pRGBFrame);
m_iDispFrameNum++;
memcpy(&m_sFrInfo, &ImageInfo, sizeof(stImageInfo));
CameraDisplay(mCKCamHandle, pRGBFrame, &ImageInfo);
}

在图像中绘画图形

void CameraStartDisplay()
{
CameraSdkStatus ret;
//第一步：枚举
if ((ret = CameraEnumerateDevice(&mCameraNums)) != CAMERA_STATUS_SUCCESS || mCameraNums <= 0)
return ret;
//第二步：初始化相机
if((ret = CameraInitEx(&mCKCamHandle, mCameraNums - 1, -1, -1)) != CAMERA_STATUS_SUCCESS)
return ret;
//第三步： SDK 内部显示初始化（如果用户不需要 SDK 内部提供显示功能的情况下，此步奏可以略去）
if((ret = CameraDisplayInit(mCKCamHandle, hwnd)) != CAMERA_STATUS_SUCCESS)
{
CameraUnInit(mCKCamHandle);
return ret;
}
//第四步：采用被动方式获取图像数据,设置回调函数
ret = CameraSetCallbackFunction(mCKCamHandle, GrabImageCallback, (PVOID)this, NULL);
//第五步：设置绘画回调函数
ret = CameraSetDisplayCallbackFun(mCKCamHandle, DrawGraphCallback, (LPVOID)this, NULL);
//第六步：相机进入运行状态
ret = CameraPlay(mCKCamHandle);
return ret;
}
void GrabImageCallback(HANDLE handle, BYTE *pFrameBuffer, stImageInfo* pFrameInfo)
{
stImageInfo ImageInfo;
memcpy(&ImageInfo, pFrameInfo, sizeof(stImageInfo));
if (pRGBFrame == NULL || dRGBBufLen < (ImageInfo.iWidth*ImageInfo.iHeight * 4))
{
if (pRGBFrame)
delete pRGBFrame;
dRGBBufLen = (ImageInfo.iWidth*ImageInfo.iHeight * 4);
pRGBFrame = new BYTE[dRGBBufLen];
}
CameraGetOutImageBuffer(mCKCamHandle, &ImageInfo, pFrameBuffer, pRGBFrame);
m_iDispFrameNum++;
memcpy(&m_sFrInfo, &ImageInfo, sizeof(stImageInfo));
CameraDisplay(mCKCamHandle, pRGBFrame, &ImageInfo);
}
void DrawGraphCallback(HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
{
int width = pDisplayWindow->WinRect.right-pDisplayWindow->WinRect.left;
int height = pDisplayWindow->WinRect.bottom - pDisplayWindow->WinRect.top;
::MoveToEx(hdc, 0, 500, NULL);
::LineTo(hdc, pDisplayWindow->ImageWidth, 500);
::MoveToEx(hdc, 500, 0, NULL);
::LineTo(hdc, 500, pDisplayWindow->ImageHeight);
}
制作者 doxygen 1.8.10


CKCameraAPI: 模块

  • 模块
  • 类
  • 文件
模块
这里列出了所有模块:
[详情级别 12]
▼ SDK接口函数
获取相机设备列表
相机初始化、反初始化及相机能力级的获取
获得图像数据
相机的播放与暂停
显示预览图像
抓拍图片
曝光设置
白平衡设置
GAMMA设置
ISP设置
触发设置
相机参数的保存与加载
相机序列号的设置
版本信息
设置属性页
错误码
枚举
回调函数


CKCameraAPI: SDK接口函数

模块 | 函数
SDK接口函数

模块

获取相机设备列表
相机初始化、反初始化及相机能力级的获取
获得图像数据
相机的播放与暂停
显示预览图像
抓拍图片
曝光设置
白平衡设置
GAMMA设置
ISP设置
触发设置
相机参数的保存与加载
相机序列号的设置
版本信息
设置属性页

函数

CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeResolution (HANDLE hCamera, tSdkImageResolution *pImageCustom)
打开分辨率自定义面板，并通过可视化的方式来配置一个自定义分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeReferWin (HANDLE hCamera, INT iWinType, INT *piHOff, INT *piVOff, INT *piWidth, INT *piHeight)
打开参考窗口自定义面板。并通过可视化的方式来获得一个自定义窗口的位置。一般是用自定义白平衡和自动曝光的参考窗口。 更多...

详细描述

版本
2.0

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraCustomizeReferWin | ( | HANDLE | hCamera,
 |  | INT | iWinType,
 |  | INT * | piHOff,
 |  | INT * | piVOff,
 |  | INT * | piWidth,
 |  | INT * | piHeight
 | ) |  |

打开参考窗口自定义面板。并通过可视化的方式来获得一个自定义窗口的位置。一般是用自定义白平衡和自动曝光的参考窗口。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iWinType | 要生成的参考窗口的用途。0,自动曝光参考窗口；1,白平衡参考窗口。
[out] | piHOff | 指针，返回自定义窗口的左上角横坐标。
[out] | piVOff | 指针，返回自定义窗口的左上角纵坐标。
[out] | piWidth | 指针，返回自定义窗口的宽度。
[out] | piHeight | 指针，返回自定义窗口的高度。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraCustomizeResolution | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageCustom
 | ) |  |

打开分辨率自定义面板，并通过可视化的方式来配置一个自定义分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pImageCustom | 指针，返回自定义的分辨率。
返回
状态码


CKCameraAPI: 获取相机设备列表

函数
获取相机设备列表
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraEnumerateDevice (INT *pDeviceNum)
枚举设备，并建立设备列表。在调用CameraInit 之前，必须调用该函数来获得设备的信息。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetEnumIndexInfo (INT CameraIndex, tDevEnumInfo *pDevInfo)
获得指定设备的信息 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDevice ( INT * pDeviceNum )

枚举设备，并建立设备列表。在调用CameraInit 之前，必须调用该函数来获得设备的信息。

参数
[out] pDeviceNum 设备的个数指针，函数返回时，保存实际找到的设备个数。
返回
状态码
注解
通过该函数获得当前查询到的所有设备，返回实际找到的设备个数
CKSDK_API CameraSdkStatus __stdcall CameraGetEnumIndexInfo | ( | INT | CameraIndex,
 |  | tDevEnumInfo * | pDevInfo
 | ) |  |

获得指定设备的信息

参数
[in] | CameraIndex | 相机标号，通过CameraEnumerateDevice获得，选取(0-DeviceNum-1)
[out] | pDevInfo | 指针，返回设备的信息。
返回
状态码
注解
该函数通过 CameraEnumerateDevice 获得设备列表的个数，确定相机 标号，从而查询相应设备信息， 描述信息以结构体的方式返回，比如 相机的名称、型号、序列号、接口类型等都会详细列出。


CKCameraAPI: 相机初始化、反初始化及相机能力级的获取

函数
相机初始化、反初始化及相机能力级的获取
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraInit (PHANDLE phCamera, INT CameraIndex)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口,默认使用上次退出时的参数。注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx (PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx2 (PHANDLE phCamera, const char *pFriendlyName)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx3 (PHANDLE phCamera, const char *pCameraSN)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraUnInit (HANDLE hCamera)
相机反初始化。释放资源。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCapability (HANDLE hCamera, tSdkCameraCapbility *pCameraCap)
获得相机的特性描述结构体。该结构体中包含了相机 可设置的各种参数的范围信息。决定了相关函数的参数 返回，也可用于动态创建相机的配置界面。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurDevInfo (HANDLE hCamera, tDevLoadInfo *pDevInfo)
获得指定设备的枚举信息 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetCapability | ( | HANDLE | hCamera,
 |  | tSdkCameraCapbility * | pCameraCap
 | ) |  |

获得相机的特性描述结构体。该结构体中包含了相机 可设置的各种参数的范围信息。决定了相关函数的参数 返回，也可用于动态创建相机的配置界面。

  • 参数
    [in] | hCamera | 相机的句柄，由CameraInit函数获得
    [out] | pCameraCap | 指针，返回该相机特性描述的结构体。
    返回
    状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetCurDevInfo | ( | HANDLE | hCamera,
 |  | tDevLoadInfo * | pDevInfo
 | ) |  |

获得指定设备的枚举信息

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pDevInfo | 指针，返回设备的枚举信息和状态信息。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraInit | ( | PHANDLE | phCamera,
 |  | INT | CameraIndex
 | ) |  |

相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口,默认使用上次退出时的参数。注意需要先调用CameraEnumerateDevice枚举相机

参数
[out] | phCamera | 相机的句柄指针，初始化成功后，该指针 返回该相机的有效句柄，在调用其他相机 相关的操作接口时，都需要传入该句柄，主要 用于多相机之间的区分。
[in] | CameraIndex | 相机标号，通过CameraEnumerateDevice获得 设备个数，从而设置要打开的相机标号，选取(0-DeviceNum-1)
返回
状态码
参见
CameraEnumerateDevice
注解
CameraInit 只要传入相机的序号即可，例如初始化第 1 个相机，传入 0，第二个相机传入 1，以此类推
CKSDK_API CameraSdkStatus __stdcall CameraInitEx | ( | PHANDLE | phCamera,
 |  | INT | CameraIndex,
 |  | INT | iParamLoadMode,
 |  | INT | emTeam
 | ) |  |

相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。注意需要先调用CameraEnumerateDevice枚举相机

参数
[out] | phCamera | 相机的句柄指针，初始化成功后，该指针 返回该相机的有效句柄，在调用其他相机 相关的操作接口时，都需要传入该句柄，主要用于多相机之间的区分。
[in] | CameraIndex | 相机标号，通过CameraEnumerateDevice获得 设备个数，从而设置要打开的相机标号，选取(0-DeviceNum-1)
[in] | iParamLoadMode | 相机初始化时使用的参数加载方式。-1表示使用上一次退出时的保存的加载方式。 为 emSdkParameterMode::PARAM_MODE_BY_MODEL 表示按型号加载; 为 emSdkParameterMode::PARAM_MODE_BY_SN 表示按序列号加载; 为 emSdkParameterMode::PARAM_MODE_BY_NAME 表示按昵称加载.
[in] | emTeam | 初始化时使用的参数组。-1表示使用上一次退出时保存的参数组,通过iParamLoadMode和emTeam查找需要加载参数的文件 ,若没有找到对应的文件，按默认加载方式加载。
返回
状态码
参见
CameraEnumerateDevice
注解
CameraInitEx 不仅要传入相机的序号 ID ，而且还要传入参数加 载模式和组别，初始化加载相应参数，当iParamLoadMode和emTeam都位-1时，使用上一次退出时保存的参数组,通过iParamLoadMode 和emTeam查找需要加载参数的文件,若没有找到对应的文件，按默认加载方式加载。
CKSDK_API CameraSdkStatus __stdcall CameraInitEx2 | ( | PHANDLE | phCamera,
 |  | const char * | pFriendlyName
 | ) |  |

相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调用CameraEnumerateDevice枚举相机

参数
[in] | phCamera | 相机的句柄指针，初始化成功后，该指针 返回该相机的有效句柄，在调用其他相机 相关的操作接口时，都需要传入该句柄，主要 用于多相机之间的区分。
[in] | pFriendlyName | 相机昵称，用于找到相同昵称的相机，字节长度最大为32个字节
返回
状态码
参见
CameraEnumerateDevice
CameraGetEnumIndexInfo
注解
CameraInitEx2 不需要传入相机的序列 ID，只需要传入相机的名 称 ， 由于出厂时相机的昵称都是一样的，需要事先通过 CameraSetFriendlyName 函数将相机名称改如"MyCamera1"， CameraInitEx2 调用时，传入"MyCamera1"即可，对于多相机同时工作 的案例，这个方法可以有效的建立一一对应的关系，但是要注意，每 个相机的名称必须改成不同的，确保唯一性。
CKSDK_API CameraSdkStatus __stdcall CameraInitEx3 | ( | PHANDLE | phCamera,
 |  | const char * | pCameraSN
 | ) |  |

相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调用CameraEnumerateDevice枚举相机

参数
[out] | phCamera | 相机的句柄指针，初始化成功后，该指针 返回该相机的有效句柄，在调用其他相机 相关的操作接口时，都需要传入该句柄，主要 用于多相机之间的区分。
[in] | pCameraSN | 相机SN码，用于找到SN相同的相机，而且是唯一相机，字节长度最大为32个字节 可以通过调用CameraGetEnumIndexInfo获得相应SN码的信息
返回
状态码
参见
CameraEnumerateDevice
CameraGetEnumIndexInfo
注解
CameraInitEx3 不需要传入相机的序列 ID，只需要传入相机的 SN 码，可以通过调用 CameraGetEnumIndexInfo获取，对于多相机同时工作的案 例，这个方法可以有效的建立一一对应的关系，确保唯一性。
CKSDK_API CameraSdkStatus __stdcall CameraUnInit ( HANDLE hCamera )

相机反初始化。释放资源。

参数
[in] hCamera 相机的句柄，由CameraInit函数获得
返回
状态码
参见
CameraInit
CameraInitEx
CameraInitEx2
CameraInitEx3
注解
无论采用哪种初始化方式，反初始化调用 CameraUnInit 即可。


CKCameraAPI: 获得图像数据

函数
获得图像数据
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraGetRawImageBuffer (HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes)
获得一帧图像原始数据。为了提高效率，SDK在图像抓取时采用了零拷贝机制， CameraGetRawImageBuffer实际获得是内核中的一个缓冲区地址， 该函数成功调用后，必须调用CameraReleaseFrameHandle,以便让内核继续使用 该缓冲区。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraReleaseFrameHandle (HANDLE hCamera, HANDLE hRawBuf)
释放由CameraGetRawImageBuffer获得缓冲区 更多...
CKSDK_API BYTE *__stdcall | CameraGetImageInfo (HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo)
获得当前帧图像信息 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageBuffer (HANDLE hCamera, stImageInfo *pImgInfo, HANDLE hRawBuf, BYTE *pImgBuf)
将获得的相机原始输出图像数据进行处理，叠加饱和度、 颜色增益和校正、降噪等处理效果，处理完后图像的输出格式 可以是 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 的其中一种。 更多...
CKSDK_API BYTE *__stdcall | CameraGetImageBufferEx (HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes)
获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数调用后，该函数返回的图像数据缓冲区。适用于主动方式调用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageBufferEx1 (HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT uTimes)
获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数调用后，会将处理后的图像数据放入提供的缓冲区中，适用于主动方式调用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCallbackFunction (HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld)
设置图像捕获的回调函数。当捕获到新的图像数据帧时，pCallBack所指向的回调函数就会被调用。 更多...

详细描述

函数说明

CKSDK_API BYTE* __stdcall CameraGetImageBufferEx | ( | HANDLE | hCamera,
 |  | stImageInfo * | pImgInfo,
 |  | UINT | uTimes
 | ) |  |

获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数调用后，该函数返回的图像数据缓冲区。适用于主动方式调用。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pImgInfo | 结构体，返回帧头信息
[in] | uTimes | 抓取图像的超时时间。单位毫秒。在 wTimes时间内还未获得图像，则该函数会返回超时信息。
返回
成功时，返回 RGB 数据缓冲区的首地址; 否则返回 NULL。
警告
区别于 CameraGetRawImageBuffer 函数，该函数得到的就是按 输出格式输出图像数据。后续不需要再调用 CameraGetOutImageBuffer函数。
CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx1 | ( | HANDLE | hCamera,
 |  | BYTE * | pImageData,
 |  | stImageInfo * | pImgInfo,
 |  | UINT | uTimes
 | ) |  |

获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数调用后，会将处理后的图像数据放入提供的缓冲区中，适用于主动方式调用。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pImageData | 图像数据缓冲区指针
[out] | pImgInfo | 结构体，返回帧头信息
[in] | uTimes | 抓取图像的超时时间。单位毫秒。在 wTimes时间内还未获得图像，则该函数 会返回超时信息。
返回
状态码
CKSDK_API BYTE* __stdcall CameraGetImageInfo | ( | HANDLE | hCamera,
 |  | HANDLE | hRawBuf,
 |  | stImageInfo * | pImgInfo
 | ) |  |

获得当前帧图像信息

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | hRawBuf | 通过CameraGetRawImageBuffer获得图像的数据的缓冲区句柄。
[in] | pImgInfo | 获得帧信息
返回
状态码
参见
CameraGetRawImageBuffer
CameraReleaseFrameHandle
注解
通过调用 CameraGetRawImageBuffer 获得一帧图像句柄，通过该句 柄获得图像数据缓冲区地址，以及帧头信息。 初始化完成之后，就可以开始相机取图工作。 按照取图方式， SDK 分为主动和被动（回调函数）两种。
  1. 主动取图方式 在完成相机初始化后工作，可以使用 CameraGetRawImageBuffer 函 数和 CameraGetImageInfo 函数主动读取图像，二者的区别是， CameraGetRawImageBuffer 函数得到的是原始的 RAW 数据缓冲区， 需要使用 CameraGetOutImageBuffer函数将 RAW 数据转换为指定的 数据格式，在使用完得到的缓冲区指针后，要调用 CameraReleaseFrameHandle 释放缓冲区使用权，需要解释的是 CameraReleaseFrameHandle 只是释放由 CameraGetRawImageBuffer 得到的数据缓冲区的使用权，并不会反复申请和释放内存，无需担心 效率问题；具体的格式由输入的参数决定，可以是 8 位灰度，也可 以是 24 位、 32 位彩色格式数据。
  2. 被动读取方式（回调函数） 如果需要使用回调函数进行读图处理，则需要在相机初始化以后设置 好读图的回调函数。
CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageBuffer | ( | HANDLE | hCamera,
 |  | stImageInfo * | pImgInfo,
 |  | HANDLE | hRawBuf,
 |  | BYTE * | pImgBuf
 | ) |  |

将获得的相机原始输出图像数据进行处理，叠加饱和度、 颜色增益和校正、降噪等处理效果，处理完后图像的输出格式 可以是 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 的其中一种。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pImgInfo | 输入图像的帧头信息，处理完成后，帧头信息 中的图像格式uiMediaType会随之改变。
[in] | hRawBuf | 输入图像数据的缓冲区地址，不能为NULL。
[out] | pImgBuf | 处理后图像输出的缓冲区地址，不能为NULL。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetRawImageBuffer | ( | HANDLE | hCamera,
 |  | PHANDLE | phRawBuf,
 |  | UINT | uTimes
 | ) |  |

获得一帧图像原始数据。为了提高效率，SDK在图像抓取时采用了零拷贝机制， CameraGetRawImageBuffer实际获得是内核中的一个缓冲区地址， 该函数成功调用后，必须调用CameraReleaseFrameHandle,以便让内核继续使用 该缓冲区。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | phRawBuf | 获得图像的数据的句柄。
[in] | uTimes | 抓取图像的超时时间。单位毫秒。在mTimes时间内还未获得图像，则该函数会返回超时信息。
返回
状态码
参见
CameraReleaseFrameHandle
注解
一般情况下，工业相机传输的都是原始的 RAW 数据，对于黑白相机， 就是灰度图像数据，对于彩色相机，就是 Bayer 格式的图像数据。 CameraGetRawImageBuffer 函数，得到的就是原始的 RAW 数据，默认是 8bit 。 该函数可以设置超时时间，例如设置 1000 毫秒的超时时间，则在 1000 毫秒内，如果没有获取到有效图像，则该函数会阻塞，线程会 被挂起，直到超过 1000 毫秒或者读到了有效图像，所以在软件结构 的设计上，用户可以创建一个专门采集图像的线程，然后一直进行图 像采集，只需要设定一个合理的超时时间即可，或者在需要采集图像 的时候调用一次函数，获取一张图像。
警告
CameraGetRawImageBuffer 需要和 CameraReleaseFrameHandle配套使用。
CKSDK_API CameraSdkStatus __stdcall CameraReleaseFrameHandle | ( | HANDLE | hCamera,
 |  | HANDLE | hRawBuf
 | ) |  |

释放由CameraGetRawImageBuffer获得缓冲区

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | hRawBuf | 通过CameraGetRawImageBuffer指向图像的数据的缓冲区句柄。
返回
状态码
成功时，返回帧数据的缓冲区地址
参见
CameraGetRawImageBuffer
CameraGetImageInfo
CKSDK_API CameraSdkStatus __stdcall CameraSetCallbackFunction | ( | HANDLE | hCamera,
 |  | CAMERA_SNAP_PROC | pCallBack,
 |  | LPVOID | lpParam,
 |  | CAMERA_SNAP_PROC * | pCallbackOld
 | ) |  |

设置图像捕获的回调函数。当捕获到新的图像数据帧时，pCallBack所指向的回调函数就会被调用。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pCallBack | 回调函数指针。
[in] | lpParam | 回调函数的附加参数，在回调函数被调用时 该附加参数会被传入，可以为NULL。多用于 多个相机时携带附加信息。
[out] | pCallbackOld | 用于保存当前的回调函数。可以为NULL。
返回
状态码


CKCameraAPI: 相机的播放与暂停

函数
相机的播放与暂停
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraPause (HANDLE hCamera)
让SDK进入暂停模式，不接收来自相机的图像数据， 同时也会发送命令让相机暂停输出，释放传输带宽。 暂停模式下，可以对相机的参数进行配置，并立即生效。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraPlay (HANDLE hCamera)
让SDK进入工作模式，开始接收来自相机发送的图像 数据。如果当前相机是触发模式，则需要接收到 触发帧以后才会更新图像。 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraPause ( HANDLE hCamera )

让SDK进入暂停模式，不接收来自相机的图像数据， 同时也会发送命令让相机暂停输出，释放传输带宽。 暂停模式下，可以对相机的参数进行配置，并立即生效。

参数
[in] hCamera 相机的句柄，由CameraInit函数获得
返回
状态码
参见
CameraPlay
CKSDK_API CameraSdkStatus __stdcall CameraPlay ( HANDLE hCamera )

让SDK进入工作模式，开始接收来自相机发送的图像 数据。如果当前相机是触发模式，则需要接收到 触发帧以后才会更新图像。

参数
[in] hCamera 相机的句柄，由CameraInit函数获得
返回
状态码
参见
CameraPause


CKCameraAPI: 显示预览图像

函数
显示预览图像
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraDisplayInit (HANDLE hCamera, HWND hWndDisplay)
初始化SDK内部的显示模块。在调用CameraDisplay 前必须先调用该函数初始化。如果您在二次开发中， 使用自己的方式进行图像显示(不调用CameraDisplay)， 则不需要调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayMode (HANDLE hCamera, INT iMode)
设置显示的模式。必须调用过CameraDisplayInit 进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayScaleRadio (HANDLE hCamera, INT iRadio)
设置显示的缩放比率。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如100 是显示窗口和图像窗口为1:1,200是显示窗口和图像窗口为2:1 50是显示窗口和图像窗口为0.5:1，故该值为倍率X100，必须调用过 CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayOffset (HANDLE hCamera, INT iOffsetX, INT iOffsetY)
设置显示的起始偏移值。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如显示控件的大小为320X240，而图像的 的尺寸为640X480，那么当iOffsetX = 160,iOffsetY = 120时 显示的区域就是图像的居中320X240的位置。必须调用过 CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplaySize (HANDLE hCamera, INT iWidth, INT iHeight)
设置显示控件的尺寸。必须调用过 CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCrossLine (HANDLE hCamera, INT iLine, INT x, INT y, UINT uColor, BOOL bVisible)
设置指定十字线的参数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCrossLine (HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible)
获得指定十字线的状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraImageOverlay (HANDLE hCamera, BYTE *pImgBuf, const stImageInfo *pImgInfo)
将输入的图像数据上叠加十字线、白平衡参考窗口、 自动曝光参考窗口等图形。只有设置为可见状态的 十字线和参考窗口才能被叠加上。 注意，该函数的输入图像必须是RGB格式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraDrawText (BYTE *pImgBuf, const stImageInfo *pImgInfo, char const *pFontFileName, UINT FontWidth, UINT FontHeight, char const *pText, INT Left, INT Top, UINT Width, UINT Height, UINT TextColor, UINT uFlags)
在输入的图像数据中绘制文字 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraDisplay (HANDLE hCamera, BYTE *pImgBuf, stImageInfo *pImgInfo)
显示图像。必须调用过CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayCallbackFun (HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld)
设置显示回调。必须调用过CameraDisplayInit进行 初始化才能调用本函数，同时当显示图像数据帧时， pCallBack所指向的回调函数就会被调用。 更多...

详细描述

为了简化用户二次开发的流程， SDK 内部封装了一些接口函数可以方 便可以进行图像预览，前提是必须使用 VS 相关的工具进行界面开 发。在相机初始化后，调用如下代码完成显示部分的初始化工作。 CameraDisplayInit 传入窗口的 hWnd 句柄。 不同的开发工具，有 不同的方式获得显示控件的 hWnd 句柄。

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraDisplay | ( | HANDLE | hCamera,
 |  | BYTE * | pImgBuf,
 |  | stImageInfo * | pImgInfo
 | ) |  |

显示图像。必须调用过CameraDisplayInit进行初始化才能调用本函数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pImgBuf | 图像的数据缓冲区。
[in] | pImgInfo | 图像的帧头信息。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraDisplayInit | ( | HANDLE | hCamera,
 |  | HWND | hWndDisplay
 | ) |  |

初始化SDK内部的显示模块。在调用CameraDisplay 前必须先调用该函数初始化。如果您在二次开发中， 使用自己的方式进行图像显示(不调用CameraDisplay)， 则不需要调用本函数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | hWndDisplay | 显示窗口的句柄，一般为窗口的m_hWnd成员。
返回
状态码
参见
CameraDisplay
警告
在调用 CameraDisplay 前必须先调用该函数初始化。如果 您在二次开发中，使用自己的方式进行图像显示(不调用CameraDisplay)，则不需要调用 CameraDisplayInit 函数 。
CKSDK_API CameraSdkStatus __stdcall CameraDrawText | ( | BYTE * | pImgBuf,
 |  | const stImageInfo * | pImgInfo,
 |  | char const * | pFontFileName,
 |  | UINT | FontWidth,
 |  | UINT | FontHeight,
 |  | char const * | pText,
 |  | INT | Left,
 |  | INT | Top,
 |  | UINT | Width,
 |  | UINT | Height,
 |  | UINT | TextColor,
 |  | UINT | uFlags
 | ) |  |

在输入的图像数据中绘制文字

参数
[in] | pImgBuf | 图像数据缓冲区
[in] | pImgInfo | 图像的帧头信息
[in] | pFontFileName | 字体文件名
[in] | FontWidth | 字体宽度
[in] | FontHeight | 字体高度
[in] | pText | 要输出的文字
[in] | Left | 文件输出矩形的左坐标
[in] | Top | 文件输出矩形的上坐标
[in] | Width | 文件输出矩形的宽度
[in] | Height | 文件输出矩形的高度
[in] | TextColor | 文字颜色RGB
[in] | uFlags | 输出标志, 暂时未使用，填0即可
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetCrossLine | ( | HANDLE | hCamera,
 |  | INT | iLine,
 |  | INT * | px,
 |  | INT * | py,
 |  | UINT * | puColor,
 |  | BOOL * | pbVisible
 | ) |  |

获得指定十字线的状态。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iLine | 表示要获取的第几条十字线的状态。范围为[0,8]，共9条。
[out] | px | 指针，返回该十字线中心位置的横坐标。
[out] | py | 指针，返回该十字线中心位置的横坐标。
[out] | puColor | 指针，返回该十字线的颜色，格式为(R|(G<<8)|(B<<16))。
[out] | pbVisible | 指针，返回TRUE，则表示该十字线可见。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraImageOverlay | ( | HANDLE | hCamera,
 |  | BYTE * | pImgBuf,
 |  | const stImageInfo * | pImgInfo
 | ) |  |

将输入的图像数据上叠加十字线、白平衡参考窗口、 自动曝光参考窗口等图形。只有设置为可见状态的 十字线和参考窗口才能被叠加上。 注意，该函数的输入图像必须是RGB格式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pImgBuf | 图像数据缓冲区。
[in] | pImgInfo | 图像的帧头信息。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetCrossLine | ( | HANDLE | hCamera,
 |  | INT | iLine,
 |  | INT | x,
 |  | INT | y,
 |  | UINT | uColor,
 |  | BOOL | bVisible
 | ) |  |

设置指定十字线的参数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iLine | 表示要设置第几条十字线的状态。范围为[0,8]，共9条。
[in] | x | 十字线中心位置的横坐标值。
[in] | y | 十字线中心位置的纵坐标值。
[in] | uColor | 十字线的颜色，格式为(R|(G<<8)|(B<<16))
[in] | bVisible | 十字线的显示状态。TRUE，表示显示。只有设置为显示状态的十字线，在调用 CameraImageOverlay后才会被叠加到图像上。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayCallbackFun | ( | HANDLE | hCamera,
 |  | CAMERA_DISPLAY_PROC | pCallBack,
 |  | LPVOID | lpParam,
 |  | CAMERA_DISPLAY_PROC * | pCallbackOld
 | ) |  |

设置显示回调。必须调用过CameraDisplayInit进行 初始化才能调用本函数，同时当显示图像数据帧时， pCallBack所指向的回调函数就会被调用。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pCallBack | 回调函数指针。
[in] | lpParam | 回调函数的附加参数，在回调函数被调用时 该附加参数会被传入，可以为NULL。
[out] | pCallbackOld | 用于保存当前的回调函数。可以为NULL。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayMode | ( | HANDLE | hCamera,
 |  | INT | iMode
 | ) |  |

设置显示的模式。必须调用过CameraDisplayInit 进行初始化才能调用本函数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iMode | 显示模式，emSdkDisplayMode::DISPLAYMODE_SCALE或者emSdkDisplayMode::DISPLAYMODE_REAL, 具体参见CKDeviceDef.h中emSdkDisplayMode的定义。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayOffset | ( | HANDLE | hCamera,
 |  | INT | iOffsetX,
 |  | INT | iOffsetY
 | ) |  |

设置显示的起始偏移值。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如显示控件的大小为320X240，而图像的 的尺寸为640X480，那么当iOffsetX = 160,iOffsetY = 120时 显示的区域就是图像的居中320X240的位置。必须调用过 CameraDisplayInit进行初始化才能调用本函数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iOffsetX | 偏移的X坐标。
[in] | iOffsetY | 偏移的Y坐标。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayScaleRadio | ( | HANDLE | hCamera,
 |  | INT | iRadio
 | ) |  |

设置显示的缩放比率。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如100 是显示窗口和图像窗口为1:1,200是显示窗口和图像窗口为2:1 50是显示窗口和图像窗口为0.5:1，故该值为倍率X100，必须调用过 CameraDisplayInit进行初始化才能调用本函数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iRadio | 缩放比率。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplaySize | ( | HANDLE | hCamera,
 |  | INT | iWidth,
 |  | INT | iHeight
 | ) |  |

设置显示控件的尺寸。必须调用过 CameraDisplayInit进行初始化才能调用本函数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iWidth | 宽度
[in] | iHeight | 高度
返回
状态码


CKCameraAPI: 抓拍图片

函数
抓拍图片
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSnapToBuffer (HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE **ppImgBuf, UINT uWaitTimeMs)
抓拍一张图像到缓冲区中。相机会进入抓拍模式，并且 自动切换到抓拍模式的分辨率进行图像捕获。然后将 捕获到的数据保存到缓冲区中。 该函数成功调用后，必须调用CameraReleaseFrameHandle 释放由CameraSnapToBuffer得到的缓冲区。具体请参考 CameraGetRawImageBuffer函数的功能描述部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
设置抓拍模式下相机输出图像的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
获得抓拍模式下的分辨率。 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionForSnap | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

获得抓拍模式下的分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pImageResolution | 指针，返回抓拍模式的分辨率。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionForSnap | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

设置抓拍模式下相机输出图像的分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pImageResolution | 如果pImageResolution->iWidth 和 pImageResolution->iHeight都为0， 则表示设定为跟随当前预览分辨率。抓 怕到的图像的分辨率会和当前设定的 预览分辨率一样。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSnapToBuffer | ( | HANDLE | hCamera,
 |  | PHANDLE | phBuf,
 |  | stImageInfo * | pImgInfo,
 |  | BYTE ** | ppImgBuf,
 |  | UINT | uWaitTimeMs
 | ) |  |

抓拍一张图像到缓冲区中。相机会进入抓拍模式，并且 自动切换到抓拍模式的分辨率进行图像捕获。然后将 捕获到的数据保存到缓冲区中。 该函数成功调用后，必须调用CameraReleaseFrameHandle 释放由CameraSnapToBuffer得到的缓冲区。具体请参考 CameraGetRawImageBuffer函数的功能描述部分。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | phBuf | 指针，返回图像的数据的缓冲区句柄。用于释放数据，CameraReleaseFrameHandle
[out] | pImgInfo | 指针，返回图像的帧头信息
[out] | ppImgBuf | 指针，返回图像的数据指针
[in] | uWaitTimeMs | 超时时间，单位毫秒。在该时间内，如果仍然没有成功捕获的数据，则返回超时信息。
返回
状态码


CKCameraAPI: 曝光设置

函数
曝光设置
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSetAeState (HANDLE hCamera, BOOL bAeState)
设置相机曝光的模式。自动或者手动。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeState (HANDLE hCamera, BOOL *pAeState)
获得相机当前的曝光模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeTarget (HANDLE hCamera, WORD AeTarget)
设定自动曝光的亮度目标值。设定范围由CameraGetCapability函数获得。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeTarget (HANDLE hCamera, WORD *pAeTarget)
获得自动曝光的亮度目标值。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAnalogGain (HANDLE hCamera, UINT uAnalogGain)
设置相机的图像模拟增益值。该值乘以CameraGetCapability获得 的相机属性结构体中sExposeDesc.fAnalogGainStep，就 得到实际的图像信号放大倍数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAnalogGain (HANDLE hCamera, UINT *puAnalogGain)
获得图像信号的模拟增益值。参见CameraSetAnalogGain详细说明。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetExposureTime (HANDLE hCamera, double dExposureTime)
设置曝光时间。单位为微秒。对于CMOS传感器，其曝光 的单位是按照行来计算的，因此，曝光时间并不能在微秒 级别连续可调。而是会按照整行来取舍。在调用 本函数设定曝光时间后，建议再调用CameraGetExposureTime 来获得实际设定的值。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureTime (HANDLE hCamera, double *pdExposureTime)
获得相机的曝光时间。请参见CameraSetExposureTime 的功能描述。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
设置自动曝光的参考窗口。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
获得自动曝光参考窗口的位置。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWinVisible (HANDLE hCamera, BOOL bDisplayEn)
设置自动曝光参考窗口的显示状态。当设置窗口状态 为显示，调用CameraImageOverlay后，能够将窗口位置 以矩形的方式叠加在图像上。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWinVisible (HANDLE hCamera, BOOL *pbDisplayEn)
获得自动曝光参考窗口的显示状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAntiFlick (HANDLE hCamera, BOOL bEnable)
设置自动曝光时抗频闪功能的使能状态。对于手动 曝光模式下无效。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAntiFlick (HANDLE hCamera, BOOL *pbEnable)
获得自动曝光时抗频闪功能的使能状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetLightFrequency (HANDLE hCamera, INT iFrequencySel)
设置自动曝光时消频闪的频率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLightFrequency (HANDLE hCamera, INT *piFrequencySel)
获得自动曝光时，消频闪的频率选择。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureLineTime (HANDLE hCamera, double *pExposureLineTime)
获得一行曝光的时间，单位：微妙。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureMode (HANDLE hCamera, INT iMode)
设定自动曝光模式下的曝光模式 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureMode (HANDLE hCamera, INT *piMode)
获得自动曝光模式下的曝光模式 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureRange (HANDLE hCamera, double dMinExposureTime, double dMaxExposureTime)
设定自动曝光模式的曝光时间调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureRange (HANDLE hCamera, double *pdMinExposureTime, double *pdMaxExposureTime)
获得自动曝光模式的曝光时间调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeAnalogGainRange (HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain)
设定自动曝光模式的增益调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeAnalogGainRange (HANDLE hCamera, INT *iMinAnalogGain, INT *iMaxAnalogGain)
获得自动曝光模式的增益调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGain (HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB)
设置图像的数字增益。设定范围由CameraGetCapability 获得的相机属性结构体中sRgbGainRange成员表述。 实际的放大倍数是设定值/100。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGain (HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB)
获得图像处理的数字增益。具体请参见CameraSetGain 的功能描述部分。 更多...

详细描述

相机出厂时，为了方便演示效果，默认是自动曝光，也就是说，相机 会根据环境光的亮度，自动调节相机的曝光时间和模拟增益值来获取 最佳的图像亮度。但是这种自动调节模式，并不适合工业应用，因此 需要调用一些函数，来手动设置曝光和增益，来稳定图像亮度，用以 适合软件算法的需求，例如一些情况，用户可能希望图像大部分区域 过曝光以减少图像干扰。

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetAeAnalogGainRange | ( | HANDLE | hCamera,
 |  | INT * | iMinAnalogGain,
 |  | INT * | iMaxAnalogGain
 | ) |  |

获得自动曝光模式的增益调节范围

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | iMinAnalogGain | 最小增益
[out] | iMaxAnalogGain | 最大增益
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureMode | ( | HANDLE | hCamera,
 |  | INT * | piMode
 | ) |  |

获得自动曝光模式下的曝光模式

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piMode | 指针，获得自动曝光模式，AE_FRAME_MODE帧率优先，AE_EXP_MODE曝光优先
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureRange | ( | HANDLE | hCamera,
 |  | double * | pdMinExposureTime,
 |  | double * | pdMaxExposureTime
 | ) |  |

获得自动曝光模式的曝光时间调节范围

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pdMinExposureTime | 最小曝光时间（微秒）
[out] | pdMaxExposureTime | 最大曝光时间（微秒）
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAeState | ( | HANDLE | hCamera,
 |  | BOOL * | pAeState
 | ) |  |

获得相机当前的曝光模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pAeState | 指针，用于返回自动曝光的使能状态。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAeTarget | ( | HANDLE | hCamera,
 |  | WORD * | pAeTarget
 | ) |  |

获得自动曝光的亮度目标值。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pAeTarget | 指针，返回目标值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAeWindow | ( | HANDLE | hCamera,
 |  | DWORD * | pdwLeft,
 |  | DWORD * | pdwTop,
 |  | DWORD * | pdwWidth,
 |  | DWORD * | pdwHeight
 | ) |  |

获得自动曝光参考窗口的位置。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pdwLeft | 指针，返回参考窗口的左上角横坐标 。
[out] | pdwTop | 指针，返回参考窗口的左上角纵坐标 。
[out] | pdwWidth | 指针，返回参考窗口的宽度。
[out] | pdwHeight | 指针，返回参考窗口的高度。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAeWinVisible | ( | HANDLE | hCamera,
 |  | BOOL * | pbDisplayEn
 | ) |  |

获得自动曝光参考窗口的显示状态。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pbDisplayEn | 指针，返回TRUE，则表示当前窗口会被叠加在图像内容上。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAnalogGain | ( | HANDLE | hCamera,
 |  | UINT * | puAnalogGain
 | ) |  |

获得图像信号的模拟增益值。参见CameraSetAnalogGain详细说明。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | puAnalogGain | 指针，返回当前的模拟增益值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetAntiFlick | ( | HANDLE | hCamera,
 |  | BOOL * | pbEnable
 | ) |  |

获得自动曝光时抗频闪功能的使能状态。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pbEnable | 指针，返回该功能的使能状态。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetExposureLineTime | ( | HANDLE | hCamera,
 |  | double * | pExposureLineTime
 | ) |  |

获得一行曝光的时间，单位：微妙。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pExposureLineTime | 指针，返回一行曝光时间，单位：微妙。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetExposureTime | ( | HANDLE | hCamera,
 |  | double * | pdExposureTime
 | ) |  |

获得相机的曝光时间。请参见CameraSetExposureTime 的功能描述。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pdExposureTime | 指针，返回当前的曝光时间，单位微秒。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetGain | ( | HANDLE | hCamera,
 |  | WORD * | pDGainR,
 |  | WORD * | pDGainG,
 |  | WORD * | pDGainB
 | ) |  |

获得图像处理的数字增益。具体请参见CameraSetGain 的功能描述部分。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pDGainR | 指针，返回红色通道的数字增益值。
[out] | pDGainG | 指针，返回绿色通道的数字增益值。
[out] | pDGainB | 指针，返回蓝色通道的数字增益值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetLightFrequency | ( | HANDLE | hCamera,
 |  | INT * | piFrequencySel
 | ) |  |

获得自动曝光时，消频闪的频率选择。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piFrequencySel | 指针，返回选择的索引号。1:50HZ 2:60HZ
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAeAnalogGainRange | ( | HANDLE | hCamera,
 |  | INT | iMinAnalogGain,
 |  | INT | iMaxAnalogGain
 | ) |  |

设定自动曝光模式的增益调节范围

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iMinAnalogGain | 最小增益
[in] | iMaxAnalogGain | 最大增益
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureMode | ( | HANDLE | hCamera,
 |  | INT | iMode
 | ) |  |

设定自动曝光模式下的曝光模式

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iMode | 自动曝光模式，AE_FRAME_MODE帧率优先，AE_EXP_MODE曝光优先
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureRange | ( | HANDLE | hCamera,
 |  | double | dMinExposureTime,
 |  | double | dMaxExposureTime
 | ) |  |

设定自动曝光模式的曝光时间调节范围

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | dMinExposureTime | 最小曝光时间（微秒）
[in] | dMaxExposureTime | 最大曝光时间（微秒）
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAeState | ( | HANDLE | hCamera,
 |  | BOOL | bAeState
 | ) |  |

设置相机曝光的模式。自动或者手动。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | bAeState | TRUE，使能自动曝光；FALSE，停止自动曝光。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAeTarget | ( | HANDLE | hCamera,
 |  | WORD | AeTarget
 | ) |  |

设定自动曝光的亮度目标值。设定范围由CameraGetCapability函数获得。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | AeTarget | 亮度目标值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAeWindow | ( | HANDLE | hCamera,
 |  | DWORD | dwLeft,
 |  | DWORD | dwTop,
 |  | DWORD | dwWidth,
 |  | DWORD | dwHeight
 | ) |  |

设置自动曝光的参考窗口。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | dwLeft | 窗口左上角的横坐标
[in] | dwTop | 窗口左上角的纵坐标
[in] | dwWidth | 窗口的宽度
[in] | dwHeight | 窗口的高度
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAeWinVisible | ( | HANDLE | hCamera,
 |  | BOOL | bDisplayEn
 | ) |  |

设置自动曝光参考窗口的显示状态。当设置窗口状态 为显示，调用CameraImageOverlay后，能够将窗口位置 以矩形的方式叠加在图像上。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | bDisplayEn | TRUE，设置为显示；FALSE，不显示。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetAnalogGain | ( | HANDLE | hCamera,
 |  | UINT | uAnalogGain
 | ) |  |

设置相机的图像模拟增益值。该值乘以CameraGetCapability获得 的相机属性结构体中sExposeDesc.fAnalogGainStep，就 得到实际的图像信号放大倍数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | uAnalogGain | 设定的模拟增益值。
返回
状态码
注解
设置相机的模拟增益值，这个值的大小只会影响图像亮度，不会影响 图像帧率，因为只是一个电路放大系数，不过该值增大后会提升图像 背景噪声，对于追求画质的应用场合，模拟增益应该设置到最小。
警告
该函数必须在手动模式下才可以生效。
CKSDK_API CameraSdkStatus __stdcall CameraSetAntiFlick | ( | HANDLE | hCamera,
 |  | BOOL | bEnable
 | ) |  |

设置自动曝光时抗频闪功能的使能状态。对于手动 曝光模式下无效。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | bEnable | TRUE，开启抗频闪功能;FALSE，关闭该功能。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetExposureTime | ( | HANDLE | hCamera,
 |  | double | dExposureTime
 | ) |  |

设置曝光时间。单位为微秒。对于CMOS传感器，其曝光 的单位是按照行来计算的，因此，曝光时间并不能在微秒 级别连续可调。而是会按照整行来取舍。在调用 本函数设定曝光时间后，建议再调用CameraGetExposureTime 来获得实际设定的值。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | dExposureTime | 曝光时间，单位微秒。
返回
状态码
注解
该函数设置相机的曝光时间，单位为微秒。曝光时间越大，相机的帧 率越低，例如曝光时间设置到 500 毫秒，则一秒相机最多成像 2 次， 图像看上去就会比较卡顿。因此为了减少取图时间，曝先时间应该是 要越低越好，当然，曝先时间低，就需要外部光源加大光照，否则图 像就会很暗。
警告
该函数必须在手动模式下才可以生效。
CKSDK_API CameraSdkStatus __stdcall CameraSetGain | ( | HANDLE | hCamera,
 |  | WORD | DGainR,
 |  | WORD | DGainG,
 |  | WORD | DGainB
 | ) |  |

设置图像的数字增益。设定范围由CameraGetCapability 获得的相机属性结构体中sRgbGainRange成员表述。 实际的放大倍数是设定值/100。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | DGainR | 红色通道的增益值。
[in] | DGainG | 绿色通道的增益值。
[in] | DGainB | 蓝色通道的增益值。
返回
状态码
注解
该函数设置 R、 G、 B 三个颜色通道的增益值。
警告
该函数必须在手动模式下才可以生效。
CKSDK_API CameraSdkStatus __stdcall CameraSetLightFrequency | ( | HANDLE | hCamera,
 |  | INT | iFrequencySel
 | ) |  |

设置自动曝光时消频闪的频率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iFrequencySel | 1:50HZ , 2:60HZ
返回
状态码


CKCameraAPI: 白平衡设置

函数
白平衡设置
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSetWbMode (HANDLE hCamera, BOOL bAuto)
设置相机白平衡模式。分为手动和自动两种方式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbMode (HANDLE hCamera, BOOL *pbAuto)
获得当前的白平衡模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOnceWB (HANDLE hCamera)
在手动白平衡模式下，调用该函数会进行一次白平衡。 生效的时间为接收到下一帧图像数据时。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
设置白平衡参考窗口的位置。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
获得白平衡参考窗口的位置。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWinVisible (HANDLE hCamera, BOOL bDisplayEn)
设置白平衡参考窗口显示使能。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWinVisible (HANDLE hCamera, BOOL *pDisplayEn)
获得白平衡参考窗口显示使能状态。 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetWbMode | ( | HANDLE | hCamera,
 |  | BOOL * | pbAuto
 | ) |  |

获得当前的白平衡模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pbAuto | 指针，返回TRUE表示自动模式，FALSE 为手动模式。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetWbWindow | ( | HANDLE | hCamera,
 |  | DWORD * | pdwLeft,
 |  | DWORD * | pdwTop,
 |  | DWORD * | pdwWidth,
 |  | DWORD * | pdwHeight
 | ) |  |

获得白平衡参考窗口的位置。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pdwLeft | 指针，返回参考窗口的左上角横坐标 。
[out] | pdwTop | 指针，返回参考窗口的左上角纵坐标 。
[out] | pdwWidth | 指针，返回参考窗口的宽度。
[out] | pdwHeight | 指针，返回参考窗口的高度。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetWbWinVisible | ( | HANDLE | hCamera,
 |  | BOOL * | pDisplayEn
 | ) |  |

获得白平衡参考窗口显示使能状态。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pDisplayEn | 指针，白平衡参考窗口显示使能状态 0：不显示；1：显示。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetOnceWB ( HANDLE hCamera )

在手动白平衡模式下，调用该函数会进行一次白平衡。 生效的时间为接收到下一帧图像数据时。

参数
[in] hCamera 相机的句柄，由CameraInit函数获得
返回
状态码
警告
该函数必须在手动模式下才可以生效。
CKSDK_API CameraSdkStatus __stdcall CameraSetWbMode | ( | HANDLE | hCamera,
 |  | BOOL | bAuto
 | ) |  |

设置相机白平衡模式。分为手动和自动两种方式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | bAuto | TRUE，则表示使能自动模式。FALSE，则表示使用手动模式，通过调用 CameraSetOnceWB来进行一次白平衡。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetWbWindow | ( | HANDLE | hCamera,
 |  | DWORD | dwLeft,
 |  | DWORD | dwTop,
 |  | DWORD | dwWidth,
 |  | DWORD | dwHeight
 | ) |  |

设置白平衡参考窗口的位置。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | dwLeft | 参考窗口的左上角横坐标。
[in] | dwTop | 参考窗口的左上角纵坐标。
[in] | dwWidth | 参考窗口的宽度。
[in] | dwHeight | 参考窗口的高度。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetWbWinVisible | ( | HANDLE | hCamera,
 |  | BOOL | bDisplayEn
 | ) |  |

设置白平衡参考窗口显示使能。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | bDisplayEn | 显示使能 0：不显示；1：显示
返回
状态码


CKCameraAPI: GAMMA设置

函数
GAMMA设置
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSetLutMode (HANDLE hCamera, INT emLutMode)
设置相机的查表变换模式LUT模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutMode (HANDLE hCamera, INT *pemLutMode)
获得相机的查表变换模式LUT模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGamma (HANDLE hCamera, int iGamma)
设定LUT动态生成模式下的Gamma值。设定的值会 马上保存在SDK内部，但是只有当相机处于动态 参数生成的LUT模式时，才会生效。请参考CameraSetLutMode 的函数说明部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGamma (HANDLE hCamera, int *piGamma)
获得LUT动态生成模式下的Gamma值。请参考CameraSetGamma 函数的功能描述。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrastLut (HANDLE hCamera, int iContrast)
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrastLut (HANDLE hCamera, int *piContrast)
CKSDK_API CameraSdkStatus __stdcall | CameraSelectLutPreset (HANDLE hCamera, INT iSel)
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutPresetSel (HANDLE hCamera, INT *piSel)
获得预设LUT模式下的LUT表索引号。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCustomLut (HANDLE hCamera, int iChannel, USHORT *pLut)
设置自定义的LUT表。必须先使用CameraSetLutMode 将LUT模式设置为自定义模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCustomLut (HANDLE hCamera, int iChannel, USHORT *pLut)
获得当前使用的自定义LUT表。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentLut (HANDLE hCamera, int iChannel, USHORT *pLut)

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetContrastLut | ( | HANDLE | hCamera,
 |  | int * | piContrast
 | ) |  |
CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentLut | ( | HANDLE | hCamera,
 |  | int | iChannel,
 |  | USHORT * | pLut
 | ) |  |
CKSDK_API CameraSdkStatus __stdcall CameraGetCustomLut | ( | HANDLE | hCamera,
 |  | int | iChannel,
 |  | USHORT * | pLut
 | ) |  |

获得当前使用的自定义LUT表。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iChannel | 指定要获得的LUT颜色通道。当为LUT_CHANNEL_ALL时， 返回红色通道的LUT表。参考emSdkLutChannel定义。
[out] | pLut | 指针，指向LUT表的地址。LUT表为无符号短整形数组，数组大小为 4096，分别代码颜色通道从0到4096(12bit颜色精度)对应的映射值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetGamma | ( | HANDLE | hCamera,
 |  | int * | piGamma
 | ) |  |

获得LUT动态生成模式下的Gamma值。请参考CameraSetGamma 函数的功能描述。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piGamma | 指针，返回当前的Gamma值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetLutMode | ( | HANDLE | hCamera,
 |  | INT * | pemLutMode
 | ) |  |

获得相机的查表变换模式LUT模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pemLutMode | 指针，返回当前LUT模式。意义与CameraSetLutMode 中emLutMode参数相同。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetLutPresetSel | ( | HANDLE | hCamera,
 |  | INT * | piSel
 | ) |  |

获得预设LUT模式下的LUT表索引号。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piSel | 指针，返回表的索引号。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSelectLutPreset | ( | HANDLE | hCamera,
 |  | INT | iSel
 | ) |  |
CKSDK_API CameraSdkStatus __stdcall CameraSetContrastLut | ( | HANDLE | hCamera,
 |  | int | iContrast
 | ) |  |
CKSDK_API CameraSdkStatus __stdcall CameraSetCustomLut | ( | HANDLE | hCamera,
 |  | int | iChannel,
 |  | USHORT * | pLut
 | ) |  |

设置自定义的LUT表。必须先使用CameraSetLutMode 将LUT模式设置为自定义模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iChannel | 指定要获得的LUT颜色通道。当为LUT_CHANNEL_ALL时， 返回红色通道的LUT表。参考emSdkLutChannel定义。
[in] | pLut | 指针，指向LUT表的地址。LUT表为无符号短整形数组，数组大小为 4096，分别代码颜色通道从0到4096(12bit颜色精度)对应的映射值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetGamma | ( | HANDLE | hCamera,
 |  | int | iGamma
 | ) |  |

设定LUT动态生成模式下的Gamma值。设定的值会 马上保存在SDK内部，但是只有当相机处于动态 参数生成的LUT模式时，才会生效。请参考CameraSetLutMode 的函数说明部分。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iGamma | 要设定的Gamma值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetLutMode | ( | HANDLE | hCamera,
 |  | INT | emLutMode
 | ) |  |

设置相机的查表变换模式LUT模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | emLutMode | LUTMODE_PARAM_GEN 表示由伽马和对比度参数动态生成LUT表。 LUTMODE_PRESET 表示使用预设的LUT表。 LUTMODE_USER_DEF 表示使用用户自定的LUT表。 LUTMODE_PARAM_GEN的定义参考CameraDefine.h中emSdkLutMode类型。
返回
状态码


CKCameraAPI: ISP设置

函数
ISP设置
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSetSharpness (HANDLE hCamera, INT iSharpness)
设置图像的处理的锐化参数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSharpness (HANDLE hCamera, INT *piSharpness)
获取当前锐化设定值。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetSaturation (HANDLE hCamera, INT iSaturation)
设定图像处理的饱和度。对黑白相机无效。 设定范围由CameraGetCapability获得。100表示 表示原始色度，不增强。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSaturation (HANDLE hCamera, INT *piSaturation)
获得图像处理的饱和度。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrast (HANDLE hCamera, INT iContrast)
设定图像处理的对比度 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrast (HANDLE hCamera, INT *piContrast)
获得对比度值。请参考 CameraSetContrast函数的功能描述。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrame (HANDLE hCamera, double *pdFrameTime)
获得当前图像帧时间。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFrameSpeed (HANDLE hCamera, INT iFrameSpeed)
设定相机输出图像的帧率。相机可供选择的帧率模式由 CameraGetCapability获得的信息结构体中iFrameSpeedDesc 表示最大帧率选择模式个数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameSpeed (HANDLE hCamera, INT *piFrameSpeed)
获得相机输出图像的帧率选择索引号。具体用法参考 CameraSetFrameSpeed函数的功能描述部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolution (HANDLE hCamera, INT iResolutionIndex)
设定相机输出图像的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolution (HANDLE hCamera, INT *piResolutionIndex)
获得相机输出图像的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionEx (HANDLE hCamera, tSdkImageResolution *pImageResolution)
设置自定义预览的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionEx (HANDLE hCamera, INT iResolution, tSdkImageResolution *pImageResolution)
获得索引号的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurResolution (HANDLE hCamera, tSdkImageResolution *pImageResolution)
获得当前预览的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageSize (HANDLE hCamera, DWORD *pWidth, DWORD *pHeight)
获得输出图像的大小。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgMode (HANDLE hCamera, INT iAlgMode)
设置Bayer转RGB算法模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgThreshold (HANDLE hCamera, INT iAlgMode)
设置Bayer转RGB算法模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBayerAlgMode (HANDLE hCamera, INT *piAlgMode)
获得Bayer转RGB算法模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetIspOutFormat (HANDLE hCamera, INT iFormat)
设置CameraImageProcess函数的图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 (在CameraDefine.h中定义)5种，分别对应8位灰度图像和24RGB、32位RGB、24位BGR、32位BGR彩色图像。 默认输出是CAMERA_MEDIA_TYPE_BGR8格式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetIspOutFormat (HANDLE hCamera, INT *piFormat)
获得CameraGetOutImageBuffer函数图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 (在CameraDefine.h中定义)5种，分别对应8位灰度图像和24RGB、32位RGB、24位BGR、32位BGR彩色图像。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameStatistic (HANDLE hCamera, FrameStatistic *psFrameStatistic)
获得相机接收帧率的统计信息，包括错误帧和丢帧的情况。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveImage (HANDLE hCamera, const char *lpszFileName, const BYTE *pImgBuf, const stImageInfo *pImgInfo, UINT byFileType, BYTE byQuality)
将图像缓冲区的数据保存成图片文件。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetMirror (HANDLE hCamera, INT iDir, BOOL bEnable)
设置图像镜像操作。镜像操作分为水平和垂直两个方向。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMirror (HANDLE hCamera, INT iDir, BOOL *pbEnable)
获得图像的镜像状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetMonochrome (HANDLE hCamera, BOOL bEnable)
设置彩色转为黑白功能的使能。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMonochrome (HANDLE hCamera, BOOL *pbEnable)
获得彩色转换黑白功能的使能状况。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBlackLevel (HANDLE hCamera, INT iBlackLevel)
设置图像的黑电平基准，默认值为0 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBlackLevel (HANDLE hCamera, INT *piBlackLevel)
获得图像的黑电平基准，默认值为0 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetBayerAlgMode | ( | HANDLE | hCamera,
 |  | INT * | piAlgMode
 | ) |  |

获得Bayer转RGB算法模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piAlgMode | 指针 返回Bayer转RGB算法模式
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetBlackLevel | ( | HANDLE | hCamera,
 |  | INT * | piBlackLevel
 | ) |  |

获得图像的黑电平基准，默认值为0

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piBlackLevel | 返回当前的黑电平值。范围为0到255。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetContrast | ( | HANDLE | hCamera,
 |  | INT * | piContrast
 | ) |  |

获得对比度值。请参考 CameraSetContrast函数的功能描述。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piContrast | 指针，返回当前的对比度值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetCurResolution | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

获得当前预览的分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pImageResolution | 结构体指针，用于返回当前的分辨率。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetFrame | ( | HANDLE | hCamera,
 |  | double * | pdFrameTime
 | ) |  |

获得当前图像帧时间。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pdFrameTime | 指针，返回当前的帧时间，单位微秒。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetFrameSpeed | ( | HANDLE | hCamera,
 |  | INT * | piFrameSpeed
 | ) |  |

获得相机输出图像的帧率选择索引号。具体用法参考 CameraSetFrameSpeed函数的功能描述部分。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piFrameSpeed | 指针，返回选择的帧率模式索引号。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetFrameStatistic | ( | HANDLE | hCamera,
 |  | FrameStatistic * | psFrameStatistic
 | ) |  |

获得相机接收帧率的统计信息，包括错误帧和丢帧的情况。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | psFrameStatistic | 指针，返回统计信息。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetIspOutFormat | ( | HANDLE | hCamera,
 |  | INT * | piFormat
 | ) |  |

获得CameraGetOutImageBuffer函数图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 (在CameraDefine.h中定义)5种，分别对应8位灰度图像和24RGB、32位RGB、24位BGR、32位BGR彩色图像。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piFormat | 返回当前设定的格式。 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetMirror | ( | HANDLE | hCamera,
 |  | INT | iDir,
 |  | BOOL * | pbEnable
 | ) |  |

获得图像的镜像状态。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iDir | 表示要获得的镜像方向。 0，表示水平方向；1，表示垂直方向。
[out] | pbEnable | 指针，返回TRUE，则表示iDir所指的方向 镜像被使能。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetMonochrome | ( | HANDLE | hCamera,
 |  | BOOL * | pbEnable
 | ) |  |

获得彩色转换黑白功能的使能状况。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pbEnable | 指针。返回TRUE表示开启了彩色图像 转换为黑白图像的功能。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageSize | ( | HANDLE | hCamera,
 |  | DWORD * | pWidth,
 |  | DWORD * | pHeight
 | ) |  |

获得输出图像的大小。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pWidth | 指针，用于返回输出图像的宽度。
[out] | pHeight | 指针，用于返回输出图像的高度。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetResolution | ( | HANDLE | hCamera,
 |  | INT * | piResolutionIndex
 | ) |  |

获得相机输出图像的分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piResolutionIndex | 指针，返回选择的帧率模式索引号,请参见emResolutionMode。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionEx | ( | HANDLE | hCamera,
 |  | INT | iResolution,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

获得索引号的分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iResolution | 获得分辨率的索引号，参见 emResolutionMode，自定义为0xff
[out] | pImageResolution | 结构体指针，用于返回当前的分辨率。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetSaturation | ( | HANDLE | hCamera,
 |  | INT * | piSaturation
 | ) |  |

获得图像处理的饱和度。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piSaturation | 指针，返回当前图像处理的饱和度值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetSharpness | ( | HANDLE | hCamera,
 |  | INT * | piSharpness
 | ) |  |

获取当前锐化设定值。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piSharpness | 指针，返回当前设定的锐化的设定值。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSaveImage | ( | HANDLE | hCamera,
 |  | const char * | lpszFileName,
 |  | const BYTE * | pImgBuf,
 |  | const stImageInfo * | pImgInfo,
 |  | UINT | byFileType,
 |  | BYTE | byQuality
 | ) |  |

将图像缓冲区的数据保存成图片文件。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | lpszFileName | 图片保存文件完整路径。
[in] | pImgBuf | 图像的数据缓冲区。
[in] | pImgInfo | 图像的帧头信息。
[in] | byFileType | emFileType。目前支持 BMP、JPG、PNG、RAW四种格式。其中RAW表示 相机输出的原始数据，保存RAW格式文件要求 pImgBuf和pImgInfo是由CameraGetOutImageBuffer 获得的数据，而且未经CameraImageProcess转换 成BMP格式；反之，如果要保存成BMP格式，则pImgBuf和pImgInfo是由 CameraImageProcess处理后的RGB格式数据。
[in] | byQuality | 图像保存的质量因子，仅当保存为JPG格式时该参数有效，范围1到100。其余格式可以写成0。
返回
状态码
注解
图像保存功能。使用 CameraSaveImage，可以将图像保存为 RAW、 BMP、 JPG、 PNG 的其中一种。一个典型的流程为：
  1. 使用 CameraGetRawImageBuffer 函数和 CameraGetImageInfo 函 数取到 RAW 图像数据；
  2. 使用 CameraGetOutImageBuffer 函数将 RAW 转换成 BGR24 或者 8 位灰度格式。如果要保存 RAW 格式数据，返一步跳过。
  3. CameraReleaseFrameHandle释放 CameraGetRawImageBuffer 的 到的 RAW 数据缓冲区的使用权。
  4. CameraSaveImage 函数将 CameraGetOutImageBuffer 函数得到的 图像数据进行保存成BMP。如果是RAW数据保存则使用CameraGetRawImageBuffer 函数和 CameraGetImageInfo 函数得到的 RAW 数据 buffer。
CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgMode | ( | HANDLE | hCamera,
 |  | INT | iAlgMode
 | ) |  |

设置Bayer转RGB算法模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iAlgMode | Bayer转RGB算法模式
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgThreshold | ( | HANDLE | hCamera,
 |  | INT | iAlgMode
 | ) |  |

设置Bayer转RGB算法模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iAlgMode | Bayer转RGB算法模式
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetBlackLevel | ( | HANDLE | hCamera,
 |  | INT | iBlackLevel
 | ) |  |

设置图像的黑电平基准，默认值为0

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iBlackLevel | 要设定的电平值。范围为0到255。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetContrast | ( | HANDLE | hCamera,
 |  | INT | iContrast
 | ) |  |

设定图像处理的对比度

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iContrast | 设定的对比度值。
返回
状态码
注解
该函数设置相机的对比度值，对比度越大，会使图像黑的区域越黑， 白的区域越白，使得图像看起来黑白分明，在一些视觉处理上可以有 效的捕捉轮廓；反之，如果对比度越小，会是黑白不分明，看起来比 较朦胧。对比度默认是 50，最小可以到 1，最大到 100。
CKSDK_API CameraSdkStatus __stdcall CameraSetFrameSpeed | ( | HANDLE | hCamera,
 |  | INT | iFrameSpeed
 | ) |  |

设定相机输出图像的帧率。相机可供选择的帧率模式由 CameraGetCapability获得的信息结构体中iFrameSpeedDesc 表示最大帧率选择模式个数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iFrameSpeed | 选择的帧率模式索引号，范围从0到 CameraGetCapability获得的信息结构体中iFrameSpeedDesc - 1
返回
状态码
注解
通过 CameraSetFrameSpeed 函数，可以动态设置相机的输出帧率。 CameraSetFrameSpeed 是设置速度的档位，我们将其分为高速、中速、 低速等几种模式，对于不同型号的相机，高中低速度模式下对应具体 的帧率是不一样的。 CameraSetFrameSpeed（hCamera,0） ;//讴置为低速模式。 CameraSetFrameSpeed（hCamera,1） ;//讴置为中速模式。 CameraSetFrameSpeed（hCamera,2） ;//讴置为高速模式。 一般相机出厂时，默认就是最高速度的，如果需要降速运行，就可以 调用 CameraSetFrameSpeed 函数迕行降速。 另外，有些型号的相机， 叧支持 2 个速度模式，有些支持 4 个，具体支持模式的数量，可以通 过 CameraGetCapability 函数，得到相机的描述信息 tSdkCameraCapbility 结极体， tSdkCameraCapbility 结极体中的 iFrameSpeedDesc 成员，表明了当前型号的相机支持的速度模式的个 数。
CKSDK_API CameraSdkStatus __stdcall CameraSetIspOutFormat | ( | HANDLE | hCamera,
 |  | INT | iFormat
 | ) |  |

设置CameraImageProcess函数的图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 (在CameraDefine.h中定义)5种，分别对应8位灰度图像和24RGB、32位RGB、24位BGR、32位BGR彩色图像。 默认输出是CAMERA_MEDIA_TYPE_BGR8格式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iFormat | 要设定格式。 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8
返回
状态码
注解
该函数是最终通过 CameraGetOutImageBuffer 函数的得到的图像像 素格式，而并非相机输出的原始 RAW 的像素格式。 在相机初始化以后，通过调用 CameraSetIspOutFormat 来设置了。
  1. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_MONO); 设置后， CameraGetOutImageBuffer 输出的图像就是 8bit 的灰度图 像了， 1 个像素占用 1 个字节，依次排列。
  2. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_RGB8); 设置后， CameraGetOutImageBuffer 输出的图像就是 24bit RBG 的 彩色图像了， 1 个像素占用 3 个字节，依次是红色、 绿色、 蓝色 返样排列。
  3. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_BGR8); 设置后， CameraGetOutImageBuffer 输出的图像就是 24bit BGR 的 彩色图像了， 1 个像素占用 3 个字节，依次是蓝色、 绿色、 红色 排列。
  4. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_RGBA8); 设置后， CameraGetOutImageBuffer 输出的图像就是 32bit RBGA 的 彩色图像了， 1 个像素占用 4 个字节，依次是红色 8bit、 绿色 8bit、 蓝色 8bit、 Alpha8bit 排列。
  5. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_BGRA8); 设置后， CameraGetOutImageBuffer 输出的图像就是 32bit BGRA 的 彩色图像了， 1 个像素占用 3 个字节，依次是蓝色、 绿色、 红色、 Alpha 排列。
CKSDK_API CameraSdkStatus __stdcall CameraSetMirror | ( | HANDLE | hCamera,
 |  | INT | iDir,
 |  | BOOL | bEnable
 | ) |  |

设置图像镜像操作。镜像操作分为水平和垂直两个方向。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iDir | 表示镜像的方向。0，表示水平方向；1，表示垂直方向。
[in] | bEnable | TRUE，使能镜像;FALSE，禁止镜像
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetMonochrome | ( | HANDLE | hCamera,
 |  | BOOL | bEnable
 | ) |  |

设置彩色转为黑白功能的使能。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | bEnable | TRUE，表示将彩色图像转为黑白。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetResolution | ( | HANDLE | hCamera,
 |  | INT | iResolutionIndex
 | ) |  |

设定相机输出图像的分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iResolutionIndex | 选择的帧率模式索引号,相机可供选择的分辨率模式由 CameraGetCapability获得的信息结构体中iImageSizeDesc 表示可以选择的分辨率模式个数。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionEx | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

设置自定义预览的分辨率。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pImageResolution | 结构体指针，用于返回当前的分辨率。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetSaturation | ( | HANDLE | hCamera,
 |  | INT | iSaturation
 | ) |  |

设定图像处理的饱和度。对黑白相机无效。 设定范围由CameraGetCapability获得。100表示 表示原始色度，不增强。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iSaturation | 设定的饱和度值。
返回
状态码
注解
该函数设置图像饱和度。饱和度越大色彩越浓；反之越淡，饱和度如 果设置为 0，图像就完全没有色彩了，等效于黑白相机。默认值是 100。调节范围是 0 到 200。
CKSDK_API CameraSdkStatus __stdcall CameraSetSharpness | ( | HANDLE | hCamera,
 |  | INT | iSharpness
 | ) |  |

设置图像的处理的锐化参数。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iSharpness | 锐化参数。范围由CameraGetCapability 获得，一般是[0,100]，0表示关闭锐化处理。
返回
状态码
注解
该函数设置图像的锐化级别。锐化度越高，图像清晰度越好，但是噪 声也会越大；反之锐化度越低，图像朦胧感就强，但是噪声降低，显 得平滑。默认值是 0，就是没有锐化增强的效果。


CKCameraAPI: 触发设置

函数
触发设置
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerMode (HANDLE hCamera, INT iTriggerModeSel)
设置相机的触发模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerMode (HANDLE hCamera, INT *piTriggerModeSel)
获得相机的触发模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSoftTrigger (HANDLE hCamera)
执行一次软触发。 更多...
CameraSdkStatus __stdcall | CameraSetTriggerFrameCount (HANDLE hCamera, INT frameCount)
设置硬件触发时连续拍多少张图片 更多...
CameraSdkStatus __stdcall | CameraGetTriggerFrameCount (HANDLE hCamera, INT *pFrameCount)
获取硬件触发时连续拍多少张图片 更多...
CameraSdkStatus __stdcall | CameraSetTriggerDelayTime (HANDLE hCamera, UINT delayTimeUs)
设置硬件触发后多少时间进行拍照 更多...
CameraSdkStatus __stdcall | CameraGetTriggerDelayTime (HANDLE hCamera, UINT *pDelayTimeUs)
设置硬件触发后多少时间进行拍照 更多...
CameraSdkStatus __stdcall | CameraSetTriggerJitterTime (HANDLE hCamera, UINT jitterTimeUs)
设置硬件触发后去抖时间 更多...
CameraSdkStatus __stdcall | CameraGetTriggerJitterTime (HANDLE hCamera, UINT *pJitterTimeUs)
获取硬件触发后去抖时间 更多...
CameraSdkStatus __stdcall | CameraSetTriggerSignalType (HANDLE hCamera, INT type)
设置硬件触发信号类型 更多...
CameraSdkStatus __stdcall | CameraGetTriggerSignalType (HANDLE hCamera, INT *pType)
获取硬件触发信号类型 更多...
CameraSdkStatus __stdcall | CameraSetStrobeMode (HANDLE hCamera, INT mode)
设置闪光灯工作模式 更多...
CameraSdkStatus __stdcall | CameraGetStrobeMode (HANDLE hCamera, INT *pMode)
获取闪光灯工作模式 更多...
CameraSdkStatus __stdcall | CameraSetStrobeDelayTime (HANDLE hCamera, UINT delayTimeUs)
设置触发后延时多少时间点亮闪光灯 更多...
CameraSdkStatus __stdcall | CameraGetStrobeDelayTime (HANDLE hCamera, UINT *pDevlayTimeUs)
获取触发后点亮闪光灯的延时时间 更多...
CameraSdkStatus __stdcall | CameraSetStrobePulseWidth (HANDLE hCamera, UINT pulseWidth)
设置闪光灯的脉宽宽度 更多...
CameraSdkStatus __stdcall | CameraGetStrobePulseWidth (HANDLE hCamera, UINT *pPulseWidth)
获取闪光灯的脉宽宽度 更多...
CameraSdkStatus __stdcall | CameraSetStrobePolarity (HANDLE hCamera, INT polarity)
设置闪光灯的有效电平 更多...
CameraSdkStatus __stdcall | CameraGetStrobePolarity (HANDLE hCamera, INT *pPolarity)
获取闪光灯的有效电平 更多...
CameraSdkStatus __stdcall | CameraSetOutputIOMode (HANDLE hCamera, INT outputIOIndex, INT mode)
设置输出IO的工作模式， 预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 更多...
CameraSdkStatus __stdcall | CameraSetInputIOMode (HANDLE hCamera, INT inputIOIndex, INT mode)
设置输入IO的模式，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决定 更多...
CameraSdkStatus __stdcall | CameraSetOutputIOState (HANDLE hCamera, INT outputIOIndex, INT state)
设置指定IO的电平状态，IO为输出型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 更多...
CameraSdkStatus __stdcall | CameraSetOutputIOPWM (HANDLE hCamera, INT outputIOIndex, INT cycle, INT duty)
设置PWM型输出的参数，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 更多...
CameraSdkStatus __stdcall | CameraGetInputIOState (HANDLE hCamera, INT inputIOIndex, int *pState)
设置指定IO的电平状态，IO为输入型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决定。 更多...

详细描述

函数说明

CameraSdkStatus __stdcall CameraGetInputIOState | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | int * | pState
 | ) |  |

设置指定IO的电平状态，IO为输入型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决定。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得。
[in] | inputIOIndex | IO的索引号，从0开始。
[in] | pState | 指针，返回IO状态,1为导通，0为不导通
返回
状态码
CameraSdkStatus __stdcall CameraGetStrobeDelayTime | ( | HANDLE | hCamera,
 |  | UINT * | pDevlayTimeUs
 | ) |  |

获取触发后点亮闪光灯的延时时间

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pDevlayTimeUs | 延时时间，单位微秒
返回
状态码
CameraSdkStatus __stdcall CameraGetStrobeMode | ( | HANDLE | hCamera,
 |  | INT * | pMode
 | ) |  |

获取闪光灯工作模式

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pMode | 触发类型，请参考emStrobeControl
返回
状态码
CameraSdkStatus __stdcall CameraGetStrobePolarity | ( | HANDLE | hCamera,
 |  | INT * | pPolarity
 | ) |  |

获取闪光灯的有效电平

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pPolarity | 有效电平
返回
状态码
CameraSdkStatus __stdcall CameraGetStrobePulseWidth | ( | HANDLE | hCamera,
 |  | UINT * | pPulseWidth
 | ) |  |

获取闪光灯的脉宽宽度

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pPulseWidth | 脉宽宽度，单位微秒
返回
状态码
CameraSdkStatus __stdcall CameraGetTriggerDelayTime | ( | HANDLE | hCamera,
 |  | UINT * | pDelayTimeUs
 | ) |  |

设置硬件触发后多少时间进行拍照

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pDelayTimeUs | 延时时间，单位微秒
返回
状态码
CameraSdkStatus __stdcall CameraGetTriggerFrameCount | ( | HANDLE | hCamera,
 |  | INT * | pFrameCount
 | ) |  |

获取硬件触发时连续拍多少张图片

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pFrameCount | 连续拍多少张图片
返回
状态码
CameraSdkStatus __stdcall CameraGetTriggerJitterTime | ( | HANDLE | hCamera,
 |  | UINT * | pJitterTimeUs
 | ) |  |

获取硬件触发后去抖时间

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pJitterTimeUs | 去抖时间，单位微秒
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerMode | ( | HANDLE | hCamera,
 |  | INT * | piTriggerModeSel
 | ) |  |

获得相机的触发模式。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piTriggerModeSel | 指针，返回当前选择的相机触发模式的索引号。
返回
状态码
CameraSdkStatus __stdcall CameraGetTriggerSignalType | ( | HANDLE | hCamera,
 |  | INT * | pType
 | ) |  |

获取硬件触发信号类型

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pType | 触发类型，请参考emExtTrigSignal
返回
状态码
CameraSdkStatus __stdcall CameraSetInputIOMode | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | INT | mode
 | ) |  |

设置输入IO的模式，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决定

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | inputIOIndex | IO的索引号，从0开始
[in] | mode | 输入IO模式, 参考emSdkInputIOMode
返回
状态码
CameraSdkStatus __stdcall CameraSetOutputIOMode | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT | mode
 | ) |  |

设置输出IO的工作模式， 预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | outputIOIndex | 输出IO的索引号，从0开始
[out] | mode | 输出IO模式，参考emSdkOutputIOMode
返回
状态码
CameraSdkStatus __stdcall CameraSetOutputIOPWM | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT | cycle,
 |  | INT | duty
 | ) |  |

设置PWM型输出的参数，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得。
[in] | outputIOIndex | IO的索引号，从0开始。
[in] | cycle | PWM的周期，单位(us)
[in] | duty | 占用比，取值1%~99%
返回
状态码
CameraSdkStatus __stdcall CameraSetOutputIOState | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT | state
 | ) |  |

设置指定IO的电平状态，IO为输出型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | outputIOIndex | IO的索引号，从0开始。
[in] | state | 要设定的状态，1为导通，0为不导通
返回
状态码
CameraSdkStatus __stdcall CameraSetStrobeDelayTime | ( | HANDLE | hCamera,
 |  | UINT | delayTimeUs
 | ) |  |

设置触发后延时多少时间点亮闪光灯

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | delayTimeUs | 延时时间，单位微秒
返回
状态码
CameraSdkStatus __stdcall CameraSetStrobeMode | ( | HANDLE | hCamera,
 |  | INT | mode
 | ) |  |

设置闪光灯工作模式

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | mode | 触发类型，请参考emStrobeControl
返回
状态码
CameraSdkStatus __stdcall CameraSetStrobePolarity | ( | HANDLE | hCamera,
 |  | INT | polarity
 | ) |  |

设置闪光灯的有效电平

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | polarity | 有效电平
返回
状态码
CameraSdkStatus __stdcall CameraSetStrobePulseWidth | ( | HANDLE | hCamera,
 |  | UINT | pulseWidth
 | ) |  |

设置闪光灯的脉宽宽度

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pulseWidth | 脉宽宽度，单位微秒
返回
状态码
CameraSdkStatus __stdcall CameraSetTriggerDelayTime | ( | HANDLE | hCamera,
 |  | UINT | delayTimeUs
 | ) |  |

设置硬件触发后多少时间进行拍照

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | delayTimeUs | 延时时间，单位微秒
返回
状态码
CameraSdkStatus __stdcall CameraSetTriggerFrameCount | ( | HANDLE | hCamera,
 |  | INT | frameCount
 | ) |  |

设置硬件触发时连续拍多少张图片

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | frameCount | 连续拍多少张图片
返回
状态码
CameraSdkStatus __stdcall CameraSetTriggerJitterTime | ( | HANDLE | hCamera,
 |  | UINT | jitterTimeUs
 | ) |  |

设置硬件触发后去抖时间

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | jitterTimeUs | 去抖时间，单位微秒
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerMode | ( | HANDLE | hCamera,
 |  | INT | iTriggerModeSel
 | ) |  |

设置相机的触发模式。

参数
[in] hCamera 相机的句柄，由CameraInit函数获得
[in] iTriggerModeSel 模式选择索引号。可设定的模式由 CameraGetCapability函数获取。请参考 CameraDefine.h中tSdkCameraCapbility的定义。 一般情况，
  1. 0.表示连续采集模式；
  2. 1.表示软件触发模式；
  3. 2.表示硬件触发模式。
返回
状态码
CameraSdkStatus __stdcall CameraSetTriggerSignalType | ( | HANDLE | hCamera,
 |  | INT | type
 | ) |  |

设置硬件触发信号类型

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | type | 触发类型，请参考emExtTrigSignal
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSoftTrigger ( HANDLE hCamera )

执行一次软触发。

参数
[in] hCamera 相机的句柄，由CameraInit函数获得
返回
状态码
注解
相机出厂默认就处于连续取图模式，也可以通过 CameraSetTriggerMode(hCamera,0);切换为连续取图模式。
  1. 1.设置相机为软触发取图模式。通过 CameraSetTriggerMode(hCamera,1);切换为软触发取图模式。进入该 模式后，相机停止图像采集和发送。只有当用户调用 CameraSoftTrigger(hCamera)一次，相机就采集一次图像发送上来。 发完之后相机又会进入等待状态，直到下次用户调用 CameraSoftTrigger(hCamera)。
  2. 2.设置相机为硬触发取图模式。通过 CameraSetTriggerMode(hCamera,2);切换为硬触发取图模式。进入该 模式后，相机停止图像采集和发送。 只有当用户在相机外壳上的触 发端子上输入一个脉冲时，相机就采集一次图像发送上 来。发完之后相机又会进入等待状态，直到下次收到触发脉冲。


CKCameraAPI: 相机参数的保存与加载

函数
相机参数的保存与加载
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSetParameterMode (HANDLE hCamera, INT iMode)
设定参数存取的目标对象。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetParameterMode (HANDLE hCamera, INT *piMode)
获得参数存取的目标对象。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameter (HANDLE hCamera, INT iTeam)
保存当前相机参数到指定的参数组中。相机提供了A,B,C,D A,B,C,D四组空间来进行参数的保存。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameterToFile (HANDLE hCamera, const char *sFileName)
保存当前相机参数到指定的文件中。该文件可以复制到 别的电脑上供其他相机加载，也可以做参数备份用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraReadParameterFromFile (HANDLE hCamera, const char *sFileName)
从PC上指定的参数文件中加载参数。我公司相机参数 保存在PC上为.config后缀的文件，位于安装下的 Camera\Configs文件夹中。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadParameter (HANDLE hCamera, INT iTeam)
加载指定组的参数到相机中。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentParameterGroup (HANDLE hCamera, INT *piTeam)
获得当前选择的参数组。 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentParameterGroup | ( | HANDLE | hCamera,
 |  | INT * | piTeam
 | ) |  |

获得当前选择的参数组。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piTeam | 指针，返回当前选择的参数组。返回值 参考CameraLoadParameter中iTeam参数。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetParameterMode | ( | HANDLE | hCamera,
 |  | INT * | piMode
 | ) |  |

获得参数存取的目标对象。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | piMode | 指针，返回参数存取的模式
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraLoadParameter | ( | HANDLE | hCamera,
 |  | INT | iTeam
 | ) |  |

加载指定组的参数到相机中。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iTeam | PARAMETER_TEAM_A 加载A组参数, emSdkParameterTeam::PARAMETER_TEAM_B 加载B组参数, emSdkParameterTeam::PARAMETER_TEAM_C 加载C组参数, emSdkParameterTeam::PARAMETER_TEAM_D 加载D组参数, emSdkParameterTeam::PARAMETER_TEAM_DEFAULT 加载默认参数。 类型定义参考CameraDefine.h中emSdkParameterTeam类型
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraReadParameterFromFile | ( | HANDLE | hCamera,
 |  | const char * | sFileName
 | ) |  |

从PC上指定的参数文件中加载参数。我公司相机参数 保存在PC上为.config后缀的文件，位于安装下的 Camera\Configs文件夹中。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | *sFileName | 参数文件的完整路径。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSaveParameter | ( | HANDLE | hCamera,
 |  | INT | iTeam
 | ) |  |

保存当前相机参数到指定的参数组中。相机提供了A,B,C,D A,B,C,D四组空间来进行参数的保存。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iTeam | PARAMETER_TEAM_A 保存到A组中, PARAMETER_TEAM_B 保存到B组中, PARAMETER_TEAM_C 保存到C组中, PARAMETER_TEAM_D 保存到D组中
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSaveParameterToFile | ( | HANDLE | hCamera,
 |  | const char * | sFileName
 | ) |  |

保存当前相机参数到指定的文件中。该文件可以复制到 别的电脑上供其他相机加载，也可以做参数备份用。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | sFileName | 参数文件的完整路径。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetParameterMode | ( | HANDLE | hCamera,
 |  | INT | iMode
 | ) |  |

设定参数存取的目标对象。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | iMode | 参数存取的模式。参考CameraDefine.h 中emSdkParameterMode的类型定义。
返回
状态码


CKCameraAPI: 相机序列号的设置

函数
相机序列号的设置
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraWriteSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
设置相机的序列号。我公司相机序列号分为3级。0级的是我公司自定义的相机序列号，出厂时已经 设定好，1级和2级留给二次开发使用。每级序列 号长度都是32个字节。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraReadSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
读取相机指定级别的序列号。序列号的定义请参考 CameraWriteSN函数的功能描述部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
将用户自定义的数据保存到相机的非易性存储器中。每个型号的相机可能支持的用户数据区最大长度不一样。可以从设备的特性描述中获取该长度信息。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
从相机的非易性存储器中读取用户自定义的数据。每个型号的相机可能支持的用户数据区最大长度不一样。可以从设备的特性描述中获取该长度信息。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFriendlyName (HANDLE hCamera, char *pName)
读取用户自定义的设备昵称。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFriendlyName (HANDLE hCamera, char *pName)
设置用户自定义的设备昵称。 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraGetFriendlyName | ( | HANDLE | hCamera,
 |  | char * | pName
 | ) |  |

读取用户自定义的设备昵称。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pName | 指针，返回指向0结尾的字符串， 设备昵称不超过32个字节，因此该指针 指向的缓冲区必须大于等于32个字节空间。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraLoadUserData | ( | HANDLE | hCamera,
 |  | UINT | uStartAddr,
 |  | BYTE * | pbData,
 |  | INT | iLen
 | ) |  |

从相机的非易性存储器中读取用户自定义的数据。每个型号的相机可能支持的用户数据区最大长度不一样。可以从设备的特性描述中获取该长度信息。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | uStartAddr | 起始地址，从0开始。
[out] | pbData | 数据缓冲区指针，返回读到的数据。
[in] | iLen | 读取数据的长度，ilen + uStartAddr必须小于用户区最大长度
返回
状态码
注解
我公司所有型号的相机，都带一段数据存储空间，用户可以自由读写。 并且掉电后也会保存，不会丢失数据。每个型号的相机，存储空间的 大小是不一样的，具体的大小可以通过 CameraGetCapability 函数 得到， tSdkCameraCapbility 结极体的 iUserDataMaxLen 表示相机 的最大存储字节数。
CKSDK_API CameraSdkStatus __stdcall CameraReadSN | ( | HANDLE | hCamera,
 |  | BYTE * | pbySN,
 |  | INT | iLevel
 | ) |  |

读取相机指定级别的序列号。序列号的定义请参考 CameraWriteSN函数的功能描述部分。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pbySN | 序列号的缓冲区。
[in] | iLevel | 要读取的序列号级别。只能是1和2。
返回
状态码
参见
CameraWriteSN
CKSDK_API CameraSdkStatus __stdcall CameraSaveUserData | ( | HANDLE | hCamera,
 |  | UINT | uStartAddr,
 |  | BYTE * | pbData,
 |  | INT | iLen
 | ) |  |

将用户自定义的数据保存到相机的非易性存储器中。每个型号的相机可能支持的用户数据区最大长度不一样。可以从设备的特性描述中获取该长度信息。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | uStartAddr | 起始地址，从0开始。
[in] | pbData | 数据缓冲区指针
[in] | iLen | 写入数据的长度，ilen + uStartAddr必须小于用户区最大长度。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetFriendlyName | ( | HANDLE | hCamera,
 |  | char * | pName
 | ) |  |

设置用户自定义的设备昵称。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pName | 指针，指向0结尾的字符串，设备昵称不超过32个字节，因此该指针指向字符串必须小于等于32个字节空间。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraWriteSN | ( | HANDLE | hCamera,
 |  | BYTE * | pbySN,
 |  | INT | iLevel
 | ) |  |

设置相机的序列号。我公司相机序列号分为3级。0级的是我公司自定义的相机序列号，出厂时已经 设定好，1级和2级留给二次开发使用。每级序列 号长度都是32个字节。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | pbySN | 序列号的缓冲区。
[in] | iLevel | 要设定的序列号级别，只能是1或者2。
返回
状态码
参见
CameraReadSN
注解
相机自带三级序列号，其中一级序列号是可读的，不可以修改，出厂 的时候已经固定好了。二级和三级序列号可自由读写。每级序列号都 是 32 个字节。


CKCameraAPI: 版本信息

函数
版本信息
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraSdkGetVersionString (char *pVersionString)
获得SDK版本信息 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraCheckFwUpdate (HANDLE hCamera, BOOL *pNeedUpdate)
检测固件版本，是否需要升级。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFirmwareVision (HANDLE hCamera, char *pVersion)
获得固件版本的字符串 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetDeviceType (HANDLE hCamera, DWORD *pDeviceID)
获得设备版本ID 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInerfaceVersion (HANDLE hCamera, char *pVersion)
获得指定设备接口的版本 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraCheckFwUpdate | ( | HANDLE | hCamera,
 |  | BOOL * | pNeedUpdate
 | ) |  |

检测固件版本，是否需要升级。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pNeedUpdate | 指针，返回固件检测状态，TRUE表示需要更新
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetDeviceType | ( | HANDLE | hCamera,
 |  | DWORD * | pDeviceID
 | ) |  |

获得设备版本ID

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pDeviceID | 必须指向一个4字节的缓冲区， 返回设备版本ID。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetFirmwareVision | ( | HANDLE | hCamera,
 |  | char * | pVersion
 | ) |  |

获得固件版本的字符串

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pVersion | 必须指向一个大于32字节的缓冲区， 返回固件的版本字符串。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraGetInerfaceVersion | ( | HANDLE | hCamera,
 |  | char * | pVersion
 | ) |  |

获得指定设备接口的版本

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[out] | pVersion | 指向一个大于32字节的缓冲区，返回接口版本字符串。
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSdkGetVersionString ( char * pVersionString )

获得SDK版本信息

参数
[in] pVersionString 指针，返回SDK版本字符串。该指针指向的缓冲区大小必须大于32个字节
返回
状态码


CKCameraAPI: 设置属性页

函数
设置属性页
SDK接口函数

函数

CKSDK_API CameraSdkStatus __stdcall | CameraShowSettingPage (HANDLE hCamera, BOOL bShow)
设置相机属性配置窗口显示状态。必须先调用CameraCreateSettingPageEx 成功创建相机属性配置窗口后，才能调用本函数进行显示。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetActivePage (HANDLE hCamera, LONG lActivePage, INT iDefault)
设置相机配置窗口的激活页面。相机配置窗口有多个子页面构成，该函数可以设定当前哪一个子页面为激活状态，显示在最前端。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraCreateSettingPageEx (HANDLE hCamera)
创建相机配置窗口。创建之前要先调用CameraSetActivePage设置子页面构成。 更多...

详细描述

函数说明

CKSDK_API CameraSdkStatus __stdcall CameraCreateSettingPageEx ( HANDLE hCamera )

创建相机配置窗口。创建之前要先调用CameraSetActivePage设置子页面构成。

参数
[in] hCamera 相机的句柄，由CameraInit函数获得
返回
状态码
CKSDK_API CameraSdkStatus __stdcall CameraSetActivePage | ( | HANDLE | hCamera,
 |  | LONG | lActivePage,
 |  | INT | iDefault
 | ) |  |

设置相机配置窗口的激活页面。相机配置窗口有多个子页面构成，该函数可以设定当前哪一个子页面为激活状态，显示在最前端。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | lActivePage | 配置页面使能位 emSettingPage::SETTING_PAGE_ALL
[in] | iDefault | 子页面的索引号。
返回
状态码
参见
CameraCreateSettingPageEx
CameraShowSettingPage
CKSDK_API CameraSdkStatus __stdcall CameraShowSettingPage | ( | HANDLE | hCamera,
 |  | BOOL | bShow
 | ) |  |

设置相机属性配置窗口显示状态。必须先调用CameraCreateSettingPageEx 成功创建相机属性配置窗口后，才能调用本函数进行显示。

参数
[in] | hCamera | 相机的句柄，由CameraInit函数获得
[in] | bShow | TRUE，显示;FALSE，隐藏。
返回
状态码
参见
CameraCreateSettingPageEx
CameraSetActivePage


CKCameraAPI: 错误码

宏定义
错误码

宏定义

#define | CAMERA_STATUS_SUCCESS 0
操作成功 更多...
#define | CAMERA_STATUS_FAILED -1
操作失败 更多...
#define | CAMERA_STATUS_INTERNAL_ERROR -2
内部错误 更多...
#define | CAMERA_STATUS_UNKNOW -3
未知错误 更多...
#define | CAMERA_STATUS_NOT_SUPPORTED -4
不支持该功能 更多...
#define | CAMERA_STATUS_NOT_INITIALIZED -5
初始化未完成 更多...
#define | CAMERA_STATUS_PARAMETER_INVALID -6
参数无效 更多...
#define | CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7
参数越界 更多...
#define | CAMERA_STATUS_UNENABLED -8
未使能 更多...
#define | CAMERA_STATUS_USER_CANCEL -9
用户手动取消了，比如roi面板点击取消，返回 更多...
#define | CAMERA_STATUS_PATH_NOT_FOUND -10
注册表中没有找到对应的路径 更多...
#define | CAMERA_STATUS_SIZE_DISMATCH -11
获得图像数据长度和定义的尺寸不匹配 更多...
#define | CAMERA_STATUS_TIME_OUT -12
超时错误 更多...
#define | CAMERA_STATUS_IO_ERROR -13
硬件IO错误 更多...
#define | CAMERA_STATUS_COMM_ERROR -14
通讯错误 更多...
#define | CAMERA_STATUS_BUS_ERROR -15
总线错误 更多...
#define | CAMERA_STATUS_NO_DEVICE_FOUND -16
没有发现设备 更多...
#define | CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17
未找到逻辑设备 更多...
#define | CAMERA_STATUS_DEVICE_IS_OPENED -18
设备已经打开 更多...
#define | CAMERA_STATUS_DEVICE_IS_CLOSED -19
设备已经关闭 更多...
#define | CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20
没有打开设备视频，调用录像相关的函数时，如果相机视频没有打开，则回返回该错误。 更多...
#define | CAMERA_STATUS_NO_MEMORY -21
没有足够系统内存 更多...
#define | CAMERA_STATUS_FILE_CREATE_FAILED -22
创建文件失败 更多...
#define | CAMERA_STATUS_FILE_INVALID -23
文件格式无效 更多...
#define | CAMERA_STATUS_WRITE_PROTECTED -24
写保护，不可写 更多...
#define | CAMERA_STATUS_GRAB_FAILED -25
数据采集失败 更多...
#define | CAMERA_STATUS_LOST_DATA -26
数据丢失，不完整 更多...
#define | CAMERA_STATUS_EOF_ERROR -27
未接收到帧结束符 更多...
#define | CAMERA_STATUS_BUSY -28
正忙(上一次操作还在进行中)，此次操作不能进行 更多...
#define | CAMERA_STATUS_WAIT -29
需要等待(进行操作的条件不成立)，可以再次尝试 更多...
#define | CAMERA_STATUS_IN_PROCESS -30
正在进行，已经被操作过 更多...
#define | CAMERA_STATUS_IIC_ERROR -31
IIC传输错误 更多...
#define | CAMERA_STATUS_SPI_ERROR -32
SPI传输错误 更多...
#define | CAMERA_STATUS_USB_CONTROL_ERROR -33
USB控制传输错误 更多...
#define | CAMERA_STATUS_USB_BULK_ERROR -34
USB BULK传输错误 更多...
#define | CAMERA_STATUS_SOCKET_INIT_ERROR -35
网络传输套件初始化失败 更多...
#define | CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36
网络相机内核过滤驱动初始化失败，请检查是否正确安装了驱动，或者重新安装。 更多...
#define | CAMERA_STATUS_NET_SEND_ERROR -37
网络数据发送错误 更多...
#define | CAMERA_STATUS_DEVICE_LOST -38
与网络相机失去连接，心跳检测超时 更多...
#define | CAMERA_STATUS_DATA_RECV_LESS -39
接收到的字节数比请求的少 更多...
#define | CAMERA_STATUS_FUNCTION_LOAD_FAILED -40
从文件中加载程序失败 更多...
#define | CAMERA_STATUS_CRITICAL_FILE_LOST -41
程序运行所必须的文件丢失。 更多...
#define | CAMERA_STATUS_SENSOR_ID_DISMATCH -42
固件和程序不匹配，原因是下载了错误的固件。 更多...
#define | CAMERA_STATUS_OUT_OF_RANGE -43
参数超出有效范围。 更多...
#define | CAMERA_STATUS_REGISTRY_ERROR -44
安装程序注册错误。请重新安装程序，或者运行安装目录Setup/Installer.exe 更多...
#define | CAMERA_STATUS_ACCESS_DENY -45
禁止访问。指定相机已经被其他程序占用时，再申请访问该相机，会返回该状态。(一个相机不能被多个程序同时访问) 更多...
#define | CAMERA_STATUS_CAMERA_NEED_RESET -46
表示相机需要复位后才能正常使用，此时请让相机断电重启，或者重启操作系统后，便可正常使用。 更多...
#define | CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47
ISP模块未初始化 更多...
#define | CAMERA_STATUS_ISP_DATA_CRC_ERROR -48
数据校验错误 更多...
#define | CAMERA_STATUS_MV_TEST_FAILED -49
数据测试失败 更多...
#define | CAMERA_STATUS_WAIT_TRIGGER -50
等待触发帧 更多...
#define | CAMERA_STATUS_EEPROM_UPDATA -51
EE数据版本需要更新 更多...
#define | CAMERA_STATUS_OPEN_DEVICE_ERROR -52
打开设备失败 更多...
#define | CAMERA_STATUS_OPEN_STREAM_ERROR -53
打开视频流失败 更多...
#define | CAMERA_STATUS_READ_ERROR -54
读错误 更多...
#define | CAMERA_STATUS_WRITE_ERROR -55
写错误 更多...
#define | CAMERA_STATUS_NO_OPEN_DEVICE -56
没有打开的设备 更多...
#define | CAMERA_STATUS_UNKNOW_SENSOR -57
未识别sensor 更多...
#define | CAMERA_STATUS_NO_WRITE_EEPROM -58
没有写EE数据 更多...
#define | CMAERA_STATUS_FPGA_CFG_ERROR -59
FPGA配置失败 更多...

详细描述

宏定义说明

#define CAMERA_STATUS_ACCESS_DENY -45

禁止访问。指定相机已经被其他程序占用时，再申请访问该相机，会返回该状态。(一个相机不能被多个程序同时访问)

#define CAMERA_STATUS_BUS_ERROR -15

总线错误

#define CAMERA_STATUS_BUSY -28

正忙(上一次操作还在进行中)，此次操作不能进行

#define CAMERA_STATUS_CAMERA_NEED_RESET -46

表示相机需要复位后才能正常使用，此时请让相机断电重启，或者重启操作系统后，便可正常使用。

#define CAMERA_STATUS_COMM_ERROR -14

通讯错误

#define CAMERA_STATUS_CRITICAL_FILE_LOST -41

程序运行所必须的文件丢失。

#define CAMERA_STATUS_DATA_RECV_LESS -39

接收到的字节数比请求的少

#define CAMERA_STATUS_DEVICE_IS_CLOSED -19

设备已经关闭

#define CAMERA_STATUS_DEVICE_IS_OPENED -18

设备已经打开

#define CAMERA_STATUS_DEVICE_LOST -38

与网络相机失去连接，心跳检测超时

#define CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20

没有打开设备视频，调用录像相关的函数时，如果相机视频没有打开，则回返回该错误。

#define CAMERA_STATUS_EEPROM_UPDATA -51

EE数据版本需要更新

#define CAMERA_STATUS_EOF_ERROR -27

未接收到帧结束符

#define CAMERA_STATUS_FAILED -1

操作失败

#define CAMERA_STATUS_FILE_CREATE_FAILED -22

创建文件失败

#define CAMERA_STATUS_FILE_INVALID -23

文件格式无效

#define CAMERA_STATUS_FUNCTION_LOAD_FAILED -40

从文件中加载程序失败

#define CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36

网络相机内核过滤驱动初始化失败，请检查是否正确安装了驱动，或者重新安装。

#define CAMERA_STATUS_GRAB_FAILED -25

数据采集失败

#define CAMERA_STATUS_IIC_ERROR -31

IIC传输错误

#define CAMERA_STATUS_IN_PROCESS -30

正在进行，已经被操作过

#define CAMERA_STATUS_INTERNAL_ERROR -2

内部错误

#define CAMERA_STATUS_IO_ERROR -13

硬件IO错误

#define CAMERA_STATUS_ISP_DATA_CRC_ERROR -48

数据校验错误

#define CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47

ISP模块未初始化

#define CAMERA_STATUS_LOST_DATA -26

数据丢失，不完整

#define CAMERA_STATUS_MV_TEST_FAILED -49

数据测试失败

#define CAMERA_STATUS_NET_SEND_ERROR -37

网络数据发送错误

#define CAMERA_STATUS_NO_DEVICE_FOUND -16

没有发现设备

#define CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17

未找到逻辑设备

#define CAMERA_STATUS_NO_MEMORY -21

没有足够系统内存

#define CAMERA_STATUS_NO_OPEN_DEVICE -56

没有打开的设备

#define CAMERA_STATUS_NO_WRITE_EEPROM -58

没有写EE数据

#define CAMERA_STATUS_NOT_INITIALIZED -5

初始化未完成

#define CAMERA_STATUS_NOT_SUPPORTED -4

不支持该功能

#define CAMERA_STATUS_OPEN_DEVICE_ERROR -52

打开设备失败

#define CAMERA_STATUS_OPEN_STREAM_ERROR -53

打开视频流失败

#define CAMERA_STATUS_OUT_OF_RANGE -43

参数超出有效范围。

#define CAMERA_STATUS_PARAMETER_INVALID -6

参数无效

#define CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7

参数越界

#define CAMERA_STATUS_PATH_NOT_FOUND -10

注册表中没有找到对应的路径

#define CAMERA_STATUS_READ_ERROR -54

读错误

#define CAMERA_STATUS_REGISTRY_ERROR -44

安装程序注册错误。请重新安装程序，或者运行安装目录Setup/Installer.exe

#define CAMERA_STATUS_SENSOR_ID_DISMATCH -42

固件和程序不匹配，原因是下载了错误的固件。

#define CAMERA_STATUS_SIZE_DISMATCH -11

获得图像数据长度和定义的尺寸不匹配

#define CAMERA_STATUS_SOCKET_INIT_ERROR -35

网络传输套件初始化失败

#define CAMERA_STATUS_SPI_ERROR -32

SPI传输错误

#define CAMERA_STATUS_SUCCESS 0

操作成功

#define CAMERA_STATUS_TIME_OUT -12

超时错误

#define CAMERA_STATUS_UNENABLED -8

未使能

#define CAMERA_STATUS_UNKNOW -3

未知错误

#define CAMERA_STATUS_UNKNOW_SENSOR -57

未识别sensor

#define CAMERA_STATUS_USB_BULK_ERROR -34

USB BULK传输错误

#define CAMERA_STATUS_USB_CONTROL_ERROR -33

USB控制传输错误

#define CAMERA_STATUS_USER_CANCEL -9

用户手动取消了，比如roi面板点击取消，返回

#define CAMERA_STATUS_WAIT -29

需要等待(进行操作的条件不成立)，可以再次尝试

#define CAMERA_STATUS_WAIT_TRIGGER -50

等待触发帧

#define CAMERA_STATUS_WRITE_ERROR -55

写错误

#define CAMERA_STATUS_WRITE_PROTECTED -24

写保护，不可写

#define CMAERA_STATUS_FPGA_CFG_ERROR -59

FPGA配置失败


CKCameraAPI: 枚举

枚举
枚举

枚举

enum emResolutionMode {
IMAGEOUT_MODE_512X384 = 0, IMAGEOUT_MODE_640X480 = 1, IMAGEOUT_MODE_800X600 = 2, IMAGEOUT_MODE_1024X768 = 3,
IMAGEOUT_MODE_1280X720 = 4, IMAGEOUT_MODE_1280X960 = 5, IMAGEOUT_MODE_1920X1280 = 6, IMAGEOUT_MODE_2048X1536 = 7,
IMAGEOUT_MODE_320X240 = 8, IMAGEOUT_MODE_1280X1024 = 9, IMAGEOUT_MODE_1600X1200 = 10, IMAGEOUT_MODE_2592X1944 = 11,
IMAGEOUT_MODE_752X480 = 12, IMAGEOUT_MODE_768X576 = 13, IMAGEOUT_MODE_3664X2748 = 14, IMAGEOUT_MODE_NUM,
IMAGEOUT_MODE_CUSTOM = 0XFF
}
图像分辨率 更多...
enum | emFrameMode { FRAME_SPEED_LOW = 0, FRAME_SPEED_MIDDLE, FRAME_SPEED_HIGH }
帧速度 更多...
enum | emFlickerMode { FREQ_FLICKER_MODE_NULL = 0, FREQ_FLICKER_MODE_50HZ, FREQ_FLICKER_MODE_60HZ }
灯光频闪 更多...
enum emFileType {
FILE_JPG = 1, FILE_BMP = 2, FILE_RAW = 4, FILE_PNG = 8,
FILE_BMP_8BIT = 16, FILE_PNG_8BIT = 32, FILE_RAW_16BIT = 64
}
保存图片的文件格式 更多...
enum | emStatisticsMode { STATISTICS_AVG = 0, STATISTICS_HIST, STATISTICS_WINDOW, STATISTICS_REFER_WINDOW }
曝光算法 更多...
enum | emSdkParameterMode { PARAM_MODE_BY_MODEL = 0, PARAM_MODE_BY_NAME, PARAM_MODE_BY_SN, PARAM_MODE_IN_DEVICE }
参数文件加载方式 更多...
enum emSdkParameterTeam {
PARAMETER_TEAM_A = 0, PARAMETER_TEAM_B = 1, PARAMETER_TEAM_C = 2, PARAMETER_TEAM_D = 3,
PARAMETER_TEAM_DEFAULT = 0xff
}
相机的配置参数，分为A,B,C,D共4组进行保存。 更多...
enum | emTriggerMode { TRIGGER_MODE_CONTINUOUS = 0, TRIGGER_MODE_SOFT, TRIGGER_MODE_HARD }
相机触发模式 更多...
enum mTriggerHardType {
TRIGGER_HARD_IDLE = 0, TRIGGER_HARD_RISE = 1, TRIGGER_HARD_FALL = 2, TRIGGER_HARD_HIGH = 3,
TRIGGER_HARD_LOW = 4
}
图像镜像模式 更多...
enum | emStrobeControl { STROBE_SYNC_WITH_TRIG_AUTO = 0, STROBE_SYNC_WITH_TRIG_MANUAL, STROBE_ALWAYS_HIGH, STROBE_ALWAYS_LOW }
闪光灯信号控制方式 更多...
enum emExtTrigSignal {
EXT_TRIG_LEADING_EDGE = 0, EXT_TRIG_TRAILING_EDGE, EXT_TRIG_HIGH_LEVEL, EXT_TRIG_LOW_LEVEL,
EXT_TRIG_DOUBLE_EDGE
}
硬件外触发的信号种类 更多...
enum | emMirrorMode { MIRROR_MODE_H = 0, MIRROR_MODE_V = 1 }
enum | emSdkDisplayMode { DISPLAYMODE_SCALE = 0, DISPLAYMODE_REAL }
SDK内部显示接口的显示方式 更多...
enum | emAeExpMode { AE_EXP_MODE = 0, AE_FRAME_MODE }
自动曝光模式 更多...
enum emSettingPage {
SETTING_PAGE_DEVINFO = 0x01, SETTING_PAGE_IMG_SETTING = 0x02, SETTING_PAGE_EXP_SETTING = 0x04, SETTING_PAGE_AWB_SETTING = 0x08,
SETTING_PAGE_CROSS_LINE = 0x10, SETTING_PAGE_OUT_SETTING = 0x20, SETTING_PAGE_REL_SETTING = 0x40, SETTING_PAGE_GAMMA_SETTING = 0x80,
SETTING_PAGE_ALL = 0xFF
}
设备属性设置对话框显示的TAB页面的掩码 更多...
enum | emSdkLutChannel { LUT_CHANNEL_ALL = 0, LUT_CHANNEL_RED, LUT_CHANNEL_GREEN, LUT_CHANNEL_BLUE }
LUT的颜色通道 更多...
enum | emSdkLutMode { GAMMA_DYNAMIC_MODE = 0, GAMMA_PRESET_MODE, GAMMA_USER_MODE }
LUT的模式 更多...
enum | emSdkOutputIOMode { IOMODE_STROBE_OUTPUT = 0, IOMODE_GP_OUTPUT, IOMODE_PWM_OUTPUT }
IO输出模式 更多...
enum | emSdkInputIOMode { IOMODE_TRIG_INPUT = 0, IOMODE_GP_INPUT }
IO输入模式 更多...

详细描述

枚举类型说明

enum emAeExpMode

自动曝光模式

枚举值
AE_EXP_MODE | 自动曝光帧率优先模式
AE_FRAME_MODE | 自动曝光曝光优先模式
enum emExtTrigSignal

硬件外触发的信号种类

枚举值
EXT_TRIG_LEADING_EDGE | 上升沿触发，默认为该方式
EXT_TRIG_TRAILING_EDGE | 下降沿触发
EXT_TRIG_HIGH_LEVEL | 高电平触发,电平宽度决定曝光时间，仅部分型号的相机支持电平触发方式
EXT_TRIG_LOW_LEVEL | 低电平触发
EXT_TRIG_DOUBLE_EDGE | 双边沿触发
enum emFileType

保存图片的文件格式

枚举值
FILE_JPG | 保存为JPEG文件格式
FILE_BMP | 保存为BMP文件格式
FILE_RAW | 保存为BMP文件格式, 对于不支持bayer格式输出相机，无法保存为该格式
FILE_PNG | 保存为PNG 24BIT文件格式
FILE_BMP_8BIT | 保存为BMP 8BIT文件格式
FILE_PNG_8BIT | 保存为PNG 8BIT文件格式
FILE_RAW_16BIT | 保存为BMP 16BIT文件格式, 对于不支持bayer格式输出相机，无法保存为该格式
enum emFlickerMode

灯光频闪

枚举值
FREQ_FLICKER_MODE_NULL | 禁止消除频闪
FREQ_FLICKER_MODE_50HZ | 消除50hz频闪
FREQ_FLICKER_MODE_60HZ | 消除60hz频闪
enum emFrameMode

帧速度

枚举值
FRAME_SPEED_LOW | 帧速度 低速
FRAME_SPEED_MIDDLE | 帧速度 中速
FRAME_SPEED_HIGH | 帧速度 高速
enum emMirrorMode
枚举值
MIRROR_MODE_H | 水平镜像
MIRROR_MODE_V | 垂直镜像
enum emResolutionMode

图像分辨率

枚举值
IMAGEOUT_MODE_512X384 | 分辨率512x384
IMAGEOUT_MODE_640X480 | 分辨率512x384
IMAGEOUT_MODE_800X600 | 分辨率512x384
IMAGEOUT_MODE_1024X768 | 分辨率512x384
IMAGEOUT_MODE_1280X720 | 分辨率512x384
IMAGEOUT_MODE_1280X960 | 分辨率512x384
IMAGEOUT_MODE_1920X1280 | 分辨率512x384
IMAGEOUT_MODE_2048X1536 | 分辨率512x384
IMAGEOUT_MODE_320X240 | 分辨率512x384
IMAGEOUT_MODE_1280X1024 | 分辨率512x384
IMAGEOUT_MODE_1600X1200 | 分辨率512x384
IMAGEOUT_MODE_2592X1944 | 分辨率512x384
IMAGEOUT_MODE_752X480 | 分辨率512x384
IMAGEOUT_MODE_768X576 | 分辨率512x384
IMAGEOUT_MODE_3664X2748 | 分辨率512x384
IMAGEOUT_MODE_NUM | SDK预定义的分辩率的个数
IMAGEOUT_MODE_CUSTOM | 自定义分辨率
enum emSdkDisplayMode

SDK内部显示接口的显示方式

枚举值
DISPLAYMODE_SCALE | 缩放显示模式，缩放到显示控件的尺寸
DISPLAYMODE_REAL | 1:1显示模式，当图像尺寸大于显示控件的尺寸时，只显示局部
enum emSdkInputIOMode

IO输入模式

枚举值
IOMODE_TRIG_INPUT
IOMODE_GP_INPUT
enum emSdkLutChannel

LUT的颜色通道

枚举值
LUT_CHANNEL_ALL
LUT_CHANNEL_RED
LUT_CHANNEL_GREEN
LUT_CHANNEL_BLUE
enum emSdkLutMode

LUT的模式

枚举值
GAMMA_DYNAMIC_MODE
GAMMA_PRESET_MODE
GAMMA_USER_MODE
enum emSdkOutputIOMode

IO输出模式

枚举值
IOMODE_STROBE_OUTPUT
IOMODE_GP_OUTPUT
IOMODE_PWM_OUTPUT
enum emSdkParameterMode

参数文件加载方式

枚举值
PARAM_MODE_BY_MODEL | 根据相机型号名从文件中加载参数，例如CK-U2B300
PARAM_MODE_BY_NAME | 根据设备昵称(tDevInfo.acFriendlyName)从文件中加载参数，例如CK-U2B300,该昵称可自定义
PARAM_MODE_BY_SN | 根据设备的唯一序列号从文件中加载参数，序列号在出厂时已经写入设备，每台相机拥有不同的序列号。
PARAM_MODE_IN_DEVICE | 从设备的固态存储器中加载参数。不是所有的型号都支持从相机中读写参数组，由tSdkCameraCapbility.bParamInDevice决定
enum emSdkParameterTeam

相机的配置参数，分为A,B,C,D共4组进行保存。

枚举值
PARAMETER_TEAM_A
PARAMETER_TEAM_B
PARAMETER_TEAM_C
PARAMETER_TEAM_D
PARAMETER_TEAM_DEFAULT
enum emSettingPage

设备属性设置对话框显示的TAB页面的掩码

枚举值
SETTING_PAGE_DEVINFO | 设备信息配置页面
SETTING_PAGE_IMG_SETTING | 图像参数配置页面
SETTING_PAGE_EXP_SETTING | 曝光配置页面
SETTING_PAGE_AWB_SETTING | 白平衡配置页面
SETTING_PAGE_CROSS_LINE | 十字线配置页面
SETTING_PAGE_OUT_SETTING | 视频输出配置页面
SETTING_PAGE_REL_SETTING | 分辨率配置页面
SETTING_PAGE_GAMMA_SETTING | 伽玛配置界面
SETTING_PAGE_ALL | 显示所有的属性页
enum emStatisticsMode

曝光算法

枚举值
STATISTICS_AVG | 均值统计
STATISTICS_HIST | 直方图的统计方式
STATISTICS_WINDOW | 带权重3x3的统计方式
STATISTICS_REFER_WINDOW | 参考窗口的统计方式
enum emStrobeControl

闪光灯信号控制方式

枚举值
STROBE_SYNC_WITH_TRIG_AUTO | 和触发信号同步，触发后，相机进行曝光时，自动生成STROBE信号。此时，有效极性可设置(CameraSetStrobePolarity)
STROBE_SYNC_WITH_TRIG_MANUAL | 和触发信号同步，触发后，STROBE延时指定的时间后(CameraSetStrobeDelayTime)，再持续指定时间的脉冲(CameraSetStrobePulseWidth)，有效极性可设置(CameraSetStrobePolarity)
STROBE_ALWAYS_HIGH | 始终为高，忽略STROBE信号的其他设置
STROBE_ALWAYS_LOW | 始终为低，忽略STROBE信号的其他设置
enum emTriggerMode

相机触发模式

枚举值
TRIGGER_MODE_CONTINUOUS | 连续触发模式
TRIGGER_MODE_SOFT | 软件触发模式
TRIGGER_MODE_HARD | 硬件触发模式
enum mTriggerHardType

图像镜像模式

枚举值
TRIGGER_HARD_IDLE
TRIGGER_HARD_RISE
TRIGGER_HARD_FALL
TRIGGER_HARD_HIGH
TRIGGER_HARD_LOW


CKCameraAPI: 回调函数

类型定义
回调函数

类型定义

typedef void(WINAPI * | CAMERA_SNAP_PROC) (HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)
图像捕获的回调函数定义 更多...
typedef void(WINAPI * | CAMERA_DISPLAY_PROC) (HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
图像显示的回调函数 更多...

详细描述

类型定义说明

typedef void(WINAPI* CAMERA_DISPLAY_PROC) (HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)

图像显示的回调函数

typedef void(WINAPI* CAMERA_SNAP_PROC) (HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)

图像捕获的回调函数定义


CKCameraAPI: 类列表

  • 类列表
  • 类索引
  • 类成员
类列表
这里列出了所有类、结构、联合以及接口定义等，并附带简要说明:
C _DisplayWindow | 显示窗口的参数
C _FrameStatistic | 帧率统计信息
C _stImageInfo | 帧头信息
C _tContrastRange | 对比度的设定范围
C _tDevEnumInfo | 枚举信息
C _tDeviceCfg | 设备能力级
C _tDevInfo | 相机的设备信息
C _tDevLoadInfo | /设备的当前模式和枚举信息
C _tDevLoadMode | 设备加载模式信息
C _tExpose | 相机曝光功能范围定义
C _tGammaContrastRange | 伽马对比度的设定范围
C _tGammaRange | 伽马的设定范围
C _tIspAe | 曝光参数
C _tIspGamma | Gama参数
C _tIspWb | 白平衡参数
C _tResolutionRange | 相机的分辨率设定范围，用于构件UI
C _tRgbGainRange | RGB三通道数字增益的设定范围
C _tSaturationRange | 饱和度设定的范围
C _tSdkAeAlgorithm | AE算法描述
C _tSdkBayerDecodeAlgorithm | RAW转RGB算法描述
C _tSdkBayerType | 相机输出的图像数据格式
C _tSdkCameraCapbility | 相机能力级
C _tSdkColorTemperatureDes | 相机白平衡色温模式描述信息
C _tSdkFrameSpeed | 相机帧率描述信息
C _tSdkImageResolution |
C _tSdkIspCapacity | ISP模块的使能信息
C _tSdkMediaType | 相机输出的图像数据格式
C _tSdkPackLength | 传输分包大小描述(主要是针对网络相机有效)
C _tSdkPresetLut | 预设的LUT表描述
C _tSdkTrigger | 触发模式描述
C _tSensorCfg | Sensor能力级
C _tSharpnessRange | 锐化的设定范围


CKCameraAPI: _DisplayWindow结构体 参考

Public 属性 | 所有成员列表
_DisplayWindow结构体 参考

显示窗口的参数 更多...

#include <CKDeviceDef.h>

Public 属性

UINT | ImageWidth
图像宽度 更多...
UINT | ImageHeight
图像高度 更多...
RECT | WinRect
显示窗口矩形 更多...
RECT | ImageRect
有效图像矩形框 更多...

详细描述

显示窗口的参数

类成员变量说明

UINT _DisplayWindow::ImageHeight

图像高度

RECT _DisplayWindow::ImageRect

有效图像矩形框

UINT _DisplayWindow::ImageWidth

图像宽度

RECT _DisplayWindow::WinRect

显示窗口矩形

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _FrameStatistic结构体 参考

Public 属性 | 所有成员列表
_FrameStatistic结构体 参考

帧率统计信息 更多...

#include <CKDeviceDef.h>

Public 属性

DWORD | iTotal
当前采集的总帧数（包括错误帧） 更多...
DWORD | iCapture
当前采集的有效帧的数量 更多...
INT | iLost
当前丢帧的数量 更多...

详细描述

帧率统计信息

类成员变量说明

DWORD _FrameStatistic::iCapture

当前采集的有效帧的数量

INT _FrameStatistic::iLost

当前丢帧的数量

DWORD _FrameStatistic::iTotal

当前采集的总帧数（包括错误帧）

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _stImageInfo结构体 参考

Public 属性 | 所有成员列表
_stImageInfo结构体 参考

帧头信息 更多...

#include <CKDeviceDef.h>

Public 属性

UINT | iWidth
当前图像宽 更多...
UINT | iHeight
当期图像高 更多...
UINT | TotalBytes
图像数据字节数,Total bytes 更多...
UINT | uiMediaType
图像格式 更多...
double | ExpTime
当前图像的曝光时间，单位为微秒us 更多...
double | ExpLineTime
当前图像的行曝光时间，单位为微秒us 更多...
UINT | Gain
当前图像的增益倍数 更多...

详细描述

帧头信息

类成员变量说明

double _stImageInfo::ExpLineTime

当前图像的行曝光时间，单位为微秒us

double _stImageInfo::ExpTime

当前图像的曝光时间，单位为微秒us

UINT _stImageInfo::Gain

当前图像的增益倍数

UINT _stImageInfo::iHeight

当期图像高

UINT _stImageInfo::iWidth

当前图像宽

UINT _stImageInfo::TotalBytes

图像数据字节数,Total bytes

UINT _stImageInfo::uiMediaType

图像格式

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tContrastRange结构体 参考

Public 属性 | 所有成员列表
_tContrastRange结构体 参考

对比度的设定范围 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iMin
最小值 更多...
INT | iMax
最大值 更多...

详细描述

对比度的设定范围

类成员变量说明

INT _tContrastRange::iMax

最大值

INT _tContrastRange::iMin

最小值

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tDevEnumInfo结构体 参考

Public 属性 | 所有成员列表
_tDevEnumInfo结构体 参考

枚举信息 更多...

#include <CKDeviceDef.h>

Public 属性

tDevInfo DevAttribute
设备属性信息 更多...
BOOL bDevOpen
当前设备是否打开 0:设备没有打开;1:设备已经打开 更多...

详细描述

枚举信息

类成员变量说明

BOOL _tDevEnumInfo::bDevOpen

当前设备是否打开 0:设备没有打开;1:设备已经打开

tDevInfo _tDevEnumInfo::DevAttribute

设备属性信息

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tDeviceCfg结构体 参考

Public 属性 | 所有成员列表
_tDeviceCfg结构体 参考

设备能力级 更多...

#include <CKDeviceDef.h>

Public 属性

tRgbGainRange sRgbGainRange
图像数字增益范围描述 更多...
tSaturationRange sSaturationRange
饱和度范围描述 更多...
tGammaRange sGammaRange
伽马范围描述 更多...
tGammaContrastRange sGammaContrastRange
伽马对比度范围描述 更多...
tContrastRange sContrastRange
对比度范围描述 更多...
tSharpnessRange sSharpnessRange
锐化范围描述 更多...
tSdkIspCapacity sIspCapacity
ISP能力描述 更多...
tSdkTrigger * pTriggerDesc
触发模式 更多...
INT | iTriggerDesc
触发模式的个数，即pTriggerDesc数组的大小 更多...
tSdkImageResolution * pImageSizeDesc
预设分辨率选择 更多...
INT | iImageSizeDesc
预设分辨率的个数，即pImageSizeDesc数组的大小 更多...
tSdkColorTemperatureDes * pClrTempDesc
预设色温模式，用于白平衡 更多...
INT | iClrTempDesc
tSdkBayerType * pBayerTypeDesc
相机Bayer格式 更多...
INT | iBayerTypdeDesc
相机Bayer格式的种类个数，即pBayerTypeDesc数组的大小。 更多...
tSdkMediaType * pMediaTypeDesc
相机输出图像格式 更多...
INT | iMediaTypdeDesc
相机输出图像格式的种类个数，即pMediaTypeDesc数组的大小。 更多...
tSdkFrameSpeed * pFrameSpeedDesc
可调节帧速类型，对应界面上普通 高速 和超级三种速度设置 更多...
INT | iFrameSpeedDesc
可调节帧速类型的个数，即pFrameSpeedDesc数组的大小。 更多...
tSdkPackLength * pPackLenDesc
传输包长度，一般用于网络设备 更多...
INT | iPackLenDesc
可供选择的传输分包长度的个数，即pPackLenDesc数组的大小。 更多...
INT | iOutputIoCounts
可编程输出IO的个数 更多...
INT | iInputIoCounts
可编程输入IO的个数 更多...
tSdkPresetLut * pPresetLutDesc
相机预设的LUT表 更多...
INT | iPresetLut
相机预设的LUT表的个数，即pPresetLutDesc数组的大小 更多...
INT | iUserDataMaxLen
指示该相机中用于保存用户数据区的最大长度。为0表示无。 更多...
BOOL | bParamInDevice
指示该设备是否支持从设备中读写参数组。1为支持，0不支持。 更多...
tSdkAeAlgorithm * pAeAlmSwDesc
软件自动曝光算法描述 更多...
int | iAeAlmSwDesc
软件自动曝光算法个数 更多...
tSdkAeAlgorithm * pAeAlmHdDesc
硬件自动曝光算法描述，为NULL表示不支持硬件自动曝光 更多...
int | iAeAlmHdDesc
硬件自动曝光算法个数，为0表示不支持硬件自动曝光 更多...
tSdkBayerDecodeAlgorithm * pBayerDecAlmSwDesc
软件Bayer转换为RGB数据的算法描述 更多...
int | iBayerDecAlmSwDesc
软件Bayer转换为RGB数据的算法个数 更多...
tSdkBayerDecodeAlgorithm * pBayerDecAlmHdDesc
硬件Bayer转换为RGB数据的算法描述，为NULL表示不支持 更多...
int | iBayerDecAlmHdDesc
硬件Bayer转换为RGB数据的算法个数，为0表示不支持 更多...

详细描述

设备能力级

类成员变量说明

BOOL _tDeviceCfg::bParamInDevice

指示该设备是否支持从设备中读写参数组。1为支持，0不支持。

int _tDeviceCfg::iAeAlmHdDesc

硬件自动曝光算法个数，为0表示不支持硬件自动曝光

int _tDeviceCfg::iAeAlmSwDesc

软件自动曝光算法个数

int _tDeviceCfg::iBayerDecAlmHdDesc

硬件Bayer转换为RGB数据的算法个数，为0表示不支持

int _tDeviceCfg::iBayerDecAlmSwDesc

软件Bayer转换为RGB数据的算法个数

INT _tDeviceCfg::iBayerTypdeDesc

相机Bayer格式的种类个数，即pBayerTypeDesc数组的大小。

INT _tDeviceCfg::iClrTempDesc
INT _tDeviceCfg::iFrameSpeedDesc

可调节帧速类型的个数，即pFrameSpeedDesc数组的大小。

INT _tDeviceCfg::iImageSizeDesc

预设分辨率的个数，即pImageSizeDesc数组的大小

INT _tDeviceCfg::iInputIoCounts

可编程输入IO的个数

INT _tDeviceCfg::iMediaTypdeDesc

相机输出图像格式的种类个数，即pMediaTypeDesc数组的大小。

INT _tDeviceCfg::iOutputIoCounts

可编程输出IO的个数

INT _tDeviceCfg::iPackLenDesc

可供选择的传输分包长度的个数，即pPackLenDesc数组的大小。

INT _tDeviceCfg::iPresetLut

相机预设的LUT表的个数，即pPresetLutDesc数组的大小

INT _tDeviceCfg::iTriggerDesc

触发模式的个数，即pTriggerDesc数组的大小

INT _tDeviceCfg::iUserDataMaxLen

指示该相机中用于保存用户数据区的最大长度。为0表示无。

tSdkAeAlgorithm* _tDeviceCfg::pAeAlmHdDesc

硬件自动曝光算法描述，为NULL表示不支持硬件自动曝光

tSdkAeAlgorithm* _tDeviceCfg::pAeAlmSwDesc

软件自动曝光算法描述

tSdkBayerDecodeAlgorithm* _tDeviceCfg::pBayerDecAlmHdDesc

硬件Bayer转换为RGB数据的算法描述，为NULL表示不支持

tSdkBayerDecodeAlgorithm* _tDeviceCfg::pBayerDecAlmSwDesc

软件Bayer转换为RGB数据的算法描述

tSdkBayerType* _tDeviceCfg::pBayerTypeDesc

相机Bayer格式

tSdkColorTemperatureDes* _tDeviceCfg::pClrTempDesc

预设色温模式，用于白平衡

tSdkFrameSpeed* _tDeviceCfg::pFrameSpeedDesc

可调节帧速类型，对应界面上普通 高速 和超级三种速度设置

tSdkImageResolution* _tDeviceCfg::pImageSizeDesc

预设分辨率选择

tSdkMediaType* _tDeviceCfg::pMediaTypeDesc

相机输出图像格式

tSdkPackLength* _tDeviceCfg::pPackLenDesc

传输包长度，一般用于网络设备

tSdkPresetLut* _tDeviceCfg::pPresetLutDesc

相机预设的LUT表

tSdkTrigger* _tDeviceCfg::pTriggerDesc

触发模式

tContrastRange _tDeviceCfg::sContrastRange

对比度范围描述

tGammaContrastRange _tDeviceCfg::sGammaContrastRange

伽马对比度范围描述

tGammaRange _tDeviceCfg::sGammaRange

伽马范围描述

tSdkIspCapacity _tDeviceCfg::sIspCapacity

ISP能力描述

tRgbGainRange _tDeviceCfg::sRgbGainRange

图像数字增益范围描述

tSaturationRange _tDeviceCfg::sSaturationRange

饱和度范围描述

tSharpnessRange _tDeviceCfg::sSharpnessRange

锐化范围描述

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tDevInfo结构体 参考

Public 属性 | 所有成员列表
_tDevInfo结构体 参考

相机的设备信息 更多...

#include <CKDeviceDef.h>

Public 属性

char | acProductSeries [32]
产品系列 更多...
char | acProductName [32]
产品名称 更多...
char | acFriendlyName [32]
产品昵称，用户可自定义改昵称，保存在相机内，用于区分多个相机同时使用,可以用CameraSetFriendlyName接口改变该昵称，设备重启后生效。 更多...
char | acLinkName [32]
内核符号连接名，内部使用 更多...
char | acDriverName [128]
驱动名称 更多...
char | acDriverVersion [32]
驱动版本 更多...
char | acSensorType [32]
sensor类型 更多...
char | acPortType [32]
接口类型 更多...
UINT | uInstance
该型号相机在该电脑上的实例索引号，用于区分同型号多相机 更多...
char | acSn [32]
产品唯一序列号 更多...
WORD | VendorID
厂商ID 更多...
WORD | DeviceDrvID
设备驱动ID 更多...
WORD | DeviceDrvVersionID
设备驱动版本ID 更多...
DWORD | DeviceID
设备ID 更多...
char | SymbolicName [128]
设备标号，内部使用 更多...
char | Name [64]
设备标号，内部使用 更多...
DWORD | SensorID
Sensor ID. 更多...

详细描述

相机的设备信息

类成员变量说明

char _tDevInfo::acDriverName[128]

驱动名称

char _tDevInfo::acDriverVersion[32]

驱动版本

char _tDevInfo::acFriendlyName[32]

产品昵称，用户可自定义改昵称，保存在相机内，用于区分多个相机同时使用,可以用CameraSetFriendlyName接口改变该昵称，设备重启后生效。

char _tDevInfo::acLinkName[32]

内核符号连接名，内部使用

char _tDevInfo::acPortType[32]

接口类型

char _tDevInfo::acProductName[32]

产品名称

char _tDevInfo::acProductSeries[32]

产品系列

char _tDevInfo::acSensorType[32]

sensor类型

char _tDevInfo::acSn[32]

产品唯一序列号

WORD _tDevInfo::DeviceDrvID

设备驱动ID

WORD _tDevInfo::DeviceDrvVersionID

设备驱动版本ID

DWORD _tDevInfo::DeviceID

设备ID

char _tDevInfo::Name[64]

设备标号，内部使用

DWORD _tDevInfo::SensorID

Sensor ID.

char _tDevInfo::SymbolicName[128]

设备标号，内部使用

UINT _tDevInfo::uInstance

该型号相机在该电脑上的实例索引号，用于区分同型号多相机

WORD _tDevInfo::VendorID

厂商ID

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tDevLoadInfo结构体 参考

Public 属性 | 所有成员列表
_tDevLoadInfo结构体 参考

/设备的当前模式和枚举信息 更多...

#include <CKDeviceDef.h>

Public 属性

tDevEnumInfo DevEnumInfo
枚举信息 更多...
tDevLoadMode DevLoadMode
模式信息 更多...

详细描述

/设备的当前模式和枚举信息

类成员变量说明

tDevEnumInfo _tDevLoadInfo::DevEnumInfo

枚举信息

tDevLoadMode _tDevLoadInfo::DevLoadMode

模式信息

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tDevLoadMode结构体 参考

Public 属性 | 所有成员列表
_tDevLoadMode结构体 参考

设备加载模式信息 更多...

#include <CKDeviceDef.h>

Public 属性

tIspAe sIspAe
AE参数 更多...
tIspWb sIspWb
白平衡参数 更多...
UINT | TriggerMode
触发模式 更多...
UINT | ResolutionMode
分辨率 更多...
UINT | MediaTypeMode
输出格式 更多...
UINT | FrameSpeedMode
帧速度 更多...
UINT | Sharpness
锐度 更多...
UINT | Saturation
饱和度 更多...
UINT | Contrast
对比度 更多...
tIspGamma sIspGamma
Gamma. 更多...
UINT | ParameterMode
参数的模式 更多...
UINT | ParameterTeam
参数的组别 更多...
UINT | MirrorHEn
水平镜像使能 更多...
UINT | MirrorVEn
垂直镜像使能 更多...
UINT | ColorToGrayEn
彩色转灰度图 更多...
UINT | BlackLevel
黑电平 更多...

详细描述

设备加载模式信息

类成员变量说明

UINT _tDevLoadMode::BlackLevel

黑电平

UINT _tDevLoadMode::ColorToGrayEn

彩色转灰度图

UINT _tDevLoadMode::Contrast

对比度

UINT _tDevLoadMode::FrameSpeedMode

帧速度

UINT _tDevLoadMode::MediaTypeMode

输出格式

UINT _tDevLoadMode::MirrorHEn

水平镜像使能

UINT _tDevLoadMode::MirrorVEn

垂直镜像使能

UINT _tDevLoadMode::ParameterMode

参数的模式

UINT _tDevLoadMode::ParameterTeam

参数的组别

UINT _tDevLoadMode::ResolutionMode

分辨率

UINT _tDevLoadMode::Saturation

饱和度

UINT _tDevLoadMode::Sharpness

锐度

tIspAe _tDevLoadMode::sIspAe

AE参数

tIspGamma _tDevLoadMode::sIspGamma

Gamma.

tIspWb _tDevLoadMode::sIspWb

白平衡参数

UINT _tDevLoadMode::TriggerMode

触发模式

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tExpose结构体 参考

Public 属性 | 所有成员列表
_tExpose结构体 参考

相机曝光功能范围定义 更多...

#include <CKDeviceDef.h>

Public 属性

UINT | uiTargetMin
自动曝光亮度目标最小值 更多...
UINT | uiTargetMax
自动曝光亮度目标最大值 更多...
UINT | uiAnalogGainMin
模拟增益的最小值，单位为倍数，再扩大1000倍 更多...
UINT | uiAnalogGainMax
模拟增益的最大值，单位为倍数，再扩大1000倍 更多...
UINT | uiExposeTimeMin
手动模式下，曝光时间的最小值，单位:行。根据CameraGetExposureLineTime可以获得一行对应的时间(微秒),从而得到整帧的曝光时间 更多...
UINT | uiExposeTimeMax
手动模式下，曝光时间的最大值，单位:行 更多...

详细描述

相机曝光功能范围定义

类成员变量说明

UINT _tExpose::uiAnalogGainMax

模拟增益的最大值，单位为倍数，再扩大1000倍

UINT _tExpose::uiAnalogGainMin

模拟增益的最小值，单位为倍数，再扩大1000倍

UINT _tExpose::uiExposeTimeMax

手动模式下，曝光时间的最大值，单位:行

UINT _tExpose::uiExposeTimeMin

手动模式下，曝光时间的最小值，单位:行。根据CameraGetExposureLineTime可以获得一行对应的时间(微秒),从而得到整帧的曝光时间

UINT _tExpose::uiTargetMax

自动曝光亮度目标最大值

UINT _tExpose::uiTargetMin

自动曝光亮度目标最小值

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tGammaContrastRange结构体 参考

Public 属性 | 所有成员列表
_tGammaContrastRange结构体 参考

伽马对比度的设定范围 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iMin
最小值 更多...
INT | iMax
最大值 更多...

详细描述

伽马对比度的设定范围

类成员变量说明

INT _tGammaContrastRange::iMax

最大值

INT _tGammaContrastRange::iMin

最小值

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tGammaRange结构体 参考

Public 属性 | 所有成员列表
_tGammaRange结构体 参考

伽马的设定范围 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iMin
最小值 更多...
INT | iMax
最大值 更多...

详细描述

伽马的设定范围

类成员变量说明

INT _tGammaRange::iMax

最大值

INT _tGammaRange::iMin

最小值

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tIspAe结构体 参考

Public 属性 | 所有成员列表
_tIspAe结构体 参考

曝光参数 更多...

#include <CKDeviceDef.h>

Public 属性

BOOL | bAutoExposure
在支持自动曝光功能的前提下，默认使能 更多...
double | ExposureTime
在支持手动曝光功能的前提下设置 更多...
UINT | AnalogGain
在支持手动曝光功能的前提下设置 更多...
UINT | AeTarget
AE目标亮度 更多...
INT | AeMode
AE自动曝光的模式，AE_FRAME_MODE帧率优先，AE_EXP_MODE曝光优先 更多...
double | fMinExposureTime
自动模式下的最小曝光时间，us 更多...
double | fMaxExposureTime
自动模式下的最大曝光时间，us 更多...
INT | iMinAnalogGain
自动模式下的最小模拟增益 更多...
INT | iMaxAnalogGain
自动模式下的最大模拟增益 更多...
BOOL | bAntiFlick
在支持自动曝光功能的前提下，默认关闭 更多...
UINT | FrequencySel
频闪模式 更多...
INT | Left
设置窗口左 更多...
INT | Top
设置窗口上 更多...
INT | Width
设置窗口宽度 更多...
INT | Height
设置窗口高度 更多...

详细描述

曝光参数

类成员变量说明

INT _tIspAe::AeMode

AE自动曝光的模式，AE_FRAME_MODE帧率优先，AE_EXP_MODE曝光优先

UINT _tIspAe::AeTarget

AE目标亮度

UINT _tIspAe::AnalogGain

在支持手动曝光功能的前提下设置

BOOL _tIspAe::bAntiFlick

在支持自动曝光功能的前提下，默认关闭

BOOL _tIspAe::bAutoExposure

在支持自动曝光功能的前提下，默认使能

double _tIspAe::ExposureTime

在支持手动曝光功能的前提下设置

double _tIspAe::fMaxExposureTime

自动模式下的最大曝光时间，us

double _tIspAe::fMinExposureTime

自动模式下的最小曝光时间，us

UINT _tIspAe::FrequencySel

频闪模式

INT _tIspAe::Height

设置窗口高度

INT _tIspAe::iMaxAnalogGain

自动模式下的最大模拟增益

INT _tIspAe::iMinAnalogGain

自动模式下的最小模拟增益

INT _tIspAe::Left

设置窗口左

INT _tIspAe::Top

设置窗口上

INT _tIspAe::Width

设置窗口宽度

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tIspGamma结构体 参考

Public 属性 | 所有成员列表
_tIspGamma结构体 参考

gama参数 更多...

#include <CKDeviceDef.h>

Public 属性

UINT | Mode
UINT | Gamma
gamma值 更多...
UINT | GammaContrast
LUT的对比度值 更多...
UINT | PresetSel
INT | rev [5]

详细描述

gama参数

类成员变量说明

UINT _tIspGamma::Gamma

gamma值

UINT _tIspGamma::GammaContrast

LUT的对比度值

UINT _tIspGamma::Mode
UINT _tIspGamma::PresetSel
INT _tIspGamma::rev[5]
该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tIspWb结构体 参考

Public 属性 | 所有成员列表
_tIspWb结构体 参考

白平衡参数 更多...

#include <CKDeviceDef.h>

Public 属性

BOOL | bAutoWb
在支持自动白平衡功能的前提下，默认关闭 更多...
UINT | DGainR
UINT | DGainG
UINT | DGainB
INT | Left
设置窗口左 更多...
INT | Top
设置窗口上 更多...
INT | Width
设置窗口宽度 更多...
INT | Height
设置窗口高度 更多...
INT | CCM [9]
色彩空间 更多...

详细描述

白平衡参数

类成员变量说明

BOOL _tIspWb::bAutoWb

在支持自动白平衡功能的前提下，默认关闭

INT _tIspWb::CCM[9]

色彩空间

UINT _tIspWb::DGainB
UINT _tIspWb::DGainG
UINT _tIspWb::DGainR
INT _tIspWb::Height

设置窗口高度

INT _tIspWb::Left

设置窗口左

INT _tIspWb::Top

设置窗口上

INT _tIspWb::Width

设置窗口宽度

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tResolutionRange结构体 参考

Public 属性 | 所有成员列表
_tResolutionRange结构体 参考

相机的分辨率设定范围，用于构件UI 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iHeightMax
图像最大高度 更多...
INT | iHeightMin
图像最小高度 更多...
INT | iWidthMax
图像最大宽度 更多...
INT | iWidthMin
图像最小宽度 更多...
UINT | uSkipModeMask
SKIP模式掩码，为0，表示不支持SKIP 。bit0为1,表示支持SKIP 2x2 ;bit1为1，表示支持SKIP 3x3.... 更多...
UINT | uBinSumModeMask
BIN(求和)模式掩码，为0，表示不支持BIN 。bit0为1,表示支持BIN 2x2 ;bit1为1，表示支持BIN 3x3.... 更多...
UINT | uBinAverageModeMask
BIN(求均值)模式掩码，为0，表示不支持BIN 。bit0为1,表示支持BIN 2x2 ;bit1为1，表示支持BIN 3x3.... 更多...
UINT | uResampleMask
硬件重采样的掩码 更多...

详细描述

相机的分辨率设定范围，用于构件UI

类成员变量说明

INT _tResolutionRange::iHeightMax

图像最大高度

INT _tResolutionRange::iHeightMin

图像最小高度

INT _tResolutionRange::iWidthMax

图像最大宽度

INT _tResolutionRange::iWidthMin

图像最小宽度

UINT _tResolutionRange::uBinAverageModeMask

BIN(求均值)模式掩码，为0，表示不支持BIN 。bit0为1,表示支持BIN 2x2 ;bit1为1，表示支持BIN 3x3....

UINT _tResolutionRange::uBinSumModeMask

BIN(求和)模式掩码，为0，表示不支持BIN 。bit0为1,表示支持BIN 2x2 ;bit1为1，表示支持BIN 3x3....

UINT _tResolutionRange::uResampleMask

硬件重采样的掩码

UINT _tResolutionRange::uSkipModeMask

SKIP模式掩码，为0，表示不支持SKIP 。bit0为1,表示支持SKIP 2x2 ;bit1为1，表示支持SKIP 3x3....

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tRgbGainRange结构体 参考

Public 属性 | 所有成员列表
_tRgbGainRange结构体 参考

RGB三通道数字增益的设定范围 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iRGainMin
红色增益的最小值 更多...
INT | iRGainMax
红色增益的最大值 更多...
INT | iGGainMin
绿色增益的最小值 更多...
INT | iGGainMax
绿色增益的最大值 更多...
INT | iBGainMin
蓝色增益的最小值 更多...
INT | iBGainMax
蓝色增益的最大值 更多...

详细描述

RGB三通道数字增益的设定范围

类成员变量说明

INT _tRgbGainRange::iBGainMax

蓝色增益的最大值

INT _tRgbGainRange::iBGainMin

蓝色增益的最小值

INT _tRgbGainRange::iGGainMax

绿色增益的最大值

INT _tRgbGainRange::iGGainMin

绿色增益的最小值

INT _tRgbGainRange::iRGainMax

红色增益的最大值

INT _tRgbGainRange::iRGainMin

红色增益的最小值

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSaturationRange结构体 参考

Public 属性 | 所有成员列表
_tSaturationRange结构体 参考

饱和度设定的范围 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iMin
最小值 更多...
INT | iMax
最大值 更多...

详细描述

饱和度设定的范围

类成员变量说明

INT _tSaturationRange::iMax

最大值

INT _tSaturationRange::iMin

最小值

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkAeAlgorithm结构体 参考

Public 属性 | 所有成员列表
_tSdkAeAlgorithm结构体 参考

AE算法描述 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
编号 更多...
char | acDescription [32]
描述信息 更多...

详细描述

AE算法描述

类成员变量说明

char _tSdkAeAlgorithm::acDescription[32]

描述信息

INT _tSdkAeAlgorithm::iIndex

编号

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkBayerDecodeAlgorithm结构体 参考

Public 属性 | 所有成员列表
_tSdkBayerDecodeAlgorithm结构体 参考

RAW转RGB算法描述 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
编号 更多...
char | acDescription [32]
描述信息 更多...

详细描述

RAW转RGB算法描述

类成员变量说明

char _tSdkBayerDecodeAlgorithm::acDescription[32]

描述信息

INT _tSdkBayerDecodeAlgorithm::iIndex

编号

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkBayerType结构体 参考

Public 属性 | 所有成员列表
_tSdkBayerType结构体 参考

相机输出的图像数据格式 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
格式种类编号 更多...
char | acDescription [32]
描述信息 更多...
UINT | iMediaType
对应的sensor支持的格式编码，如CAMERA_MEDIA_TYPE_BAYGR8 更多...

详细描述

相机输出的图像数据格式

类成员变量说明

char _tSdkBayerType::acDescription[32]

描述信息

INT _tSdkBayerType::iIndex

格式种类编号

UINT _tSdkBayerType::iMediaType

对应的sensor支持的格式编码，如CAMERA_MEDIA_TYPE_BAYGR8

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkCameraCapbility结构体 参考

Public 属性 | 所有成员列表
_tSdkCameraCapbility结构体 参考

相机能力级 更多...

#include <CKDeviceDef.h>

Public 属性

tDeviceCfg tDeviceCapbility
设备能力级 更多...
tSensorCfg tSensorCapbility
sensor能力级 更多...

详细描述

相机能力级

类成员变量说明

tDeviceCfg _tSdkCameraCapbility::tDeviceCapbility

设备能力级

tSensorCfg _tSdkCameraCapbility::tSensorCapbility

sensor能力级

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkColorTemperatureDes结构体 参考

Public 属性 | 所有成员列表
_tSdkColorTemperatureDes结构体 参考

相机白平衡色温模式描述信息 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
模式索引号 更多...
char | acDescription [32]
描述信息 更多...

详细描述

相机白平衡色温模式描述信息

类成员变量说明

char _tSdkColorTemperatureDes::acDescription[32]

描述信息

INT _tSdkColorTemperatureDes::iIndex

模式索引号

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkFrameSpeed结构体 参考

Public 属性 | 所有成员列表
_tSdkFrameSpeed结构体 参考

相机帧率描述信息 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
帧率索引号，一般0对应于低速模式，1对应于普通模式，2对应于高速模式 更多...
char | acDescription [32]
描述信息 更多...

详细描述

相机帧率描述信息

类成员变量说明

char _tSdkFrameSpeed::acDescription[32]

描述信息

INT _tSdkFrameSpeed::iIndex

帧率索引号，一般0对应于低速模式，1对应于普通模式，2对应于高速模式

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkImageResolution结构体 参考

Public 属性 | 所有成员列表
_tSdkImageResolution结构体 参考

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
分辨率 emResolutionMode 更多...
char | acDescription [32]
该分辨率的描述信息。仅预设分辨率时该信息有效。自定义分辨率可忽略该信息 更多...
UINT | uBinSumMode
BIN(求和)的模式,范围不能超过tSdkResolutionRange中uBinSumModeMask. 更多...
UINT | uBinAverageMode
BIN(求均值)的模式,范围不能超过tSdkResolutionRange中uBinAverageModeMask. 更多...
UINT | uSkipMode
是否SKIP的尺寸，为0表示禁止SKIP模式，范围不能超过tSdkResolutionRange中uSkipModeMask 更多...
UINT | uResampleMask
硬件重采样的掩码 更多...
INT | iHOffsetFOV
采集视场相对于Sensor最大视场左上角的水平偏移，偶数 更多...
INT | iVOffsetFOV
采集视场相对于Sensor最大视场左上角的垂直偏移，偶数 更多...
INT | iWidthFOV
采集视场的宽度，必须为偶数 更多...
INT | iHeightFOV
采集视场的高度，必须为偶数 更多...
INT | iWidth
相机最终输出的图像的宽度,偶数,且4字节对齐 更多...
INT | iHeight
相机最终输出的图像的高度，偶数 更多...
INT | iWidthZoomHd
硬件缩放的宽度,不需要进行此操作的分辨率，此变量设置为0. 更多...
INT | iHeightZoomHd
硬件缩放的高度,不需要进行此操作的分辨率，此变量设置为0. 更多...
INT | iWidthZoomSw
软件缩放的宽度,不需要进行此操作的分辨率，此变量设置为0.偶数,且4字节对齐 更多...
INT | iHeightZoomSw
软件缩放的高度,不需要进行此操作的分辨率，此变量设置为0.偶数 更多...

类成员变量说明

char _tSdkImageResolution::acDescription[32]

该分辨率的描述信息。仅预设分辨率时该信息有效。自定义分辨率可忽略该信息

INT _tSdkImageResolution::iHeight

相机最终输出的图像的高度，偶数

INT _tSdkImageResolution::iHeightFOV

采集视场的高度，必须为偶数

INT _tSdkImageResolution::iHeightZoomHd

硬件缩放的高度,不需要进行此操作的分辨率，此变量设置为0.

INT _tSdkImageResolution::iHeightZoomSw

软件缩放的高度,不需要进行此操作的分辨率，此变量设置为0.偶数

INT _tSdkImageResolution::iHOffsetFOV

采集视场相对于Sensor最大视场左上角的水平偏移，偶数

INT _tSdkImageResolution::iIndex

分辨率 emResolutionMode

INT _tSdkImageResolution::iVOffsetFOV

采集视场相对于Sensor最大视场左上角的垂直偏移，偶数

INT _tSdkImageResolution::iWidth

相机最终输出的图像的宽度,偶数,且4字节对齐

INT _tSdkImageResolution::iWidthFOV

采集视场的宽度，必须为偶数

INT _tSdkImageResolution::iWidthZoomHd

硬件缩放的宽度,不需要进行此操作的分辨率，此变量设置为0.

INT _tSdkImageResolution::iWidthZoomSw

软件缩放的宽度,不需要进行此操作的分辨率，此变量设置为0.偶数,且4字节对齐

UINT _tSdkImageResolution::uBinAverageMode

BIN(求均值)的模式,范围不能超过tSdkResolutionRange中uBinAverageModeMask.

UINT _tSdkImageResolution::uBinSumMode

BIN(求和)的模式,范围不能超过tSdkResolutionRange中uBinSumModeMask.

UINT _tSdkImageResolution::uResampleMask

硬件重采样的掩码

UINT _tSdkImageResolution::uSkipMode

是否SKIP的尺寸，为0表示禁止SKIP模式，范围不能超过tSdkResolutionRange中uSkipModeMask

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkIspCapacity结构体 参考

Public 属性 | 所有成员列表
_tSdkIspCapacity结构体 参考

ISP模块的使能信息 更多...

#include <CKDeviceDef.h>

Public 属性

BOOL | bMonoSensor
表示该型号相机是否为黑白相机,如果是黑白相机，则颜色相关的功能都无法调节 更多...
BOOL | bWbOnce
表示该型号相机是否支持一次白平衡功能 更多...
BOOL | bAutoWb
表示该型号相机是否支持自动白平衡功能 更多...
BOOL | bAutoExposure
表示该型号相机是否支持自动曝光功能 更多...
BOOL | bManualExposure
表示该型号相机是否支持手动曝光功能 更多...
BOOL | bAntiFlick
表示该型号相机是否支持抗频闪功能 更多...
BOOL | bIspGamma
表示该型号相机是否支持Gamma功能 更多...
BOOL | bDeviceIsp
表示该型号相机是否支持硬件ISP功能 更多...
BOOL | bForceUseDeviceIsp
bDeviceIsp和bForceUseDeviceIsp同时为TRUE时，表示强制只用硬件ISP，不可取消。 更多...
BOOL | bZoomHD
相机硬件是否支持图像缩放输出(只能是缩小)。 更多...
BOOL | rev [4]

详细描述

ISP模块的使能信息

类成员变量说明

BOOL _tSdkIspCapacity::bAntiFlick

表示该型号相机是否支持抗频闪功能

BOOL _tSdkIspCapacity::bAutoExposure

表示该型号相机是否支持自动曝光功能

BOOL _tSdkIspCapacity::bAutoWb

表示该型号相机是否支持自动白平衡功能

BOOL _tSdkIspCapacity::bDeviceIsp

表示该型号相机是否支持硬件ISP功能

BOOL _tSdkIspCapacity::bForceUseDeviceIsp

bDeviceIsp和bForceUseDeviceIsp同时为TRUE时，表示强制只用硬件ISP，不可取消。

BOOL _tSdkIspCapacity::bIspGamma

表示该型号相机是否支持Gamma功能

BOOL _tSdkIspCapacity::bManualExposure

表示该型号相机是否支持手动曝光功能

BOOL _tSdkIspCapacity::bMonoSensor

表示该型号相机是否为黑白相机,如果是黑白相机，则颜色相关的功能都无法调节

BOOL _tSdkIspCapacity::bWbOnce

表示该型号相机是否支持一次白平衡功能

BOOL _tSdkIspCapacity::bZoomHD

相机硬件是否支持图像缩放输出(只能是缩小)。

BOOL _tSdkIspCapacity::rev[4]
该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkMediaType结构体 参考

Public 属性 | 所有成员列表
_tSdkMediaType结构体 参考

相机输出的图像数据格式 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
格式种类编号 更多...
char | acDescription [32]
描述信息 更多...
UINT | iMediaType
对应的图像格式编码，如CAMERA_MEDIA_TYPE_BAYGR8，在本文件中有定义。 更多...

详细描述

相机输出的图像数据格式

类成员变量说明

char _tSdkMediaType::acDescription[32]

描述信息

INT _tSdkMediaType::iIndex

格式种类编号

UINT _tSdkMediaType::iMediaType

对应的图像格式编码，如CAMERA_MEDIA_TYPE_BAYGR8，在本文件中有定义。

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkPackLength结构体 参考

Public 属性 | 所有成员列表
_tSdkPackLength结构体 参考

传输分包大小描述(主要是针对网络相机有效) 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
分包大小索引号 更多...
char | acDescription [32]
对应的描述信息 更多...
UINT | iPackSize

详细描述

传输分包大小描述(主要是针对网络相机有效)

类成员变量说明

char _tSdkPackLength::acDescription[32]

对应的描述信息

INT _tSdkPackLength::iIndex

分包大小索引号

UINT _tSdkPackLength::iPackSize
该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkPresetLut结构体 参考

Public 属性 | 所有成员列表
_tSdkPresetLut结构体 参考

预设的LUT表描述 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
编号 更多...
char | acDescription [32]
描述信息 更多...

详细描述

预设的LUT表描述

类成员变量说明

char _tSdkPresetLut::acDescription[32]

描述信息

INT _tSdkPresetLut::iIndex

编号

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSdkTrigger结构体 参考

Public 属性 | 所有成员列表
_tSdkTrigger结构体 参考

触发模式描述 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iIndex
模式索引号 更多...
char | acDescription [32]
该模式的描述信息 更多...

详细描述

触发模式描述

类成员变量说明

char _tSdkTrigger::acDescription[32]

该模式的描述信息

INT _tSdkTrigger::iIndex

模式索引号

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSensorCfg结构体 参考

Public 属性 | 所有成员列表
_tSensorCfg结构体 参考

sensor能力级 更多...

#include <CKDeviceDef.h>

Public 属性

tExpose sExposeDesc
曝光的范围值 更多...
tResolutionRange sResolutionRange
分辨率范围描述 更多...
tSdkImageResolution sMaxResolution
最大分辨率 更多...

详细描述

sensor能力级

类成员变量说明

tExpose _tSensorCfg::sExposeDesc

曝光的范围值

tSdkImageResolution _tSensorCfg::sMaxResolution

最大分辨率

tResolutionRange _tSensorCfg::sResolutionRange

分辨率范围描述

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: _tSharpnessRange结构体 参考

Public 属性 | 所有成员列表
_tSharpnessRange结构体 参考

锐化的设定范围 更多...

#include <CKDeviceDef.h>

Public 属性

INT | iMin
最小值 更多...
INT | iMax
最大值 更多...

详细描述

锐化的设定范围

类成员变量说明

INT _tSharpnessRange::iMax

最大值

INT _tSharpnessRange::iMin

最小值

该结构体的文档由以下文件生成:
  • CKDeviceDef.h


CKCameraAPI: 类索引

类索引
_
_
_tDeviceCfg _tIspAe _tSdkBayerDecodeAlgorithm _tSdkMediaType
_tDevInfo _tIspGamma _tSdkBayerType _tSdkPackLength
_DisplayWindow _tDevLoadInfo _tIspWb _tSdkCameraCapbility _tSdkPresetLut
_FrameStatistic _tDevLoadMode _tResolutionRange _tSdkColorTemperatureDes _tSdkTrigger
_stImageInfo _tExpose _tRgbGainRange _tSdkFrameSpeed _tSensorCfg
_tContrastRange _tGammaContrastRange _tSaturationRange _tSdkImageResolution _tSharpnessRange
_tDevEnumInfo _tGammaRange _tSdkAeAlgorithm _tSdkIspCapacity
_


CKCameraAPI: 类成员

  • 全部
  • 变量
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w
这里列出了所有类成员，并附带类的详细说明:

- a -

  • acDescription : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • acDriverName : _tDevInfo
  • acDriverVersion : _tDevInfo
  • acFriendlyName : _tDevInfo
  • acLinkName : _tDevInfo
  • acPortType : _tDevInfo
  • acProductName : _tDevInfo
  • acProductSeries : _tDevInfo
  • acSensorType : _tDevInfo
  • acSn : _tDevInfo
  • AeMode : _tIspAe
  • AeTarget : _tIspAe
  • AnalogGain : _tIspAe

- b -

  • bAntiFlick : _tIspAe , _tSdkIspCapacity
  • bAutoExposure : _tIspAe , _tSdkIspCapacity
  • bAutoWb : _tIspWb , _tSdkIspCapacity
  • bDeviceIsp : _tSdkIspCapacity
  • bDevOpen : _tDevEnumInfo
  • bForceUseDeviceIsp : _tSdkIspCapacity
  • bIspGamma : _tSdkIspCapacity
  • BlackLevel : _tDevLoadMode
  • bManualExposure : _tSdkIspCapacity
  • bMonoSensor : _tSdkIspCapacity
  • bParamInDevice : _tDeviceCfg
  • bWbOnce : _tSdkIspCapacity
  • bZoomHD : _tSdkIspCapacity

- c -

  • CCM : _tIspWb
  • ColorToGrayEn : _tDevLoadMode
  • Contrast : _tDevLoadMode

- d -

  • DevAttribute : _tDevEnumInfo
  • DevEnumInfo : _tDevLoadInfo
  • DeviceDrvID : _tDevInfo
  • DeviceDrvVersionID : _tDevInfo
  • DeviceID : _tDevInfo
  • DevLoadMode : _tDevLoadInfo
  • DGainB : _tIspWb
  • DGainG : _tIspWb
  • DGainR : _tIspWb

- e -

  • ExpLineTime : _stImageInfo
  • ExposureTime : _tIspAe
  • ExpTime : _stImageInfo

- f -

  • fMaxExposureTime : _tIspAe
  • fMinExposureTime : _tIspAe
  • FrameSpeedMode : _tDevLoadMode
  • FrequencySel : _tIspAe

- g -

  • Gain : _stImageInfo
  • Gamma : _tIspGamma
  • GammaContrast : _tIspGamma

- h -

  • Height : _tIspAe , _tIspWb

- i -

  • iAeAlmHdDesc : _tDeviceCfg
  • iAeAlmSwDesc : _tDeviceCfg
  • iBayerDecAlmHdDesc : _tDeviceCfg
  • iBayerDecAlmSwDesc : _tDeviceCfg
  • iBayerTypdeDesc : _tDeviceCfg
  • iBGainMax : _tRgbGainRange
  • iBGainMin : _tRgbGainRange
  • iCapture : _FrameStatistic
  • iClrTempDesc : _tDeviceCfg
  • iFrameSpeedDesc : _tDeviceCfg
  • iGGainMax : _tRgbGainRange
  • iGGainMin : _tRgbGainRange
  • iHeight : _stImageInfo , _tSdkImageResolution
  • iHeightFOV : _tSdkImageResolution
  • iHeightMax : _tResolutionRange
  • iHeightMin : _tResolutionRange
  • iHeightZoomHd : _tSdkImageResolution
  • iHeightZoomSw : _tSdkImageResolution
  • iHOffsetFOV : _tSdkImageResolution
  • iImageSizeDesc : _tDeviceCfg
  • iIndex : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • iInputIoCounts : _tDeviceCfg
  • iLost : _FrameStatistic
  • ImageHeight : _DisplayWindow
  • ImageRect : _DisplayWindow
  • ImageWidth : _DisplayWindow
  • iMax : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMaxAnalogGain : _tIspAe
  • iMediaTypdeDesc : _tDeviceCfg
  • iMediaType : _tSdkBayerType , _tSdkMediaType
  • iMin : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMinAnalogGain : _tIspAe
  • iOutputIoCounts : _tDeviceCfg
  • iPackLenDesc : _tDeviceCfg
  • iPackSize : _tSdkPackLength
  • iPresetLut : _tDeviceCfg
  • iRGainMax : _tRgbGainRange
  • iRGainMin : _tRgbGainRange
  • iTotal : _FrameStatistic
  • iTriggerDesc : _tDeviceCfg
  • iUserDataMaxLen : _tDeviceCfg
  • iVOffsetFOV : _tSdkImageResolution
  • iWidth : _stImageInfo , _tSdkImageResolution
  • iWidthFOV : _tSdkImageResolution
  • iWidthMax : _tResolutionRange
  • iWidthMin : _tResolutionRange
  • iWidthZoomHd : _tSdkImageResolution
  • iWidthZoomSw : _tSdkImageResolution

- l -

  • Left : _tIspAe , _tIspWb

- m -

  • MediaTypeMode : _tDevLoadMode
  • MirrorHEn : _tDevLoadMode
  • MirrorVEn : _tDevLoadMode
  • Mode : _tIspGamma

- n -

  • Name : _tDevInfo

- p -

  • pAeAlmHdDesc : _tDeviceCfg
  • pAeAlmSwDesc : _tDeviceCfg
  • ParameterMode : _tDevLoadMode
  • ParameterTeam : _tDevLoadMode
  • pBayerDecAlmHdDesc : _tDeviceCfg
  • pBayerDecAlmSwDesc : _tDeviceCfg
  • pBayerTypeDesc : _tDeviceCfg
  • pClrTempDesc : _tDeviceCfg
  • pFrameSpeedDesc : _tDeviceCfg
  • pImageSizeDesc : _tDeviceCfg
  • pMediaTypeDesc : _tDeviceCfg
  • pPackLenDesc : _tDeviceCfg
  • pPresetLutDesc : _tDeviceCfg
  • PresetSel : _tIspGamma
  • pTriggerDesc : _tDeviceCfg

- r -

  • ResolutionMode : _tDevLoadMode
  • rev : _tIspGamma , _tSdkIspCapacity

- s -

  • Saturation : _tDevLoadMode
  • sContrastRange : _tDeviceCfg
  • SensorID : _tDevInfo
  • sExposeDesc : _tSensorCfg
  • sGammaContrastRange : _tDeviceCfg
  • sGammaRange : _tDeviceCfg
  • Sharpness : _tDevLoadMode
  • sIspAe : _tDevLoadMode
  • sIspCapacity : _tDeviceCfg
  • sIspGamma : _tDevLoadMode
  • sIspWb : _tDevLoadMode
  • sMaxResolution : _tSensorCfg
  • sResolutionRange : _tSensorCfg
  • sRgbGainRange : _tDeviceCfg
  • sSaturationRange : _tDeviceCfg
  • sSharpnessRange : _tDeviceCfg
  • SymbolicName : _tDevInfo

- t -

  • tDeviceCapbility : _tSdkCameraCapbility
  • Top : _tIspAe , _tIspWb
  • TotalBytes : _stImageInfo
  • TriggerMode : _tDevLoadMode
  • tSensorCapbility : _tSdkCameraCapbility

- u -

  • uBinAverageMode : _tSdkImageResolution
  • uBinAverageModeMask : _tResolutionRange
  • uBinSumMode : _tSdkImageResolution
  • uBinSumModeMask : _tResolutionRange
  • uiAnalogGainMax : _tExpose
  • uiAnalogGainMin : _tExpose
  • uiExposeTimeMax : _tExpose
  • uiExposeTimeMin : _tExpose
  • uiMediaType : _stImageInfo
  • uInstance : _tDevInfo
  • uiTargetMax : _tExpose
  • uiTargetMin : _tExpose
  • uResampleMask : _tResolutionRange , _tSdkImageResolution
  • uSkipMode : _tSdkImageResolution
  • uSkipModeMask : _tResolutionRange

- v -

  • VendorID : _tDevInfo

- w -

  • Width : _tIspAe , _tIspWb
  • WinRect : _DisplayWindow


CKCameraAPI: 类成员 - 变量

  • 全部
  • 变量
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • acDescription : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • acDriverName : _tDevInfo
  • acDriverVersion : _tDevInfo
  • acFriendlyName : _tDevInfo
  • acLinkName : _tDevInfo
  • acPortType : _tDevInfo
  • acProductName : _tDevInfo
  • acProductSeries : _tDevInfo
  • acSensorType : _tDevInfo
  • acSn : _tDevInfo
  • AeMode : _tIspAe
  • AeTarget : _tIspAe
  • AnalogGain : _tIspAe

- b -

  • bAntiFlick : _tIspAe , _tSdkIspCapacity
  • bAutoExposure : _tIspAe , _tSdkIspCapacity
  • bAutoWb : _tIspWb , _tSdkIspCapacity
  • bDeviceIsp : _tSdkIspCapacity
  • bDevOpen : _tDevEnumInfo
  • bForceUseDeviceIsp : _tSdkIspCapacity
  • bIspGamma : _tSdkIspCapacity
  • BlackLevel : _tDevLoadMode
  • bManualExposure : _tSdkIspCapacity
  • bMonoSensor : _tSdkIspCapacity
  • bParamInDevice : _tDeviceCfg
  • bWbOnce : _tSdkIspCapacity
  • bZoomHD : _tSdkIspCapacity

- c -

  • CCM : _tIspWb
  • ColorToGrayEn : _tDevLoadMode
  • Contrast : _tDevLoadMode

- d -

  • DevAttribute : _tDevEnumInfo
  • DevEnumInfo : _tDevLoadInfo
  • DeviceDrvID : _tDevInfo
  • DeviceDrvVersionID : _tDevInfo
  • DeviceID : _tDevInfo
  • DevLoadMode : _tDevLoadInfo
  • DGainB : _tIspWb
  • DGainG : _tIspWb
  • DGainR : _tIspWb

- e -

  • ExpLineTime : _stImageInfo
  • ExposureTime : _tIspAe
  • ExpTime : _stImageInfo

- f -

  • fMaxExposureTime : _tIspAe
  • fMinExposureTime : _tIspAe
  • FrameSpeedMode : _tDevLoadMode
  • FrequencySel : _tIspAe

- g -

  • Gain : _stImageInfo
  • Gamma : _tIspGamma
  • GammaContrast : _tIspGamma

- h -

  • Height : _tIspAe , _tIspWb

- i -

  • iAeAlmHdDesc : _tDeviceCfg
  • iAeAlmSwDesc : _tDeviceCfg
  • iBayerDecAlmHdDesc : _tDeviceCfg
  • iBayerDecAlmSwDesc : _tDeviceCfg
  • iBayerTypdeDesc : _tDeviceCfg
  • iBGainMax : _tRgbGainRange
  • iBGainMin : _tRgbGainRange
  • iCapture : _FrameStatistic
  • iClrTempDesc : _tDeviceCfg
  • iFrameSpeedDesc : _tDeviceCfg
  • iGGainMax : _tRgbGainRange
  • iGGainMin : _tRgbGainRange
  • iHeight : _stImageInfo , _tSdkImageResolution
  • iHeightFOV : _tSdkImageResolution
  • iHeightMax : _tResolutionRange
  • iHeightMin : _tResolutionRange
  • iHeightZoomHd : _tSdkImageResolution
  • iHeightZoomSw : _tSdkImageResolution
  • iHOffsetFOV : _tSdkImageResolution
  • iImageSizeDesc : _tDeviceCfg
  • iIndex : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • iInputIoCounts : _tDeviceCfg
  • iLost : _FrameStatistic
  • ImageHeight : _DisplayWindow
  • ImageRect : _DisplayWindow
  • ImageWidth : _DisplayWindow
  • iMax : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMaxAnalogGain : _tIspAe
  • iMediaTypdeDesc : _tDeviceCfg
  • iMediaType : _tSdkBayerType , _tSdkMediaType
  • iMin : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMinAnalogGain : _tIspAe
  • iOutputIoCounts : _tDeviceCfg
  • iPackLenDesc : _tDeviceCfg
  • iPackSize : _tSdkPackLength
  • iPresetLut : _tDeviceCfg
  • iRGainMax : _tRgbGainRange
  • iRGainMin : _tRgbGainRange
  • iTotal : _FrameStatistic
  • iTriggerDesc : _tDeviceCfg
  • iUserDataMaxLen : _tDeviceCfg
  • iVOffsetFOV : _tSdkImageResolution
  • iWidth : _stImageInfo , _tSdkImageResolution
  • iWidthFOV : _tSdkImageResolution
  • iWidthMax : _tResolutionRange
  • iWidthMin : _tResolutionRange
  • iWidthZoomHd : _tSdkImageResolution
  • iWidthZoomSw : _tSdkImageResolution

- l -

  • Left : _tIspAe , _tIspWb

- m -

  • MediaTypeMode : _tDevLoadMode
  • MirrorHEn : _tDevLoadMode
  • MirrorVEn : _tDevLoadMode
  • Mode : _tIspGamma

- n -

  • Name : _tDevInfo

- p -

  • pAeAlmHdDesc : _tDeviceCfg
  • pAeAlmSwDesc : _tDeviceCfg
  • ParameterMode : _tDevLoadMode
  • ParameterTeam : _tDevLoadMode
  • pBayerDecAlmHdDesc : _tDeviceCfg
  • pBayerDecAlmSwDesc : _tDeviceCfg
  • pBayerTypeDesc : _tDeviceCfg
  • pClrTempDesc : _tDeviceCfg
  • pFrameSpeedDesc : _tDeviceCfg
  • pImageSizeDesc : _tDeviceCfg
  • pMediaTypeDesc : _tDeviceCfg
  • pPackLenDesc : _tDeviceCfg
  • pPresetLutDesc : _tDeviceCfg
  • PresetSel : _tIspGamma
  • pTriggerDesc : _tDeviceCfg

- r -

  • ResolutionMode : _tDevLoadMode
  • rev : _tIspGamma , _tSdkIspCapacity

- s -

  • Saturation : _tDevLoadMode
  • sContrastRange : _tDeviceCfg
  • SensorID : _tDevInfo
  • sExposeDesc : _tSensorCfg
  • sGammaContrastRange : _tDeviceCfg
  • sGammaRange : _tDeviceCfg
  • Sharpness : _tDevLoadMode
  • sIspAe : _tDevLoadMode
  • sIspCapacity : _tDeviceCfg
  • sIspGamma : _tDevLoadMode
  • sIspWb : _tDevLoadMode
  • sMaxResolution : _tSensorCfg
  • sResolutionRange : _tSensorCfg
  • sRgbGainRange : _tDeviceCfg
  • sSaturationRange : _tDeviceCfg
  • sSharpnessRange : _tDeviceCfg
  • SymbolicName : _tDevInfo

- t -

  • tDeviceCapbility : _tSdkCameraCapbility
  • Top : _tIspAe , _tIspWb
  • TotalBytes : _stImageInfo
  • TriggerMode : _tDevLoadMode
  • tSensorCapbility : _tSdkCameraCapbility

- u -

  • uBinAverageMode : _tSdkImageResolution
  • uBinAverageModeMask : _tResolutionRange
  • uBinSumMode : _tSdkImageResolution
  • uBinSumModeMask : _tResolutionRange
  • uiAnalogGainMax : _tExpose
  • uiAnalogGainMin : _tExpose
  • uiExposeTimeMax : _tExpose
  • uiExposeTimeMin : _tExpose
  • uiMediaType : _stImageInfo
  • uInstance : _tDevInfo
  • uiTargetMax : _tExpose
  • uiTargetMin : _tExpose
  • uResampleMask : _tResolutionRange , _tSdkImageResolution
  • uSkipMode : _tSdkImageResolution
  • uSkipModeMask : _tResolutionRange

- v -

  • VendorID : _tDevInfo

- w -

  • Width : _tIspAe , _tIspWb
  • WinRect : _DisplayWindow


CKCameraAPI: 文件列表

  • 文件列表
  • 文件成员
文件列表
这里列出了所有文件，并附带简要说明:
[详情级别 12]
▼ html
dynsections.js
jquery.js
CKCameraInterface.h
CKDeviceDef.h


CKCameraAPI: html 目录参考

  • html
html 目录参考

文件

文件 | dynsections.js
文件 | jquery.js


CKCameraAPI: html/dynsections.js 文件参考

  • 文件列表
  • 文件成员
  • html
函数
dynsections.js 文件参考

函数

function | toggleVisibility (linkObj)
function | updateStripes ()
function | toggleLevel (level)
function | toggleFolder (id)
function | toggleInherit (id)

函数说明

function toggleFolder ( id )
function toggleInherit ( id )
function toggleLevel ( level )
function toggleVisibility ( linkObj )
function updateStripes ( )


CKCameraAPI: html/jquery.js 文件参考

  • 文件列表
  • 文件成员
  • html
函数 | 变量
jquery.js 文件参考

函数

b | extend ({cssHooks:{opacity:{get:function(bw, bv){if(bv){var e=Z(bw,"opacity","opacity");return e===""?"1":e}else{return bw.style.opacity}}}}, cssNumber:{fillOpacity:true, fontWeight:true, lineHeight:true, opacity:true, orphans:true, widows:true, zIndex:true, zoom:true}, cssProps:{"float":b.support.cssFloat?"cssFloat":"styleFloat"}, style:function(bx, bw, bD, by){if(!bx||bx.nodeType===3||bx.nodeType===8||!bx.style){return}var bB, bC, bz=b.camelCase(bw), bv=bx.style, bE=b.cssHooks[bz];bw=b.cssProps[bz]||bz;if(bD!==L){bC=typeof bD;if(bC==="string"&&(bB=I.exec(bD))){bD=(+(bB[1]+1)*+bB[2])+parseFloat(b.css(bx, bw));bC="number"}if(bD==null||bC==="number"&&isNaN(bD)){return}if(bC==="number"&&!b.cssNumber[bz]){bD+="px"}if(!bE||!("set"in bE)||(bD=bE.set(bx, bD))!==L){try{bv[bw]=bD}catch(bA){}}}else{if(bE &&"get"in bE &&(bB=bE.get(bx, false, by))!==L){return bB}return bv[bw]}}, css:function(by, bx, bv){var bw, e;bx=b.camelCase(bx);e=b.cssHooks[bx];bx=b.cssProps[bx]||bx;if(bx==="cssFloat"){bx="float"}if(e &&"get"in e &&(bw=e.get(by, true, bv))!==L){return bw}else{if(Z){return Z(by, bx)}}}, swap:function(bx, bw, by){var e={};for(var bv in bw){e[bv]=bx.style[bv];bx.style[bv]=bw[bv]}by.call(bx);for(bv in bw){bx.style[bv]=e[bv]}}})
b | each (["height","width"], function(bv, e){b.cssHooks[e]={get:function(by, bx, bw){var bz;if(bx){if(by.offsetWidth!==0){return p(by, e, bw)}else{b.swap(by, a7, function(){bz=p(by, e, bw)})}return bz}}, set:function(bw, bx){if(bc.test(bx)){bx=parseFloat(bx);if(bx >=0){return bx+"px"}}else{return bx}}}})
if (!b.support.opacity)
b (function(){if(!b.support.reliableMarginRight){b.cssHooks.marginRight={get:function(bw, bv){var e;b.swap(bw,{display:"inline-block"}, function(){if(bv){e=Z(bw,"margin-right","marginRight")}else{e=bw.style.marginRight}});return e}}}})
if (av.defaultView &&av.defaultView.getComputedStyle)
if (av.documentElement.currentStyle)
function | p (by, bw, bv)
if (b.expr &&b.expr.filters)

变量

function | bb
var L | av =bb.document
var L | bu =bb.navigator
var L | bl =bb.location
var | b
var | au =/opacity=([^)]*)/,z=/([A-Z]|^ms)/g,bc=/^-?\d+(?:px)?$/i,bn=/^-?\d/,I=/^([\-+])=([\-+.\de]+)/,a7={position:"absolute",visibility:"hidden",display:"block"},an=["Left","Right"],a1=["Top","Bottom"],Z,aI,aX
b fn | css =function(e,bv){if(arguments.length===2&&bv===L){return this}return b.access(this,e,bv,true,function(bx,bw,by){return by!==L?b.style(bx,bw,by):b.css(bx,bw)})}
b curCSS =b.css
Z =aI||aX
var | k =/%20/g
var | ap =/\[\]$/
var | bs =/\r?\n/g
var | bq =/#.*$/
var | aD =/^(.*?):[ \t]*([^\r\n]*)\r?$/mg
var | aZ =/^(?:color|date|datetime|datetime-local|email|hidden|month|number|password|range|search|tel|text|time|url|week)$/i
var | aM =/^(?:about|app|app\-storage|.+\-extension|file|res|widget):$/
var | aQ =/^(?:GET|HEAD)$/
var | c

函数说明

b ( function(){if(!b.support.reliableMarginRight){b.cssHooks.marginRight={get:function(bw, bv){var e;b.swap(bw,{display:"inline-block"}, function(){if(bv){e=Z(bw,"margin-right","marginRight")}else{e=bw.style.marginRight}});return e}}}} )
b each ( function(bv, e){b.cssHooks[e]={get:function(by, bx, bw){var bz;if(bx){if(by.offsetWidth!==0){return p(by, e, bw)}else{b.swap(by, a7, function(){bz=p(by, e, bw)})}return bz}}, set:function(bw, bx){if(bc.test(bx)){bx=parseFloat(bx);if(bx >=0){return bx+"px"}}else{return bx}}}} )
b extend ( {cssHooks:{opacity:{get:function(bw, bv){if(bv){var e=Z(bw,"opacity","opacity");return e===""?"1":e}else{return bw.style.opacity}}}}, cssNumber:{fillOpacity:true, fontWeight:true, lineHeight:true, opacity:true, orphans:true, widows:true, zIndex:true, zoom:true}, cssProps:{"float":b.support.cssFloat?"cssFloat":"styleFloat"}, style:function(bx, bw, bD, by){if(!bx||bx.nodeType===3||bx.nodeType===8||!bx.style){return}var bB, bC, bz=b.camelCase(bw), bv=bx.style, bE=b.cssHooks[bz];bw=b.cssProps[bz]||bz;if(bD!==L){bC=typeof bD;if(bC==="string"&&(bB=I.exec(bD))){bD=(+(bB[1]+1)*+bB[2])+parseFloat(b.css(bx, bw));bC="number"}if(bD==null||bC==="number"&&isNaN(bD)){return}if(bC==="number"&&!b.cssNumber[bz]){bD+="px"}if(!bE||!("set"in bE)||(bD=bE.set(bx, bD))!==L){try{bv[bw]=bD}catch(bA){}}}else{if(bE &&"get"in bE &&(bB=bE.get(bx, false, by))!==L){return bB}return bv[bw]}}, css:function(by, bx, bv){var bw, e;bx=b.camelCase(bx);e=b.cssHooks[bx];bx=b.cssProps[bx]||bx;if(bx==="cssFloat"){bx="float"}if(e &&"get"in e &&(bw=e.get(by, true, bv))!==L){return bw}else{if(Z){return Z(by, bx)}}}, swap:function(bx, bw, by){var e={};for(var bv in bw){e[bv]=bx.style[bv];bx.style[bv]=bw[bv]}by.call(bx);for(bv in bw){bx.style[bv]=e[bv]}}} )
if ( av.documentElement. currentStyle )
if ( av.defaultView &&av.defaultView. getComputedStyle )
if ( b.expr &&b.expr. filters )
if ( !b.support. opacity )
function p | ( | by,
 |  | bw,
 |  | bv
 | ) |

变量说明

var aD =/^(.*?):[ \t]*([^\r\n]*)\r?$/mg
var aM =/^(?:about|app|app\-storage|.+\-extension|file|res|widget):$/
var ap =/\[\]$/
var aQ =/^(?:GET|HEAD)$/
var au =/opacity=([^)]*)/,z=/([A-Z]|^ms)/g,bc=/^-?\d+(?:px)?$/i,bn=/^-?\d/,I=/^([\-+])=([\-+.\de]+)/,a7={position:"absolute",visibility:"hidden",display:"block"},an=["Left","Right"],a1=["Top","Bottom"],Z,aI,aX
var L av =bb.document
var aZ =/^(?:color|date|datetime|datetime-local|email|hidden|month|number|password|range|search|tel|text|time|url|week)$/i
var b
初始值:
=(function(){var bF=function(b0,b1){return new bF.fn.init(b0,b1,bD)},bU=bb.jQuery,bH=bb.$,bD,bY=/^(?:[^#<]*(<[\w\W]+>)[^>]*$|#([\w\-]*)$)/,bM=/\S/,bI=/^\s+/,bE=/\s+$/,bA=/^<(\w+)\s*\/?>(?:<\/\1>)?$/,bN=/^[\],:{}\s]*$/,bW=/\\(?:["\\\/bfnrt]|u[0-9a-fA-F]{4})/g,bP=/"[^"\\\n\r]*"|true|false|null|-?\d+(?:\.\d*)?(?:[eE][+\-]?\d+)?/g,bJ=/(?:^|:|,)(?:\s*\[)+/g,by=/(webkit)[ \/]([\w.]+)/,bR=/(opera)(?:.*version)?[ \/]([\w.]+)/,bQ=/(msie) ([\w.]+)/,bS=/(mozilla)(?:.*? rv:([\w.]+))?/,bB=/-([a-z]|[0-9])/ig,bZ=/^-ms-/,bT=function(b0,b1){return(b1+"").toUpperCase()},bX=bu.userAgent,bV,bC,e,bL=Object.prototype.toString,bG=Object.prototype.hasOwnProperty,bz=Array.prototype.push,bK=Array.prototype.slice,bO=String.prototype.trim,bv=Array.prototype.indexOf,bx={};bF.fn=bF.prototype={constructor:bF,init:function(b0,b4,b3){var b2,b5,b1,b6;if(!b0){return this}if(b0.nodeType){this.context=this[0]=b0;this.length=1;return this}if(b0==="body"&&!b4&&av.body){this.context=av;this[0]=av.body;this.selector=b0;this.length=1;return this}if(typeof b0==="string"){if(b0.charAt(0)==="<"&&b0.charAt(b0.length-1)===">"&&b0.length>=3){b2=[null,b0,null]}else{b2=bY.exec(b0)}if(b2&&(b2[1]||!b4)){if(b2[1]){b4=b4 instanceof bF?b4[0]:b4;b6=(b4?b4.ownerDocument||b4:av);b1=bA.exec(b0);if(b1){if(bF.isPlainObject(b4)){b0=[av.createElement(b1[1])];bF.fn.attr.call(b0,b4,true)}else{b0=[b6.createElement(b1[1])]}}else{b1=bF.buildFragment([b2[1]],[b6]);b0=(b1.cacheable?bF.clone(b1.fragment):b1.fragment).childNodes}return bF.merge(this,b0)}else{b5=av.getElementById(b2[2]);if(b5&&b5.parentNode){if(b5.id!==b2[2]){return b3.find(b0)}this.length=1;this[0]=b5}this.context=av;this.selector=b0;return this}}else{if(!b4||b4.jquery){return(b4||b3).find(b0)}else{return this.constructor(b4).find(b0)}}}else{if(bF.isFunction(b0)){return b3.ready(b0)}}if(b0.selector!==L){this.selector=b0.selector;this.context=b0.context}return bF.makeArray(b0,this)},selector:"",jquery:"1.7.1",length:0,size:function(){return this.length},toArray:function(){return bK.call(this,0)},get:function(b0){return b0==null?this.toArray():(b0<0?this[this.length+b0]:this[b0])},pushStack:function(b1,b3,b0){var b2=this.constructor();if(bF.isArray(b1)){bz.apply(b2,b1)}else{bF.merge(b2,b1)}b2.prevObject=this;b2.context=this.context;if(b3==="find"){b2.selector=this.selector+(this.selector?" ":"")+b0}else{if(b3){b2.selector=this.selector+"."+b3+"("+b0+")"}}return b2},each:function(b1,b0){return bF.each(this,b1,b0)},ready:function(b0){bF.bindReady();bC.add(b0);return this},eq:function(b0){b0=+b0;return b0===-1?this.slice(b0):this.slice(b0,b0+1)},first:function(){return this.eq(0)},last:function(){return this.eq(-1)},slice:function(){return this.pushStack(bK.apply(this,arguments),"slice",bK.call(arguments).join(","))},map:function(b0){return this.pushStack(bF.map(this,function(b2,b1){return b0.call(b2,b1,b2)}))},end:function(){return this.prevObject||this.constructor(null)},push:bz,sort:[].sort,splice:[].splice};bF.fn.init.prototype=bF.fn;bF.extend=bF.fn.extend=function(){var b9,b2,b0,b1,b6,b7,b5=arguments[0]||{},b4=1,b3=arguments.length,b8=false;if(typeof b5==="boolean"){b8=b5;b5=arguments[1]||{};b4=2}if(typeof b5!=="object"&&!bF.isFunction(b5)){b5={}}if(b3===b4){b5=this;--b4}for(;b4<b3;b4++){if((b9=arguments[b4])!=null){for(b2 in b9){b0=b5[b2];b1=b9[b2];if(b5===b1){continue}if(b8&&b1&&(bF.isPlainObject(b1)||(b6=bF.isArray(b1)))){if(b6){b6=false;b7=b0&&bF.isArray(b0)?b0:[]}else{b7=b0&&bF.isPlainObject(b0)?b0:{}}b5[b2]=bF.extend(b8,b7,b1)}else{if(b1!==L){b5[b2]=b1}}}}}return b5};bF.extend({noConflict:function(b0){if(bb.$===bF){bb.$=bH}if(b0&&bb.jQuery===bF){bb.jQuery=bU}return bF},isReady:false,readyWait:1,holdReady:function(b0){if(b0){bF.readyWait++}else{bF.ready(true)}},ready:function(b0){if((b0===true&&!--bF.readyWait)||(b0!==true&&!bF.isReady)){if(!av.body){return setTimeout(bF.ready,1)}bF.isReady=true;if(b0!==true&&--bF.readyWait>0){return}bC.fireWith(av,[bF]);if(bF.fn.trigger){bF(av).trigger("ready").off("ready")}}},bindReady:function(){if(bC){return}bC=bF.Callbacks("once memory");if(av.readyState==="complete"){return setTimeout(bF.ready,1)}if(av.addEventListener){av.addEventListener("DOMContentLoaded",e,false);bb.addEventListener("load",bF.ready,false)}else{if(av.attachEvent){av.attachEvent("onreadystatechange",e);bb.attachEvent("onload",bF.ready);var b0=false;try{b0=bb.frameElement==null}catch(b1){}if(av.documentElement.doScroll&&b0){bw()}}}},isFunction:function(b0){return bF.type(b0)==="function"},isArray:Array.isArray||function(b0){return bF.type(b0)==="array"},isWindow:function(b0){return b0&&typeof b0==="object"&&"setInterval" in b0},isNumeric:function(b0){return !isNaN(parseFloat(b0))&&isFinite(b0)},type:function(b0){return b0==null?String(b0):bx[bL.call(b0)]||"object"},isPlainObject:function(b2){if(!b2||bF.type(b2)!=="object"||b2.nodeType||bF.isWindow(b2)){return false}try{if(b2.constructor&&!bG.call(b2,"constructor")&&!bG.call(b2.constructor.prototype,"isPrototypeOf")){return false}}catch(b1){return false}var b0;for(b0 in b2){}return b0===L||bG.call(b2,b0)},isEmptyObject:function(b1){for(var b0 in b1){return false}return true},error:function(b0){throw new Error(b0)},parseJSON:function(b0){if(typeof b0!=="string"||!b0){return null}b0=bF.trim(b0);if(bb.JSON&&bb.JSON.parse){return bb.JSON.parse(b0)}if(bN.test(b0.replace(bW,"@").replace(bP,"]").replace(bJ,""))){return(new Function("return "+b0))()}bF.error("Invalid JSON: "+b0)},parseXML:function(b2){var b0,b1;try{if(bb.DOMParser){b1=new DOMParser();b0=b1.parseFromString(b2,"text/xml")}else{b0=new ActiveXObject("Microsoft.XMLDOM");b0.async="false";b0.loadXML(b2)}}catch(b3){b0=L}if(!b0||!b0.documentElement||b0.getElementsByTagName("parsererror").length){bF.error("Invalid XML: "+b2)}return b0},noop:function(){},globalEval:function(b0){if(b0&&bM.test(b0)){(bb.execScript||function(b1){bb["eval"].call(bb,b1)})(b0)}},camelCase:function(b0){return b0.replace(bZ,"ms-").replace(bB,bT)},nodeName:function(b1,b0){return b1.nodeName&&b1.nodeName.toUpperCase()===b0.toUpperCase()},each:function(b3,b6,b2){var b1,b4=0,b5=b3.length,b0=b5===L||bF.isFunction(b3);if(b2){if(b0){for(b1 in b3){if(b6.apply(b3[b1],b2)===false){break}}}else{for(;b4<b5;){if(b6.apply(b3[b4++],b2)===false){break}}}}else{if(b0){for(b1 in b3){if(b6.call(b3[b1],b1,b3[b1])===false){break}}}else{for(;b4<b5;){if(b6.call(b3[b4],b4,b3[b4++])===false){break}}}}return b3},trim:bO?function(b0){return b0==null?"":bO.call(b0)}:function(b0){return b0==null?"":b0.toString().replace(bI,"").replace(bE,"")},makeArray:function(b3,b1){var b0=b1||[];if(b3!=null){var b2=bF.type(b3);if(b3.length==null||b2==="string"||b2==="function"||b2==="regexp"||bF.isWindow(b3)){bz.call(b0,b3)}else{bF.merge(b0,b3)}}return b0},inArray:function(b2,b3,b1){var b0;if(b3){if(bv){return bv.call(b3,b2,b1)}b0=b3.length;b1=b1?b1<0?Math.max(0,b0+b1):b1:0;for(;b1<b0;b1++){if(b1 in b3&&b3[b1]===b2){return b1}}}return -1},merge:function(b4,b2){var b3=b4.length,b1=0;if(typeof b2.length==="number"){for(var b0=b2.length;b1<b0;b1++){b4[b3++]=b2[b1]}}else{while(b2[b1]!==L){b4[b3++]=b2[b1++]}}b4.length=b3;return b4},grep:function(b1,b6,b0){var b2=[],b5;b0=!!b0;for(var b3=0,b4=b1.length;b3<b4;b3++){b5=!!b6(b1[b3],b3);if(b0!==b5){b2.push(b1[b3])}}return b2},map:function(b0,b7,b8){var b5,b6,b4=[],b2=0,b1=b0.length,b3=b0 instanceof bF||b1!==L&&typeof b1==="number"&&((b1>0&&b0[0]&&b0[b1-1])||b1===0||bF.isArray(b0));if(b3){for(;b2<b1;b2++){b5=b7(b0[b2],b2,b8);if(b5!=null){b4[b4.length]=b5}}}else{for(b6 in b0){b5=b7(b0[b6],b6,b8);if(b5!=null){b4[b4.length]=b5}}}return b4.concat.apply([],b4)},guid:1,proxy:function(b4,b3){if(typeof b3==="string"){var b2=b4[b3];b3=b4;b4=b2}if(!bF.isFunction(b4)){return L}var b0=bK.call(arguments,2),b1=function(){return b4.apply(b3,b0.concat(bK.call(arguments)))};b1.guid=b4.guid=b4.guid||b1.guid||bF.guid++;return b1},access:function(b0,b8,b6,b2,b5,b7){var b1=b0.length;if(typeof b8==="object"){for(var b3 in b8){bF.access(b0,b3,b8[b3],b2,b5,b6)}return b0}if(b6!==L){b2=!b7&&b2&&bF.isFunction(b6);for(var b4=0;b4<b1;b4++){b5(b0[b4],b8,b2?b6.call(b0[b4],b4,b5(b0[b4],b8)):b6,b7)}return b0}return b1?b5(b0[0],b8):L},now:function(){return(new Date()).getTime()},uaMatch:function(b1){b1=b1.toLowerCase();var b0=by.exec(b1)||bR.exec(b1)||bQ.exec(b1)||b1.indexOf("compatible")<0&&bS.exec(b1)||[];return{browser:b0[1]||"",version:b0[2]||"0"}},sub:function(){function b0(b3,b4){return new b0.fn.init(b3,b4)}bF.extend(true,b0,this);b0.superclass=this;b0.fn=b0.prototype=this();b0.fn.constructor=b0;b0.sub=this.sub;b0.fn.init=function b2(b3,b4){if(b4&&b4 instanceof bF&&!(b4 instanceof b0)){b4=b0(b4)}return bF.fn.init.call(this,b3,b4,b1)};b0.fn.init.prototype=b0.fn;var b1=b0(av);return b0},browser:{}});bF.each("Boolean Number String Function Array Date RegExp Object".split(" "),function(b1,b0){bx["[object "+b0+"]"]=b0.toLowerCase()});bV=bF.uaMatch(bX);if(bV.browser){bF.browser[bV.browser]=true;bF.browser.version=bV.version}if(bF.browser.webkit){bF.browser.safari=true}if(bM.test("\xA0")){bI=/^[\s\xA0]+/;bE=/[\s\xA0]+$/}bD=bF(av);if(av.addEventListener){e=function(){av.removeEventListener("DOMContentLoaded",e,false);bF.ready()}}else{if(av.attachEvent){e=function(){if(av.readyState==="complete"){av.detachEvent("onreadystatechange",e);bF.ready()}}}}function bw(){if(bF.isReady){return}try{av.documentElement.doScroll("left")}catch(b0){setTimeout(bw,1);return}bF.ready()}return bF})();var a2={};function X(e){var bv=a2[e]={},bw,bx;e=e.split(/\s+/);for(bw=0,bx=e.length;bw<bx;bw++){bv[e[bw]]=true}return bv}b.Callbacks=function(bw){bw=bw?(a2[bw]||X(bw)):{};var bB=[],bC=[],bx,by,bv,bz,bA,bE=function(bF){var bG,bJ,bI,bH,bK;for(bG=0,bJ=bF.length;bG<bJ;bG++){bI=bF[bG];bH=b.type(bI);if(bH==="array"){bE(bI)}else{if(bH==="function"){if(!bw.unique||!bD.has(bI)){bB.push(bI)}}}}},e=function(bG,bF){bF=bF||[];bx=!bw.memory||[bG,bF];by=true;bA=bv||0;bv=0;bz=bB.length;for(;bB&&bA<bz;bA++){if(bB[bA].apply(bG,bF)===false&&bw.stopOnFalse){bx=true;break}}by=false;if(bB){if(!bw.once){if(bC&&bC.length){bx=bC.shift();bD.fireWith(bx[0],bx[1])}}else{if(bx===true){bD.disable()}else{bB=[]}}}},bD={add:function(){if(bB){var bF=bB.length;bE(arguments);if(by){bz=bB.length}else{if(bx&&bx!==true){bv=bF;e(bx[0],bx[1])}}}return this},remove:function(){if(bB){var bF=arguments,bH=0,bI=bF.length;for(;bH<bI;bH++){for(var bG=0;bG<bB.length;bG++){if(bF[bH]===bB[bG]){if(by){if(bG<=bz){bz--;if(bG<=bA){bA--}}}bB.splice(bG--,1);if(bw.unique){break}}}}}return this},has:function(bG){if(bB){var bF=0,bH=bB.length;for(;bF<bH;bF++){if(bG===bB[bF]){return true}}}return false},empty:function(){bB=[];return this},disable:function(){bB=bC=bx=L;return this},disabled:function(){return !bB},lock:function(){bC=L;if(!bx||bx===true){bD.disable()}return this},locked:function(){return !bC},fireWith:function(bG,bF){if(bC){if(by){if(!bw.once){bC.push([bG,bF])}}else{if(!(bw.once&&bx)){e(bG,bF)}}}return this},fire:function(){bD.fireWith(this,arguments);return this},fired:function(){return !!bx}};return bD};var aJ=[].slice;b.extend({Deferred:function(by){var bx=b.Callbacks("once memory"),bw=b.Callbacks("once memory"),bv=b.Callbacks("memory"),e="pending",bA={resolve:bx,reject:bw,notify:bv},bC={done:bx.add,fail:bw.add,progress:bv.add,state:function(){return e},isResolved:bx.fired,isRejected:bw.fired,then:function(bE,bD,bF){bB.done(bE).fail(bD).progress(bF);return this},always:function(){bB.done.apply(bB,arguments).fail.apply(bB,arguments);return this},pipe:function(bF,bE,bD){return b.Deferred(function(bG){b.each({done:[bF,"resolve"],fail:[bE,"reject"],progress:[bD,"notify"]},function(bI,bL){var bH=bL[0],bK=bL[1],bJ;if(b.isFunction(bH)){bB[bI](function(){bJ=bH.apply(this,arguments);if(bJ&&b.isFunction(bJ.promise)){bJ.promise().then(bG.resolve,bG.reject,bG.notify)}else{bG[bK+"With"](this===bB?bG:this,[bJ])}})}else{bB[bI](bG[bK])}})}).promise()},promise:function(bE){if(bE==null){bE=bC}else{for(var bD in bC){bE[bD]=bC[bD]}}return bE}},bB=bC.promise({}),bz;for(bz in bA){bB[bz]=bA[bz].fire;bB[bz+"With"]=bA[bz].fireWith}bB.done(function(){e="resolved"},bw.disable,bv.lock).fail(function(){e="rejected"},bx.disable,bv.lock);if(by){by.call(bB,bB)}return bB},when:function(bA){var bx=aJ.call(arguments,0),bv=0,e=bx.length,bB=new Array(e),bw=e,by=e,bC=e<=1&&bA&&b.isFunction(bA.promise)?bA:b.Deferred(),bE=bC.promise();function bD(bF){return function(bG){bx[bF]=arguments.length>1?aJ.call(arguments,0):bG;if(!(--bw)){bC.resolveWith(bC,bx)}}}function bz(bF){return function(bG){bB[bF]=arguments.length>1?aJ.call(arguments,0):bG;bC.notifyWith(bE,bB)}}if(e>1){for(;bv<e;bv++){if(bx[bv]&&bx[bv].promise&&b.isFunction(bx[bv].promise)){bx[bv].promise().then(bD(bv),bC.reject,bz(bv))}else{--bw}}if(!bw){bC.resolveWith(bC,bx)}}else{if(bC!==bA){bC.resolveWith(bC,e?[bA]:[])}}return bE}});b.support=(function(){var bJ,bI,bF,bG,bx,bE,bA,bD,bz,bK,bB,by,bw,bv=av.createElement("div"),bH=av.documentElement;bv.setAttribute("className","t");bv.innerHTML=" <link/><table></table><a href='/a' style='top:1px;float:left;opacity:.55;'>a</a><input type='checkbox'/>";bI=bv.getElementsByTagName("*");bF=bv.getElementsByTagName("a")[0];if(!bI||!bI.length||!bF){return{}}bG=av.createElement("select");bx=bG.appendChild(av.createElement("option"));bE=bv.getElementsByTagName("input")[0];bJ={leadingWhitespace:(bv.firstChild.nodeType===3),tbody:!bv.getElementsByTagName("tbody").length,htmlSerialize:!!bv.getElementsByTagName("link").length,style:/top/.test(bF.getAttribute("style")),hrefNormalized:(bF.getAttribute("href")==="/a"),opacity:/^0.55/.test(bF.style.opacity),cssFloat:!!bF.style.cssFloat,checkOn:(bE.value==="on"),optSelected:bx.selected,getSetAttribute:bv.className!=="t",enctype:!!av.createElement("form").enctype,html5Clone:av.createElement("nav").cloneNode(true).outerHTML!=="<:nav></:nav>",submitBubbles:true,changeBubbles:true,focusinBubbles:false,deleteExpando:true,noCloneEvent:true,inlineBlockNeedsLayout:false,shrinkWrapBlocks:false,reliableMarginRight:true};bE.checked=true;bJ.noCloneChecked=bE.cloneNode(true).checked;bG.disabled=true;bJ.optDisabled=!bx.disabled;try{delete bv.test}catch(bC){bJ.deleteExpando=false}if(!bv.addEventListener&&bv.attachEvent&&bv.fireEvent){bv.attachEvent("onclick",function(){bJ.noCloneEvent=false});bv.cloneNode(true).fireEvent("onclick")}bE=av.createElement("input");bE.value="t";bE.setAttribute("type","radio");bJ.radioValue=bE.value==="t";bE.setAttribute("checked","checked");bv.appendChild(bE);bD=av.createDocumentFragment();bD.appendChild(bv.lastChild);bJ.checkClone=bD.cloneNode(true).cloneNode(true).lastChild.checked;bJ.appendChecked=bE.checked;bD.removeChild(bE);bD.appendChild(bv);bv.innerHTML="";if(bb.getComputedStyle){bA=av.createElement("div");bA.style.width="0";bA.style.marginRight="0";bv.style.width="2px";bv.appendChild(bA);bJ.reliableMarginRight=(parseInt((bb.getComputedStyle(bA,null)||{marginRight:0}).marginRight,10)||0)===0}if(bv.attachEvent){for(by in {submit:1,change:1,focusin:1}){bB="on"+by;bw=(bB in bv);if(!bw){bv.setAttribute(bB,"return;");bw=(typeof bv[bB]==="function")}bJ[by+"Bubbles"]=bw}}bD.removeChild(bv);bD=bG=bx=bA=bv=bE=null;b(function(){var bM,bU,bV,bT,bN,bO,bL,bS,bR,e,bP,bQ=av.getElementsByTagName("body")[0];if(!bQ){return}bL=1;bS="position:absolute;top:0;left:0;width:1px;height:1px;margin:0;";bR="visibility:hidden;border:0;";e="style='"+bS+"border:5px solid #000;padding:0;'";bP="<div "+e+"><div></div></div><table "+e+" cellpadding='0' cellspacing='0'><tr><td></td></tr></table>";bM=av.createElement("div");bM.style.cssText=bR+"width:0;height:0;position:static;top:0;margin-top:"+bL+"px";bQ.insertBefore(bM,bQ.firstChild);bv=av.createElement("div");bM.appendChild(bv);bv.innerHTML="<table><tr><td style='padding:0;border:0;display:none'></td><td>t</td></tr></table>";bz=bv.getElementsByTagName("td");bw=(bz[0].offsetHeight===0);bz[0].style.display="";bz[1].style.display="none";bJ.reliableHiddenOffsets=bw&&(bz[0].offsetHeight===0);bv.innerHTML="";bv.style.width=bv.style.paddingLeft="1px";b.boxModel=bJ.boxModel=bv.offsetWidth===2;if(typeof bv.style.zoom!=="undefined"){bv.style.display="inline";bv.style.zoom=1;bJ.inlineBlockNeedsLayout=(bv.offsetWidth===2);bv.style.display="";bv.innerHTML="<div style='width:4px;'></div>";bJ.shrinkWrapBlocks=(bv.offsetWidth!==2)}bv.style.cssText=bS+bR;bv.innerHTML=bP;bU=bv.firstChild;bV=bU.firstChild;bN=bU.nextSibling.firstChild.firstChild;bO={doesNotAddBorder:(bV.offsetTop!==5),doesAddBorderForTableAndCells:(bN.offsetTop===5)};bV.style.position="fixed";bV.style.top="20px";bO.fixedPosition=(bV.offsetTop===20||bV.offsetTop===15);bV.style.position=bV.style.top="";bU.style.overflow="hidden";bU.style.position="relative";bO.subtractsBorderForOverflowNotVisible=(bV.offsetTop===-5);bO.doesNotIncludeMarginInBodyOffset=(bQ.offsetTop!==bL);bQ.removeChild(bM);bv=bM=null;b.extend(bJ,bO)});return bJ})();var aS=/^(?:\{.*\}|\[.*\])$/,aA=/([A-Z])/g;b.extend({cache:{},uuid:0,expando:"jQuery"+(b.fn.jquery+Math.random()).replace(/\D/g,""),noData:{embed:true,object:"clsid:D27CDB6E-AE6D-11cf-96B8-444553540000",applet:true},hasData:function(e){e=e.nodeType?b.cache[e[b.expando]]:e[b.expando];return !!e&&!S(e)},data:function(bx,bv,bz,by){if(!b.acceptData(bx)){return}var bG,bA,bD,bE=b.expando,bC=typeof bv==="string",bF=bx.nodeType,e=bF?b.cache:bx,bw=bF?bx[bE]:bx[bE]&&bE,bB=bv==="events";if((!bw||!e[bw]||(!bB&&!by&&!e[bw].data))&&bC&&bz===L){return}if(!bw){if(bF){bx[bE]=bw=++b.uuid}else{bw=bE}}if(!e[bw]){e[bw]={};if(!bF){e[bw].toJSON=b.noop}}if(typeof bv==="object"||typeof bv==="function"){if(by){e[bw]=b.extend(e[bw],bv)}else{e[bw].data=b.extend(e[bw].data,bv)}}bG=bA=e[bw];if(!by){if(!bA.data){bA.data={}}bA=bA.data}if(bz!==L){bA[b.camelCase(bv)]=bz}if(bB&&!bA[bv]){return bG.events}if(bC){bD=bA[bv];if(bD==null){bD=bA[b.camelCase(bv)]}}else{bD=bA}return bD},removeData:function(bx,bv,by){if(!b.acceptData(bx)){return}var bB,bA,bz,bC=b.expando,bD=bx.nodeType,e=bD?b.cache:bx,bw=bD?bx[bC]:bC;if(!e[bw]){return}if(bv){bB=by?e[bw]:e[bw].data;if(bB){if(!b.isArray(bv)){if(bv in bB){bv=[bv]}else{bv=b.camelCase(bv);if(bv in bB){bv=[bv]}else{bv=bv.split(" ")}}}for(bA=0,bz=bv.length;bA<bz;bA++){delete bB[bv[bA]]}if(!(by?S:b.isEmptyObject)(bB)){return}}}if(!by){delete e[bw].data;if(!S(e[bw])){return}}if(b.support.deleteExpando||!e.setInterval){delete e[bw]}else{e[bw]=null}if(bD){if(b.support.deleteExpando){delete bx[bC]}else{if(bx.removeAttribute){bx.removeAttribute(bC)}else{bx[bC]=null}}}},_data:function(bv,e,bw){return b.data(bv,e,bw,true)},acceptData:function(bv){if(bv.nodeName){var e=b.noData[bv.nodeName.toLowerCase()];if(e){return !(e===true||bv.getAttribute("classid")!==e)}}return true}});b.fn.extend({data:function(by,bA){var bB,e,bw,bz=null;if(typeof by==="undefined"){if(this.length){bz=b.data(this[0]);if(this[0].nodeType===1&&!b._data(this[0],"parsedAttrs")){e=this[0].attributes;for(var bx=0,bv=e.length;bx<bv;bx++){bw=e[bx].name;if(bw.indexOf("data-")===0){bw=b.camelCase(bw.substring(5));a5(this[0],bw,bz[bw])}}b._data(this[0],"parsedAttrs",true)}}return bz}else{if(typeof by==="object"){return this.each(function(){b.data(this,by)})}}bB=by.split(".");bB[1]=bB[1]?"."+bB[1]:"";if(bA===L){bz=this.triggerHandler("getData"+bB[1]+"!",[bB[0]]);if(bz===L&&this.length){bz=b.data(this[0],by);bz=a5(this[0],by,bz)}return bz===L&&bB[1]?this.data(bB[0]):bz}else{return this.each(function(){var bC=b(this),bD=[bB[0],bA];bC.triggerHandler("setData"+bB[1]+"!",bD);b.data(this,by,bA);bC.triggerHandler("changeData"+bB[1]+"!",bD)})}},removeData:function(e){return this.each(function(){b.removeData(this,e)})}});function a5(bx,bw,by){if(by===L&&bx.nodeType===1){var bv="data-"+bw.replace(aA,"-$1").toLowerCase();by=bx.getAttribute(bv);if(typeof by==="string"){try{by=by==="true"?true:by==="false"?false:by==="null"?null:b.isNumeric(by)?parseFloat(by):aS.test(by)?b.parseJSON(by):by}catch(bz){}b.data(bx,bw,by)}else{by=L}}return by}function S(bv){for(var e in bv){if(e==="data"&&b.isEmptyObject(bv[e])){continue}if(e!=="toJSON"){return false}}return true}function bi(by,bx,bA){var bw=bx+"defer",bv=bx+"queue",e=bx+"mark",bz=b._data(by,bw);if(bz&&(bA==="queue"||!b._data(by,bv))&&(bA==="mark"||!b._data(by,e))){setTimeout(function(){if(!b._data(by,bv)&&!b._data(by,e)){b.removeData(by,bw,true);bz.fire()}},0)}}b.extend({_mark:function(bv,e){if(bv){e=(e||"fx")+"mark";b._data(bv,e,(b._data(bv,e)||0)+1)}},_unmark:function(by,bx,bv){if(by!==true){bv=bx;bx=by;by=false}if(bx){bv=bv||"fx";var e=bv+"mark",bw=by?0:((b._data(bx,e)||1)-1);if(bw){b._data(bx,e,bw)}else{b.removeData(bx,e,true);bi(bx,bv,"mark")}}},queue:function(bv,e,bx){var bw;if(bv){e=(e||"fx")+"queue";bw=b._data(bv,e);if(bx){if(!bw||b.isArray(bx)){bw=b._data(bv,e,b.makeArray(bx))}else{bw.push(bx)}}return bw||[]}},dequeue:function(by,bx){bx=bx||"fx";var bv=b.queue(by,bx),bw=bv.shift(),e={};if(bw==="inprogress"){bw=bv.shift()}if(bw){if(bx==="fx"){bv.unshift("inprogress")}b._data(by,bx+".run",e);bw.call(by,function(){b.dequeue(by,bx)},e)}if(!bv.length){b.removeData(by,bx+"queue "+bx+".run",true);bi(by,bx,"queue")}}});b.fn.extend({queue:function(e,bv){if(typeof e!=="string"){bv=e;e="fx"}if(bv===L){return b.queue(this[0],e)}return this.each(function(){var bw=b.queue(this,e,bv);if(e==="fx"&&bw[0]!=="inprogress"){b.dequeue(this,e)}})},dequeue:function(e){return this.each(function(){b.dequeue(this,e)})},delay:function(bv,e){bv=b.fx?b.fx.speeds[bv]||bv:bv;e=e||"fx";return this.queue(e,function(bx,bw){var by=setTimeout(bx,bv);bw.stop=function(){clearTimeout(by)}})},clearQueue:function(e){return this.queue(e||"fx",[])},promise:function(bD,bw){if(typeof bD!=="string"){bw=bD;bD=L}bD=bD||"fx";var e=b.Deferred(),bv=this,by=bv.length,bB=1,bz=bD+"defer",bA=bD+"queue",bC=bD+"mark",bx;function bE(){if(!(--bB)){e.resolveWith(bv,[bv])}}while(by--){if((bx=b.data(bv[by],bz,L,true)||(b.data(bv[by],bA,L,true)||b.data(bv[by],bC,L,true))&&b.data(bv[by],bz,b.Callbacks("once memory"),true))){bB++;bx.add(bE)}}bE();return e.promise()}});var aP=/[\n\t\r]/g,af=/\s+/,aU=/\r/g,g=/^(?:button|input)$/i,D=/^(?:button|input|object|select|textarea)$/i,l=/^a(?:rea)?$/i,ao=/^(?:autofocus|autoplay|async|checked|controls|defer|disabled|hidden|loop|multiple|open|readonly|required|scoped|selected)$/i,F=b.support.getSetAttribute,be,aY,aF;b.fn.extend({attr:function(e,bv){return b.access(this,e,bv,true,b.attr)},removeAttr:function(e){return this.each(function(){b.removeAttr(this,e)})},prop:function(e,bv){return b.access(this,e,bv,true,b.prop)},removeProp:function(e){e=b.propFix[e]||e;return this.each(function(){try{this[e]=L;delete this[e]}catch(bv){}})},addClass:function(by){var bA,bw,bv,bx,bz,bB,e;if(b.isFunction(by)){return this.each(function(bC){b(this).addClass(by.call(this,bC,this.className))})}if(by&&typeof by==="string"){bA=by.split(af);for(bw=0,bv=this.length;bw<bv;bw++){bx=this[bw];if(bx.nodeType===1){if(!bx.className&&bA.length===1){bx.className=by}else{bz=" "+bx.className+" ";for(bB=0,e=bA.length;bB<e;bB++){if(!~bz.indexOf(" "+bA[bB]+" ")){bz+=bA[bB]+" "}}bx.className=b.trim(bz)}}}}return this},removeClass:function(bz){var bA,bw,bv,by,bx,bB,e;if(b.isFunction(bz)){return this.each(function(bC){b(this).removeClass(bz.call(this,bC,this.className))})}if((bz&&typeof bz==="string")||bz===L){bA=(bz||"").split(af);for(bw=0,bv=this.length;bw<bv;bw++){by=this[bw];if(by.nodeType===1&&by.className){if(bz){bx=(" "+by.className+" ").replace(aP," ");for(bB=0,e=bA.length;bB<e;bB++){bx=bx.replace(" "+bA[bB]+" "," ")}by.className=b.trim(bx)}else{by.className=""}}}}return this},toggleClass:function(bx,bv){var bw=typeof bx,e=typeof bv==="boolean";if(b.isFunction(bx)){return this.each(function(by){b(this).toggleClass(bx.call(this,by,this.className,bv),bv)})}return this.each(function(){if(bw==="string"){var bA,bz=0,by=b(this),bB=bv,bC=bx.split(af);while((bA=bC[bz++])){bB=e?bB:!by.hasClass(bA);by[bB?"addClass":"removeClass"](bA)}}else{if(bw==="undefined"||bw==="boolean"){if(this.className){b._data(this,"__className__",this.className)}this.className=this.className||bx===false?"":b._data(this,"__className__")||""}}})},hasClass:function(e){var bx=" "+e+" ",bw=0,bv=this.length;for(;bw<bv;bw++){if(this[bw].nodeType===1&&(" "+this[bw].className+" ").replace(aP," ").indexOf(bx)>-1){return true}}return false},val:function(bx){var e,bv,by,bw=this[0];if(!arguments.length){if(bw){e=b.valHooks[bw.nodeName.toLowerCase()]||b.valHooks[bw.type];if(e&&"get" in e&&(bv=e.get(bw,"value"))!==L){return bv}bv=bw.value;return typeof bv==="string"?bv.replace(aU,""):bv==null?"":bv}return}by=b.isFunction(bx);return this.each(function(bA){var bz=b(this),bB;if(this.nodeType!==1){return}if(by){bB=bx.call(this,bA,bz.val())}else{bB=bx}if(bB==null){bB=""}else{if(typeof bB==="number"){bB+=""}else{if(b.isArray(bB)){bB=b.map(bB,function(bC){return bC==null?"":bC+""})}}}e=b.valHooks[this.nodeName.toLowerCase()]||b.valHooks[this.type];if(!e||!("set" in e)||e.set(this,bB,"value")===L){this.value=bB}})}});b.extend({valHooks:{option:{get:function(e){var bv=e.attributes.value;return !bv||bv.specified?e.value:e.text}},select:{get:function(e){var bA,bv,bz,bx,by=e.selectedIndex,bB=[],bC=e.options,bw=e.type==="select-one";if(by<0){return null}bv=bw?by:0;bz=bw?by+1:bC.length;for(;bv<bz;bv++){bx=bC[bv];if(bx.selected&&(b.support.optDisabled?!bx.disabled:bx.getAttribute("disabled")===null)&&(!bx.parentNode.disabled||!b.nodeName(bx.parentNode,"optgroup"))){bA=b(bx).val();if(bw){return bA}bB.push(bA)}}if(bw&&!bB.length&&bC.length){return b(bC[by]).val()}return bB},set:function(bv,bw){var e=b.makeArray(bw);b(bv).find("option").each(function(){this.selected=b.inArray(b(this).val(),e)>=0});if(!e.length){bv.selectedIndex=-1}return e}}},attrFn:{val:true,css:true,html:true,text:true,data:true,width:true,height:true,offset:true},attr:function(bA,bx,bB,bz){var bw,e,by,bv=bA.nodeType;if(!bA||bv===3||bv===8||bv===2){return}if(bz&&bx in b.attrFn){return b(bA)[bx](bB)}if(typeof bA.getAttribute==="undefined"){return b.prop(bA,bx,bB)}by=bv!==1||!b.isXMLDoc(bA);if(by){bx=bx.toLowerCase();e=b.attrHooks[bx]||(ao.test(bx)?aY:be)}if(bB!==L){if(bB===null){b.removeAttr(bA,bx);return}else{if(e&&"set" in e&&by&&(bw=e.set(bA,bB,bx))!==L){return bw}else{bA.setAttribute(bx,""+bB);return bB}}}else{if(e&&"get" in e&&by&&(bw=e.get(bA,bx))!==null){return bw}else{bw=bA.getAttribute(bx);return bw===null?L:bw}}},removeAttr:function(bx,bz){var by,bA,bv,e,bw=0;if(bz&&bx.nodeType===1){bA=bz.toLowerCase().split(af);e=bA.length;for(;bw<e;bw++){bv=bA[bw];if(bv){by=b.propFix[bv]||bv;b.attr(bx,bv,"");bx.removeAttribute(F?bv:by);if(ao.test(bv)&&by in bx){bx[by]=false}}}}},attrHooks:{type:{set:function(e,bv){if(g.test(e.nodeName)&&e.parentNode){b.error("type property can't be changed")}else{if(!b.support.radioValue&&bv==="radio"&&b.nodeName(e,"input")){var bw=e.value;e.setAttribute("type",bv);if(bw){e.value=bw}return bv}}}},value:{get:function(bv,e){if(be&&b.nodeName(bv,"button")){return be.get(bv,e)}return e in bv?bv.value:null},set:function(bv,bw,e){if(be&&b.nodeName(bv,"button")){return be.set(bv,bw,e)}bv.value=bw}}},propFix:{tabindex:"tabIndex",readonly:"readOnly","for":"htmlFor","class":"className",maxlength:"maxLength",cellspacing:"cellSpacing",cellpadding:"cellPadding",rowspan:"rowSpan",colspan:"colSpan",usemap:"useMap",frameborder:"frameBorder",contenteditable:"contentEditable"},prop:function(bz,bx,bA){var bw,e,by,bv=bz.nodeType;if(!bz||bv===3||bv===8||bv===2){return}by=bv!==1||!b.isXMLDoc(bz);if(by){bx=b.propFix[bx]||bx;e=b.propHooks[bx]}if(bA!==L){if(e&&"set" in e&&(bw=e.set(bz,bA,bx))!==L){return bw}else{return(bz[bx]=bA)}}else{if(e&&"get" in e&&(bw=e.get(bz,bx))!==null){return bw}else{return bz[bx]}}},propHooks:{tabIndex:{get:function(bv){var e=bv.getAttributeNode("tabindex");return e&&e.specified?parseInt(e.value,10):D.test(bv.nodeName)||l.test(bv.nodeName)&&bv.href?0:L}}}});b.attrHooks.tabindex=b.propHooks.tabIndex;aY={get:function(bv,e){var bx,bw=b.prop(bv,e);return bw===true||typeof bw!=="boolean"&&(bx=bv.getAttributeNode(e))&&bx.nodeValue!==false?e.toLowerCase():L},set:function(bv,bx,e){var bw;if(bx===false){b.removeAttr(bv,e)}else{bw=b.propFix[e]||e;if(bw in bv){bv[bw]=true}bv.setAttribute(e,e.toLowerCase())}return e}};if(!F){aF={name:true,id:true};be=b.valHooks.button={get:function(bw,bv){var e;e=bw.getAttributeNode(bv);return e&&(aF[bv]?e.nodeValue!=="":e.specified)?e.nodeValue:L},set:function(bw,bx,bv){var e=bw.getAttributeNode(bv);if(!e){e=av.createAttribute(bv);bw.setAttributeNode(e)}return(e.nodeValue=bx+"")}};b.attrHooks.tabindex.set=be.set;b.each(["width","height"],function(bv,e){b.attrHooks[e]=b.extend(b.attrHooks[e],{set:function(bw,bx){if(bx===""){bw.setAttribute(e,"auto");return bx}}})});b.attrHooks.contenteditable={get:be.get,set:function(bv,bw,e){if(bw===""){bw="false"}be.set(bv,bw,e)}}}if(!b.support.hrefNormalized){b.each(["href","src","width","height"],function(bv,e){b.attrHooks[e]=b.extend(b.attrHooks[e],{get:function(bx){var bw=bx.getAttribute(e,2);return bw===null?L:bw}})})}if(!b.support.style){b.attrHooks.style={get:function(e){return e.style.cssText.toLowerCase()||L},set:function(e,bv){return(e.style.cssText=""+bv)}}}if(!b.support.optSelected){b.propHooks.selected=b.extend(b.propHooks.selected,{get:function(bv){var e=bv.parentNode;if(e){e.selectedIndex;if(e.parentNode){e.parentNode.selectedIndex}}return null}})}if(!b.support.enctype){b.propFix.enctype="encoding"}if(!b.support.checkOn){b.each(["radio","checkbox"],function(){b.valHooks[this]={get:function(e){return e.getAttribute("value")===null?"on":e.value}}})}b.each(["radio","checkbox"],function(){b.valHooks[this]=b.extend(b.valHooks[this],{set:function(e,bv){if(b.isArray(bv)){return(e.checked=b.inArray(b(e).val(),bv)>=0)}}})});var bd=/^(?:textarea|input|select)$/i,n=/^([^\.]*)?(?:\.(.+))?$/,J=/\bhover(\.\S+)?\b/,aO=/^key/,bf=/^(?:mouse|contextmenu)|click/,T=/^(?:focusinfocus|focusoutblur)$/,U=/^(\w*)(?:#([\w\-]+))?(?:\.([\w\-]+))?$/,Y=function(e){var bv=U.exec(e);if(bv){bv[1]=(bv[1]||"").toLowerCase();bv[3]=bv[3]&&new RegExp("(?:^|\\s)"+bv[3]+"(?:\\s|$)")}return bv},j=function(bw,e){var bv=bw.attributes||{};return((!e[1]||bw.nodeName.toLowerCase()===e[1])&&(!e[2]||(bv.id||{}).value===e[2])&&(!e[3]||e[3].test((bv["class"]||{}).value)))},bt=function(e){return b.event.special.hover?e:e.replace(J,"mouseenter$1 mouseleave$1")};b.event={add:function(bx,bC,bJ,bA,by){var bD,bB,bK,bI,bH,bF,e,bG,bv,bz,bw,bE;if(bx.nodeType===3||bx.nodeType===8||!bC||!bJ||!(bD=b._data(bx))){return}if(bJ.handler){bv=bJ;bJ=bv.handler}if(!bJ.guid){bJ.guid=b.guid++}bK=bD.events;if(!bK){bD.events=bK={}}bB=bD.handle;if(!bB){bD.handle=bB=function(bL){return typeof b!=="undefined"&&(!bL||b.event.triggered!==bL.type)?b.event.dispatch.apply(bB.elem,arguments):L};bB.elem=bx}bC=b.trim(bt(bC)).split(" ");for(bI=0;bI<bC.length;bI++){bH=n.exec(bC[bI])||[];bF=bH[1];e=(bH[2]||"").split(".").sort();bE=b.event.special[bF]||{};bF=(by?bE.delegateType:bE.bindType)||bF;bE=b.event.special[bF]||{};bG=b.extend({type:bF,origType:bH[1],data:bA,handler:bJ,guid:bJ.guid,selector:by,quick:Y(by),namespace:e.join(".")},bv);bw=bK[bF];if(!bw){bw=bK[bF]=[];bw.delegateCount=0;if(!bE.setup||bE.setup.call(bx,bA,e,bB)===false){if(bx.addEventListener){bx.addEventListener(bF,bB,false)}else{if(bx.attachEvent){bx.attachEvent("on"+bF,bB)}}}}if(bE.add){bE.add.call(bx,bG);if(!bG.handler.guid){bG.handler.guid=bJ.guid}}if(by){bw.splice(bw.delegateCount++,0,bG)}else{bw.push(bG)}b.event.global[bF]=true}bx=null},global:{},remove:function(bJ,bE,bv,bH,bB){var bI=b.hasData(bJ)&&b._data(bJ),bF,bx,bz,bL,bC,bA,bG,bw,by,bK,bD,e;if(!bI||!(bw=bI.events)){return}bE=b.trim(bt(bE||"")).split(" ");for(bF=0;bF<bE.length;bF++){bx=n.exec(bE[bF])||[];bz=bL=bx[1];bC=bx[2];if(!bz){for(bz in bw){b.event.remove(bJ,bz+bE[bF],bv,bH,true)}continue}by=b.event.special[bz]||{};bz=(bH?by.delegateType:by.bindType)||bz;bD=bw[bz]||[];bA=bD.length;bC=bC?new RegExp("(^|\\.)"+bC.split(".").sort().join("\\.(?:.*\\.)?")+"(\\.|$)"):null;for(bG=0;bG<bD.length;bG++){e=bD[bG];if((bB||bL===e.origType)&&(!bv||bv.guid===e.guid)&&(!bC||bC.test(e.namespace))&&(!bH||bH===e.selector||bH==="**"&&e.selector)){bD.splice(bG--,1);if(e.selector){bD.delegateCount--}if(by.remove){by.remove.call(bJ,e)}}}if(bD.length===0&&bA!==bD.length){if(!by.teardown||by.teardown.call(bJ,bC)===false){b.removeEvent(bJ,bz,bI.handle)}delete bw[bz]}}if(b.isEmptyObject(bw)){bK=bI.handle;if(bK){bK.elem=null}b.removeData(bJ,["events","handle"],true)}},customEvent:{getData:true,setData:true,changeData:true},trigger:function(bv,bD,bA,bJ){if(bA&&(bA.nodeType===3||bA.nodeType===8)){return}var bG=bv.type||bv,bx=[],e,bw,bC,bH,bz,by,bF,bE,bB,bI;if(T.test(bG+b.event.triggered)){return}if(bG.indexOf("!")>=0){bG=bG.slice(0,-1);bw=true}if(bG.indexOf(".")>=0){bx=bG.split(".");bG=bx.shift();bx.sort()}if((!bA||b.event.customEvent[bG])&&!b.event.global[bG]){return}bv=typeof bv==="object"?bv[b.expando]?bv:new b.Event(bG,bv):new b.Event(bG);bv.type=bG;bv.isTrigger=true;bv.exclusive=bw;bv.namespace=bx.join(".");bv.namespace_re=bv.namespace?new RegExp("(^|\\.)"+bx.join("\\.(?:.*\\.)?")+"(\\.|$)"):null;by=bG.indexOf(":")<0?"on"+bG:"";if(!bA){e=b.cache;for(bC in e){if(e[bC].events&&e[bC].events[bG]){b.event.trigger(bv,bD,e[bC].handle.elem,true)}}return}bv.result=L;if(!bv.target){bv.target=bA}bD=bD!=null?b.makeArray(bD):[];bD.unshift(bv);bF=b.event.special[bG]||{};if(bF.trigger&&bF.trigger.apply(bA,bD)===false){return}bB=[[bA,bF.bindType||bG]];if(!bJ&&!bF.noBubble&&!b.isWindow(bA)){bI=bF.delegateType||bG;bH=T.test(bI+bG)?bA:bA.parentNode;bz=null;for(;bH;bH=bH.parentNode){bB.push([bH,bI]);bz=bH}if(bz&&bz===bA.ownerDocument){bB.push([bz.defaultView||bz.parentWindow||bb,bI])}}for(bC=0;bC<bB.length&&!bv.isPropagationStopped();bC++){bH=bB[bC][0];bv.type=bB[bC][1];bE=(b._data(bH,"events")||{})[bv.type]&&b._data(bH,"handle");if(bE){bE.apply(bH,bD)}bE=by&&bH[by];if(bE&&b.acceptData(bH)&&bE.apply(bH,bD)===false){bv.preventDefault()}}bv.type=bG;if(!bJ&&!bv.isDefaultPrevented()){if((!bF._default||bF._default.apply(bA.ownerDocument,bD)===false)&&!(bG==="click"&&b.nodeName(bA,"a"))&&b.acceptData(bA)){if(by&&bA[bG]&&((bG!=="focus"&&bG!=="blur")||bv.target.offsetWidth!==0)&&!b.isWindow(bA)){bz=bA[by];if(bz){bA[by]=null}b.event.triggered=bG;bA[bG]();b.event.triggered=L;if(bz){bA[by]=bz}}}}return bv.result},dispatch:function(e){e=b.event.fix(e||bb.event);var bz=((b._data(this,"events")||{})[e.type]||[]),bA=bz.delegateCount,bG=[].slice.call(arguments,0),by=!e.exclusive&&!e.namespace,bH=[],bC,bB,bK,bx,bF,bE,bv,bD,bI,bw,bJ;bG[0]=e;e.delegateTarget=this;if(bA&&!e.target.disabled&&!(e.button&&e.type==="click")){bx=b(this);bx.context=this.ownerDocument||this;for(bK=e.target;bK!=this;bK=bK.parentNode||this){bE={};bD=[];bx[0]=bK;for(bC=0;bC<bA;bC++){bI=bz[bC];bw=bI.selector;if(bE[bw]===L){bE[bw]=(bI.quick?j(bK,bI.quick):bx.is(bw))}if(bE[bw]){bD.push(bI)}}if(bD.length){bH.push({elem:bK,matches:bD})}}}if(bz.length>bA){bH.push({elem:this,matches:bz.slice(bA)})}for(bC=0;bC<bH.length&&!e.isPropagationStopped();bC++){bv=bH[bC];e.currentTarget=bv.elem;for(bB=0;bB<bv.matches.length&&!e.isImmediatePropagationStopped();bB++){bI=bv.matches[bB];if(by||(!e.namespace&&!bI.namespace)||e.namespace_re&&e.namespace_re.test(bI.namespace)){e.data=bI.data;e.handleObj=bI;bF=((b.event.special[bI.origType]||{}).handle||bI.handler).apply(bv.elem,bG);if(bF!==L){e.result=bF;if(bF===false){e.preventDefault();e.stopPropagation()}}}}}return e.result},props:"attrChange attrName relatedNode srcElement altKey bubbles cancelable ctrlKey currentTarget eventPhase metaKey relatedTarget shiftKey target timeStamp view which".split(" "),fixHooks:{},keyHooks:{props:"char charCode key keyCode".split(" "),filter:function(bv,e){if(bv.which==null){bv.which=e.charCode!=null?e.charCode:e.keyCode}return bv}},mouseHooks:{props:"button buttons clientX clientY fromElement offsetX offsetY pageX pageY screenX screenY toElement".split(" "),filter:function(bx,bw){var by,bz,e,bv=bw.button,bA=bw.fromElement;if(bx.pageX==null&&bw.clientX!=null){by=bx.target.ownerDocument||av;bz=by.documentElement;e=by.body;bx.pageX=bw.clientX+(bz&&bz.scrollLeft||e&&e.scrollLeft||0)-(bz&&bz.clientLeft||e&&e.clientLeft||0);bx.pageY=bw.clientY+(bz&&bz.scrollTop||e&&e.scrollTop||0)-(bz&&bz.clientTop||e&&e.clientTop||0)}if(!bx.relatedTarget&&bA){bx.relatedTarget=bA===bx.target?bw.toElement:bA}if(!bx.which&&bv!==L){bx.which=(bv&1?1:(bv&2?3:(bv&4?2:0)))}return bx}},fix:function(bw){if(bw[b.expando]){return bw}var bv,bz,e=bw,bx=b.event.fixHooks[bw.type]||{},by=bx.props?this.props.concat(bx.props):this.props;bw=b.Event(e);for(bv=by.length;bv;){bz=by[--bv];bw[bz]=e[bz]}if(!bw.target){bw.target=e.srcElement||av}if(bw.target.nodeType===3){bw.target=bw.target.parentNode}if(bw.metaKey===L){bw.metaKey=bw.ctrlKey}return bx.filter?bx.filter(bw,e):bw},special:{ready:{setup:b.bindReady},load:{noBubble:true},focus:{delegateType:"focusin"},blur:{delegateType:"focusout"},beforeunload:{setup:function(bw,bv,e){if(b.isWindow(this)){this.onbeforeunload=e}},teardown:function(bv,e){if(this.onbeforeunload===e){this.onbeforeunload=null}}}},simulate:function(bw,by,bx,bv){var bz=b.extend(new b.Event(),bx,{type:bw,isSimulated:true,originalEvent:{}});if(bv){b.event.trigger(bz,null,by)}else{b.event.dispatch.call(by,bz)}if(bz.isDefaultPrevented()){bx.preventDefault()}}};b.event.handle=b.event.dispatch;b.removeEvent=av.removeEventListener?function(bv,e,bw){if(bv.removeEventListener){bv.removeEventListener(e,bw,false)}}:function(bv,e,bw){if(bv.detachEvent){bv.detachEvent("on"+e,bw)}};b.Event=function(bv,e){if(!(this instanceof b.Event)){return new b.Event(bv,e)}if(bv&&bv.type){this.originalEvent=bv;this.type=bv.type;this.isDefaultPrevented=(bv.defaultPrevented||bv.returnValue===false||bv.getPreventDefault&&bv.getPreventDefault())?i:bk}else{this.type=bv}if(e){b.extend(this,e)}this.timeStamp=bv&&bv.timeStamp||b.now();this[b.expando]=true};function bk(){return false}function i(){return true}b.Event.prototype={preventDefault:function(){this.isDefaultPrevented=i;var bv=this.originalEvent;if(!bv){return}if(bv.preventDefault){bv.preventDefault()}else{bv.returnValue=false}},stopPropagation:function(){this.isPropagationStopped=i;var bv=this.originalEvent;if(!bv){return}if(bv.stopPropagation){bv.stopPropagation()}bv.cancelBubble=true},stopImmediatePropagation:function(){this.isImmediatePropagationStopped=i;this.stopPropagation()},isDefaultPrevented:bk,isPropagationStopped:bk,isImmediatePropagationStopped:bk};b.each({mouseenter:"mouseover",mouseleave:"mouseout"},function(bv,e){b.event.special[bv]={delegateType:e,bindType:e,handle:function(bz){var bB=this,bA=bz.relatedTarget,by=bz.handleObj,bw=by.selector,bx;if(!bA||(bA!==bB&&!b.contains(bB,bA))){bz.type=by.origType;bx=by.handler.apply(this,arguments);bz.type=e}return bx}}});if(!b.support.submitBubbles){b.event.special.submit={setup:function(){if(b.nodeName(this,"form")){return false}b.event.add(this,"click._submit keypress._submit",function(bx){var bw=bx.target,bv=b.nodeName(bw,"input")||b.nodeName(bw,"button")?bw.form:L;if(bv&&!bv._submit_attached){b.event.add(bv,"submit._submit",function(e){if(this.parentNode&&!e.isTrigger){b.event.simulate("submit",this.parentNode,e,true)}});bv._submit_attached=true}})},teardown:function(){if(b.nodeName(this,"form")){return false}b.event.remove(this,"._submit")}}}if(!b.support.changeBubbles){b.event.special.change={setup:function(){if(bd.test(this.nodeName)){if(this.type==="checkbox"||this.type==="radio"){b.event.add(this,"propertychange._change",function(e){if(e.originalEvent.propertyName==="checked"){this._just_changed=true}});b.event.add(this,"click._change",function(e){if(this._just_changed&&!e.isTrigger){this._just_changed=false;b.event.simulate("change",this,e,true)}})}return false}b.event.add(this,"beforeactivate._change",function(bw){var bv=bw.target;if(bd.test(bv.nodeName)&&!bv._change_attached){b.event.add(bv,"change._change",function(e){if(this.parentNode&&!e.isSimulated&&!e.isTrigger){b.event.simulate("change",this.parentNode,e,true)}});bv._change_attached=true}})},handle:function(bv){var e=bv.target;if(this!==e||bv.isSimulated||bv.isTrigger||(e.type!=="radio"&&e.type!=="checkbox")){return bv.handleObj.handler.apply(this,arguments)}},teardown:function(){b.event.remove(this,"._change");return bd.test(this.nodeName)}}}if(!b.support.focusinBubbles){b.each({focus:"focusin",blur:"focusout"},function(bx,e){var bv=0,bw=function(by){b.event.simulate(e,by.target,b.event.fix(by),true)};b.event.special[e]={setup:function(){if(bv++===0){av.addEventListener(bx,bw,true)}},teardown:function(){if(--bv===0){av.removeEventListener(bx,bw,true)}}}})}b.fn.extend({on:function(bw,e,bz,by,bv){var bA,bx;if(typeof bw==="object"){if(typeof e!=="string"){bz=e;e=L}for(bx in bw){this.on(bx,e,bz,bw[bx],bv)}return this}if(bz==null&&by==null){by=e;bz=e=L}else{if(by==null){if(typeof e==="string"){by=bz;bz=L}else{by=bz;bz=e;e=L}}}if(by===false){by=bk}else{if(!by){return this}}if(bv===1){bA=by;by=function(bB){b().off(bB);return bA.apply(this,arguments)};by.guid=bA.guid||(bA.guid=b.guid++)}return this.each(function(){b.event.add(this,bw,by,bz,e)})},one:function(bv,e,bx,bw){return this.on.call(this,bv,e,bx,bw,1)},off:function(bw,e,by){if(bw&&bw.preventDefault&&bw.handleObj){var bv=bw.handleObj;b(bw.delegateTarget).off(bv.namespace?bv.type+"."+bv.namespace:bv.type,bv.selector,bv.handler);return this}if(typeof bw==="object"){for(var bx in bw){this.off(bx,e,bw[bx])}return this}if(e===false||typeof e==="function"){by=e;e=L}if(by===false){by=bk}return this.each(function(){b.event.remove(this,bw,by,e)})},bind:function(e,bw,bv){return this.on(e,null,bw,bv)},unbind:function(e,bv){return this.off(e,null,bv)},live:function(e,bw,bv){b(this.context).on(e,this.selector,bw,bv);return this},die:function(e,bv){b(this.context).off(e,this.selector||"**",bv);return this},delegate:function(e,bv,bx,bw){return this.on(bv,e,bx,bw)},undelegate:function(e,bv,bw){return arguments.length==1?this.off(e,"**"):this.off(bv,e,bw)},trigger:function(e,bv){return this.each(function(){b.event.trigger(e,bv,this)})},triggerHandler:function(e,bv){if(this[0]){return b.event.trigger(e,bv,this[0],true)}},toggle:function(bx){var bv=arguments,e=bx.guid||b.guid++,bw=0,by=function(bz){var bA=(b._data(this,"lastToggle"+bx.guid)||0)%bw;b._data(this,"lastToggle"+bx.guid,bA+1);bz.preventDefault();return bv[bA].apply(this,arguments)||false};by.guid=e;while(bw<bv.length){bv[bw++].guid=e}return this.click(by)},hover:function(e,bv){return this.mouseenter(e).mouseleave(bv||e)}});b.each(("blur focus focusin focusout load resize scroll unload click dblclick mousedown mouseup mousemove mouseover mouseout mouseenter mouseleave change select submit keydown keypress keyup error contextmenu").split(" "),function(bv,e){b.fn[e]=function(bx,bw){if(bw==null){bw=bx;bx=null}return arguments.length>0?this.on(e,null,bx,bw):this.trigger(e)};if(b.attrFn){b.attrFn[e]=true}if(aO.test(e)){b.event.fixHooks[e]=b.event.keyHooks}if(bf.test(e)){b.event.fixHooks[e]=b.event.mouseHooks}});
(function(){var bH=/((?:\((?:\([^()]+\)|[^()]+)+\)|\[(?:\[[^\[\]]*\]|['"][^'"]*['"]|[^\[\]'"]+)+\]|\\.|[^ >+~,(\[\\]+)+|[>+~])(\s*,\s*)?((?:.|\r|\n)*)/g,bC="sizcache"+(Math.random()+"").replace(".",""),bI=0,bL=Object.prototype.toString,bB=false,bA=true,bK=/\\/g,bO=/\r\n/g,bQ=/\W/;[0,0].sort(function(){bA=false;return 0});var by=function(bV,e,bY,bZ){bY=bY||[];e=e||av;var b1=e;if(e.nodeType!==1&&e.nodeType!==9){return[]}if(!bV||typeof bV!=="string"){return bY}var bS,b3,b6,bR,b2,b5,b4,bX,bU=true,bT=by.isXML(e),bW=[],b0=bV;do{bH.exec("");bS=bH.exec(b0);if(bS){b0=bS[3];bW.push(bS[1]);if(bS[2]){bR=bS[3];break}}}while(bS);if(bW.length>1&&bD.exec(bV)){if(bW.length===2&&bE.relative[bW[0]]){b3=bM(bW[0]+bW[1],e,bZ)}else{b3=bE.relative[bW[0]]?[e]:by(bW.shift(),e);while(bW.length){bV=bW.shift();if(bE.relative[bV]){bV+=bW.shift()}b3=bM(bV,b3,bZ)}}}else{if(!bZ&&bW.length>1&&e.nodeType===9&&!bT&&bE.match.ID.test(bW[0])&&!bE.match.ID.test(bW[bW.length-1])){b2=by.find(bW.shift(),e,bT);e=b2.expr?by.filter(b2.expr,b2.set)[0]:b2.set[0]}if(e){b2=bZ?{expr:bW.pop(),set:bF(bZ)}:by.find(bW.pop(),bW.length===1&&(bW[0]==="~"||bW[0]==="+")&&e.parentNode?e.parentNode:e,bT);b3=b2.expr?by.filter(b2.expr,b2.set):b2.set;if(bW.length>0){b6=bF(b3)}else{bU=false}while(bW.length){b5=bW.pop();b4=b5;if(!bE.relative[b5]){b5=""}else{b4=bW.pop()}if(b4==null){b4=e}bE.relative[b5](b6,b4,bT)}}else{b6=bW=[]}}if(!b6){b6=b3}if(!b6){by.error(b5||bV)}if(bL.call(b6)==="[object Array]"){if(!bU){bY.push.apply(bY,b6)}else{if(e&&e.nodeType===1){for(bX=0;b6[bX]!=null;bX++){if(b6[bX]&&(b6[bX]===true||b6[bX].nodeType===1&&by.contains(e,b6[bX]))){bY.push(b3[bX])}}}else{for(bX=0;b6[bX]!=null;bX++){if(b6[bX]&&b6[bX].nodeType===1){bY.push(b3[bX])}}}}}else{bF(b6,bY)}if(bR){by(bR,b1,bY,bZ);by.uniqueSort(bY)}return bY};by.uniqueSort=function(bR){if(bJ){bB=bA;bR.sort(bJ);if(bB){for(var e=1;e<bR.length;e++){if(bR[e]===bR[e-1]){bR.splice(e--,1)}}}}return bR};by.matches=function(e,bR){return by(e,null,null,bR)};by.matchesSelector=function(e,bR){return by(bR,null,null,[e]).length>0};by.find=function(bX,e,bY){var bW,bS,bU,bT,bV,bR;if(!bX){return[]}for(bS=0,bU=bE.order.length;bS<bU;bS++){bV=bE.order[bS];if((bT=bE.leftMatch[bV].exec(bX))){bR=bT[1];bT.splice(1,1);if(bR.substr(bR.length-1)!=="\\"){bT[1]=(bT[1]||"").replace(bK,"");bW=bE.find[bV](bT,e,bY);if(bW!=null){bX=bX.replace(bE.match[bV],"");break}}}}if(!bW){bW=typeof e.getElementsByTagName!=="undefined"?e.getElementsByTagName("*"):[]}return{set:bW,expr:bX}};by.filter=function(b1,b0,b4,bU){var bW,e,bZ,b6,b3,bR,bT,bV,b2,bS=b1,b5=[],bY=b0,bX=b0&&b0[0]&&by.isXML(b0[0]);while(b1&&b0.length){for(bZ in bE.filter){if((bW=bE.leftMatch[bZ].exec(b1))!=null&&bW[2]){bR=bE.filter[bZ];bT=bW[1];e=false;bW.splice(1,1);if(bT.substr(bT.length-1)==="\\"){continue}if(bY===b5){b5=[]}if(bE.preFilter[bZ]){bW=bE.preFilter[bZ](bW,bY,b4,b5,bU,bX);if(!bW){e=b6=true}else{if(bW===true){continue}}}if(bW){for(bV=0;(b3=bY[bV])!=null;bV++){if(b3){b6=bR(b3,bW,bV,bY);b2=bU^b6;if(b4&&b6!=null){if(b2){e=true}else{bY[bV]=false}}else{if(b2){b5.push(b3);e=true}}}}}if(b6!==L){if(!b4){bY=b5}b1=b1.replace(bE.match[bZ],"");if(!e){return[]}break}}}if(b1===bS){if(e==null){by.error(b1)}else{break}}bS=b1}return bY};by.error=function(e){throw new Error("Syntax error, unrecognized expression: "+e)};var bw=by.getText=function(bU){var bS,bT,e=bU.nodeType,bR="";if(e){if(e===1||e===9){if(typeof bU.textContent==="string"){return bU.textContent}else{if(typeof bU.innerText==="string"){return bU.innerText.replace(bO,"")}else{for(bU=bU.firstChild;bU;bU=bU.nextSibling){bR+=bw(bU)}}}}else{if(e===3||e===4){return bU.nodeValue}}}else{for(bS=0;(bT=bU[bS]);bS++){if(bT.nodeType!==8){bR+=bw(bT)}}}return bR};var bE=by.selectors={order:["ID","NAME","TAG"],match:{ID:/#((?:[\w\u00c0-\uFFFF\-]|\\.)+)/,CLASS:/\.((?:[\w\u00c0-\uFFFF\-]|\\.)+)/,NAME:/\[name=['"]*((?:[\w\u00c0-\uFFFF\-]|\\.)+)['"]*\]/,ATTR:/\[\s*((?:[\w\u00c0-\uFFFF\-]|\\.)+)\s*(?:(\S?=)\s*(?:(['"])(.*?)\3|(#?(?:[\w\u00c0-\uFFFF\-]|\\.)*)|)|)\s*\]/,TAG:/^((?:[\w\u00c0-\uFFFF\*\-]|\\.)+)/,CHILD:/:(only|nth|last|first)-child(?:\(\s*(even|odd|(?:[+\-]?\d+|(?:[+\-]?\d*)?n\s*(?:[+\-]\s*\d+)?))\s*\))?/,POS:/:(nth|eq|gt|lt|first|last|even|odd)(?:\((\d*)\))?(?=[^\-]|$)/,PSEUDO:/:((?:[\w\u00c0-\uFFFF\-]|\\.)+)(?:\((['"]?)((?:\([^\)]+\)|[^\(\)]*)+)\2\))?/},leftMatch:{},attrMap:{"class":"className","for":"htmlFor"},attrHandle:{href:function(e){return e.getAttribute("href")},type:function(e){return e.getAttribute("type")}},relative:{"+":function(bW,bR){var bT=typeof bR==="string",bV=bT&&!bQ.test(bR),bX=bT&&!bV;if(bV){bR=bR.toLowerCase()}for(var bS=0,e=bW.length,bU;bS<e;bS++){if((bU=bW[bS])){while((bU=bU.previousSibling)&&bU.nodeType!==1){}bW[bS]=bX||bU&&bU.nodeName.toLowerCase()===bR?bU||false:bU===bR}}if(bX){by.filter(bR,bW,true)}},">":function(bW,bR){var bV,bU=typeof bR==="string",bS=0,e=bW.length;if(bU&&!bQ.test(bR)){bR=bR.toLowerCase();for(;bS<e;bS++){bV=bW[bS];if(bV){var bT=bV.parentNode;bW[bS]=bT.nodeName.toLowerCase()===bR?bT:false}}}else{for(;bS<e;bS++){bV=bW[bS];if(bV){bW[bS]=bU?bV.parentNode:bV.parentNode===bR}}if(bU){by.filter(bR,bW,true)}}},"":function(bT,bR,bV){var bU,bS=bI++,e=bN;if(typeof bR==="string"&&!bQ.test(bR)){bR=bR.toLowerCase();bU=bR;e=bv}e("parentNode",bR,bS,bT,bU,bV)},"~":function(bT,bR,bV){var bU,bS=bI++,e=bN;if(typeof bR==="string"&&!bQ.test(bR)){bR=bR.toLowerCase();bU=bR;e=bv}e("previousSibling",bR,bS,bT,bU,bV)}},find:{ID:function(bR,bS,bT){if(typeof bS.getElementById!=="undefined"&&!bT){var e=bS.getElementById(bR[1]);return e&&e.parentNode?[e]:[]}},NAME:function(bS,bV){if(typeof bV.getElementsByName!=="undefined"){var bR=[],bU=bV.getElementsByName(bS[1]);for(var bT=0,e=bU.length;bT<e;bT++){if(bU[bT].getAttribute("name")===bS[1]){bR.push(bU[bT])}}return bR.length===0?null:bR}},TAG:function(e,bR){if(typeof bR.getElementsByTagName!=="undefined"){return bR.getElementsByTagName(e[1])}}},preFilter:{CLASS:function(bT,bR,bS,e,bW,bX){bT=" "+bT[1].replace(bK,"")+" ";if(bX){return bT}for(var bU=0,bV;(bV=bR[bU])!=null;bU++){if(bV){if(bW^(bV.className&&(" "+bV.className+" ").replace(/[\t\n\r]/g," ").indexOf(bT)>=0)){if(!bS){e.push(bV)}}else{if(bS){bR[bU]=false}}}}return false},ID:function(e){return e[1].replace(bK,"")},TAG:function(bR,e){return bR[1].replace(bK,"").toLowerCase()},CHILD:function(e){if(e[1]==="nth"){if(!e[2]){by.error(e[0])}e[2]=e[2].replace(/^\+|\s*/g,"");var bR=/(-?)(\d*)(?:n([+\-]?\d*))?/.exec(e[2]==="even"&&"2n"||e[2]==="odd"&&"2n+1"||!/\D/.test(e[2])&&"0n+"+e[2]||e[2]);e[2]=(bR[1]+(bR[2]||1))-0;e[3]=bR[3]-0}else{if(e[2]){by.error(e[0])}}e[0]=bI++;return e},ATTR:function(bU,bR,bS,e,bV,bW){var bT=bU[1]=bU[1].replace(bK,"");if(!bW&&bE.attrMap[bT]){bU[1]=bE.attrMap[bT]}bU[4]=(bU[4]||bU[5]||"").replace(bK,"");if(bU[2]==="~="){bU[4]=" "+bU[4]+" "}return bU},PSEUDO:function(bU,bR,bS,e,bV){if(bU[1]==="not"){if((bH.exec(bU[3])||"").length>1||/^\w/.test(bU[3])){bU[3]=by(bU[3],null,null,bR)}else{var bT=by.filter(bU[3],bR,bS,true^bV);if(!bS){e.push.apply(e,bT)}return false}}else{if(bE.match.POS.test(bU[0])||bE.match.CHILD.test(bU[0])){return true}}return bU},POS:function(e){e.unshift(true);return e}},filters:{enabled:function(e){return e.disabled===false&&e.type!=="hidden"},disabled:function(e){return e.disabled===true},checked:function(e){return e.checked===true},selected:function(e){if(e.parentNode){e.parentNode.selectedIndex}return e.selected===true},parent:function(e){return !!e.firstChild},empty:function(e){return !e.firstChild},has:function(bS,bR,e){return !!by(e[3],bS).length},header:function(e){return(/h\d/i).test(e.nodeName)},text:function(bS){var e=bS.getAttribute("type"),bR=bS.type;return bS.nodeName.toLowerCase()==="input"&&"text"===bR&&(e===bR||e===null)},radio:function(e){return e.nodeName.toLowerCase()==="input"&&"radio"===e.type},checkbox:function(e){return e.nodeName.toLowerCase()==="input"&&"checkbox"===e.type},file:function(e){return e.nodeName.toLowerCase()==="input"&&"file"===e.type},password:function(e){return e.nodeName.toLowerCase()==="input"&&"password"===e.type},submit:function(bR){var e=bR.nodeName.toLowerCase();return(e==="input"||e==="button")&&"submit"===bR.type},image:function(e){return e.nodeName.toLowerCase()==="input"&&"image"===e.type},reset:function(bR){var e=bR.nodeName.toLowerCase();return(e==="input"||e==="button")&&"reset"===bR.type},button:function(bR){var e=bR.nodeName.toLowerCase();return e==="input"&&"button"===bR.type||e==="button"},input:function(e){return(/input|select|textarea|button/i).test(e.nodeName)},focus:function(e){return e===e.ownerDocument.activeElement}},setFilters:{first:function(bR,e){return e===0},last:function(bS,bR,e,bT){return bR===bT.length-1},even:function(bR,e){return e%2===0},odd:function(bR,e){return e%2===1},lt:function(bS,bR,e){return bR<e[3]-0},gt:function(bS,bR,e){return bR>e[3]-0},nth:function(bS,bR,e){return e[3]-0===bR},eq:function(bS,bR,e){return e[3]-0===bR}},filter:{PSEUDO:function(bS,bX,bW,bY){var e=bX[1],bR=bE.filters[e];if(bR){return bR(bS,bW,bX,bY)}else{if(e==="contains"){return(bS.textContent||bS.innerText||bw([bS])||"").indexOf(bX[3])>=0}else{if(e==="not"){var bT=bX[3];for(var bV=0,bU=bT.length;bV<bU;bV++){if(bT[bV]===bS){return false}}return true}else{by.error(e)}}}},CHILD:function(bS,bU){var bT,b0,bW,bZ,e,bV,bY,bX=bU[1],bR=bS;switch(bX){case"only":case"first":while((bR=bR.previousSibling)){if(bR.nodeType===1){return false}}if(bX==="first"){return true}bR=bS;case"last":while((bR=bR.nextSibling)){if(bR.nodeType===1){return false}}return true;case"nth":bT=bU[2];b0=bU[3];if(bT===1&&b0===0){return true}bW=bU[0];bZ=bS.parentNode;if(bZ&&(bZ[bC]!==bW||!bS.nodeIndex)){bV=0;for(bR=bZ.firstChild;bR;bR=bR.nextSibling){if(bR.nodeType===1){bR.nodeIndex=++bV}}bZ[bC]=bW}bY=bS.nodeIndex-b0;if(bT===0){return bY===0}else{return(bY%bT===0&&bY/bT>=0)}}},ID:function(bR,e){return bR.nodeType===1&&bR.getAttribute("id")===e},TAG:function(bR,e){return(e==="*"&&bR.nodeType===1)||!!bR.nodeName&&bR.nodeName.toLowerCase()===e},CLASS:function(bR,e){return(" "+(bR.className||bR.getAttribute("class"))+" ").indexOf(e)>-1},ATTR:function(bV,bT){var bS=bT[1],e=by.attr?by.attr(bV,bS):bE.attrHandle[bS]?bE.attrHandle[bS](bV):bV[bS]!=null?bV[bS]:bV.getAttribute(bS),bW=e+"",bU=bT[2],bR=bT[4];return e==null?bU==="!=":!bU&&by.attr?e!=null:bU==="="?bW===bR:bU==="*="?bW.indexOf(bR)>=0:bU==="~="?(" "+bW+" ").indexOf(bR)>=0:!bR?bW&&e!==false:bU==="!="?bW!==bR:bU==="^="?bW.indexOf(bR)===0:bU==="$="?bW.substr(bW.length-bR.length)===bR:bU==="|="?bW===bR||bW.substr(0,bR.length+1)===bR+"-":false},POS:function(bU,bR,bS,bV){var e=bR[2],bT=bE.setFilters[e];if(bT){return bT(bU,bS,bR,bV)}}}};var bD=bE.match.POS,bx=function(bR,e){return"\\"+(e-0+1)};for(var bz in bE.match){bE.match[bz]=new RegExp(bE.match[bz].source+(/(?![^\[]*\])(?![^\(]*\))/.source));bE.leftMatch[bz]=new RegExp(/(^(?:.|\r|\n)*?)/.source+bE.match[bz].source.replace(/\\(\d+)/g,bx))}var bF=function(bR,e){bR=Array.prototype.slice.call(bR,0);if(e){e.push.apply(e,bR);return e}return bR};try{Array.prototype.slice.call(av.documentElement.childNodes,0)[0].nodeType}catch(bP){bF=function(bU,bT){var bS=0,bR=bT||[];if(bL.call(bU)==="[object Array]"){Array.prototype.push.apply(bR,bU)}else{if(typeof bU.length==="number"){for(var e=bU.length;bS<e;bS++){bR.push(bU[bS])}}else{for(;bU[bS];bS++){bR.push(bU[bS])}}}return bR}}var bJ,bG;if(av.documentElement.compareDocumentPosition){bJ=function(bR,e){if(bR===e){bB=true;return 0}if(!bR.compareDocumentPosition||!e.compareDocumentPosition){return bR.compareDocumentPosition?-1:1}return bR.compareDocumentPosition(e)&4?-1:1}}else{bJ=function(bY,bX){if(bY===bX){bB=true;return 0}else{if(bY.sourceIndex&&bX.sourceIndex){return bY.sourceIndex-bX.sourceIndex}}var bV,bR,bS=[],e=[],bU=bY.parentNode,bW=bX.parentNode,bZ=bU;if(bU===bW){return bG(bY,bX)}else{if(!bU){return -1}else{if(!bW){return 1}}}while(bZ){bS.unshift(bZ);bZ=bZ.parentNode}bZ=bW;while(bZ){e.unshift(bZ);bZ=bZ.parentNode}bV=bS.length;bR=e.length;for(var bT=0;bT<bV&&bT<bR;bT++){if(bS[bT]!==e[bT]){return bG(bS[bT],e[bT])}}return bT===bV?bG(bY,e[bT],-1):bG(bS[bT],bX,1)};bG=function(bR,e,bS){if(bR===e){return bS}var bT=bR.nextSibling;while(bT){if(bT===e){return -1}bT=bT.nextSibling}return 1}}(function(){var bR=av.createElement("div"),bS="script"+(new Date()).getTime(),e=av.documentElement;bR.innerHTML="<a name='"+bS+"'/>";e.insertBefore(bR,e.firstChild);if(av.getElementById(bS)){bE.find.ID=function(bU,bV,bW){if(typeof bV.getElementById!=="undefined"&&!bW){var bT=bV.getElementById(bU[1]);return bT?bT.id===bU[1]||typeof bT.getAttributeNode!=="undefined"&&bT.getAttributeNode("id").nodeValue===bU[1]?[bT]:L:[]}};bE.filter.ID=function(bV,bT){var bU=typeof bV.getAttributeNode!=="undefined"&&bV.getAttributeNode("id");return bV.nodeType===1&&bU&&bU.nodeValue===bT}}e.removeChild(bR);e=bR=null})();(function(){var e=av.createElement("div");e.appendChild(av.createComment(""));if(e.getElementsByTagName("*").length>0){bE.find.TAG=function(bR,bV){var bU=bV.getElementsByTagName(bR[1]);if(bR[1]==="*"){var bT=[];for(var bS=0;bU[bS];bS++){if(bU[bS].nodeType===1){bT.push(bU[bS])}}bU=bT}return bU}}e.innerHTML="<a href='#'></a>";if(e.firstChild&&typeof e.firstChild.getAttribute!=="undefined"&&e.firstChild.getAttribute("href")!=="#"){bE.attrHandle.href=function(bR){return bR.getAttribute("href",2)}}e=null})();if(av.querySelectorAll){(function(){var e=by,bT=av.createElement("div"),bS="__sizzle__";bT.innerHTML="<p class='TEST'></p>";if(bT.querySelectorAll&&bT.querySelectorAll(".TEST").length===0){return}by=function(b4,bV,bZ,b3){bV=bV||av;if(!b3&&!by.isXML(bV)){var b2=/^(\w+$)|^\.([\w\-]+$)|^#([\w\-]+$)/.exec(b4);if(b2&&(bV.nodeType===1||bV.nodeType===9)){if(b2[1]){return bF(bV.getElementsByTagName(b4),bZ)}else{if(b2[2]&&bE.find.CLASS&&bV.getElementsByClassName){return bF(bV.getElementsByClassName(b2[2]),bZ)}}}if(bV.nodeType===9){if(b4==="body"&&bV.body){return bF([bV.body],bZ)}else{if(b2&&b2[3]){var bY=bV.getElementById(b2[3]);if(bY&&bY.parentNode){if(bY.id===b2[3]){return bF([bY],bZ)}}else{return bF([],bZ)}}}try{return bF(bV.querySelectorAll(b4),bZ)}catch(b0){}}else{if(bV.nodeType===1&&bV.nodeName.toLowerCase()!=="object"){var bW=bV,bX=bV.getAttribute("id"),bU=bX||bS,b6=bV.parentNode,b5=/^\s*[+~]/.test(b4);if(!bX){bV.setAttribute("id",bU)}else{bU=bU.replace(/'/g,"\\$&")}if(b5&&b6){bV=bV.parentNode}try{if(!b5||b6){return bF(bV.querySelectorAll("[id='"+bU+"'] "+b4),bZ)}}catch(b1){}finally{if(!bX){bW.removeAttribute("id")}}}}}return e(b4,bV,bZ,b3)};for(var bR in e){by[bR]=e[bR]}bT=null})()}(function(){var e=av.documentElement,bS=e.matchesSelector||e.mozMatchesSelector||e.webkitMatchesSelector||e.msMatchesSelector;if(bS){var bU=!bS.call(av.createElement("div"),"div"),bR=false;try{bS.call(av.documentElement,"[test!='']:sizzle")}catch(bT){bR=true}by.matchesSelector=function(bW,bY){bY=bY.replace(/\=\s*([^'"\]]*)\s*\]/g,"='$1']");if(!by.isXML(bW)){try{if(bR||!bE.match.PSEUDO.test(bY)&&!/!=/.test(bY)){var bV=bS.call(bW,bY);if(bV||!bU||bW.document&&bW.document.nodeType!==11){return bV}}}catch(bX){}}return by(bY,null,null,[bW]).length>0}}})();(function(){var e=av.createElement("div");e.innerHTML="<div class='test e'></div><div class='test'></div>";if(!e.getElementsByClassName||e.getElementsByClassName("e").length===0){return}e.lastChild.className="e";if(e.getElementsByClassName("e").length===1){return}bE.order.splice(1,0,"CLASS");bE.find.CLASS=function(bR,bS,bT){if(typeof bS.getElementsByClassName!=="undefined"&&!bT){return bS.getElementsByClassName(bR[1])}};e=null})();function bv(bR,bW,bV,bZ,bX,bY){for(var bT=0,bS=bZ.length;bT<bS;bT++){var e=bZ[bT];if(e){var bU=false;e=e[bR];while(e){if(e[bC]===bV){bU=bZ[e.sizset];break}if(e.nodeType===1&&!bY){e[bC]=bV;e.sizset=bT}if(e.nodeName.toLowerCase()===bW){bU=e;break}e=e[bR]}bZ[bT]=bU}}}function bN(bR,bW,bV,bZ,bX,bY){for(var bT=0,bS=bZ.length;bT<bS;bT++){var e=bZ[bT];if(e){var bU=false;e=e[bR];while(e){if(e[bC]===bV){bU=bZ[e.sizset];break}if(e.nodeType===1){if(!bY){e[bC]=bV;e.sizset=bT}if(typeof bW!=="string"){if(e===bW){bU=true;break}}else{if(by.filter(bW,[e]).length>0){bU=e;break}}}e=e[bR]}bZ[bT]=bU}}}if(av.documentElement.contains){by.contains=function(bR,e){return bR!==e&&(bR.contains?bR.contains(e):true)}}else{if(av.documentElement.compareDocumentPosition){by.contains=function(bR,e){return !!(bR.compareDocumentPosition(e)&16)}}else{by.contains=function(){return false}}}by.isXML=function(e){var bR=(e?e.ownerDocument||e:0).documentElement;return bR?bR.nodeName!=="HTML":false};var bM=function(bS,e,bW){var bV,bX=[],bU="",bY=e.nodeType?[e]:e;while((bV=bE.match.PSEUDO.exec(bS))){bU+=bV[0];bS=bS.replace(bE.match.PSEUDO,"")}bS=bE.relative[bS]?bS+"*":bS;for(var bT=0,bR=bY.length;bT<bR;bT++){by(bS,bY[bT],bX,bW)}return by.filter(bU,bX)};by.attr=b.attr;by.selectors.attrMap={};b.find=by;b.expr=by.selectors;b.expr[":"]=b.expr.filters;b.unique=by.uniqueSort;b.text=by.getText;b.isXMLDoc=by.isXML;b.contains=by.contains})();var ab=/Until$/,aq=/^(?:parents|prevUntil|prevAll)/,a9=/,/,bp=/^.[^:#\[\.,]*$/,P=Array.prototype.slice,H=b.expr.match.POS,ay={children:true,contents:true,next:true,prev:true};b.fn.extend({find:function(e){var bw=this,by,bv;if(typeof e!=="string"){return b(e).filter(function(){for(by=0,bv=bw.length;by<bv;by++){if(b.contains(bw[by],this)){return true}}})}var bx=this.pushStack("","find",e),bA,bB,bz;for(by=0,bv=this.length;by<bv;by++){bA=bx.length;b.find(e,this[by],bx);if(by>0){for(bB=bA;bB<bx.length;bB++){for(bz=0;bz<bA;bz++){if(bx[bz]===bx[bB]){bx.splice(bB--,1);break}}}}}return bx},has:function(bv){var e=b(bv);return this.filter(function(){for(var bx=0,bw=e.length;bx<bw;bx++){if(b.contains(this,e[bx])){return true}}})},not:function(e){return this.pushStack(aG(this,e,false),"not",e)},filter:function(e){return this.pushStack(aG(this,e,true),"filter",e)},is:function(e){return !!e&&(typeof e==="string"?H.test(e)?b(e,this.context).index(this[0])>=0:b.filter(e,this).length>0:this.filter(e).length>0)},closest:function(by,bx){var bv=[],bw,e,bz=this[0];if(b.isArray(by)){var bB=1;while(bz&&bz.ownerDocument&&bz!==bx){for(bw=0;bw<by.length;bw++){if(b(bz).is(by[bw])){bv.push({selector:by[bw],elem:bz,level:bB})}}bz=bz.parentNode;bB++}return bv}var bA=H.test(by)||typeof by!=="string"?b(by,bx||this.context):0;for(bw=0,e=this.length;bw<e;bw++){bz=this[bw];while(bz){if(bA?bA.index(bz)>-1:b.find.matchesSelector(bz,by)){bv.push(bz);break}else{bz=bz.parentNode;if(!bz||!bz.ownerDocument||bz===bx||bz.nodeType===11){break}}}}bv=bv.length>1?b.unique(bv):bv;return this.pushStack(bv,"closest",by)},index:function(e){if(!e){return(this[0]&&this[0].parentNode)?this.prevAll().length:-1}if(typeof e==="string"){return b.inArray(this[0],b(e))}return b.inArray(e.jquery?e[0]:e,this)},add:function(e,bv){var bx=typeof e==="string"?b(e,bv):b.makeArray(e&&e.nodeType?[e]:e),bw=b.merge(this.get(),bx);return this.pushStack(C(bx[0])||C(bw[0])?bw:b.unique(bw))},andSelf:function(){return this.add(this.prevObject)}});function C(e){return !e||!e.parentNode||e.parentNode.nodeType===11}b.each({parent:function(bv){var e=bv.parentNode;return e&&e.nodeType!==11?e:null},parents:function(e){return b.dir(e,"parentNode")},parentsUntil:function(bv,e,bw){return b.dir(bv,"parentNode",bw)},next:function(e){return b.nth(e,2,"nextSibling")},prev:function(e){return b.nth(e,2,"previousSibling")},nextAll:function(e){return b.dir(e,"nextSibling")},prevAll:function(e){return b.dir(e,"previousSibling")},nextUntil:function(bv,e,bw){return b.dir(bv,"nextSibling",bw)},prevUntil:function(bv,e,bw){return b.dir(bv,"previousSibling",bw)},siblings:function(e){return b.sibling(e.parentNode.firstChild,e)},children:function(e){return b.sibling(e.firstChild)},contents:function(e){return b.nodeName(e,"iframe")?e.contentDocument||e.contentWindow.document:b.makeArray(e.childNodes)}},function(e,bv){b.fn[e]=function(by,bw){var bx=b.map(this,bv,by);if(!ab.test(e)){bw=by}if(bw&&typeof bw==="string"){bx=b.filter(bw,bx)}bx=this.length>1&&!ay[e]?b.unique(bx):bx;if((this.length>1||a9.test(bw))&&aq.test(e)){bx=bx.reverse()}return this.pushStack(bx,e,P.call(arguments).join(","))}});b.extend({filter:function(bw,e,bv){if(bv){bw=":not("+bw+")"}return e.length===1?b.find.matchesSelector(e[0],bw)?[e[0]]:[]:b.find.matches(bw,e)},dir:function(bw,bv,by){var e=[],bx=bw[bv];while(bx&&bx.nodeType!==9&&(by===L||bx.nodeType!==1||!b(bx).is(by))){if(bx.nodeType===1){e.push(bx)}bx=bx[bv]}return e},nth:function(by,e,bw,bx){e=e||1;var bv=0;for(;by;by=by[bw]){if(by.nodeType===1&&++bv===e){break}}return by},sibling:function(bw,bv){var e=[];for(;bw;bw=bw.nextSibling){if(bw.nodeType===1&&bw!==bv){e.push(bw)}}return e}});function aG(bx,bw,e){bw=bw||0;if(b.isFunction(bw)){return b.grep(bx,function(bz,by){var bA=!!bw.call(bz,by,bz);return bA===e})}else{if(bw.nodeType){return b.grep(bx,function(bz,by){return(bz===bw)===e})}else{if(typeof bw==="string"){var bv=b.grep(bx,function(by){return by.nodeType===1});if(bp.test(bw)){return b.filter(bw,bv,!e)}else{bw=b.filter(bw,bv)}}}}return b.grep(bx,function(bz,by){return(b.inArray(bz,bw)>=0)===e})}function a(e){var bw=aR.split("|"),bv=e.createDocumentFragment();if(bv.createElement){while(bw.length){bv.createElement(bw.pop())}}return bv}var aR="abbr|article|aside|audio|canvas|datalist|details|figcaption|figure|footer|header|hgroup|mark|meter|nav|output|progress|section|summary|time|video",ag=/ jQuery\d+="(?:\d+|null)"/g,ar=/^\s+/,R=/<(?!area|br|col|embed|hr|img|input|link|meta|param)(([\w:]+)[^>]*)\/>/ig,d=/<([\w:]+)/,w=/<tbody/i,W=/<|&#?\w+;/,ae=/<(?:script|style)/i,O=/<(?:script|object|embed|option|style)/i,ah=new RegExp("<(?:"+aR+")","i"),o=/checked\s*(?:[^=]|=\s*.checked.)/i,bm=/\/(java|ecma)script/i,aN=/^\s*<!(?:\[CDATA\[|\-\-)/,ax={option:[1,"<select multiple='multiple'>","</select>"],legend:[1,"<fieldset>","</fieldset>"],thead:[1,"<table>","</table>"],tr:[2,"<table><tbody>","</tbody></table>"],td:[3,"<table><tbody><tr>","</tr></tbody></table>"],col:[2,"<table><tbody></tbody><colgroup>","</colgroup></table>"],area:[1,"<map>","</map>"],_default:[0,"",""]},ac=a(av);ax.optgroup=ax.option;ax.tbody=ax.tfoot=ax.colgroup=ax.caption=ax.thead;ax.th=ax.td;if(!b.support.htmlSerialize){ax._default=[1,"div<div>","</div>"]}b.fn.extend({text:function(e){if(b.isFunction(e)){return this.each(function(bw){var bv=b(this);bv.text(e.call(this,bw,bv.text()))})}if(typeof e!=="object"&&e!==L){return this.empty().append((this[0]&&this[0].ownerDocument||av).createTextNode(e))}return b.text(this)},wrapAll:function(e){if(b.isFunction(e)){return this.each(function(bw){b(this).wrapAll(e.call(this,bw))})}if(this[0]){var bv=b(e,this[0].ownerDocument).eq(0).clone(true);if(this[0].parentNode){bv.insertBefore(this[0])}bv.map(function(){var bw=this;while(bw.firstChild&&bw.firstChild.nodeType===1){bw=bw.firstChild}return bw}).append(this)}return this},wrapInner:function(e){if(b.isFunction(e)){return this.each(function(bv){b(this).wrapInner(e.call(this,bv))})}return this.each(function(){var bv=b(this),bw=bv.contents();if(bw.length){bw.wrapAll(e)}else{bv.append(e)}})},wrap:function(e){var bv=b.isFunction(e);return this.each(function(bw){b(this).wrapAll(bv?e.call(this,bw):e)})},unwrap:function(){return this.parent().each(function(){if(!b.nodeName(this,"body")){b(this).replaceWith(this.childNodes)}}).end()},append:function(){return this.domManip(arguments,true,function(e){if(this.nodeType===1){this.appendChild(e)}})},prepend:function(){return this.domManip(arguments,true,function(e){if(this.nodeType===1){this.insertBefore(e,this.firstChild)}})},before:function(){if(this[0]&&this[0].parentNode){return this.domManip(arguments,false,function(bv){this.parentNode.insertBefore(bv,this)})}else{if(arguments.length){var e=b.clean(arguments);e.push.apply(e,this.toArray());return this.pushStack(e,"before",arguments)}}},after:function(){if(this[0]&&this[0].parentNode){return this.domManip(arguments,false,function(bv){this.parentNode.insertBefore(bv,this.nextSibling)})}else{if(arguments.length){var e=this.pushStack(this,"after",arguments);e.push.apply(e,b.clean(arguments));return e}}},remove:function(e,bx){for(var bv=0,bw;(bw=this[bv])!=null;bv++){if(!e||b.filter(e,[bw]).length){if(!bx&&bw.nodeType===1){b.cleanData(bw.getElementsByTagName("*"));b.cleanData([bw])}if(bw.parentNode){bw.parentNode.removeChild(bw)}}}return this},empty:function(){for(var e=0,bv;(bv=this[e])!=null;e++){if(bv.nodeType===1){b.cleanData(bv.getElementsByTagName("*"))}while(bv.firstChild){bv.removeChild(bv.firstChild)}}return this},clone:function(bv,e){bv=bv==null?false:bv;e=e==null?bv:e;return this.map(function(){return b.clone(this,bv,e)})},html:function(bx){if(bx===L){return this[0]&&this[0].nodeType===1?this[0].innerHTML.replace(ag,""):null}else{if(typeof bx==="string"&&!ae.test(bx)&&(b.support.leadingWhitespace||!ar.test(bx))&&!ax[(d.exec(bx)||["",""])[1].toLowerCase()]){bx=bx.replace(R,"<$1></$2>");try{for(var bw=0,bv=this.length;bw<bv;bw++){if(this[bw].nodeType===1){b.cleanData(this[bw].getElementsByTagName("*"));this[bw].innerHTML=bx}}}catch(by){this.empty().append(bx)}}else{if(b.isFunction(bx)){this.each(function(bz){var e=b(this);e.html(bx.call(this,bz,e.html()))})}else{this.empty().append(bx)}}}return this},replaceWith:function(e){if(this[0]&&this[0].parentNode){if(b.isFunction(e)){return this.each(function(bx){var bw=b(this),bv=bw.html();bw.replaceWith(e.call(this,bx,bv))})}if(typeof e!=="string"){e=b(e).detach()}return this.each(function(){var bw=this.nextSibling,bv=this.parentNode;b(this).remove();if(bw){b(bw).before(e)}else{b(bv).append(e)}})}else{return this.length?this.pushStack(b(b.isFunction(e)?e():e),"replaceWith",e):this}},detach:function(e){return this.remove(e,true)},domManip:function(bB,bF,bE){var bx,by,bA,bD,bC=bB[0],bv=[];if(!b.support.checkClone&&arguments.length===3&&typeof bC==="string"&&o.test(bC)){return this.each(function(){b(this).domManip(bB,bF,bE,true)})}if(b.isFunction(bC)){return this.each(function(bH){var bG=b(this);bB[0]=bC.call(this,bH,bF?bG.html():L);bG.domManip(bB,bF,bE)})}if(this[0]){bD=bC&&bC.parentNode;if(b.support.parentNode&&bD&&bD.nodeType===11&&bD.childNodes.length===this.length){bx={fragment:bD}}else{bx=b.buildFragment(bB,this,bv)}bA=bx.fragment;if(bA.childNodes.length===1){by=bA=bA.firstChild}else{by=bA.firstChild}if(by){bF=bF&&b.nodeName(by,"tr");for(var bw=0,e=this.length,bz=e-1;bw<e;bw++){bE.call(bF?ba(this[bw],by):this[bw],bx.cacheable||(e>1&&bw<bz)?b.clone(bA,true,true):bA)}}if(bv.length){b.each(bv,bo)}}return this}});function ba(e,bv){return b.nodeName(e,"table")?(e.getElementsByTagName("tbody")[0]||e.appendChild(e.ownerDocument.createElement("tbody"))):e}function t(bB,bv){if(bv.nodeType!==1||!b.hasData(bB)){return}var by,bx,e,bA=b._data(bB),bz=b._data(bv,bA),bw=bA.events;if(bw){delete bz.handle;bz.events={};for(by in bw){for(bx=0,e=bw[by].length;bx<e;bx++){b.event.add(bv,by+(bw[by][bx].namespace?".":"")+bw[by][bx].namespace,bw[by][bx],bw[by][bx].data)}}}if(bz.data){bz.data=b.extend({},bz.data)}}function ai(bv,e){var bw;if(e.nodeType!==1){return}if(e.clearAttributes){e.clearAttributes()}if(e.mergeAttributes){e.mergeAttributes(bv)}bw=e.nodeName.toLowerCase();if(bw==="object"){e.outerHTML=bv.outerHTML}else{if(bw==="input"&&(bv.type==="checkbox"||bv.type==="radio")){if(bv.checked){e.defaultChecked=e.checked=bv.checked}if(e.value!==bv.value){e.value=bv.value}}else{if(bw==="option"){e.selected=bv.defaultSelected}else{if(bw==="input"||bw==="textarea"){e.defaultValue=bv.defaultValue}}}}e.removeAttribute(b.expando)}b.buildFragment=function(bz,bx,bv){var by,e,bw,bA,bB=bz[0];if(bx&&bx[0]){bA=bx[0].ownerDocument||bx[0]}if(!bA.createDocumentFragment){bA=av}if(bz.length===1&&typeof bB==="string"&&bB.length<512&&bA===av&&bB.charAt(0)==="<"&&!O.test(bB)&&(b.support.checkClone||!o.test(bB))&&(b.support.html5Clone||!ah.test(bB))){e=true;bw=b.fragments[bB];if(bw&&bw!==1){by=bw}}if(!by){by=bA.createDocumentFragment();b.clean(bz,bA,by,bv)}if(e){b.fragments[bB]=bw?by:1}return{fragment:by,cacheable:e}};b.fragments={};b.each({appendTo:"append",prependTo:"prepend",insertBefore:"before",insertAfter:"after",replaceAll:"replaceWith"},function(e,bv){b.fn[e]=function(bw){var bz=[],bC=b(bw),bB=this.length===1&&this[0].parentNode;if(bB&&bB.nodeType===11&&bB.childNodes.length===1&&bC.length===1){bC[bv](this[0]);return this}else{for(var bA=0,bx=bC.length;bA<bx;bA++){var by=(bA>0?this.clone(true):this).get();b(bC[bA])[bv](by);bz=bz.concat(by)}return this.pushStack(bz,e,bC.selector)}}});function bg(e){if(typeof e.getElementsByTagName!=="undefined"){return e.getElementsByTagName("*")}else{if(typeof e.querySelectorAll!=="undefined"){return e.querySelectorAll("*")}else{return[]}}}function az(e){if(e.type==="checkbox"||e.type==="radio"){e.defaultChecked=e.checked}}function E(e){var bv=(e.nodeName||"").toLowerCase();if(bv==="input"){az(e)}else{if(bv!=="script"&&typeof e.getElementsByTagName!=="undefined"){b.grep(e.getElementsByTagName("input"),az)}}}function al(e){var bv=av.createElement("div");ac.appendChild(bv);bv.innerHTML=e.outerHTML;return bv.firstChild}b.extend({clone:function(by,bA,bw){var e,bv,bx,bz=b.support.html5Clone||!ah.test("<"+by.nodeName)?by.cloneNode(true):al(by);if((!b.support.noCloneEvent||!b.support.noCloneChecked)&&(by.nodeType===1||by.nodeType===11)&&!b.isXMLDoc(by)){ai(by,bz);e=bg(by);bv=bg(bz);for(bx=0;e[bx];++bx){if(bv[bx]){ai(e[bx],bv[bx])}}}if(bA){t(by,bz);if(bw){e=bg(by);bv=bg(bz);for(bx=0;e[bx];++bx){t(e[bx],bv[bx])}}}e=bv=null;return bz},clean:function(bw,by,bH,bA){var bF;by=by||av;if(typeof by.createElement==="undefined"){by=by.ownerDocument||by[0]&&by[0].ownerDocument||av}var bI=[],bB;for(var bE=0,bz;(bz=bw[bE])!=null;bE++){if(typeof bz==="number"){bz+=""}if(!bz){continue}if(typeof bz==="string"){if(!W.test(bz)){bz=by.createTextNode(bz)}else{bz=bz.replace(R,"<$1></$2>");var bK=(d.exec(bz)||["",""])[1].toLowerCase(),bx=ax[bK]||ax._default,bD=bx[0],bv=by.createElement("div");if(by===av){ac.appendChild(bv)}else{a(by).appendChild(bv)}bv.innerHTML=bx[1]+bz+bx[2];while(bD--){bv=bv.lastChild}if(!b.support.tbody){var e=w.test(bz),bC=bK==="table"&&!e?bv.firstChild&&bv.firstChild.childNodes:bx[1]==="<table>"&&!e?bv.childNodes:[];for(bB=bC.length-1;bB>=0;--bB){if(b.nodeName(bC[bB],"tbody")&&!bC[bB].childNodes.length){bC[bB].parentNode.removeChild(bC[bB])}}}if(!b.support.leadingWhitespace&&ar.test(bz)){bv.insertBefore(by.createTextNode(ar.exec(bz)[0]),bv.firstChild)}bz=bv.childNodes}}var bG;if(!b.support.appendChecked){if(bz[0]&&typeof(bG=bz.length)==="number"){for(bB=0;bB<bG;bB++){E(bz[bB])}}else{E(bz)}}if(bz.nodeType){bI.push(bz)}else{bI=b.merge(bI,bz)}}if(bH){bF=function(bL){return !bL.type||bm.test(bL.type)};for(bE=0;bI[bE];bE++){if(bA&&b.nodeName(bI[bE],"script")&&(!bI[bE].type||bI[bE].type.toLowerCase()==="text/javascript")){bA.push(bI[bE].parentNode?bI[bE].parentNode.removeChild(bI[bE]):bI[bE])}else{if(bI[bE].nodeType===1){var bJ=b.grep(bI[bE].getElementsByTagName("script"),bF);bI.splice.apply(bI,[bE+1,0].concat(bJ))}bH.appendChild(bI[bE])}}}return bI},cleanData:function(bv){var by,bw,e=b.cache,bB=b.event.special,bA=b.support.deleteExpando;for(var bz=0,bx;(bx=bv[bz])!=null;bz++){if(bx.nodeName&&b.noData[bx.nodeName.toLowerCase()]){continue}bw=bx[b.expando];if(bw){by=e[bw];if(by&&by.events){for(var bC in by.events){if(bB[bC]){b.event.remove(bx,bC)}else{b.removeEvent(bx,bC,by.handle)}}if(by.handle){by.handle.elem=null}}if(bA){delete bx[b.expando]}else{if(bx.removeAttribute){bx.removeAttribute(b.expando)}}delete e[bw]}}}});function bo(e,bv){if(bv.src){b.ajax({url:bv.src,async:false,dataType:"script"})}else{b.globalEval((bv.text||bv.textContent||bv.innerHTML||"").replace(aN,"/*$0*/"))}if(bv.parentNode){bv.parentNode.removeChild(bv)}}var ak=/alpha\([^)]*\)/i
av
var L av
Definition: jquery.js:16
p
function p(by, bw, bv)
Definition: jquery.js:23
css
b fn css
Definition: jquery.js:23
if
if(!b.support.opacity)
Definition: jquery.js:23
bu
var L bu
Definition: jquery.js:16
each
b each(["height","width"], function(bv, e){b.cssHooks[e]={get:function(by, bx, bw){var bz;if(bx){if(by.offsetWidth!==0){return p(by, e, bw)}else{b.swap(by, a7, function(){bz=p(by, e, bw)})}return bz}}, set:function(bw, bx){if(bc.test(bx)){bx=parseFloat(bx);if(bx >=0){return bx+"px"}}else{return bx}}}})
bb
function bb
Definition: jquery.js:16
b
var b
Definition: jquery.js:16
Z
Z
Definition: jquery.js:23
function bb

jQuery JavaScript Library v1.7.1 http://jquery.com/

Copyright 2011, John Resig Dual licensed under the MIT or GPL Version 2 licenses. http://jquery.org/license

Includes Sizzle.js http://sizzlejs.com/ Copyright 2011, The Dojo Foundation Released under the MIT, BSD, and GPL Licenses.

Date: Mon Nov 21 21:11:03 2011 -0500

var L bl =bb.location
var bq =/#.*$/
var bs =/\r?\n/g
var L bu =bb.navigator
var c
初始值:
=/^\/\
* jQuery UI 1.8.18
*
* Copyright 2011
b fn css =function(e,bv){if(arguments.length===2&&bv===L){return this}return b.access(this,e,bv,true,function(bx,bw,by){return by!==L?b.style(bx,bw,by):b.css(bx,bw)})}
b curCSS =b.css
var k =/%20/g
Z =aI||aX


CKCameraAPI: CKCameraInterface.h 文件参考

  • 文件列表
  • 文件成员
宏定义 | 类型定义 | 函数
CKCameraInterface.h 文件参考
#include "CKDeviceDef.h"

浏览源代码.

宏定义

#define CKSDK_API _declspec(dllimport)

类型定义

typedef int CameraSdkStatus

函数

CKSDK_API CameraSdkStatus __stdcall | CameraEnumerateDevice (INT *pDeviceNum)
枚举设备，并建立设备列表。在调用CameraInit 之前，必须调用该函数来获得设备的信息。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetEnumIndexInfo (INT CameraIndex, tDevEnumInfo *pDevInfo)
获得指定设备的信息 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraInit (PHANDLE phCamera, INT CameraIndex)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口,默认使用上次退出时的参数。注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx (PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx2 (PHANDLE phCamera, const char *pFriendlyName)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx3 (PHANDLE phCamera, const char *pCameraSN)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调用CameraEnumerateDevice枚举相机 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraUnInit (HANDLE hCamera)
相机反初始化。释放资源。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCapability (HANDLE hCamera, tSdkCameraCapbility *pCameraCap)
获得相机的特性描述结构体。该结构体中包含了相机 可设置的各种参数的范围信息。决定了相关函数的参数 返回，也可用于动态创建相机的配置界面。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurDevInfo (HANDLE hCamera, tDevLoadInfo *pDevInfo)
获得指定设备的枚举信息 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetRawImageBuffer (HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes)
获得一帧图像原始数据。为了提高效率，SDK在图像抓取时采用了零拷贝机制， CameraGetRawImageBuffer实际获得是内核中的一个缓冲区地址， 该函数成功调用后，必须调用CameraReleaseFrameHandle,以便让内核继续使用 该缓冲区。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraReleaseFrameHandle (HANDLE hCamera, HANDLE hRawBuf)
释放由CameraGetRawImageBuffer获得缓冲区 更多...
CKSDK_API BYTE *__stdcall | CameraGetImageInfo (HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo)
获得当前帧图像信息 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageBuffer (HANDLE hCamera, stImageInfo *pImgInfo, HANDLE hRawBuf, BYTE *pImgBuf)
将获得的相机原始输出图像数据进行处理，叠加饱和度、 颜色增益和校正、降噪等处理效果，处理完后图像的输出格式 可以是 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 的其中一种。 更多...
CKSDK_API BYTE *__stdcall | CameraGetImageBufferEx (HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes)
获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数调用后，该函数返回的图像数据缓冲区。适用于主动方式调用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageBufferEx1 (HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT uTimes)
获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数调用后，会将处理后的图像数据放入提供的缓冲区中，适用于主动方式调用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCallbackFunction (HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld)
设置图像捕获的回调函数。当捕获到新的图像数据帧时，pCallBack所指向的回调函数就会被调用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraPause (HANDLE hCamera)
让SDK进入暂停模式，不接收来自相机的图像数据， 同时也会发送命令让相机暂停输出，释放传输带宽。 暂停模式下，可以对相机的参数进行配置，并立即生效。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraPlay (HANDLE hCamera)
让SDK进入工作模式，开始接收来自相机发送的图像 数据。如果当前相机是触发模式，则需要接收到 触发帧以后才会更新图像。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraDisplayInit (HANDLE hCamera, HWND hWndDisplay)
初始化SDK内部的显示模块。在调用CameraDisplay 前必须先调用该函数初始化。如果您在二次开发中， 使用自己的方式进行图像显示(不调用CameraDisplay)， 则不需要调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayMode (HANDLE hCamera, INT iMode)
设置显示的模式。必须调用过CameraDisplayInit 进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayScaleRadio (HANDLE hCamera, INT iRadio)
设置显示的缩放比率。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如100 是显示窗口和图像窗口为1:1,200是显示窗口和图像窗口为2:1 50是显示窗口和图像窗口为0.5:1，故该值为倍率X100，必须调用过 CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayOffset (HANDLE hCamera, INT iOffsetX, INT iOffsetY)
设置显示的起始偏移值。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如显示控件的大小为320X240，而图像的 的尺寸为640X480，那么当iOffsetX = 160,iOffsetY = 120时 显示的区域就是图像的居中320X240的位置。必须调用过 CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplaySize (HANDLE hCamera, INT iWidth, INT iHeight)
设置显示控件的尺寸。必须调用过 CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCrossLine (HANDLE hCamera, INT iLine, INT x, INT y, UINT uColor, BOOL bVisible)
设置指定十字线的参数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCrossLine (HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible)
获得指定十字线的状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraImageOverlay (HANDLE hCamera, BYTE *pImgBuf, const stImageInfo *pImgInfo)
将输入的图像数据上叠加十字线、白平衡参考窗口、 自动曝光参考窗口等图形。只有设置为可见状态的 十字线和参考窗口才能被叠加上。 注意，该函数的输入图像必须是RGB格式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraDrawText (BYTE *pImgBuf, const stImageInfo *pImgInfo, char const *pFontFileName, UINT FontWidth, UINT FontHeight, char const *pText, INT Left, INT Top, UINT Width, UINT Height, UINT TextColor, UINT uFlags)
在输入的图像数据中绘制文字 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraDisplay (HANDLE hCamera, BYTE *pImgBuf, stImageInfo *pImgInfo)
显示图像。必须调用过CameraDisplayInit进行初始化才能调用本函数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayCallbackFun (HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld)
设置显示回调。必须调用过CameraDisplayInit进行 初始化才能调用本函数，同时当显示图像数据帧时， pCallBack所指向的回调函数就会被调用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSnapToBuffer (HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE **ppImgBuf, UINT uWaitTimeMs)
抓拍一张图像到缓冲区中。相机会进入抓拍模式，并且 自动切换到抓拍模式的分辨率进行图像捕获。然后将 捕获到的数据保存到缓冲区中。 该函数成功调用后，必须调用CameraReleaseFrameHandle 释放由CameraSnapToBuffer得到的缓冲区。具体请参考 CameraGetRawImageBuffer函数的功能描述部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
设置抓拍模式下相机输出图像的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
获得抓拍模式下的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeState (HANDLE hCamera, BOOL bAeState)
设置相机曝光的模式。自动或者手动。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeState (HANDLE hCamera, BOOL *pAeState)
获得相机当前的曝光模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeTarget (HANDLE hCamera, WORD AeTarget)
设定自动曝光的亮度目标值。设定范围由CameraGetCapability函数获得。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeTarget (HANDLE hCamera, WORD *pAeTarget)
获得自动曝光的亮度目标值。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAnalogGain (HANDLE hCamera, UINT uAnalogGain)
设置相机的图像模拟增益值。该值乘以CameraGetCapability获得 的相机属性结构体中sExposeDesc.fAnalogGainStep，就 得到实际的图像信号放大倍数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAnalogGain (HANDLE hCamera, UINT *puAnalogGain)
获得图像信号的模拟增益值。参见CameraSetAnalogGain详细说明。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetExposureTime (HANDLE hCamera, double dExposureTime)
设置曝光时间。单位为微秒。对于CMOS传感器，其曝光 的单位是按照行来计算的，因此，曝光时间并不能在微秒 级别连续可调。而是会按照整行来取舍。在调用 本函数设定曝光时间后，建议再调用CameraGetExposureTime 来获得实际设定的值。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureTime (HANDLE hCamera, double *pdExposureTime)
获得相机的曝光时间。请参见CameraSetExposureTime 的功能描述。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
设置自动曝光的参考窗口。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
获得自动曝光参考窗口的位置。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWinVisible (HANDLE hCamera, BOOL bDisplayEn)
设置自动曝光参考窗口的显示状态。当设置窗口状态 为显示，调用CameraImageOverlay后，能够将窗口位置 以矩形的方式叠加在图像上。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWinVisible (HANDLE hCamera, BOOL *pbDisplayEn)
获得自动曝光参考窗口的显示状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAntiFlick (HANDLE hCamera, BOOL bEnable)
设置自动曝光时抗频闪功能的使能状态。对于手动 曝光模式下无效。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAntiFlick (HANDLE hCamera, BOOL *pbEnable)
获得自动曝光时抗频闪功能的使能状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetLightFrequency (HANDLE hCamera, INT iFrequencySel)
设置自动曝光时消频闪的频率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLightFrequency (HANDLE hCamera, INT *piFrequencySel)
获得自动曝光时，消频闪的频率选择。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureLineTime (HANDLE hCamera, double *pExposureLineTime)
获得一行曝光的时间，单位：微妙。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureMode (HANDLE hCamera, INT iMode)
设定自动曝光模式下的曝光模式 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureMode (HANDLE hCamera, INT *piMode)
获得自动曝光模式下的曝光模式 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureRange (HANDLE hCamera, double dMinExposureTime, double dMaxExposureTime)
设定自动曝光模式的曝光时间调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureRange (HANDLE hCamera, double *pdMinExposureTime, double *pdMaxExposureTime)
获得自动曝光模式的曝光时间调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeAnalogGainRange (HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain)
设定自动曝光模式的增益调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeAnalogGainRange (HANDLE hCamera, INT *iMinAnalogGain, INT *iMaxAnalogGain)
获得自动曝光模式的增益调节范围 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGain (HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB)
设置图像的数字增益。设定范围由CameraGetCapability 获得的相机属性结构体中sRgbGainRange成员表述。 实际的放大倍数是设定值/100。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGain (HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB)
获得图像处理的数字增益。具体请参见CameraSetGain 的功能描述部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbMode (HANDLE hCamera, BOOL bAuto)
设置相机白平衡模式。分为手动和自动两种方式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbMode (HANDLE hCamera, BOOL *pbAuto)
获得当前的白平衡模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOnceWB (HANDLE hCamera)
在手动白平衡模式下，调用该函数会进行一次白平衡。 生效的时间为接收到下一帧图像数据时。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
设置白平衡参考窗口的位置。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
获得白平衡参考窗口的位置。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWinVisible (HANDLE hCamera, BOOL bDisplayEn)
设置白平衡参考窗口显示使能。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWinVisible (HANDLE hCamera, BOOL *pDisplayEn)
获得白平衡参考窗口显示使能状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetLutMode (HANDLE hCamera, INT emLutMode)
设置相机的查表变换模式LUT模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutMode (HANDLE hCamera, INT *pemLutMode)
获得相机的查表变换模式LUT模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGamma (HANDLE hCamera, int iGamma)
设定LUT动态生成模式下的Gamma值。设定的值会 马上保存在SDK内部，但是只有当相机处于动态 参数生成的LUT模式时，才会生效。请参考CameraSetLutMode 的函数说明部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGamma (HANDLE hCamera, int *piGamma)
获得LUT动态生成模式下的Gamma值。请参考CameraSetGamma 函数的功能描述。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrastLut (HANDLE hCamera, int iContrast)
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrastLut (HANDLE hCamera, int *piContrast)
CKSDK_API CameraSdkStatus __stdcall | CameraSelectLutPreset (HANDLE hCamera, INT iSel)
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutPresetSel (HANDLE hCamera, INT *piSel)
获得预设LUT模式下的LUT表索引号。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCustomLut (HANDLE hCamera, int iChannel, USHORT *pLut)
设置自定义的LUT表。必须先使用CameraSetLutMode 将LUT模式设置为自定义模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCustomLut (HANDLE hCamera, int iChannel, USHORT *pLut)
获得当前使用的自定义LUT表。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentLut (HANDLE hCamera, int iChannel, USHORT *pLut)
CKSDK_API CameraSdkStatus __stdcall | CameraSetSharpness (HANDLE hCamera, INT iSharpness)
设置图像的处理的锐化参数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSharpness (HANDLE hCamera, INT *piSharpness)
获取当前锐化设定值。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetSaturation (HANDLE hCamera, INT iSaturation)
设定图像处理的饱和度。对黑白相机无效。 设定范围由CameraGetCapability获得。100表示 表示原始色度，不增强。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSaturation (HANDLE hCamera, INT *piSaturation)
获得图像处理的饱和度。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrast (HANDLE hCamera, INT iContrast)
设定图像处理的对比度 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrast (HANDLE hCamera, INT *piContrast)
获得对比度值。请参考 CameraSetContrast函数的功能描述。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrame (HANDLE hCamera, double *pdFrameTime)
获得当前图像帧时间。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFrameSpeed (HANDLE hCamera, INT iFrameSpeed)
设定相机输出图像的帧率。相机可供选择的帧率模式由 CameraGetCapability获得的信息结构体中iFrameSpeedDesc 表示最大帧率选择模式个数。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameSpeed (HANDLE hCamera, INT *piFrameSpeed)
获得相机输出图像的帧率选择索引号。具体用法参考 CameraSetFrameSpeed函数的功能描述部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolution (HANDLE hCamera, INT iResolutionIndex)
设定相机输出图像的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolution (HANDLE hCamera, INT *piResolutionIndex)
获得相机输出图像的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionEx (HANDLE hCamera, tSdkImageResolution *pImageResolution)
设置自定义预览的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionEx (HANDLE hCamera, INT iResolution, tSdkImageResolution *pImageResolution)
获得索引号的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurResolution (HANDLE hCamera, tSdkImageResolution *pImageResolution)
获得当前预览的分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageSize (HANDLE hCamera, DWORD *pWidth, DWORD *pHeight)
获得输出图像的大小。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgMode (HANDLE hCamera, INT iAlgMode)
设置Bayer转RGB算法模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgThreshold (HANDLE hCamera, INT iAlgMode)
设置Bayer转RGB算法模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBayerAlgMode (HANDLE hCamera, INT *piAlgMode)
获得Bayer转RGB算法模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetIspOutFormat (HANDLE hCamera, INT iFormat)
设置CameraImageProcess函数的图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 (在CameraDefine.h中定义)5种，分别对应8位灰度图像和24RGB、32位RGB、24位BGR、32位BGR彩色图像。 默认输出是CAMERA_MEDIA_TYPE_BGR8格式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetIspOutFormat (HANDLE hCamera, INT *piFormat)
获得CameraGetOutImageBuffer函数图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 (在CameraDefine.h中定义)5种，分别对应8位灰度图像和24RGB、32位RGB、24位BGR、32位BGR彩色图像。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameStatistic (HANDLE hCamera, FrameStatistic *psFrameStatistic)
获得相机接收帧率的统计信息，包括错误帧和丢帧的情况。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveImage (HANDLE hCamera, const char *lpszFileName, const BYTE *pImgBuf, const stImageInfo *pImgInfo, UINT byFileType, BYTE byQuality)
将图像缓冲区的数据保存成图片文件。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetMirror (HANDLE hCamera, INT iDir, BOOL bEnable)
设置图像镜像操作。镜像操作分为水平和垂直两个方向。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMirror (HANDLE hCamera, INT iDir, BOOL *pbEnable)
获得图像的镜像状态。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetMonochrome (HANDLE hCamera, BOOL bEnable)
设置彩色转为黑白功能的使能。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMonochrome (HANDLE hCamera, BOOL *pbEnable)
获得彩色转换黑白功能的使能状况。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBlackLevel (HANDLE hCamera, INT iBlackLevel)
设置图像的黑电平基准，默认值为0 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBlackLevel (HANDLE hCamera, INT *piBlackLevel)
获得图像的黑电平基准，默认值为0 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerMode (HANDLE hCamera, INT iTriggerModeSel)
设置相机的触发模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerMode (HANDLE hCamera, INT *piTriggerModeSel)
获得相机的触发模式。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSoftTrigger (HANDLE hCamera)
执行一次软触发。 更多...
CameraSdkStatus __stdcall | CameraSetTriggerFrameCount (HANDLE hCamera, INT frameCount)
设置硬件触发时连续拍多少张图片 更多...
CameraSdkStatus __stdcall | CameraGetTriggerFrameCount (HANDLE hCamera, INT *pFrameCount)
获取硬件触发时连续拍多少张图片 更多...
CameraSdkStatus __stdcall | CameraSetTriggerDelayTime (HANDLE hCamera, UINT delayTimeUs)
设置硬件触发后多少时间进行拍照 更多...
CameraSdkStatus __stdcall | CameraGetTriggerDelayTime (HANDLE hCamera, UINT *pDelayTimeUs)
设置硬件触发后多少时间进行拍照 更多...
CameraSdkStatus __stdcall | CameraSetTriggerJitterTime (HANDLE hCamera, UINT jitterTimeUs)
设置硬件触发后去抖时间 更多...
CameraSdkStatus __stdcall | CameraGetTriggerJitterTime (HANDLE hCamera, UINT *pJitterTimeUs)
获取硬件触发后去抖时间 更多...
CameraSdkStatus __stdcall | CameraSetTriggerSignalType (HANDLE hCamera, INT type)
设置硬件触发信号类型 更多...
CameraSdkStatus __stdcall | CameraGetTriggerSignalType (HANDLE hCamera, INT *pType)
获取硬件触发信号类型 更多...
CameraSdkStatus __stdcall | CameraSetStrobeMode (HANDLE hCamera, INT mode)
设置闪光灯工作模式 更多...
CameraSdkStatus __stdcall | CameraGetStrobeMode (HANDLE hCamera, INT *pMode)
获取闪光灯工作模式 更多...
CameraSdkStatus __stdcall | CameraSetStrobeDelayTime (HANDLE hCamera, UINT delayTimeUs)
设置触发后延时多少时间点亮闪光灯 更多...
CameraSdkStatus __stdcall | CameraGetStrobeDelayTime (HANDLE hCamera, UINT *pDevlayTimeUs)
获取触发后点亮闪光灯的延时时间 更多...
CameraSdkStatus __stdcall | CameraSetStrobePulseWidth (HANDLE hCamera, UINT pulseWidth)
设置闪光灯的脉宽宽度 更多...
CameraSdkStatus __stdcall | CameraGetStrobePulseWidth (HANDLE hCamera, UINT *pPulseWidth)
获取闪光灯的脉宽宽度 更多...
CameraSdkStatus __stdcall | CameraSetStrobePolarity (HANDLE hCamera, INT polarity)
设置闪光灯的有效电平 更多...
CameraSdkStatus __stdcall | CameraGetStrobePolarity (HANDLE hCamera, INT *pPolarity)
获取闪光灯的有效电平 更多...
CameraSdkStatus __stdcall | CameraSetOutputIOMode (HANDLE hCamera, INT outputIOIndex, INT mode)
设置输出IO的工作模式， 预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 更多...
CameraSdkStatus __stdcall | CameraSetInputIOMode (HANDLE hCamera, INT inputIOIndex, INT mode)
设置输入IO的模式，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决定 更多...
CameraSdkStatus __stdcall | CameraSetOutputIOState (HANDLE hCamera, INT outputIOIndex, INT state)
设置指定IO的电平状态，IO为输出型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 更多...
CameraSdkStatus __stdcall | CameraSetOutputIOPWM (HANDLE hCamera, INT outputIOIndex, INT cycle, INT duty)
设置PWM型输出的参数，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 更多...
CameraSdkStatus __stdcall | CameraGetInputIOState (HANDLE hCamera, INT inputIOIndex, int *pState)
设置指定IO的电平状态，IO为输入型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决定。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetParameterMode (HANDLE hCamera, INT iMode)
设定参数存取的目标对象。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetParameterMode (HANDLE hCamera, INT *piMode)
获得参数存取的目标对象。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameter (HANDLE hCamera, INT iTeam)
保存当前相机参数到指定的参数组中。相机提供了A,B,C,D A,B,C,D四组空间来进行参数的保存。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameterToFile (HANDLE hCamera, const char *sFileName)
保存当前相机参数到指定的文件中。该文件可以复制到 别的电脑上供其他相机加载，也可以做参数备份用。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraReadParameterFromFile (HANDLE hCamera, const char *sFileName)
从PC上指定的参数文件中加载参数。我公司相机参数 保存在PC上为.config后缀的文件，位于安装下的 Camera\Configs文件夹中。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadParameter (HANDLE hCamera, INT iTeam)
加载指定组的参数到相机中。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentParameterGroup (HANDLE hCamera, INT *piTeam)
获得当前选择的参数组。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraWriteSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
设置相机的序列号。我公司相机序列号分为3级。0级的是我公司自定义的相机序列号，出厂时已经 设定好，1级和2级留给二次开发使用。每级序列 号长度都是32个字节。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraReadSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
读取相机指定级别的序列号。序列号的定义请参考 CameraWriteSN函数的功能描述部分。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
将用户自定义的数据保存到相机的非易性存储器中。每个型号的相机可能支持的用户数据区最大长度不一样。可以从设备的特性描述中获取该长度信息。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
从相机的非易性存储器中读取用户自定义的数据。每个型号的相机可能支持的用户数据区最大长度不一样。可以从设备的特性描述中获取该长度信息。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFriendlyName (HANDLE hCamera, char *pName)
读取用户自定义的设备昵称。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFriendlyName (HANDLE hCamera, char *pName)
设置用户自定义的设备昵称。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSdkGetVersionString (char *pVersionString)
获得SDK版本信息 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraCheckFwUpdate (HANDLE hCamera, BOOL *pNeedUpdate)
检测固件版本，是否需要升级。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFirmwareVision (HANDLE hCamera, char *pVersion)
获得固件版本的字符串 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetDeviceType (HANDLE hCamera, DWORD *pDeviceID)
获得设备版本ID 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInerfaceVersion (HANDLE hCamera, char *pVersion)
获得指定设备接口的版本 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraShowSettingPage (HANDLE hCamera, BOOL bShow)
设置相机属性配置窗口显示状态。必须先调用CameraCreateSettingPageEx 成功创建相机属性配置窗口后，才能调用本函数进行显示。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraSetActivePage (HANDLE hCamera, LONG lActivePage, INT iDefault)
设置相机配置窗口的激活页面。相机配置窗口有多个子页面构成，该函数可以设定当前哪一个子页面为激活状态，显示在最前端。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraCreateSettingPageEx (HANDLE hCamera)
创建相机配置窗口。创建之前要先调用CameraSetActivePage设置子页面构成。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeResolution (HANDLE hCamera, tSdkImageResolution *pImageCustom)
打开分辨率自定义面板，并通过可视化的方式来配置一个自定义分辨率。 更多...
CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeReferWin (HANDLE hCamera, INT iWinType, INT *piHOff, INT *piVOff, INT *piWidth, INT *piHeight)
打开参考窗口自定义面板。并通过可视化的方式来获得一个自定义窗口的位置。一般是用自定义白平衡和自动曝光的参考窗口。 更多...

宏定义说明

#define CKSDK_API _declspec(dllimport)

类型定义说明

typedef int CameraSdkStatus


CKCameraAPI: CKDeviceDef.h 文件参考

  • 文件列表
  • 文件成员
类 | 宏定义 | 类型定义 | 枚举
CKDeviceDef.h 文件参考

浏览源代码.

类

struct | _tIspAe
曝光参数 更多...
struct | _tIspWb
白平衡参数 更多...
struct | _tIspGamma
gama参数 更多...
struct | _tDevLoadMode
设备加载模式信息 更多...
struct | _tExpose
相机曝光功能范围定义 更多...
struct | _tResolutionRange
相机的分辨率设定范围，用于构件UI 更多...
struct | _tSdkTrigger
触发模式描述 更多...
struct | _tSdkImageResolution
struct | _tSdkColorTemperatureDes
相机白平衡色温模式描述信息 更多...
struct | _tSdkPackLength
传输分包大小描述(主要是针对网络相机有效) 更多...
struct | _tSdkPresetLut
预设的LUT表描述 更多...
struct | _tSdkAeAlgorithm
AE算法描述 更多...
struct | _tSdkBayerDecodeAlgorithm
RAW转RGB算法描述 更多...
struct | _tSdkMediaType
相机输出的图像数据格式 更多...
struct | _tSdkBayerType
相机输出的图像数据格式 更多...
struct | _tSdkFrameSpeed
相机帧率描述信息 更多...
struct | _tRgbGainRange
RGB三通道数字增益的设定范围 更多...
struct | _tSaturationRange
饱和度设定的范围 更多...
struct | _tSharpnessRange
锐化的设定范围 更多...
struct | _tGammaRange
伽马的设定范围 更多...
struct | _tGammaContrastRange
伽马对比度的设定范围 更多...
struct | _tContrastRange
对比度的设定范围 更多...
struct | _tSdkIspCapacity
ISP模块的使能信息 更多...
struct | _tSensorCfg
sensor能力级 更多...
struct | _tDeviceCfg
设备能力级 更多...
struct | _tDevInfo
相机的设备信息 更多...
struct | _stImageInfo
帧头信息 更多...
struct | _FrameStatistic
帧率统计信息 更多...
struct | _tSdkCameraCapbility
相机能力级 更多...
struct | _DisplayWindow
显示窗口的参数 更多...
struct | _tDevEnumInfo
枚举信息 更多...
struct | _tDevLoadInfo
/设备的当前模式和枚举信息 更多...

宏定义

#define | CROSSLINE_MAX_NUM 9
#define | CAMERA_STATUS_SUCCESS 0
操作成功 更多...
#define | CAMERA_STATUS_FAILED -1
操作失败 更多...
#define | CAMERA_STATUS_INTERNAL_ERROR -2
内部错误 更多...
#define | CAMERA_STATUS_UNKNOW -3
未知错误 更多...
#define | CAMERA_STATUS_NOT_SUPPORTED -4
不支持该功能 更多...
#define | CAMERA_STATUS_NOT_INITIALIZED -5
初始化未完成 更多...
#define | CAMERA_STATUS_PARAMETER_INVALID -6
参数无效 更多...
#define | CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7
参数越界 更多...
#define | CAMERA_STATUS_UNENABLED -8
未使能 更多...
#define | CAMERA_STATUS_USER_CANCEL -9
用户手动取消了，比如roi面板点击取消，返回 更多...
#define | CAMERA_STATUS_PATH_NOT_FOUND -10
注册表中没有找到对应的路径 更多...
#define | CAMERA_STATUS_SIZE_DISMATCH -11
获得图像数据长度和定义的尺寸不匹配 更多...
#define | CAMERA_STATUS_TIME_OUT -12
超时错误 更多...
#define | CAMERA_STATUS_IO_ERROR -13
硬件IO错误 更多...
#define | CAMERA_STATUS_COMM_ERROR -14
通讯错误 更多...
#define | CAMERA_STATUS_BUS_ERROR -15
总线错误 更多...
#define | CAMERA_STATUS_NO_DEVICE_FOUND -16
没有发现设备 更多...
#define | CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17
未找到逻辑设备 更多...
#define | CAMERA_STATUS_DEVICE_IS_OPENED -18
设备已经打开 更多...
#define | CAMERA_STATUS_DEVICE_IS_CLOSED -19
设备已经关闭 更多...
#define | CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20
没有打开设备视频，调用录像相关的函数时，如果相机视频没有打开，则回返回该错误。 更多...
#define | CAMERA_STATUS_NO_MEMORY -21
没有足够系统内存 更多...
#define | CAMERA_STATUS_FILE_CREATE_FAILED -22
创建文件失败 更多...
#define | CAMERA_STATUS_FILE_INVALID -23
文件格式无效 更多...
#define | CAMERA_STATUS_WRITE_PROTECTED -24
写保护，不可写 更多...
#define | CAMERA_STATUS_GRAB_FAILED -25
数据采集失败 更多...
#define | CAMERA_STATUS_LOST_DATA -26
数据丢失，不完整 更多...
#define | CAMERA_STATUS_EOF_ERROR -27
未接收到帧结束符 更多...
#define | CAMERA_STATUS_BUSY -28
正忙(上一次操作还在进行中)，此次操作不能进行 更多...
#define | CAMERA_STATUS_WAIT -29
需要等待(进行操作的条件不成立)，可以再次尝试 更多...
#define | CAMERA_STATUS_IN_PROCESS -30
正在进行，已经被操作过 更多...
#define | CAMERA_STATUS_IIC_ERROR -31
IIC传输错误 更多...
#define | CAMERA_STATUS_SPI_ERROR -32
SPI传输错误 更多...
#define | CAMERA_STATUS_USB_CONTROL_ERROR -33
USB控制传输错误 更多...
#define | CAMERA_STATUS_USB_BULK_ERROR -34
USB BULK传输错误 更多...
#define | CAMERA_STATUS_SOCKET_INIT_ERROR -35
网络传输套件初始化失败 更多...
#define | CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36
网络相机内核过滤驱动初始化失败，请检查是否正确安装了驱动，或者重新安装。 更多...
#define | CAMERA_STATUS_NET_SEND_ERROR -37
网络数据发送错误 更多...
#define | CAMERA_STATUS_DEVICE_LOST -38
与网络相机失去连接，心跳检测超时 更多...
#define | CAMERA_STATUS_DATA_RECV_LESS -39
接收到的字节数比请求的少 更多...
#define | CAMERA_STATUS_FUNCTION_LOAD_FAILED -40
从文件中加载程序失败 更多...
#define | CAMERA_STATUS_CRITICAL_FILE_LOST -41
程序运行所必须的文件丢失。 更多...
#define | CAMERA_STATUS_SENSOR_ID_DISMATCH -42
固件和程序不匹配，原因是下载了错误的固件。 更多...
#define | CAMERA_STATUS_OUT_OF_RANGE -43
参数超出有效范围。 更多...
#define | CAMERA_STATUS_REGISTRY_ERROR -44
安装程序注册错误。请重新安装程序，或者运行安装目录Setup/Installer.exe 更多...
#define | CAMERA_STATUS_ACCESS_DENY -45
禁止访问。指定相机已经被其他程序占用时，再申请访问该相机，会返回该状态。(一个相机不能被多个程序同时访问) 更多...
#define | CAMERA_STATUS_CAMERA_NEED_RESET -46
表示相机需要复位后才能正常使用，此时请让相机断电重启，或者重启操作系统后，便可正常使用。 更多...
#define | CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47
ISP模块未初始化 更多...
#define | CAMERA_STATUS_ISP_DATA_CRC_ERROR -48
数据校验错误 更多...
#define | CAMERA_STATUS_MV_TEST_FAILED -49
数据测试失败 更多...
#define | CAMERA_STATUS_WAIT_TRIGGER -50
等待触发帧 更多...
#define | CAMERA_STATUS_EEPROM_UPDATA -51
EE数据版本需要更新 更多...
#define | CAMERA_STATUS_OPEN_DEVICE_ERROR -52
打开设备失败 更多...
#define | CAMERA_STATUS_OPEN_STREAM_ERROR -53
打开视频流失败 更多...
#define | CAMERA_STATUS_READ_ERROR -54
读错误 更多...
#define | CAMERA_STATUS_WRITE_ERROR -55
写错误 更多...
#define | CAMERA_STATUS_NO_OPEN_DEVICE -56
没有打开的设备 更多...
#define | CAMERA_STATUS_UNKNOW_SENSOR -57
未识别sensor 更多...
#define | CAMERA_STATUS_NO_WRITE_EEPROM -58
没有写EE数据 更多...
#define | CMAERA_STATUS_FPGA_CFG_ERROR -59
FPGA配置失败 更多...
#define | CAMERA_MEDIA_TYPE_MONO 0x01000000
#define | CAMERA_MEDIA_TYPE_RGB 0x02000000
#define | CAMERA_MEDIA_TYPE_COLOR 0x02000000
#define | CAMERA_MEDIA_TYPE_OCCUPY1BIT 0x00010000
#define | CAMERA_MEDIA_TYPE_OCCUPY2BIT 0x00020000
#define | CAMERA_MEDIA_TYPE_OCCUPY4BIT 0x00040000
#define | CAMERA_MEDIA_TYPE_OCCUPY8BIT 0x00080000
#define | CAMERA_MEDIA_TYPE_OCCUPY10BIT 0x000A0000
#define | CAMERA_MEDIA_TYPE_OCCUPY12BIT 0x000C0000
#define | CAMERA_MEDIA_TYPE_OCCUPY16BIT 0x00100000
#define | CAMERA_MEDIA_TYPE_OCCUPY24BIT 0x00180000
#define | CAMERA_MEDIA_TYPE_OCCUPY32BIT 0x00200000
#define | CAMERA_FORMAT_RGB 0x00000014
#define | CAMERA_FORMAT_BGR 0x00000015
#define | CAMERA_FORMAT_MONO 0x00000000
#define | CAMERA_MEDIA_TYPE_COLOR_MASK 0xFF000000
#define | CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK 0x00FF0000
#define | CAMERA_MEDIA_TYPE_ID_MASK 0x0000FFFF
#define | CAMERA_MEDIA_TYPE_MEDIA_FORMAT 0x000000FF
#define | CAMERA_MEDIA_TYPE_BAYGR8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0008)
#define | CAMERA_MEDIA_TYPE_BAYRG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0009)
#define | CAMERA_MEDIA_TYPE_BAYGB8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000A)
#define | CAMERA_MEDIA_TYPE_BAYBG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000B)
#define | CAMERA_MEDIA_TYPE_RGB8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_RGB)
#define | CAMERA_MEDIA_TYPE_BGR8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_BGR)
#define | CAMERA_MEDIA_TYPE_RGBA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_RGB)
#define | CAMERA_MEDIA_TYPE_BGRA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_BGR)
#define | CAMERA_MEDIA_TYPE_MONO8 CAMERA_MEDIA_TYPE_MONO

类型定义

typedef struct _tIspAe | tIspAe
曝光参数 更多...
typedef struct _tIspWb | tIspWb
白平衡参数 更多...
typedef struct _tIspGamma | tIspGamma
gama参数 更多...
typedef struct _tDevLoadMode | tDevLoadMode
设备加载模式信息 更多...
typedef struct _tExpose | tExpose
相机曝光功能范围定义 更多...
typedef struct _tResolutionRange | tResolutionRange
相机的分辨率设定范围，用于构件UI 更多...
typedef struct _tSdkTrigger | tSdkTrigger
触发模式描述 更多...
typedef struct _tSdkImageResolution | tSdkImageResolution
typedef struct _tSdkColorTemperatureDes | tSdkColorTemperatureDes
相机白平衡色温模式描述信息 更多...
typedef struct _tSdkPackLength | tSdkPackLength
传输分包大小描述(主要是针对网络相机有效) 更多...
typedef struct _tSdkPresetLut | tSdkPresetLut
预设的LUT表描述 更多...
typedef struct _tSdkAeAlgorithm | tSdkAeAlgorithm
AE算法描述 更多...
typedef struct _tSdkBayerDecodeAlgorithm | tSdkBayerDecodeAlgorithm
RAW转RGB算法描述 更多...
typedef struct _tSdkMediaType | tSdkMediaType
相机输出的图像数据格式 更多...
typedef struct _tSdkBayerType | tSdkBayerType
相机输出的图像数据格式 更多...
typedef struct _tSdkFrameSpeed | tSdkFrameSpeed
相机帧率描述信息 更多...
typedef struct _tRgbGainRange | tRgbGainRange
RGB三通道数字增益的设定范围 更多...
typedef struct _tSaturationRange | tSaturationRange
饱和度设定的范围 更多...
typedef struct _tSharpnessRange | tSharpnessRange
锐化的设定范围 更多...
typedef struct _tGammaRange | tGammaRange
伽马的设定范围 更多...
typedef struct _tGammaContrastRange | tGammaContrastRange
伽马对比度的设定范围 更多...
typedef struct _tContrastRange | tContrastRange
对比度的设定范围 更多...
typedef struct _tSdkIspCapacity | tSdkIspCapacity
ISP模块的使能信息 更多...
typedef struct _tSensorCfg | tSensorCfg
sensor能力级 更多...
typedef struct _tDeviceCfg | tDeviceCfg
设备能力级 更多...
typedef struct _tDevInfo | tDevInfo
相机的设备信息 更多...
typedef struct _stImageInfo | stImageInfo
帧头信息 更多...
typedef struct _stImageInfo * | PstImageInfo
typedef struct _FrameStatistic | FrameStatistic
帧率统计信息 更多...
typedef struct _tSdkCameraCapbility | tSdkCameraCapbility
相机能力级 更多...
typedef struct _DisplayWindow | DisplayWindow
显示窗口的参数 更多...
typedef struct _tDevEnumInfo | tDevEnumInfo
枚举信息 更多...
typedef struct _tDevLoadInfo | tDevLoadInfo
/设备的当前模式和枚举信息 更多...
typedef void(WINAPI * | CAMERA_SNAP_PROC) (HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)
图像捕获的回调函数定义 更多...
typedef void(WINAPI * | CAMERA_DISPLAY_PROC) (HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
图像显示的回调函数 更多...

枚举

enum emResolutionMode {
IMAGEOUT_MODE_512X384 = 0, IMAGEOUT_MODE_640X480 = 1, IMAGEOUT_MODE_800X600 = 2, IMAGEOUT_MODE_1024X768 = 3,
IMAGEOUT_MODE_1280X720 = 4, IMAGEOUT_MODE_1280X960 = 5, IMAGEOUT_MODE_1920X1280 = 6, IMAGEOUT_MODE_2048X1536 = 7,
IMAGEOUT_MODE_320X240 = 8, IMAGEOUT_MODE_1280X1024 = 9, IMAGEOUT_MODE_1600X1200 = 10, IMAGEOUT_MODE_2592X1944 = 11,
IMAGEOUT_MODE_752X480 = 12, IMAGEOUT_MODE_768X576 = 13, IMAGEOUT_MODE_3664X2748 = 14, IMAGEOUT_MODE_NUM,
IMAGEOUT_MODE_CUSTOM = 0XFF
}
图像分辨率 更多...
enum | emFrameMode { FRAME_SPEED_LOW = 0, FRAME_SPEED_MIDDLE, FRAME_SPEED_HIGH }
帧速度 更多...
enum | emFlickerMode { FREQ_FLICKER_MODE_NULL = 0, FREQ_FLICKER_MODE_50HZ, FREQ_FLICKER_MODE_60HZ }
灯光频闪 更多...
enum emFileType {
FILE_JPG = 1, FILE_BMP = 2, FILE_RAW = 4, FILE_PNG = 8,
FILE_BMP_8BIT = 16, FILE_PNG_8BIT = 32, FILE_RAW_16BIT = 64
}
保存图片的文件格式 更多...
enum | emStatisticsMode { STATISTICS_AVG = 0, STATISTICS_HIST, STATISTICS_WINDOW, STATISTICS_REFER_WINDOW }
曝光算法 更多...
enum | emSdkParameterMode { PARAM_MODE_BY_MODEL = 0, PARAM_MODE_BY_NAME, PARAM_MODE_BY_SN, PARAM_MODE_IN_DEVICE }
参数文件加载方式 更多...
enum emSdkParameterTeam {
PARAMETER_TEAM_A = 0, PARAMETER_TEAM_B = 1, PARAMETER_TEAM_C = 2, PARAMETER_TEAM_D = 3,
PARAMETER_TEAM_DEFAULT = 0xff
}
相机的配置参数，分为A,B,C,D共4组进行保存。 更多...
enum | emTriggerMode { TRIGGER_MODE_CONTINUOUS = 0, TRIGGER_MODE_SOFT, TRIGGER_MODE_HARD }
相机触发模式 更多...
enum mTriggerHardType {
TRIGGER_HARD_IDLE = 0, TRIGGER_HARD_RISE = 1, TRIGGER_HARD_FALL = 2, TRIGGER_HARD_HIGH = 3,
TRIGGER_HARD_LOW = 4
}
图像镜像模式 更多...
enum | emStrobeControl { STROBE_SYNC_WITH_TRIG_AUTO = 0, STROBE_SYNC_WITH_TRIG_MANUAL, STROBE_ALWAYS_HIGH, STROBE_ALWAYS_LOW }
闪光灯信号控制方式 更多...
enum emExtTrigSignal {
EXT_TRIG_LEADING_EDGE = 0, EXT_TRIG_TRAILING_EDGE, EXT_TRIG_HIGH_LEVEL, EXT_TRIG_LOW_LEVEL,
EXT_TRIG_DOUBLE_EDGE
}
硬件外触发的信号种类 更多...
enum | emMirrorMode { MIRROR_MODE_H = 0, MIRROR_MODE_V = 1 }
enum | emSdkDisplayMode { DISPLAYMODE_SCALE = 0, DISPLAYMODE_REAL }
SDK内部显示接口的显示方式 更多...
enum | emAeExpMode { AE_EXP_MODE = 0, AE_FRAME_MODE }
自动曝光模式 更多...
enum emSettingPage {
SETTING_PAGE_DEVINFO = 0x01, SETTING_PAGE_IMG_SETTING = 0x02, SETTING_PAGE_EXP_SETTING = 0x04, SETTING_PAGE_AWB_SETTING = 0x08,
SETTING_PAGE_CROSS_LINE = 0x10, SETTING_PAGE_OUT_SETTING = 0x20, SETTING_PAGE_REL_SETTING = 0x40, SETTING_PAGE_GAMMA_SETTING = 0x80,
SETTING_PAGE_ALL = 0xFF
}
设备属性设置对话框显示的TAB页面的掩码 更多...
enum | emSdkLutChannel { LUT_CHANNEL_ALL = 0, LUT_CHANNEL_RED, LUT_CHANNEL_GREEN, LUT_CHANNEL_BLUE }
LUT的颜色通道 更多...
enum | emSdkLutMode { GAMMA_DYNAMIC_MODE = 0, GAMMA_PRESET_MODE, GAMMA_USER_MODE }
LUT的模式 更多...
enum | emSdkOutputIOMode { IOMODE_STROBE_OUTPUT = 0, IOMODE_GP_OUTPUT, IOMODE_PWM_OUTPUT }
IO输出模式 更多...
enum | emSdkInputIOMode { IOMODE_TRIG_INPUT = 0, IOMODE_GP_INPUT }
IO输入模式 更多...

宏定义说明

#define CAMERA_FORMAT_BGR 0x00000015
#define CAMERA_FORMAT_MONO 0x00000000
#define CAMERA_FORMAT_RGB 0x00000014
#define CAMERA_MEDIA_TYPE_BAYBG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000B)
#define CAMERA_MEDIA_TYPE_BAYGB8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000A)
#define CAMERA_MEDIA_TYPE_BAYGR8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0008)
#define CAMERA_MEDIA_TYPE_BAYRG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0009)
#define CAMERA_MEDIA_TYPE_BGR8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_BGR)
#define CAMERA_MEDIA_TYPE_BGRA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_BGR)
#define CAMERA_MEDIA_TYPE_COLOR 0x02000000
#define CAMERA_MEDIA_TYPE_COLOR_MASK 0xFF000000
#define CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK 0x00FF0000
#define CAMERA_MEDIA_TYPE_ID_MASK 0x0000FFFF
#define CAMERA_MEDIA_TYPE_MEDIA_FORMAT 0x000000FF
#define CAMERA_MEDIA_TYPE_MONO 0x01000000
#define CAMERA_MEDIA_TYPE_MONO8 CAMERA_MEDIA_TYPE_MONO
#define CAMERA_MEDIA_TYPE_OCCUPY10BIT 0x000A0000
#define CAMERA_MEDIA_TYPE_OCCUPY12BIT 0x000C0000
#define CAMERA_MEDIA_TYPE_OCCUPY16BIT 0x00100000
#define CAMERA_MEDIA_TYPE_OCCUPY1BIT 0x00010000
#define CAMERA_MEDIA_TYPE_OCCUPY24BIT 0x00180000
#define CAMERA_MEDIA_TYPE_OCCUPY2BIT 0x00020000
#define CAMERA_MEDIA_TYPE_OCCUPY32BIT 0x00200000
#define CAMERA_MEDIA_TYPE_OCCUPY4BIT 0x00040000
#define CAMERA_MEDIA_TYPE_OCCUPY8BIT 0x00080000
#define CAMERA_MEDIA_TYPE_RGB 0x02000000
#define CAMERA_MEDIA_TYPE_RGB8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_RGB)
#define CAMERA_MEDIA_TYPE_RGBA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_RGB)
#define CROSSLINE_MAX_NUM 9

类型定义说明

typedef struct _DisplayWindow DisplayWindow

显示窗口的参数

typedef struct _FrameStatistic FrameStatistic

帧率统计信息

typedef struct _stImageInfo * PstImageInfo
typedef struct _stImageInfo stImageInfo

帧头信息

typedef struct _tContrastRange tContrastRange

对比度的设定范围

typedef struct _tDevEnumInfo tDevEnumInfo

枚举信息

typedef struct _tDeviceCfg tDeviceCfg

设备能力级

typedef struct _tDevInfo tDevInfo

相机的设备信息

typedef struct _tDevLoadInfo tDevLoadInfo

/设备的当前模式和枚举信息

typedef struct _tDevLoadMode tDevLoadMode

设备加载模式信息

typedef struct _tExpose tExpose

相机曝光功能范围定义

typedef struct _tGammaContrastRange tGammaContrastRange

伽马对比度的设定范围

typedef struct _tGammaRange tGammaRange

伽马的设定范围

typedef struct _tIspAe tIspAe

曝光参数

typedef struct _tIspGamma tIspGamma

gama参数

typedef struct _tIspWb tIspWb

白平衡参数

typedef struct _tResolutionRange tResolutionRange

相机的分辨率设定范围，用于构件UI

typedef struct _tRgbGainRange tRgbGainRange

RGB三通道数字增益的设定范围

typedef struct _tSaturationRange tSaturationRange

饱和度设定的范围

typedef struct _tSdkAeAlgorithm tSdkAeAlgorithm

AE算法描述

typedef struct _tSdkBayerDecodeAlgorithm tSdkBayerDecodeAlgorithm

RAW转RGB算法描述

typedef struct _tSdkBayerType tSdkBayerType

相机输出的图像数据格式

typedef struct _tSdkCameraCapbility tSdkCameraCapbility

相机能力级

typedef struct _tSdkColorTemperatureDes tSdkColorTemperatureDes

相机白平衡色温模式描述信息

typedef struct _tSdkFrameSpeed tSdkFrameSpeed

相机帧率描述信息

typedef struct _tSdkImageResolution tSdkImageResolution
typedef struct _tSdkIspCapacity tSdkIspCapacity

ISP模块的使能信息

typedef struct _tSdkMediaType tSdkMediaType

相机输出的图像数据格式

typedef struct _tSdkPackLength tSdkPackLength

传输分包大小描述(主要是针对网络相机有效)

typedef struct _tSdkPresetLut tSdkPresetLut

预设的LUT表描述

typedef struct _tSdkTrigger tSdkTrigger

触发模式描述

typedef struct _tSensorCfg tSensorCfg

sensor能力级

typedef struct _tSharpnessRange tSharpnessRange

锐化的设定范围


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- a -

  • aD : jquery.js
  • AE_EXP_MODE : CKDeviceDef.h
  • AE_FRAME_MODE : CKDeviceDef.h
  • aM : jquery.js
  • ap : jquery.js
  • aQ : jquery.js
  • au : jquery.js
  • av : jquery.js
  • aZ : jquery.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- b -

  • b : jquery.js
  • bb : jquery.js
  • bl : jquery.js
  • bq : jquery.js
  • bs : jquery.js
  • bu : jquery.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- c -

  • c : jquery.js
  • CAMERA_DISPLAY_PROC : CKDeviceDef.h
  • CAMERA_FORMAT_BGR : CKDeviceDef.h
  • CAMERA_FORMAT_MONO : CKDeviceDef.h
  • CAMERA_FORMAT_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGRA8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_ID_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MEDIA_FORMAT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY10BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY12BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY16BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY1BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY24BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY2BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY32BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY4BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY8BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGBA8 : CKDeviceDef.h
  • CAMERA_SNAP_PROC : CKDeviceDef.h
  • CAMERA_STATUS_ACCESS_DENY : CKDeviceDef.h
  • CAMERA_STATUS_BUS_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_BUSY : CKDeviceDef.h
  • CAMERA_STATUS_CAMERA_NEED_RESET : CKDeviceDef.h
  • CAMERA_STATUS_COMM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_CRITICAL_FILE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DATA_RECV_LESS : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_OPENED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_VEDIO_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_EEPROM_UPDATA : CKDeviceDef.h
  • CAMERA_STATUS_EOF_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_CREATE_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_FUNCTION_LOAD_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_GIGE_FILTER_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_GRAB_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_IIC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IN_PROCESS : CKDeviceDef.h
  • CAMERA_STATUS_INTERNAL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IO_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_DATA_CRC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_LOST_DATA : CKDeviceDef.h
  • CAMERA_STATUS_MV_TEST_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_NET_SEND_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_NO_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_MEMORY : CKDeviceDef.h
  • CAMERA_STATUS_NO_OPEN_DEVICE : CKDeviceDef.h
  • CAMERA_STATUS_NO_WRITE_EEPROM : CKDeviceDef.h
  • CAMERA_STATUS_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_NOT_SUPPORTED : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_DEVICE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_STREAM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OUT_OF_RANGE : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_OUT_OF_BOUND : CKDeviceDef.h
  • CAMERA_STATUS_PATH_NOT_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_READ_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_REGISTRY_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SENSOR_ID_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SIZE_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SOCKET_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SPI_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SUCCESS : CKDeviceDef.h
  • CAMERA_STATUS_TIME_OUT : CKDeviceDef.h
  • CAMERA_STATUS_UNENABLED : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW_SENSOR : CKDeviceDef.h
  • CAMERA_STATUS_USB_BULK_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USB_CONTROL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USER_CANCEL : CKDeviceDef.h
  • CAMERA_STATUS_WAIT : CKDeviceDef.h
  • CAMERA_STATUS_WAIT_TRIGGER : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_PROTECTED : CKDeviceDef.h
  • CameraCheckFwUpdate() : CKCameraInterface.h
  • CameraCreateSettingPageEx() : CKCameraInterface.h
  • CameraCustomizeReferWin() : CKCameraInterface.h
  • CameraCustomizeResolution() : CKCameraInterface.h
  • CameraDisplay() : CKCameraInterface.h
  • CameraDisplayInit() : CKCameraInterface.h
  • CameraDrawText() : CKCameraInterface.h
  • CameraEnumerateDevice() : CKCameraInterface.h
  • CameraGetAeAnalogGainRange() : CKCameraInterface.h
  • CameraGetAeExposureMode() : CKCameraInterface.h
  • CameraGetAeExposureRange() : CKCameraInterface.h
  • CameraGetAeState() : CKCameraInterface.h
  • CameraGetAeTarget() : CKCameraInterface.h
  • CameraGetAeWindow() : CKCameraInterface.h
  • CameraGetAeWinVisible() : CKCameraInterface.h
  • CameraGetAnalogGain() : CKCameraInterface.h
  • CameraGetAntiFlick() : CKCameraInterface.h
  • CameraGetBayerAlgMode() : CKCameraInterface.h
  • CameraGetBlackLevel() : CKCameraInterface.h
  • CameraGetCapability() : CKCameraInterface.h
  • CameraGetContrast() : CKCameraInterface.h
  • CameraGetContrastLut() : CKCameraInterface.h
  • CameraGetCrossLine() : CKCameraInterface.h
  • CameraGetCurDevInfo() : CKCameraInterface.h
  • CameraGetCurrentLut() : CKCameraInterface.h
  • CameraGetCurrentParameterGroup() : CKCameraInterface.h
  • CameraGetCurResolution() : CKCameraInterface.h
  • CameraGetCustomLut() : CKCameraInterface.h
  • CameraGetDeviceType() : CKCameraInterface.h
  • CameraGetEnumIndexInfo() : CKCameraInterface.h
  • CameraGetExposureLineTime() : CKCameraInterface.h
  • CameraGetExposureTime() : CKCameraInterface.h
  • CameraGetFirmwareVision() : CKCameraInterface.h
  • CameraGetFrame() : CKCameraInterface.h
  • CameraGetFrameSpeed() : CKCameraInterface.h
  • CameraGetFrameStatistic() : CKCameraInterface.h
  • CameraGetFriendlyName() : CKCameraInterface.h
  • CameraGetGain() : CKCameraInterface.h
  • CameraGetGamma() : CKCameraInterface.h
  • CameraGetImageBufferEx() : CKCameraInterface.h
  • CameraGetImageBufferEx1() : CKCameraInterface.h
  • CameraGetImageInfo() : CKCameraInterface.h
  • CameraGetInerfaceVersion() : CKCameraInterface.h
  • CameraGetInputIOState() : CKCameraInterface.h
  • CameraGetIspOutFormat() : CKCameraInterface.h
  • CameraGetLightFrequency() : CKCameraInterface.h
  • CameraGetLutMode() : CKCameraInterface.h
  • CameraGetLutPresetSel() : CKCameraInterface.h
  • CameraGetMirror() : CKCameraInterface.h
  • CameraGetMonochrome() : CKCameraInterface.h
  • CameraGetOutImageBuffer() : CKCameraInterface.h
  • CameraGetOutImageSize() : CKCameraInterface.h
  • CameraGetParameterMode() : CKCameraInterface.h
  • CameraGetRawImageBuffer() : CKCameraInterface.h
  • CameraGetResolution() : CKCameraInterface.h
  • CameraGetResolutionEx() : CKCameraInterface.h
  • CameraGetResolutionForSnap() : CKCameraInterface.h
  • CameraGetSaturation() : CKCameraInterface.h
  • CameraGetSharpness() : CKCameraInterface.h
  • CameraGetStrobeDelayTime() : CKCameraInterface.h
  • CameraGetStrobeMode() : CKCameraInterface.h
  • CameraGetStrobePolarity() : CKCameraInterface.h
  • CameraGetStrobePulseWidth() : CKCameraInterface.h
  • CameraGetTriggerDelayTime() : CKCameraInterface.h
  • CameraGetTriggerFrameCount() : CKCameraInterface.h
  • CameraGetTriggerJitterTime() : CKCameraInterface.h
  • CameraGetTriggerMode() : CKCameraInterface.h
  • CameraGetTriggerSignalType() : CKCameraInterface.h
  • CameraGetWbMode() : CKCameraInterface.h
  • CameraGetWbWindow() : CKCameraInterface.h
  • CameraGetWbWinVisible() : CKCameraInterface.h
  • CameraImageOverlay() : CKCameraInterface.h
  • CameraInit() : CKCameraInterface.h
  • CameraInitEx() : CKCameraInterface.h
  • CameraInitEx2() : CKCameraInterface.h
  • CameraInitEx3() : CKCameraInterface.h
  • CameraLoadParameter() : CKCameraInterface.h
  • CameraLoadUserData() : CKCameraInterface.h
  • CameraPause() : CKCameraInterface.h
  • CameraPlay() : CKCameraInterface.h
  • CameraReadParameterFromFile() : CKCameraInterface.h
  • CameraReadSN() : CKCameraInterface.h
  • CameraReleaseFrameHandle() : CKCameraInterface.h
  • CameraSaveImage() : CKCameraInterface.h
  • CameraSaveParameter() : CKCameraInterface.h
  • CameraSaveParameterToFile() : CKCameraInterface.h
  • CameraSaveUserData() : CKCameraInterface.h
  • CameraSdkGetVersionString() : CKCameraInterface.h
  • CameraSdkStatus : CKCameraInterface.h
  • CameraSelectLutPreset() : CKCameraInterface.h
  • CameraSetActivePage() : CKCameraInterface.h
  • CameraSetAeAnalogGainRange() : CKCameraInterface.h
  • CameraSetAeExposureMode() : CKCameraInterface.h
  • CameraSetAeExposureRange() : CKCameraInterface.h
  • CameraSetAeState() : CKCameraInterface.h
  • CameraSetAeTarget() : CKCameraInterface.h
  • CameraSetAeWindow() : CKCameraInterface.h
  • CameraSetAeWinVisible() : CKCameraInterface.h
  • CameraSetAnalogGain() : CKCameraInterface.h
  • CameraSetAntiFlick() : CKCameraInterface.h
  • CameraSetBayerAlgMode() : CKCameraInterface.h
  • CameraSetBayerAlgThreshold() : CKCameraInterface.h
  • CameraSetBlackLevel() : CKCameraInterface.h
  • CameraSetCallbackFunction() : CKCameraInterface.h
  • CameraSetContrast() : CKCameraInterface.h
  • CameraSetContrastLut() : CKCameraInterface.h
  • CameraSetCrossLine() : CKCameraInterface.h
  • CameraSetCustomLut() : CKCameraInterface.h
  • CameraSetDisplayCallbackFun() : CKCameraInterface.h
  • CameraSetDisplayMode() : CKCameraInterface.h
  • CameraSetDisplayOffset() : CKCameraInterface.h
  • CameraSetDisplayScaleRadio() : CKCameraInterface.h
  • CameraSetDisplaySize() : CKCameraInterface.h
  • CameraSetExposureTime() : CKCameraInterface.h
  • CameraSetFrameSpeed() : CKCameraInterface.h
  • CameraSetFriendlyName() : CKCameraInterface.h
  • CameraSetGain() : CKCameraInterface.h
  • CameraSetGamma() : CKCameraInterface.h
  • CameraSetInputIOMode() : CKCameraInterface.h
  • CameraSetIspOutFormat() : CKCameraInterface.h
  • CameraSetLightFrequency() : CKCameraInterface.h
  • CameraSetLutMode() : CKCameraInterface.h
  • CameraSetMirror() : CKCameraInterface.h
  • CameraSetMonochrome() : CKCameraInterface.h
  • CameraSetOnceWB() : CKCameraInterface.h
  • CameraSetOutputIOMode() : CKCameraInterface.h
  • CameraSetOutputIOPWM() : CKCameraInterface.h
  • CameraSetOutputIOState() : CKCameraInterface.h
  • CameraSetParameterMode() : CKCameraInterface.h
  • CameraSetResolution() : CKCameraInterface.h
  • CameraSetResolutionEx() : CKCameraInterface.h
  • CameraSetResolutionForSnap() : CKCameraInterface.h
  • CameraSetSaturation() : CKCameraInterface.h
  • CameraSetSharpness() : CKCameraInterface.h
  • CameraSetStrobeDelayTime() : CKCameraInterface.h
  • CameraSetStrobeMode() : CKCameraInterface.h
  • CameraSetStrobePolarity() : CKCameraInterface.h
  • CameraSetStrobePulseWidth() : CKCameraInterface.h
  • CameraSetTriggerDelayTime() : CKCameraInterface.h
  • CameraSetTriggerFrameCount() : CKCameraInterface.h
  • CameraSetTriggerJitterTime() : CKCameraInterface.h
  • CameraSetTriggerMode() : CKCameraInterface.h
  • CameraSetTriggerSignalType() : CKCameraInterface.h
  • CameraSetWbMode() : CKCameraInterface.h
  • CameraSetWbWindow() : CKCameraInterface.h
  • CameraSetWbWinVisible() : CKCameraInterface.h
  • CameraShowSettingPage() : CKCameraInterface.h
  • CameraSnapToBuffer() : CKCameraInterface.h
  • CameraSoftTrigger() : CKCameraInterface.h
  • CameraUnInit() : CKCameraInterface.h
  • CameraWriteSN() : CKCameraInterface.h
  • CKSDK_API : CKCameraInterface.h
  • CMAERA_STATUS_FPGA_CFG_ERROR : CKDeviceDef.h
  • CROSSLINE_MAX_NUM : CKDeviceDef.h
  • css : jquery.js
  • curCSS : jquery.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- d -

  • DISPLAYMODE_REAL : CKDeviceDef.h
  • DISPLAYMODE_SCALE : CKDeviceDef.h
  • DisplayWindow : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- e -

  • each() : jquery.js
  • emAeExpMode : CKDeviceDef.h
  • emExtTrigSignal : CKDeviceDef.h
  • emFileType : CKDeviceDef.h
  • emFlickerMode : CKDeviceDef.h
  • emFrameMode : CKDeviceDef.h
  • emMirrorMode : CKDeviceDef.h
  • emResolutionMode : CKDeviceDef.h
  • emSdkDisplayMode : CKDeviceDef.h
  • emSdkInputIOMode : CKDeviceDef.h
  • emSdkLutChannel : CKDeviceDef.h
  • emSdkLutMode : CKDeviceDef.h
  • emSdkOutputIOMode : CKDeviceDef.h
  • emSdkParameterMode : CKDeviceDef.h
  • emSdkParameterTeam : CKDeviceDef.h
  • emSettingPage : CKDeviceDef.h
  • emStatisticsMode : CKDeviceDef.h
  • emStrobeControl : CKDeviceDef.h
  • emTriggerMode : CKDeviceDef.h
  • EXT_TRIG_DOUBLE_EDGE : CKDeviceDef.h
  • EXT_TRIG_HIGH_LEVEL : CKDeviceDef.h
  • EXT_TRIG_LEADING_EDGE : CKDeviceDef.h
  • EXT_TRIG_LOW_LEVEL : CKDeviceDef.h
  • EXT_TRIG_TRAILING_EDGE : CKDeviceDef.h
  • extend() : jquery.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- f -

  • FILE_BMP : CKDeviceDef.h
  • FILE_BMP_8BIT : CKDeviceDef.h
  • FILE_JPG : CKDeviceDef.h
  • FILE_PNG : CKDeviceDef.h
  • FILE_PNG_8BIT : CKDeviceDef.h
  • FILE_RAW : CKDeviceDef.h
  • FILE_RAW_16BIT : CKDeviceDef.h
  • FRAME_SPEED_HIGH : CKDeviceDef.h
  • FRAME_SPEED_LOW : CKDeviceDef.h
  • FRAME_SPEED_MIDDLE : CKDeviceDef.h
  • FrameStatistic : CKDeviceDef.h
  • FREQ_FLICKER_MODE_50HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_60HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_NULL : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- g -

  • GAMMA_DYNAMIC_MODE : CKDeviceDef.h
  • GAMMA_PRESET_MODE : CKDeviceDef.h
  • GAMMA_USER_MODE : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- i -

  • if() : jquery.js
  • IMAGEOUT_MODE_1024X768 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X1024 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X720 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X960 : CKDeviceDef.h
  • IMAGEOUT_MODE_1600X1200 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1280 : CKDeviceDef.h
  • IMAGEOUT_MODE_2048X1536 : CKDeviceDef.h
  • IMAGEOUT_MODE_2592X1944 : CKDeviceDef.h
  • IMAGEOUT_MODE_320X240 : CKDeviceDef.h
  • IMAGEOUT_MODE_3664X2748 : CKDeviceDef.h
  • IMAGEOUT_MODE_512X384 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_752X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_768X576 : CKDeviceDef.h
  • IMAGEOUT_MODE_800X600 : CKDeviceDef.h
  • IMAGEOUT_MODE_CUSTOM : CKDeviceDef.h
  • IMAGEOUT_MODE_NUM : CKDeviceDef.h
  • IOMODE_GP_INPUT : CKDeviceDef.h
  • IOMODE_GP_OUTPUT : CKDeviceDef.h
  • IOMODE_PWM_OUTPUT : CKDeviceDef.h
  • IOMODE_STROBE_OUTPUT : CKDeviceDef.h
  • IOMODE_TRIG_INPUT : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- k -

  • k : jquery.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- l -

  • LUT_CHANNEL_ALL : CKDeviceDef.h
  • LUT_CHANNEL_BLUE : CKDeviceDef.h
  • LUT_CHANNEL_GREEN : CKDeviceDef.h
  • LUT_CHANNEL_RED : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- m -

  • MIRROR_MODE_H : CKDeviceDef.h
  • MIRROR_MODE_V : CKDeviceDef.h
  • mTriggerHardType : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- p -

  • p() : jquery.js
  • PARAM_MODE_BY_MODEL : CKDeviceDef.h
  • PARAM_MODE_BY_NAME : CKDeviceDef.h
  • PARAM_MODE_BY_SN : CKDeviceDef.h
  • PARAM_MODE_IN_DEVICE : CKDeviceDef.h
  • PARAMETER_TEAM_A : CKDeviceDef.h
  • PARAMETER_TEAM_B : CKDeviceDef.h
  • PARAMETER_TEAM_C : CKDeviceDef.h
  • PARAMETER_TEAM_D : CKDeviceDef.h
  • PARAMETER_TEAM_DEFAULT : CKDeviceDef.h
  • PstImageInfo : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- s -

  • SETTING_PAGE_ALL : CKDeviceDef.h
  • SETTING_PAGE_AWB_SETTING : CKDeviceDef.h
  • SETTING_PAGE_CROSS_LINE : CKDeviceDef.h
  • SETTING_PAGE_DEVINFO : CKDeviceDef.h
  • SETTING_PAGE_EXP_SETTING : CKDeviceDef.h
  • SETTING_PAGE_GAMMA_SETTING : CKDeviceDef.h
  • SETTING_PAGE_IMG_SETTING : CKDeviceDef.h
  • SETTING_PAGE_OUT_SETTING : CKDeviceDef.h
  • SETTING_PAGE_REL_SETTING : CKDeviceDef.h
  • STATISTICS_AVG : CKDeviceDef.h
  • STATISTICS_HIST : CKDeviceDef.h
  • STATISTICS_REFER_WINDOW : CKDeviceDef.h
  • STATISTICS_WINDOW : CKDeviceDef.h
  • stImageInfo : CKDeviceDef.h
  • STROBE_ALWAYS_HIGH : CKDeviceDef.h
  • STROBE_ALWAYS_LOW : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_AUTO : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_MANUAL : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- t -

  • tContrastRange : CKDeviceDef.h
  • tDevEnumInfo : CKDeviceDef.h
  • tDeviceCfg : CKDeviceDef.h
  • tDevInfo : CKDeviceDef.h
  • tDevLoadInfo : CKDeviceDef.h
  • tDevLoadMode : CKDeviceDef.h
  • tExpose : CKDeviceDef.h
  • tGammaContrastRange : CKDeviceDef.h
  • tGammaRange : CKDeviceDef.h
  • tIspAe : CKDeviceDef.h
  • tIspGamma : CKDeviceDef.h
  • tIspWb : CKDeviceDef.h
  • toggleFolder() : dynsections.js
  • toggleInherit() : dynsections.js
  • toggleLevel() : dynsections.js
  • toggleVisibility() : dynsections.js
  • tResolutionRange : CKDeviceDef.h
  • tRgbGainRange : CKDeviceDef.h
  • TRIGGER_HARD_FALL : CKDeviceDef.h
  • TRIGGER_HARD_HIGH : CKDeviceDef.h
  • TRIGGER_HARD_IDLE : CKDeviceDef.h
  • TRIGGER_HARD_LOW : CKDeviceDef.h
  • TRIGGER_HARD_RISE : CKDeviceDef.h
  • TRIGGER_MODE_CONTINUOUS : CKDeviceDef.h
  • TRIGGER_MODE_HARD : CKDeviceDef.h
  • TRIGGER_MODE_SOFT : CKDeviceDef.h
  • tSaturationRange : CKDeviceDef.h
  • tSdkAeAlgorithm : CKDeviceDef.h
  • tSdkBayerDecodeAlgorithm : CKDeviceDef.h
  • tSdkBayerType : CKDeviceDef.h
  • tSdkCameraCapbility : CKDeviceDef.h
  • tSdkColorTemperatureDes : CKDeviceDef.h
  • tSdkFrameSpeed : CKDeviceDef.h
  • tSdkImageResolution : CKDeviceDef.h
  • tSdkIspCapacity : CKDeviceDef.h
  • tSdkMediaType : CKDeviceDef.h
  • tSdkPackLength : CKDeviceDef.h
  • tSdkPresetLut : CKDeviceDef.h
  • tSdkTrigger : CKDeviceDef.h
  • tSensorCfg : CKDeviceDef.h
  • tSharpnessRange : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- u -

  • updateStripes() : dynsections.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • p
  • s
  • t
  • u
  • z
这里列出了所有文件成员,并附带其所属的文件:

- z -

  • Z : jquery.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • b
  • c
  • e
  • i
  • p
  • t
  • u

- b -

  • b() : jquery.js

- c -

  • CameraCheckFwUpdate() : CKCameraInterface.h
  • CameraCreateSettingPageEx() : CKCameraInterface.h
  • CameraCustomizeReferWin() : CKCameraInterface.h
  • CameraCustomizeResolution() : CKCameraInterface.h
  • CameraDisplay() : CKCameraInterface.h
  • CameraDisplayInit() : CKCameraInterface.h
  • CameraDrawText() : CKCameraInterface.h
  • CameraEnumerateDevice() : CKCameraInterface.h
  • CameraGetAeAnalogGainRange() : CKCameraInterface.h
  • CameraGetAeExposureMode() : CKCameraInterface.h
  • CameraGetAeExposureRange() : CKCameraInterface.h
  • CameraGetAeState() : CKCameraInterface.h
  • CameraGetAeTarget() : CKCameraInterface.h
  • CameraGetAeWindow() : CKCameraInterface.h
  • CameraGetAeWinVisible() : CKCameraInterface.h
  • CameraGetAnalogGain() : CKCameraInterface.h
  • CameraGetAntiFlick() : CKCameraInterface.h
  • CameraGetBayerAlgMode() : CKCameraInterface.h
  • CameraGetBlackLevel() : CKCameraInterface.h
  • CameraGetCapability() : CKCameraInterface.h
  • CameraGetContrast() : CKCameraInterface.h
  • CameraGetContrastLut() : CKCameraInterface.h
  • CameraGetCrossLine() : CKCameraInterface.h
  • CameraGetCurDevInfo() : CKCameraInterface.h
  • CameraGetCurrentLut() : CKCameraInterface.h
  • CameraGetCurrentParameterGroup() : CKCameraInterface.h
  • CameraGetCurResolution() : CKCameraInterface.h
  • CameraGetCustomLut() : CKCameraInterface.h
  • CameraGetDeviceType() : CKCameraInterface.h
  • CameraGetEnumIndexInfo() : CKCameraInterface.h
  • CameraGetExposureLineTime() : CKCameraInterface.h
  • CameraGetExposureTime() : CKCameraInterface.h
  • CameraGetFirmwareVision() : CKCameraInterface.h
  • CameraGetFrame() : CKCameraInterface.h
  • CameraGetFrameSpeed() : CKCameraInterface.h
  • CameraGetFrameStatistic() : CKCameraInterface.h
  • CameraGetFriendlyName() : CKCameraInterface.h
  • CameraGetGain() : CKCameraInterface.h
  • CameraGetGamma() : CKCameraInterface.h
  • CameraGetImageBufferEx() : CKCameraInterface.h
  • CameraGetImageBufferEx1() : CKCameraInterface.h
  • CameraGetImageInfo() : CKCameraInterface.h
  • CameraGetInerfaceVersion() : CKCameraInterface.h
  • CameraGetInputIOState() : CKCameraInterface.h
  • CameraGetIspOutFormat() : CKCameraInterface.h
  • CameraGetLightFrequency() : CKCameraInterface.h
  • CameraGetLutMode() : CKCameraInterface.h
  • CameraGetLutPresetSel() : CKCameraInterface.h
  • CameraGetMirror() : CKCameraInterface.h
  • CameraGetMonochrome() : CKCameraInterface.h
  • CameraGetOutImageBuffer() : CKCameraInterface.h
  • CameraGetOutImageSize() : CKCameraInterface.h
  • CameraGetParameterMode() : CKCameraInterface.h
  • CameraGetRawImageBuffer() : CKCameraInterface.h
  • CameraGetResolution() : CKCameraInterface.h
  • CameraGetResolutionEx() : CKCameraInterface.h
  • CameraGetResolutionForSnap() : CKCameraInterface.h
  • CameraGetSaturation() : CKCameraInterface.h
  • CameraGetSharpness() : CKCameraInterface.h
  • CameraGetStrobeDelayTime() : CKCameraInterface.h
  • CameraGetStrobeMode() : CKCameraInterface.h
  • CameraGetStrobePolarity() : CKCameraInterface.h
  • CameraGetStrobePulseWidth() : CKCameraInterface.h
  • CameraGetTriggerDelayTime() : CKCameraInterface.h
  • CameraGetTriggerFrameCount() : CKCameraInterface.h
  • CameraGetTriggerJitterTime() : CKCameraInterface.h
  • CameraGetTriggerMode() : CKCameraInterface.h
  • CameraGetTriggerSignalType() : CKCameraInterface.h
  • CameraGetWbMode() : CKCameraInterface.h
  • CameraGetWbWindow() : CKCameraInterface.h
  • CameraGetWbWinVisible() : CKCameraInterface.h
  • CameraImageOverlay() : CKCameraInterface.h
  • CameraInit() : CKCameraInterface.h
  • CameraInitEx() : CKCameraInterface.h
  • CameraInitEx2() : CKCameraInterface.h
  • CameraInitEx3() : CKCameraInterface.h
  • CameraLoadParameter() : CKCameraInterface.h
  • CameraLoadUserData() : CKCameraInterface.h
  • CameraPause() : CKCameraInterface.h
  • CameraPlay() : CKCameraInterface.h
  • CameraReadParameterFromFile() : CKCameraInterface.h
  • CameraReadSN() : CKCameraInterface.h
  • CameraReleaseFrameHandle() : CKCameraInterface.h
  • CameraSaveImage() : CKCameraInterface.h
  • CameraSaveParameter() : CKCameraInterface.h
  • CameraSaveParameterToFile() : CKCameraInterface.h
  • CameraSaveUserData() : CKCameraInterface.h
  • CameraSdkGetVersionString() : CKCameraInterface.h
  • CameraSelectLutPreset() : CKCameraInterface.h
  • CameraSetActivePage() : CKCameraInterface.h
  • CameraSetAeAnalogGainRange() : CKCameraInterface.h
  • CameraSetAeExposureMode() : CKCameraInterface.h
  • CameraSetAeExposureRange() : CKCameraInterface.h
  • CameraSetAeState() : CKCameraInterface.h
  • CameraSetAeTarget() : CKCameraInterface.h
  • CameraSetAeWindow() : CKCameraInterface.h
  • CameraSetAeWinVisible() : CKCameraInterface.h
  • CameraSetAnalogGain() : CKCameraInterface.h
  • CameraSetAntiFlick() : CKCameraInterface.h
  • CameraSetBayerAlgMode() : CKCameraInterface.h
  • CameraSetBayerAlgThreshold() : CKCameraInterface.h
  • CameraSetBlackLevel() : CKCameraInterface.h
  • CameraSetCallbackFunction() : CKCameraInterface.h
  • CameraSetContrast() : CKCameraInterface.h
  • CameraSetContrastLut() : CKCameraInterface.h
  • CameraSetCrossLine() : CKCameraInterface.h
  • CameraSetCustomLut() : CKCameraInterface.h
  • CameraSetDisplayCallbackFun() : CKCameraInterface.h
  • CameraSetDisplayMode() : CKCameraInterface.h
  • CameraSetDisplayOffset() : CKCameraInterface.h
  • CameraSetDisplayScaleRadio() : CKCameraInterface.h
  • CameraSetDisplaySize() : CKCameraInterface.h
  • CameraSetExposureTime() : CKCameraInterface.h
  • CameraSetFrameSpeed() : CKCameraInterface.h
  • CameraSetFriendlyName() : CKCameraInterface.h
  • CameraSetGain() : CKCameraInterface.h
  • CameraSetGamma() : CKCameraInterface.h
  • CameraSetInputIOMode() : CKCameraInterface.h
  • CameraSetIspOutFormat() : CKCameraInterface.h
  • CameraSetLightFrequency() : CKCameraInterface.h
  • CameraSetLutMode() : CKCameraInterface.h
  • CameraSetMirror() : CKCameraInterface.h
  • CameraSetMonochrome() : CKCameraInterface.h
  • CameraSetOnceWB() : CKCameraInterface.h
  • CameraSetOutputIOMode() : CKCameraInterface.h
  • CameraSetOutputIOPWM() : CKCameraInterface.h
  • CameraSetOutputIOState() : CKCameraInterface.h
  • CameraSetParameterMode() : CKCameraInterface.h
  • CameraSetResolution() : CKCameraInterface.h
  • CameraSetResolutionEx() : CKCameraInterface.h
  • CameraSetResolutionForSnap() : CKCameraInterface.h
  • CameraSetSaturation() : CKCameraInterface.h
  • CameraSetSharpness() : CKCameraInterface.h
  • CameraSetStrobeDelayTime() : CKCameraInterface.h
  • CameraSetStrobeMode() : CKCameraInterface.h
  • CameraSetStrobePolarity() : CKCameraInterface.h
  • CameraSetStrobePulseWidth() : CKCameraInterface.h
  • CameraSetTriggerDelayTime() : CKCameraInterface.h
  • CameraSetTriggerFrameCount() : CKCameraInterface.h
  • CameraSetTriggerJitterTime() : CKCameraInterface.h
  • CameraSetTriggerMode() : CKCameraInterface.h
  • CameraSetTriggerSignalType() : CKCameraInterface.h
  • CameraSetWbMode() : CKCameraInterface.h
  • CameraSetWbWindow() : CKCameraInterface.h
  • CameraSetWbWinVisible() : CKCameraInterface.h
  • CameraShowSettingPage() : CKCameraInterface.h
  • CameraSnapToBuffer() : CKCameraInterface.h
  • CameraSoftTrigger() : CKCameraInterface.h
  • CameraUnInit() : CKCameraInterface.h
  • CameraWriteSN() : CKCameraInterface.h

- e -

  • each() : jquery.js
  • extend() : jquery.js

- i -

  • if() : jquery.js

- p -

  • p() : jquery.js

- t -

  • toggleFolder() : dynsections.js
  • toggleInherit() : dynsections.js
  • toggleLevel() : dynsections.js
  • toggleVisibility() : dynsections.js

- u -

  • updateStripes() : dynsections.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • aD : jquery.js
  • aM : jquery.js
  • ap : jquery.js
  • aQ : jquery.js
  • au : jquery.js
  • av : jquery.js
  • aZ : jquery.js
  • b : jquery.js
  • bb : jquery.js
  • bl : jquery.js
  • bq : jquery.js
  • bs : jquery.js
  • bu : jquery.js
  • c : jquery.js
  • css : jquery.js
  • curCSS : jquery.js
  • k : jquery.js
  • Z : jquery.js


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • c
  • d
  • f
  • p
  • s
  • t

- c -

  • CAMERA_DISPLAY_PROC : CKDeviceDef.h
  • CAMERA_SNAP_PROC : CKDeviceDef.h
  • CameraSdkStatus : CKCameraInterface.h

- d -

  • DisplayWindow : CKDeviceDef.h

- f -

  • FrameStatistic : CKDeviceDef.h

- p -

  • PstImageInfo : CKDeviceDef.h

- s -

  • stImageInfo : CKDeviceDef.h

- t -

  • tContrastRange : CKDeviceDef.h
  • tDevEnumInfo : CKDeviceDef.h
  • tDeviceCfg : CKDeviceDef.h
  • tDevInfo : CKDeviceDef.h
  • tDevLoadInfo : CKDeviceDef.h
  • tDevLoadMode : CKDeviceDef.h
  • tExpose : CKDeviceDef.h
  • tGammaContrastRange : CKDeviceDef.h
  • tGammaRange : CKDeviceDef.h
  • tIspAe : CKDeviceDef.h
  • tIspGamma : CKDeviceDef.h
  • tIspWb : CKDeviceDef.h
  • tResolutionRange : CKDeviceDef.h
  • tRgbGainRange : CKDeviceDef.h
  • tSaturationRange : CKDeviceDef.h
  • tSdkAeAlgorithm : CKDeviceDef.h
  • tSdkBayerDecodeAlgorithm : CKDeviceDef.h
  • tSdkBayerType : CKDeviceDef.h
  • tSdkCameraCapbility : CKDeviceDef.h
  • tSdkColorTemperatureDes : CKDeviceDef.h
  • tSdkFrameSpeed : CKDeviceDef.h
  • tSdkImageResolution : CKDeviceDef.h
  • tSdkIspCapacity : CKDeviceDef.h
  • tSdkMediaType : CKDeviceDef.h
  • tSdkPackLength : CKDeviceDef.h
  • tSdkPresetLut : CKDeviceDef.h
  • tSdkTrigger : CKDeviceDef.h
  • tSensorCfg : CKDeviceDef.h
  • tSharpnessRange : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • emAeExpMode : CKDeviceDef.h
  • emExtTrigSignal : CKDeviceDef.h
  • emFileType : CKDeviceDef.h
  • emFlickerMode : CKDeviceDef.h
  • emFrameMode : CKDeviceDef.h
  • emMirrorMode : CKDeviceDef.h
  • emResolutionMode : CKDeviceDef.h
  • emSdkDisplayMode : CKDeviceDef.h
  • emSdkInputIOMode : CKDeviceDef.h
  • emSdkLutChannel : CKDeviceDef.h
  • emSdkLutMode : CKDeviceDef.h
  • emSdkOutputIOMode : CKDeviceDef.h
  • emSdkParameterMode : CKDeviceDef.h
  • emSdkParameterTeam : CKDeviceDef.h
  • emSettingPage : CKDeviceDef.h
  • emStatisticsMode : CKDeviceDef.h
  • emStrobeControl : CKDeviceDef.h
  • emTriggerMode : CKDeviceDef.h
  • mTriggerHardType : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • a
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • p
  • s
  • t

- a -

  • AE_EXP_MODE : CKDeviceDef.h
  • AE_FRAME_MODE : CKDeviceDef.h

- d -

  • DISPLAYMODE_REAL : CKDeviceDef.h
  • DISPLAYMODE_SCALE : CKDeviceDef.h

- e -

  • EXT_TRIG_DOUBLE_EDGE : CKDeviceDef.h
  • EXT_TRIG_HIGH_LEVEL : CKDeviceDef.h
  • EXT_TRIG_LEADING_EDGE : CKDeviceDef.h
  • EXT_TRIG_LOW_LEVEL : CKDeviceDef.h
  • EXT_TRIG_TRAILING_EDGE : CKDeviceDef.h

- f -

  • FILE_BMP : CKDeviceDef.h
  • FILE_BMP_8BIT : CKDeviceDef.h
  • FILE_JPG : CKDeviceDef.h
  • FILE_PNG : CKDeviceDef.h
  • FILE_PNG_8BIT : CKDeviceDef.h
  • FILE_RAW : CKDeviceDef.h
  • FILE_RAW_16BIT : CKDeviceDef.h
  • FRAME_SPEED_HIGH : CKDeviceDef.h
  • FRAME_SPEED_LOW : CKDeviceDef.h
  • FRAME_SPEED_MIDDLE : CKDeviceDef.h
  • FREQ_FLICKER_MODE_50HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_60HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_NULL : CKDeviceDef.h

- g -

  • GAMMA_DYNAMIC_MODE : CKDeviceDef.h
  • GAMMA_PRESET_MODE : CKDeviceDef.h
  • GAMMA_USER_MODE : CKDeviceDef.h

- i -

  • IMAGEOUT_MODE_1024X768 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X1024 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X720 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X960 : CKDeviceDef.h
  • IMAGEOUT_MODE_1600X1200 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1280 : CKDeviceDef.h
  • IMAGEOUT_MODE_2048X1536 : CKDeviceDef.h
  • IMAGEOUT_MODE_2592X1944 : CKDeviceDef.h
  • IMAGEOUT_MODE_320X240 : CKDeviceDef.h
  • IMAGEOUT_MODE_3664X2748 : CKDeviceDef.h
  • IMAGEOUT_MODE_512X384 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_752X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_768X576 : CKDeviceDef.h
  • IMAGEOUT_MODE_800X600 : CKDeviceDef.h
  • IMAGEOUT_MODE_CUSTOM : CKDeviceDef.h
  • IMAGEOUT_MODE_NUM : CKDeviceDef.h
  • IOMODE_GP_INPUT : CKDeviceDef.h
  • IOMODE_GP_OUTPUT : CKDeviceDef.h
  • IOMODE_PWM_OUTPUT : CKDeviceDef.h
  • IOMODE_STROBE_OUTPUT : CKDeviceDef.h
  • IOMODE_TRIG_INPUT : CKDeviceDef.h

- l -

  • LUT_CHANNEL_ALL : CKDeviceDef.h
  • LUT_CHANNEL_BLUE : CKDeviceDef.h
  • LUT_CHANNEL_GREEN : CKDeviceDef.h
  • LUT_CHANNEL_RED : CKDeviceDef.h

- m -

  • MIRROR_MODE_H : CKDeviceDef.h
  • MIRROR_MODE_V : CKDeviceDef.h

- p -

  • PARAM_MODE_BY_MODEL : CKDeviceDef.h
  • PARAM_MODE_BY_NAME : CKDeviceDef.h
  • PARAM_MODE_BY_SN : CKDeviceDef.h
  • PARAM_MODE_IN_DEVICE : CKDeviceDef.h
  • PARAMETER_TEAM_A : CKDeviceDef.h
  • PARAMETER_TEAM_B : CKDeviceDef.h
  • PARAMETER_TEAM_C : CKDeviceDef.h
  • PARAMETER_TEAM_D : CKDeviceDef.h
  • PARAMETER_TEAM_DEFAULT : CKDeviceDef.h

- s -

  • SETTING_PAGE_ALL : CKDeviceDef.h
  • SETTING_PAGE_AWB_SETTING : CKDeviceDef.h
  • SETTING_PAGE_CROSS_LINE : CKDeviceDef.h
  • SETTING_PAGE_DEVINFO : CKDeviceDef.h
  • SETTING_PAGE_EXP_SETTING : CKDeviceDef.h
  • SETTING_PAGE_GAMMA_SETTING : CKDeviceDef.h
  • SETTING_PAGE_IMG_SETTING : CKDeviceDef.h
  • SETTING_PAGE_OUT_SETTING : CKDeviceDef.h
  • SETTING_PAGE_REL_SETTING : CKDeviceDef.h
  • STATISTICS_AVG : CKDeviceDef.h
  • STATISTICS_HIST : CKDeviceDef.h
  • STATISTICS_REFER_WINDOW : CKDeviceDef.h
  • STATISTICS_WINDOW : CKDeviceDef.h
  • STROBE_ALWAYS_HIGH : CKDeviceDef.h
  • STROBE_ALWAYS_LOW : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_AUTO : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_MANUAL : CKDeviceDef.h

- t -

  • TRIGGER_HARD_FALL : CKDeviceDef.h
  • TRIGGER_HARD_HIGH : CKDeviceDef.h
  • TRIGGER_HARD_IDLE : CKDeviceDef.h
  • TRIGGER_HARD_LOW : CKDeviceDef.h
  • TRIGGER_HARD_RISE : CKDeviceDef.h
  • TRIGGER_MODE_CONTINUOUS : CKDeviceDef.h
  • TRIGGER_MODE_HARD : CKDeviceDef.h
  • TRIGGER_MODE_SOFT : CKDeviceDef.h


CKCameraAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 枚举
  • 枚举值
  • 宏定义
  • c

- c -

  • CAMERA_FORMAT_BGR : CKDeviceDef.h
  • CAMERA_FORMAT_MONO : CKDeviceDef.h
  • CAMERA_FORMAT_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGRA8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_ID_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MEDIA_FORMAT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY10BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY12BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY16BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY1BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY24BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY2BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY32BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY4BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY8BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGBA8 : CKDeviceDef.h
  • CAMERA_STATUS_ACCESS_DENY : CKDeviceDef.h
  • CAMERA_STATUS_BUS_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_BUSY : CKDeviceDef.h
  • CAMERA_STATUS_CAMERA_NEED_RESET : CKDeviceDef.h
  • CAMERA_STATUS_COMM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_CRITICAL_FILE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DATA_RECV_LESS : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_OPENED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_VEDIO_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_EEPROM_UPDATA : CKDeviceDef.h
  • CAMERA_STATUS_EOF_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_CREATE_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_FUNCTION_LOAD_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_GIGE_FILTER_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_GRAB_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_IIC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IN_PROCESS : CKDeviceDef.h
  • CAMERA_STATUS_INTERNAL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IO_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_DATA_CRC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_LOST_DATA : CKDeviceDef.h
  • CAMERA_STATUS_MV_TEST_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_NET_SEND_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_NO_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_MEMORY : CKDeviceDef.h
  • CAMERA_STATUS_NO_OPEN_DEVICE : CKDeviceDef.h
  • CAMERA_STATUS_NO_WRITE_EEPROM : CKDeviceDef.h
  • CAMERA_STATUS_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_NOT_SUPPORTED : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_DEVICE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_STREAM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OUT_OF_RANGE : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_OUT_OF_BOUND : CKDeviceDef.h
  • CAMERA_STATUS_PATH_NOT_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_READ_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_REGISTRY_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SENSOR_ID_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SIZE_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SOCKET_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SPI_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SUCCESS : CKDeviceDef.h
  • CAMERA_STATUS_TIME_OUT : CKDeviceDef.h
  • CAMERA_STATUS_UNENABLED : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW_SENSOR : CKDeviceDef.h
  • CAMERA_STATUS_USB_BULK_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USB_CONTROL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USER_CANCEL : CKDeviceDef.h
  • CAMERA_STATUS_WAIT : CKDeviceDef.h
  • CAMERA_STATUS_WAIT_TRIGGER : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_PROTECTED : CKDeviceDef.h
  • CKSDK_API : CKCameraInterface.h
  • CMAERA_STATUS_FPGA_CFG_ERROR : CKDeviceDef.h
  • CROSSLINE_MAX_NUM : CKDeviceDef.h


CKCameraAPI: CKCameraInterface.h 源文件

  • 文件列表
  • 文件成员
CKCameraInterface.h
浏览该文件的文档.
1
138
149
182
185
194
201
205
245
253
257
273 #ifndef __CK_CAMERA_INTERFACE_H__
274 #define __CK_CAMERA_INTERFACE_H__
275
276 #include "CKDeviceDef.h"
277
278
279 #ifdef CKCAMERADLL_EXPORTS
280 #define CKSDK_API _declspec(dllexport)
281 #elif defined(CKCAMERALIB)
282 #define CKSDK_API
283 #else
284 #define CKSDK_API _declspec(dllimport)
285 #endif
286
287
288 typedef int CameraSdkStatus;
289
290
291 extern "C" {
292
293 /****************************************************************************************/
294 /****************************************************************************************/
295 /****************************************************************************************/
296 /****************************************************************************************/
302 /****************************************************************************************/
303 /****************************************************************************************/
304 /****************************************************************************************/
305 /****************************************************************************************/
315 CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDevice(INT *pDeviceNum);
316
326 CKSDK_API CameraSdkStatus __stdcall CameraGetEnumIndexInfo(INT CameraIndex, tDevEnumInfo* pDevInfo);
345 CKSDK_API CameraSdkStatus __stdcall CameraInit(PHANDLE phCamera, INT CameraIndex);
346
367 CKSDK_API CameraSdkStatus __stdcall CameraInitEx(PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam);
368
387 CKSDK_API CameraSdkStatus __stdcall CameraInitEx2(PHANDLE phCamera, const char *pFriendlyName);
388
405 CKSDK_API CameraSdkStatus __stdcall CameraInitEx3(PHANDLE phCamera, const char *pCameraSN);
406
417 CKSDK_API CameraSdkStatus __stdcall CameraUnInit(HANDLE hCamera);
418
426 CKSDK_API CameraSdkStatus __stdcall CameraGetCapability(HANDLE hCamera, tSdkCameraCapbility* pCameraCap);
427
434 CKSDK_API CameraSdkStatus __stdcall CameraGetCurDevInfo(HANDLE hCamera, tDevLoadInfo* pDevInfo);
463 CKSDK_API CameraSdkStatus __stdcall CameraGetRawImageBuffer(HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes);
464
474 CKSDK_API CameraSdkStatus __stdcall CameraReleaseFrameHandle(HANDLE hCamera, HANDLE hRawBuf);
475
503 CKSDK_API BYTE* __stdcall CameraGetImageInfo(HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo);
504
521 CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageBuffer(HANDLE hCamera, stImageInfo *pImgInfo, HANDLE hRawBuf, BYTE *pImgBuf);
522
535 CKSDK_API BYTE* __stdcall CameraGetImageBufferEx(HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes);
536
548 CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx1(HANDLE hCamera, BYTE* pImageData, stImageInfo *pImgInfo, UINT uTimes);
549
560 CKSDK_API CameraSdkStatus __stdcall CameraSetCallbackFunction(HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld);
575 CKSDK_API CameraSdkStatus __stdcall CameraPause(HANDLE hCamera);
576
585 CKSDK_API CameraSdkStatus __stdcall CameraPlay(HANDLE hCamera);
588 /****************************************************************************************/
589 /****************************************************************************************/
590 /****************************************************************************************/
591 /****************************************************************************************/
613 CKSDK_API CameraSdkStatus __stdcall CameraDisplayInit(HANDLE hCamera, HWND hWndDisplay);
614
623 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayMode(HANDLE hCamera, INT iMode);
624
634 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayScaleRadio(HANDLE hCamera, INT iRadio);
635
647 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayOffset(HANDLE hCamera, INT iOffsetX, INT iOffsetY);
648
657 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplaySize(HANDLE hCamera, INT iWidth, INT iHeight);
658
670 CKSDK_API CameraSdkStatus __stdcall CameraSetCrossLine(HANDLE hCamera, INT iLine,INT x,INT y,UINT uColor,BOOL bVisible);
671
682 CKSDK_API CameraSdkStatus __stdcall CameraGetCrossLine(HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible);
683
694 CKSDK_API CameraSdkStatus __stdcall CameraImageOverlay(HANDLE hCamera, BYTE* pImgBuf, const stImageInfo* pImgInfo);
695
712 CKSDK_API CameraSdkStatus __stdcall CameraDrawText(BYTE* pImgBuf, const stImageInfo* pImgInfo,
713 char const* pFontFileName,
714 UINT FontWidth,
715 UINT FontHeight,
716 char const* pText,
717 INT Left,
718 INT Top,
719 UINT Width,
720 UINT Height,
721 UINT TextColor,
722 UINT uFlags
723 );
724
732 CKSDK_API CameraSdkStatus __stdcall CameraDisplay(HANDLE hCamera, BYTE* pImgBuf, stImageInfo* pImgInfo);
733
745 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayCallbackFun(HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld);
749 /****************************************************************************************/
750 /****************************************************************************************/
751 /****************************************************************************************/
752 /****************************************************************************************/
771 CKSDK_API CameraSdkStatus __stdcall CameraSnapToBuffer(HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE** ppImgBuf, UINT uWaitTimeMs);
772
783 CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionForSnap(HANDLE hCamera,tSdkImageResolution* pImageResolution);
784
791 CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionForSnap(HANDLE hCamera,tSdkImageResolution* pImageResolution);
792
795 /****************************************************************************************/
796 /****************************************************************************************/
797 /****************************************************************************************/
798 /****************************************************************************************/
815 CKSDK_API CameraSdkStatus __stdcall CameraSetAeState(HANDLE hCamera, BOOL bAeState);
816
823 CKSDK_API CameraSdkStatus __stdcall CameraGetAeState(HANDLE hCamera, BOOL *pAeState);
824
831 CKSDK_API CameraSdkStatus __stdcall CameraSetAeTarget(HANDLE hCamera, WORD AeTarget);
832
839 CKSDK_API CameraSdkStatus __stdcall CameraGetAeTarget(HANDLE hCamera, WORD *pAeTarget);
840
853 CKSDK_API CameraSdkStatus __stdcall CameraSetAnalogGain(HANDLE hCamera, UINT uAnalogGain);
854
861 CKSDK_API CameraSdkStatus __stdcall CameraGetAnalogGain(HANDLE hCamera, UINT *puAnalogGain);
862
879 CKSDK_API CameraSdkStatus __stdcall CameraSetExposureTime(HANDLE hCamera, double dExposureTime);
880
888 CKSDK_API CameraSdkStatus __stdcall CameraGetExposureTime(HANDLE hCamera, double *pdExposureTime);
889
899 CKSDK_API CameraSdkStatus __stdcall CameraSetAeWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight);
900
910 CKSDK_API CameraSdkStatus __stdcall CameraGetAeWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight);
911
920 CKSDK_API CameraSdkStatus __stdcall CameraSetAeWinVisible(HANDLE hCamera, BOOL bDisplayEn);
921
928 CKSDK_API CameraSdkStatus __stdcall CameraGetAeWinVisible(HANDLE hCamera, BOOL *pbDisplayEn);
929
937 CKSDK_API CameraSdkStatus __stdcall CameraSetAntiFlick(HANDLE hCamera, BOOL bEnable);
938
945 CKSDK_API CameraSdkStatus __stdcall CameraGetAntiFlick(HANDLE hCamera, BOOL *pbEnable);
946
953 CKSDK_API CameraSdkStatus __stdcall CameraSetLightFrequency(HANDLE hCamera, INT iFrequencySel);
954
961 CKSDK_API CameraSdkStatus __stdcall CameraGetLightFrequency(HANDLE hCamera, INT *piFrequencySel);
962
969 CKSDK_API CameraSdkStatus __stdcall CameraGetExposureLineTime(HANDLE hCamera, double *pExposureLineTime);
970
977 CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureMode(HANDLE hCamera, INT iMode);
978
985 CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureMode(HANDLE hCamera, INT* piMode);
986
994 CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureRange(HANDLE hCamera,double dMinExposureTime,double dMaxExposureTime);
995
1003 CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureRange(HANDLE hCamera,double* pdMinExposureTime,double* pdMaxExposureTime);
1004
1012 CKSDK_API CameraSdkStatus __stdcall CameraSetAeAnalogGainRange(HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain);
1013
1021 CKSDK_API CameraSdkStatus __stdcall CameraGetAeAnalogGainRange(HANDLE hCamera, INT* iMinAnalogGain, INT* iMaxAnalogGain);
1022
1035 CKSDK_API CameraSdkStatus __stdcall CameraSetGain(HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB);
1036
1046 CKSDK_API CameraSdkStatus __stdcall CameraGetGain(HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB);
1047
1051 /****************************************************************************************/
1052 /****************************************************************************************/
1053 /****************************************************************************************/
1054 /****************************************************************************************/
1066 CKSDK_API CameraSdkStatus __stdcall CameraSetWbMode(HANDLE hCamera, BOOL bAuto);
1067
1075 CKSDK_API CameraSdkStatus __stdcall CameraGetWbMode(HANDLE hCamera, BOOL *pbAuto);
1076
1084 CKSDK_API CameraSdkStatus __stdcall CameraSetOnceWB(HANDLE hCamera);
1085
1095 CKSDK_API CameraSdkStatus __stdcall CameraSetWbWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight);
1096
1106 CKSDK_API CameraSdkStatus __stdcall CameraGetWbWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight);
1107
1114 CKSDK_API CameraSdkStatus __stdcall CameraSetWbWinVisible(HANDLE hCamera, BOOL bDisplayEn);
1115
1122 CKSDK_API CameraSdkStatus __stdcall CameraGetWbWinVisible(HANDLE hCamera, BOOL *pDisplayEn);
1125 /****************************************************************************************/
1126 /****************************************************************************************/
1127 /****************************************************************************************/
1128 /****************************************************************************************/
1142 CKSDK_API CameraSdkStatus __stdcall CameraSetLutMode(HANDLE hCamera, INT emLutMode);
1143
1151 CKSDK_API CameraSdkStatus __stdcall CameraGetLutMode(HANDLE hCamera, INT *pemLutMode);
1152
1162 CKSDK_API CameraSdkStatus __stdcall CameraSetGamma(HANDLE hCamera, int iGamma);
1163
1171 CKSDK_API CameraSdkStatus __stdcall CameraGetGamma(HANDLE hCamera,int* piGamma);
1172
1173 /******************************************************/
1174 // 函数名 : CameraSetContrastLut
1175 // 功能描述 : 设定LUT动态生成模式下的对比度值。设定的值会
1176 // 马上保存在SDK内部，但是只有当相机处于动态
1177 // 参数生成的LUT模式时，才会生效。请参考CameraSetLutMode
1178 // 的函数说明部分。
1179 // 参数 : hCamera 相机的句柄，由CameraInit函数获得。
1180 // iContrast 设定的对比度值。
1181 // 返回值 : 成功时，返回CAMERA_STATUS_SUCCESS (0);
1182 // 否则返回非0值的错误码,请参考CKDeviceStatus.h
1183 // 中错误码的定义。
1184 /******************************************************/
1185 CKSDK_API CameraSdkStatus __stdcall CameraSetContrastLut(HANDLE hCamera,int iContrast);
1186
1187 /******************************************************/
1188 // 函数名 : CameraGetContrast
1189 // 功能描述 : 获得LUT动态生成模式下的对比度值。请参考
1190 // CameraSetContrastLut函数的功能描述。
1191 // 参数 : hCamera 相机的句柄，由CameraInit函数获得。
1192 // piContrast 指针，返回当前的对比度值。
1193 // 返回值 : 成功时，返回CAMERA_STATUS_SUCCESS (0);
1194 // 否则返回非0值的错误码,请参考CKDeviceStatus.h
1195 // 中错误码的定义。
1196 /******************************************************/
1197 CKSDK_API CameraSdkStatus __stdcall CameraGetContrastLut(HANDLE hCamera,int* piContrast);
1198
1199 /******************************************************/
1200 // 函数名 : CameraSelectLutPreset
1201 // 功能描述 : 选择预设LUT模式下的LUT表。必须先使用CameraSetLutMode
1202 // 将LUT模式设置为预设模式。
1203 // 参数 : hCamera 相机的句柄，由CameraInit函数获得。
1204 // iSel 表的索引号。表的个数由CameraGetCapability
1205 // 获得。
1206 // 返回值 : 成功时，返回CAMERA_STATUS_SUCCESS (0);
1207 // 否则返回非0值的错误码,请参考CKDeviceStatus.h
1208 // 中错误码的定义。
1209 /******************************************************/
1210 CKSDK_API CameraSdkStatus __stdcall CameraSelectLutPreset(HANDLE hCamera, INT iSel);
1211
1218 CKSDK_API CameraSdkStatus __stdcall CameraGetLutPresetSel(HANDLE hCamera, INT *piSel);
1219
1230 CKSDK_API CameraSdkStatus __stdcall CameraSetCustomLut(HANDLE hCamera,int iChannel,USHORT* pLut);
1231
1241 CKSDK_API CameraSdkStatus __stdcall CameraGetCustomLut(HANDLE hCamera,int iChannel,USHORT* pLut);
1242
1243 /******************************************************/
1244 // 函数名 : CameraGetCurrentLut
1245 // 功能描述 : 获得相机当前的LUT表，在任何LUT模式下都可以调用,
1246 // 用来直观的观察LUT曲线的变化。
1247 // 参数 : hCamera 相机的句柄，由CameraInit函数获得。
1248 // iChannel 指定要获得的LUT颜色通道。当为LUT_CHANNEL_ALL时，
1249 // 返回红色通道的LUT表。
1250 // 参考CKDeviceDef.h中emSdkLutChannel定义。
1251 // pLut 指针，指向LUT表的地址。LUT表为无符号短整形数组，数组大小为
1252 // 4096，分别代码颜色通道从0到4096(12bit颜色精度)对应的映射值。
1253 // 返回值 : 成功时，返回CAMERA_STATUS_SUCCESS (0);
1254 // 否则返回非0值的错误码,请参考CKDeviceStatus.h
1255 // 中错误码的定义。
1256 /******************************************************/
1257 CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentLut(HANDLE hCamera,int iChannel,USHORT* pLut);
1258
1259
1262 /****************************************************************************************/
1263 /****************************************************************************************/
1264 /****************************************************************************************/
1265 /****************************************************************************************/
1280 CKSDK_API CameraSdkStatus __stdcall CameraSetSharpness(HANDLE hCamera, INT iSharpness);
1281
1288 CKSDK_API CameraSdkStatus __stdcall CameraGetSharpness(HANDLE hCamera, INT *piSharpness);
1289
1301 CKSDK_API CameraSdkStatus __stdcall CameraSetSaturation(HANDLE hCamera, INT iSaturation);
1302
1309 CKSDK_API CameraSdkStatus __stdcall CameraGetSaturation(HANDLE hCamera, INT *piSaturation);
1310
1321 CKSDK_API CameraSdkStatus __stdcall CameraSetContrast(HANDLE hCamera, INT iContrast);
1322
1330 CKSDK_API CameraSdkStatus __stdcall CameraGetContrast(HANDLE hCamera, INT *piContrast);
1331
1338 CKSDK_API CameraSdkStatus __stdcall CameraGetFrame(HANDLE hCamera, double *pdFrameTime);
1339
1363 CKSDK_API CameraSdkStatus __stdcall CameraSetFrameSpeed(HANDLE hCamera, INT iFrameSpeed);
1364
1372 CKSDK_API CameraSdkStatus __stdcall CameraGetFrameSpeed(HANDLE hCamera, INT *piFrameSpeed);
1373
1382 CKSDK_API CameraSdkStatus __stdcall CameraSetResolution(HANDLE hCamera, INT iResolutionIndex);
1383
1390 CKSDK_API CameraSdkStatus __stdcall CameraGetResolution(HANDLE hCamera, INT *piResolutionIndex);
1391
1398 CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionEx(HANDLE hCamera,tSdkImageResolution* pImageResolution);
1399
1407 CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionEx(HANDLE hCamera, INT iResolution, tSdkImageResolution* pImageResolution);
1408
1415 CKSDK_API CameraSdkStatus __stdcall CameraGetCurResolution(HANDLE hCamera, tSdkImageResolution* pImageResolution);
1416
1424 CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageSize(HANDLE hCamera, DWORD *pWidth, DWORD *pHeight);
1425
1432 CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgMode(HANDLE hCamera, INT iAlgMode);
1433
1440 CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgThreshold(HANDLE hCamera, INT iAlgMode);
1441
1448 CKSDK_API CameraSdkStatus __stdcall CameraGetBayerAlgMode(HANDLE hCamera, INT *piAlgMode);
1449
1490 CKSDK_API CameraSdkStatus __stdcall CameraSetIspOutFormat(HANDLE hCamera, INT iFormat);
1491
1509 CKSDK_API CameraSdkStatus __stdcall CameraGetIspOutFormat(HANDLE hCamera, INT *piFormat);
1510
1517 CKSDK_API CameraSdkStatus __stdcall CameraGetFrameStatistic(HANDLE hCamera, FrameStatistic *psFrameStatistic);
1518
1545 CKSDK_API CameraSdkStatus __stdcall CameraSaveImage(HANDLE hCamera, const char* lpszFileName, const BYTE* pImgBuf, const stImageInfo* pImgInfo, UINT byFileType, BYTE byQuality);
1546
1554 CKSDK_API CameraSdkStatus __stdcall CameraSetMirror(HANDLE hCamera, INT iDir, BOOL bEnable);
1555
1565 CKSDK_API CameraSdkStatus __stdcall CameraGetMirror(HANDLE hCamera, INT iDir, BOOL *pbEnable);
1566
1573 CKSDK_API CameraSdkStatus __stdcall CameraSetMonochrome(HANDLE hCamera, BOOL bEnable);
1574
1582 CKSDK_API CameraSdkStatus __stdcall CameraGetMonochrome(HANDLE hCamera, BOOL *pbEnable);
1583
1590 CKSDK_API CameraSdkStatus __stdcall CameraSetBlackLevel(HANDLE hCamera,INT iBlackLevel);
1591
1598 CKSDK_API CameraSdkStatus __stdcall CameraGetBlackLevel(HANDLE hCamera,INT* piBlackLevel);
1601 /****************************************************************************************/
1602 /****************************************************************************************/
1603 /****************************************************************************************/
1604 /****************************************************************************************/
1621 CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerMode(HANDLE hCamera, INT iTriggerModeSel);
1622
1629 CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerMode(HANDLE hCamera, INT *piTriggerModeSel);
1630
1649 CKSDK_API CameraSdkStatus __stdcall CameraSoftTrigger(HANDLE hCamera);
1650
1657 CameraSdkStatus __stdcall CameraSetTriggerFrameCount(HANDLE hCamera, INT frameCount);
1658
1665 CameraSdkStatus __stdcall CameraGetTriggerFrameCount(HANDLE hCamera, INT *pFrameCount);
1666
1673 CameraSdkStatus __stdcall CameraSetTriggerDelayTime(HANDLE hCamera, UINT delayTimeUs);
1674
1681 CameraSdkStatus __stdcall CameraGetTriggerDelayTime(HANDLE hCamera, UINT *pDelayTimeUs);
1682
1689 CameraSdkStatus __stdcall CameraSetTriggerJitterTime(HANDLE hCamera, UINT jitterTimeUs);
1690
1697 CameraSdkStatus __stdcall CameraGetTriggerJitterTime(HANDLE hCamera, UINT *pJitterTimeUs);
1698
1705 CameraSdkStatus __stdcall CameraSetTriggerSignalType(HANDLE hCamera, INT type);
1706
1713 CameraSdkStatus __stdcall CameraGetTriggerSignalType(HANDLE hCamera, INT *pType);
1714
1721 CameraSdkStatus __stdcall CameraSetStrobeMode(HANDLE hCamera, INT mode);
1722
1729 CameraSdkStatus __stdcall CameraGetStrobeMode(HANDLE hCamera, INT *pMode);
1730
1737 CameraSdkStatus __stdcall CameraSetStrobeDelayTime(HANDLE hCamera, UINT delayTimeUs);
1738
1745 CameraSdkStatus __stdcall CameraGetStrobeDelayTime(HANDLE hCamera, UINT *pDevlayTimeUs);
1746
1753 CameraSdkStatus __stdcall CameraSetStrobePulseWidth(HANDLE hCamera, UINT pulseWidth);
1754
1761 CameraSdkStatus __stdcall CameraGetStrobePulseWidth(HANDLE hCamera, UINT *pPulseWidth);
1762
1769 CameraSdkStatus __stdcall CameraSetStrobePolarity(HANDLE hCamera, INT polarity);
1770
1777 CameraSdkStatus __stdcall CameraGetStrobePolarity(HANDLE hCamera, INT *pPolarity);
1778
1786 CameraSdkStatus __stdcall CameraSetOutputIOMode(HANDLE hCamera, INT outputIOIndex, INT mode);
1787
1795 CameraSdkStatus __stdcall CameraSetInputIOMode(HANDLE hCamera, INT inputIOIndex, INT mode);
1796
1804 CameraSdkStatus __stdcall CameraSetOutputIOState(HANDLE hCamera, INT outputIOIndex, INT state);
1805
1814 CameraSdkStatus __stdcall CameraSetOutputIOPWM(HANDLE hCamera, INT outputIOIndex, INT cycle, INT duty);
1815
1823 CameraSdkStatus __stdcall CameraGetInputIOState(HANDLE hCamera, INT inputIOIndex, int *pState);
1826 /****************************************************************************************/
1827 /****************************************************************************************/
1828 /****************************************************************************************/
1829 /****************************************************************************************/
1841 CKSDK_API CameraSdkStatus __stdcall CameraSetParameterMode(HANDLE hCamera,INT iMode);
1842
1849 CKSDK_API CameraSdkStatus __stdcall CameraGetParameterMode(HANDLE hCamera,INT* piMode);
1850
1861 CKSDK_API CameraSdkStatus __stdcall CameraSaveParameter(HANDLE hCamera,INT iTeam);
1862
1870 CKSDK_API CameraSdkStatus __stdcall CameraSaveParameterToFile(HANDLE hCamera, const char* sFileName);
1871
1880 CKSDK_API CameraSdkStatus __stdcall CameraReadParameterFromFile(HANDLE hCamera, const char* sFileName);
1881
1893 CKSDK_API CameraSdkStatus __stdcall CameraLoadParameter(HANDLE hCamera,INT iTeam);
1894
1902 CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentParameterGroup(HANDLE hCamera,INT* piTeam);
1905 /****************************************************************************************/
1906 /****************************************************************************************/
1907 /****************************************************************************************/
1908 /****************************************************************************************/
1926 CKSDK_API CameraSdkStatus __stdcall CameraWriteSN(HANDLE hCamera,BYTE* pbySN, INT iLevel);
1927
1937 CKSDK_API CameraSdkStatus __stdcall CameraReadSN(HANDLE hCamera,BYTE* pbySN,INT iLevel);
1938
1947 CKSDK_API CameraSdkStatus __stdcall CameraSaveUserData(HANDLE hCamera,UINT uStartAddr,BYTE *pbData,INT iLen);
1948
1962 CKSDK_API CameraSdkStatus __stdcall CameraLoadUserData(HANDLE hCamera,UINT uStartAddr,BYTE *pbData,INT iLen);
1963
1972 CKSDK_API CameraSdkStatus __stdcall CameraGetFriendlyName(HANDLE hCamera,char* pName);
1973
1980 CKSDK_API CameraSdkStatus __stdcall CameraSetFriendlyName(HANDLE hCamera,char* pName);
1983 /****************************************************************************************/
1984 /****************************************************************************************/
1985 /****************************************************************************************/
1986 /****************************************************************************************/
1996 CKSDK_API CameraSdkStatus __stdcall CameraSdkGetVersionString(char* pVersionString);
1997
2004 CKSDK_API CameraSdkStatus __stdcall CameraCheckFwUpdate(HANDLE hCamera,BOOL* pNeedUpdate);
2005
2013 CKSDK_API CameraSdkStatus __stdcall CameraGetFirmwareVision(HANDLE hCamera,char* pVersion);
2014
2022 CKSDK_API CameraSdkStatus __stdcall CameraGetDeviceType(HANDLE hCamera, DWORD* pDeviceID);
2023
2030 CKSDK_API CameraSdkStatus __stdcall CameraGetInerfaceVersion(HANDLE hCamera, char* pVersion);
2033 /****************************************************************************************/
2034 /****************************************************************************************/
2035 /****************************************************************************************/
2036 /****************************************************************************************/
2049 CKSDK_API CameraSdkStatus __stdcall CameraShowSettingPage(HANDLE hCamera,BOOL bShow);
2050
2060 CKSDK_API CameraSdkStatus __stdcall CameraSetActivePage(HANDLE hCamera, LONG lActivePage, INT iDefault);
2061
2067 CKSDK_API CameraSdkStatus __stdcall CameraCreateSettingPageEx(HANDLE hCamera);
2068
2077 CKSDK_API CameraSdkStatus __stdcall CameraCustomizeResolution(
2078 HANDLE hCamera,
2079 tSdkImageResolution* pImageCustom
2080 );
2081
2092 CKSDK_API CameraSdkStatus __stdcall CameraCustomizeReferWin(
2093 HANDLE hCamera,
2094 INT iWinType,
2095 INT* piHOff,
2096 INT* piVOff,
2097 INT* piWidth,
2098 INT* piHeight
2099 );
2102 #ifdef __cplusplus
2103 }
2104 #endif
2105
2106 #endif
CameraSetAeTarget
CKSDK_API CameraSdkStatus __stdcall CameraSetAeTarget(HANDLE hCamera, WORD AeTarget)
设定自动曝光的亮度目标值。设定范围由CameraGetCapability函数获得。
CameraGetAeWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraGetAeWinVisible(HANDLE hCamera, BOOL *pbDisplayEn)
获得自动曝光参考窗口的显示状态。
CameraSetDisplayMode
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayMode(HANDLE hCamera, INT iMode)
设置显示的模式。必须调用过CameraDisplayInit 进行初始化才能调用本函数。
CameraGetTriggerMode
CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerMode(HANDLE hCamera, INT *piTriggerModeSel)
获得相机的触发模式。
CameraSetBayerAlgMode
CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgMode(HANDLE hCamera, INT iAlgMode)
设置Bayer转RGB算法模式。
CameraSetTriggerSignalType
CameraSdkStatus __stdcall CameraSetTriggerSignalType(HANDLE hCamera, INT type)
设置硬件触发信号类型
CameraUnInit
CKSDK_API CameraSdkStatus __stdcall CameraUnInit(HANDLE hCamera)
相机反初始化。释放资源。
CameraGetAeExposureMode
CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureMode(HANDLE hCamera, INT *piMode)
获得自动曝光模式下的曝光模式
CameraSdkGetVersionString
CKSDK_API CameraSdkStatus __stdcall CameraSdkGetVersionString(char *pVersionString)
获得SDK版本信息
CameraSetDisplayCallbackFun
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayCallbackFun(HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld)
设置显示回调。必须调用过CameraDisplayInit进行 初始化才能调用本函数，同时当显示图像数据帧时， pCallBac...
CameraSetStrobeDelayTime
CameraSdkStatus __stdcall CameraSetStrobeDelayTime(HANDLE hCamera, UINT delayTimeUs)
设置触发后延时多少时间点亮闪光灯
CameraSetTriggerFrameCount
CameraSdkStatus __stdcall CameraSetTriggerFrameCount(HANDLE hCamera, INT frameCount)
设置硬件触发时连续拍多少张图片
CameraGetRawImageBuffer
CKSDK_API CameraSdkStatus __stdcall CameraGetRawImageBuffer(HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes)
获得一帧图像原始数据。为了提高效率，SDK在图像抓取时采用了零拷贝机制， CameraGetRawImageBuffer实际获得...
CameraSaveParameterToFile
CKSDK_API CameraSdkStatus __stdcall CameraSaveParameterToFile(HANDLE hCamera, const char *sFileName)
保存当前相机参数到指定的文件中。该文件可以复制到 别的电脑上供其他相机加载，也可以做参数备份用。 ...
CameraGetWbMode
CKSDK_API CameraSdkStatus __stdcall CameraGetWbMode(HANDLE hCamera, BOOL *pbAuto)
获得当前的白平衡模式。
CameraSetAeExposureMode
CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureMode(HANDLE hCamera, INT iMode)
设定自动曝光模式下的曝光模式
CameraReadParameterFromFile
CKSDK_API CameraSdkStatus __stdcall CameraReadParameterFromFile(HANDLE hCamera, const char *sFileName)
从PC上指定的参数文件中加载参数。我公司相机参数 保存在PC上为.config后缀的文件，位于安装下的 Camera\Con...
CameraGetFirmwareVision
CKSDK_API CameraSdkStatus __stdcall CameraGetFirmwareVision(HANDLE hCamera, char *pVersion)
获得固件版本的字符串
CameraGetExposureLineTime
CKSDK_API CameraSdkStatus __stdcall CameraGetExposureLineTime(HANDLE hCamera, double *pExposureLineTime)
获得一行曝光的时间，单位：微妙。
CameraSetStrobePolarity
CameraSdkStatus __stdcall CameraSetStrobePolarity(HANDLE hCamera, INT polarity)
设置闪光灯的有效电平
CameraSetContrastLut
CKSDK_API CameraSdkStatus __stdcall CameraSetContrastLut(HANDLE hCamera, int iContrast)
CameraSetOutputIOPWM
CameraSdkStatus __stdcall CameraSetOutputIOPWM(HANDLE hCamera, INT outputIOIndex, INT cycle, INT duty)
设置PWM型输出的参数，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 ...
CameraGetLutPresetSel
CKSDK_API CameraSdkStatus __stdcall CameraGetLutPresetSel(HANDLE hCamera, INT *piSel)
获得预设LUT模式下的LUT表索引号。
_tSdkCameraCapbility
相机能力级
Definition: CKDeviceDef.h:958
CameraGetStrobePulseWidth
CameraSdkStatus __stdcall CameraGetStrobePulseWidth(HANDLE hCamera, UINT *pPulseWidth)
获取闪光灯的脉宽宽度
CameraSetAeWindow
CKSDK_API CameraSdkStatus __stdcall CameraSetAeWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
设置自动曝光的参考窗口。
CameraGetOutImageBuffer
CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageBuffer(HANDLE hCamera, stImageInfo *pImgInfo, HANDLE hRawBuf, BYTE *pImgBuf)
将获得的相机原始输出图像数据进行处理，叠加饱和度、 颜色增益和校正、降噪等处理效果，处理完后图像的输出...
CameraGetImageBufferEx1
CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx1(HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT uTimes)
获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数�...
CameraReadSN
CKSDK_API CameraSdkStatus __stdcall CameraReadSN(HANDLE hCamera, BYTE *pbySN, INT iLevel)
读取相机指定级别的序列号。序列号的定义请参考 CameraWriteSN函数的功能描述部分。
CameraGetSharpness
CKSDK_API CameraSdkStatus __stdcall CameraGetSharpness(HANDLE hCamera, INT *piSharpness)
获取当前锐化设定值。
CameraSoftTrigger
CKSDK_API CameraSdkStatus __stdcall CameraSoftTrigger(HANDLE hCamera)
执行一次软触发。
CameraGetOutImageSize
CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageSize(HANDLE hCamera, DWORD *pWidth, DWORD *pHeight)
获得输出图像的大小。
CameraSetLightFrequency
CKSDK_API CameraSdkStatus __stdcall CameraSetLightFrequency(HANDLE hCamera, INT iFrequencySel)
设置自动曝光时消频闪的频率。
CameraGetTriggerDelayTime
CameraSdkStatus __stdcall CameraGetTriggerDelayTime(HANDLE hCamera, UINT *pDelayTimeUs)
设置硬件触发后多少时间进行拍照
CameraSetOutputIOState
CameraSdkStatus __stdcall CameraSetOutputIOState(HANDLE hCamera, INT outputIOIndex, INT state)
设置指定IO的电平状态，IO为输出型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts�...
CameraGetAeAnalogGainRange
CKSDK_API CameraSdkStatus __stdcall CameraGetAeAnalogGainRange(HANDLE hCamera, INT *iMinAnalogGain, INT *iMaxAnalogGain)
获得自动曝光模式的增益调节范围
CameraGetStrobePolarity
CameraSdkStatus __stdcall CameraGetStrobePolarity(HANDLE hCamera, INT *pPolarity)
获取闪光灯的有效电平
CameraSetExposureTime
CKSDK_API CameraSdkStatus __stdcall CameraSetExposureTime(HANDLE hCamera, double dExposureTime)
设置曝光时间。单位为微秒。对于CMOS传感器，其曝光 的单位是按照行来计算的，因此，曝光时间并不能在微秒 �...
CameraSetOutputIOMode
CameraSdkStatus __stdcall CameraSetOutputIOMode(HANDLE hCamera, INT outputIOIndex, INT mode)
设置输出IO的工作模式， 预留可编程输出IO的个数由tSdkCameraCapbility中iOutputIoCounts决定。 ...
CameraGetContrast
CKSDK_API CameraSdkStatus __stdcall CameraGetContrast(HANDLE hCamera, INT *piContrast)
获得对比度值。请参考 CameraSetContrast函数的功能描述。
CameraSetSharpness
CKSDK_API CameraSdkStatus __stdcall CameraSetSharpness(HANDLE hCamera, INT iSharpness)
设置图像的处理的锐化参数。
CameraSetDisplayOffset
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayOffset(HANDLE hCamera, INT iOffsetX, INT iOffsetY)
设置显示的起始偏移值。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如显示控件的大小为32...
CameraSaveParameter
CKSDK_API CameraSdkStatus __stdcall CameraSaveParameter(HANDLE hCamera, INT iTeam)
保存当前相机参数到指定的参数组中。相机提供了A,B,C,D A,B,C,D四组空间来进行参数的保存。 ...
CameraSetStrobeMode
CameraSdkStatus __stdcall CameraSetStrobeMode(HANDLE hCamera, INT mode)
设置闪光灯工作模式
CameraSetOnceWB
CKSDK_API CameraSdkStatus __stdcall CameraSetOnceWB(HANDLE hCamera)
在手动白平衡模式下，调用该函数会进行一次白平衡。 生效的时间为接收到下一帧图像数据时。 ...
CameraSetAntiFlick
CKSDK_API CameraSdkStatus __stdcall CameraSetAntiFlick(HANDLE hCamera, BOOL bEnable)
设置自动曝光时抗频闪功能的使能状态。对于手动 曝光模式下无效。
CameraGetDeviceType
CKSDK_API CameraSdkStatus __stdcall CameraGetDeviceType(HANDLE hCamera, DWORD *pDeviceID)
获得设备版本ID
CameraGetEnumIndexInfo
CKSDK_API CameraSdkStatus __stdcall CameraGetEnumIndexInfo(INT CameraIndex, tDevEnumInfo *pDevInfo)
获得指定设备的信息
CameraSetMirror
CKSDK_API CameraSdkStatus __stdcall CameraSetMirror(HANDLE hCamera, INT iDir, BOOL bEnable)
设置图像镜像操作。镜像操作分为水平和垂直两个方向。
CameraGetAeWindow
CKSDK_API CameraSdkStatus __stdcall CameraGetAeWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
获得自动曝光参考窗口的位置。
CameraGetExposureTime
CKSDK_API CameraSdkStatus __stdcall CameraGetExposureTime(HANDLE hCamera, double *pdExposureTime)
获得相机的曝光时间。请参见CameraSetExposureTime 的功能描述。
CameraSetFrameSpeed
CKSDK_API CameraSdkStatus __stdcall CameraSetFrameSpeed(HANDLE hCamera, INT iFrameSpeed)
设定相机输出图像的帧率。相机可供选择的帧率模式由 CameraGetCapability获得的信息结构体中iFrameSpeedDesc...
CameraGetTriggerSignalType
CameraSdkStatus __stdcall CameraGetTriggerSignalType(HANDLE hCamera, INT *pType)
获取硬件触发信号类型
CameraSetStrobePulseWidth
CameraSdkStatus __stdcall CameraSetStrobePulseWidth(HANDLE hCamera, UINT pulseWidth)
设置闪光灯的脉宽宽度
CKSDK_API
#define CKSDK_API
Definition: CKCameraInterface.h:284
CameraWriteSN
CKSDK_API CameraSdkStatus __stdcall CameraWriteSN(HANDLE hCamera, BYTE *pbySN, INT iLevel)
设置相机的序列号。我公司相机序列号分为3级。0级的是我公司自定义的相机序列号，出厂时已经 设定好，1级和2...
CameraSetCustomLut
CKSDK_API CameraSdkStatus __stdcall CameraSetCustomLut(HANDLE hCamera, int iChannel, USHORT *pLut)
设置自定义的LUT表。必须先使用CameraSetLutMode 将LUT模式设置为自定义模式。
CameraImageOverlay
CKSDK_API CameraSdkStatus __stdcall CameraImageOverlay(HANDLE hCamera, BYTE *pImgBuf, const stImageInfo *pImgInfo)
将输入的图像数据上叠加十字线、白平衡参考窗口、 自动曝光参考窗口等图形。只有设置为可见状态的 十字线和�...
CameraSetResolutionEx
CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionEx(HANDLE hCamera, tSdkImageResolution *pImageResolution)
设置自定义预览的分辨率。
CameraGetInputIOState
CameraSdkStatus __stdcall CameraGetInputIOState(HANDLE hCamera, INT inputIOIndex, int *pState)
设置指定IO的电平状态，IO为输入型IO，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决...
CameraSetSaturation
CKSDK_API CameraSdkStatus __stdcall CameraSetSaturation(HANDLE hCamera, INT iSaturation)
设定图像处理的饱和度。对黑白相机无效。 设定范围由CameraGetCapability获得。100表示 表示原始色度，不增�...
CameraCheckFwUpdate
CKSDK_API CameraSdkStatus __stdcall CameraCheckFwUpdate(HANDLE hCamera, BOOL *pNeedUpdate)
检测固件版本，是否需要升级。
CameraGetInerfaceVersion
CKSDK_API CameraSdkStatus __stdcall CameraGetInerfaceVersion(HANDLE hCamera, char *pVersion)
获得指定设备接口的版本
CameraPlay
CKSDK_API CameraSdkStatus __stdcall CameraPlay(HANDLE hCamera)
让SDK进入工作模式，开始接收来自相机发送的图像 数据。如果当前相机是触发模式，则需要接收到 触发帧以后才...
CameraSetTriggerMode
CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerMode(HANDLE hCamera, INT iTriggerModeSel)
设置相机的触发模式。
CameraSetBayerAlgThreshold
CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgThreshold(HANDLE hCamera, INT iAlgMode)
设置Bayer转RGB算法模式。
CameraSetTriggerDelayTime
CameraSdkStatus __stdcall CameraSetTriggerDelayTime(HANDLE hCamera, UINT delayTimeUs)
设置硬件触发后多少时间进行拍照
CameraGetStrobeMode
CameraSdkStatus __stdcall CameraGetStrobeMode(HANDLE hCamera, INT *pMode)
获取闪光灯工作模式
CameraGetBayerAlgMode
CKSDK_API CameraSdkStatus __stdcall CameraGetBayerAlgMode(HANDLE hCamera, INT *piAlgMode)
获得Bayer转RGB算法模式。
CameraGetImageBufferEx
CKSDK_API BYTE *__stdcall CameraGetImageBufferEx(HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes)
获得一帧图像数据。该接口获得的图像是经过处理后的格式。该格式可以通过CameraSetIspOutFormat设置 该函数�...
CameraCustomizeResolution
CKSDK_API CameraSdkStatus __stdcall CameraCustomizeResolution(HANDLE hCamera, tSdkImageResolution *pImageCustom)
打开分辨率自定义面板，并通过可视化的方式来配置一个自定义分辨率。
CameraReleaseFrameHandle
CKSDK_API CameraSdkStatus __stdcall CameraReleaseFrameHandle(HANDLE hCamera, HANDLE hRawBuf)
释放由CameraGetRawImageBuffer获得缓冲区
CameraGetCurrentParameterGroup
CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentParameterGroup(HANDLE hCamera, INT *piTeam)
获得当前选择的参数组。
CameraSetDisplaySize
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplaySize(HANDLE hCamera, INT iWidth, INT iHeight)
设置显示控件的尺寸。必须调用过 CameraDisplayInit进行初始化才能调用本函数。
CameraSelectLutPreset
CKSDK_API CameraSdkStatus __stdcall CameraSelectLutPreset(HANDLE hCamera, INT iSel)
_FrameStatistic
帧率统计信息
Definition: CKDeviceDef.h:947
CameraGetCurrentLut
CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentLut(HANDLE hCamera, int iChannel, USHORT *pLut)
CameraGetBlackLevel
CKSDK_API CameraSdkStatus __stdcall CameraGetBlackLevel(HANDLE hCamera, INT *piBlackLevel)
获得图像的黑电平基准，默认值为0
CameraInitEx3
CKSDK_API CameraSdkStatus __stdcall CameraInitEx3(PHANDLE phCamera, const char *pCameraSN)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调...
_tDevEnumInfo
枚举信息
Definition: CKDeviceDef.h:983
CameraLoadUserData
CKSDK_API CameraSdkStatus __stdcall CameraLoadUserData(HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
从相机的非易性存储器中读取用户自定义的数据。每个型号的相机可能支持的用户数据区最大长度不一样。可以从�...
CameraDrawText
CKSDK_API CameraSdkStatus __stdcall CameraDrawText(BYTE *pImgBuf, const stImageInfo *pImgInfo, char const *pFontFileName, UINT FontWidth, UINT FontHeight, char const *pText, INT Left, INT Top, UINT Width, UINT Height, UINT TextColor, UINT uFlags)
在输入的图像数据中绘制文字
CameraSetAeState
CKSDK_API CameraSdkStatus __stdcall CameraSetAeState(HANDLE hCamera, BOOL bAeState)
设置相机曝光的模式。自动或者手动。
CameraSetGamma
CKSDK_API CameraSdkStatus __stdcall CameraSetGamma(HANDLE hCamera, int iGamma)
设定LUT动态生成模式下的Gamma值。设定的值会 马上保存在SDK内部，但是只有当相机处于动态 参数生成的LUT模�...
CameraSetLutMode
CKSDK_API CameraSdkStatus __stdcall CameraSetLutMode(HANDLE hCamera, INT emLutMode)
设置相机的查表变换模式LUT模式。
CameraPause
CKSDK_API CameraSdkStatus __stdcall CameraPause(HANDLE hCamera)
让SDK进入暂停模式，不接收来自相机的图像数据， 同时也会发送命令让相机暂停输出，释放传输带宽。 暂停模式...
CKDeviceDef.h
CameraSetResolutionForSnap
CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionForSnap(HANDLE hCamera, tSdkImageResolution *pImageResolution)
设置抓拍模式下相机输出图像的分辨率。
CameraSetDisplayScaleRadio
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayScaleRadio(HANDLE hCamera, INT iRadio)
设置显示的缩放比率。仅当显示模式为emSdkDisplayMode::DISPLAYMODE_REAL 时有效。例如100 是显示窗口和图像...
CameraSetBlackLevel
CKSDK_API CameraSdkStatus __stdcall CameraSetBlackLevel(HANDLE hCamera, INT iBlackLevel)
设置图像的黑电平基准，默认值为0
CameraGetGamma
CKSDK_API CameraSdkStatus __stdcall CameraGetGamma(HANDLE hCamera, int *piGamma)
获得LUT动态生成模式下的Gamma值。请参考CameraSetGamma 函数的功能描述。
CameraGetCrossLine
CKSDK_API CameraSdkStatus __stdcall CameraGetCrossLine(HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible)
获得指定十字线的状态。
CameraInitEx2
CKSDK_API CameraSdkStatus __stdcall CameraInitEx2(PHANDLE phCamera, const char *pFriendlyName)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。默认使用上次退出时的参数，注意需要先调...
CameraGetLightFrequency
CKSDK_API CameraSdkStatus __stdcall CameraGetLightFrequency(HANDLE hCamera, INT *piFrequencySel)
获得自动曝光时，消频闪的频率选择。
CameraGetMirror
CKSDK_API CameraSdkStatus __stdcall CameraGetMirror(HANDLE hCamera, INT iDir, BOOL *pbEnable)
获得图像的镜像状态。
CameraGetStrobeDelayTime
CameraSdkStatus __stdcall CameraGetStrobeDelayTime(HANDLE hCamera, UINT *pDevlayTimeUs)
获取触发后点亮闪光灯的延时时间
CameraSetIspOutFormat
CKSDK_API CameraSdkStatus __stdcall CameraSetIspOutFormat(HANDLE hCamera, INT iFormat)
设置CameraImageProcess函数的图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CA...
CameraGetResolutionEx
CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionEx(HANDLE hCamera, INT iResolution, tSdkImageResolution *pImageResolution)
获得索引号的分辨率。
CameraGetParameterMode
CKSDK_API CameraSdkStatus __stdcall CameraGetParameterMode(HANDLE hCamera, INT *piMode)
获得参数存取的目标对象。
CameraSetCrossLine
CKSDK_API CameraSdkStatus __stdcall CameraSetCrossLine(HANDLE hCamera, INT iLine, INT x, INT y, UINT uColor, BOOL bVisible)
设置指定十字线的参数。
CameraCreateSettingPageEx
CKSDK_API CameraSdkStatus __stdcall CameraCreateSettingPageEx(HANDLE hCamera)
创建相机配置窗口。创建之前要先调用CameraSetActivePage设置子页面构成。
CameraGetImageInfo
CKSDK_API BYTE *__stdcall CameraGetImageInfo(HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo)
获得当前帧图像信息
CameraSetParameterMode
CKSDK_API CameraSdkStatus __stdcall CameraSetParameterMode(HANDLE hCamera, INT iMode)
设定参数存取的目标对象。
CameraGetResolution
CKSDK_API CameraSdkStatus __stdcall CameraGetResolution(HANDLE hCamera, INT *piResolutionIndex)
获得相机输出图像的分辨率。
CameraSdkStatus
int CameraSdkStatus
Definition: CKCameraInterface.h:288
CameraGetFrameStatistic
CKSDK_API CameraSdkStatus __stdcall CameraGetFrameStatistic(HANDLE hCamera, FrameStatistic *psFrameStatistic)
获得相机接收帧率的统计信息，包括错误帧和丢帧的情况。
CameraSetTriggerJitterTime
CameraSdkStatus __stdcall CameraSetTriggerJitterTime(HANDLE hCamera, UINT jitterTimeUs)
设置硬件触发后去抖时间
CameraGetTriggerFrameCount
CameraSdkStatus __stdcall CameraGetTriggerFrameCount(HANDLE hCamera, INT *pFrameCount)
获取硬件触发时连续拍多少张图片
CameraCustomizeReferWin
CKSDK_API CameraSdkStatus __stdcall CameraCustomizeReferWin(HANDLE hCamera, INT iWinType, INT *piHOff, INT *piVOff, INT *piWidth, INT *piHeight)
打开参考窗口自定义面板。并通过可视化的方式来获得一个自定义窗口的位置。一般是用自定义白平衡和自动曝光�...
CameraGetFrame
CKSDK_API CameraSdkStatus __stdcall CameraGetFrame(HANDLE hCamera, double *pdFrameTime)
获得当前图像帧时间。
CameraGetMonochrome
CKSDK_API CameraSdkStatus __stdcall CameraGetMonochrome(HANDLE hCamera, BOOL *pbEnable)
获得彩色转换黑白功能的使能状况。
_tDevLoadInfo
/设备的当前模式和枚举信息
Definition: CKDeviceDef.h:992
CameraInitEx
CKSDK_API CameraSdkStatus __stdcall CameraInitEx(PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口。注意需要先调用CameraEnumerateDevice枚�...
CameraGetAntiFlick
CKSDK_API CameraSdkStatus __stdcall CameraGetAntiFlick(HANDLE hCamera, BOOL *pbEnable)
获得自动曝光时抗频闪功能的使能状态。
CameraSetMonochrome
CKSDK_API CameraSdkStatus __stdcall CameraSetMonochrome(HANDLE hCamera, BOOL bEnable)
设置彩色转为黑白功能的使能。
CameraSetAeAnalogGainRange
CKSDK_API CameraSdkStatus __stdcall CameraSetAeAnalogGainRange(HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain)
设定自动曝光模式的增益调节范围
CameraGetCustomLut
CKSDK_API CameraSdkStatus __stdcall CameraGetCustomLut(HANDLE hCamera, int iChannel, USHORT *pLut)
获得当前使用的自定义LUT表。
CameraGetFrameSpeed
CKSDK_API CameraSdkStatus __stdcall CameraGetFrameSpeed(HANDLE hCamera, INT *piFrameSpeed)
获得相机输出图像的帧率选择索引号。具体用法参考 CameraSetFrameSpeed函数的功能描述部分。 ...
CameraSetGain
CKSDK_API CameraSdkStatus __stdcall CameraSetGain(HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB)
设置图像的数字增益。设定范围由CameraGetCapability 获得的相机属性结构体中sRgbGainRange成员表述。 实际�...
CameraGetCurDevInfo
CKSDK_API CameraSdkStatus __stdcall CameraGetCurDevInfo(HANDLE hCamera, tDevLoadInfo *pDevInfo)
获得指定设备的枚举信息
CameraSetActivePage
CKSDK_API CameraSdkStatus __stdcall CameraSetActivePage(HANDLE hCamera, LONG lActivePage, INT iDefault)
设置相机配置窗口的激活页面。相机配置窗口有多个子页面构成，该函数可以设定当前哪一个子页面为激活状态，�...
CameraSetAnalogGain
CKSDK_API CameraSdkStatus __stdcall CameraSetAnalogGain(HANDLE hCamera, UINT uAnalogGain)
设置相机的图像模拟增益值。该值乘以CameraGetCapability获得 的相机属性结构体中sExposeDesc.fAnalogGainStep，就 得到实际的图像信号放大倍数。
CameraShowSettingPage
CKSDK_API CameraSdkStatus __stdcall CameraShowSettingPage(HANDLE hCamera, BOOL bShow)
设置相机属性配置窗口显示状态。必须先调用CameraCreateSettingPageEx 成功创建相机属性配置窗口后，才能调�...
CameraGetWbWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraGetWbWinVisible(HANDLE hCamera, BOOL *pDisplayEn)
获得白平衡参考窗口显示使能状态。
CAMERA_DISPLAY_PROC
void(WINAPI * CAMERA_DISPLAY_PROC)(HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
图像显示的回调函数
Definition: CKDeviceDef.h:1007
CameraInit
CKSDK_API CameraSdkStatus __stdcall CameraInit(PHANDLE phCamera, INT CameraIndex)
相机初始化。初始化成功后，才能调用任何其他 相机相关的操作接口,默认使用上次退出时的参数。注意需要先调�...
CameraSnapToBuffer
CKSDK_API CameraSdkStatus __stdcall CameraSnapToBuffer(HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE **ppImgBuf, UINT uWaitTimeMs)
抓拍一张图像到缓冲区中。相机会进入抓拍模式，并且 自动切换到抓拍模式的分辨率进行图像捕获。然后将 捕获�...
CameraSetAeExposureRange
CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureRange(HANDLE hCamera, double dMinExposureTime, double dMaxExposureTime)
设定自动曝光模式的曝光时间调节范围
CameraSetResolution
CKSDK_API CameraSdkStatus __stdcall CameraSetResolution(HANDLE hCamera, INT iResolutionIndex)
设定相机输出图像的分辨率。
_tSdkImageResolution
Definition: CKDeviceDef.h:585
CameraEnumerateDevice
CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDevice(INT *pDeviceNum)
枚举设备，并建立设备列表。在调用CameraInit 之前，必须调用该函数来获得设备的信息。 ...
CameraGetIspOutFormat
CKSDK_API CameraSdkStatus __stdcall CameraGetIspOutFormat(HANDLE hCamera, INT *piFormat)
获得CameraGetOutImageBuffer函数图像处理的输出格式，支持 CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8...
CameraSetWbWindow
CKSDK_API CameraSdkStatus __stdcall CameraSetWbWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
设置白平衡参考窗口的位置。
CameraSetWbWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraSetWbWinVisible(HANDLE hCamera, BOOL bDisplayEn)
设置白平衡参考窗口显示使能。
CAMERA_SNAP_PROC
void(WINAPI * CAMERA_SNAP_PROC)(HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)
图像捕获的回调函数定义
Definition: CKDeviceDef.h:1005
CameraGetCurResolution
CKSDK_API CameraSdkStatus __stdcall CameraGetCurResolution(HANDLE hCamera, tSdkImageResolution *pImageResolution)
获得当前预览的分辨率。
CameraSetCallbackFunction
CKSDK_API CameraSdkStatus __stdcall CameraSetCallbackFunction(HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld)
设置图像捕获的回调函数。当捕获到新的图像数据帧时，pCallBack所指向的回调函数就会被调用。 ...
CameraGetLutMode
CKSDK_API CameraSdkStatus __stdcall CameraGetLutMode(HANDLE hCamera, INT *pemLutMode)
获得相机的查表变换模式LUT模式。
CameraGetAeState
CKSDK_API CameraSdkStatus __stdcall CameraGetAeState(HANDLE hCamera, BOOL *pAeState)
获得相机当前的曝光模式。
CameraGetSaturation
CKSDK_API CameraSdkStatus __stdcall CameraGetSaturation(HANDLE hCamera, INT *piSaturation)
获得图像处理的饱和度。
CameraGetWbWindow
CKSDK_API CameraSdkStatus __stdcall CameraGetWbWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
获得白平衡参考窗口的位置。
CameraGetGain
CKSDK_API CameraSdkStatus __stdcall CameraGetGain(HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB)
获得图像处理的数字增益。具体请参见CameraSetGain 的功能描述部分。
CameraSetAeWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraSetAeWinVisible(HANDLE hCamera, BOOL bDisplayEn)
设置自动曝光参考窗口的显示状态。当设置窗口状态 为显示，调用CameraImageOverlay后，能够将窗口位置 以矩�...
CameraGetTriggerJitterTime
CameraSdkStatus __stdcall CameraGetTriggerJitterTime(HANDLE hCamera, UINT *pJitterTimeUs)
获取硬件触发后去抖时间
CameraSetWbMode
CKSDK_API CameraSdkStatus __stdcall CameraSetWbMode(HANDLE hCamera, BOOL bAuto)
设置相机白平衡模式。分为手动和自动两种方式。
CameraSetInputIOMode
CameraSdkStatus __stdcall CameraSetInputIOMode(HANDLE hCamera, INT inputIOIndex, INT mode)
设置输入IO的模式，相机预留可编程输出IO的个数由tSdkCameraCapbility中iInputIoCounts决定 ...
CameraGetAeExposureRange
CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureRange(HANDLE hCamera, double *pdMinExposureTime, double *pdMaxExposureTime)
获得自动曝光模式的曝光时间调节范围
CameraGetResolutionForSnap
CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionForSnap(HANDLE hCamera, tSdkImageResolution *pImageResolution)
获得抓拍模式下的分辨率。
_stImageInfo
帧头信息
Definition: CKDeviceDef.h:928
CameraDisplayInit
CKSDK_API CameraSdkStatus __stdcall CameraDisplayInit(HANDLE hCamera, HWND hWndDisplay)
初始化SDK内部的显示模块。在调用CameraDisplay 前必须先调用该函数初始化。如果您在二次开发中， 使用自己�...
CameraDisplay
CKSDK_API CameraSdkStatus __stdcall CameraDisplay(HANDLE hCamera, BYTE *pImgBuf, stImageInfo *pImgInfo)
显示图像。必须调用过CameraDisplayInit进行初始化才能调用本函数。
CameraGetFriendlyName
CKSDK_API CameraSdkStatus __stdcall CameraGetFriendlyName(HANDLE hCamera, char *pName)
读取用户自定义的设备昵称。
CameraSetFriendlyName
CKSDK_API CameraSdkStatus __stdcall CameraSetFriendlyName(HANDLE hCamera, char *pName)
设置用户自定义的设备昵称。
CameraGetContrastLut
CKSDK_API CameraSdkStatus __stdcall CameraGetContrastLut(HANDLE hCamera, int *piContrast)
CameraGetAnalogGain
CKSDK_API CameraSdkStatus __stdcall CameraGetAnalogGain(HANDLE hCamera, UINT *puAnalogGain)
获得图像信号的模拟增益值。参见CameraSetAnalogGain详细说明。
CameraGetAeTarget
CKSDK_API CameraSdkStatus __stdcall CameraGetAeTarget(HANDLE hCamera, WORD *pAeTarget)
获得自动曝光的亮度目标值。
CameraLoadParameter
CKSDK_API CameraSdkStatus __stdcall CameraLoadParameter(HANDLE hCamera, INT iTeam)
加载指定组的参数到相机中。
CameraSaveImage
CKSDK_API CameraSdkStatus __stdcall CameraSaveImage(HANDLE hCamera, const char *lpszFileName, const BYTE *pImgBuf, const stImageInfo *pImgInfo, UINT byFileType, BYTE byQuality)
将图像缓冲区的数据保存成图片文件。
CameraSaveUserData
CKSDK_API CameraSdkStatus __stdcall CameraSaveUserData(HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
将用户自定义的数据保存到相机的非易性存储器中。每个型号的相机可能支持的用户数据区最大长度不一样。可以�...
CameraSetContrast
CKSDK_API CameraSdkStatus __stdcall CameraSetContrast(HANDLE hCamera, INT iContrast)
设定图像处理的对比度
CameraGetCapability
CKSDK_API CameraSdkStatus __stdcall CameraGetCapability(HANDLE hCamera, tSdkCameraCapbility *pCameraCap)
获得相机的特性描述结构体。该结构体中包含了相机 可设置的各种参数的范围信息。决定了相关函数的参数 返回�...


CKCameraAPI: CKDeviceDef.h 源文件

  • 文件列表
  • 文件成员
CKDeviceDef.h
浏览该文件的文档.
1 //VTDeviceErr.h
3
4
5 #ifndef __CK_DEVICE_DEF_H__
6 #define __CK_DEVICE_DEF_H__
7
8
9
10 #define CROSSLINE_MAX_NUM 9
11
12
18 #define CAMERA_STATUS_SUCCESS 0
19
20 #define CAMERA_STATUS_FAILED -1
21
22 #define CAMERA_STATUS_INTERNAL_ERROR -2
23
24 #define CAMERA_STATUS_UNKNOW -3
25
26 #define CAMERA_STATUS_NOT_SUPPORTED -4
27
28 #define CAMERA_STATUS_NOT_INITIALIZED -5
29
30 #define CAMERA_STATUS_PARAMETER_INVALID -6
31
32 #define CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7
33
34 #define CAMERA_STATUS_UNENABLED -8
35
36 #define CAMERA_STATUS_USER_CANCEL -9
37
38 #define CAMERA_STATUS_PATH_NOT_FOUND -10
39
40 #define CAMERA_STATUS_SIZE_DISMATCH -11
41
42 #define CAMERA_STATUS_TIME_OUT -12
43
44 #define CAMERA_STATUS_IO_ERROR -13
45
46 #define CAMERA_STATUS_COMM_ERROR -14
47
48 #define CAMERA_STATUS_BUS_ERROR -15
49
50 #define CAMERA_STATUS_NO_DEVICE_FOUND -16
51
52 #define CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17
53
54 #define CAMERA_STATUS_DEVICE_IS_OPENED -18
55
56 #define CAMERA_STATUS_DEVICE_IS_CLOSED -19
57
58 #define CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20
59
60 #define CAMERA_STATUS_NO_MEMORY -21
61
62 #define CAMERA_STATUS_FILE_CREATE_FAILED -22
63
64 #define CAMERA_STATUS_FILE_INVALID -23
65
66 #define CAMERA_STATUS_WRITE_PROTECTED -24
67
68 #define CAMERA_STATUS_GRAB_FAILED -25
69
70 #define CAMERA_STATUS_LOST_DATA -26
71
72 #define CAMERA_STATUS_EOF_ERROR -27
73
74 #define CAMERA_STATUS_BUSY -28
75
76 #define CAMERA_STATUS_WAIT -29
77
78 #define CAMERA_STATUS_IN_PROCESS -30
79
80 #define CAMERA_STATUS_IIC_ERROR -31
81
82 #define CAMERA_STATUS_SPI_ERROR -32
83
84 #define CAMERA_STATUS_USB_CONTROL_ERROR -33
85
86 #define CAMERA_STATUS_USB_BULK_ERROR -34
87
88 #define CAMERA_STATUS_SOCKET_INIT_ERROR -35
89
90 #define CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36
91
92 #define CAMERA_STATUS_NET_SEND_ERROR -37
93
94 #define CAMERA_STATUS_DEVICE_LOST -38
95
96 #define CAMERA_STATUS_DATA_RECV_LESS -39
97
98 #define CAMERA_STATUS_FUNCTION_LOAD_FAILED -40
99
100 #define CAMERA_STATUS_CRITICAL_FILE_LOST -41
101
102 #define CAMERA_STATUS_SENSOR_ID_DISMATCH -42
103
104 #define CAMERA_STATUS_OUT_OF_RANGE -43
105
106 #define CAMERA_STATUS_REGISTRY_ERROR -44
107
108 #define CAMERA_STATUS_ACCESS_DENY -45
109
110 #define CAMERA_STATUS_CAMERA_NEED_RESET -46
111
112 #define CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47
113
114 #define CAMERA_STATUS_ISP_DATA_CRC_ERROR -48
115
116 #define CAMERA_STATUS_MV_TEST_FAILED -49
117
118 #define CAMERA_STATUS_WAIT_TRIGGER -50
119
120 #define CAMERA_STATUS_EEPROM_UPDATA -51
121
122 #define CAMERA_STATUS_OPEN_DEVICE_ERROR -52
123
124 #define CAMERA_STATUS_OPEN_STREAM_ERROR -53
125
126 #define CAMERA_STATUS_READ_ERROR -54
127
128 #define CAMERA_STATUS_WRITE_ERROR -55
129
130 #define CAMERA_STATUS_NO_OPEN_DEVICE -56
131
132 #define CAMERA_STATUS_UNKNOW_SENSOR -57
133
134 #define CAMERA_STATUS_NO_WRITE_EEPROM -58
135
136 #define CMAERA_STATUS_FPGA_CFG_ERROR -59
137
145 typedef enum
146 {
148 IMAGEOUT_MODE_512X384 = 0,
150 IMAGEOUT_MODE_640X480 = 1,
152 IMAGEOUT_MODE_800X600 = 2,
154 IMAGEOUT_MODE_1024X768 = 3,
156 IMAGEOUT_MODE_1280X720 = 4,
158 IMAGEOUT_MODE_1280X960 = 5,
160 IMAGEOUT_MODE_1920X1280 = 6,
162 IMAGEOUT_MODE_2048X1536 = 7,
164 IMAGEOUT_MODE_320X240 = 8,
166 IMAGEOUT_MODE_1280X1024 = 9,
168 IMAGEOUT_MODE_1600X1200 = 10,
170 IMAGEOUT_MODE_2592X1944 = 11,
172 IMAGEOUT_MODE_752X480 = 12,
174 IMAGEOUT_MODE_768X576 = 13,
176 IMAGEOUT_MODE_3664X2748 = 14,
178 IMAGEOUT_MODE_NUM,
179
181 IMAGEOUT_MODE_CUSTOM = 0XFF,
182 }emResolutionMode;
183
185 typedef enum
186 {
188 FRAME_SPEED_LOW = 0,
190 FRAME_SPEED_MIDDLE,
192 FRAME_SPEED_HIGH,
193 }emFrameMode;
194
196 typedef enum
197 {
199 FREQ_FLICKER_MODE_NULL = 0,
201 FREQ_FLICKER_MODE_50HZ,
203 FREQ_FLICKER_MODE_60HZ,
204 }emFlickerMode;
205
207 typedef enum
208 {
210 FILE_JPG = 1,
212 FILE_BMP = 2,//BMP 24bit
214 FILE_RAW = 4,
216 FILE_PNG = 8,
218 FILE_BMP_8BIT = 16,
220 FILE_PNG_8BIT = 32,
222 FILE_RAW_16BIT = 64
223 }emFileType;
224
226 typedef enum
227 {
229 STATISTICS_AVG = 0,
231 STATISTICS_HIST,
233 STATISTICS_WINDOW,
235 STATISTICS_REFER_WINDOW,
236 }emStatisticsMode;
237
239 typedef enum
240 {
242 PARAM_MODE_BY_MODEL = 0,
244 PARAM_MODE_BY_NAME,
246 PARAM_MODE_BY_SN,
248 PARAM_MODE_IN_DEVICE,
249 }emSdkParameterMode;
250
252 typedef enum
253 {
254 PARAMETER_TEAM_A = 0,
255 PARAMETER_TEAM_B = 1,
256 PARAMETER_TEAM_C = 2,
257 PARAMETER_TEAM_D = 3,
258 PARAMETER_TEAM_DEFAULT = 0xff,
259 }emSdkParameterTeam;
260
262 typedef enum
263 {
265 TRIGGER_MODE_CONTINUOUS = 0,
267 TRIGGER_MODE_SOFT,
269 TRIGGER_MODE_HARD,
270 }emTriggerMode;
271
273 typedef enum
274 {
275 TRIGGER_HARD_IDLE = 0,
276 TRIGGER_HARD_RISE = 1,
277 TRIGGER_HARD_FALL = 2,
278 TRIGGER_HARD_HIGH = 3,
279 TRIGGER_HARD_LOW = 4,
280 }mTriggerHardType;
281
283 typedef enum
284 {
286 STROBE_SYNC_WITH_TRIG_AUTO = 0,
288 STROBE_SYNC_WITH_TRIG_MANUAL,
290 STROBE_ALWAYS_HIGH,
292 STROBE_ALWAYS_LOW
293 }emStrobeControl;
294
296 typedef enum
297 {
299 EXT_TRIG_LEADING_EDGE = 0,
301 EXT_TRIG_TRAILING_EDGE,
303 EXT_TRIG_HIGH_LEVEL,
305 EXT_TRIG_LOW_LEVEL,
307 EXT_TRIG_DOUBLE_EDGE,
308 }emExtTrigSignal;
309
310 typedef enum
311 {
313 MIRROR_MODE_H = 0,
315 MIRROR_MODE_V = 1,
316 }emMirrorMode;
317
319 typedef enum
320 {
322 DISPLAYMODE_SCALE = 0,
324 DISPLAYMODE_REAL,
325 }emSdkDisplayMode;
326
328 typedef enum
329 {
331 AE_EXP_MODE = 0,
333 AE_FRAME_MODE,
334 }emAeExpMode;
335
337 typedef enum
338 {
340 SETTING_PAGE_DEVINFO = 0x01,
342 SETTING_PAGE_IMG_SETTING = 0x02,
344 SETTING_PAGE_EXP_SETTING = 0x04,
346 SETTING_PAGE_AWB_SETTING = 0x08,
348 SETTING_PAGE_CROSS_LINE = 0x10,
350 SETTING_PAGE_OUT_SETTING = 0x20,
352 SETTING_PAGE_REL_SETTING = 0x40,
354 SETTING_PAGE_GAMMA_SETTING = 0x80,
356 SETTING_PAGE_ALL = 0xFF,
357 }emSettingPage;
358
359
360
362 typedef enum
363 {
364 LUT_CHANNEL_ALL = 0,//R,B,G三通道同时调节
365 LUT_CHANNEL_RED, //红色通道
366 LUT_CHANNEL_GREEN, //绿色通道
367 LUT_CHANNEL_BLUE, //蓝色通道
368 }emSdkLutChannel;
369
371 typedef enum
372 {
373 GAMMA_DYNAMIC_MODE = 0, //动态模式
374 GAMMA_PRESET_MODE, //预置模式
375 GAMMA_USER_MODE, //自定义模式
376 }emSdkLutMode;
377
379 typedef enum
380 {
381 IOMODE_STROBE_OUTPUT = 0, //闪光灯输出
382 IOMODE_GP_OUTPUT, //通用输出
383 IOMODE_PWM_OUTPUT, //PWM输出
384 }emSdkOutputIOMode;
385
387 typedef enum
388 {
389 IOMODE_TRIG_INPUT = 0, //触发输入
390 IOMODE_GP_INPUT, //通用输入
391 }emSdkInputIOMode;
392
395 //----------------------------IMAGE FORMAT DEFINE------------------------------------
396 //----------------------------图像格式定义-------------------------------------------
397 #define CAMERA_MEDIA_TYPE_MONO 0x01000000
398 #define CAMERA_MEDIA_TYPE_RGB 0x02000000
399 #define CAMERA_MEDIA_TYPE_COLOR 0x02000000
400 #define CAMERA_MEDIA_TYPE_OCCUPY1BIT 0x00010000
401 #define CAMERA_MEDIA_TYPE_OCCUPY2BIT 0x00020000
402 #define CAMERA_MEDIA_TYPE_OCCUPY4BIT 0x00040000
403 #define CAMERA_MEDIA_TYPE_OCCUPY8BIT 0x00080000
404 #define CAMERA_MEDIA_TYPE_OCCUPY10BIT 0x000A0000
405 #define CAMERA_MEDIA_TYPE_OCCUPY12BIT 0x000C0000
406 #define CAMERA_MEDIA_TYPE_OCCUPY16BIT 0x00100000
407 #define CAMERA_MEDIA_TYPE_OCCUPY24BIT 0x00180000
408 #define CAMERA_MEDIA_TYPE_OCCUPY32BIT 0x00200000
409
410 #define CAMERA_FORMAT_RGB 0x00000014
411 #define CAMERA_FORMAT_BGR 0x00000015
412 #define CAMERA_FORMAT_MONO 0x00000000
413
414 #define CAMERA_MEDIA_TYPE_COLOR_MASK 0xFF000000
415 #define CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK 0x00FF0000
416 #define CAMERA_MEDIA_TYPE_ID_MASK 0x0000FFFF
417 #define CAMERA_MEDIA_TYPE_MEDIA_FORMAT 0x000000FF
418 /*Bayer */
419 #define CAMERA_MEDIA_TYPE_BAYGR8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0008)
420 #define CAMERA_MEDIA_TYPE_BAYRG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0009)
421 #define CAMERA_MEDIA_TYPE_BAYGB8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000A)
422 #define CAMERA_MEDIA_TYPE_BAYBG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000B)
423
424 /*RGB */
425 #define CAMERA_MEDIA_TYPE_RGB8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_RGB)
426 #define CAMERA_MEDIA_TYPE_BGR8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_BGR)
427 #define CAMERA_MEDIA_TYPE_RGBA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_RGB)
428 #define CAMERA_MEDIA_TYPE_BGRA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_BGR)
429
430 #define CAMERA_MEDIA_TYPE_MONO8 CAMERA_MEDIA_TYPE_MONO
431
433 typedef struct _tIspAe
434 {
436 BOOL bAutoExposure;
438 double ExposureTime;
440 UINT AnalogGain;
442 UINT AeTarget;
444 INT AeMode;
446 double fMinExposureTime;
448 double fMaxExposureTime;
450 INT iMinAnalogGain;
452 INT iMaxAnalogGain;
454 BOOL bAntiFlick;
456 UINT FrequencySel;
458 INT Left;
460 INT Top;
462 INT Width;
464 INT Height;
465 }tIspAe;
466
468 typedef struct _tIspWb
469 {
471 BOOL bAutoWb;
472 UINT DGainR;
473 UINT DGainG;
474 UINT DGainB;
476 INT Left;
478 INT Top;
480 INT Width;
482 INT Height;
484 INT CCM[9];
485 }tIspWb;
486
488 typedef struct _tIspGamma
489 {
490 UINT Mode;
492 UINT Gamma;
494 UINT GammaContrast;
495 UINT PresetSel;
496 INT rev[5]; //保留参数
497 }tIspGamma;
498
501 typedef struct _tDevLoadMode
502 {
504 tIspAe sIspAe;
506 tIspWb sIspWb;
508 UINT TriggerMode;
510 UINT ResolutionMode;
512 UINT MediaTypeMode;
514 UINT FrameSpeedMode;
516 UINT Sharpness;
518 UINT Saturation;
520 UINT Contrast;
522 tIspGamma sIspGamma;
524 UINT ParameterMode;
526 UINT ParameterTeam;
528 UINT MirrorHEn;
530 UINT MirrorVEn;
532 UINT ColorToGrayEn;
534 UINT BlackLevel;
535 } tDevLoadMode;
536
538 typedef struct _tExpose
539 {
541 UINT uiTargetMin;
543 UINT uiTargetMax;
545 UINT uiAnalogGainMin;
547 UINT uiAnalogGainMax;
549 UINT uiExposeTimeMin;
551 UINT uiExposeTimeMax;
552 } tExpose;
553
555 typedef struct _tResolutionRange
556 {
558 INT iHeightMax;
560 INT iHeightMin;
562 INT iWidthMax;
564 INT iWidthMin;
566 UINT uSkipModeMask;
568 UINT uBinSumModeMask;
570 UINT uBinAverageModeMask;
572 UINT uResampleMask;
573 } tResolutionRange;
574
576 typedef struct _tSdkTrigger
577 {
579 INT iIndex;
581 char acDescription[32];
582 } tSdkTrigger;
583
584 //相机的分辨率描述
585 typedef struct _tSdkImageResolution
586 {
588 INT iIndex;
590 char acDescription[32];
592 UINT uBinSumMode;
594 UINT uBinAverageMode;
596 UINT uSkipMode;
598 UINT uResampleMask;
600 INT iHOffsetFOV;
602 INT iVOffsetFOV;
604 INT iWidthFOV;
606 INT iHeightFOV;
608 INT iWidth;
610 INT iHeight;
612 INT iWidthZoomHd;
614 INT iHeightZoomHd;
616 INT iWidthZoomSw;
618 INT iHeightZoomSw;
619 } tSdkImageResolution;
620
622 typedef struct _tSdkColorTemperatureDes
623 {
625 INT iIndex;
627 char acDescription[32];
628 } tSdkColorTemperatureDes;
629
631 typedef struct _tSdkPackLength
632 {
634 INT iIndex;
636 char acDescription[32];
637 UINT iPackSize;
638 } tSdkPackLength;
639
641 typedef struct _tSdkPresetLut
642 {
644 INT iIndex;
646 char acDescription[32];
647 } tSdkPresetLut;
648
650 typedef struct _tSdkAeAlgorithm
651 {
653 INT iIndex;
655 char acDescription[32];
656 } tSdkAeAlgorithm;
657
659 typedef struct _tSdkBayerDecodeAlgorithm
660 {
662 INT iIndex;
664 char acDescription[32];
665 } tSdkBayerDecodeAlgorithm;
666
668 typedef struct _tSdkMediaType
669 {
671 INT iIndex;
673 char acDescription[32];
675 UINT iMediaType;
676 } tSdkMediaType;
677
679 typedef struct _tSdkBayerType
680 {
682 INT iIndex;
684 char acDescription[32];
686 UINT iMediaType;
687 } tSdkBayerType;
688
690 typedef struct _tSdkFrameSpeed
691 {
693 INT iIndex;
695 char acDescription[32];
696 } tSdkFrameSpeed;
697
699 typedef struct _tRgbGainRange
700 {
702 INT iRGainMin;
704 INT iRGainMax;
706 INT iGGainMin;
708 INT iGGainMax;
710 INT iBGainMin;
712 INT iBGainMax;
713 } tRgbGainRange;
714
716 typedef struct _tSaturationRange
717 {
719 INT iMin;
721 INT iMax;
722 } tSaturationRange;
723
725 typedef struct _tSharpnessRange
726 {
728 INT iMin;
730 INT iMax;
731 } tSharpnessRange;
732
734 typedef struct _tGammaRange
735 {
737 INT iMin;
739 INT iMax;
740 } tGammaRange;
741
743 typedef struct _tGammaContrastRange
744 {
746 INT iMin;
748 INT iMax;
749 }tGammaContrastRange;
750
751 //对比度的设定范围
753 typedef struct _tContrastRange
754 {
756 INT iMin;
758 INT iMax;
759 } tContrastRange;
760
762 typedef struct _tSdkIspCapacity
763 {
765 BOOL bMonoSensor;
767 BOOL bWbOnce;
769 BOOL bAutoWb;
771 BOOL bAutoExposure;
773 BOOL bManualExposure;
775 BOOL bAntiFlick;
777 BOOL bIspGamma;
779 BOOL bDeviceIsp;
781 BOOL bForceUseDeviceIsp;
783 BOOL bZoomHD;
784 BOOL rev[4];
785 } tSdkIspCapacity;
786
788 typedef struct _tSensorCfg
789 {
791 tExpose sExposeDesc;
793 tResolutionRange sResolutionRange;
795 tSdkImageResolution sMaxResolution;
796 } tSensorCfg;
797
799 typedef struct _tDeviceCfg
800 {
801
803 tRgbGainRange sRgbGainRange;
805 tSaturationRange sSaturationRange;
807 tGammaRange sGammaRange;
809 tGammaContrastRange sGammaContrastRange;
811 tContrastRange sContrastRange;
813 tSharpnessRange sSharpnessRange;
815 tSdkIspCapacity sIspCapacity;
816
818 tSdkTrigger *pTriggerDesc;
820 INT iTriggerDesc;
821
823 tSdkImageResolution *pImageSizeDesc;
825 INT iImageSizeDesc;
826
828 tSdkColorTemperatureDes *pClrTempDesc;
829 INT iClrTempDesc;
830
832 tSdkBayerType *pBayerTypeDesc;
834 INT iBayerTypdeDesc;
835
837 tSdkMediaType *pMediaTypeDesc;
839 INT iMediaTypdeDesc;
840
842 tSdkFrameSpeed *pFrameSpeedDesc;
844 INT iFrameSpeedDesc;
845
847 tSdkPackLength *pPackLenDesc;
849 INT iPackLenDesc;
850
852 INT iOutputIoCounts;
854 INT iInputIoCounts;
855
857 tSdkPresetLut *pPresetLutDesc;
859 INT iPresetLut;
860
862 INT iUserDataMaxLen;
864 BOOL bParamInDevice;
865
867 tSdkAeAlgorithm *pAeAlmSwDesc;
869 int iAeAlmSwDesc;
870
872 tSdkAeAlgorithm *pAeAlmHdDesc;
874 int iAeAlmHdDesc;
875
877 tSdkBayerDecodeAlgorithm *pBayerDecAlmSwDesc;
879 int iBayerDecAlmSwDesc;
880
882 tSdkBayerDecodeAlgorithm *pBayerDecAlmHdDesc;
884 int iBayerDecAlmHdDesc;
885
886 } tDeviceCfg;
887
889 typedef struct _tDevInfo
890 {
892 char acProductSeries[32];
894 char acProductName[32];
896 char acFriendlyName[32];
898 char acLinkName[32];
900 char acDriverName[128];
902 char acDriverVersion[32];
904 char acSensorType[32];
906 char acPortType[32];
908 UINT uInstance;
910 char acSn[32];
912 WORD VendorID;
914 WORD DeviceDrvID;
916 WORD DeviceDrvVersionID;
918 DWORD DeviceID;
920 char SymbolicName[128];
922 char Name[64];
924 DWORD SensorID;
925 } tDevInfo;
926
928 typedef struct _stImageInfo
929 {
931 UINT iWidth;
933 UINT iHeight;
935 UINT TotalBytes;
937 UINT uiMediaType;
939 double ExpTime;
941 double ExpLineTime;
943 UINT Gain;
944 }stImageInfo, *PstImageInfo;
945
947 typedef struct _FrameStatistic
948 {
950 DWORD iTotal;
952 DWORD iCapture;
954 INT iLost;
955 } FrameStatistic;
956
958 typedef struct _tSdkCameraCapbility
959 {
961 tDeviceCfg tDeviceCapbility;
963 tSensorCfg tSensorCapbility;
964
965 } tSdkCameraCapbility;
966
967
968
970 typedef struct _DisplayWindow
971 {
973 UINT ImageWidth;
975 UINT ImageHeight;
977 RECT WinRect;
979 RECT ImageRect;
980 }DisplayWindow;
981
983 typedef struct _tDevEnumInfo
984 {
986 tDevInfo DevAttribute;
988 BOOL bDevOpen;
989 } tDevEnumInfo;
990
992 typedef struct _tDevLoadInfo
993 {
995 tDevEnumInfo DevEnumInfo;
997 tDevLoadMode DevLoadMode;
998 } tDevLoadInfo;
999
1000
1005 typedef void (WINAPI* CAMERA_SNAP_PROC)(HANDLE handle, BYTE *pFrameBuffer, stImageInfo* pFrameInfo, LPVOID lpParam);
1007 typedef void (WINAPI* CAMERA_DISPLAY_PROC)(HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam);
1012 #endif
_tSdkBayerDecodeAlgorithm::iIndex
INT iIndex
编号
Definition: CKDeviceDef.h:662
_tDeviceCfg::iAeAlmSwDesc
int iAeAlmSwDesc
软件自动曝光算法个数
Definition: CKDeviceDef.h:869
MIRROR_MODE_V
垂直镜像
Definition: CKDeviceDef.h:315
tSdkMediaType
struct _tSdkMediaType tSdkMediaType
相机输出的图像数据格式
_tResolutionRange::uResampleMask
UINT uResampleMask
硬件重采样的掩码
Definition: CKDeviceDef.h:572
_tRgbGainRange::iRGainMax
INT iRGainMax
红色增益的最大值
Definition: CKDeviceDef.h:704
_tIspGamma::Mode
UINT Mode
Definition: CKDeviceDef.h:490
PARAMETER_TEAM_A
Definition: CKDeviceDef.h:254
_tSdkMediaType::iMediaType
UINT iMediaType
对应的图像格式编码，如CAMERA_MEDIA_TYPE_BAYGR8，在本文件中有定义。
Definition: CKDeviceDef.h:675
STATISTICS_WINDOW
带权重3x3的统计方式
Definition: CKDeviceDef.h:233
emFlickerMode
emFlickerMode
灯光频闪
Definition: CKDeviceDef.h:196
_tDeviceCfg::iOutputIoCounts
INT iOutputIoCounts
可编程输出IO的个数
Definition: CKDeviceDef.h:852
IMAGEOUT_MODE_1600X1200
分辨率512x384
Definition: CKDeviceDef.h:168
tSdkAeAlgorithm
struct _tSdkAeAlgorithm tSdkAeAlgorithm
AE算法描述
_tIspAe::bAntiFlick
BOOL bAntiFlick
在支持自动曝光功能的前提下，默认关闭
Definition: CKDeviceDef.h:454
_tSdkImageResolution::iWidth
INT iWidth
相机最终输出的图像的宽度,偶数,且4字节对齐
Definition: CKDeviceDef.h:608
tSdkFrameSpeed
struct _tSdkFrameSpeed tSdkFrameSpeed
相机帧率描述信息
_tIspWb
白平衡参数
Definition: CKDeviceDef.h:468
emFileType
emFileType
保存图片的文件格式
Definition: CKDeviceDef.h:207
_tDeviceCfg::sGammaRange
tGammaRange sGammaRange
伽马范围描述
Definition: CKDeviceDef.h:807
_tSdkIspCapacity
ISP模块的使能信息
Definition: CKDeviceDef.h:762
_tSdkImageResolution::acDescription
char acDescription[32]
该分辨率的描述信息。仅预设分辨率时该信息有效。自定义分辨率可忽略该信息
Definition: CKDeviceDef.h:590
IMAGEOUT_MODE_320X240
分辨率512x384
Definition: CKDeviceDef.h:164
_tDeviceCfg::sSharpnessRange
tSharpnessRange sSharpnessRange
锐化范围描述
Definition: CKDeviceDef.h:813
_tSdkPackLength::iIndex
INT iIndex
分包大小索引号
Definition: CKDeviceDef.h:634
_tDeviceCfg::pImageSizeDesc
tSdkImageResolution * pImageSizeDesc
预设分辨率选择
Definition: CKDeviceDef.h:823
FILE_BMP
保存为BMP文件格式
Definition: CKDeviceDef.h:212
_tSdkPackLength
传输分包大小描述(主要是针对网络相机有效)
Definition: CKDeviceDef.h:631
_tIspWb::Width
INT Width
设置窗口宽度
Definition: CKDeviceDef.h:480
_tDevEnumInfo::DevAttribute
tDevInfo DevAttribute
设备属性信息
Definition: CKDeviceDef.h:986
_tDevLoadMode::sIspWb
tIspWb sIspWb
白平衡参数
Definition: CKDeviceDef.h:506
tSensorCfg
struct _tSensorCfg tSensorCfg
sensor能力级
_tIspWb::Height
INT Height
设置窗口高度
Definition: CKDeviceDef.h:482
_tDeviceCfg::iBayerDecAlmHdDesc
int iBayerDecAlmHdDesc
硬件Bayer转换为RGB数据的算法个数，为0表示不支持
Definition: CKDeviceDef.h:884
_tIspAe::fMinExposureTime
double fMinExposureTime
自动模式下的最小曝光时间，us
Definition: CKDeviceDef.h:446
_tDeviceCfg::pTriggerDesc
tSdkTrigger * pTriggerDesc
触发模式
Definition: CKDeviceDef.h:818
_tSdkImageResolution::iVOffsetFOV
INT iVOffsetFOV
采集视场相对于Sensor最大视场左上角的垂直偏移，偶数
Definition: CKDeviceDef.h:602
_tExpose::uiExposeTimeMax
UINT uiExposeTimeMax
手动模式下，曝光时间的最大值，单位:行
Definition: CKDeviceDef.h:551
TRIGGER_HARD_FALL
Definition: CKDeviceDef.h:277
IOMODE_TRIG_INPUT
Definition: CKDeviceDef.h:389
_tDeviceCfg::iBayerDecAlmSwDesc
int iBayerDecAlmSwDesc
软件Bayer转换为RGB数据的算法个数
Definition: CKDeviceDef.h:879
_tDeviceCfg::pFrameSpeedDesc
tSdkFrameSpeed * pFrameSpeedDesc
可调节帧速类型，对应界面上普通 高速 和超级三种速度设置
Definition: CKDeviceDef.h:842
SETTING_PAGE_EXP_SETTING
曝光配置页面
Definition: CKDeviceDef.h:344
IMAGEOUT_MODE_1280X720
分辨率512x384
Definition: CKDeviceDef.h:156
_tSdkTrigger
触发模式描述
Definition: CKDeviceDef.h:576
_tSdkImageResolution::iHeightZoomSw
INT iHeightZoomSw
软件缩放的高度,不需要进行此操作的分辨率，此变量设置为0.偶数
Definition: CKDeviceDef.h:618
_stImageInfo::ExpTime
double ExpTime
当前图像的曝光时间，单位为微秒us
Definition: CKDeviceDef.h:939
_tSdkIspCapacity::bManualExposure
BOOL bManualExposure
表示该型号相机是否支持手动曝光功能
Definition: CKDeviceDef.h:773
_tSdkBayerType::iIndex
INT iIndex
格式种类编号
Definition: CKDeviceDef.h:682
emTriggerMode
emTriggerMode
相机触发模式
Definition: CKDeviceDef.h:262
IOMODE_STROBE_OUTPUT
Definition: CKDeviceDef.h:381
SETTING_PAGE_DEVINFO
设备信息配置页面
Definition: CKDeviceDef.h:340
_tRgbGainRange::iBGainMax
INT iBGainMax
蓝色增益的最大值
Definition: CKDeviceDef.h:712
EXT_TRIG_DOUBLE_EDGE
双边沿触发
Definition: CKDeviceDef.h:307
_tSdkBayerDecodeAlgorithm::acDescription
char acDescription[32]
描述信息
Definition: CKDeviceDef.h:664
STATISTICS_AVG
均值统计
Definition: CKDeviceDef.h:229
SETTING_PAGE_REL_SETTING
分辨率配置页面
Definition: CKDeviceDef.h:352
SETTING_PAGE_AWB_SETTING
白平衡配置页面
Definition: CKDeviceDef.h:346
_tSdkMediaType::acDescription
char acDescription[32]
描述信息
Definition: CKDeviceDef.h:673
SETTING_PAGE_GAMMA_SETTING
伽玛配置界面
Definition: CKDeviceDef.h:354
_tDevLoadMode::sIspAe
tIspAe sIspAe
AE参数
Definition: CKDeviceDef.h:504
_tSdkCameraCapbility
相机能力级
Definition: CKDeviceDef.h:958
_tExpose
相机曝光功能范围定义
Definition: CKDeviceDef.h:538
emSdkOutputIOMode
emSdkOutputIOMode
IO输出模式
Definition: CKDeviceDef.h:379
_tResolutionRange
相机的分辨率设定范围，用于构件UI
Definition: CKDeviceDef.h:555
_tSdkBayerDecodeAlgorithm
RAW转RGB算法描述
Definition: CKDeviceDef.h:659
_tRgbGainRange::iRGainMin
INT iRGainMin
红色增益的最小值
Definition: CKDeviceDef.h:702
LUT_CHANNEL_GREEN
Definition: CKDeviceDef.h:366
_tDevInfo::acSensorType
char acSensorType[32]
sensor类型
Definition: CKDeviceDef.h:904
_tIspWb::bAutoWb
BOOL bAutoWb
在支持自动白平衡功能的前提下，默认关闭
Definition: CKDeviceDef.h:471
_tGammaRange::iMin
INT iMin
最小值
Definition: CKDeviceDef.h:737
tSdkPackLength
struct _tSdkPackLength tSdkPackLength
传输分包大小描述(主要是针对网络相机有效)
tIspAe
struct _tIspAe tIspAe
曝光参数
_tDevInfo::DeviceDrvVersionID
WORD DeviceDrvVersionID
设备驱动版本ID
Definition: CKDeviceDef.h:916
IMAGEOUT_MODE_NUM
SDK预定义的分辩率的个数
Definition: CKDeviceDef.h:178
_tResolutionRange::iWidthMin
INT iWidthMin
图像最小宽度
Definition: CKDeviceDef.h:564
IOMODE_GP_OUTPUT
Definition: CKDeviceDef.h:382
_tIspWb::DGainG
UINT DGainG
Definition: CKDeviceDef.h:473
_tIspWb::DGainB
UINT DGainB
Definition: CKDeviceDef.h:474
_tResolutionRange::iWidthMax
INT iWidthMax
图像最大宽度
Definition: CKDeviceDef.h:562
mTriggerHardType
mTriggerHardType
图像镜像模式
Definition: CKDeviceDef.h:273
_tIspGamma::PresetSel
UINT PresetSel
Definition: CKDeviceDef.h:495
GAMMA_USER_MODE
Definition: CKDeviceDef.h:375
_DisplayWindow::ImageRect
RECT ImageRect
有效图像矩形框
Definition: CKDeviceDef.h:979
tSdkCameraCapbility
struct _tSdkCameraCapbility tSdkCameraCapbility
相机能力级
_tDevLoadMode::BlackLevel
UINT BlackLevel
黑电平
Definition: CKDeviceDef.h:534
_tSdkPresetLut
预设的LUT表描述
Definition: CKDeviceDef.h:641
IOMODE_PWM_OUTPUT
Definition: CKDeviceDef.h:383
_tSdkCameraCapbility::tSensorCapbility
tSensorCfg tSensorCapbility
sensor能力级
Definition: CKDeviceDef.h:963
_tSensorCfg::sExposeDesc
tExpose sExposeDesc
曝光的范围值
Definition: CKDeviceDef.h:791
_tExpose::uiAnalogGainMin
UINT uiAnalogGainMin
模拟增益的最小值，单位为倍数，再扩大1000倍
Definition: CKDeviceDef.h:545
_tSdkMediaType::iIndex
INT iIndex
格式种类编号
Definition: CKDeviceDef.h:671
_tIspGamma::rev
INT rev[5]
Definition: CKDeviceDef.h:496
_tDevInfo::acPortType
char acPortType[32]
接口类型
Definition: CKDeviceDef.h:906
_tSensorCfg::sResolutionRange
tResolutionRange sResolutionRange
分辨率范围描述
Definition: CKDeviceDef.h:793
_tIspAe::AeTarget
UINT AeTarget
AE目标亮度
Definition: CKDeviceDef.h:442
_tExpose::uiAnalogGainMax
UINT uiAnalogGainMax
模拟增益的最大值，单位为倍数，再扩大1000倍
Definition: CKDeviceDef.h:547
emSdkLutChannel
emSdkLutChannel
LUT的颜色通道
Definition: CKDeviceDef.h:362
emSettingPage
emSettingPage
设备属性设置对话框显示的TAB页面的掩码
Definition: CKDeviceDef.h:337
_DisplayWindow::ImageWidth
UINT ImageWidth
图像宽度
Definition: CKDeviceDef.h:973
_tIspWb::CCM
INT CCM[9]
色彩空间
Definition: CKDeviceDef.h:484
_tDeviceCfg::sRgbGainRange
tRgbGainRange sRgbGainRange
图像数字增益范围描述
Definition: CKDeviceDef.h:803
_tSdkImageResolution::iWidthFOV
INT iWidthFOV
采集视场的宽度，必须为偶数
Definition: CKDeviceDef.h:604
_tSharpnessRange::iMin
INT iMin
最小值
Definition: CKDeviceDef.h:728
_tSdkColorTemperatureDes::acDescription
char acDescription[32]
描述信息
Definition: CKDeviceDef.h:627
SETTING_PAGE_CROSS_LINE
十字线配置页面
Definition: CKDeviceDef.h:348
_DisplayWindow::WinRect
RECT WinRect
显示窗口矩形
Definition: CKDeviceDef.h:977
tSdkPresetLut
struct _tSdkPresetLut tSdkPresetLut
预设的LUT表描述
_tSensorCfg
sensor能力级
Definition: CKDeviceDef.h:788
_tIspGamma::GammaContrast
UINT GammaContrast
LUT的对比度值
Definition: CKDeviceDef.h:494
_tContrastRange::iMin
INT iMin
最小值
Definition: CKDeviceDef.h:756
SETTING_PAGE_OUT_SETTING
视频输出配置页面
Definition: CKDeviceDef.h:350
_tDevInfo::SymbolicName
char SymbolicName[128]
设备标号，内部使用
Definition: CKDeviceDef.h:920
emMirrorMode
emMirrorMode
Definition: CKDeviceDef.h:310
_tSdkIspCapacity::bZoomHD
BOOL bZoomHD
相机硬件是否支持图像缩放输出(只能是缩小)。
Definition: CKDeviceDef.h:783
_tDevInfo::acProductName
char acProductName[32]
产品名称
Definition: CKDeviceDef.h:894
_tDeviceCfg::pAeAlmHdDesc
tSdkAeAlgorithm * pAeAlmHdDesc
硬件自动曝光算法描述，为NULL表示不支持硬件自动曝光
Definition: CKDeviceDef.h:872
_tGammaRange::iMax
INT iMax
最大值
Definition: CKDeviceDef.h:739
_tDevLoadMode::ColorToGrayEn
UINT ColorToGrayEn
彩色转灰度图
Definition: CKDeviceDef.h:532
tSdkColorTemperatureDes
struct _tSdkColorTemperatureDes tSdkColorTemperatureDes
相机白平衡色温模式描述信息
_tSdkColorTemperatureDes
相机白平衡色温模式描述信息
Definition: CKDeviceDef.h:622
_tDeviceCfg::iBayerTypdeDesc
INT iBayerTypdeDesc
相机Bayer格式的种类个数，即pBayerTypeDesc数组的大小。
Definition: CKDeviceDef.h:834
_tRgbGainRange::iBGainMin
INT iBGainMin
蓝色增益的最小值
Definition: CKDeviceDef.h:710
_tSdkColorTemperatureDes::iIndex
INT iIndex
模式索引号
Definition: CKDeviceDef.h:625
IMAGEOUT_MODE_512X384
分辨率512x384
Definition: CKDeviceDef.h:148
_tDevLoadMode::MirrorVEn
UINT MirrorVEn
垂直镜像使能
Definition: CKDeviceDef.h:530
_tGammaRange
伽马的设定范围
Definition: CKDeviceDef.h:734
_tSdkImageResolution::uBinSumMode
UINT uBinSumMode
BIN(求和)的模式,范围不能超过tSdkResolutionRange中uBinSumModeMask.
Definition: CKDeviceDef.h:592
TRIGGER_MODE_HARD
硬件触发模式
Definition: CKDeviceDef.h:269
_tResolutionRange::uSkipModeMask
UINT uSkipModeMask
SKIP模式掩码，为0，表示不支持SKIP 。bit0为1,表示支持SKIP 2x2 ;bit1为1，表示支持SKIP 3x3...
Definition: CKDeviceDef.h:566
FREQ_FLICKER_MODE_60HZ
消除60hz频闪
Definition: CKDeviceDef.h:203
_tSdkBayerType::acDescription
char acDescription[32]
描述信息
Definition: CKDeviceDef.h:684
_tResolutionRange::iHeightMax
INT iHeightMax
图像最大高度
Definition: CKDeviceDef.h:558
_tSharpnessRange
锐化的设定范围
Definition: CKDeviceDef.h:725
_tIspAe::ExposureTime
double ExposureTime
在支持手动曝光功能的前提下设置
Definition: CKDeviceDef.h:438
_tSdkImageResolution::uSkipMode
UINT uSkipMode
是否SKIP的尺寸，为0表示禁止SKIP模式，范围不能超过tSdkResolutionRange中uSkipModeMask ...
Definition: CKDeviceDef.h:596
_tSdkIspCapacity::bMonoSensor
BOOL bMonoSensor
表示该型号相机是否为黑白相机,如果是黑白相机，则颜色相关的功能都无法调节
Definition: CKDeviceDef.h:765
_stImageInfo::uiMediaType
UINT uiMediaType
图像格式
Definition: CKDeviceDef.h:937
_tSdkIspCapacity::bDeviceIsp
BOOL bDeviceIsp
表示该型号相机是否支持硬件ISP功能
Definition: CKDeviceDef.h:779
tSdkBayerDecodeAlgorithm
struct _tSdkBayerDecodeAlgorithm tSdkBayerDecodeAlgorithm
RAW转RGB算法描述
_tDevInfo::acProductSeries
char acProductSeries[32]
产品系列
Definition: CKDeviceDef.h:892
IOMODE_GP_INPUT
Definition: CKDeviceDef.h:390
_tDevLoadMode::Sharpness
UINT Sharpness
锐度
Definition: CKDeviceDef.h:516
_tIspAe::Left
INT Left
设置窗口左
Definition: CKDeviceDef.h:458
tSdkImageResolution
struct _tSdkImageResolution tSdkImageResolution
LUT_CHANNEL_BLUE
Definition: CKDeviceDef.h:367
_tDevLoadMode::Saturation
UINT Saturation
饱和度
Definition: CKDeviceDef.h:518
_stImageInfo::ExpLineTime
double ExpLineTime
当前图像的行曝光时间，单位为微秒us
Definition: CKDeviceDef.h:941
_tDeviceCfg::iClrTempDesc
INT iClrTempDesc
Definition: CKDeviceDef.h:829
FREQ_FLICKER_MODE_NULL
禁止消除频闪
Definition: CKDeviceDef.h:199
_DisplayWindow::ImageHeight
UINT ImageHeight
图像高度
Definition: CKDeviceDef.h:975
_tIspAe::Width
INT Width
设置窗口宽度
Definition: CKDeviceDef.h:462
_tSdkImageResolution::iHeightZoomHd
INT iHeightZoomHd
硬件缩放的高度,不需要进行此操作的分辨率，此变量设置为0.
Definition: CKDeviceDef.h:614
_tDevLoadMode::sIspGamma
tIspGamma sIspGamma
Gamma.
Definition: CKDeviceDef.h:522
_tIspAe::AeMode
INT AeMode
AE自动曝光的模式，AE_FRAME_MODE帧率优先，AE_EXP_MODE曝光优先
Definition: CKDeviceDef.h:444
_tIspAe
曝光参数
Definition: CKDeviceDef.h:433
tRgbGainRange
struct _tRgbGainRange tRgbGainRange
RGB三通道数字增益的设定范围
DisplayWindow
struct _DisplayWindow DisplayWindow
显示窗口的参数
_tSdkImageResolution::uBinAverageMode
UINT uBinAverageMode
BIN(求均值)的模式,范围不能超过tSdkResolutionRange中uBinAverageModeMask.
Definition: CKDeviceDef.h:594
_tResolutionRange::iHeightMin
INT iHeightMin
图像最小高度
Definition: CKDeviceDef.h:560
tContrastRange
struct _tContrastRange tContrastRange
对比度的设定范围
IMAGEOUT_MODE_2592X1944
分辨率512x384
Definition: CKDeviceDef.h:170
_tDeviceCfg::pPresetLutDesc
tSdkPresetLut * pPresetLutDesc
相机预设的LUT表
Definition: CKDeviceDef.h:857
_tDeviceCfg::pPackLenDesc
tSdkPackLength * pPackLenDesc
传输包长度，一般用于网络设备
Definition: CKDeviceDef.h:847
_tDeviceCfg::sContrastRange
tContrastRange sContrastRange
对比度范围描述
Definition: CKDeviceDef.h:811
_FrameStatistic::iLost
INT iLost
当前丢帧的数量
Definition: CKDeviceDef.h:954
_tSharpnessRange::iMax
INT iMax
最大值
Definition: CKDeviceDef.h:730
_tSdkFrameSpeed::acDescription
char acDescription[32]
描述信息
Definition: CKDeviceDef.h:695
_tDevInfo
相机的设备信息
Definition: CKDeviceDef.h:889
EXT_TRIG_TRAILING_EDGE
下降沿触发
Definition: CKDeviceDef.h:301
_tSaturationRange::iMin
INT iMin
最小值
Definition: CKDeviceDef.h:719
PARAMETER_TEAM_B
Definition: CKDeviceDef.h:255
PARAMETER_TEAM_C
Definition: CKDeviceDef.h:256
_tSdkIspCapacity::bIspGamma
BOOL bIspGamma
表示该型号相机是否支持Gamma功能
Definition: CKDeviceDef.h:777
_tDeviceCfg::pAeAlmSwDesc
tSdkAeAlgorithm * pAeAlmSwDesc
软件自动曝光算法描述
Definition: CKDeviceDef.h:867
STROBE_ALWAYS_HIGH
始终为高，忽略STROBE信号的其他设置
Definition: CKDeviceDef.h:290
FRAME_SPEED_LOW
帧速度 低速
Definition: CKDeviceDef.h:188
EXT_TRIG_LEADING_EDGE
上升沿触发，默认为该方式
Definition: CKDeviceDef.h:299
_tExpose::uiTargetMax
UINT uiTargetMax
自动曝光亮度目标最大值
Definition: CKDeviceDef.h:543
emSdkParameterMode
emSdkParameterMode
参数文件加载方式
Definition: CKDeviceDef.h:239
_tDeviceCfg::pMediaTypeDesc
tSdkMediaType * pMediaTypeDesc
相机输出图像格式
Definition: CKDeviceDef.h:837
_tDeviceCfg::iFrameSpeedDesc
INT iFrameSpeedDesc
可调节帧速类型的个数，即pFrameSpeedDesc数组的大小。
Definition: CKDeviceDef.h:844
_tDevInfo::VendorID
WORD VendorID
厂商ID
Definition: CKDeviceDef.h:912
_DisplayWindow
显示窗口的参数
Definition: CKDeviceDef.h:970
_FrameStatistic
帧率统计信息
Definition: CKDeviceDef.h:947
_tSdkImageResolution::iWidthZoomHd
INT iWidthZoomHd
硬件缩放的宽度,不需要进行此操作的分辨率，此变量设置为0.
Definition: CKDeviceDef.h:612
_stImageInfo::iHeight
UINT iHeight
当期图像高
Definition: CKDeviceDef.h:933
FREQ_FLICKER_MODE_50HZ
消除50hz频闪
Definition: CKDeviceDef.h:201
_tDevEnumInfo
枚举信息
Definition: CKDeviceDef.h:983
STATISTICS_HIST
直方图的统计方式
Definition: CKDeviceDef.h:231
_tDeviceCfg::iPackLenDesc
INT iPackLenDesc
可供选择的传输分包长度的个数，即pPackLenDesc数组的大小。
Definition: CKDeviceDef.h:849
emSdkParameterTeam
emSdkParameterTeam
相机的配置参数，分为A,B,C,D共4组进行保存。
Definition: CKDeviceDef.h:252
emAeExpMode
emAeExpMode
自动曝光模式
Definition: CKDeviceDef.h:328
_tContrastRange::iMax
INT iMax
最大值
Definition: CKDeviceDef.h:758
_tRgbGainRange
RGB三通道数字增益的设定范围
Definition: CKDeviceDef.h:699
_tGammaContrastRange::iMax
INT iMax
最大值
Definition: CKDeviceDef.h:748
emFrameMode
emFrameMode
帧速度
Definition: CKDeviceDef.h:185
_tDevLoadMode::ParameterMode
UINT ParameterMode
参数的模式
Definition: CKDeviceDef.h:524
IMAGEOUT_MODE_768X576
分辨率512x384
Definition: CKDeviceDef.h:174
emExtTrigSignal
emExtTrigSignal
硬件外触发的信号种类
Definition: CKDeviceDef.h:296
_tDeviceCfg::iImageSizeDesc
INT iImageSizeDesc
预设分辨率的个数，即pImageSizeDesc数组的大小
Definition: CKDeviceDef.h:825
_tDeviceCfg::iTriggerDesc
INT iTriggerDesc
触发模式的个数，即pTriggerDesc数组的大小
Definition: CKDeviceDef.h:820
_FrameStatistic::iTotal
DWORD iTotal
当前采集的总帧数（包括错误帧）
Definition: CKDeviceDef.h:950
_tSdkIspCapacity::bForceUseDeviceIsp
BOOL bForceUseDeviceIsp
bDeviceIsp和bForceUseDeviceIsp同时为TRUE时，表示强制只用硬件ISP，不可取消。
Definition: CKDeviceDef.h:781
_tSaturationRange
饱和度设定的范围
Definition: CKDeviceDef.h:716
FILE_RAW_16BIT
保存为BMP 16BIT文件格式, 对于不支持bayer格式输出相机，无法保存为该格式
Definition: CKDeviceDef.h:222
IMAGEOUT_MODE_2048X1536
分辨率512x384
Definition: CKDeviceDef.h:162
tDeviceCfg
struct _tDeviceCfg tDeviceCfg
设备能力级
STROBE_SYNC_WITH_TRIG_AUTO
和触发信号同步，触发后，相机进行曝光时，自动生成STROBE信号。此时，有效极性可设置(CameraSetStrobePolar...
Definition: CKDeviceDef.h:286
IMAGEOUT_MODE_CUSTOM
自定义分辨率
Definition: CKDeviceDef.h:181
_tSdkPackLength::iPackSize
UINT iPackSize
Definition: CKDeviceDef.h:637
LUT_CHANNEL_ALL
Definition: CKDeviceDef.h:364
PARAM_MODE_IN_DEVICE
从设备的固态存储器中加载参数。不是所有的型号都支持从相机中读写参数组，由tSdkCameraCapbility.bParamInDevice决定
Definition: CKDeviceDef.h:248
_tSdkCameraCapbility::tDeviceCapbility
tDeviceCfg tDeviceCapbility
设备能力级
Definition: CKDeviceDef.h:961
TRIGGER_MODE_CONTINUOUS
连续触发模式
Definition: CKDeviceDef.h:265
_tSdkFrameSpeed
相机帧率描述信息
Definition: CKDeviceDef.h:690
tDevEnumInfo
struct _tDevEnumInfo tDevEnumInfo
枚举信息
DISPLAYMODE_SCALE
缩放显示模式，缩放到显示控件的尺寸
Definition: CKDeviceDef.h:322
_tDeviceCfg::iPresetLut
INT iPresetLut
相机预设的LUT表的个数，即pPresetLutDesc数组的大小
Definition: CKDeviceDef.h:859
_tSaturationRange::iMax
INT iMax
最大值
Definition: CKDeviceDef.h:721
EXT_TRIG_LOW_LEVEL
低电平触发
Definition: CKDeviceDef.h:305
_tDevLoadInfo::DevLoadMode
tDevLoadMode DevLoadMode
模式信息
Definition: CKDeviceDef.h:997
FILE_RAW
保存为BMP文件格式, 对于不支持bayer格式输出相机，无法保存为该格式
Definition: CKDeviceDef.h:214
_tSdkBayerType::iMediaType
UINT iMediaType
对应的sensor支持的格式编码，如CAMERA_MEDIA_TYPE_BAYGR8
Definition: CKDeviceDef.h:686
_tSdkIspCapacity::bAutoWb
BOOL bAutoWb
表示该型号相机是否支持自动白平衡功能
Definition: CKDeviceDef.h:769
_tSdkImageResolution::iHeightFOV
INT iHeightFOV
采集视场的高度，必须为偶数
Definition: CKDeviceDef.h:606
FRAME_SPEED_MIDDLE
帧速度 中速
Definition: CKDeviceDef.h:190
SETTING_PAGE_IMG_SETTING
图像参数配置页面
Definition: CKDeviceDef.h:342
emSdkInputIOMode
emSdkInputIOMode
IO输入模式
Definition: CKDeviceDef.h:387
FILE_JPG
保存为JPEG文件格式
Definition: CKDeviceDef.h:210
_tDeviceCfg::iUserDataMaxLen
INT iUserDataMaxLen
指示该相机中用于保存用户数据区的最大长度。为0表示无。
Definition: CKDeviceDef.h:862
SETTING_PAGE_ALL
显示所有的属性页
Definition: CKDeviceDef.h:356
_tDeviceCfg::pBayerTypeDesc
tSdkBayerType * pBayerTypeDesc
相机Bayer格式
Definition: CKDeviceDef.h:832
_stImageInfo::Gain
UINT Gain
当前图像的增益倍数
Definition: CKDeviceDef.h:943
_tDeviceCfg
设备能力级
Definition: CKDeviceDef.h:799
emResolutionMode
emResolutionMode
图像分辨率
Definition: CKDeviceDef.h:145
tResolutionRange
struct _tResolutionRange tResolutionRange
相机的分辨率设定范围，用于构件UI
_tDeviceCfg::sGammaContrastRange
tGammaContrastRange sGammaContrastRange
伽马对比度范围描述
Definition: CKDeviceDef.h:809
_tResolutionRange::uBinSumModeMask
UINT uBinSumModeMask
BIN(求和)模式掩码，为0，表示不支持BIN 。bit0为1,表示支持BIN 2x2 ;bit1为1，表示支持BIN 3x3...
Definition: CKDeviceDef.h:568
PARAM_MODE_BY_MODEL
根据相机型号名从文件中加载参数，例如CK-U2B300
Definition: CKDeviceDef.h:242
_tDevInfo::Name
char Name[64]
设备标号，内部使用
Definition: CKDeviceDef.h:922
_tDeviceCfg::pBayerDecAlmHdDesc
tSdkBayerDecodeAlgorithm * pBayerDecAlmHdDesc
硬件Bayer转换为RGB数据的算法描述，为NULL表示不支持
Definition: CKDeviceDef.h:882
_tDevLoadMode::ResolutionMode
UINT ResolutionMode
分辨率
Definition: CKDeviceDef.h:510
EXT_TRIG_HIGH_LEVEL
高电平触发,电平宽度决定曝光时间，仅部分型号的相机支持电平触发方式
Definition: CKDeviceDef.h:303
emStatisticsMode
emStatisticsMode
曝光算法
Definition: CKDeviceDef.h:226
_tSdkIspCapacity::bWbOnce
BOOL bWbOnce
表示该型号相机是否支持一次白平衡功能
Definition: CKDeviceDef.h:767
tDevInfo
struct _tDevInfo tDevInfo
相机的设备信息
_tSdkPresetLut::iIndex
INT iIndex
编号
Definition: CKDeviceDef.h:644
_tIspAe::iMaxAnalogGain
INT iMaxAnalogGain
自动模式下的最大模拟增益
Definition: CKDeviceDef.h:452
IMAGEOUT_MODE_752X480
分辨率512x384
Definition: CKDeviceDef.h:172
tSdkBayerType
struct _tSdkBayerType tSdkBayerType
相机输出的图像数据格式
AE_FRAME_MODE
自动曝光曝光优先模式
Definition: CKDeviceDef.h:333
tGammaRange
struct _tGammaRange tGammaRange
伽马的设定范围
stImageInfo
struct _stImageInfo stImageInfo
帧头信息
_tSdkImageResolution::iIndex
INT iIndex
分辨率 emResolutionMode
Definition: CKDeviceDef.h:588
_tDeviceCfg::iAeAlmHdDesc
int iAeAlmHdDesc
硬件自动曝光算法个数，为0表示不支持硬件自动曝光
Definition: CKDeviceDef.h:874
tIspGamma
struct _tIspGamma tIspGamma
gama参数
tIspWb
struct _tIspWb tIspWb
白平衡参数
_tSdkIspCapacity::bAntiFlick
BOOL bAntiFlick
表示该型号相机是否支持抗频闪功能
Definition: CKDeviceDef.h:775
_tSdkMediaType
相机输出的图像数据格式
Definition: CKDeviceDef.h:668
_tDevLoadInfo
/设备的当前模式和枚举信息
Definition: CKDeviceDef.h:992
_tDevLoadMode::TriggerMode
UINT TriggerMode
触发模式
Definition: CKDeviceDef.h:508
_tDevInfo::acLinkName
char acLinkName[32]
内核符号连接名，内部使用
Definition: CKDeviceDef.h:898
_tDevInfo::acDriverName
char acDriverName[128]
驱动名称
Definition: CKDeviceDef.h:900
_tDeviceCfg::iInputIoCounts
INT iInputIoCounts
可编程输入IO的个数
Definition: CKDeviceDef.h:854
GAMMA_DYNAMIC_MODE
Definition: CKDeviceDef.h:373
DISPLAYMODE_REAL
1:1显示模式，当图像尺寸大于显示控件的尺寸时，只显示局部
Definition: CKDeviceDef.h:324
_tDevInfo::acSn
char acSn[32]
产品唯一序列号
Definition: CKDeviceDef.h:910
_tGammaContrastRange::iMin
INT iMin
最小值
Definition: CKDeviceDef.h:746
_tSdkTrigger::iIndex
INT iIndex
模式索引号
Definition: CKDeviceDef.h:579
AE_EXP_MODE
自动曝光帧率优先模式
Definition: CKDeviceDef.h:331
IMAGEOUT_MODE_1280X1024
分辨率512x384
Definition: CKDeviceDef.h:166
_tDevInfo::acDriverVersion
char acDriverVersion[32]
驱动版本
Definition: CKDeviceDef.h:902
_tIspGamma
gama参数
Definition: CKDeviceDef.h:488
TRIGGER_MODE_SOFT
软件触发模式
Definition: CKDeviceDef.h:267
_tDevLoadMode::FrameSpeedMode
UINT FrameSpeedMode
帧速度
Definition: CKDeviceDef.h:514
IMAGEOUT_MODE_1280X960
分辨率512x384
Definition: CKDeviceDef.h:158
TRIGGER_HARD_IDLE
Definition: CKDeviceDef.h:275
GAMMA_PRESET_MODE
Definition: CKDeviceDef.h:374
FRAME_SPEED_HIGH
帧速度 高速
Definition: CKDeviceDef.h:192
_tSdkPackLength::acDescription
char acDescription[32]
对应的描述信息
Definition: CKDeviceDef.h:636
_tDeviceCfg::sIspCapacity
tSdkIspCapacity sIspCapacity
ISP能力描述
Definition: CKDeviceDef.h:815
_tSdkFrameSpeed::iIndex
INT iIndex
帧率索引号，一般0对应于低速模式，1对应于普通模式，2对应于高速模式
Definition: CKDeviceDef.h:693
TRIGGER_HARD_LOW
Definition: CKDeviceDef.h:279
_tSdkImageResolution::iHeight
INT iHeight
相机最终输出的图像的高度，偶数
Definition: CKDeviceDef.h:610
_tDevLoadMode::MirrorHEn
UINT MirrorHEn
水平镜像使能
Definition: CKDeviceDef.h:528
_tIspWb::DGainR
UINT DGainR
Definition: CKDeviceDef.h:472
_tIspAe::bAutoExposure
BOOL bAutoExposure
在支持自动曝光功能的前提下，默认使能
Definition: CKDeviceDef.h:436
_tIspAe::Top
INT Top
设置窗口上
Definition: CKDeviceDef.h:460
_tRgbGainRange::iGGainMin
INT iGGainMin
绿色增益的最小值
Definition: CKDeviceDef.h:706
_tSdkImageResolution::iHOffsetFOV
INT iHOffsetFOV
采集视场相对于Sensor最大视场左上角的水平偏移，偶数
Definition: CKDeviceDef.h:600
_tDevLoadInfo::DevEnumInfo
tDevEnumInfo DevEnumInfo
枚举信息
Definition: CKDeviceDef.h:995
emSdkLutMode
emSdkLutMode
LUT的模式
Definition: CKDeviceDef.h:371
_tDeviceCfg::iMediaTypdeDesc
INT iMediaTypdeDesc
相机输出图像格式的种类个数，即pMediaTypeDesc数组的大小。
Definition: CKDeviceDef.h:839
_tDevLoadMode::Contrast
UINT Contrast
对比度
Definition: CKDeviceDef.h:520
_tSdkPresetLut::acDescription
char acDescription[32]
描述信息
Definition: CKDeviceDef.h:646
_tSdkAeAlgorithm::acDescription
char acDescription[32]
描述信息
Definition: CKDeviceDef.h:655
IMAGEOUT_MODE_1024X768
分辨率512x384
Definition: CKDeviceDef.h:154
CAMERA_DISPLAY_PROC
void(WINAPI * CAMERA_DISPLAY_PROC)(HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
图像显示的回调函数
Definition: CKDeviceDef.h:1007
_tDeviceCfg::pBayerDecAlmSwDesc
tSdkBayerDecodeAlgorithm * pBayerDecAlmSwDesc
软件Bayer转换为RGB数据的算法描述
Definition: CKDeviceDef.h:877
IMAGEOUT_MODE_1920X1280
分辨率512x384
Definition: CKDeviceDef.h:160
_tIspGamma::Gamma
UINT Gamma
gamma值
Definition: CKDeviceDef.h:492
LUT_CHANNEL_RED
Definition: CKDeviceDef.h:365
tDevLoadMode
struct _tDevLoadMode tDevLoadMode
设备加载模式信息
_stImageInfo::iWidth
UINT iWidth
当前图像宽
Definition: CKDeviceDef.h:931
IMAGEOUT_MODE_3664X2748
分辨率512x384
Definition: CKDeviceDef.h:176
FILE_PNG_8BIT
保存为PNG 8BIT文件格式
Definition: CKDeviceDef.h:220
_tIspAe::AnalogGain
UINT AnalogGain
在支持手动曝光功能的前提下设置
Definition: CKDeviceDef.h:440
TRIGGER_HARD_HIGH
Definition: CKDeviceDef.h:278
STROBE_SYNC_WITH_TRIG_MANUAL
和触发信号同步，触发后，STROBE延时指定的时间后(CameraSetStrobeDelayTime)，再持续指定时间的脉冲(Camera...
Definition: CKDeviceDef.h:288
_tSdkIspCapacity::bAutoExposure
BOOL bAutoExposure
表示该型号相机是否支持自动曝光功能
Definition: CKDeviceDef.h:771
_tSdkImageResolution
Definition: CKDeviceDef.h:585
STROBE_ALWAYS_LOW
始终为低，忽略STROBE信号的其他设置
Definition: CKDeviceDef.h:292
tSaturationRange
struct _tSaturationRange tSaturationRange
饱和度设定的范围
_tSdkTrigger::acDescription
char acDescription[32]
该模式的描述信息
Definition: CKDeviceDef.h:581
_tSdkBayerType
相机输出的图像数据格式
Definition: CKDeviceDef.h:679
tDevLoadInfo
struct _tDevLoadInfo tDevLoadInfo
/设备的当前模式和枚举信息
PARAMETER_TEAM_D
Definition: CKDeviceDef.h:257
tSdkIspCapacity
struct _tSdkIspCapacity tSdkIspCapacity
ISP模块的使能信息
_stImageInfo::TotalBytes
UINT TotalBytes
图像数据字节数,Total bytes
Definition: CKDeviceDef.h:935
CAMERA_SNAP_PROC
void(WINAPI * CAMERA_SNAP_PROC)(HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)
图像捕获的回调函数定义
Definition: CKDeviceDef.h:1005
_tSdkAeAlgorithm
AE算法描述
Definition: CKDeviceDef.h:650
PARAM_MODE_BY_SN
根据设备的唯一序列号从文件中加载参数，序列号在出厂时已经写入设备，每台相机拥有不同的序列号。 ...
Definition: CKDeviceDef.h:246
_tSdkIspCapacity::rev
BOOL rev[4]
Definition: CKDeviceDef.h:784
_tGammaContrastRange
伽马对比度的设定范围
Definition: CKDeviceDef.h:743
emSdkDisplayMode
emSdkDisplayMode
SDK内部显示接口的显示方式
Definition: CKDeviceDef.h:319
_tIspWb::Top
INT Top
设置窗口上
Definition: CKDeviceDef.h:478
tSharpnessRange
struct _tSharpnessRange tSharpnessRange
锐化的设定范围
_tRgbGainRange::iGGainMax
INT iGGainMax
绿色增益的最大值
Definition: CKDeviceDef.h:708
_tDevLoadMode::ParameterTeam
UINT ParameterTeam
参数的组别
Definition: CKDeviceDef.h:526
_tSdkImageResolution::iWidthZoomSw
INT iWidthZoomSw
软件缩放的宽度,不需要进行此操作的分辨率，此变量设置为0.偶数,且4字节对齐
Definition: CKDeviceDef.h:616
IMAGEOUT_MODE_800X600
分辨率512x384
Definition: CKDeviceDef.h:152
tGammaContrastRange
struct _tGammaContrastRange tGammaContrastRange
伽马对比度的设定范围
_tIspAe::FrequencySel
UINT FrequencySel
频闪模式
Definition: CKDeviceDef.h:456
tExpose
struct _tExpose tExpose
相机曝光功能范围定义
STATISTICS_REFER_WINDOW
参考窗口的统计方式
Definition: CKDeviceDef.h:235
_tExpose::uiTargetMin
UINT uiTargetMin
自动曝光亮度目标最小值
Definition: CKDeviceDef.h:541
_stImageInfo
帧头信息
Definition: CKDeviceDef.h:928
_tIspWb::Left
INT Left
设置窗口左
Definition: CKDeviceDef.h:476
_tIspAe::iMinAnalogGain
INT iMinAnalogGain
自动模式下的最小模拟增益
Definition: CKDeviceDef.h:450
_tDevLoadMode::MediaTypeMode
UINT MediaTypeMode
输出格式
Definition: CKDeviceDef.h:512
_tResolutionRange::uBinAverageModeMask
UINT uBinAverageModeMask
BIN(求均值)模式掩码，为0，表示不支持BIN 。bit0为1,表示支持BIN 2x2 ;bit1为1，表示支持BIN 3x3...
Definition: CKDeviceDef.h:570
_tDevInfo::SensorID
DWORD SensorID
Sensor ID.
Definition: CKDeviceDef.h:924
_tSdkAeAlgorithm::iIndex
INT iIndex
编号
Definition: CKDeviceDef.h:653
_tDeviceCfg::pClrTempDesc
tSdkColorTemperatureDes * pClrTempDesc
预设色温模式，用于白平衡
Definition: CKDeviceDef.h:828
TRIGGER_HARD_RISE
Definition: CKDeviceDef.h:276
_tIspAe::Height
INT Height
设置窗口高度
Definition: CKDeviceDef.h:464
_tDevInfo::acFriendlyName
char acFriendlyName[32]
产品昵称，用户可自定义改昵称，保存在相机内，用于区分多个相机同时使用,可以用CameraSetFriendlyName接口�...
Definition: CKDeviceDef.h:896
emStrobeControl
emStrobeControl
闪光灯信号控制方式
Definition: CKDeviceDef.h:283
_tSensorCfg::sMaxResolution
tSdkImageResolution sMaxResolution
最大分辨率
Definition: CKDeviceDef.h:795
PstImageInfo
struct _stImageInfo * PstImageInfo
_tSdkImageResolution::uResampleMask
UINT uResampleMask
硬件重采样的掩码
Definition: CKDeviceDef.h:598
_tDevInfo::uInstance
UINT uInstance
该型号相机在该电脑上的实例索引号，用于区分同型号多相机
Definition: CKDeviceDef.h:908
_tDevInfo::DeviceDrvID
WORD DeviceDrvID
设备驱动ID
Definition: CKDeviceDef.h:914
PARAMETER_TEAM_DEFAULT
Definition: CKDeviceDef.h:258
_tDevInfo::DeviceID
DWORD DeviceID
设备ID
Definition: CKDeviceDef.h:918
_tExpose::uiExposeTimeMin
UINT uiExposeTimeMin
手动模式下，曝光时间的最小值，单位:行。根据CameraGetExposureLineTime可以获得一行对应的时间(微秒),从而得到整帧的曝光时间
Definition: CKDeviceDef.h:549
_tDeviceCfg::bParamInDevice
BOOL bParamInDevice
指示该设备是否支持从设备中读写参数组。1为支持，0不支持。
Definition: CKDeviceDef.h:864
PARAM_MODE_BY_NAME
根据设备昵称(tDevInfo.acFriendlyName)从文件中加载参数，例如CK-U2B300,该昵称可自定义 ...
Definition: CKDeviceDef.h:244
_tIspAe::fMaxExposureTime
double fMaxExposureTime
自动模式下的最大曝光时间，us
Definition: CKDeviceDef.h:448
FILE_BMP_8BIT
保存为BMP 8BIT文件格式
Definition: CKDeviceDef.h:218
IMAGEOUT_MODE_640X480
分辨率512x384
Definition: CKDeviceDef.h:150
_tDeviceCfg::sSaturationRange
tSaturationRange sSaturationRange
饱和度范围描述
Definition: CKDeviceDef.h:805
FILE_PNG
保存为PNG 24BIT文件格式
Definition: CKDeviceDef.h:216
FrameStatistic
struct _FrameStatistic FrameStatistic
帧率统计信息
MIRROR_MODE_H
水平镜像
Definition: CKDeviceDef.h:313
_tContrastRange
对比度的设定范围
Definition: CKDeviceDef.h:753
tSdkTrigger
struct _tSdkTrigger tSdkTrigger
触发模式描述
_tDevEnumInfo::bDevOpen
BOOL bDevOpen
当前设备是否打开 0:设备没有打开;1:设备已经打开
Definition: CKDeviceDef.h:988
_FrameStatistic::iCapture
DWORD iCapture
当前采集的有效帧的数量
Definition: CKDeviceDef.h:952
_tDevLoadMode
设备加载模式信息
Definition: CKDeviceDef.h:501


CKCameraAPI: 成员列表

_DisplayWindow 成员列表

成员的完整列表，这些成员属于 _DisplayWindow,包括所有继承而来的类成员

ImageHeight | _DisplayWindow
ImageRect | _DisplayWindow
ImageWidth | _DisplayWindow
WinRect | _DisplayWindow


CKCameraAPI: 成员列表

_FrameStatistic 成员列表

成员的完整列表，这些成员属于 _FrameStatistic,包括所有继承而来的类成员

iCapture | _FrameStatistic
iLost | _FrameStatistic
iTotal | _FrameStatistic


CKCameraAPI: 成员列表

_stImageInfo 成员列表

成员的完整列表，这些成员属于 _stImageInfo,包括所有继承而来的类成员

ExpLineTime | _stImageInfo
ExpTime | _stImageInfo
Gain | _stImageInfo
iHeight | _stImageInfo
iWidth | _stImageInfo
TotalBytes | _stImageInfo
uiMediaType | _stImageInfo


CKCameraAPI: 成员列表

_tContrastRange 成员列表

成员的完整列表，这些成员属于 _tContrastRange,包括所有继承而来的类成员

iMax | _tContrastRange
iMin | _tContrastRange


CKCameraAPI: 成员列表

_tDevEnumInfo 成员列表

成员的完整列表，这些成员属于 _tDevEnumInfo,包括所有继承而来的类成员

bDevOpen | _tDevEnumInfo
DevAttribute | _tDevEnumInfo


CKCameraAPI: 成员列表

_tDevInfo 成员列表

成员的完整列表，这些成员属于 _tDevInfo,包括所有继承而来的类成员

acDriverName | _tDevInfo
acDriverVersion | _tDevInfo
acFriendlyName | _tDevInfo
acLinkName | _tDevInfo
acPortType | _tDevInfo
acProductName | _tDevInfo
acProductSeries | _tDevInfo
acSensorType | _tDevInfo
acSn | _tDevInfo
DeviceDrvID | _tDevInfo
DeviceDrvVersionID | _tDevInfo
DeviceID | _tDevInfo
Name | _tDevInfo
SensorID | _tDevInfo
SymbolicName | _tDevInfo
uInstance | _tDevInfo
VendorID | _tDevInfo


CKCameraAPI: 成员列表

_tDevLoadInfo 成员列表

成员的完整列表，这些成员属于 _tDevLoadInfo,包括所有继承而来的类成员

DevEnumInfo | _tDevLoadInfo
DevLoadMode | _tDevLoadInfo


CKCameraAPI: 成员列表

_tDevLoadMode 成员列表

成员的完整列表，这些成员属于 _tDevLoadMode,包括所有继承而来的类成员

BlackLevel | _tDevLoadMode
ColorToGrayEn | _tDevLoadMode
Contrast | _tDevLoadMode
FrameSpeedMode | _tDevLoadMode
MediaTypeMode | _tDevLoadMode
MirrorHEn | _tDevLoadMode
MirrorVEn | _tDevLoadMode
ParameterMode | _tDevLoadMode
ParameterTeam | _tDevLoadMode
ResolutionMode | _tDevLoadMode
Saturation | _tDevLoadMode
Sharpness | _tDevLoadMode
sIspAe | _tDevLoadMode
sIspGamma | _tDevLoadMode
sIspWb | _tDevLoadMode
TriggerMode | _tDevLoadMode


CKCameraAPI: 成员列表

_tDeviceCfg 成员列表

成员的完整列表，这些成员属于 _tDeviceCfg,包括所有继承而来的类成员

bParamInDevice | _tDeviceCfg
iAeAlmHdDesc | _tDeviceCfg
iAeAlmSwDesc | _tDeviceCfg
iBayerDecAlmHdDesc | _tDeviceCfg
iBayerDecAlmSwDesc | _tDeviceCfg
iBayerTypdeDesc | _tDeviceCfg
iClrTempDesc | _tDeviceCfg
iFrameSpeedDesc | _tDeviceCfg
iImageSizeDesc | _tDeviceCfg
iInputIoCounts | _tDeviceCfg
iMediaTypdeDesc | _tDeviceCfg
iOutputIoCounts | _tDeviceCfg
iPackLenDesc | _tDeviceCfg
iPresetLut | _tDeviceCfg
iTriggerDesc | _tDeviceCfg
iUserDataMaxLen | _tDeviceCfg
pAeAlmHdDesc | _tDeviceCfg
pAeAlmSwDesc | _tDeviceCfg
pBayerDecAlmHdDesc | _tDeviceCfg
pBayerDecAlmSwDesc | _tDeviceCfg
pBayerTypeDesc | _tDeviceCfg
pClrTempDesc | _tDeviceCfg
pFrameSpeedDesc | _tDeviceCfg
pImageSizeDesc | _tDeviceCfg
pMediaTypeDesc | _tDeviceCfg
pPackLenDesc | _tDeviceCfg
pPresetLutDesc | _tDeviceCfg
pTriggerDesc | _tDeviceCfg
sContrastRange | _tDeviceCfg
sGammaContrastRange | _tDeviceCfg
sGammaRange | _tDeviceCfg
sIspCapacity | _tDeviceCfg
sRgbGainRange | _tDeviceCfg
sSaturationRange | _tDeviceCfg
sSharpnessRange | _tDeviceCfg


CKCameraAPI: 成员列表

_tExpose 成员列表

成员的完整列表，这些成员属于 _tExpose,包括所有继承而来的类成员

uiAnalogGainMax | _tExpose
uiAnalogGainMin | _tExpose
uiExposeTimeMax | _tExpose
uiExposeTimeMin | _tExpose
uiTargetMax | _tExpose
uiTargetMin | _tExpose


CKCameraAPI: 成员列表

_tGammaContrastRange 成员列表

成员的完整列表，这些成员属于 _tGammaContrastRange,包括所有继承而来的类成员

iMax | _tGammaContrastRange
iMin | _tGammaContrastRange


CKCameraAPI: 成员列表

_tGammaRange 成员列表

成员的完整列表，这些成员属于 _tGammaRange,包括所有继承而来的类成员

iMax | _tGammaRange
iMin | _tGammaRange


CKCameraAPI: 成员列表

_tIspAe 成员列表

成员的完整列表，这些成员属于 _tIspAe,包括所有继承而来的类成员

AeMode | _tIspAe
AeTarget | _tIspAe
AnalogGain | _tIspAe
bAntiFlick | _tIspAe
bAutoExposure | _tIspAe
ExposureTime | _tIspAe
fMaxExposureTime | _tIspAe
fMinExposureTime | _tIspAe
FrequencySel | _tIspAe
Height | _tIspAe
iMaxAnalogGain | _tIspAe
iMinAnalogGain | _tIspAe
Left | _tIspAe
Top | _tIspAe
Width | _tIspAe


CKCameraAPI: 成员列表

_tIspGamma 成员列表

成员的完整列表，这些成员属于 _tIspGamma,包括所有继承而来的类成员

Gamma | _tIspGamma
GammaContrast | _tIspGamma
Mode | _tIspGamma
PresetSel | _tIspGamma
rev | _tIspGamma


CKCameraAPI: 成员列表

_tIspWb 成员列表

成员的完整列表，这些成员属于 _tIspWb,包括所有继承而来的类成员

bAutoWb | _tIspWb
CCM | _tIspWb
DGainB | _tIspWb
DGainG | _tIspWb
DGainR | _tIspWb
Height | _tIspWb
Left | _tIspWb
Top | _tIspWb
Width | _tIspWb


CKCameraAPI: 成员列表

_tResolutionRange 成员列表

成员的完整列表，这些成员属于 _tResolutionRange,包括所有继承而来的类成员

iHeightMax | _tResolutionRange
iHeightMin | _tResolutionRange
iWidthMax | _tResolutionRange
iWidthMin | _tResolutionRange
uBinAverageModeMask | _tResolutionRange
uBinSumModeMask | _tResolutionRange
uResampleMask | _tResolutionRange
uSkipModeMask | _tResolutionRange


CKCameraAPI: 成员列表

_tRgbGainRange 成员列表

成员的完整列表，这些成员属于 _tRgbGainRange,包括所有继承而来的类成员

iBGainMax | _tRgbGainRange
iBGainMin | _tRgbGainRange
iGGainMax | _tRgbGainRange
iGGainMin | _tRgbGainRange
iRGainMax | _tRgbGainRange
iRGainMin | _tRgbGainRange


CKCameraAPI: 成员列表

_tSaturationRange 成员列表

成员的完整列表，这些成员属于 _tSaturationRange,包括所有继承而来的类成员

iMax | _tSaturationRange
iMin | _tSaturationRange


CKCameraAPI: 成员列表

_tSdkAeAlgorithm 成员列表

成员的完整列表，这些成员属于 _tSdkAeAlgorithm,包括所有继承而来的类成员

acDescription | _tSdkAeAlgorithm
iIndex | _tSdkAeAlgorithm


CKCameraAPI: 成员列表

_tSdkBayerDecodeAlgorithm 成员列表

成员的完整列表，这些成员属于 _tSdkBayerDecodeAlgorithm,包括所有继承而来的类成员

acDescription | _tSdkBayerDecodeAlgorithm
iIndex | _tSdkBayerDecodeAlgorithm


CKCameraAPI: 成员列表

_tSdkBayerType 成员列表

成员的完整列表，这些成员属于 _tSdkBayerType,包括所有继承而来的类成员

acDescription | _tSdkBayerType
iIndex | _tSdkBayerType
iMediaType | _tSdkBayerType


CKCameraAPI: 成员列表

_tSdkCameraCapbility 成员列表

成员的完整列表，这些成员属于 _tSdkCameraCapbility,包括所有继承而来的类成员

tDeviceCapbility | _tSdkCameraCapbility
tSensorCapbility | _tSdkCameraCapbility


CKCameraAPI: 成员列表

_tSdkColorTemperatureDes 成员列表

成员的完整列表，这些成员属于 _tSdkColorTemperatureDes,包括所有继承而来的类成员

acDescription | _tSdkColorTemperatureDes
iIndex | _tSdkColorTemperatureDes


CKCameraAPI: 成员列表

_tSdkFrameSpeed 成员列表

成员的完整列表，这些成员属于 _tSdkFrameSpeed,包括所有继承而来的类成员

acDescription | _tSdkFrameSpeed
iIndex | _tSdkFrameSpeed


CKCameraAPI: 成员列表

_tSdkImageResolution 成员列表

成员的完整列表，这些成员属于 _tSdkImageResolution,包括所有继承而来的类成员

acDescription | _tSdkImageResolution
iHeight | _tSdkImageResolution
iHeightFOV | _tSdkImageResolution
iHeightZoomHd | _tSdkImageResolution
iHeightZoomSw | _tSdkImageResolution
iHOffsetFOV | _tSdkImageResolution
iIndex | _tSdkImageResolution
iVOffsetFOV | _tSdkImageResolution
iWidth | _tSdkImageResolution
iWidthFOV | _tSdkImageResolution
iWidthZoomHd | _tSdkImageResolution
iWidthZoomSw | _tSdkImageResolution
uBinAverageMode | _tSdkImageResolution
uBinSumMode | _tSdkImageResolution
uResampleMask | _tSdkImageResolution
uSkipMode | _tSdkImageResolution


CKCameraAPI: 成员列表

_tSdkIspCapacity 成员列表

成员的完整列表，这些成员属于 _tSdkIspCapacity,包括所有继承而来的类成员

bAntiFlick | _tSdkIspCapacity
bAutoExposure | _tSdkIspCapacity
bAutoWb | _tSdkIspCapacity
bDeviceIsp | _tSdkIspCapacity
bForceUseDeviceIsp | _tSdkIspCapacity
bIspGamma | _tSdkIspCapacity
bManualExposure | _tSdkIspCapacity
bMonoSensor | _tSdkIspCapacity
bWbOnce | _tSdkIspCapacity
bZoomHD | _tSdkIspCapacity
rev | _tSdkIspCapacity


CKCameraAPI: 成员列表

_tSdkMediaType 成员列表

成员的完整列表，这些成员属于 _tSdkMediaType,包括所有继承而来的类成员

acDescription | _tSdkMediaType
iIndex | _tSdkMediaType
iMediaType | _tSdkMediaType


CKCameraAPI: 成员列表

_tSdkPackLength 成员列表

成员的完整列表，这些成员属于 _tSdkPackLength,包括所有继承而来的类成员

acDescription | _tSdkPackLength
iIndex | _tSdkPackLength
iPackSize | _tSdkPackLength


CKCameraAPI: 成员列表

_tSdkPresetLut 成员列表

成员的完整列表，这些成员属于 _tSdkPresetLut,包括所有继承而来的类成员

acDescription | _tSdkPresetLut
iIndex | _tSdkPresetLut


CKCameraAPI: 成员列表

_tSdkTrigger 成员列表

成员的完整列表，这些成员属于 _tSdkTrigger,包括所有继承而来的类成员

acDescription | _tSdkTrigger
iIndex | _tSdkTrigger


CKCameraAPI: 成员列表

_tSensorCfg 成员列表

成员的完整列表，这些成员属于 _tSensorCfg,包括所有继承而来的类成员

sExposeDesc | _tSensorCfg
sMaxResolution | _tSensorCfg
sResolutionRange | _tSensorCfg


CKCameraAPI: 成员列表

_tSharpnessRange 成员列表

成员的完整列表，这些成员属于 _tSharpnessRange,包括所有继承而来的类成员

iMax | _tSharpnessRange
iMin | _tSharpnessRange