CKCameraAPI: SDK Development Manual

CKCameraAPI v2.14
CKSDK API Document
SDK Development Manual

Document Release History

4/7/2017(V1.0)

  • Release the first version

4/8/2017(V2.0)

  • Add CameraSetDisplayMode to set the display mode function
  • Add CameraSetCrossLine to set the crosshair function
  • Add CameraImageOverlay image overlay function
  • Add CameraSetDisplayCallbackFun to display the callback function
  • Add CameraSetResolutionEx to set custom resolution function
  • Add CameraSetBlackLevel to set the black level function
  • Add CameraGetImageBufferEx to get the image format data directly

    15/10/2018(V2.1)

  • Add trigger function

10/12/2018(V2.2)

  • Add IO control function

2019-8-1 (V2.4)

  • Add CameraSetSensorOutPixelFormat
    + Add CameraGetSensorOutPixelFormat
  • Add CameraGetImageBufferEx2
  • Add CameraGetImageTimestamp
  • Add CameraResetTimestamp

2019-8-10 (V2.5)

  • Add CameraGigeGetIp
  • Add CameraGigeSetIp
  • Add CameraGigeGetTransPacketSize
  • Add CameraGigeSetTransPacketSize

2020-7-2 (V2.6)

  • Add CameraGigeSetTransPacketSize can set the range 1500-9000

2020-8-6 (V2.7)

  • Add CameraSetCorrectDeadPixel
  • Add CameraGetCorrectDeadPixel

2020-8-13 (V2.8)

  • Add CameraStartRecord
  • Add CameraPushOneFrame
  • Add CameraStopRecord

2020-8-15 (V2.9)

  • Add CameraUpgrade

2020-9-15 (V2.10)

  • Add CameraGigeGetPacketDelayTime
  • Add CameraGigeSetPacketDelayTime

2020-12-30 (V2.11)

  • Add CameraSetIntValue
  • Add CameraGetIntValue

2022-8-15 (V2.12)

  • Add CameraReboot
  • Add CameraLscCalib
  • Add CameraLscCorrect

Overview

file structure

In the secondary development, the library file that needs to be directly used is located in the SDK file of the installation directory. The folder is divided into 32-bit and 64-bit development kits. 64-bit SDK development pieces, located in the SDK/X64 folder, compared to 32-bit SDK files, 64-bit SDK File names end with _X64. CKCameraDLL.DLL in the SDK directory is the camera's SDK dynamic link library, provided externally All library interface functions, VC/C++ routines reference the library file.

development environment

SDK is a standard C language interface dynamic link library, we provide based on VC2015/C++ Builder 5/C++ Builder 6/ Demo such as Delphi/labview/QT5/VB6/VB.Net

Quick Development Guide

Overview of camera operation process

We recommend that you follow the process below to operate the camera (some of the steps are optional, already marked):

  1. load the SDK's dynamic link library file CKCameraDLL.DLL. You can use dynamic or static State loading is two ways. If you use C/C++ for development, in engineering references CKCameraInterface.h header file (located in the SDK/include of the installation directory), Then you can directly reference the interface function in the SDK in the project, but CKCameraDLL.DLL Must be in the same directory as your application or the system32 directory of your system Under, when placed in another directory, you must set the system's environment variable (PATH).
  2. enumerate equipment. Call the CameraEnumerateDevice function to enumerate the device and get The total number of cameras currently connected to the PC, call CameraGetEnumIndexInfo The function obtains the current label including the device name nickname (can be modified by itself), version number, unique sequence No., camera model and other information.
  3. initialize the device. Called according to the camera device enumeration information obtained in the second step The CameraInit function initializes the set camera and gets the handle of the camera. If you need the same When multiple cameras are turned on, CameraInit is called multiple times with the device name of multiple cameras. Get the handle of multiple cameras, follow-up camera operations, you need the camera sentence obtained at this time Handle to specify the camera object for the operation.
  4. let the SDK enter the image acquisition mode. Call the CameraPlay function and let the camera enter In the working mode, the SDK starts receiving images from the camera.
  5. grab the image. The SDK provides two ways to get image data. The efficiency is the same, the bottom layer uses a zero copy mechanism to improve efficiency, you can root Choose one of them according to your development habits.
  • 1. Actively call CameraGetRawImageBuffer to get a frame of image handle. with , this function can set the timeout period, and no image is obtained within the specified time (line The program will be suspended), then return to timeout. Call CameraGetImageInfo with this handle This function will get the address of a buffer used by the part of the SDK to receive image data. and frame header information.
  • 2. In the third step, after initializing the camera, call CameraSetCallbackFunction to specify a callback function. This way is passive , the specified image data will be called after receiving a valid image data frame inside the SDK. Tuning function to pass the received image data frame.
  1. processing images. The image frame obtained in the previous step is the original format of the camera output. Most models of the camera, the original output is Bayer format or YUV format, these Format information will be automatically added to the frame header information, called CameraGetOutImageBuffer to get the effect of image processing, such as color gain adjustment, White balance correction, saturation, etc., and convert raw data from YUV or Bayer format Bitmap format of 24BIT or 32BIT.
  2. save the image or display the image (if you are in development, do not need to save the image To file or display, this step can be skipped). If you need to save the image to a file, after the sixth step, call CameraSaveImage function to save images, SDK supports BMP and raw data the way. If you want to save the original data, you should call it after step 5 CameraSaveImage function; if saved in BMP format, you should be after step 6 Call CameraSaveImage If you need to display an image, there are two ways:
  • 1. Realize image display according to the development environment, for example, using OpenGL, DirectDraw, WindowsGDI, etc. to achieve image display.
  • 2. Use the packaged display interface in our SDK to display images. In the fourth step After initializing the camera, call the CameraDisplayInit function to initialize the display interface. This function needs to pass in the handle of the display control (HWND type).
  1. Turn off the camera before exiting the program. Call the CameraUnInit function when the camera is turned off Number.

development routine

Routine to get image data actively

CameraSdkStatus CameraStartDisplay()
{
CameraSdkStatus ret;
// Step 1: Enumeration
if((ret = CameraEnumerateDevice(&mCameraNums)) != CAMERA_STATUS_SUCCESS || mCameraNums <= 0)
return ret;
//Step 2: Initialize the camera
if((ret = CameraInitEx(&mCKCamHandle, mCameraNums - 1, -1, -1)) != CAMERA_STATUS_SUCCESS)
return ret;
//Step 3: The SDK internal display initialization (this step can be omitted if the user does not need the SDK to provide display function internally)
if((ret = CameraDisplayInit(mCKCamHandle, hwnd)) != CAMERA_STATUS_SUCCESS)
{
CameraUnInit(mCKCamHandle);
return ret;
}
//Step 4: Acquire image data in an active way
m_bExit = FALSE;
m_hDispThread = (HANDLE)_beginthreadex(NULL, 0, &uiDisplayThread, this, 0, &m_threadID);
ASSERT(m_hDispThread);
return ret;
}
UINT uiDisplayThread()
{
BYTE* pbyBuffer;
stImageInfo ImageInfo;
int status = CAMERA_STATUS_SUCCESS;
FrameStatistic fstatistic;
CameraPlay(mCKCamHandle);
while(!m_bExit)
{
HANDLE hBuf;
// Get RAW data
Status = CameraGetRawImageBuffer(mCKCamHandle, &hBuf, 1000);
if(status == CAMERA_STATUS_SUCCESS)
{
// Get the image buffer address
pbyBuffer = CameraGetImageInfo(mCKCamHandle, hBuf, &ImageInfo);
// Get ISP processed RGB data
if(pRGBFrame == NULL || dRGBBufLen < (ImageInfo.iWidth*
ImageInfo.iHeight * 4))
{
if(pRGBFrame) delete pRGBFrame;
dRGBBufLen = (ImageInfo.iWidth*ImageInfo.iHeight * 4);
pRGBFrame = new BYTE[dRGBBufLen];
}
CameraGetOutImageBuffer(mCKCamHandle, &ImageInfo, pbyBuffer, pRGBFrame);
m_iDispFrameNum++;
memcpy(&m_sFrInfo, &ImageInfo, sizeof(stImageInfo));
CameraDisplay(mCKCamHandle, pRGBFrame, &ImageInfo);
// Release the buffer obtained by CameraGetRawImageBuffer
CameraReleaseFrameHandle(mCKCamHandle, hBuf);
}
}
CameraPause(mCKCamHandle);
_endthreadex(0);
return 0;
}

Routine for passively acquiring image data

void CameraStartDisplay()
{
CameraSdkStatus ret;
// Step 1: Enumeration
if((ret = CameraEnumerateDevice(&mCameraNums)) != CAMERA_STATUS_SUCCESS || mCameraNums <= 0)
return ret;
//Step 2: Initialize the camera
if((ret = CameraInitEx(&mCKCamHandle, mCameraNums - 1, -1, -1)) != CAMERA_STATUS_SUCCESS)
return ret;
//Step 3: The SDK internal display initialization (this step can be omitted if the user does not need the SDK to provide display function internally)
if((ret = CameraDisplayInit(mCKCamHandle, hwnd)) != CAMERA_STATUS_SUCCESS)
{
CameraUnInit(mCKCamHandle);
return ret;
}
Ret = CameraSetCallbackFunction(mCKCamHandle, GrabImageCallback, (PVOID)this, NULL);
Ret = CameraPlay(mCKCamHandle);
return ret;
}
void GrabImageCallback(HANDLE handle, BYTE *pFrameBuffer, stImageInfo* pFrameInfo)
{
stImageInfo ImageInfo;
Memcpy(&ImageInfo, pFrameInfo, sizeof(stImageInfo));
if(pRGBFrame == NULL || dRGBBufLen < (ImageInfo.iWidth*ImageInfo.iHeight * 4))
{
if(pRGBFrame) delete pRGBFrame;
dRGBBufLen = (ImageInfo.iWidth*ImageInfo.iHeight * 4);
pRGBFrame = new BYTE[dRGBBufLen];
}
CameraGetOutImageBuffer(mCKCamHandle, &ImageInfo, pFrameBuffer, pRGBFrame);
m_iDispFrameNum++;
Memcpy(&m_sFrInfo, &ImageInfo, sizeof(stImageInfo));
CameraDisplay(mCKCamHandle, pRGBFrame, &ImageInfo);
}

Drawing graphics in images

void CameraStartDisplay()
{
CameraSdkStatus ret;
// Step 1: Enumeration
if((ret = CameraEnumerateDevice(&mCameraNums)) != CAMERA_STATUS_SUCCESS || mCameraNums <= 0)
return ret;
//Step 2: Initialize the camera
if((ret = CameraInitEx(&mCKCamHandle, mCameraNums - 1, -1, -1)) != CAMERA_STATUS_SUCCESS)
return ret;
//Step 3: The SDK internal display initialization (this step can be omitted if the user does not need the SDK to provide display function internally)
if((ret = CameraDisplayInit(mCKCamHandle, hwnd)) != CAMERA_STATUS_SUCCESS)
{
CameraUnInit(mCKCamHandle);
return ret;
}
//Step 4: Get image data in a passive way, set the callback function
Ret = CameraSetCallbackFunction(mCKCamHandle, GrabImageCallback, (PVOID)this, NULL);
//Step 5: Set the paint callback function
Ret = CameraSetDisplayCallbackFun(mCKCamHandle, DrawGraphCallback, (LPVOID)this, NULL);
//Step 6: The camera enters the running state
Ret = CameraPlay(mCKCamHandle);
return ret;
}
void GrabImageCallback(HANDLE handle, BYTE *pFrameBuffer, stImageInfo* pFrameInfo)
{
stImageInfo ImageInfo;
Memcpy(&ImageInfo, pFrameInfo, sizeof(stImageInfo));
if(pRGBFrame == NULL || dRGBBufLen < (ImageInfo.iWidth*ImageInfo.iHeight * 4))
{
if(pRGBFrame)
Delete pRGBFrame;
dRGBBufLen = (ImageInfo.iWidth*ImageInfo.iHeight * 4);
pRGBFrame = new BYTE[dRGBBufLen];
}
CameraGetOutImageBuffer(mCKCamHandle, &ImageInfo, pFrameBuffer, pRGBFrame);
m_iDispFrameNum++;
memcpy(&m_sFrInfo, &ImageInfo, sizeof(stImageInfo));
CameraDisplay(mCKCamHandle, pRGBFrame, &ImageInfo);
}
void DrawGraphCallback(HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
{
int width = pDisplayWindow->WinRect.right - pDisplayWindow->WinRect.left;
int height = pDisplayWindow->WinRect.bottom - pDisplayWindow->WinRect.top;
::MoveToEx(hdc, 0, 500, NULL);
::LineTo(hdc, pDisplayWindow->ImageWidth, 500);
::MoveToEx(hdc, 500, 0, NULL);
::LineTo(hdc, 500, pDisplayWindow->ImageHeight);
}
Generated by doxygen 1.8.14


CKCameraAPI: Modules

Modules
Here is a list of all modules:
[detail level 12]
Error code
Enumeration
Image format definition
▼ SDK interface function
Get a list of camera devices
Open or Close camera
Device information
Get image data
Camera play and pause
Display preview image
Exposure and gain settings
White balance settings
GAMMA settings
Image process
Trigger Settings
Saving and loading camera parameters
User data
Version information
Set property page
Save Image
Mirror and rotate
IO settings
Advanced settings
ROI settings
GigE settings
Record settings


CKCameraAPI: Error code

Error code
#define | CAMERA_STATUS_SUCCESS 0
 | Operation succeeded. More...
#define | CAMERA_STATUS_FAILED -1
 | Operation failed. More...
#define | CAMERA_STATUS_INTERNAL_ERROR -2
 | Internal error. More...
#define | CAMERA_STATUS_UNKNOW -3
 | Unknown error. More...
#define | CAMERA_STATUS_NOT_SUPPORTED -4
 | Don't support this feature. More...
#define | CAMERA_STATUS_NOT_INITIALIZED -5
 | Initialization not completed. More...
#define | CAMERA_STATUS_PARAMETER_INVALID -6
 | Parameter is invalid. More...
#define | CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7
 | Parameter out of bounds. More...
#define | CAMERA_STATUS_UNENABLED -8
 | It is not enabled. More...
#define | CAMERA_STATUS_USER_CANCEL -9
 | The user canceled manually, such as the roi panel click cancel, return. More...
#define | CAMERA_STATUS_PATH_NOT_FOUND -10
 | The corresponding path was not found in the registry. More...
#define | CAMERA_STATUS_SIZE_DISMATCH -11
 | Get image data length and defined size does not match. More...
#define | CAMERA_STATUS_TIME_OUT -12
 | Timeout error. More...
#define | CAMERA_STATUS_IO_ERROR -13
 | Hardware IO error. More...
#define | CAMERA_STATUS_COMM_ERROR -14
 | Communication error. More...
#define | CAMERA_STATUS_BUS_ERROR -15
 | Bus error. More...
#define | CAMERA_STATUS_NO_DEVICE_FOUND -16
 | No devices found. More...
#define | CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17
 | No logical device found. More...
#define | CAMERA_STATUS_DEVICE_IS_OPENED -18
 | Device is already open. More...
#define | CAMERA_STATUS_DEVICE_IS_CLOSED -19
 | Device is turned off. More...
#define | CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20
 | When the device video is not turned on, when the video related function is called, if the camera video is not turned on, the error is returned. More...
#define | CAMERA_STATUS_NO_MEMORY -21
 | Not enough system memory. More...
#define | CAMERA_STATUS_FILE_CREATE_FAILED -22
 | Failed to create file. More...
#define | CAMERA_STATUS_FILE_INVALID -23
 | File format is invalid. More...
#define | CAMERA_STATUS_WRITE_PROTECTED -24
 | Write protection, not writeable. More...
#define | CAMERA_STATUS_GRAB_FAILED -25
 | Data collection failed. More...
#define | CAMERA_STATUS_LOST_DATA -26
 | Data is missing, incomplete. More...
#define | CAMERA_STATUS_EOF_ERROR -27
 | Frame end not received. More...
#define | CAMERA_STATUS_BUSY -28
 | Is busy (the last operation is still in progress), this operation cannot be done. More...
#define | CAMERA_STATUS_WAIT -29
 | Needs to wait (the conditions for the operation are not met), you can try again. More...
#define | CAMERA_STATUS_IN_PROCESS -30
 | Is in progress and has been manipulated. More...
#define | CAMERA_STATUS_IIC_ERROR -31
 | IIC transmission error. More...
#define | CAMERA_STATUS_SPI_ERROR -32
 | SPI transmission error. More...
#define | CAMERA_STATUS_USB_CONTROL_ERROR -33
 | USB control transfer error. More...
#define | CAMERA_STATUS_USB_BULK_ERROR -34
 | USB BULK transmission error. More...
#define | CAMERA_STATUS_SOCKET_INIT_ERROR -35
 | Network Transfer Kit initialization failed. More...
#define | CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36
 | The network camera kernel filter driver failed to initialize. Please check if the driver is properly installed or reinstall. More...
#define | CAMERA_STATUS_NET_SEND_ERROR -37
 | Network data sending error. More...
#define | CAMERA_STATUS_DEVICE_LOST -38
 | Lost connection with web camera, heartbeat detection timed out. More...
#define | CAMERA_STATUS_DATA_RECV_LESS -39
 | Received fewer bytes than requested. More...
#define | CAMERA_STATUS_FUNCTION_LOAD_FAILED -40
 | Failed to load program from file. More...
#define | CAMERA_STATUS_CRITICAL_FILE_LOST -41
 | The files necessary for the program to run are missing. More...
#define | CAMERA_STATUS_SENSOR_ID_DISMATCH -42
 | The firmware and program do not match because the wrong firmware was downloaded. More...
#define | CAMERA_STATUS_OUT_OF_RANGE -43
 | The parameter is outside the valid range. More...
#define | CAMERA_STATUS_REGISTRY_ERROR -44
 | Installer registration error. Please reinstall the program. More...
#define | CAMERA_STATUS_ACCESS_DENY -45
 | No access. When the specified camera is already occupied by another program, it will return to this state after requesting access to the camera. (A camera cannot be accessed simultaneously by multiple programs) More...
#define | CAMERA_STATUS_CAMERA_NEED_RESET -46
 | Means that the camera needs to be reset before it can be used normally. In this case, please let the camera power off and restart, or restart the operating system, then it can be used normally. More...
#define | CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47
 | ISP module is not initialized. More...
#define | CAMERA_STATUS_ISP_DATA_CRC_ERROR -48
 | Data validation error. More...
#define | CAMERA_STATUS_MV_TEST_FAILED -49
 | Data test failed. More...
#define | CAMERA_STATUS_WAIT_TRIGGER -50
 | Waiting for trigger frame. More...
#define | CAMERA_STATUS_EEPROM_UPDATA -51
 | EE data version needs to be updated. More...
#define | CAMERA_STATUS_OPEN_DEVICE_ERROR -52
 | Failed to open device. More...
#define | CAMERA_STATUS_OPEN_STREAM_ERROR -53
 | Failed to open video stream. More...
#define | CAMERA_STATUS_READ_ERROR -54
 | Read error. More...
#define | CAMERA_STATUS_WRITE_ERROR -55
 | Write error. More...
#define | CAMERA_STATUS_NO_OPEN_DEVICE -56
 | No open device. More...
#define | CAMERA_STATUS_UNKNOW_SENSOR -57
 | Sensor not recognized. More...
#define | CAMERA_STATUS_NO_WRITE_EEPROM -58
 | Don't write EE data. More...
#define | CMAERA_STATUS_FPGA_CFG_ERROR -59
 | FPGA configuration failed. More...

Detailed Description

Macro Definition Documentation

◆ CAMERA_STATUS_ACCESS_DENY

#define CAMERA_STATUS_ACCESS_DENY -45

No access. When the specified camera is already occupied by another program, it will return to this state after requesting access to the camera. (A camera cannot be accessed simultaneously by multiple programs)

◆ CAMERA_STATUS_BUS_ERROR

#define CAMERA_STATUS_BUS_ERROR -15

Bus error.

◆ CAMERA_STATUS_BUSY

#define CAMERA_STATUS_BUSY -28

Is busy (the last operation is still in progress), this operation cannot be done.

◆ CAMERA_STATUS_CAMERA_NEED_RESET

#define CAMERA_STATUS_CAMERA_NEED_RESET -46

Means that the camera needs to be reset before it can be used normally. In this case, please let the camera power off and restart, or restart the operating system, then it can be used normally.

◆ CAMERA_STATUS_COMM_ERROR

#define CAMERA_STATUS_COMM_ERROR -14

Communication error.

◆ CAMERA_STATUS_CRITICAL_FILE_LOST

#define CAMERA_STATUS_CRITICAL_FILE_LOST -41

The files necessary for the program to run are missing.

◆ CAMERA_STATUS_DATA_RECV_LESS

#define CAMERA_STATUS_DATA_RECV_LESS -39

Received fewer bytes than requested.

◆ CAMERA_STATUS_DEVICE_IS_CLOSED

#define CAMERA_STATUS_DEVICE_IS_CLOSED -19

Device is turned off.

◆ CAMERA_STATUS_DEVICE_IS_OPENED

#define CAMERA_STATUS_DEVICE_IS_OPENED -18

Device is already open.

◆ CAMERA_STATUS_DEVICE_LOST

#define CAMERA_STATUS_DEVICE_LOST -38

Lost connection with web camera, heartbeat detection timed out.

◆ CAMERA_STATUS_DEVICE_VEDIO_CLOSED

#define CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20

When the device video is not turned on, when the video related function is called, if the camera video is not turned on, the error is returned.

◆ CAMERA_STATUS_EEPROM_UPDATA

#define CAMERA_STATUS_EEPROM_UPDATA -51

EE data version needs to be updated.

◆ CAMERA_STATUS_EOF_ERROR

#define CAMERA_STATUS_EOF_ERROR -27

Frame end not received.

◆ CAMERA_STATUS_FAILED

#define CAMERA_STATUS_FAILED -1

Operation failed.

◆ CAMERA_STATUS_FILE_CREATE_FAILED

#define CAMERA_STATUS_FILE_CREATE_FAILED -22

Failed to create file.

◆ CAMERA_STATUS_FILE_INVALID

#define CAMERA_STATUS_FILE_INVALID -23

File format is invalid.

◆ CAMERA_STATUS_FUNCTION_LOAD_FAILED

#define CAMERA_STATUS_FUNCTION_LOAD_FAILED -40

Failed to load program from file.

◆ CAMERA_STATUS_GIGE_FILTER_INIT_ERROR

#define CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36

The network camera kernel filter driver failed to initialize. Please check if the driver is properly installed or reinstall.

◆ CAMERA_STATUS_GRAB_FAILED

#define CAMERA_STATUS_GRAB_FAILED -25

Data collection failed.

◆ CAMERA_STATUS_IIC_ERROR

#define CAMERA_STATUS_IIC_ERROR -31

IIC transmission error.

◆ CAMERA_STATUS_IN_PROCESS

#define CAMERA_STATUS_IN_PROCESS -30

Is in progress and has been manipulated.

◆ CAMERA_STATUS_INTERNAL_ERROR

#define CAMERA_STATUS_INTERNAL_ERROR -2

Internal error.

◆ CAMERA_STATUS_IO_ERROR

#define CAMERA_STATUS_IO_ERROR -13

Hardware IO error.

◆ CAMERA_STATUS_ISP_DATA_CRC_ERROR

#define CAMERA_STATUS_ISP_DATA_CRC_ERROR -48

Data validation error.

◆ CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED

#define CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47

ISP module is not initialized.

◆ CAMERA_STATUS_LOST_DATA

#define CAMERA_STATUS_LOST_DATA -26

Data is missing, incomplete.

◆ CAMERA_STATUS_MV_TEST_FAILED

#define CAMERA_STATUS_MV_TEST_FAILED -49

Data test failed.

◆ CAMERA_STATUS_NET_SEND_ERROR

#define CAMERA_STATUS_NET_SEND_ERROR -37

Network data sending error.

◆ CAMERA_STATUS_NO_DEVICE_FOUND

#define CAMERA_STATUS_NO_DEVICE_FOUND -16

No devices found.

◆ CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND

#define CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17

No logical device found.

◆ CAMERA_STATUS_NO_MEMORY

#define CAMERA_STATUS_NO_MEMORY -21

Not enough system memory.

◆ CAMERA_STATUS_NO_OPEN_DEVICE

#define CAMERA_STATUS_NO_OPEN_DEVICE -56

No open device.

◆ CAMERA_STATUS_NO_WRITE_EEPROM

#define CAMERA_STATUS_NO_WRITE_EEPROM -58

Don't write EE data.

◆ CAMERA_STATUS_NOT_INITIALIZED

#define CAMERA_STATUS_NOT_INITIALIZED -5

Initialization not completed.

◆ CAMERA_STATUS_NOT_SUPPORTED

#define CAMERA_STATUS_NOT_SUPPORTED -4

Don't support this feature.

◆ CAMERA_STATUS_OPEN_DEVICE_ERROR

#define CAMERA_STATUS_OPEN_DEVICE_ERROR -52

Failed to open device.

◆ CAMERA_STATUS_OPEN_STREAM_ERROR

#define CAMERA_STATUS_OPEN_STREAM_ERROR -53

Failed to open video stream.

◆ CAMERA_STATUS_OUT_OF_RANGE

#define CAMERA_STATUS_OUT_OF_RANGE -43

The parameter is outside the valid range.

◆ CAMERA_STATUS_PARAMETER_INVALID

#define CAMERA_STATUS_PARAMETER_INVALID -6

Parameter is invalid.

◆ CAMERA_STATUS_PARAMETER_OUT_OF_BOUND

#define CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7

Parameter out of bounds.

◆ CAMERA_STATUS_PATH_NOT_FOUND

#define CAMERA_STATUS_PATH_NOT_FOUND -10

The corresponding path was not found in the registry.

◆ CAMERA_STATUS_READ_ERROR

#define CAMERA_STATUS_READ_ERROR -54

Read error.

◆ CAMERA_STATUS_REGISTRY_ERROR

#define CAMERA_STATUS_REGISTRY_ERROR -44

Installer registration error. Please reinstall the program.

◆ CAMERA_STATUS_SENSOR_ID_DISMATCH

#define CAMERA_STATUS_SENSOR_ID_DISMATCH -42

The firmware and program do not match because the wrong firmware was downloaded.

◆ CAMERA_STATUS_SIZE_DISMATCH

#define CAMERA_STATUS_SIZE_DISMATCH -11

Get image data length and defined size does not match.

◆ CAMERA_STATUS_SOCKET_INIT_ERROR

#define CAMERA_STATUS_SOCKET_INIT_ERROR -35

Network Transfer Kit initialization failed.

◆ CAMERA_STATUS_SPI_ERROR

#define CAMERA_STATUS_SPI_ERROR -32

SPI transmission error.

◆ CAMERA_STATUS_SUCCESS

#define CAMERA_STATUS_SUCCESS 0

Operation succeeded.

◆ CAMERA_STATUS_TIME_OUT

#define CAMERA_STATUS_TIME_OUT -12

Timeout error.

◆ CAMERA_STATUS_UNENABLED

#define CAMERA_STATUS_UNENABLED -8

It is not enabled.

◆ CAMERA_STATUS_UNKNOW

#define CAMERA_STATUS_UNKNOW -3

Unknown error.

◆ CAMERA_STATUS_UNKNOW_SENSOR

#define CAMERA_STATUS_UNKNOW_SENSOR -57

Sensor not recognized.

◆ CAMERA_STATUS_USB_BULK_ERROR

#define CAMERA_STATUS_USB_BULK_ERROR -34

USB BULK transmission error.

◆ CAMERA_STATUS_USB_CONTROL_ERROR

#define CAMERA_STATUS_USB_CONTROL_ERROR -33

USB control transfer error.

◆ CAMERA_STATUS_USER_CANCEL

#define CAMERA_STATUS_USER_CANCEL -9

The user canceled manually, such as the roi panel click cancel, return.

◆ CAMERA_STATUS_WAIT

#define CAMERA_STATUS_WAIT -29

Needs to wait (the conditions for the operation are not met), you can try again.

◆ CAMERA_STATUS_WAIT_TRIGGER

#define CAMERA_STATUS_WAIT_TRIGGER -50

Waiting for trigger frame.

◆ CAMERA_STATUS_WRITE_ERROR

#define CAMERA_STATUS_WRITE_ERROR -55

Write error.

◆ CAMERA_STATUS_WRITE_PROTECTED

#define CAMERA_STATUS_WRITE_PROTECTED -24

Write protection, not writeable.

◆ CMAERA_STATUS_FPGA_CFG_ERROR

#define CMAERA_STATUS_FPGA_CFG_ERROR -59

FPGA configuration failed.


CKCameraAPI: Enumeration

Enumeration
enum | emDeviceType { DEVICE_TYPE_UNKNOW = 0, DEVICE_TYPE_USB20 = 0x1201, DEVICE_TYPE_USB30 = 0x1301, DEVICE_TYPE_GIGE = 0x2001 }
device type More...
enum emResolutionMode {
IMAGEOUT_MODE_512X384 = 0, IMAGEOUT_MODE_640X480 = 1, IMAGEOUT_MODE_800X600 = 2, IMAGEOUT_MODE_1024X768 = 3,
IMAGEOUT_MODE_1280X720 = 4, IMAGEOUT_MODE_1280X960 = 5, IMAGEOUT_MODE_1920X1280 = 6, IMAGEOUT_MODE_2048X1536 = 7,
IMAGEOUT_MODE_320X240 = 8, IMAGEOUT_MODE_1280X1024 = 9, IMAGEOUT_MODE_1600X1200 = 10, IMAGEOUT_MODE_2592X1944 = 11,
IMAGEOUT_MODE_752X480 = 12, IMAGEOUT_MODE_768X576 = 13, IMAGEOUT_MODE_3664X2748 = 14, IMAGEOUT_MODE_1920X1080 = 15,
IMAGEOUT_MODE_2304X1296 = 16, IMAGEOUT_MODE_2304X1728 = 17, IMAGEOUT_MODE_4608X3456 = 18, IMAGEOUT_MODE_640X360 = 19,
IMAGEOUT_MODE_3072X2048 = 20, IMAGEOUT_MODE_1920X1200 = 21, IMAGEOUT_MODE_5472X3648 = 22, IMAGEOUT_MODE_2448X2048 = 23,
IMAGEOUT_MODE_4000X3000 = 24, IMAGEOUT_MODE_3008X3008 = 25, IMAGEOUT_MODE_4096X2160 = 26, IMAGEOUT_MODE_2736X1824 = 27,
IMAGEOUT_MODE_4144X2822 = 28, IMAGEOUT_MODE_720X540 = 29, IMAGEOUT_MODE_1440X1080 = 30, IMAGEOUT_MODE_1280X800 = 31,
IMAGEOUT_MODE_1296X972 = 32, IMAGEOUT_MODE_960x600 = 33, IMAGEOUT_MODE_2848X2848 = 34, IMAGEOUT_MODE_1424x1424 = 35,
IMAGEOUT_MODE_640X512 = 36, IMAGEOUT_MODE_NUM, IMAGEOUT_MODE_CUSTOM = 0XFF
}
Image resolution. More...
enum | emFrameMode { FRAME_SPEED_LOW = 0, FRAME_SPEED_MIDDLE, FRAME_SPEED_HIGH }
frame rate More...
enum | emFlickerMode { FREQ_FLICKER_MODE_NULL = 0, FREQ_FLICKER_MODE_50HZ, FREQ_FLICKER_MODE_60HZ }
Light strobe. More...
enum emFileType {
FILE_JPG = 1, FILE_BMP = 2, FILE_RAW = 4, FILE_PNG = 8,
FILE_BMP_8BIT = 16, FILE_PNG_8BIT = 32, FILE_RAW_16BIT = 64
}
Save the file format of the image. More...
enum | emStatisticsMode { STATISTICS_AVG = 0, STATISTICS_HIST, STATISTICS_WINDOW, STATISTICS_REFER_WINDOW }
Exposure Algorithm. More...
enum | emSdkParameterMode { PARAM_MODE_BY_MODEL = 0, PARAM_MODE_BY_NAME, PARAM_MODE_BY_SN, PARAM_MODE_IN_DEVICE }
Parameter file loading method. More...
enum emSdkParameterTeam {
PARAMETER_TEAM_A = 0, PARAMETER_TEAM_B = 1, PARAMETER_TEAM_C = 2, PARAMETER_TEAM_D = 3,
PARAMETER_TEAM_DEFAULT = 0xff
}
The camera's configuration parameters are divided into 4 groups of A, B, C, and D for saving. More...
enum | emTriggerMode { TRIGGER_MODE_CONTINUOUS = 0, TRIGGER_MODE_SOFT, TRIGGER_MODE_HARD }
Camera Trigger Mode. More...
enum | emStrobeControl { STROBE_SYNC_WITH_TRIG_AUTO = 0, STROBE_SYNC_WITH_TRIG_MANUAL }
Strobe signal control method. More...
enum emExtTrigSignal {
EXT_TRIG_LEADING_EDGE = 0, EXT_TRIG_TRAILING_EDGE, EXT_TRIG_HIGH_LEVEL, EXT_TRIG_LOW_LEVEL,
EXT_TRIG_DOUBLE_EDGE
}
Type of signal triggered by hardware. More...
enum | emMirrorMode { MIRROR_MODE_H = 0, MIRROR_MODE_V = 1 }
Image mirroring mode. More...
enum | emSdkDisplayMode { DISPLAYMODE_SCALE = 0, DISPLAYMODE_REAL }
SDK internal display interface display mode. More...
enum | emAeExpMode { AE_EXP_MODE = 0, AE_FRAME_MODE }
Auto Exposure Mode. More...
enum emSettingPage {
SETTING_PAGE_DEVINFO = 0x01, SETTING_PAGE_IMG_SETTING = 0x02, SETTING_PAGE_EXP_SETTING = 0x04, SETTING_PAGE_AWB_SETTING = 0x08,
SETTING_PAGE_CROSS_LINE = 0x10, SETTING_PAGE_OUT_SETTING = 0x20, SETTING_PAGE_REL_SETTING = 0x40, SETTING_PAGE_GAMMA_SETTING = 0x80,
SETTING_PAGE_GIGE_SETTING = 0x100, SETTING_PAGE_SPECIAL_SETTING = 0x200, SETTING_PAGE_ALL = 0xFFFFFF
}
The mask of the TAB page displayed in the device property settings dialog. More...
enum | emSdkLutChannel { LUT_CHANNEL_ALL = 0, LUT_CHANNEL_RED, LUT_CHANNEL_GREEN, LUT_CHANNEL_BLUE }
LUT color channel. More...
enum | emSdkLutMode { GAMMA_DYNAMIC_MODE = 0, GAMMA_PRESET_MODE, GAMMA_USER_MODE }
LUT mode. More...
enum | emSdkOutputIOMode { IOMODE_STROBE_OUTPUT = 0, IOMODE_GP_OUTPUT, IOMODE_PWM_OUTPUT }
IO output mode. More...
enum | emSdkInputIOMode { IOMODE_TRIG_INPUT = 0, IOMODE_GP_INPUT }
IO input mode. More...
enum | emImageTransferMode { TRANSFER_NEWEST_IMAGE = 0, TRANSFER_OLDEST_IMAGE = 1, TRANSFER_IMAGE_ON_PASSIVE_MODE = 2, TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE = 3 }
Camera cache frame transfer mode. More...
enum | emRequestTransferCmd { REQUEST_TRANSFER_CURRENT_FRAME = 0, REQUEST_TRANSFER_NEXT_FRAME = 1, REQUEST_TRANSFER_LATEST_FRAME = 2 }
enum emSdkValueType {
IMAGE_CHANNEL_MASK = 0, LED_LIGHT, ENABLE_WDR, CONTROL_FOCUS_VALUE,
CONTROL_FOCUS_MIN_VALUE, CONTROL_FOCUS_MAX_VALUE, CONTROL_FOCUS_DEFAULT_VALUE, IS_SUPPORT_CONTROL_FOCUS,
IMAGE_CHANNEL_NUM, FRAME_OUTPUT_QUEUE_SIZE, FIND_ME
}
Set the type of parameter. More...
enum | emSdkExceptionType { EXCEPTION_DEV_DISCONNECT = 0, EXCEPTION_DEV_RECONNECT, EXCEPTION_VERSION_CHECK }
typedef enum emSdkValueType | emSdkValueType
Set the type of parameter. More...
typedef enum emSdkExceptionType | emSdkExceptionType

Detailed Description

Typedef Documentation

◆ emSdkExceptionType

typedef enum emSdkExceptionType emSdkExceptionType

◆ emSdkValueType

typedef enum emSdkValueType emSdkValueType

Set the type of parameter.

Enumeration Type Documentation

◆ emAeExpMode

enum emAeExpMode

Auto Exposure Mode.

Enumerator
AE_EXP_MODE | Auto exposure frame rate priority mode.
AE_FRAME_MODE | AE exposure priority mode.

◆ emDeviceType

enum emDeviceType

device type

Enumerator
DEVICE_TYPE_UNKNOW
DEVICE_TYPE_USB20
DEVICE_TYPE_USB30
DEVICE_TYPE_GIGE

◆ emExtTrigSignal

enum emExtTrigSignal

Type of signal triggered by hardware.

Enumerator
EXT_TRIG_LEADING_EDGE | Rising edge trigger, defaults to this mode.
EXT_TRIG_TRAILING_EDGE | Falling edge trigger.
EXT_TRIG_HIGH_LEVEL | High level trigger, level width determines exposure time, only some models support level trigger mode.
EXT_TRIG_LOW_LEVEL | Low level trigger.
EXT_TRIG_DOUBLE_EDGE | Bilateral edge trigger.

◆ emFileType

enum emFileType

Save the file format of the image.

Enumerator
FILE_JPG | Save as JPEG file format.
FILE_BMP | Save as BMP file format.
FILE_RAW | Save as BMP file format, for cameras that do not support bayer format, cannot be saved as this format.
FILE_PNG | Save as PNG 24BIT file format.
FILE_BMP_8BIT | Save as BMP 8BIT file format.
FILE_PNG_8BIT | Save as PNG 8BIT file format.
FILE_RAW_16BIT | Save as BMP 16BIT file format, for cameras that do not support bayer format, cannot be saved as this format.

◆ emFlickerMode

enum emFlickerMode

Light strobe.

Enumerator
FREQ_FLICKER_MODE_NULL | Prohibits the elimination of strobes.
FREQ_FLICKER_MODE_50HZ | Eliminate 50hz strobe.
FREQ_FLICKER_MODE_60HZ | Eliminate 60hz strobe.

◆ emFrameMode

enum emFrameMode

frame rate

Enumerator
FRAME_SPEED_LOW | Frame rate Low speed.
FRAME_SPEED_MIDDLE | Frame rate Medium speed.
FRAME_SPEED_HIGH | Frame speed High speed.

◆ emImageTransferMode

enum emImageTransferMode

Camera cache frame transfer mode.

Enumerator
TRANSFER_NEWEST_IMAGE | Read the newest frame in the camera memory.
TRANSFER_OLDEST_IMAGE | Read the oldest frame in the camera memory.
TRANSFER_IMAGE_ON_PASSIVE_MODE | The camera does not take the initiative to send image frames, but only sends them when a request is sent, and each transmission is the last image captured by the camera.
TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE | The camera does not take the initiative to send image frames, but sends them when a request is sent, and the position of the frame is determined according to the command in emRequestTransferCmd.

◆ emMirrorMode

enum emMirrorMode

Image mirroring mode.

Enumerator
MIRROR_MODE_H | horizontal mirroring
MIRROR_MODE_V | Vertical Mirror.

◆ emRequestTransferCmd

enum emRequestTransferCmd
Enumerator
REQUEST_TRANSFER_CURRENT_FRAME | Request to retransmit the last transmitted image frame.
REQUEST_TRANSFER_NEXT_FRAME | Request to transmit the next frame of the image frame that was last transmitted.
REQUEST_TRANSFER_LATEST_FRAME | Request to transfer the latest image frame.

◆ emResolutionMode

enum emResolutionMode

Image resolution.

Enumerator
IMAGEOUT_MODE_512X384 | Resolution 512x384.
IMAGEOUT_MODE_640X480 | Resolution 640x480.
IMAGEOUT_MODE_800X600 | Resolution 800x600.
IMAGEOUT_MODE_1024X768 | Resolution 1024x768.
IMAGEOUT_MODE_1280X720 | Resolution 1280x720.
IMAGEOUT_MODE_1280X960 | Resolution 1280x960.
IMAGEOUT_MODE_1920X1280 | Resolution 1920x1280.
IMAGEOUT_MODE_2048X1536 | Resolution 2048x1536.
IMAGEOUT_MODE_320X240 | Resolution 320x240.
IMAGEOUT_MODE_1280X1024 | Resolution 1280x1024.
IMAGEOUT_MODE_1600X1200 | Resolution 1600x1200.
IMAGEOUT_MODE_2592X1944 | Resolution 2592x1944.
IMAGEOUT_MODE_752X480 | Resolution 752x480.
IMAGEOUT_MODE_768X576 | Resolution 768x576.
IMAGEOUT_MODE_3664X2748 | Resolution 3664x2748.
IMAGEOUT_MODE_1920X1080 | Resolution 1920x1080.
IMAGEOUT_MODE_2304X1296 | Resolution 2304x1296.
IMAGEOUT_MODE_2304X1728 | Resolution 2304x1728.
IMAGEOUT_MODE_4608X3456 | Resolution 4608x3456.
IMAGEOUT_MODE_640X360 | Resolution 640x360.
IMAGEOUT_MODE_3072X2048 | Resolution 3072X2048.
IMAGEOUT_MODE_1920X1200 | Resolution 1920X1200.
IMAGEOUT_MODE_5472X3648 | Resolution 5472X3648.
IMAGEOUT_MODE_2448X2048 | Resolution 2448X2048.
IMAGEOUT_MODE_4000X3000 | Resolution 4000X3000.
IMAGEOUT_MODE_3008X3008 | Resolution 3008X3008.
IMAGEOUT_MODE_4096X2160 | Resolution 4096X2160.
IMAGEOUT_MODE_2736X1824 | Resolution 2736X1824.
IMAGEOUT_MODE_4144X2822 | Resolution 4144X2822.
IMAGEOUT_MODE_720X540 | Resolution 720X540.
IMAGEOUT_MODE_1440X1080 | Resolution 1440X1080.
IMAGEOUT_MODE_1280X800 | Resolution 1280X800.
IMAGEOUT_MODE_1296X972 | Resolution 1296x972.
IMAGEOUT_MODE_960x600 | Resolution 960x600.
IMAGEOUT_MODE_2848X2848 | Resolution 2840x2840.
IMAGEOUT_MODE_1424x1424 | Resolution 2840x2840.
IMAGEOUT_MODE_640X512 | Resolution 640X512.
IMAGEOUT_MODE_NUM | SDK predefined number of resolutions.
IMAGEOUT_MODE_CUSTOM | Custom Resolution.

◆ emSdkDisplayMode

enum emSdkDisplayMode

SDK internal display interface display mode.

Enumerator
DISPLAYMODE_SCALE | Zoom display mode, zoom to display control size.
DISPLAYMODE_REAL | 1:1 display mode, when the image size is larger than the size of the display control, only the partial

◆ emSdkExceptionType

enum emSdkExceptionType
Enumerator
EXCEPTION_DEV_DISCONNECT
EXCEPTION_DEV_RECONNECT
EXCEPTION_VERSION_CHECK

◆ emSdkInputIOMode

enum emSdkInputIOMode

IO input mode.

Enumerator
IOMODE_TRIG_INPUT | Trigger input.
IOMODE_GP_INPUT | General input.

◆ emSdkLutChannel

enum emSdkLutChannel

LUT color channel.

Enumerator
LUT_CHANNEL_ALL | R, B, G three channels simultaneously adjust.
LUT_CHANNEL_RED | Red channel.
LUT_CHANNEL_GREEN | Green channel.
LUT_CHANNEL_BLUE | Blue channel.

◆ emSdkLutMode

enum emSdkLutMode

LUT mode.

Enumerator
GAMMA_DYNAMIC_MODE | Dynamic mode.
GAMMA_PRESET_MODE | Preset mode.
GAMMA_USER_MODE | Custom mode.

◆ emSdkOutputIOMode

enum emSdkOutputIOMode

IO output mode.

Enumerator
IOMODE_STROBE_OUTPUT | Strobe output.
IOMODE_GP_OUTPUT | General output.
IOMODE_PWM_OUTPUT | PWM output.

◆ emSdkParameterMode

enum emSdkParameterMode

Parameter file loading method.

Enumerator
PARAM_MODE_BY_MODEL | Loads parameters from a file based on the camera model name, such as CK-U2B300.
PARAM_MODE_BY_NAME | Loads parameters from the file according to the device nickname (tDevInfo.acFriendlyName), such as CK-U2B300, which can be customized.
PARAM_MODE_BY_SN | Loads parameters from a file based on its unique serial number. The serial number is already written to the device at the factory, and each camera has a different serial number.
PARAM_MODE_IN_DEVICE | Loads parameters from the device's solid state memory. Not all models support reading and writing parameter sets from the camera, as determined by tSdkCameraCapbility.bParamInDevice.

◆ emSdkParameterTeam

enum emSdkParameterTeam

The camera's configuration parameters are divided into 4 groups of A, B, C, and D for saving.

Enumerator
PARAMETER_TEAM_A
PARAMETER_TEAM_B
PARAMETER_TEAM_C
PARAMETER_TEAM_D
PARAMETER_TEAM_DEFAULT

◆ emSdkValueType

enum emSdkValueType

Set the type of parameter.

Enumerator
IMAGE_CHANNEL_MASK | Multichannel cameras specify which channels of images to output, bit0 for channel0 bit1 for channel1 etc.
LED_LIGHT | For U2BMT120C-GW model, control the LED output light.
ENABLE_WDR | Whether to enable WDR function.
CONTROL_FOCUS_VALUE | Set and get focus value of adjustable focus lens.
CONTROL_FOCUS_MIN_VALUE | Get the minimum value of the focus value.
CONTROL_FOCUS_MAX_VALUE | Get the maximum value of the focus value.
CONTROL_FOCUS_DEFAULT_VALUE | Get the default value of the focus value.
IS_SUPPORT_CONTROL_FOCUS | Whether to support focusing.
IMAGE_CHANNEL_NUM | The maximum number of channel images supported by the camera.
FRAME_OUTPUT_QUEUE_SIZE | Set the output cache queue length.
FIND_ME |

◆ emSettingPage

enum emSettingPage

The mask of the TAB page displayed in the device property settings dialog.

Enumerator
SETTING_PAGE_DEVINFO | Device Information Configuration Page.
SETTING_PAGE_IMG_SETTING | Image Parameter Configuration Page.
SETTING_PAGE_EXP_SETTING | Exposure configuration page.
SETTING_PAGE_AWB_SETTING | White Balance Configuration Page.
SETTING_PAGE_CROSS_LINE | Crosshair configuration page.
SETTING_PAGE_OUT_SETTING | Video Output Configuration Page.
SETTING_PAGE_REL_SETTING | Resolution Configuration Page.
SETTING_PAGE_GAMMA_SETTING | gamma configuration interface
SETTING_PAGE_GIGE_SETTING | GigE camera configuration page, only GigE camera is valid.
SETTING_PAGE_SPECIAL_SETTING | Special parameter settings.
SETTING_PAGE_ALL | Show all property pages.

◆ emStatisticsMode

enum emStatisticsMode

Exposure Algorithm.

Enumerator
STATISTICS_AVG | Mean Statistics.
STATISTICS_HIST | Histogram statistics.
STATISTICS_WINDOW | Statistical method with weight 3x3.
STATISTICS_REFER_WINDOW | Reference window statistics.

◆ emStrobeControl

enum emStrobeControl

Strobe signal control method.

Enumerator
STROBE_SYNC_WITH_TRIG_AUTO | Synchronize with the trigger signal. When triggered, the STROBE signal is automatically generated when the camera is exposed. At this time, the effective polarity can be set CameraSetStrobePolarity.
STROBE_SYNC_WITH_TRIG_MANUAL | Synchronize with the trigger signal. After the trigger, STROBE delays the specified time CameraSetStrobeDelayTime, and then continues the pulse of the specified time CameraSetStrobePulseWidth, the effective polarity can be set CameraSetStrobePolarity.

◆ emTriggerMode

enum emTriggerMode

Camera Trigger Mode.

Enumerator
TRIGGER_MODE_CONTINUOUS | Continuous trigger mode.
TRIGGER_MODE_SOFT | Software Trigger Mode.
TRIGGER_MODE_HARD | Hardware Trigger Mode.


CKCameraAPI: CKDeviceDef.h File Reference

Classes | Macros | Typedefs
CKDeviceDef.h File Reference
#include <stdint.h>

Go to the source code of this file.

Classes

struct | tagRECT
struct | _tInitCameraParam
When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera. More...
struct | _tIspAe
Exposure parameters. More...
struct | _tIspWb
White balance parameter. More...
struct | _tIspGamma
Gama parameter. More...
struct | _tDevLoadMode
Device loading mode information. More...
struct | _tExpose
Camera exposure function range definition. More...
struct | _tResolutionRange
Camera resolution setting range for widget UI. More...
struct | _tSdkTrigger
Trigger Mode Description. More...
struct | _tSdkImageResolution
Camera resolution description. More...
struct | _tSdkColorTemperatureDes
Camera white balance color temperature mode description information. More...
struct | _tSdkPackLength
Transfer packet size description (mainly valid for web cameras) More...
struct | _tSdkPresetLut
Preset LUT table description. More...
struct | _tSdkAeAlgorithm
AE algorithm description. More...
struct | _tSdkBayerDecodeAlgorithm
RAW to RGB algorithm description. More...
struct | _tSdkMediaType
Image data format output by the camera. More...
struct | _tSdkBayerType
Image data format output by the camera. More...
struct | _tSdkFrameSpeed
Camera frame rate description information. More...
struct | _tRgbGainRange
RGB three-channel digital gain setting range. More...
struct | _tSaturationRange
Range of saturation setting. More...
struct | _tSharpnessRange
Sharpening setting range. More...
struct | _tGammaRange
Gamma setting range. More...
struct | _tGammaContrastRange
Gamma contrast setting range. More...
struct | _tContrastRange
Contrast setting range. More...
struct | _tSdkIspCapacity
ISP module enable information. More...
struct | _tSensorCfg
sensor level More...
struct | _tDeviceCfg
Device Capability Level. More...
struct | _tDevInfo
Camera device information. More...
struct | _stImageInfo
Frame header information. More...
struct | _FrameStatistic
Frame rate statistics. More...
struct | _tSdkCameraCapbility
Camera Ability Level. More...
struct | _DisplayWindow
Display window parameters. More...
struct | _tDevEnumInfo
Enumeration information. More...
struct | _tDevLoadInfo
Current mode and enumeration information for the device. More...
struct | _tGigeNetworkInfo
Network information of GigE camera. More...
struct | _tLscCalibParam
LSC calibration parameter. More...
struct | _tLscCorrectParam
LSC correction parameter. More...

Macros

#define | FALSE 0
#define | TRUE 1
#define | CROSSLINE_MAX_NUM 9
#define | CAMERA_STATUS_SUCCESS 0
Operation succeeded. More...
#define | CAMERA_STATUS_FAILED -1
Operation failed. More...
#define | CAMERA_STATUS_INTERNAL_ERROR -2
Internal error. More...
#define | CAMERA_STATUS_UNKNOW -3
Unknown error. More...
#define | CAMERA_STATUS_NOT_SUPPORTED -4
Don't support this feature. More...
#define | CAMERA_STATUS_NOT_INITIALIZED -5
Initialization not completed. More...
#define | CAMERA_STATUS_PARAMETER_INVALID -6
Parameter is invalid. More...
#define | CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7
Parameter out of bounds. More...
#define | CAMERA_STATUS_UNENABLED -8
It is not enabled. More...
#define | CAMERA_STATUS_USER_CANCEL -9
The user canceled manually, such as the roi panel click cancel, return. More...
#define | CAMERA_STATUS_PATH_NOT_FOUND -10
The corresponding path was not found in the registry. More...
#define | CAMERA_STATUS_SIZE_DISMATCH -11
Get image data length and defined size does not match. More...
#define | CAMERA_STATUS_TIME_OUT -12
Timeout error. More...
#define | CAMERA_STATUS_IO_ERROR -13
Hardware IO error. More...
#define | CAMERA_STATUS_COMM_ERROR -14
Communication error. More...
#define | CAMERA_STATUS_BUS_ERROR -15
Bus error. More...
#define | CAMERA_STATUS_NO_DEVICE_FOUND -16
No devices found. More...
#define | CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17
No logical device found. More...
#define | CAMERA_STATUS_DEVICE_IS_OPENED -18
Device is already open. More...
#define | CAMERA_STATUS_DEVICE_IS_CLOSED -19
Device is turned off. More...
#define | CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20
When the device video is not turned on, when the video related function is called, if the camera video is not turned on, the error is returned. More...
#define | CAMERA_STATUS_NO_MEMORY -21
Not enough system memory. More...
#define | CAMERA_STATUS_FILE_CREATE_FAILED -22
Failed to create file. More...
#define | CAMERA_STATUS_FILE_INVALID -23
File format is invalid. More...
#define | CAMERA_STATUS_WRITE_PROTECTED -24
Write protection, not writeable. More...
#define | CAMERA_STATUS_GRAB_FAILED -25
Data collection failed. More...
#define | CAMERA_STATUS_LOST_DATA -26
Data is missing, incomplete. More...
#define | CAMERA_STATUS_EOF_ERROR -27
Frame end not received. More...
#define | CAMERA_STATUS_BUSY -28
Is busy (the last operation is still in progress), this operation cannot be done. More...
#define | CAMERA_STATUS_WAIT -29
Needs to wait (the conditions for the operation are not met), you can try again. More...
#define | CAMERA_STATUS_IN_PROCESS -30
Is in progress and has been manipulated. More...
#define | CAMERA_STATUS_IIC_ERROR -31
IIC transmission error. More...
#define | CAMERA_STATUS_SPI_ERROR -32
SPI transmission error. More...
#define | CAMERA_STATUS_USB_CONTROL_ERROR -33
USB control transfer error. More...
#define | CAMERA_STATUS_USB_BULK_ERROR -34
USB BULK transmission error. More...
#define | CAMERA_STATUS_SOCKET_INIT_ERROR -35
Network Transfer Kit initialization failed. More...
#define | CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36
The network camera kernel filter driver failed to initialize. Please check if the driver is properly installed or reinstall. More...
#define | CAMERA_STATUS_NET_SEND_ERROR -37
Network data sending error. More...
#define | CAMERA_STATUS_DEVICE_LOST -38
Lost connection with web camera, heartbeat detection timed out. More...
#define | CAMERA_STATUS_DATA_RECV_LESS -39
Received fewer bytes than requested. More...
#define | CAMERA_STATUS_FUNCTION_LOAD_FAILED -40
Failed to load program from file. More...
#define | CAMERA_STATUS_CRITICAL_FILE_LOST -41
The files necessary for the program to run are missing. More...
#define | CAMERA_STATUS_SENSOR_ID_DISMATCH -42
The firmware and program do not match because the wrong firmware was downloaded. More...
#define | CAMERA_STATUS_OUT_OF_RANGE -43
The parameter is outside the valid range. More...
#define | CAMERA_STATUS_REGISTRY_ERROR -44
Installer registration error. Please reinstall the program. More...
#define | CAMERA_STATUS_ACCESS_DENY -45
No access. When the specified camera is already occupied by another program, it will return to this state after requesting access to the camera. (A camera cannot be accessed simultaneously by multiple programs) More...
#define | CAMERA_STATUS_CAMERA_NEED_RESET -46
Means that the camera needs to be reset before it can be used normally. In this case, please let the camera power off and restart, or restart the operating system, then it can be used normally. More...
#define | CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47
ISP module is not initialized. More...
#define | CAMERA_STATUS_ISP_DATA_CRC_ERROR -48
Data validation error. More...
#define | CAMERA_STATUS_MV_TEST_FAILED -49
Data test failed. More...
#define | CAMERA_STATUS_WAIT_TRIGGER -50
Waiting for trigger frame. More...
#define | CAMERA_STATUS_EEPROM_UPDATA -51
EE data version needs to be updated. More...
#define | CAMERA_STATUS_OPEN_DEVICE_ERROR -52
Failed to open device. More...
#define | CAMERA_STATUS_OPEN_STREAM_ERROR -53
Failed to open video stream. More...
#define | CAMERA_STATUS_READ_ERROR -54
Read error. More...
#define | CAMERA_STATUS_WRITE_ERROR -55
Write error. More...
#define | CAMERA_STATUS_NO_OPEN_DEVICE -56
No open device. More...
#define | CAMERA_STATUS_UNKNOW_SENSOR -57
Sensor not recognized. More...
#define | CAMERA_STATUS_NO_WRITE_EEPROM -58
Don't write EE data. More...
#define | CMAERA_STATUS_FPGA_CFG_ERROR -59
FPGA configuration failed. More...
#define | CAMERA_MEDIA_TYPE_MONO 0x01000000
#define | CAMERA_MEDIA_TYPE_RGB 0x02000000
#define | CAMERA_MEDIA_TYPE_COLOR 0x02000000
#define | CAMERA_MEDIA_TYPE_OCCUPY1BIT 0x00010000
#define | CAMERA_MEDIA_TYPE_OCCUPY2BIT 0x00020000
#define | CAMERA_MEDIA_TYPE_OCCUPY4BIT 0x00040000
#define | CAMERA_MEDIA_TYPE_OCCUPY8BIT 0x00080000
#define | CAMERA_MEDIA_TYPE_OCCUPY10BIT 0x000A0000
#define | CAMERA_MEDIA_TYPE_OCCUPY12BIT 0x000C0000
#define | CAMERA_MEDIA_TYPE_OCCUPY16BIT 0x00100000
#define | CAMERA_MEDIA_TYPE_OCCUPY24BIT 0x00180000
#define | CAMERA_MEDIA_TYPE_OCCUPY32BIT 0x00200000
#define | CAMERA_FORMAT_BAYGR8 0x00000008
#define | CAMERA_FORMAT_BAYGR12 0x00000010
#define | CAMERA_FORMAT_RGB 0x00000014
#define | CAMERA_FORMAT_BGR 0x00000015
#define | CAMERA_FORMAT_MONO 0x00000000
#define | CAMERA_MEDIA_TYPE_COLOR_MASK 0xFF000000
#define | CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK 0x00FF0000
#define | CAMERA_MEDIA_TYPE_ID_MASK 0x0000FFFF
#define | CAMERA_MEDIA_TYPE_MEDIA_FORMAT 0x000000FF
#define | CAMERA_MEDIA_TYPE_BAYGR8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0008)
#define | CAMERA_MEDIA_TYPE_BAYRG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0009)
#define | CAMERA_MEDIA_TYPE_BAYGB8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000A)
#define | CAMERA_MEDIA_TYPE_BAYBG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000B)
#define | CAMERA_MEDIA_TYPE_BAYGR10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000C)
#define | CAMERA_MEDIA_TYPE_BAYRG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000D)
#define | CAMERA_MEDIA_TYPE_BAYGB10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000E)
#define | CAMERA_MEDIA_TYPE_BAYBG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000F)
#define | CAMERA_MEDIA_TYPE_BAYGR12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0010)
#define | CAMERA_MEDIA_TYPE_BAYRG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0011)
#define | CAMERA_MEDIA_TYPE_BAYGB12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0012)
#define | CAMERA_MEDIA_TYPE_BAYBG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0013)
#define | CAMERA_MEDIA_TYPE_BAYGR10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0026)
#define | CAMERA_MEDIA_TYPE_BAYRG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0027)
#define | CAMERA_MEDIA_TYPE_BAYGB10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0028)
#define | CAMERA_MEDIA_TYPE_BAYBG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0029)
#define | CAMERA_MEDIA_TYPE_BAYGR12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002A)
#define | CAMERA_MEDIA_TYPE_BAYRG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002B)
#define | CAMERA_MEDIA_TYPE_BAYGB12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002C)
#define | CAMERA_MEDIA_TYPE_BAYBG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002D)
#define | CAMERA_MEDIA_TYPE_BAYGR16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002E)
#define | CAMERA_MEDIA_TYPE_BAYRG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002F)
#define | CAMERA_MEDIA_TYPE_BAYGB16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0030)
#define | CAMERA_MEDIA_TYPE_BAYBG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0031)
#define | CAMERA_MEDIA_TYPE_RGB8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_RGB)
#define | CAMERA_MEDIA_TYPE_BGR8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_BGR)
#define | CAMERA_MEDIA_TYPE_RGBA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_RGB)
#define | CAMERA_MEDIA_TYPE_BGRA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_BGR)
#define | CAMERA_MEDIA_TYPE_YUV411_8_UYYVYY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x001E)
#define | CAMERA_MEDIA_TYPE_YUV422_8_UYVY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x001F)
#define | CAMERA_MEDIA_TYPE_YUV422_8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0032)
#define | CAMERA_MEDIA_TYPE_YUV8_UYV (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x0020)
#define | CAMERA_MEDIA_TYPE_YCBCR8_CBYCR (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x003A)
#define | CAMERA_MEDIA_TYPE_MONO8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0000)
#define | CAMERA_MEDIA_TYPE_MONO8_SIGNED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0002)
#define | CAMERA_MEDIA_TYPE_MONO10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0003)
#define | CAMERA_MEDIA_TYPE_MONO10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0004)
#define | CAMERA_MEDIA_TYPE_MONO12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0005)
#define | CAMERA_MEDIA_TYPE_MONO12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0006)
#define | CAMERA_MEDIA_TYPE_MONO14 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0025)
#define | CAMERA_MEDIA_TYPE_MONO16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0007)

Typedefs

typedef uint32_t | DWORD
typedef int32_t | INT
typedef uint32_t | UINT
typedef uint16_t | WORD
typedef uint64_t | UINT64
typedef int | BOOL
typedef uint8_t | BYTE
typedef long | LONG
typedef void * | HANDLE
typedef HANDLE * | PHANDLE
typedef void * | LPVOID
typedef void * | HDC
typedef uint16_t | WCHAR
typedef unsigned short | USHORT
typedef char | TCHAR
typedef void * | HWND
typedef struct tagRECT | RECT
typedef struct _tInitCameraParam | tInitCameraParam
When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera. More...
typedef struct _tIspAe | tIspAe
Exposure parameters. More...
typedef struct _tIspWb | tIspWb
White balance parameter. More...
typedef struct _tIspGamma | tIspGamma
Gama parameter. More...
typedef struct _tDevLoadMode | tDevLoadMode
Device loading mode information. More...
typedef struct _tExpose | tExpose
Camera exposure function range definition. More...
typedef struct _tResolutionRange | tResolutionRange
Camera resolution setting range for widget UI. More...
typedef struct _tSdkTrigger | tSdkTrigger
Trigger Mode Description. More...
typedef struct _tSdkImageResolution | tSdkImageResolution
Camera resolution description. More...
typedef struct _tSdkColorTemperatureDes | tSdkColorTemperatureDes
Camera white balance color temperature mode description information. More...
typedef struct _tSdkPackLength | tSdkPackLength
Transfer packet size description (mainly valid for web cameras) More...
typedef struct _tSdkPresetLut | tSdkPresetLut
Preset LUT table description. More...
typedef struct _tSdkAeAlgorithm | tSdkAeAlgorithm
AE algorithm description. More...
typedef struct _tSdkBayerDecodeAlgorithm | tSdkBayerDecodeAlgorithm
RAW to RGB algorithm description. More...
typedef struct _tSdkMediaType | tSdkMediaType
Image data format output by the camera. More...
typedef struct _tSdkBayerType | tSdkBayerType
Image data format output by the camera. More...
typedef struct _tSdkFrameSpeed | tSdkFrameSpeed
Camera frame rate description information. More...
typedef struct _tRgbGainRange | tRgbGainRange
RGB three-channel digital gain setting range. More...
typedef struct _tSaturationRange | tSaturationRange
Range of saturation setting. More...
typedef struct _tSharpnessRange | tSharpnessRange
Sharpening setting range. More...
typedef struct _tGammaRange | tGammaRange
Gamma setting range. More...
typedef struct _tGammaContrastRange | tGammaContrastRange
Gamma contrast setting range. More...
typedef struct _tContrastRange | tContrastRange
Contrast setting range. More...
typedef struct _tSdkIspCapacity | tSdkIspCapacity
ISP module enable information. More...
typedef struct _tSensorCfg | tSensorCfg
sensor level More...
typedef struct _tDeviceCfg | tDeviceCfg
Device Capability Level. More...
typedef struct _tDevInfo | tDevInfo
Camera device information. More...
typedef struct _stImageInfo | stImageInfo
Frame header information. More...
typedef struct _stImageInfo * | PstImageInfo
typedef struct _FrameStatistic | FrameStatistic
Frame rate statistics. More...
typedef struct _tSdkCameraCapbility | tSdkCameraCapbility
Camera Ability Level. More...
typedef struct _DisplayWindow | DisplayWindow
Display window parameters. More...
typedef struct _tDevEnumInfo | tDevEnumInfo
Enumeration information. More...
typedef struct _tDevLoadInfo | tDevLoadInfo
Current mode and enumeration information for the device. More...
typedef struct _tGigeNetworkInfo | tGigeNetworkInfo
Network information of GigE camera. More...
typedef struct _tLscCalibParam | tLscCalibParam
LSC calibration parameter. More...
typedef struct _tLscCorrectParam | tLscCorrectParam
LSC correction parameter. More...
enum | emDeviceType { DEVICE_TYPE_UNKNOW = 0, DEVICE_TYPE_USB20 = 0x1201, DEVICE_TYPE_USB30 = 0x1301, DEVICE_TYPE_GIGE = 0x2001 }
device type More...
enum emResolutionMode {
IMAGEOUT_MODE_512X384 = 0, IMAGEOUT_MODE_640X480 = 1, IMAGEOUT_MODE_800X600 = 2, IMAGEOUT_MODE_1024X768 = 3,
IMAGEOUT_MODE_1280X720 = 4, IMAGEOUT_MODE_1280X960 = 5, IMAGEOUT_MODE_1920X1280 = 6, IMAGEOUT_MODE_2048X1536 = 7,
IMAGEOUT_MODE_320X240 = 8, IMAGEOUT_MODE_1280X1024 = 9, IMAGEOUT_MODE_1600X1200 = 10, IMAGEOUT_MODE_2592X1944 = 11,
IMAGEOUT_MODE_752X480 = 12, IMAGEOUT_MODE_768X576 = 13, IMAGEOUT_MODE_3664X2748 = 14, IMAGEOUT_MODE_1920X1080 = 15,
IMAGEOUT_MODE_2304X1296 = 16, IMAGEOUT_MODE_2304X1728 = 17, IMAGEOUT_MODE_4608X3456 = 18, IMAGEOUT_MODE_640X360 = 19,
IMAGEOUT_MODE_3072X2048 = 20, IMAGEOUT_MODE_1920X1200 = 21, IMAGEOUT_MODE_5472X3648 = 22, IMAGEOUT_MODE_2448X2048 = 23,
IMAGEOUT_MODE_4000X3000 = 24, IMAGEOUT_MODE_3008X3008 = 25, IMAGEOUT_MODE_4096X2160 = 26, IMAGEOUT_MODE_2736X1824 = 27,
IMAGEOUT_MODE_4144X2822 = 28, IMAGEOUT_MODE_720X540 = 29, IMAGEOUT_MODE_1440X1080 = 30, IMAGEOUT_MODE_1280X800 = 31,
IMAGEOUT_MODE_1296X972 = 32, IMAGEOUT_MODE_960x600 = 33, IMAGEOUT_MODE_2848X2848 = 34, IMAGEOUT_MODE_1424x1424 = 35,
IMAGEOUT_MODE_640X512 = 36, IMAGEOUT_MODE_NUM, IMAGEOUT_MODE_CUSTOM = 0XFF
}
Image resolution. More...
enum | emFrameMode { FRAME_SPEED_LOW = 0, FRAME_SPEED_MIDDLE, FRAME_SPEED_HIGH }
frame rate More...
enum | emFlickerMode { FREQ_FLICKER_MODE_NULL = 0, FREQ_FLICKER_MODE_50HZ, FREQ_FLICKER_MODE_60HZ }
Light strobe. More...
enum emFileType {
FILE_JPG = 1, FILE_BMP = 2, FILE_RAW = 4, FILE_PNG = 8,
FILE_BMP_8BIT = 16, FILE_PNG_8BIT = 32, FILE_RAW_16BIT = 64
}
Save the file format of the image. More...
enum | emStatisticsMode { STATISTICS_AVG = 0, STATISTICS_HIST, STATISTICS_WINDOW, STATISTICS_REFER_WINDOW }
Exposure Algorithm. More...
enum | emSdkParameterMode { PARAM_MODE_BY_MODEL = 0, PARAM_MODE_BY_NAME, PARAM_MODE_BY_SN, PARAM_MODE_IN_DEVICE }
Parameter file loading method. More...
enum emSdkParameterTeam {
PARAMETER_TEAM_A = 0, PARAMETER_TEAM_B = 1, PARAMETER_TEAM_C = 2, PARAMETER_TEAM_D = 3,
PARAMETER_TEAM_DEFAULT = 0xff
}
The camera's configuration parameters are divided into 4 groups of A, B, C, and D for saving. More...
enum | emTriggerMode { TRIGGER_MODE_CONTINUOUS = 0, TRIGGER_MODE_SOFT, TRIGGER_MODE_HARD }
Camera Trigger Mode. More...
enum | emStrobeControl { STROBE_SYNC_WITH_TRIG_AUTO = 0, STROBE_SYNC_WITH_TRIG_MANUAL }
Strobe signal control method. More...
enum emExtTrigSignal {
EXT_TRIG_LEADING_EDGE = 0, EXT_TRIG_TRAILING_EDGE, EXT_TRIG_HIGH_LEVEL, EXT_TRIG_LOW_LEVEL,
EXT_TRIG_DOUBLE_EDGE
}
Type of signal triggered by hardware. More...
enum | emMirrorMode { MIRROR_MODE_H = 0, MIRROR_MODE_V = 1 }
Image mirroring mode. More...
enum | emSdkDisplayMode { DISPLAYMODE_SCALE = 0, DISPLAYMODE_REAL }
SDK internal display interface display mode. More...
enum | emAeExpMode { AE_EXP_MODE = 0, AE_FRAME_MODE }
Auto Exposure Mode. More...
enum emSettingPage {
SETTING_PAGE_DEVINFO = 0x01, SETTING_PAGE_IMG_SETTING = 0x02, SETTING_PAGE_EXP_SETTING = 0x04, SETTING_PAGE_AWB_SETTING = 0x08,
SETTING_PAGE_CROSS_LINE = 0x10, SETTING_PAGE_OUT_SETTING = 0x20, SETTING_PAGE_REL_SETTING = 0x40, SETTING_PAGE_GAMMA_SETTING = 0x80,
SETTING_PAGE_GIGE_SETTING = 0x100, SETTING_PAGE_SPECIAL_SETTING = 0x200, SETTING_PAGE_ALL = 0xFFFFFF
}
The mask of the TAB page displayed in the device property settings dialog. More...
enum | emSdkLutChannel { LUT_CHANNEL_ALL = 0, LUT_CHANNEL_RED, LUT_CHANNEL_GREEN, LUT_CHANNEL_BLUE }
LUT color channel. More...
enum | emSdkLutMode { GAMMA_DYNAMIC_MODE = 0, GAMMA_PRESET_MODE, GAMMA_USER_MODE }
LUT mode. More...
enum | emSdkOutputIOMode { IOMODE_STROBE_OUTPUT = 0, IOMODE_GP_OUTPUT, IOMODE_PWM_OUTPUT }
IO output mode. More...
enum | emSdkInputIOMode { IOMODE_TRIG_INPUT = 0, IOMODE_GP_INPUT }
IO input mode. More...
enum | emImageTransferMode { TRANSFER_NEWEST_IMAGE = 0, TRANSFER_OLDEST_IMAGE = 1, TRANSFER_IMAGE_ON_PASSIVE_MODE = 2, TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE = 3 }
Camera cache frame transfer mode. More...
enum | emRequestTransferCmd { REQUEST_TRANSFER_CURRENT_FRAME = 0, REQUEST_TRANSFER_NEXT_FRAME = 1, REQUEST_TRANSFER_LATEST_FRAME = 2 }
enum emSdkValueType {
IMAGE_CHANNEL_MASK = 0, LED_LIGHT, ENABLE_WDR, CONTROL_FOCUS_VALUE,
CONTROL_FOCUS_MIN_VALUE, CONTROL_FOCUS_MAX_VALUE, CONTROL_FOCUS_DEFAULT_VALUE, IS_SUPPORT_CONTROL_FOCUS,
IMAGE_CHANNEL_NUM, FRAME_OUTPUT_QUEUE_SIZE, FIND_ME
}
Set the type of parameter. More...
enum | emSdkExceptionType { EXCEPTION_DEV_DISCONNECT = 0, EXCEPTION_DEV_RECONNECT, EXCEPTION_VERSION_CHECK }
typedef enum emSdkValueType | emSdkValueType
Set the type of parameter. More...
typedef enum emSdkExceptionType | emSdkExceptionType

Macro Definition Documentation

◆ CROSSLINE_MAX_NUM

#define CROSSLINE_MAX_NUM 9

◆ FALSE

#define FALSE 0

◆ TRUE

#define TRUE 1

Typedef Documentation

◆ BOOL

typedef int BOOL

◆ BYTE

typedef uint8_t BYTE

◆ DisplayWindow

typedef struct _DisplayWindow DisplayWindow

Display window parameters.

◆ DWORD

typedef uint32_t DWORD

◆ FrameStatistic

typedef struct _FrameStatistic FrameStatistic

Frame rate statistics.

◆ HANDLE

typedef void* HANDLE

◆ HDC

typedef void* HDC

◆ HWND

typedef void* HWND

◆ INT

typedef int32_t INT

◆ LONG

typedef long LONG

◆ LPVOID

typedef void* LPVOID

◆ PHANDLE

typedef HANDLE* PHANDLE

◆ PstImageInfo

typedef struct _stImageInfo * PstImageInfo

◆ RECT

typedef struct tagRECT RECT

◆ stImageInfo

typedef struct _stImageInfo stImageInfo

Frame header information.

◆ TCHAR

typedef char TCHAR

◆ tContrastRange

typedef struct _tContrastRange tContrastRange

Contrast setting range.

◆ tDevEnumInfo

typedef struct _tDevEnumInfo tDevEnumInfo

Enumeration information.

◆ tDeviceCfg

typedef struct _tDeviceCfg tDeviceCfg

Device Capability Level.

◆ tDevInfo

typedef struct _tDevInfo tDevInfo

Camera device information.

◆ tDevLoadInfo

typedef struct _tDevLoadInfo tDevLoadInfo

Current mode and enumeration information for the device.

◆ tDevLoadMode

typedef struct _tDevLoadMode tDevLoadMode

Device loading mode information.

◆ tExpose

typedef struct _tExpose tExpose

Camera exposure function range definition.

◆ tGammaContrastRange

typedef struct _tGammaContrastRange tGammaContrastRange

Gamma contrast setting range.

◆ tGammaRange

typedef struct _tGammaRange tGammaRange

Gamma setting range.

◆ tGigeNetworkInfo

typedef struct _tGigeNetworkInfo tGigeNetworkInfo

Network information of GigE camera.

◆ tInitCameraParam

typedef struct _tInitCameraParam tInitCameraParam

When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera.

end of CK_IMAGE_FORMAT_DEFINE

◆ tIspAe

typedef struct _tIspAe tIspAe

Exposure parameters.

◆ tIspGamma

typedef struct _tIspGamma tIspGamma

Gama parameter.

◆ tIspWb

typedef struct _tIspWb tIspWb

White balance parameter.

◆ tLscCalibParam

typedef struct _tLscCalibParam tLscCalibParam

LSC calibration parameter.

◆ tLscCorrectParam

typedef struct _tLscCorrectParam tLscCorrectParam

LSC correction parameter.

◆ tResolutionRange

typedef struct _tResolutionRange tResolutionRange

Camera resolution setting range for widget UI.

◆ tRgbGainRange

typedef struct _tRgbGainRange tRgbGainRange

RGB three-channel digital gain setting range.

◆ tSaturationRange

typedef struct _tSaturationRange tSaturationRange

Range of saturation setting.

◆ tSdkAeAlgorithm

typedef struct _tSdkAeAlgorithm tSdkAeAlgorithm

AE algorithm description.

◆ tSdkBayerDecodeAlgorithm

typedef struct _tSdkBayerDecodeAlgorithm tSdkBayerDecodeAlgorithm

RAW to RGB algorithm description.

◆ tSdkBayerType

typedef struct _tSdkBayerType tSdkBayerType

Image data format output by the camera.

◆ tSdkCameraCapbility

typedef struct _tSdkCameraCapbility tSdkCameraCapbility

Camera Ability Level.

◆ tSdkColorTemperatureDes

typedef struct _tSdkColorTemperatureDes tSdkColorTemperatureDes

Camera white balance color temperature mode description information.

◆ tSdkFrameSpeed

typedef struct _tSdkFrameSpeed tSdkFrameSpeed

Camera frame rate description information.

◆ tSdkImageResolution

typedef struct _tSdkImageResolution tSdkImageResolution

Camera resolution description.

◆ tSdkIspCapacity

typedef struct _tSdkIspCapacity tSdkIspCapacity

ISP module enable information.

◆ tSdkMediaType

typedef struct _tSdkMediaType tSdkMediaType

Image data format output by the camera.

◆ tSdkPackLength

typedef struct _tSdkPackLength tSdkPackLength

Transfer packet size description (mainly valid for web cameras)

◆ tSdkPresetLut

typedef struct _tSdkPresetLut tSdkPresetLut

Preset LUT table description.

◆ tSdkTrigger

typedef struct _tSdkTrigger tSdkTrigger

Trigger Mode Description.

◆ tSensorCfg

typedef struct _tSensorCfg tSensorCfg

sensor level

◆ tSharpnessRange

typedef struct _tSharpnessRange tSharpnessRange

Sharpening setting range.

◆ UINT

typedef uint32_t UINT

◆ UINT64

typedef uint64_t UINT64

◆ USHORT

typedef unsigned short USHORT

◆ WCHAR

typedef uint16_t WCHAR

◆ WORD

typedef uint16_t WORD


CKCameraAPI: Image format definition

Image format definition
#define | CAMERA_MEDIA_TYPE_MONO 0x01000000
#define | CAMERA_MEDIA_TYPE_RGB 0x02000000
#define | CAMERA_MEDIA_TYPE_COLOR 0x02000000
#define | CAMERA_MEDIA_TYPE_OCCUPY1BIT 0x00010000
#define | CAMERA_MEDIA_TYPE_OCCUPY2BIT 0x00020000
#define | CAMERA_MEDIA_TYPE_OCCUPY4BIT 0x00040000
#define | CAMERA_MEDIA_TYPE_OCCUPY8BIT 0x00080000
#define | CAMERA_MEDIA_TYPE_OCCUPY10BIT 0x000A0000
#define | CAMERA_MEDIA_TYPE_OCCUPY12BIT 0x000C0000
#define | CAMERA_MEDIA_TYPE_OCCUPY16BIT 0x00100000
#define | CAMERA_MEDIA_TYPE_OCCUPY24BIT 0x00180000
#define | CAMERA_MEDIA_TYPE_OCCUPY32BIT 0x00200000
#define | CAMERA_FORMAT_BAYGR8 0x00000008
#define | CAMERA_FORMAT_BAYGR12 0x00000010
#define | CAMERA_FORMAT_RGB 0x00000014
#define | CAMERA_FORMAT_BGR 0x00000015
#define | CAMERA_FORMAT_MONO 0x00000000
#define | CAMERA_MEDIA_TYPE_COLOR_MASK 0xFF000000
#define | CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK 0x00FF0000
#define | CAMERA_MEDIA_TYPE_ID_MASK 0x0000FFFF
#define | CAMERA_MEDIA_TYPE_MEDIA_FORMAT 0x000000FF
#define | CAMERA_MEDIA_TYPE_BAYGR8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0008)
#define | CAMERA_MEDIA_TYPE_BAYRG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0009)
#define | CAMERA_MEDIA_TYPE_BAYGB8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000A)
#define | CAMERA_MEDIA_TYPE_BAYBG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000B)
#define | CAMERA_MEDIA_TYPE_BAYGR10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000C)
#define | CAMERA_MEDIA_TYPE_BAYRG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000D)
#define | CAMERA_MEDIA_TYPE_BAYGB10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000E)
#define | CAMERA_MEDIA_TYPE_BAYBG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000F)
#define | CAMERA_MEDIA_TYPE_BAYGR12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0010)
#define | CAMERA_MEDIA_TYPE_BAYRG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0011)
#define | CAMERA_MEDIA_TYPE_BAYGB12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0012)
#define | CAMERA_MEDIA_TYPE_BAYBG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0013)
#define | CAMERA_MEDIA_TYPE_BAYGR10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0026)
#define | CAMERA_MEDIA_TYPE_BAYRG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0027)
#define | CAMERA_MEDIA_TYPE_BAYGB10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0028)
#define | CAMERA_MEDIA_TYPE_BAYBG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0029)
#define | CAMERA_MEDIA_TYPE_BAYGR12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002A)
#define | CAMERA_MEDIA_TYPE_BAYRG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002B)
#define | CAMERA_MEDIA_TYPE_BAYGB12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002C)
#define | CAMERA_MEDIA_TYPE_BAYBG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002D)
#define | CAMERA_MEDIA_TYPE_BAYGR16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002E)
#define | CAMERA_MEDIA_TYPE_BAYRG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002F)
#define | CAMERA_MEDIA_TYPE_BAYGB16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0030)
#define | CAMERA_MEDIA_TYPE_BAYBG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0031)
#define | CAMERA_MEDIA_TYPE_RGB8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_RGB)
#define | CAMERA_MEDIA_TYPE_BGR8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_BGR)
#define | CAMERA_MEDIA_TYPE_RGBA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_RGB)
#define | CAMERA_MEDIA_TYPE_BGRA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_BGR)
#define | CAMERA_MEDIA_TYPE_YUV411_8_UYYVYY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x001E)
#define | CAMERA_MEDIA_TYPE_YUV422_8_UYVY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x001F)
#define | CAMERA_MEDIA_TYPE_YUV422_8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0032)
#define | CAMERA_MEDIA_TYPE_YUV8_UYV (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x0020)
#define | CAMERA_MEDIA_TYPE_YCBCR8_CBYCR (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x003A)
#define | CAMERA_MEDIA_TYPE_MONO8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0000)
#define | CAMERA_MEDIA_TYPE_MONO8_SIGNED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0002)
#define | CAMERA_MEDIA_TYPE_MONO10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0003)
#define | CAMERA_MEDIA_TYPE_MONO10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0004)
#define | CAMERA_MEDIA_TYPE_MONO12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0005)
#define | CAMERA_MEDIA_TYPE_MONO12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0006)
#define | CAMERA_MEDIA_TYPE_MONO14 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0025)
#define | CAMERA_MEDIA_TYPE_MONO16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0007)

Detailed Description

Macro Definition Documentation

◆ CAMERA_FORMAT_BAYGR12

#define CAMERA_FORMAT_BAYGR12 0x00000010

◆ CAMERA_FORMAT_BAYGR8

#define CAMERA_FORMAT_BAYGR8 0x00000008

◆ CAMERA_FORMAT_BGR

#define CAMERA_FORMAT_BGR 0x00000015

◆ CAMERA_FORMAT_MONO

#define CAMERA_FORMAT_MONO 0x00000000

◆ CAMERA_FORMAT_RGB

#define CAMERA_FORMAT_RGB 0x00000014

◆ CAMERA_MEDIA_TYPE_BAYBG10

#define CAMERA_MEDIA_TYPE_BAYBG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000F)

◆ CAMERA_MEDIA_TYPE_BAYBG10_PACKED

#define CAMERA_MEDIA_TYPE_BAYBG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0029)

◆ CAMERA_MEDIA_TYPE_BAYBG12

#define CAMERA_MEDIA_TYPE_BAYBG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0013)

◆ CAMERA_MEDIA_TYPE_BAYBG12_PACKED

#define CAMERA_MEDIA_TYPE_BAYBG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002D)

◆ CAMERA_MEDIA_TYPE_BAYBG16

#define CAMERA_MEDIA_TYPE_BAYBG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0031)

◆ CAMERA_MEDIA_TYPE_BAYBG8

#define CAMERA_MEDIA_TYPE_BAYBG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000B)

◆ CAMERA_MEDIA_TYPE_BAYGB10

#define CAMERA_MEDIA_TYPE_BAYGB10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000E)

◆ CAMERA_MEDIA_TYPE_BAYGB10_PACKED

#define CAMERA_MEDIA_TYPE_BAYGB10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0028)

◆ CAMERA_MEDIA_TYPE_BAYGB12

#define CAMERA_MEDIA_TYPE_BAYGB12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0012)

◆ CAMERA_MEDIA_TYPE_BAYGB12_PACKED

#define CAMERA_MEDIA_TYPE_BAYGB12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002C)

◆ CAMERA_MEDIA_TYPE_BAYGB16

#define CAMERA_MEDIA_TYPE_BAYGB16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0030)

◆ CAMERA_MEDIA_TYPE_BAYGB8

#define CAMERA_MEDIA_TYPE_BAYGB8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000A)

◆ CAMERA_MEDIA_TYPE_BAYGR10

#define CAMERA_MEDIA_TYPE_BAYGR10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000C)

◆ CAMERA_MEDIA_TYPE_BAYGR10_PACKED

#define CAMERA_MEDIA_TYPE_BAYGR10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0026)

◆ CAMERA_MEDIA_TYPE_BAYGR12

#define CAMERA_MEDIA_TYPE_BAYGR12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0010)

◆ CAMERA_MEDIA_TYPE_BAYGR12_PACKED

#define CAMERA_MEDIA_TYPE_BAYGR12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002A)

◆ CAMERA_MEDIA_TYPE_BAYGR16

#define CAMERA_MEDIA_TYPE_BAYGR16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002E)

◆ CAMERA_MEDIA_TYPE_BAYGR8

#define CAMERA_MEDIA_TYPE_BAYGR8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0008)

◆ CAMERA_MEDIA_TYPE_BAYRG10

#define CAMERA_MEDIA_TYPE_BAYRG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000D)

◆ CAMERA_MEDIA_TYPE_BAYRG10_PACKED

#define CAMERA_MEDIA_TYPE_BAYRG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0027)

◆ CAMERA_MEDIA_TYPE_BAYRG12

#define CAMERA_MEDIA_TYPE_BAYRG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0011)

◆ CAMERA_MEDIA_TYPE_BAYRG12_PACKED

#define CAMERA_MEDIA_TYPE_BAYRG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002B)

◆ CAMERA_MEDIA_TYPE_BAYRG16

#define CAMERA_MEDIA_TYPE_BAYRG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002F)

◆ CAMERA_MEDIA_TYPE_BAYRG8

#define CAMERA_MEDIA_TYPE_BAYRG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0009)

◆ CAMERA_MEDIA_TYPE_BGR8

#define CAMERA_MEDIA_TYPE_BGR8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_BGR)

◆ CAMERA_MEDIA_TYPE_BGRA8

#define CAMERA_MEDIA_TYPE_BGRA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_BGR)

◆ CAMERA_MEDIA_TYPE_COLOR

#define CAMERA_MEDIA_TYPE_COLOR 0x02000000

◆ CAMERA_MEDIA_TYPE_COLOR_MASK

#define CAMERA_MEDIA_TYPE_COLOR_MASK 0xFF000000

◆ CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK

#define CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK 0x00FF0000

◆ CAMERA_MEDIA_TYPE_ID_MASK

#define CAMERA_MEDIA_TYPE_ID_MASK 0x0000FFFF

◆ CAMERA_MEDIA_TYPE_MEDIA_FORMAT

#define CAMERA_MEDIA_TYPE_MEDIA_FORMAT 0x000000FF

◆ CAMERA_MEDIA_TYPE_MONO

#define CAMERA_MEDIA_TYPE_MONO 0x01000000

◆ CAMERA_MEDIA_TYPE_MONO10

#define CAMERA_MEDIA_TYPE_MONO10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0003)

◆ CAMERA_MEDIA_TYPE_MONO10_PACKED

#define CAMERA_MEDIA_TYPE_MONO10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0004)

◆ CAMERA_MEDIA_TYPE_MONO12

#define CAMERA_MEDIA_TYPE_MONO12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0005)

◆ CAMERA_MEDIA_TYPE_MONO12_PACKED

#define CAMERA_MEDIA_TYPE_MONO12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0006)

◆ CAMERA_MEDIA_TYPE_MONO14

#define CAMERA_MEDIA_TYPE_MONO14 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0025)

◆ CAMERA_MEDIA_TYPE_MONO16

#define CAMERA_MEDIA_TYPE_MONO16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0007)

◆ CAMERA_MEDIA_TYPE_MONO8

#define CAMERA_MEDIA_TYPE_MONO8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0000)

◆ CAMERA_MEDIA_TYPE_MONO8_SIGNED

#define CAMERA_MEDIA_TYPE_MONO8_SIGNED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0002)

◆ CAMERA_MEDIA_TYPE_OCCUPY10BIT

#define CAMERA_MEDIA_TYPE_OCCUPY10BIT 0x000A0000

◆ CAMERA_MEDIA_TYPE_OCCUPY12BIT

#define CAMERA_MEDIA_TYPE_OCCUPY12BIT 0x000C0000

◆ CAMERA_MEDIA_TYPE_OCCUPY16BIT

#define CAMERA_MEDIA_TYPE_OCCUPY16BIT 0x00100000

◆ CAMERA_MEDIA_TYPE_OCCUPY1BIT

#define CAMERA_MEDIA_TYPE_OCCUPY1BIT 0x00010000

◆ CAMERA_MEDIA_TYPE_OCCUPY24BIT

#define CAMERA_MEDIA_TYPE_OCCUPY24BIT 0x00180000

◆ CAMERA_MEDIA_TYPE_OCCUPY2BIT

#define CAMERA_MEDIA_TYPE_OCCUPY2BIT 0x00020000

◆ CAMERA_MEDIA_TYPE_OCCUPY32BIT

#define CAMERA_MEDIA_TYPE_OCCUPY32BIT 0x00200000

◆ CAMERA_MEDIA_TYPE_OCCUPY4BIT

#define CAMERA_MEDIA_TYPE_OCCUPY4BIT 0x00040000

◆ CAMERA_MEDIA_TYPE_OCCUPY8BIT

#define CAMERA_MEDIA_TYPE_OCCUPY8BIT 0x00080000

◆ CAMERA_MEDIA_TYPE_RGB

#define CAMERA_MEDIA_TYPE_RGB 0x02000000

◆ CAMERA_MEDIA_TYPE_RGB8

#define CAMERA_MEDIA_TYPE_RGB8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_RGB)

◆ CAMERA_MEDIA_TYPE_RGBA8

#define CAMERA_MEDIA_TYPE_RGBA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_RGB)

◆ CAMERA_MEDIA_TYPE_YCBCR8_CBYCR

#define CAMERA_MEDIA_TYPE_YCBCR8_CBYCR (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x003A)

◆ CAMERA_MEDIA_TYPE_YUV411_8_UYYVYY

#define CAMERA_MEDIA_TYPE_YUV411_8_UYYVYY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x001E)

◆ CAMERA_MEDIA_TYPE_YUV422_8

#define CAMERA_MEDIA_TYPE_YUV422_8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0032)

◆ CAMERA_MEDIA_TYPE_YUV422_8_UYVY

#define CAMERA_MEDIA_TYPE_YUV422_8_UYVY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x001F)

◆ CAMERA_MEDIA_TYPE_YUV8_UYV

#define CAMERA_MEDIA_TYPE_YUV8_UYV (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x0020)


CKCameraAPI: SDK interface function

Modules
SDK interface function

Modules

Get a list of camera devices
Open or Close camera
Device information
Get image data
Camera play and pause
Display preview image
Exposure and gain settings
White balance settings
GAMMA settings
Image process
Trigger Settings
Saving and loading camera parameters
User data
Version information
Set property page
Save Image
Mirror and rotate
IO settings
Advanced settings
ROI settings
GigE settings
Record settings

Detailed Description

Generated by doxygen 1.8.14


CKCameraAPI: Get a list of camera devices

Functions
Get a list of camera devices
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraEnumerateDevice (INT *pDeviceNum)
enumerates devices and builds a list of devices. This function must be called to get information about the device before calling CameraInit. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetEnumIndexInfo (INT CameraIndex, tDevEnumInfo *pDevInfo)
Get information about the specified device. More...

Detailed Description

Function Documentation

◆ CameraEnumerateDevice()

CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDevice ( INT * pDeviceNum )

enumerates devices and builds a list of devices. This function must be called to get information about the device before calling CameraInit.

Parameters
[out] pDeviceNum The number of devices in the pDeviceNum device. When the function returns, the number of devices actually found is saved.
Returns
Status Code
Note
Use this function to get all the devices currently queried, and return the number of devices actually found.

◆ CameraGetEnumIndexInfo()

CKSDK_API CameraSdkStatus __stdcall CameraGetEnumIndexInfo | ( | INT | CameraIndex,
 |  | tDevEnumInfo * | pDevInfo
 | ) |  |

Get information about the specified device.

Parameters
[in] | CameraIndex | camera label, obtained by CameraEnumerateDevice, select (0-DeviceNum-1)
[out] | pDevInfo | Pointer, which returns information about the device.
Returns
Status Code
Note
This function gets the number of device lists via CameraEnumerateDevice, determines the camera label to query the corresponding device information, the description information is returned in a structured manner, such as The camera name, model number, serial number, interface type, etc. will be listed in detail.


CKCameraAPI: Open or Close camera

Functions
Open or Close camera
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraInit (PHANDLE phCamera, INT CameraIndex)
Camera initialization. After the initialization is successful, you can call any other The camera-related operation interface defaults to the last time the parameter was exited. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx (PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx2 (PHANDLE phCamera, const char *pFriendlyName)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx3 (PHANDLE phCamera, const char *pCameraSN)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx4 (PHANDLE phCamera, const char *pCameraSN, const tInitCameraParam *pstInitCameraParam)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraUnInit (HANDLE hCamera)
Camera reverse initialization. Release resources. More...

Detailed Description

Function Documentation

◆ CameraInit()

CKSDK_API CameraSdkStatus __stdcall CameraInit | ( | PHANDLE | phCamera,
 |  | INT | CameraIndex
 | ) |  |

Camera initialization. After the initialization is successful, you can call any other The camera-related operation interface defaults to the last time the parameter was exited. Note that you need to call CameraEnumerateDevice to enumerate the camera first.

Parameters
[out] | phCamera | The handle pointer of the camera. After the initialization is successful, the pointer Return a valid handle to the camera when calling another camera When the relevant operation interface is used, the handle needs to be passed in, mainly Used for distinguishing between multiple cameras.
[in] | CameraIndex | camera label, obtained by CameraEnumerateDevice Number of devices, thus setting the camera label to be opened, select (0-DeviceNum-1)
Returns
Status Code
See also
CameraEnumerateDevice
Note
CameraInit Just pass the camera's serial number, for example, initialize the first camera, pass in 0, the second camera will pass in 1, and so on.

◆ CameraInitEx()

CKSDK_API CameraSdkStatus __stdcall CameraInitEx | ( | PHANDLE | phCamera,
 |  | INT | CameraIndex,
 |  | INT | iParamLoadMode,
 |  | INT | emTeam
 | ) |  |

Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. Note that you need to call CameraEnumerateDevice to enumerate the camera first.

Parameters
[out] | phCamera | The handle pointer of the camera. After the initialization is successful, the pointer Return a valid handle to the camera when calling another camera When the relevant operation interface is used, the handle needs to be passed in, which is mainly used for distinguishing between multiple cameras.
[in] | CameraIndex | camera label, obtained by CameraEnumerateDevice Number of devices, thus setting the camera label to be opened, select (0-DeviceNum-1)
[in] | iParamLoadMode | The parameter loading method used when the camera is initialized. -1 indicates the saved loading method when using the last exit. For emSdkParameterMode::PARAM_MODE_BY_MODEL means to load by model; For emSdkParameterMode::PARAM_MODE_BY_SN means to load by serial number; For emSdkParameterMode::PARAM_MODE_BY_NAME means to load by nickname.
[in] | emTeam | The parameter group used by emTeam for initialization. -1 means to use the parameter group saved on the last exit, find the file that needs to load parameters through iParamLoadMode and emTeam If the corresponding file is not found, it is loaded by default loading method.
Returns
Status Code
See also
CameraEnumerateDevice
Note
CameraInitEx not only to pass the camera's serial number ID, but also to pass in the parameter plus Load mode and group, initialize the corresponding parameters, when iParamLoadMode and emTeam are both -1, use the parameter group saved on the last exit, through iParamLoadMode and emTeam finds the file that needs to load the parameter. If the corresponding file is not found, it is loaded by default loading method.

◆ CameraInitEx2()

CKSDK_API CameraSdkStatus __stdcall CameraInitEx2 | ( | PHANDLE | phCamera,
 |  | const char * | pFriendlyName
 | ) |  |

Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first.

Parameters
[in] | phCamera | The handle pointer of the camera. After the initialization is successful, the pointer Return a valid handle to the camera when calling another camera When the relevant operation interface is used, the handle needs to be passed in, mainly Used for distinguishing between multiple cameras.
[in] | pFriendlyName | Camera nickname, used to find cameras with the same nickname, up to 32 bytes in length
Returns
Status Code
See also
CameraEnumerateDevice
CameraGetEnumIndexInfo
Note
CameraInitEx2 does not need to pass the camera's serial ID, just the name of the camera Said that since the camera's nickname is the same at the factory, it needs to pass in advance. CameraSetFriendlyName function changes the camera name to "MyCamera1", When CameraInitEx2 is called, you can pass "MyCamera1" and work for multiple cameras at the same time. Case, this method can effectively establish one-to-one correspondence, but pay attention to each The names of the cameras must be changed to be different to ensure uniqueness.

◆ CameraInitEx3()

CKSDK_API CameraSdkStatus __stdcall CameraInitEx3 | ( | PHANDLE | phCamera,
 |  | const char * | pCameraSN
 | ) |  |

Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first.

Parameters
[out] | phCamera | The handle pointer of the camera. After the initialization is successful, the pointer Return a valid handle to the camera when calling another camera When the relevant operation interface is used, the handle needs to be passed in, mainly Used for distinguishing between multiple cameras.
[in] | pCameraSN | camera SN code, used to find the same camera as SN, and is the only camera with a maximum byte length of 32 bytes You can get the information of the corresponding SN code by calling CameraGetEnumIndexInfo.
Returns
Status Code
See also
CameraEnumerateDevice
CameraGetEnumIndexInfo
Note
CameraInitEx3 does not need to pass in the camera's sequence ID, only need to pass the camera's SN Code, which can be obtained by calling CameraGetEnumIndexInfo, for multiple cameras working simultaneously For example, this method can effectively establish a one-to-one correspondence to ensure uniqueness.

◆ CameraInitEx4()

CKSDK_API CameraSdkStatus __stdcall CameraInitEx4 | ( | PHANDLE | phCamera,
 |  | const char * | pCameraSN,
 |  | const tInitCameraParam * | pstInitCameraParam
 | ) |  |

Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first.

Parameters
[out] | phCamera | The handle pointer of the camera. After the initialization is successful, the pointer Return a valid handle to the camera when calling another camera When the relevant operation interface is used, the handle needs to be passed in, mainly Used for distinguishing between multiple cameras.
[in] | pCameraSN | camera SN code, used to find the same camera as SN, and is the only camera with a maximum byte length of 32 bytes You can get the information of the corresponding SN code by calling CameraGetEnumIndexInfo.
[in] | pstInitCameraParam | camera initialization parameters, after setting parameters through this method, you no longer need to call the corresponding setting function separately for parameter setting, which can improve the speed of opening the camera
Returns
Status Code
See also
CameraEnumerateDevice
CameraGetEnumIndexInfo
Note
CameraInitEx3 does not need to pass in the camera's sequence ID, only need to pass the camera's SN Code, which can be obtained by calling CameraGetEnumIndexInfo, for multiple cameras working simultaneously For example, this method can effectively establish a one-to-one correspondence to ensure uniqueness.

◆ CameraUnInit()

CKSDK_API CameraSdkStatus __stdcall CameraUnInit ( HANDLE hCamera )

Camera reverse initialization. Release resources.

Parameters
[in] hCamera The handle of the camera, obtained by the CameraInit function
Returns
Status Code
See also
CameraInit
CameraInitEx
CameraInitEx2
CameraInitEx3
Note
Regardless of the initialization method used, the inverse initialization calls CameraUnInit.


CKCameraAPI: Device information

Typedefs | Functions
Device information
SDK interface function

Typedefs

typedef void(__stdcall * CAMERA_EXCEPTION_PROC) (HANDLE hCamera, emSdkExceptionType nMsgType, LPVOID lpParam)
Exception callback function definition. More...

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraRegisterExceptionCallback (HANDLE hCamera, CAMERA_EXCEPTION_PROC pExceptionCallback, LPVOID pUser)
CKSDK_API CameraSdkStatus __stdcall | CameraGetCapability (HANDLE hCamera, tSdkCameraCapbility *pCameraCap)
Get the camera's characterization structure. The structure contains a camera Range information for various parameters that can be set. Determine the parameters of the relevant function Back, can also be used to dynamically create a camera's configuration interface. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurDevInfo (HANDLE hCamera, tDevLoadInfo *pDevInfo)
Get enumerated information for the specified device. More...

Detailed Description

Typedef Documentation

◆ CAMERA_EXCEPTION_PROC

typedef void(__stdcall* CAMERA_EXCEPTION_PROC) (HANDLE hCamera, emSdkExceptionType nMsgType, LPVOID lpParam)

Exception callback function definition.

Function Documentation

◆ CameraGetCapability()

CKSDK_API CameraSdkStatus __stdcall CameraGetCapability | ( | HANDLE | hCamera,
 |  | tSdkCameraCapbility * | pCameraCap
 | ) |  |

Get the camera's characterization structure. The structure contains a camera Range information for various parameters that can be set. Determine the parameters of the relevant function Back, can also be used to dynamically create a camera's configuration interface.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pCameraCap | The pointer returns the structure described by the camera's characterization.
Returns
Status Code

◆ CameraGetCurDevInfo()

CKSDK_API CameraSdkStatus __stdcall CameraGetCurDevInfo | ( | HANDLE | hCamera,
 |  | tDevLoadInfo * | pDevInfo
 | ) |  |

Get enumerated information for the specified device.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pDevInfo | The pointer returns the enumeration information and status information of the device.
Returns
Status Code

◆ CameraRegisterExceptionCallback()

CKSDK_API CameraSdkStatus __stdcall CameraRegisterExceptionCallback | ( | HANDLE | hCamera,
 |  | CAMERA_EXCEPTION_PROC | pExceptionCallback,
 |  | LPVOID | pUser
 | ) |  |


CKCameraAPI: Get image data

Typedefs | Functions
Get image data
SDK interface function

Typedefs

typedef void(__stdcall * CAMERA_SNAP_PROC) (HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)
Callback function definition for image capture. More...

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraGetRawImageBuffer (HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes)
Gets a frame of image raw data. In order to improve efficiency, the SDK uses a zero copy mechanism for image capture. CameraGetRawImageBuffer is actually obtained as a buffer address in the kernel. After the function is successfully called, you must call CameraReleaseFrameHandle to let the kernel continue to use. The buffer. More...
CKSDK_API CameraSdkStatus __stdcall | CameraReleaseFrameHandle (HANDLE hCamera, HANDLE hRawBuf)
release buffer obtained by CameraGetRawImageBuffer More...
CKSDK_API BYTE *__stdcall | CameraGetImageInfo (HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo)
Get current frame image information. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageTimestamp (HANDLE hCamera, HANDLE hRawBuf, UINT64 *puTimestamp)
Gets the timestamp of the current frame in microseconds. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageBuffer (HANDLE hCamera, stImageInfo *pImgInfo, BYTE *pRawBuf, BYTE *pImgBuf)
processes the obtained camera raw output image data, superimposes saturation, Color gain and correction, noise reduction and other processing effects, the output format of the processed image Can be CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 One of them. More...
CKSDK_API BYTE *__stdcall | CameraGetImageBufferEx (HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes)
Gets a frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat After the function is called, the function returns the image data buffer. Applicable to active mode calls. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageBufferEx1 (HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT uTimes)
Gets a frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat After the function is called, the processed image data is placed in the provided buffer for active mode calls. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageBufferEx2 (HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes)
Gets one frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat. More...
CKSDK_API BYTE *__stdcall | CameraGetImageBufferEx3 (HANDLE hCamera, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes)
Gets one frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat. More...
CKSDK_API CameraSdkStatus __stdcall | CameraResetTimestamp (HANDLE hCamera)
Resets the timestamp of image acquisition, starting at 0. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCallbackFunction (HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld)
Sets the callback function for image capture. When a new image data frame is captured, the callback function pointed to by pCallBack is called. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetImageTransferMode (HANDLE hCamera, INT transferMode)
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageTransferMode (HANDLE hCamera, INT *pTransferMode)
CKSDK_API CameraSdkStatus __stdcall | CameraRequestTransferImage (HANDLE hCamera)
request to transmit a frame of image buffered in the camera More...
CameraSdkStatus __stdcall | CameraRequestTransferImageEx (HANDLE hCamera, int nCmd)
Request to transfer a frame of image in the camera cache, use nCmd to specify the location of the transferred image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSnapToBuffer (HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE **ppImgBuf, UINT uWaitTimeMs)
Capture an image into the buffer. The camera will enter the capture mode, and Automatically switch to the resolution of the capture mode for image capture. followed by The captured data is saved to the buffer. After the function is successfully called, you must call CameraReleaseFrameHandle Release the buffer obtained by CameraSnapToBuffer. Please refer to the specific The functional description section of the function. More...

Detailed Description

Typedef Documentation

◆ CAMERA_SNAP_PROC

typedef void(__stdcall* CAMERA_SNAP_PROC) (HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)

Callback function definition for image capture.

Function Documentation

◆ CameraGetImageBufferEx()

CKSDK_API BYTE* __stdcall CameraGetImageBufferEx | ( | HANDLE | hCamera,
 |  | stImageInfo * | pImgInfo,
 |  | UINT | uTimes
 | ) |  |

Gets a frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat After the function is called, the function returns the image data buffer. Applicable to active mode calls.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pImgInfo | structure, returning frame header information
[in] | uTimes | Timeout for capturing images. In milliseconds. in The function returns a timeout message if the image has not been obtained within wTimes.
Returns
Returns the first address of the RGB data buffer on success; otherwise returns NULL.
Warning
is different from CameraGetRawImageBuffer function, the function gets the press The output format outputs image data. No need to call later CameraGetOutImageBuffer function.

◆ CameraGetImageBufferEx1()

CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx1 | ( | HANDLE | hCamera,
 |  | BYTE * | pImageData,
 |  | stImageInfo * | pImgInfo,
 |  | UINT | uTimes
 | ) |  |

Gets a frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat After the function is called, the processed image data is placed in the provided buffer for active mode calls.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pImageData | image data buffer pointer
[out] | pImgInfo | structure, returning frame header information
[in] | uTimes | Timeout for capturing images. In milliseconds. in This function has not been obtained in wTimes time. A timeout message will be returned.
Returns
Status Code

◆ CameraGetImageBufferEx2()

CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx2 | ( | HANDLE | hCamera,
 |  | BYTE * | pImageData,
 |  | stImageInfo * | pImgInfo,
 |  | UINT64 * | puTimeStamp,
 |  | UINT | uTimes
 | ) |  |

Gets one frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat.

Parameters
[in] | hCamera | The handle of the camera.
[out] | pImageData | image data buffer pointer
[out] | pImgInfo | structure, returning frame header information
[out] | puTimeStamp | Returns the image timestamp in microseconds
[in] | uTimes | Timeout for capturing images. In milliseconds. If the image has not been obtained within wTimes, the function will return a timeout error.
Returns
Status Code
Note
does not need to call CameraReleaseFrameHandle

◆ CameraGetImageBufferEx3()

CKSDK_API BYTE* __stdcall CameraGetImageBufferEx3 | ( | HANDLE | hCamera,
 |  | stImageInfo * | pImgInfo,
 |  | UINT64 * | puTimeStamp,
 |  | UINT | uTimes
 | ) |  |

Gets one frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat.

Parameters
[in] | hCamera | The handle of the camera.
[out] | pImgInfo | structure, returning frame header information
[out] | puTimeStamp | Returns the image timestamp in microseconds
[in] | uTimes | Timeout for capturing images. In milliseconds. If the image has not been obtained within wTimes, the function will return a timeout error.
Returns
Returns the first address of the RGB data buffer on success; otherwise returns NULL.
Note
does not need to call CameraReleaseFrameHandle

◆ CameraGetImageInfo()

CKSDK_API BYTE* __stdcall CameraGetImageInfo | ( | HANDLE | hCamera,
 |  | HANDLE | hRawBuf,
 |  | stImageInfo * | pImgInfo
 | ) |  |

Get current frame image information.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | hRawBuf | Gets the buffer handle of the image's data via CameraGetRawImageBuffer.
[out] | pImgInfo | Get frame information
Returns
Return a pointer to the original image data
See also
CameraGetRawImageBuffer
CameraReleaseFrameHandle
Note
Get a frame of image handle by calling CameraGetRawImageBuffer The handle gets the image data buffer address, as well as the frame header information. After the initialization is complete, you can start the camera fetching work. According to the drawing method, the SDK Divided into active and passive (callback function).
  1. Active drawing mode After completing the camera initialization, you can use CameraGetRawImageBuffer The number and the CameraGetImageInfo function actively read the image, the difference between the two is that CameraGetRawImageBuffer function gets the original RAW data buffer, Need to use the CameraGetOutImageBuffer function to convert RAW data to the specified Data format, to be called after using the obtained buffer pointer CameraReleaseFrameHandle Release buffer usage rights, what needs to be explained is CameraReleaseFrameHandle Just released by CameraGetRawImageBuffer Get the right to use the data buffer, and do not repeatedly apply and release memory, no need to worry Efficiency problem; the specific format is determined by the input parameters, which can be 8-bit grayscale, or It is 24-bit, 32-bit color format data.
  2. Passive read mode (callback function) If you need to use the callback function for reading processing, you need to set it after the camera is initialized. Read the callback function of the graph.

◆ CameraGetImageTimestamp()

CKSDK_API CameraSdkStatus __stdcall CameraGetImageTimestamp | ( | HANDLE | hCamera,
 |  | HANDLE | hRawBuf,
 |  | UINT64 * | puTimestamp
 | ) |  |

Gets the timestamp of the current frame in microseconds.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | hRawBuf | Gets the buffer handle of the image's data via CameraGetRawImageBuffer.
[out] | puTimestamp | get timestamp
Returns
Status Code
See also
CameraGetRawImageBuffer

◆ CameraGetImageTransferMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetImageTransferMode | ( | HANDLE | hCamera,
 |  | INT * | pTransferMode
 | ) |  |

@ brief Get the transfer mode of the image cache in the camera @ param [in] hCamera camera handle, obtained by CameraInit function @ param [in] pTransferMode Image transfer mode emImageTransferMode @ return status code

◆ CameraGetOutImageBuffer()

CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageBuffer | ( | HANDLE | hCamera,
 |  | stImageInfo * | pImgInfo,
 |  | BYTE * | pRawBuf,
 |  | BYTE * | pImgBuf
 | ) |  |

processes the obtained camera raw output image data, superimposes saturation, Color gain and correction, noise reduction and other processing effects, the output format of the processed image Can be CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 One of them.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pImgInfo | Enter the header information of the image. After processing, the image format uiMediaType in the header information will change.
[in] | pRawBuf | Enter the buffer address of the image data, which cannot be NULL. Fill in the return value of the CameraGetImageInfo function.
[out] | pImgBuf | The buffer address of the image output after processing by pImgBuf cannot be NULL.
Returns
Status Code

◆ CameraGetRawImageBuffer()

CKSDK_API CameraSdkStatus __stdcall CameraGetRawImageBuffer | ( | HANDLE | hCamera,
 |  | PHANDLE | phRawBuf,
 |  | UINT | uTimes
 | ) |  |

Gets a frame of image raw data. In order to improve efficiency, the SDK uses a zero copy mechanism for image capture. CameraGetRawImageBuffer is actually obtained as a buffer address in the kernel. After the function is successfully called, you must call CameraReleaseFrameHandle to let the kernel continue to use. The buffer.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | phRawBuf | Gets the handle of the image's data.
[in] | uTimes | Timeout for capturing images. In milliseconds. If the image has not been obtained within mTimes, the function will return a timeout message.
Returns
Status Code
See also
CameraReleaseFrameHandle
Note
In general, industrial cameras transmit raw RAW data, for black and white cameras, It is grayscale image data, and for color cameras, it is image data in Bayer format. The CameraGetRawImageBuffer function gets the original RAW data, the default is 8bit. This function can set the timeout period, for example setting a timeout of 1000 milliseconds, then Within 1000 milliseconds, if a valid image is not obtained, the function will block and the thread will Suspended until more than 1000 milliseconds or read a valid image, so in the software structure In design, the user can create a thread that collects images and then keeps the graph Like collecting, you only need to set a reasonable timeout, or you need to collect images. Call the function once to get an image.
Warning
CameraGetRawImageBuffer needs to be used with CameraReleaseFrameHandle.

◆ CameraReleaseFrameHandle()

CKSDK_API CameraSdkStatus __stdcall CameraReleaseFrameHandle | ( | HANDLE | hCamera,
 |  | HANDLE | hRawBuf
 | ) |  |

release buffer obtained by CameraGetRawImageBuffer

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | hRawBuf | A buffer handle that points to the image's data via CameraGetRawImageBuffer.
Returns
Status Code
returns the buffer address of the frame data when successful
See also
CameraGetRawImageBuffer
CameraGetImageInfo

◆ CameraRequestTransferImage()

CKSDK_API CameraSdkStatus __stdcall CameraRequestTransferImage ( HANDLE hCamera )

request to transmit a frame of image buffered in the camera

Parameters
[in] hCamera The handle of the camera, obtained by CameraInit function
Returns
status code
Note
You need to use CameraSetImageTransferMode to set it to TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE mode before it can be used normally

◆ CameraRequestTransferImageEx()

CameraSdkStatus __stdcall CameraRequestTransferImageEx | ( | HANDLE | hCamera,
 |  | int | nCmd
 | ) |  |

Request to transfer a frame of image in the camera cache, use nCmd to specify the location of the transferred image.

Parameters
[in] | hCamera | The handle of the camera, obtained by CameraInit function
[in] | nCmd | request command to determine the position of the current frame being transferred, refer to emRequestTransferCmd
Returns
status code

◆ CameraResetTimestamp()

CKSDK_API CameraSdkStatus __stdcall CameraResetTimestamp ( HANDLE hCamera )

Resets the timestamp of image acquisition, starting at 0.

Parameters
[in] hCamera The handle of the camera.
Returns
Status Code

◆ CameraSetCallbackFunction()

CKSDK_API CameraSdkStatus __stdcall CameraSetCallbackFunction | ( | HANDLE | hCamera,
 |  | CAMERA_SNAP_PROC | pCallBack,
 |  | LPVOID | lpParam,
 |  | CAMERA_SNAP_PROC * | pCallbackOld
 | ) |  |

Sets the callback function for image capture. When a new image data frame is captured, the callback function pointed to by pCallBack is called.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pCallBack | callback function pointer.
[in] | lpParam | Additional parameters for the lpParam callback function, when the callback function is called This additional parameter will be passed in and can be NULL. Used mostly Carrying additional information when multiple cameras.
[out] | pCallbackOld | is used to save the current callback function. Can be NULL.
Returns
Status Code

◆ CameraSetImageTransferMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetImageTransferMode | ( | HANDLE | hCamera,
 |  | INT | transferMode
 | ) |  |

@ brief Set the transfer mode of the image cache in the camera @ param [in] hCamera camera handle, obtained by CameraInit function @ param [in] transferMode Image transfer mode emImageTransferMode @ return status code

◆ CameraSnapToBuffer()

CKSDK_API CameraSdkStatus __stdcall CameraSnapToBuffer | ( | HANDLE | hCamera,
 |  | PHANDLE | phBuf,
 |  | stImageInfo * | pImgInfo,
 |  | BYTE ** | ppImgBuf,
 |  | UINT | uWaitTimeMs
 | ) |  |

Capture an image into the buffer. The camera will enter the capture mode, and Automatically switch to the resolution of the capture mode for image capture. followed by The captured data is saved to the buffer. After the function is successfully called, you must call CameraReleaseFrameHandle Release the buffer obtained by CameraSnapToBuffer. Please refer to the specific The functional description section of the function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | phBuf | Pointer, the buffer handle that returns the data of the image. Used to release data, CameraReleaseFrameHandle
[out] | pImgInfo | pointer, returning the frame header information of the image
[out] | ppImgBuf | pointer, returning the data pointer of the image
[in] | uWaitTimeMs | Timeout in milliseconds. During this time, if there is still no data successfully captured, a timeout message is returned.
Returns
Status Code


CKCameraAPI: Camera play and pause

Functions
Camera play and pause
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraPause (HANDLE hCamera)
puts the SDK into pause mode and does not receive image data from the camera. It also sends a command to let the camera pause the output and release the transmission bandwidth. In the pause mode, the camera's parameters can be configured and take effect immediately. More...
CKSDK_API CameraSdkStatus __stdcall | CameraPlay (HANDLE hCamera)
puts the SDK into working mode and starts receiving images sent from the camera Data. If the current camera is in trigger mode, you need to receive it. The image will not be updated until the frame is triggered. More...

Detailed Description

Function Documentation

◆ CameraPause()

CKSDK_API CameraSdkStatus __stdcall CameraPause ( HANDLE hCamera )

puts the SDK into pause mode and does not receive image data from the camera. It also sends a command to let the camera pause the output and release the transmission bandwidth. In the pause mode, the camera's parameters can be configured and take effect immediately.

Parameters
[in] hCamera The handle of the camera, obtained by the CameraInit function
Returns
Status Code
See also
CameraPlay

◆ CameraPlay()

CKSDK_API CameraSdkStatus __stdcall CameraPlay ( HANDLE hCamera )

puts the SDK into working mode and starts receiving images sent from the camera Data. If the current camera is in trigger mode, you need to receive it. The image will not be updated until the frame is triggered.

Parameters
[in] hCamera The handle of the camera, obtained by the CameraInit function
Returns
Status Code
See also
CameraPause


CKCameraAPI: Display preview image

Typedefs | Functions
Display preview image
SDK interface function

Typedefs

typedef void(__stdcall * CAMERA_DISPLAY_PROC) (HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
Image display callback function. More...

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraDisplayInit (HANDLE hCamera, HWND hWndDisplay)
Initializes the display module inside the SDK. Call CameraDisplay This function must be called before initialization. If you are in secondary development, Use your own way to display images (without calling CameraDisplay), You do not need to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayMode (HANDLE hCamera, INT iMode)
Sets the mode of display. Must call CameraDisplayInit This function can be called by initializing. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayScaleRadio (HANDLE hCamera, INT iRadio)
Sets the zoom ratio of the display. Only when the display mode is emSdkDisplayMode::DISPLAYMODE_REAL It is valid. For example, 100 is the display window and the image window is 1:1, 200 is the display window and the image window is 2:1. 50 is the display window and image window is 0.5:1, so the value is the magnification X100, must be called CameraDisplayInit is initialized to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayOffset (HANDLE hCamera, INT iOffsetX, INT iOffsetY)
Sets the starting offset value for the display. Only when the display mode is emSdkDisplayMode::DISPLAYMODE_REAL It is valid. For example, the size of the display control is 320X240, while the image The size is 640X480, then when iOffsetX = 160, iOffsetY = 120 The area shown is the center of the image at 320X240. Must be called CameraDisplayInit is initialized to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplaySize (HANDLE hCamera, INT iWidth, INT iHeight)
Sets the size of the display control. Must be called CameraDisplayInit is initialized to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCrossLine (HANDLE hCamera, INT iLine, INT x, INT y, UINT uColor, BOOL bVisible)
Sets the parameters for the specified crosshair. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCrossLine (HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible)
Gets the status of the specified crosshair. More...
CKSDK_API CameraSdkStatus __stdcall | CameraImageOverlay (HANDLE hCamera, BYTE *pImgBuf, const stImageInfo *pImgInfo)
superimposes the input image data on the crosshair, white balance reference window, Auto exposure reference window and other graphics. Only set to visible Crosshairs and reference windows can be superimposed. Note that the input image for this function must be in RGB format. More...
CKSDK_API CameraSdkStatus __stdcall | CameraDrawText (BYTE *pImgBuf, const stImageInfo *pImgInfo, char const *pFontFileName, UINT FontWidth, UINT FontHeight, char const *pText, INT Left, INT Top, UINT Width, UINT Height, UINT TextColor, UINT uFlags)
draws text in the input image data More...
CKSDK_API CameraSdkStatus __stdcall | CameraDisplay (HANDLE hCamera, BYTE *pImgBuf, stImageInfo *pImgInfo)
displays the image. You must call CameraDisplayInit to initialize this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayCallbackFun (HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld)
Sets the display callback. Must be called CameraDisplayInit This function can be called by initialization, and when displaying image data frames, The callback function pointed to by pCallBack will be called. More...

Detailed Description

In order to simplify the process of secondary development of the user, the SDK internally encapsulates some interface functions. Image preview is possible, provided that the VS-related tools must be used for the interface to open hair. After the camera is initialized, the following code is called to complete the initialization of the display part. CameraDisplayInit The hWnd handle passed to the window. Different development tools, there are Different ways to get the hWnd handle of the display control.

Typedef Documentation

◆ CAMERA_DISPLAY_PROC

typedef void(__stdcall* CAMERA_DISPLAY_PROC) (HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)

Image display callback function.

Function Documentation

◆ CameraDisplay()

CKSDK_API CameraSdkStatus __stdcall CameraDisplay | ( | HANDLE | hCamera,
 |  | BYTE * | pImgBuf,
 |  | stImageInfo * | pImgInfo
 | ) |  |

displays the image. You must call CameraDisplayInit to initialize this function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pImgBuf | The data buffer for the pImgBuf image.
[in] | pImgInfo | The header information of the image.
Returns
Status Code

◆ CameraDisplayInit()

CKSDK_API CameraSdkStatus __stdcall CameraDisplayInit | ( | HANDLE | hCamera,
 |  | HWND | hWndDisplay
 | ) |  |

Initializes the display module inside the SDK. Call CameraDisplay This function must be called before initialization. If you are in secondary development, Use your own way to display images (without calling CameraDisplay), You do not need to call this function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | hWndDisplay | The handle of the display window, typically the m_hWnd member of the window.
Returns
Status Code
See also
CameraDisplay
Warning
must be called to initialize the function before calling CameraDisplay. in case In the second development, you use your own way to display the image (do not call CameraDisplay), you do not need to call CameraDisplayInit function.

◆ CameraDrawText()

CKSDK_API CameraSdkStatus __stdcall CameraDrawText | ( | BYTE * | pImgBuf,
 |  | const stImageInfo * | pImgInfo,
 |  | char const * | pFontFileName,
 |  | UINT | FontWidth,
 |  | UINT | FontHeight,
 |  | char const * | pText,
 |  | INT | Left,
 |  | INT | Top,
 |  | UINT | Width,
 |  | UINT | Height,
 |  | UINT | TextColor,
 |  | UINT | uFlags
 | ) |  |

draws text in the input image data

Parameters
[in] | pImgBuf | image data buffer
[in] | pImgInfo | image header information
[in] | pFontFileName | font file name
[in] | FontWidth | font width
[in] | FontHeight | font height
[in] | pText | The text to be output
[in] | Left | left coordinate of the file output rectangle
[in] | Top | The upper coordinate of the file output rectangle
[in] | Width | The width of the output rectangle of the file
[in] | Height | The height of the file output rectangle
[in] | TextColor | text color RGB
[in] | uFlags | output flag, not used yet, fill in 0
Returns
Status Code

◆ CameraGetCrossLine()

CKSDK_API CameraSdkStatus __stdcall CameraGetCrossLine | ( | HANDLE | hCamera,
 |  | INT | iLine,
 |  | INT * | px,
 |  | INT * | py,
 |  | UINT * | puColor,
 |  | BOOL * | pbVisible
 | ) |  |

Gets the status of the specified crosshair.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iLine | indicates the status of the first crosshairs to be acquired. The range is [0,8], a total of 9.
[out] | px | The pointer returns the abscissa of the center of the crosshair.
[out] | py | The pointer returns the abscissa of the center of the crosshair.
[out] | puColor | The ointer returns the color of the crosshair, in the format (R|(G<<8)|(B<<16)).
[out] | pbVisible | The pointer returning TRUE, indicates that the crosshair is visible.
Returns
Status Code

◆ CameraImageOverlay()

CKSDK_API CameraSdkStatus __stdcall CameraImageOverlay | ( | HANDLE | hCamera,
 |  | BYTE * | pImgBuf,
 |  | const stImageInfo * | pImgInfo
 | ) |  |

superimposes the input image data on the crosshair, white balance reference window, Auto exposure reference window and other graphics. Only set to visible Crosshairs and reference windows can be superimposed. Note that the input image for this function must be in RGB format.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pImgBuf | Image data buffer.
[in] | pImgInfo | The header information of the image.
Returns
Status Code

◆ CameraSetCrossLine()

CKSDK_API CameraSdkStatus __stdcall CameraSetCrossLine | ( | HANDLE | hCamera,
 |  | INT | iLine,
 |  | INT | x,
 |  | INT | y,
 |  | UINT | uColor,
 |  | BOOL | bVisible
 | ) |  |

Sets the parameters for the specified crosshair.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iLine | indicates the state of the first crosshairs to be set. The range is [0,8], a total of 9.
[in] | x | The abscissa value of the center of the crosshair.
[in] | y | The ordinate value of the center of the crosshair.
[in] | uColor | The color of the crosshair, in the format (R|(G<<8)|(B<<16))
[in] | bVisible | The display status of the crosshairs. TRUE, indicating display. Only the crosshair set to the display state is called CameraImageOverlay will be superimposed on the image.
Returns
Status Code

◆ CameraSetDisplayCallbackFun()

CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayCallbackFun | ( | HANDLE | hCamera,
 |  | CAMERA_DISPLAY_PROC | pCallBack,
 |  | LPVOID | lpParam,
 |  | CAMERA_DISPLAY_PROC * | pCallbackOld
 | ) |  |

Sets the display callback. Must be called CameraDisplayInit This function can be called by initialization, and when displaying image data frames, The callback function pointed to by pCallBack will be called.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pCallBack | callback function pointer.
[in] | lpParam | Additional parameters for the lpParam callback function, when the callback function is called This additional parameter will be passed in and can be NULL.
[out] | pCallbackOld | is used to save the current callback function. Can be NULL.
Returns
Status Code

◆ CameraSetDisplayMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayMode | ( | HANDLE | hCamera,
 |  | INT | iMode
 | ) |  |

Sets the mode of display. Must call CameraDisplayInit This function can be called by initializing.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iMode | display mode, emSdkDisplayMode::DISPLAYMODE_SCALE or emSdkDisplayMode::DISPLAYMODE_REAL, See the definition of emSdkDisplayMode in CKDeviceDef.h for details.
Returns
Status Code

◆ CameraSetDisplayOffset()

CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayOffset | ( | HANDLE | hCamera,
 |  | INT | iOffsetX,
 |  | INT | iOffsetY
 | ) |  |

Sets the starting offset value for the display. Only when the display mode is emSdkDisplayMode::DISPLAYMODE_REAL It is valid. For example, the size of the display control is 320X240, while the image The size is 640X480, then when iOffsetX = 160, iOffsetY = 120 The area shown is the center of the image at 320X240. Must be called CameraDisplayInit is initialized to call this function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iOffsetX | The X coordinate of the iOffsetX offset.
[in] | iOffsetY | The Y coordinate of the offset of iOffsetY.
Returns
Status Code

◆ CameraSetDisplayScaleRadio()

CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayScaleRadio | ( | HANDLE | hCamera,
 |  | INT | iRadio
 | ) |  |

Sets the zoom ratio of the display. Only when the display mode is emSdkDisplayMode::DISPLAYMODE_REAL It is valid. For example, 100 is the display window and the image window is 1:1, 200 is the display window and the image window is 2:1. 50 is the display window and image window is 0.5:1, so the value is the magnification X100, must be called CameraDisplayInit is initialized to call this function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iRadio | scaling ratio.
Returns
Status Code

◆ CameraSetDisplaySize()

CKSDK_API CameraSdkStatus __stdcall CameraSetDisplaySize | ( | HANDLE | hCamera,
 |  | INT | iWidth,
 |  | INT | iHeight
 | ) |  |

Sets the size of the display control. Must be called CameraDisplayInit is initialized to call this function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iWidth | width
[in] | iHeight | height
Returns
Status Code


CKCameraAPI: Exposure and gain settings

Functions
Exposure and gain settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetAeState (HANDLE hCamera, BOOL bAeState)
Sets the mode in which the camera is exposed. Automatic or manual. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeState (HANDLE hCamera, BOOL *pAeState)
Gets the camera's current exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeTarget (HANDLE hCamera, WORD AeTarget)
Sets the brightness target value for auto exposure. The setting range is obtained by the CameraGetCapability function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeTarget (HANDLE hCamera, WORD *pAeTarget)
Gets the brightness target value for auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAnalogGain (HANDLE hCamera, UINT uAnalogGain)
Sets the camera's image analog gain value. Multiply this value by CameraGetCapability sExposeDesc.fAnalogGainStep in the camera property structure Obtain the actual image signal magnification. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAnalogGain (HANDLE hCamera, UINT *puAnalogGain)
Gets the analog gain value of the image signal. See CameraSetAnalogGain for details. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetExposureTime (HANDLE hCamera, double dExposureTime)
Set the exposure time. The unit is microseconds. For CMOS sensors, their exposure The unit is calculated in rows, so the exposure time is not in microseconds. The level is continuously adjustable. Instead, it will be based on the entire line. Invoking After setting the exposure time with this function, it is recommended to call CameraGetExposureTime again. To get the actual set value. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureTime (HANDLE hCamera, double *pdExposureTime)
Get the camera's exposure time. See CameraSetExposureTime Functional description. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
Sets the reference window for auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
Gets the location of the auto exposure reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWinVisible (HANDLE hCamera, BOOL bDisplayEn)
Sets the display status of the auto exposure reference window. When setting the window status For display, after calling CameraImageOverlay, the window position can be Superimposed on the image in a rectangular pattern. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWinVisible (HANDLE hCamera, BOOL *pbDisplayEn)
Gets the display status of the auto exposure reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAntiFlick (HANDLE hCamera, BOOL bEnable)
Sets the enable status of the anti-strobe function during auto exposure. For manual Inactive in exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAntiFlick (HANDLE hCamera, BOOL *pbEnable)
Gets the anti-strobe function enabled state during auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetLightFrequency (HANDLE hCamera, INT iFrequencySel)
Sets the frequency of the strobe flash during auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLightFrequency (HANDLE hCamera, INT *piFrequencySel)
When auto exposure is obtained, the frequency of the strobe is selected. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureLineTime (HANDLE hCamera, double *pExposureLineTime)
Get a line of exposure time, in subtle. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureMode (HANDLE hCamera, INT iMode)
Sets the exposure mode in auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureMode (HANDLE hCamera, INT *piMode)
Get exposure mode in auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureRange (HANDLE hCamera, double dMinExposureTime, double dMaxExposureTime)
Sets the exposure time adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureRange (HANDLE hCamera, double *pdMinExposureTime, double *pdMaxExposureTime)
Get the exposure time adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeAnalogGainRange (HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain)
Sets the gain adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeAnalogGainRange (HANDLE hCamera, INT *iMinAnalogGain, INT *iMaxAnalogGain)
Get the gain adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGain (HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB)
Sets the digital gain of the image. Setting range by CameraGetCapability The obtained sRgbGainRange member representation in the camera attribute structure. The actual magnification is the set value /100. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGain (HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB)
Gets the digital gain of image processing. See CameraSetGain for details. The functional description section. More...

Detailed Description

When the camera is shipped from the factory, in order to facilitate the presentation, the default is automatic exposure, that is, the camera It will automatically adjust the camera's exposure time and analog gain value according to the brightness of the ambient light. Best image brightness. But this automatic adjustment mode is not suitable for industrial applications, so Need to call some functions to manually set the exposure and gain to stabilize the image brightness, Suitable for software algorithm requirements, such as some cases where the user may want most of the image Overexposure to reduce image interference.

Function Documentation

◆ CameraGetAeAnalogGainRange()

CKSDK_API CameraSdkStatus __stdcall CameraGetAeAnalogGainRange | ( | HANDLE | hCamera,
 |  | INT * | iMinAnalogGain,
 |  | INT * | iMaxAnalogGain
 | ) |  |

Get the gain adjustment range of the auto exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | iMinAnalogGain | minimum gain
[out] | iMaxAnalogGain | maximum gain
Returns
Status Code

◆ CameraGetAeExposureMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureMode | ( | HANDLE | hCamera,
 |  | INT * | piMode
 | ) |  |

Get exposure mode in auto exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piMode | pointer, get auto exposure mode, AE_FRAME_MODE frame rate first, AE_EXP_MODE exposure priority
Returns
Status Code

◆ CameraGetAeExposureRange()

CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureRange | ( | HANDLE | hCamera,
 |  | double * | pdMinExposureTime,
 |  | double * | pdMaxExposureTime
 | ) |  |

Get the exposure time adjustment range of the auto exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pdMinExposureTime | Minimum exposure time (microseconds)
[out] | pdMaxExposureTime | Maximum exposure time (microseconds)
Returns
Status Code

◆ CameraGetAeState()

CKSDK_API CameraSdkStatus __stdcall CameraGetAeState | ( | HANDLE | hCamera,
 |  | BOOL * | pAeState
 | ) |  |

Gets the camera's current exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pAeState | Pointer to return the auto-exposure enable state.
Returns
Status Code

◆ CameraGetAeTarget()

CKSDK_API CameraSdkStatus __stdcall CameraGetAeTarget | ( | HANDLE | hCamera,
 |  | WORD * | pAeTarget
 | ) |  |

Gets the brightness target value for auto exposure.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pAeTarget | The pointer returns the target value.
Returns
Status Code

◆ CameraGetAeWindow()

CKSDK_API CameraSdkStatus __stdcall CameraGetAeWindow | ( | HANDLE | hCamera,
 |  | DWORD * | pdwLeft,
 |  | DWORD * | pdwTop,
 |  | DWORD * | pdwWidth,
 |  | DWORD * | pdwHeight
 | ) |  |

Gets the location of the auto exposure reference window.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pdwLeft | The pointer returns the abscissa of the upper left corner of the reference window.
[out] | pdwTop | The pointer returns the ordinate of the upper left corner of the reference window.
[out] | pdwWidth | Pointer, which returns the width of the reference window.
[out] | pdwHeight | Pointer, which returns the height of the reference window.
Returns
Status Code

◆ CameraGetAeWinVisible()

CKSDK_API CameraSdkStatus __stdcall CameraGetAeWinVisible | ( | HANDLE | hCamera,
 |  | BOOL * | pbDisplayEn
 | ) |  |

Gets the display status of the auto exposure reference window.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pbDisplayEn | Pointer, returning TRUE means that the current window will be superimposed on the image content.
Returns
Status Code

◆ CameraGetAnalogGain()

CKSDK_API CameraSdkStatus __stdcall CameraGetAnalogGain | ( | HANDLE | hCamera,
 |  | UINT * | puAnalogGain
 | ) |  |

Gets the analog gain value of the image signal. See CameraSetAnalogGain for details.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | puAnalogGain | Pointer returns the current analog gain value.
Returns
Status Code

◆ CameraGetAntiFlick()

CKSDK_API CameraSdkStatus __stdcall CameraGetAntiFlick | ( | HANDLE | hCamera,
 |  | BOOL * | pbEnable
 | ) |  |

Gets the anti-strobe function enabled state during auto exposure.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pbEnable | The pointer returns the enable state of this function.
Returns
Status Code

◆ CameraGetExposureLineTime()

CKSDK_API CameraSdkStatus __stdcall CameraGetExposureLineTime | ( | HANDLE | hCamera,
 |  | double * | pExposureLineTime
 | ) |  |

Get a line of exposure time, in subtle.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pExposureLineTime | Pointer, returns a line of exposure time, unit: subtle.
Returns
Status Code

◆ CameraGetExposureTime()

CKSDK_API CameraSdkStatus __stdcall CameraGetExposureTime | ( | HANDLE | hCamera,
 |  | double * | pdExposureTime
 | ) |  |

Get the camera's exposure time. See CameraSetExposureTime Functional description.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pdExposureTime | Pointer, which returns the current exposure time in microseconds.
Returns
Status Code

◆ CameraGetGain()

CKSDK_API CameraSdkStatus __stdcall CameraGetGain | ( | HANDLE | hCamera,
 |  | WORD * | pDGainR,
 |  | WORD * | pDGainG,
 |  | WORD * | pDGainB
 | ) |  |

Gets the digital gain of image processing. See CameraSetGain for details. The functional description section.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pDGainR | The pointer returns the digital gain value of the red channel.
[out] | pDGainG | The pointer returns the digital gain value of the green channel.
[out] | pDGainB | The pointer returns the digital gain value of the blue channel.
Returns
Status Code

◆ CameraGetLightFrequency()

CKSDK_API CameraSdkStatus __stdcall CameraGetLightFrequency | ( | HANDLE | hCamera,
 |  | INT * | piFrequencySel
 | ) |  |

When auto exposure is obtained, the frequency of the strobe is selected.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piFrequencySel | Pointer, which returns the selected index number. 1:50HZ 2:60HZ
Returns
Status Code

◆ CameraSetAeAnalogGainRange()

CKSDK_API CameraSdkStatus __stdcall CameraSetAeAnalogGainRange | ( | HANDLE | hCamera,
 |  | INT | iMinAnalogGain,
 |  | INT | iMaxAnalogGain
 | ) |  |

Sets the gain adjustment range of the auto exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iMinAnalogGain | minimum gain
[in] | iMaxAnalogGain | maximum gain
Returns
Status Code

◆ CameraSetAeExposureMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureMode | ( | HANDLE | hCamera,
 |  | INT | iMode
 | ) |  |

Sets the exposure mode in auto exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iMode | auto exposure mode, AE_FRAME_MODE frame rate priority, AE_EXP_MODE exposure priority
Returns
Status Code

◆ CameraSetAeExposureRange()

CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureRange | ( | HANDLE | hCamera,
 |  | double | dMinExposureTime,
 |  | double | dMaxExposureTime
 | ) |  |

Sets the exposure time adjustment range of the auto exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | dMinExposureTime | minimum exposure time (microseconds)
[in] | dMaxExposureTime | Maximum exposure time (microseconds)
Returns
Status Code

◆ CameraSetAeState()

CKSDK_API CameraSdkStatus __stdcall CameraSetAeState | ( | HANDLE | hCamera,
 |  | BOOL | bAeState
 | ) |  |

Sets the mode in which the camera is exposed. Automatic or manual.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | bAeState | TRUE, enables auto exposure; FALSE, stops auto exposure.
Returns
Status Code

◆ CameraSetAeTarget()

CKSDK_API CameraSdkStatus __stdcall CameraSetAeTarget | ( | HANDLE | hCamera,
 |  | WORD | AeTarget
 | ) |  |

Sets the brightness target value for auto exposure. The setting range is obtained by the CameraGetCapability function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | AeTarget | Brightness target value.
Returns
Status Code

◆ CameraSetAeWindow()

CKSDK_API CameraSdkStatus __stdcall CameraSetAeWindow | ( | HANDLE | hCamera,
 |  | DWORD | dwLeft,
 |  | DWORD | dwTop,
 |  | DWORD | dwWidth,
 |  | DWORD | dwHeight
 | ) |  |

Sets the reference window for auto exposure.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | dwLeft | The abscissa of the upper left corner of the window
[in] | dwTop | The ordinate of the upper left corner of the window
[in] | dwWidth | width of the window
[in] | dwHeight | height of the window
Returns
Status Code

◆ CameraSetAeWinVisible()

CKSDK_API CameraSdkStatus __stdcall CameraSetAeWinVisible | ( | HANDLE | hCamera,
 |  | BOOL | bDisplayEn
 | ) |  |

Sets the display status of the auto exposure reference window. When setting the window status For display, after calling CameraImageOverlay, the window position can be Superimposed on the image in a rectangular pattern.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | bDisplayEn | TRUE, set to display; FALSE, not displayed.
Returns
Status Code

◆ CameraSetAnalogGain()

CKSDK_API CameraSdkStatus __stdcall CameraSetAnalogGain | ( | HANDLE | hCamera,
 |  | UINT | uAnalogGain
 | ) |  |

Sets the camera's image analog gain value. Multiply this value by CameraGetCapability sExposeDesc.fAnalogGainStep in the camera property structure Obtain the actual image signal magnification.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | uAnalogGain | Set the analog gain value.
Returns
Status Code
Note
Sets the analog gain value of the camera. The size of this value will only affect the brightness of the image and will not affect it. Image frame rate, because it is just a circuit amplification factor, but this value will increase the image Background noise, for applications that require image quality, the analog gain should be set to a minimum.
Warning
This function must be in manual mode to take effect.

◆ CameraSetAntiFlick()

CKSDK_API CameraSdkStatus __stdcall CameraSetAntiFlick | ( | HANDLE | hCamera,
 |  | BOOL | bEnable
 | ) |  |

Sets the enable status of the anti-strobe function during auto exposure. For manual Inactive in exposure mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | bEnable | TRUE, turn on the anti-strobe function; FALSE, turn off the function.
Returns
Status Code

◆ CameraSetExposureTime()

CKSDK_API CameraSdkStatus __stdcall CameraSetExposureTime | ( | HANDLE | hCamera,
 |  | double | dExposureTime
 | ) |  |

Set the exposure time. The unit is microseconds. For CMOS sensors, their exposure The unit is calculated in rows, so the exposure time is not in microseconds. The level is continuously adjustable. Instead, it will be based on the entire line. Invoking After setting the exposure time with this function, it is recommended to call CameraGetExposureTime again. To get the actual set value.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | dExposureTime | Exposure time in microseconds.
Returns
Status Code
Note
This function sets the exposure time of the camera in microseconds. The larger the exposure time, the frame of the camera The lower the rate, for example, the exposure time is set to 500 milliseconds, then the camera is imaged up to 2 times in one second. The image will look more like a card. Therefore, in order to reduce the drawing time, the exposure time should be The lower the better, of course, the exposure time is low, you need external light source to increase the illumination, otherwise The image will be very dark.
Warning
This function must be in manual mode to take effect.

◆ CameraSetGain()

CKSDK_API CameraSdkStatus __stdcall CameraSetGain | ( | HANDLE | hCamera,
 |  | WORD | DGainR,
 |  | WORD | DGainG,
 |  | WORD | DGainB
 | ) |  |

Sets the digital gain of the image. Setting range by CameraGetCapability The obtained sRgbGainRange member representation in the camera attribute structure. The actual magnification is the set value /100.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | DGainR | The gain value of the red channel.
[in] | DGainG | The gain value of the green channel.
[in] | DGainB | Gain value of the blue channel.
Returns
Status Code
Note
This function sets the gain values ??of the three color channels R, G, and B.
Warning
This function must be in manual mode to take effect.

◆ CameraSetLightFrequency()

CKSDK_API CameraSdkStatus __stdcall CameraSetLightFrequency | ( | HANDLE | hCamera,
 |  | INT | iFrequencySel
 | ) |  |

Sets the frequency of the strobe flash during auto exposure.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iFrequencySel | 1:50HZ , 2:60HZ
Returns
Status Code


CKCameraAPI: White balance settings

Functions
White balance settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetWbMode (HANDLE hCamera, BOOL bAuto)
Sets the camera white balance mode. Divided into manual and automatic two ways. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbMode (HANDLE hCamera, BOOL *pbAuto)
Get the current white balance mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOnceWB (HANDLE hCamera)
In manual white balance mode, calling this function will perform a white balance. The effective time is when the next frame of image data is received. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
Sets the position of the white balance reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
Gets the position of the white balance reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWinVisible (HANDLE hCamera, BOOL bDisplayEn)
Sets the white balance reference window display enable. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWinVisible (HANDLE hCamera, BOOL *pDisplayEn)
Gets the white balance reference window display enable status. More...

Detailed Description

Function Documentation

◆ CameraGetWbMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetWbMode | ( | HANDLE | hCamera,
 |  | BOOL * | pbAuto
 | ) |  |

Get the current white balance mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pbAuto | pointer, return TRUE for automatic mode, FALSE In manual mode.
Returns
Status Code

◆ CameraGetWbWindow()

CKSDK_API CameraSdkStatus __stdcall CameraGetWbWindow | ( | HANDLE | hCamera,
 |  | DWORD * | pdwLeft,
 |  | DWORD * | pdwTop,
 |  | DWORD * | pdwWidth,
 |  | DWORD * | pdwHeight
 | ) |  |

Gets the position of the white balance reference window.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pdwLeft | The pointer returns the abscissa of the upper left corner of the reference window.
[out] | pdwTop | The pointer returns the ordinate of the upper left corner of the reference window.
[out] | pdwWidth | Pointer returns the width of the reference window.
[out] | pdwHeight | Pointer returns the height of the reference window.
Returns
Status Code

◆ CameraGetWbWinVisible()

CKSDK_API CameraSdkStatus __stdcall CameraGetWbWinVisible | ( | HANDLE | hCamera,
 |  | BOOL * | pDisplayEn
 | ) |  |

Gets the white balance reference window display enable status.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pDisplayEn | Pointer, white balance reference window display enable status 0: no display; 1: display.
Returns
Status Code

◆ CameraSetOnceWB()

CKSDK_API CameraSdkStatus __stdcall CameraSetOnceWB ( HANDLE hCamera )

In manual white balance mode, calling this function will perform a white balance. The effective time is when the next frame of image data is received.

Parameters
[in] hCamera The handle of the camera, obtained by the CameraInit function
Returns
Status Code
Warning
This function must be in manual mode to take effect.

◆ CameraSetWbMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetWbMode | ( | HANDLE | hCamera,
 |  | BOOL | bAuto
 | ) |  |

Sets the camera white balance mode. Divided into manual and automatic two ways.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | bAuto | TRUE means that the automatic mode is enabled. FALSE, which means using manual mode, by calling CameraSetOnceWB to perform a white balance.
Returns
Status Code

◆ CameraSetWbWindow()

CKSDK_API CameraSdkStatus __stdcall CameraSetWbWindow | ( | HANDLE | hCamera,
 |  | DWORD | dwLeft,
 |  | DWORD | dwTop,
 |  | DWORD | dwWidth,
 |  | DWORD | dwHeight
 | ) |  |

Sets the position of the white balance reference window.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | dwLeft | The upper left corner of the reference window.
[in] | dwTop | The upper left ordinate of the reference window.
[in] | dwWidth | The width of the reference window.
[in] | dwHeight | The height of the reference window.
Returns
Status Code

◆ CameraSetWbWinVisible()

CKSDK_API CameraSdkStatus __stdcall CameraSetWbWinVisible | ( | HANDLE | hCamera,
 |  | BOOL | bDisplayEn
 | ) |  |

Sets the white balance reference window display enable.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | bDisplayEn | display enable 0: no display; 1: display
Returns
Status Code


CKCameraAPI: GAMMA settings

Functions
GAMMA settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetLutMode (HANDLE hCamera, INT emLutMode)
Sets the camera's look-up table conversion mode LUT mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutMode (HANDLE hCamera, INT *pemLutMode)
Gets the camera's look-up table conversion mode LUT mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGamma (HANDLE hCamera, INT iGamma)
Sets the gamma value in the LUT dynamic generation mode. The set value will Saved inside the SDK right away, but only when the camera is dynamic The LUT mode generated by the parameter will not take effect. Please refer to CameraSetLutMode The function description section. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGamma (HANDLE hCamera, INT *piGamma)
Gets the gamma value in LUT dynamic generation mode. Please refer to CameraSetGamma A functional description of the function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrastLut (HANDLE hCamera, INT iContrast)
Set the contrast value in LUT dynamic generation mode. The set value will Save it inside the SDK right away, but only if the camera is dynamic The LUT mode generated by the parameter will not take effect. Please refer to CameraSetLutMode The function description section. param[in] hCamera The handle of the camera, obtained by the CameraInit function. param[in] iContrast The contrast value set by iContrast. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrastLut (HANDLE hCamera, INT *piContrast)
Get the contrast value in LUT dynamic generation mode. Please refer to the functional description of the CameraSetContrastLut function. param[in] hCamera The handle of the camera, obtained by the CameraInit function. param[out] piContrast The pointer which returns the current contrast value. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSelectLutPreset (HANDLE hCamera, INT iSel)
Select the LUT table in the preset LUT mode. Must use CameraSetLutMode first set the LUT mode to the preset mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutPresetSel (HANDLE hCamera, INT *piSel)
Gets the LUT table index number in the default LUT mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCustomLut (HANDLE hCamera, INT iChannel, USHORT *pLut)
Sets a custom LUT table. Must use CameraSetLutMode first set the LUT mode to custom mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCustomLut (HANDLE hCamera, INT iChannel, USHORT *pLut)
Get the custom LUT table currently in use. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentLut (HANDLE hCamera, INT iChannel, USHORT *pLut)
Get the camera's current LUT table, which can be called in any LUT mode. Used to visually observe changes in the LUT curve. More...

Detailed Description

Function Documentation

◆ CameraGetContrastLut()

CKSDK_API CameraSdkStatus __stdcall CameraGetContrastLut | ( | HANDLE | hCamera,
 |  | INT * | piContrast
 | ) |  |

Get the contrast value in LUT dynamic generation mode. Please refer to the functional description of the CameraSetContrastLut function. param[in] hCamera The handle of the camera, obtained by the CameraInit function. param[out] piContrast The pointer which returns the current contrast value.

Returns
Status Code
See also
CameraSetContrastLut

◆ CameraGetCurrentLut()

CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentLut | ( | HANDLE | hCamera,
 |  | INT | iChannel,
 |  | USHORT * | pLut
 | ) |  |

Get the camera's current LUT table, which can be called in any LUT mode. Used to visually observe changes in the LUT curve.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function.
[in] | iChannel | specifies the LUT color channel to get. When it is LUT_CHANNEL_ALL, Returns the LUT table of the red channel. Refer to the emSdkLutChannel definition in CKDeviceDef.h.
[out] | pLut | pointer to the address of the LUT table. The LUT table is an unsigned short integer array with an array size of 4096, the mapped value of the code color channel from 0 to 4096 (12bit color precision).
Returns
Status Code

◆ CameraGetCustomLut()

CKSDK_API CameraSdkStatus __stdcall CameraGetCustomLut | ( | HANDLE | hCamera,
 |  | INT | iChannel,
 |  | USHORT * | pLut
 | ) |  |

Get the custom LUT table currently in use.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iChannel | Specifies the LUT color channel to be obtained. When it is LUT_CHANNEL_ALL, Returns the LUT table of the red channel. See emSdkLutChannel definition.
[out] | pLut | The pointer to the address of the LUT table. The LUT table is an unsigned short integer array with an array size of 4096, the mapping value corresponding to the code color channel from 0 to 4096 (12 bit color precision).
Returns
Status Code
See also
CameraSetCustomLut

◆ CameraGetGamma()

CKSDK_API CameraSdkStatus __stdcall CameraGetGamma | ( | HANDLE | hCamera,
 |  | INT * | piGamma
 | ) |  |

Gets the gamma value in LUT dynamic generation mode. Please refer to CameraSetGamma A functional description of the function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piGamma | pointer, which returns the current gamma value.
Returns
Status Code

◆ CameraGetLutMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetLutMode | ( | HANDLE | hCamera,
 |  | INT * | pemLutMode
 | ) |  |

Gets the camera's look-up table conversion mode LUT mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pemLutMode | The pointer returns the current LUT mode. Meaning with CameraSetLutMode The emLutMode parameter is the same.
Returns
Status Code

◆ CameraGetLutPresetSel()

CKSDK_API CameraSdkStatus __stdcall CameraGetLutPresetSel | ( | HANDLE | hCamera,
 |  | INT * | piSel
 | ) |  |

Gets the LUT table index number in the default LUT mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piSel | pointer, which returns the index number of the table.
Returns
Status Code

◆ CameraSelectLutPreset()

CKSDK_API CameraSdkStatus __stdcall CameraSelectLutPreset | ( | HANDLE | hCamera,
 |  | INT | iSel
 | ) |  |

Select the LUT table in the preset LUT mode. Must use CameraSetLutMode first set the LUT mode to the preset mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function.
[in] | iSel | The index number of the table. The number of tables by CameraGetCapability get.
Returns
Status Code

◆ CameraSetContrastLut()

CKSDK_API CameraSdkStatus __stdcall CameraSetContrastLut | ( | HANDLE | hCamera,
 |  | INT | iContrast
 | ) |  |

Set the contrast value in LUT dynamic generation mode. The set value will Save it inside the SDK right away, but only if the camera is dynamic The LUT mode generated by the parameter will not take effect. Please refer to CameraSetLutMode The function description section. param[in] hCamera The handle of the camera, obtained by the CameraInit function. param[in] iContrast The contrast value set by iContrast.

Returns
Status Code

◆ CameraSetCustomLut()

CKSDK_API CameraSdkStatus __stdcall CameraSetCustomLut | ( | HANDLE | hCamera,
 |  | INT | iChannel,
 |  | USHORT * | pLut
 | ) |  |

Sets a custom LUT table. Must use CameraSetLutMode first set the LUT mode to custom mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iChannel | Specifies the LUT color channel to be obtained. When it is LUT_CHANNEL_ALL, Returns the LUT table of the red channel. See emSdkLutChannel definition.
[in] | pLut | pointer to the address of the LUT table. The LUT table is an unsigned short integer array with an array size of 4096, the mapping value corresponding to the code color channel from 0 to 4096 (12 bit color precision).
Returns
Status Code
See also
CameraGetCustomLut

◆ CameraSetGamma()

CKSDK_API CameraSdkStatus __stdcall CameraSetGamma | ( | HANDLE | hCamera,
 |  | INT | iGamma
 | ) |  |

Sets the gamma value in the LUT dynamic generation mode. The set value will Saved inside the SDK right away, but only when the camera is dynamic The LUT mode generated by the parameter will not take effect. Please refer to CameraSetLutMode The function description section.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iGamma | The gamma value to be set.
Returns
Status Code

◆ CameraSetLutMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetLutMode | ( | HANDLE | hCamera,
 |  | INT | emLutMode
 | ) |  |

Sets the camera's look-up table conversion mode LUT mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | emLutMode | LUTMODE_PARAM_GEN Indicates that the LUT table is dynamically generated by gamma and contrast parameters. LUTMODE_PRESET indicates that the preset LUT table is used. LUTMODE_USER_DEF indicates the use of a user-defined LUT table. The definition of LUTMODE_PARAM_GEN refers to the emSdkLutMode type in CameraDefine.h.
Returns
Status Code


CKCameraAPI: Image process

Functions
Image process
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetSharpness (HANDLE hCamera, INT iSharpness)
Sets the sharpening parameters for the processing of the image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSharpness (HANDLE hCamera, INT *piSharpness)
Gets the current sharpening setting. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetSaturation (HANDLE hCamera, INT iSaturation)
Sets the saturation of image processing. Not valid for black and white cameras. The setting range is obtained by CameraGetCapability. 100 means Indicates the original chroma, not enhanced. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSaturation (HANDLE hCamera, INT *piSaturation)
Gets the saturation of image processing. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrast (HANDLE hCamera, INT iContrast)
sets the contrast of image processing More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrast (HANDLE hCamera, INT *piContrast)
Gets the contrast value. Please refer to A functional description of the CameraSetContrast function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgMode (HANDLE hCamera, INT iAlgMode)
Sets the Bayer to RGB algorithm mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgThreshold (HANDLE hCamera, INT iAlgMode)
Sets the Bayer to RGB algorithm mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBayerAlgMode (HANDLE hCamera, INT *piAlgMode)
Get Bayer to RGB algorithm mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetIspOutFormat (HANDLE hCamera, INT iFormat)
Sets the output format of the image processing of the CameraImageProcess function, which supports CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 Five types (defined in CameraDefine.h) correspond to 8-bit grayscale images and 24RGB, 32-bit RGB, 24-bit BGR, 32-bit BGR color images. The default output is CAMERA_MEDIA_TYPE_BGR8 format. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetIspOutFormat (HANDLE hCamera, INT *piFormat)
Get the output format of CameraGetOutImageBuffer function image processing, support CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 Five types (defined in CameraDefine.h) correspond to 8-bit grayscale images and 24RGB, 32-bit RGB, 24-bit BGR, 32-bit BGR color images. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetMonochrome (HANDLE hCamera, BOOL bEnable)
Sets the color to black and white function enable. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMonochrome (HANDLE hCamera, BOOL *pbEnable)
Gets the enable status of the color conversion black and white function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBlackLevel (HANDLE hCamera, INT iBlackLevel)
sets the black level reference of the image. The default value is 0. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBlackLevel (HANDLE hCamera, INT *piBlackLevel)
Gets the black level reference of the image, the default is 0. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetSensorOutPixelFormat (HANDLE hCamera, UINT iFormat)
Set the format of the raw image data. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSensorOutPixelFormat (HANDLE hCamera, UINT *piFormat)
Get the format of the raw image data. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCorrectDeadPixel (HANDLE hCamera, BOOL bEnable)
Set whether to enable dead pixel correction. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCorrectDeadPixel (HANDLE hCamera, BOOL *pbEnable)
Get the status of dead pixel correction. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLscCalib (HANDLE hCamera, tLscCalibParam *pLscCalibParam)
LSC calibration. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLscCorrect (HANDLE hCamera, tLscCorrectParam *pLscCorrectParam)
LSC correction. More...

Detailed Description

Function Documentation

◆ CameraGetBayerAlgMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetBayerAlgMode | ( | HANDLE | hCamera,
 |  | INT * | piAlgMode
 | ) |  |

Get Bayer to RGB algorithm mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piAlgMode | pointer Returns Bayer to RGB algorithm mode
Returns
Status Code

◆ CameraGetBlackLevel()

CKSDK_API CameraSdkStatus __stdcall CameraGetBlackLevel | ( | HANDLE | hCamera,
 |  | INT * | piBlackLevel
 | ) |  |

Gets the black level reference of the image, the default is 0.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piBlackLevel | Returns the current black level value. The range is from 0 to 255.
Returns
Status Code

◆ CameraGetContrast()

CKSDK_API CameraSdkStatus __stdcall CameraGetContrast | ( | HANDLE | hCamera,
 |  | INT * | piContrast
 | ) |  |

Gets the contrast value. Please refer to A functional description of the CameraSetContrast function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piContrast | The pointer returns the current contrast value.
Returns
Status Code

◆ CameraGetCorrectDeadPixel()

CKSDK_API CameraSdkStatus __stdcall CameraGetCorrectDeadPixel | ( | HANDLE | hCamera,
 |  | BOOL * | pbEnable
 | ) |  |

Get the status of dead pixel correction.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | pbEnable | pointer, used to save the state of whether to enable dead pixel correction
Returns
Status code

◆ CameraGetIspOutFormat()

CKSDK_API CameraSdkStatus __stdcall CameraGetIspOutFormat | ( | HANDLE | hCamera,
 |  | INT * | piFormat
 | ) |  |

Get the output format of CameraGetOutImageBuffer function image processing, support CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 Five types (defined in CameraDefine.h) correspond to 8-bit grayscale images and 24RGB, 32-bit RGB, 24-bit BGR, 32-bit BGR color images.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piFormat | Returns the currently set format.  CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8
Returns
Status Code

◆ CameraGetMonochrome()

CKSDK_API CameraSdkStatus __stdcall CameraGetMonochrome | ( | HANDLE | hCamera,
 |  | BOOL * | pbEnable
 | ) |  |

Gets the enable status of the color conversion black and white function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pbEnable | pointer. Return TRUE to turn on color image The ability to convert to black and white images.
Returns
Status Code

◆ CameraGetSaturation()

CKSDK_API CameraSdkStatus __stdcall CameraGetSaturation | ( | HANDLE | hCamera,
 |  | INT * | piSaturation
 | ) |  |

Gets the saturation of image processing.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piSaturation | Pointer, which returns the saturation value of the current image processing.
Returns
Status Code

◆ CameraGetSensorOutPixelFormat()

CKSDK_API CameraSdkStatus __stdcall CameraGetSensorOutPixelFormat | ( | HANDLE | hCamera,
 |  | UINT * | piFormat
 | ) |  |

Get the format of the raw image data.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piFormat | The format of the raw image data.
Returns
Status Code
See also
CameraSetSensorOutPixelFormat
CameraGetCapability

◆ CameraGetSharpness()

CKSDK_API CameraSdkStatus __stdcall CameraGetSharpness | ( | HANDLE | hCamera,
 |  | INT * | piSharpness
 | ) |  |

Gets the current sharpening setting.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piSharpness | The pointer returns the currently set sharpening setting.
Returns
Status Code

◆ CameraLscCalib()

CKSDK_API CameraSdkStatus __stdcall CameraLscCalib | ( | HANDLE | hCamera,
 |  | tLscCalibParam * | pLscCalibParam
 | ) |  |

LSC calibration.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | pLscCalibParam | pointer, calibration parameter
Returns
Status code

◆ CameraLscCorrect()

CKSDK_API CameraSdkStatus __stdcall CameraLscCorrect | ( | HANDLE | hCamera,
 |  | tLscCorrectParam * | pLscCorrectParam
 | ) |  |

LSC correction.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | pLscCorrectParam | pointer, correction parameter
Returns
Status code

◆ CameraSetBayerAlgMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgMode | ( | HANDLE | hCamera,
 |  | INT | iAlgMode
 | ) |  |

Sets the Bayer to RGB algorithm mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iAlgMode | Bayer to RGB algorithm mode
Returns
Status Code

◆ CameraSetBayerAlgThreshold()

CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgThreshold | ( | HANDLE | hCamera,
 |  | INT | iAlgMode
 | ) |  |

Sets the Bayer to RGB algorithm mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iAlgMode | Bayer to RGB algorithm mode
Returns
Status Code

◆ CameraSetBlackLevel()

CKSDK_API CameraSdkStatus __stdcall CameraSetBlackLevel | ( | HANDLE | hCamera,
 |  | INT | iBlackLevel
 | ) |  |

sets the black level reference of the image. The default value is 0.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iBlackLevel | The level value to be set. The range is from 0 to 255.
Returns
Status Code

◆ CameraSetContrast()

CKSDK_API CameraSdkStatus __stdcall CameraSetContrast | ( | HANDLE | hCamera,
 |  | INT | iContrast
 | ) |  |

sets the contrast of image processing

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iContrast | Contrast value set by iContrast.
Returns
Status Code
Note
This function sets the contrast value of the camera. The higher the contrast, the darker the black area of ??the image. The whiter the white area, the image looks black and white, and there may be some visual processing. Effectively capture the contour; conversely, if the contrast is smaller, it will be black and white and it will look better than More ambiguous. The contrast default is 50, and the minimum can be up to 1, up to 100.

◆ CameraSetCorrectDeadPixel()

CKSDK_API CameraSdkStatus __stdcall CameraSetCorrectDeadPixel | ( | HANDLE | hCamera,
 |  | BOOL | bEnable
 | ) |  |

Set whether to enable dead pixel correction.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | bEnable | TRUE: Enable dead pixel correction FALSE: Disable dead pixel correction
Returns
Status code

◆ CameraSetIspOutFormat()

CKSDK_API CameraSdkStatus __stdcall CameraSetIspOutFormat | ( | HANDLE | hCamera,
 |  | INT | iFormat
 | ) |  |

Sets the output format of the image processing of the CameraImageProcess function, which supports CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 Five types (defined in CameraDefine.h) correspond to 8-bit grayscale images and 24RGB, 32-bit RGB, 24-bit BGR, 32-bit BGR color images. The default output is CAMERA_MEDIA_TYPE_BGR8 format.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iFormat | To format. CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8
Returns
Status Code
Note
This function is the final image image obtained by CameraGetOutImageBuffer function The prime format, not the raw RAW pixel format of the camera output. After the camera is initialized, it is set by calling CameraSetIspOutFormat.
  1. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_MONO); After setting, the image output by CameraGetOutImageBuffer is an 8-bit grayscale image. Like, 1 pixel occupies 1 byte, arranged in order.
  2. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_RGB8); After setting, the image output by CameraGetOutImageBuffer is 24bit RBG Color image, 1 pixel occupies 3 bytes, followed by red, green, blue Return to the sample.
  3. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_BGR8); After setting, the image output by CameraGetOutImageBuffer is 24bit BGR Color image, 1 pixel occupies 3 bytes, followed by blue, green, red Arrange.
    1. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_RGBA8); After setting, the image output by CameraGetOutImageBuffer is 32bit RBGA Color image, 1 pixel occupies 4 bytes, followed by red 8bit, green 8bit, blue 8bit, Alpha8bit arrangement.
    2. CameraSetIspOutFormat(hCamera, CAMERA_MEDIA_TYPE_BGRA8); After setting, the image output by CameraGetOutImageBuffer is 32bit BGRA Color image, 1 pixel occupies 3 bytes, followed by blue, green, red, Alpha arrangement.

◆ CameraSetMonochrome()

CKSDK_API CameraSdkStatus __stdcall CameraSetMonochrome | ( | HANDLE | hCamera,
 |  | BOOL | bEnable
 | ) |  |

Sets the color to black and white function enable.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | bEnable | TRUE, which means that the color image is converted to black and white.
Returns
Status Code

◆ CameraSetSaturation()

CKSDK_API CameraSdkStatus __stdcall CameraSetSaturation | ( | HANDLE | hCamera,
 |  | INT | iSaturation
 | ) |  |

Sets the saturation of image processing. Not valid for black and white cameras. The setting range is obtained by CameraGetCapability. 100 means Indicates the original chroma, not enhanced.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iSaturation | The saturation value set by iSaturation.
Returns
Status Code
Note
This function sets the image saturation. The greater the saturation, the darker the color; the lighter the contrast, the more saturated If set to 0, the image is completely colorless, equivalent to a black and white camera. The default value is
  1. The adjustment range is from 0 to 200.

◆ CameraSetSensorOutPixelFormat()

CKSDK_API CameraSdkStatus __stdcall CameraSetSensorOutPixelFormat | ( | HANDLE | hCamera,
 |  | UINT | iFormat
 | ) |  |

Set the format of the raw image data.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | iFormat | The format of the raw image data.
Note
The original image formats supported by the camera are available via CameraGetCapability and are supported in the pBayerTypeDesc array structure of tDeviceCfg.
Returns
Status Code
See also
CameraGetSensorOutPixelFormat
CameraGetCapability

◆ CameraSetSharpness()

CKSDK_API CameraSdkStatus __stdcall CameraSetSharpness | ( | HANDLE | hCamera,
 |  | INT | iSharpness
 | ) |  |

Sets the sharpening parameters for the processing of the image.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iSharpness | Sharpen the parameters. Range by CameraGetCapability Obtained, generally [0, 100], 0 means that the sharpening process is turned off.
Returns
Status Code
Note
This function sets the sharpening level of the image. The higher the sharpness, the better the image clarity, but the noise The sound will be louder; on the contrary, the lower the sharpness, the stronger the image will be, but the noise will be reduced. Smooth. The default value is 0, which means there is no sharpening enhancement.


CKCameraAPI: Trigger Settings

Functions
Trigger Settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerMode (HANDLE hCamera, INT iTriggerModeSel)
Sets the camera's trigger mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerMode (HANDLE hCamera, INT *piTriggerModeSel)
Get the trigger mode of the camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSoftTrigger (HANDLE hCamera)
performs a soft trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraBroadcastSoftTrigger (const char *pStrNetCardIP, int nCmd)
Sends soft-trigger commands to all cameras connected to the network card. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerFrameCount (HANDLE hCamera, INT frameCount)
Sets how many pictures to take continuously when camera triggers. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerFrameCount (HANDLE hCamera, INT *pFrameCount)
Get how many pictures are taken continuously when the camera is triggered. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerDelayTime (HANDLE hCamera, UINT delayTimeUs)
Set how much time to take a photo after camera trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerDelayTime (HANDLE hCamera, UINT *pDelayTimeUs)
Set how much time to take a photo after camera trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerJitterTime (HANDLE hCamera, INT inputIOIndex, UINT jitterTimeUs)
Set the hardware to trigger the debounce time. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerJitterTime (HANDLE hCamera, INT inputIOIndex, UINT *pJitterTimeUs)
Get the hardware to trigger the debounce time. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerSignalType (HANDLE hCamera, INT inputIOIndex, INT type)
sets the hardware trigger signal type More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerSignalType (HANDLE hCamera, INT inputIOIndex, INT *pType)
Get hardware trigger signal type. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobeMode (HANDLE hCamera, INT outputIOIndex, INT mode)
Set flash mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobeMode (HANDLE hCamera, INT outputIOIndex, INT *pMode)
Get flash mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobeDelayTime (HANDLE hCamera, INT outputIOIndex, UINT delayTimeUs)
Set how long to delay the flash after the trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobeDelayTime (HANDLE hCamera, INT outputIOIndex, UINT *pDevlayTimeUs)
Gets the delay time to illuminate the flash after triggering. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobePulseWidth (HANDLE hCamera, INT outputIOIndex, UINT pulseWidth)
sets the pulse width of the flash More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobePulseWidth (HANDLE hCamera, INT outputIOIndex, UINT *pPulseWidth)
Get the pulse width of the flash. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobePolarity (HANDLE hCamera, INT outputIOIndex, INT polarity)
sets the active level of the flash More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobePolarity (HANDLE hCamera, INT outputIOIndex, INT *pPolarity)
Get the active level of the flash. More...

Detailed Description

Function Documentation

◆ CameraBroadcastSoftTrigger()

CKSDK_API CameraSdkStatus __stdcall CameraBroadcastSoftTrigger | ( | const char * | pStrNetCardIP,
 |  | int | nCmd
 | ) |  |

Sends soft-trigger commands to all cameras connected to the network card.

Parameters
[in] | pStrNetCardIP | the IP address of the pStrNetCardIP network card
[in] | nCmd | Soft trigger command code, when the value is 1, clear all image frames in the camera's internal cache, other values are not cleared
Returns
status code
See also
CameraSetTriggerMode
CameraSoftTrigger

◆ CameraGetStrobeDelayTime()

CKSDK_API CameraSdkStatus __stdcall CameraGetStrobeDelayTime | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | UINT * | pDevlayTimeUs
 | ) |  |

Gets the delay time to illuminate the flash after triggering.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[out] | pDevlayTimeUs | delay time in microseconds
Returns
Status Code

◆ CameraGetStrobeMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetStrobeMode | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT * | pMode
 | ) |  |

Get flash mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[out] | pMode | trigger type, please refer to emStrobeControl
Returns
Status Code

◆ CameraGetStrobePolarity()

CKSDK_API CameraSdkStatus __stdcall CameraGetStrobePolarity | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT * | pPolarity
 | ) |  |

Get the active level of the flash.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[out] | pPolarity | active level
Returns
Status Code

◆ CameraGetStrobePulseWidth()

CKSDK_API CameraSdkStatus __stdcall CameraGetStrobePulseWidth | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | UINT * | pPulseWidth
 | ) |  |

Get the pulse width of the flash.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[out] | pPulseWidth | Pulse width in microseconds
Returns
Status Code

◆ CameraGetTriggerDelayTime()

CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerDelayTime | ( | HANDLE | hCamera,
 |  | UINT * | pDelayTimeUs
 | ) |  |

Set how much time to take a photo after camera trigger.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pDelayTimeUs | delay time in microseconds
Returns
Status Code

◆ CameraGetTriggerFrameCount()

CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerFrameCount | ( | HANDLE | hCamera,
 |  | INT * | pFrameCount
 | ) |  |

Get how many pictures are taken continuously when the camera is triggered.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pFrameCount | How many pictures are taken in a row?
Returns
Status Code

◆ CameraGetTriggerJitterTime()

CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerJitterTime | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | UINT * | pJitterTimeUs
 | ) |  |

Get the hardware to trigger the debounce time.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | inputIOIndex | Input IO port index number
[out] | pJitterTimeUs | Debounce time, in microseconds
Returns
Status Code

◆ CameraGetTriggerMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerMode | ( | HANDLE | hCamera,
 |  | INT * | piTriggerModeSel
 | ) |  |

Get the trigger mode of the camera.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piTriggerModeSel | Pointer, which returns the index number of the currently selected camera trigger mode.
Returns
Status Code

◆ CameraGetTriggerSignalType()

CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerSignalType | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | INT * | pType
 | ) |  |

Get hardware trigger signal type.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | inputIOIndex | Input IO port index number
[out] | pType | trigger type, please refer to emExtTrigSignal
Returns
Status Code

◆ CameraSetStrobeDelayTime()

CKSDK_API CameraSdkStatus __stdcall CameraSetStrobeDelayTime | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | UINT | delayTimeUs
 | ) |  |

Set how long to delay the flash after the trigger.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[in] | delayTimeUs | delay time in microseconds
Returns
Status Code

◆ CameraSetStrobeMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetStrobeMode | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT | mode
 | ) |  |

Set flash mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[in] | mode | trigger type, please refer to emStrobeControl
Returns
Status Code

◆ CameraSetStrobePolarity()

CKSDK_API CameraSdkStatus __stdcall CameraSetStrobePolarity | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT | polarity
 | ) |  |

sets the active level of the flash

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[in] | polarity | active level
Returns
Status Code

◆ CameraSetStrobePulseWidth()

CKSDK_API CameraSdkStatus __stdcall CameraSetStrobePulseWidth | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | UINT | pulseWidth
 | ) |  |

sets the pulse width of the flash

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[in] | pulseWidth | width width in microseconds
Returns
Status Code

◆ CameraSetTriggerDelayTime()

CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerDelayTime | ( | HANDLE | hCamera,
 |  | UINT | delayTimeUs
 | ) |  |

Set how much time to take a photo after camera trigger.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | delayTimeUs | delay time in microseconds
Returns
Status Code

◆ CameraSetTriggerFrameCount()

CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerFrameCount | ( | HANDLE | hCamera,
 |  | INT | frameCount
 | ) |  |

Sets how many pictures to take continuously when camera triggers.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | frameCount | How many pictures are taken in a row?
Returns
Status Code
See also
CameraSetTriggerMode
CameraSoftTrigger

◆ CameraSetTriggerJitterTime()

CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerJitterTime | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | UINT | jitterTimeUs
 | ) |  |

Set the hardware to trigger the debounce time.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | inputIOIndex | Input IO port index number
[in] | jitterTimeUs | debounce time in microseconds
Returns
Status Code

◆ CameraSetTriggerMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerMode | ( | HANDLE | hCamera,
 |  | INT | iTriggerModeSel
 | ) |  |

Sets the camera's trigger mode.

Parameters
[in] hCamera The handle of the camera, obtained by the CameraInit function
[in] iTriggerModeSel The mode selects the index number. Settable mode CameraGetCapability function gets. Please refer to The definition of tSdkCameraCapbility in CameraDefine.h. generally,
  1. 0. indicates continuous acquisition mode;
  2. 1. indicates the software trigger mode;
  3. 2. Indicates the hardware trigger mode.
Returns
Status Code
Note
When setting to hardware trigger mode, first set an input IO to trigger working mode by CameraSetInputIOMode.
See also
CameraSetInputIOMode

◆ CameraSetTriggerSignalType()

CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerSignalType | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | INT | type
 | ) |  |

sets the hardware trigger signal type

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | inputIOIndex | Input IO port index number
[in] | type | trigger type, please refer to emExtTrigSignal
Returns
Status Code

◆ CameraSoftTrigger()

CKSDK_API CameraSdkStatus __stdcall CameraSoftTrigger ( HANDLE hCamera )

performs a soft trigger.

Parameters
[in] hCamera The handle of the camera, obtained by the CameraInit function
Returns
Status Code
Note
camera defaults to continuous drawing mode and can also pass CameraSetTriggerMode(hCamera,0); Switches to continuous drawing mode.
  1. 1. Set the camera to soft trigger capture mode. by CameraSetTriggerMode(hCamera,1); Switch to soft trigger capture mode. Enter this After the mode, the camera stops image acquisition and transmission. Only when the user calls CameraSoftTrigger (hCamera) once, the camera collects an image and sends it up. After the hair is sent, the camera will enter the waiting state again until the next user call. CameraSoftTrigger (hCamera).
  2. 2. Set the camera to hard trigger capture mode. by CameraSetTriggerMode(hCamera, 2); Switch to hard trigger capture mode. Enter this After the mode, the camera stops image acquisition and transmission. Only when the user touches the camera case When a pulse is input on the terminal, the camera collects an image and sends it on. Come. After the hair is sent, the camera will enter the waiting state until the next time the trigger pulse is received.
See also
CameraSetTriggerMode
CameraSetTriggerFrameCount
CameraSetTriggerDelayTime


CKCameraAPI: Saving and loading camera parameters

Functions
Saving and loading camera parameters
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetParameterMode (HANDLE hCamera, INT iMode)
Sets the target object for parameter access. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetParameterMode (HANDLE hCamera, INT *piMode)
Get the target object for parameter access. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameter (HANDLE hCamera, INT iTeam)
Saves the current camera parameters to the specified parameter group. The camera provides A, B, C, D The four groups A, B, C, and D are used to save the parameters. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameterToFile (HANDLE hCamera, const char *sFileName)
Saves the current camera parameters to the specified file. The file can be copied to Other computers can be loaded by other cameras, and can also be used for parameter backup. More...
CKSDK_API CameraSdkStatus __stdcall | CameraReadParameterFromFile (HANDLE hCamera, const char *sFileName)
Loads parameters from the parameter file specified on the PC. My company camera parameters Save the file with the .config suffix on the PC, under the installation In the Camera\Configs folder. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadParameter (HANDLE hCamera, INT iTeam)
Loads the parameters of the specified group into the camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentParameterGroup (HANDLE hCamera, INT *piTeam)
Get the currently selected parameter group. More...

Detailed Description

Function Documentation

◆ CameraGetCurrentParameterGroup()

CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentParameterGroup | ( | HANDLE | hCamera,
 |  | INT * | piTeam
 | ) |  |

Get the currently selected parameter group.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piTeam | The pointer returns the currently selected parameter group. return value Refer to the iTeam parameter in the CameraLoadParameter.
Returns
Status Code

◆ CameraGetParameterMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetParameterMode | ( | HANDLE | hCamera,
 |  | INT * | piMode
 | ) |  |

Get the target object for parameter access.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piMode | pointer, returning the mode of parameter access
Returns
Status Code

◆ CameraLoadParameter()

CKSDK_API CameraSdkStatus __stdcall CameraLoadParameter | ( | HANDLE | hCamera,
 |  | INT | iTeam
 | ) |  |

Loads the parameters of the specified group into the camera.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iTeam | PARAMETER_TEAM_A Loads Group A parameters, emSdkParameterTeam::PARAMETER_TEAM_B Loads Group B parameters, emSdkParameterTeam::PARAMETER_TEAM_C Load C group parameters, emSdkParameterTeam::PARAMETER_TEAM_D Loads the D group parameters, emSdkParameterTeam::PARAMETER_TEAM_DEFAULT Loads the default parameters. Type definition reference emSdkParameterTeam type in CameraDefine.h
Returns
Status Code

◆ CameraReadParameterFromFile()

CKSDK_API CameraSdkStatus __stdcall CameraReadParameterFromFile | ( | HANDLE | hCamera,
 |  | const char * | sFileName
 | ) |  |

Loads parameters from the parameter file specified on the PC. My company camera parameters Save the file with the .config suffix on the PC, under the installation In the Camera\Configs folder.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | *sFileName | The full path to the parameter file.
Returns
Status Code

◆ CameraSaveParameter()

CKSDK_API CameraSdkStatus __stdcall CameraSaveParameter | ( | HANDLE | hCamera,
 |  | INT | iTeam
 | ) |  |

Saves the current camera parameters to the specified parameter group. The camera provides A, B, C, D The four groups A, B, C, and D are used to save the parameters.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iTeam | PARAMETER_TEAM_A is saved to group A, PARAMETER_TEAM_B is saved to group B, PARAMETER_TEAM_C is saved to group C, PARAMETER_TEAM_D is saved to group D
Returns
Status Code

◆ CameraSaveParameterToFile()

CKSDK_API CameraSdkStatus __stdcall CameraSaveParameterToFile | ( | HANDLE | hCamera,
 |  | const char * | sFileName
 | ) |  |

Saves the current camera parameters to the specified file. The file can be copied to Other computers can be loaded by other cameras, and can also be used for parameter backup.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | sFileName | The full path to the sFileName parameter file.
Returns
Status Code

◆ CameraSetParameterMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetParameterMode | ( | HANDLE | hCamera,
 |  | INT | iMode
 | ) |  |

Sets the target object for parameter access.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iMode | The mode in which the iMode parameter is accessed. Reference CameraDefine.h The type definition of emSdkParameterMode.
Returns
Status Code


CKCameraAPI: User data

Functions
User data
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraWriteSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
Sets the serial number of the camera. Our company's camera serial number is divided into 3 levels. Level 0 is our company's custom camera serial number, already shipped from the factory Set well, Level 1 and Level 2 are reserved for secondary development. Sequence of each level The length of the number is 32 bytes. More...
CKSDK_API CameraSdkStatus __stdcall | CameraReadSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
Reads the serial number of the camera's specified level. Please refer to the definition of serial number. The functional description section of the function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
saves user-defined data to the camera's non-volatile memory. The maximum length of the user data area that each model camera may support is different. This length information can be obtained from the characterization of the device. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
reads user-defined data from the camera's non-volatile memory. The maximum length of the user data area that each model camera may support is different. This length information can be obtained from the characterization of the device. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFriendlyName (HANDLE hCamera, char *pName)
Read user-defined device nicknames. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFriendlyName (HANDLE hCamera, char *pName)
Sets a user-defined device nickname. More...

Detailed Description

Function Documentation

◆ CameraGetFriendlyName()

CKSDK_API CameraSdkStatus __stdcall CameraGetFriendlyName | ( | HANDLE | hCamera,
 |  | char * | pName
 | ) |  |

Read user-defined device nicknames.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pName | pointer, which returns a string pointing to the end of 0. The device nickname does not exceed 32 bytes, so the pointer The buffer pointed to must be greater than or equal to 32 bytes of space.
Returns
Status Code

◆ CameraLoadUserData()

CKSDK_API CameraSdkStatus __stdcall CameraLoadUserData | ( | HANDLE | hCamera,
 |  | UINT | uStartAddr,
 |  | BYTE * | pbData,
 |  | INT | iLen
 | ) |  |

reads user-defined data from the camera's non-volatile memory. The maximum length of the user data area that each model camera may support is different. This length information can be obtained from the characterization of the device.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | uStartAddr | Start address, starting at 0.
[out] | pbData | Data buffer pointer, returns the data read.
[in] | iLen | reads the length of the data, ilen + uStartAddr must be less than the maximum length of the user area
Returns
Status Code
Note
All models of our company have a data storage space that users can read and write freely. It will also be saved after power failure, without losing data. Each model of camera, storage space The size is not the same, the specific size can be passed CameraGetCapability function Get, tSdkCameraCapbility The iUserDataMaxLen of the pole represents the camera The maximum number of bytes stored.

◆ CameraReadSN()

CKSDK_API CameraSdkStatus __stdcall CameraReadSN | ( | HANDLE | hCamera,
 |  | BYTE * | pbySN,
 |  | INT | iLevel
 | ) |  |

Reads the serial number of the camera's specified level. Please refer to the definition of serial number. The functional description section of the function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pbySN | The buffer for the serial number.
[in] | iLevel | The serial number level to be read. Can only be 0, 1 and 2.
Returns
Status Code
See also
CameraWriteSN

◆ CameraSaveUserData()

CKSDK_API CameraSdkStatus __stdcall CameraSaveUserData | ( | HANDLE | hCamera,
 |  | UINT | uStartAddr,
 |  | BYTE * | pbData,
 |  | INT | iLen
 | ) |  |

saves user-defined data to the camera's non-volatile memory. The maximum length of the user data area that each model camera may support is different. This length information can be obtained from the characterization of the device.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | uStartAddr | Start address, starting at 0.
[in] | pbData | data buffer pointer
[in] | iLen | The length of the data written by iLen, ilen + uStartAddr must be less than the maximum length of the user area.
Returns
Status Code

◆ CameraSetFriendlyName()

CKSDK_API CameraSdkStatus __stdcall CameraSetFriendlyName | ( | HANDLE | hCamera,
 |  | char * | pName
 | ) |  |

Sets a user-defined device nickname.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pName | Pointer to a string ending in 0. The device nickname is no more than 32 bytes, so the pointer to the string must be less than or equal to 32 bytes.
Returns
Status Code

◆ CameraWriteSN()

CKSDK_API CameraSdkStatus __stdcall CameraWriteSN | ( | HANDLE | hCamera,
 |  | BYTE * | pbySN,
 |  | INT | iLevel
 | ) |  |

Sets the serial number of the camera. Our company's camera serial number is divided into 3 levels. Level 0 is our company's custom camera serial number, already shipped from the factory Set well, Level 1 and Level 2 are reserved for secondary development. Sequence of each level The length of the number is 32 bytes.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pbySN | The buffer for the pbySN serial number.
[in] | iLevel | The serial number level to be set can only be 1 or 2.
Returns
Status Code
See also
CameraReadSN
Note
The camera comes with a three-level serial number, where the primary serial number is readable and cannot be modified. It has already been fixed. The secondary and tertiary serial numbers are freely readable and writable. Each serial number is 32 bytes.


CKCameraAPI: Version information

Functions
Version information
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSdkGetVersionString (char *pVersionString)
Get SDK version information. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCheckFwUpdate (HANDLE hCamera, BOOL *pNeedUpdate)
Detects the firmware version and needs to be upgraded. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFirmwareVision (HANDLE hCamera, char *pVersion)
gets the firmware version of the string More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetDeviceType (HANDLE hCamera, DWORD *pDeviceID)
Get device version ID. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInerfaceVersion (HANDLE hCamera, char *pVersion)
Get the version of the specified device interface. More...

Detailed Description

Function Documentation

◆ CameraCheckFwUpdate()

CKSDK_API CameraSdkStatus __stdcall CameraCheckFwUpdate | ( | HANDLE | hCamera,
 |  | BOOL * | pNeedUpdate
 | ) |  |

Detects the firmware version and needs to be upgraded.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pNeedUpdate | pointer, return firmware detection status, TRUE indicates need to update
Returns
Status Code

◆ CameraGetDeviceType()

CKSDK_API CameraSdkStatus __stdcall CameraGetDeviceType | ( | HANDLE | hCamera,
 |  | DWORD * | pDeviceID
 | ) |  |

Get device version ID.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pDeviceID | must point to a 4-byte buffer. Returns the device version ID.
Returns
Status Code

◆ CameraGetFirmwareVision()

CKSDK_API CameraSdkStatus __stdcall CameraGetFirmwareVision | ( | HANDLE | hCamera,
 |  | char * | pVersion
 | ) |  |

gets the firmware version of the string

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pVersion | must point to a buffer larger than 32 bytes. Returns the version string of the firmware.
Returns
Status Code

◆ CameraGetInerfaceVersion()

CKSDK_API CameraSdkStatus __stdcall CameraGetInerfaceVersion | ( | HANDLE | hCamera,
 |  | char * | pVersion
 | ) |  |

Get the version of the specified device interface.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pVersion | points to a buffer larger than 32 bytes and returns the interface version string.
Returns
Status Code

◆ CameraSdkGetVersionString()

CKSDK_API CameraSdkStatus __stdcall CameraSdkGetVersionString ( char * pVersionString )

Get SDK version information.

Parameters
[in] pVersionString Pointer, which returns the SDK version string. The buffer pointed to by this pointer must be larger than 32 bytes
Returns
Status Code


CKCameraAPI: Set property page

Functions
Set property page
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraShowSettingPage (HANDLE hCamera, BOOL bShow)
Sets the camera property configuration window display status. You must call CameraCreateSettingPageEx to create the camera property configuration window successfully before you can call this function to display. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetActivePage (HANDLE hCamera, LONG lActivePage, INT iDefault)
Sets the activation page of the camera configuration window. The camera configuration window has multiple sub-pages. This function can set which sub-page is active and displayed at the forefront. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCreateSettingPageEx (HANDLE hCamera)
Creates a camera configuration window. Before creating, you must first call CameraSetActivePage to set the subpage composition. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeResolution (HANDLE hCamera, tSdkImageResolution *pImageCustom)
Opens the resolution custom panel and visually configures a custom resolution. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeReferWin (HANDLE hCamera, INT iWinType, INT *piHOff, INT *piVOff, INT *piWidth, INT *piHeight)
Opens the reference window custom panel. And visually get the location of a custom window. A reference window for custom white balance and auto exposure is generally used. More...

Detailed Description

Function Documentation

◆ CameraCreateSettingPageEx()

CKSDK_API CameraSdkStatus __stdcall CameraCreateSettingPageEx ( HANDLE hCamera )

Creates a camera configuration window. Before creating, you must first call CameraSetActivePage to set the subpage composition.

Parameters
[in] hCamera The handle of the camera, obtained by the CameraInit function
Returns
Status Code

◆ CameraCustomizeReferWin()

CKSDK_API CameraSdkStatus __stdcall CameraCustomizeReferWin | ( | HANDLE | hCamera,
 |  | INT | iWinType,
 |  | INT * | piHOff,
 |  | INT * | piVOff,
 |  | INT * | piWidth,
 |  | INT * | piHeight
 | ) |  |

Opens the reference window custom panel. And visually get the location of a custom window. A reference window for custom white balance and auto exposure is generally used.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iWinType | The purpose of the reference window to be generated by iWinType. 0, automatic exposure reference window; 1, white balance reference window.
[out] | piHOff | Pointer, which returns the horizontal coordinate of the upper left corner of the custom window.
[out] | piVOff | Pointer, which returns the ordinate of the upper left corner of the custom window.
[out] | piWidth | Pointer, which returns the width of the custom window.
[out] | piHeight | pointer, which returns the height of the custom window.
Returns
Status Code

◆ CameraCustomizeResolution()

CKSDK_API CameraSdkStatus __stdcall CameraCustomizeResolution | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageCustom
 | ) |  |

Opens the resolution custom panel and visually configures a custom resolution.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pImageCustom | The pointer returns the custom resolution.
Returns
Status Code

◆ CameraSetActivePage()

CKSDK_API CameraSdkStatus __stdcall CameraSetActivePage | ( | HANDLE | hCamera,
 |  | LONG | lActivePage,
 |  | INT | iDefault
 | ) |  |

Sets the activation page of the camera configuration window. The camera configuration window has multiple sub-pages. This function can set which sub-page is active and displayed at the forefront.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | lActivePage | configuration page enable bit emSettingPage::SETTING_PAGE_ALL
[in] | iDefault | The index number of the iDefault subpage.
Returns
Status Code
See also
CameraCreateSettingPageEx
CameraShowSettingPage

◆ CameraShowSettingPage()

CKSDK_API CameraSdkStatus __stdcall CameraShowSettingPage | ( | HANDLE | hCamera,
 |  | BOOL | bShow
 | ) |  |

Sets the camera property configuration window display status. You must call CameraCreateSettingPageEx to create the camera property configuration window successfully before you can call this function to display.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | bShow | TRUE, display; FALSE, hidden.
Returns
Status Code
See also
CameraCreateSettingPageEx
CameraSetActivePage


CKCameraAPI: Save Image

Functions
Save Image
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall CameraSaveImage (HANDLE hCamera, const char *lpszFileName, const BYTE *pImgBuf, const stImageInfo *pImgInfo, UINT byFileType, BYTE byQuality)
Saves the image buffer data as an image file. More...

Detailed Description

Function Documentation

◆ CameraSaveImage()

CKSDK_API CameraSdkStatus __stdcall CameraSaveImage | ( | HANDLE | hCamera,
 |  | const char * | lpszFileName,
 |  | const BYTE * | pImgBuf,
 |  | const stImageInfo * | pImgInfo,
 |  | UINT | byFileType,
 |  | BYTE | byQuality
 | ) |  |

Saves the image buffer data as an image file.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | lpszFileName | The full path to the image save file.
[in] | pImgBuf | The data buffer for the pImgBuf image.
[in] | pImgInfo | The header information of the image.
[in] | byFileType | emFileType. Currently supported BMP, JPG, PNG, RAW four formats. Where RAW is represented Raw data output by the camera, saving RAW format file requirements pImgBuf and pImgInfo are by CameraGetOutImageBuffer The data obtained, and not converted by CameraImageProcess In BMP format; conversely, if you want to save to BMP format, pImgBuf and pImgInfo are CameraImageProcess processed RGB format data.
[in] | byQuality | The quality factor of the image save. This parameter is valid only when saved as JPG format, ranging from 1 to 100. The rest of the format can be written as 0.
Returns
Status Code
Note
Image saving function. Save images as RAW, using CameraSaveImage One of BMP, JPG, PNG. A typical process is:
  1. Use CameraGetRawImageBuffer function and CameraGetImageInfo Number is taken to RAW image data;
  2. Use the CameraGetOutImageBuffer function to convert RAW to BGR24 or 8-bit grayscale format. If you want to save RAW format data, skip back.
  3. CameraReleaseFrameHandle release frame buffer. CameraGetRawImageBuffer The right to use the RAW data buffer.
  4. CameraSaveImage function gets CameraGetOutImageBuffer function Image data is saved as BMP. If the RAW data is saved, use the CameraGetRawImageBuffer function and the CameraGetImageInfo function. RAW data buffer.


CKCameraAPI: Mirror and rotate

Functions
Mirror and rotate
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetMirror (HANDLE hCamera, INT iDir, BOOL bEnable)
Sets the image mirroring operation. The mirroring operation is divided into two directions, horizontal and vertical. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMirror (HANDLE hCamera, INT iDir, BOOL *pbEnable)
Gets the mirrored state of the image. More...

Detailed Description

Function Documentation

◆ CameraGetMirror()

CKSDK_API CameraSdkStatus __stdcall CameraGetMirror | ( | HANDLE | hCamera,
 |  | INT | iDir,
 |  | BOOL * | pbEnable
 | ) |  |

Gets the mirrored state of the image.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iDir | indicates the mirror direction to be obtained. 0, indicating the horizontal direction; 1, indicating the vertical direction.
[out] | pbEnable | pointer, return TRUE, indicating the direction pointed to by iDir Mirroring is enabled.
Returns
Status Code

◆ CameraSetMirror()

CKSDK_API CameraSdkStatus __stdcall CameraSetMirror | ( | HANDLE | hCamera,
 |  | INT | iDir,
 |  | BOOL | bEnable
 | ) |  |

Sets the image mirroring operation. The mirroring operation is divided into two directions, horizontal and vertical.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iDir | indicates the direction of the image. 0, indicating the horizontal direction; 1, indicating the vertical direction.
[in] | bEnable | TRUE, enable mirroring; FALSE, disable mirroring
Returns
Status Code


CKCameraAPI: IO settings

Functions
IO settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetOutputIOMode (HANDLE hCamera, INT outputIOIndex, INT mode)
Sets the operating mode of the output IO. The number of reserved output IOs is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutputIOMode (HANDLE hCamera, INT outputIOIndex, INT *pMode)
Get the operating mode of the output IO. The number of reserved output IOs is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetInputIOMode (HANDLE hCamera, INT inputIOIndex, INT mode)
Sets the mode of input IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInputIOMode (HANDLE hCamera, INT inputIOIndex, INT *pMode)
Get the mode of input IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOutputIOState (HANDLE hCamera, INT outputIOIndex, INT state)
Sets the level state of the specified IO. IO is the output type IO. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutputIOState (HANDLE hCamera, INT outputIOIndex, INT *pState)
Get the level state of the specified IO. IO is the output type IO. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOutputIOPWM (HANDLE hCamera, INT outputIOIndex, UINT cycle, UINT duty)
Sets the parameters of the PWM output. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutputIOPWM (HANDLE hCamera, INT outputIOIndex, INT *pCycle, INT *pDuty)
Get the parameters of the PWM output. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInputIOState (HANDLE hCamera, INT inputIOIndex, INT *pState)
Sets the level state of the specified IO. IO is the input type IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility. More...

Detailed Description

Function Documentation

◆ CameraGetInputIOMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetInputIOMode | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | INT * | pMode
 | ) |  |

Get the mode of input IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | inputIOIndex | IO index number, starting from 0
[out] | pMode | Enter IO mode, see emSdkInputIOMode
Returns
Status Code

◆ CameraGetInputIOState()

CKSDK_API CameraSdkStatus __stdcall CameraGetInputIOState | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | INT * | pState
 | ) |  |

Sets the level state of the specified IO. IO is the input type IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function.
[in] | inputIOIndex | The index number of IO, starting from 0.
[in] | pState | pointer, return IO status, 1 is on, 0 is not on
Returns
Status Code

◆ CameraGetOutputIOMode()

CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOMode | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT * | pMode
 | ) |  |

Get the operating mode of the output IO. The number of reserved output IOs is determined by iOutputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Outputs the index number of IO, starting from 0
[out] | pMode | Output IO mode, see emSdkOutputIOMode
Returns
Status Code

◆ CameraGetOutputIOPWM()

CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOPWM | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT * | pCycle,
 |  | INT * | pDuty
 | ) |  |

Get the parameters of the PWM output. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function.
[in] | outputIOIndex | The index number of IO, starting from 0.
[out] | pCycle | PWM period, unit (us)
[out] | pDuty | PWM high time, unit (us)
Returns
Status Code

◆ CameraGetOutputIOState()

CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOState | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT * | pState
 | ) |  |

Get the level state of the specified IO. IO is the output type IO. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | The index number of IO, starting from 0.
[in] | pState | The state to be set, 1 is on, 0 is not on
Returns
Status Code

◆ CameraSetInputIOMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetInputIOMode | ( | HANDLE | hCamera,
 |  | INT | inputIOIndex,
 |  | INT | mode
 | ) |  |

Sets the mode of input IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | inputIOIndex | IO index number, starting from 0
[in] | mode | Enter IO mode, see emSdkInputIOMode
Returns
Status Code

◆ CameraSetOutputIOMode()

CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOMode | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT | mode
 | ) |  |

Sets the operating mode of the output IO. The number of reserved output IOs is determined by iOutputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | Output IO port index number
[in] | outputIOIndex | Outputs the index number of IO, starting from 0
[in] | mode | Output IO mode, see emSdkOutputIOMode
Returns
Status Code

◆ CameraSetOutputIOPWM()

CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOPWM | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | UINT | cycle,
 |  | UINT | duty
 | ) |  |

Sets the parameters of the PWM output. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function.
[in] | outputIOIndex | The index number of IO, starting from 0.
[in] | cycle | PWM period, unit (us)
[in] | duty | PWM high time, unit (us), less than the value of cycle
Returns
Status Code

◆ CameraSetOutputIOState()

CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOState | ( | HANDLE | hCamera,
 |  | INT | outputIOIndex,
 |  | INT | state
 | ) |  |

Sets the level state of the specified IO. IO is the output type IO. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | outputIOIndex | The index number of IO, starting from 0.
[in] | state | The state to be set, 1 is on, 0 is not on
Returns
Status Code


CKCameraAPI: Advanced settings

Functions
Advanced settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameTime (HANDLE hCamera, double *pdFrameTime)
Get the current image frame time. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFrameSpeed (HANDLE hCamera, INT iFrameSpeed)
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameSpeed (HANDLE hCamera, INT *piFrameSpeed)
Gets the frame rate selection index number of the camera output image. Specific usage reference ??The functional description section of the function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameStatistic (HANDLE hCamera, FrameStatistic *psFrameStatistic)
Gets statistics on the frame rate received by the camera, including error frames and dropped frames. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetIntValue (HANDLE hCamera, emSdkValueType type, INT value)
sets the shaping parameters, the parameter type is defined by emSdkValueType More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetIntValue (HANDLE hCamera, emSdkValueType type, INT *pValue)
gets the shaping parameters, the parameter type is defined by emSdkValueType More...
CKSDK_API CameraSdkStatus __stdcall | CameraReboot (HANDLE hCamera)
reboot camera More...

Detailed Description

Function Documentation

◆ CameraGetFrameSpeed()

CKSDK_API CameraSdkStatus __stdcall CameraGetFrameSpeed | ( | HANDLE | hCamera,
 |  | INT * | piFrameSpeed
 | ) |  |

Gets the frame rate selection index number of the camera output image. Specific usage reference ??The functional description section of the function.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piFrameSpeed | ??pointer, which returns the selected frame rate mode index number.
Returns
Status Code

◆ CameraGetFrameStatistic()

CKSDK_API CameraSdkStatus __stdcall CameraGetFrameStatistic | ( | HANDLE | hCamera,
 |  | FrameStatistic * | psFrameStatistic
 | ) |  |

Gets statistics on the frame rate received by the camera, including error frames and dropped frames.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | psFrameStatistic | pointer, which returns statistics.
Returns
Status Code

◆ CameraGetFrameTime()

CKSDK_API CameraSdkStatus __stdcall CameraGetFrameTime | ( | HANDLE | hCamera,
 |  | double * | pdFrameTime
 | ) |  |

Get the current image frame time.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pdFrameTime | The pointer returns the current frame time in microseconds.
Returns
Status Code

◆ CameraGetIntValue()

CKSDK_API CameraSdkStatus __stdcall CameraGetIntValue | ( | HANDLE | hCamera,
 |  | emSdkValueType | type,
 |  | INT * | pValue
 | ) |  |

gets the shaping parameters, the parameter type is defined by emSdkValueType

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | type | Set the parameter type, refer to emSdkValueType
[in] | pValue | Set parameter value

◆ CameraReboot()

CKSDK_API CameraSdkStatus __stdcall CameraReboot ( HANDLE hCamera )

reboot camera

Parameters
[in] hCamera camera handle, obtained by CameraInit function

◆ CameraSetFrameSpeed()

CKSDK_API CameraSdkStatus __stdcall CameraSetFrameSpeed | ( | HANDLE | hCamera,
 |  | INT | iFrameSpeed
 | ) |  |

◆ CameraSetIntValue()

CKSDK_API CameraSdkStatus __stdcall CameraSetIntValue | ( | HANDLE | hCamera,
 |  | emSdkValueType | type,
 |  | INT | value
 | ) |  |

sets the shaping parameters, the parameter type is defined by emSdkValueType

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | type | Set the parameter type, refer to emSdkValueType
[in] | value | Set parameter value
Note
IMAGE_CHANNEL_MASK is used to set the image data of which channels are output by the multi-channel camera. Each bit of the binary value of the value is set to 1 to represent the data of this channel. For example, bit0 represents the image of output channel 0, bit1 represents the image of output channel 1, bit2 represents the image of output channel 2, and bit3 represents the image of output channel 3. In addition, these bits The combination represents which channels of images are output at the same time:
CameraSetIntValue(hCamera, IMAGE_CHANNEL_MASK, 0x1); //Only output the image data of channel 0
CameraSetIntValue(hCamera, IMAGE_CHANNEL_MASK, 0x2); //Only output the image data of the 1st channel
CameraSetIntValue(hCamera, IMAGE_CHANNEL_MASK, 0x3); //Output the image data of channel 0 and channel 1 at the same time
CameraSetIntValue(hCamera, IMAGE_CHANNEL_MASK, 0x7); //Simultaneously output the image data of the 0th channel, the 1st channel and the 2nd channel
CameraSetIntValue(hCamera, IMAGE_CHANNEL_MASK, 0xf); //output 4 channels of image data at the same time


CKCameraAPI: ROI settings

Functions
ROI settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Sets the resolution of the camera output image in snap mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Get the resolution in snap mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolution (HANDLE hCamera, INT iResolutionIndex)
Sets the resolution of the camera output image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolution (HANDLE hCamera, INT *piResolutionIndex)
Get the resolution of the camera output image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionEx (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Sets the resolution of the custom preview. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionEx (HANDLE hCamera, INT iResolution, tSdkImageResolution *pImageResolution)
Get the resolution of the index number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurResolution (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Get the resolution of the current preview. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageSize (HANDLE hCamera, DWORD *pWidth, DWORD *pHeight)
Gets the size of the output image. More...

Detailed Description

Function Documentation

◆ CameraGetCurResolution()

CKSDK_API CameraSdkStatus __stdcall CameraGetCurResolution | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

Get the resolution of the current preview.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pImageResolution | Structure pointer to return the current resolution.
Returns
Status Code

◆ CameraGetOutImageSize()

CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageSize | ( | HANDLE | hCamera,
 |  | DWORD * | pWidth,
 |  | DWORD * | pHeight
 | ) |  |

Gets the size of the output image.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pWidth | Pointer to return the width of the output image.
[out] | pHeight | The pointer is used to return the height of the output image.
Returns
Status Code

◆ CameraGetResolution()

CKSDK_API CameraSdkStatus __stdcall CameraGetResolution | ( | HANDLE | hCamera,
 |  | INT * | piResolutionIndex
 | ) |  |

Get the resolution of the camera output image.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | piResolutionIndex | Pointer to return the selected frame rate mode index number, see emResolutionMode.
Returns
Status Code

◆ CameraGetResolutionEx()

CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionEx | ( | HANDLE | hCamera,
 |  | INT | iResolution,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

Get the resolution of the index number.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iResolution | Get the index number of the resolution, see emResolutionMode, custom 0xff
[out] | pImageResolution | Structure pointer to return the current resolution.
Returns
Status Code

◆ CameraGetResolutionForSnap()

CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionForSnap | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

Get the resolution in snap mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pImageResolution | The pointer returns the resolution of the snap mode.
Returns
Status Code

◆ CameraSetResolution()

CKSDK_API CameraSdkStatus __stdcall CameraSetResolution | ( | HANDLE | hCamera,
 |  | INT | iResolutionIndex
 | ) |  |

Sets the resolution of the camera output image.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | iResolutionIndex | The selected frame rate mode index number, the resolution mode that the camera can choose from CameraGetCapability Get the information structure in iImageSizeDesc Indicates the number of resolution modes that can be selected.
Returns
Status Code

◆ CameraSetResolutionEx()

CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionEx | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

Sets the resolution of the custom preview.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pImageResolution | Structure pointer to return the current resolution.
Returns
Status Code

◆ CameraSetResolutionForSnap()

CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionForSnap | ( | HANDLE | hCamera,
 |  | tSdkImageResolution * | pImageResolution
 | ) |  |

Sets the resolution of the camera output image in snap mode.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | pImageResolution | if pImageResolution->iWidth And pImageResolution->iHeight are both 0, It means that it is set to follow the current preview resolution. Grab The resolution of the image that is afraid will be the same as the current setting. The preview resolution is the same.
Returns
Status Code


CKCameraAPI: GigE settings

Functions
GigE settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetIp (const char *pCameraSN, tGigeNetworkInfo *pNetworkInfo)
Set the camera's network address by camera serial number. This interface only supports GIGE cameras. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetIp (const char *pCameraSN, const tGigeNetworkInfo *pNetworkInfo)
Set the camera's network address by the camera's serial number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetTransPacketSize (HANDLE hCamera, UINT *pPacketSize)
Set the camera's network address by the camera's serial number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetTransPacketSize (HANDLE hCamera, UINT packetSize)
Get the camera's network address by the camera's serial number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetPacketDelayTime (HANDLE hCamera, UINT *pDelayUs)
Set the delay interval for GVSP packets of GigE camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetPacketDelayTime (HANDLE hCamera, UINT delayUs)
Get the delay interval for GVSP packets of GigE camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetResend (HANDLE hCamera, BOOL bEnable, UINT nMaxResendPercent, UINT nResendTimeout)
Set the retransmission parameters of the Gige camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetOptimalPacketSize (HANDLE hCamera, UINT *pOptimalPacketSize)
Get the delay interval for GVSP packets of GigE camera. More...

Detailed Description

Function Documentation

◆ CameraGigeGetIp()

CKSDK_API CameraSdkStatus __stdcall CameraGigeGetIp | ( | const char * | pCameraSN,
 |  | tGigeNetworkInfo * | pNetworkInfo
 | ) |  |

Set the camera's network address by camera serial number. This interface only supports GIGE cameras.

Parameters
[in] | pCameraSN | Camera serial number, serial number can be obtained by CameraEnumerateDevice
[out] | pNetworkInfo | Network information for camera communication
Returns
Status Code
See also
CameraGigeSetIp

◆ CameraGigeGetOptimalPacketSize()

CKSDK_API CameraSdkStatus __stdcall CameraGigeGetOptimalPacketSize | ( | HANDLE | hCamera,
 |  | UINT * | pOptimalPacketSize
 | ) |  |

Get the delay interval for GVSP packets of GigE camera.

Get GigE camera GVSP optimal transmission packet size

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[out] | pOptimalPacketSize | Returns the optimal packet size for GVSP transmission from Gige cameras
Returns
Status code

◆ CameraGigeGetPacketDelayTime()

CKSDK_API CameraSdkStatus __stdcall CameraGigeGetPacketDelayTime | ( | HANDLE | hCamera,
 |  | UINT * | pDelayUs
 | ) |  |

Set the delay interval for GVSP packets of GigE camera.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[out] | pDelayUs | GVSP packet interval time
Returns
Status code
Note
GVSP packet interval time range is 0 to 1000 microseconds, the default value is 0
See also
CameraGigeSetPacketDelayTime

◆ CameraGigeGetTransPacketSize()

CKSDK_API CameraSdkStatus __stdcall CameraGigeGetTransPacketSize | ( | HANDLE | hCamera,
 |  | UINT * | pPacketSize
 | ) |  |

Set the camera's network address by the camera's serial number.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[out] | pPacketSize | transport network packet size
Returns
Status Code
Note
Network packet transfer size ranges from 1500 to 9000
See also
CameraGigeSetTransPacketSize

◆ CameraGigeSetIp()

CKSDK_API CameraSdkStatus __stdcall CameraGigeSetIp | ( | const char * | pCameraSN,
 |  | const tGigeNetworkInfo * | pNetworkInfo
 | ) |  |

Set the camera's network address by the camera's serial number.

Parameters
[in] | pCameraSN | Camera serial number, serial number can be obtained by CameraEnumerateDevice
[out] | pNetworkInfo | Network information for camera communication
Returns
Status Code
See also
CameraGigeSetIp

◆ CameraGigeSetPacketDelayTime()

CKSDK_API CameraSdkStatus __stdcall CameraGigeSetPacketDelayTime | ( | HANDLE | hCamera,
 |  | UINT | delayUs
 | ) |  |

Get the delay interval for GVSP packets of GigE camera.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[out] | delayUs | GVSP packet interval time
Returns
Status code
Note
GVSP packet interval time range is 0 to 1000 microseconds, the default value is 0
See also
CameraGigeGetPacketDelayTime

◆ CameraGigeSetResend()

CKSDK_API CameraSdkStatus __stdcall CameraGigeSetResend | ( | HANDLE | hCamera,
 |  | BOOL | bEnable,
 |  | UINT | nMaxResendPercent,
 |  | UINT | nResendTimeout
 | ) |  |

Set the retransmission parameters of the Gige camera.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | bEnable | whether to enable retransmission
[in] | nMaxResendPercent | Maximum resend ratio
[in] | nResendTimeout | resend timeout
Returns
Status code
Note
Gige camera has the retransmission function enabled by default

◆ CameraGigeSetTransPacketSize()

CKSDK_API CameraSdkStatus __stdcall CameraGigeSetTransPacketSize | ( | HANDLE | hCamera,
 |  | UINT | packetSize
 | ) |  |

Get the camera's network address by the camera's serial number.

Parameters
[in] | hCamera | The handle of the camera, obtained by the CameraInit function
[in] | packetSize | transport network packet size
Returns
Status Code
Note
Network packet transfer size ranges from 1500 to 9000
See also
CameraGigeGetTransPacketSize


CKCameraAPI: Record settings

Functions
Record settings
SDK interface function

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraStartRecord (HANDLE hCamera, const char *pstrSavePath, INT iFormat, INT iBitrate, INT iFrameRate)
start recording More...
CKSDK_API CameraSdkStatus __stdcall | CameraPushOneFrame (HANDLE hCamera, const BYTE *pFrameBuffer, const stImageInfo *pImgInfo)
Write a frame of image data to the video file. More...
CKSDK_API CameraSdkStatus __stdcall | CameraStopRecord (HANDLE hCamera)
end recording More...

Detailed Description

Function Documentation

◆ CameraPushOneFrame()

CKSDK_API CameraSdkStatus __stdcall CameraPushOneFrame | ( | HANDLE | hCamera,
 |  | const BYTE * | pFrameBuffer,
 |  | const stImageInfo * | pImgInfo
 | ) |  |

Write a frame of image data to the video file.

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | pFrameBuffer | pointer, image data address
[in] | pImgInfo | image data information
Returns
Status code
Note
This function must be called after the CameraStartRecord function is called
See also
CameraStartRecord CameraStopRecord

◆ CameraStartRecord()

CKSDK_API CameraSdkStatus __stdcall CameraStartRecord | ( | HANDLE | hCamera,
 |  | const char * | pstrSavePath,
 |  | INT | iFormat,
 |  | INT | iBitrate,
 |  | INT | iFrameRate
 | ) |  |

start recording

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | pstrSavePath | The path to save the video file
[in] | iFormat | The format of the video file, 0: avi file
[in] | iBitrate | video file stream size, valid range -1 and 1000000-10000000, the larger the value, the better the image quality after compression, the smaller the compression rate, the larger the file, -1 means no compression
[in] | iFrameRate | The frame rate of the video file
Returns
Status code
Note
currently only supports AVI video files, save original image data, does not support compression
See also
CameraPushOneFrame CameraStopRecord

◆ CameraStopRecord()

CKSDK_API CameraSdkStatus __stdcall CameraStopRecord ( HANDLE hCamera )

end recording

Parameters
[in] hCamera camera handle, obtained by CameraInit function
Returns
Status code
Note
This function must be called after the CameraStartRecord function is called
See also
CameraStartRecord CameraPushOneFrame


CKCameraAPI: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
C _DisplayWindow | Display window parameters
C _FrameStatistic | Frame rate statistics
C _stImageInfo | Frame header information
C _tContrastRange | Contrast setting range
C _tDevEnumInfo | Enumeration information
C _tDeviceCfg | Device Capability Level
C _tDevInfo | Camera device information
C _tDevLoadInfo | Current mode and enumeration information for the device
C _tDevLoadMode | Device loading mode information
C _tExpose | Camera exposure function range definition
C _tGammaContrastRange | Gamma contrast setting range
C _tGammaRange | Gamma setting range
C _tGigeNetworkInfo | Network information of GigE camera
C _tInitCameraParam | When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera
C _tIspAe | Exposure parameters
C _tIspGamma | Gama parameter
C _tIspWb | White balance parameter
C _tLscCalibParam | LSC calibration parameter
C _tLscCorrectParam | LSC correction parameter
C _tResolutionRange | Camera resolution setting range for widget UI
C _tRgbGainRange | RGB three-channel digital gain setting range
C _tSaturationRange | Range of saturation setting
C _tSdkAeAlgorithm | AE algorithm description
C _tSdkBayerDecodeAlgorithm | RAW to RGB algorithm description
C _tSdkBayerType | Image data format output by the camera
C _tSdkCameraCapbility | Camera Ability Level
C _tSdkColorTemperatureDes | Camera white balance color temperature mode description information
C _tSdkFrameSpeed | Camera frame rate description information
C _tSdkImageResolution | Camera resolution description
C _tSdkIspCapacity | ISP module enable information
C _tSdkMediaType | Image data format output by the camera
C _tSdkPackLength | Transfer packet size description (mainly valid for web cameras)
C _tSdkPresetLut | Preset LUT table description
C _tSdkTrigger | Trigger Mode Description
C _tSensorCfg | Sensor level
C _tSharpnessRange | Sharpening setting range
C tagRECT |


CKCameraAPI: _DisplayWindow Struct Reference

Public Attributes | List of all members
_DisplayWindow Struct Reference

Display window parameters. More...

#include <CKDeviceDef.h>

Public Attributes

uint32_t | ImageWidth
Image width. More...
uint32_t | ImageHeight
Image height. More...
RECT WinRect
Display window rectangle. More...
RECT ImageRect
Effective image rectangle. More...

Detailed Description

Display window parameters.

Member Data Documentation

◆ ImageHeight

uint32_t _DisplayWindow::ImageHeight

Image height.

◆ ImageRect

RECT _DisplayWindow::ImageRect

Effective image rectangle.

◆ ImageWidth

uint32_t _DisplayWindow::ImageWidth

Image width.

◆ WinRect

RECT _DisplayWindow::WinRect

Display window rectangle.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _FrameStatistic Struct Reference

Public Attributes | List of all members
_FrameStatistic Struct Reference

Frame rate statistics. More...

#include <CKDeviceDef.h>

Public Attributes

uint32_t | iTotal
Total number of frames currently captured (including error frames) More...
uint32_t | iCapture
The number of valid frames currently being collected. More...
int | iLost
The current number of dropped frames. More...

Detailed Description

Frame rate statistics.

Member Data Documentation

◆ iCapture

uint32_t _FrameStatistic::iCapture

The number of valid frames currently being collected.

◆ iLost

int _FrameStatistic::iLost

The current number of dropped frames.

◆ iTotal

uint32_t _FrameStatistic::iTotal

Total number of frames currently captured (including error frames)

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _stImageInfo Struct Reference

Public Attributes | List of all members
_stImageInfo Struct Reference

Frame header information. More...

#include <CKDeviceDef.h>

Public Attributes

uint32_t | iWidth
Current image width. More...
uint32_t | iHeight
Current image height. More...
uint32_t | TotalBytes
Image data bytes, Total bytes. More...
uint32_t | uiMediaType
Image format. More...
double | ExpTime
The exposure time of the current image in microseconds us. More...
double | ExpLineTime
Line exposure time of the current image in microseconds us. More...
uint32_t | Gain
Gain multiple of the current image. More...

Detailed Description

Frame header information.

Member Data Documentation

◆ ExpLineTime

double _stImageInfo::ExpLineTime

Line exposure time of the current image in microseconds us.

◆ ExpTime

double _stImageInfo::ExpTime

The exposure time of the current image in microseconds us.

◆ Gain

uint32_t _stImageInfo::Gain

Gain multiple of the current image.

◆ iHeight

uint32_t _stImageInfo::iHeight

Current image height.

◆ iWidth

uint32_t _stImageInfo::iWidth

Current image width.

◆ TotalBytes

uint32_t _stImageInfo::TotalBytes

Image data bytes, Total bytes.

◆ uiMediaType

uint32_t _stImageInfo::uiMediaType

Image format.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tContrastRange Struct Reference

Public Attributes | List of all members
_tContrastRange Struct Reference

Contrast setting range. More...

#include <CKDeviceDef.h>

Public Attributes

int | iMin
Minimum value. More...
int | iMax
Maximum value. More...

Detailed Description

Contrast setting range.

Member Data Documentation

◆ iMax

int _tContrastRange::iMax

Maximum value.

◆ iMin

int _tContrastRange::iMin

Minimum value.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tDevEnumInfo Struct Reference

Public Attributes | List of all members
_tDevEnumInfo Struct Reference

Enumeration information. More...

#include <CKDeviceDef.h>

Public Attributes

tDevInfo DevAttribute
Device Attribute Information. More...
int bDevOpen
Whether the current device is turned on 0: The device is not turned on; 1: The device is already turned on. More...

Detailed Description

Enumeration information.

Member Data Documentation

◆ bDevOpen

int _tDevEnumInfo::bDevOpen

Whether the current device is turned on 0: The device is not turned on; 1: The device is already turned on.

◆ DevAttribute

tDevInfo _tDevEnumInfo::DevAttribute

Device Attribute Information.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tDeviceCfg Struct Reference

Public Attributes | List of all members
_tDeviceCfg Struct Reference

Device Capability Level. More...

#include <CKDeviceDef.h>

Public Attributes

tRgbGainRange sRgbGainRange
Image Digital Gain Range Description. More...
tSaturationRange sSaturationRange
Description of saturation range. More...
tGammaRange sGammaRange
Gamma range description. More...
tGammaContrastRange sGammaContrastRange
Gamma Contrast Range Description. More...
tContrastRange sContrastRange
Contrast range description. More...
tSharpnessRange sSharpnessRange
Sharpening range description. More...
tSdkIspCapacity sIspCapacity
ISP Capability Description. More...
tSdkTrigger * pTriggerDesc
trigger mode More...
int | iTriggerDesc
The number of trigger modes, the size of the pTriggerDesc array. More...
tSdkImageResolution * pImageSizeDesc
Preset resolution selection. More...
int | iImageSizeDesc
The number of preset resolutions, the size of the pImageSizeDesc array. More...
tSdkColorTemperatureDes * pClrTempDesc
Preset color temperature mode for white balance. More...
int | iClrTempDesc
tSdkBayerType * pBayerTypeDesc
Camera Bayer format. More...
int | iBayerTypeDesc
The number of types of camera Bayer format, the size of the pBayerTypeDesc array. More...
tSdkMediaType * pMediaTypeDesc
Camera output image format. More...
int | iMediaTypeDesc
The number of types of camera output image formats, the size of the pMediaTypeDesc array. More...
tSdkFrameSpeed * pFrameSpeedDesc
Adjustable frame rate type, corresponding to the normal high speed and super speed settings on the interface. More...
int | iFrameSpeedDesc
Adjusts the number of frame rate types, which is the size of the pFrameSpeedDesc array. More...
tSdkPackLength * pPackLenDesc
Transport packet length, generally used for network devices. More...
int | iPackLenDesc
The number of transport packet lengths to choose from, which is the size of the pPackLenDesc array. More...
int | iOutputIoCounts
Number of programmable output IOs. More...
int | iInputIoCounts
Number of programmable input IOs. More...
tSdkPresetLut * pPresetLutDesc
Camera preset LUT table. More...
int | iPresetLut
The number of LUT tables preset by the camera, the size of the pPresetLutDesc array. More...
int | iUserDataMaxLen
Indicates the maximum length in the camera that will be used to save the user data area. 0 means no. More...
int | bParamInDevice
Indicates whether the device supports reading and writing parameter groups from the device. 1 is support, 0 is not supported. More...
tSdkAeAlgorithm * pAeAlmSwDesc
Software Auto Exposure Algorithm Description. More...
int | iAeAlmSwDesc
Software automatic exposure algorithm number. More...
tSdkAeAlgorithm * pAeAlmHdDesc
Hardware auto-exposure algorithm description, NULL means hardware auto-exposure is not supported. More...
int | iAeAlmHdDesc
Number of hardware auto-exposure algorithms, 0 means hardware auto-exposure is not supported. More...
tSdkBayerDecodeAlgorithm * pBayerDecAlmSwDesc
Software Bayer algorithm for converting to RGB data. More...
int | iBayerDecAlmSwDesc
Software Bayer algorithm for converting to RGB data. More...
tSdkBayerDecodeAlgorithm * pBayerDecAlmHdDesc
Algorithm description of hardware Bayer converted to RGB data, not supported for NULL. More...
int | iBayerDecAlmHdDesc
The number of algorithms that hardware Bayer converts to RGB data, 0 means not supported. More...

Detailed Description

Device Capability Level.

Member Data Documentation

◆ bParamInDevice

int _tDeviceCfg::bParamInDevice

Indicates whether the device supports reading and writing parameter groups from the device. 1 is support, 0 is not supported.

◆ iAeAlmHdDesc

int _tDeviceCfg::iAeAlmHdDesc

Number of hardware auto-exposure algorithms, 0 means hardware auto-exposure is not supported.

◆ iAeAlmSwDesc

int _tDeviceCfg::iAeAlmSwDesc

Software automatic exposure algorithm number.

◆ iBayerDecAlmHdDesc

int _tDeviceCfg::iBayerDecAlmHdDesc

The number of algorithms that hardware Bayer converts to RGB data, 0 means not supported.

◆ iBayerDecAlmSwDesc

int _tDeviceCfg::iBayerDecAlmSwDesc

Software Bayer algorithm for converting to RGB data.

◆ iBayerTypeDesc

int _tDeviceCfg::iBayerTypeDesc

The number of types of camera Bayer format, the size of the pBayerTypeDesc array.

◆ iClrTempDesc

int _tDeviceCfg::iClrTempDesc

◆ iFrameSpeedDesc

int _tDeviceCfg::iFrameSpeedDesc

Adjusts the number of frame rate types, which is the size of the pFrameSpeedDesc array.

◆ iImageSizeDesc

int _tDeviceCfg::iImageSizeDesc

The number of preset resolutions, the size of the pImageSizeDesc array.

◆ iInputIoCounts

int _tDeviceCfg::iInputIoCounts

Number of programmable input IOs.

◆ iMediaTypeDesc

int _tDeviceCfg::iMediaTypeDesc

The number of types of camera output image formats, the size of the pMediaTypeDesc array.

◆ iOutputIoCounts

int _tDeviceCfg::iOutputIoCounts

Number of programmable output IOs.

◆ iPackLenDesc

int _tDeviceCfg::iPackLenDesc

The number of transport packet lengths to choose from, which is the size of the pPackLenDesc array.

◆ iPresetLut

int _tDeviceCfg::iPresetLut

The number of LUT tables preset by the camera, the size of the pPresetLutDesc array.

◆ iTriggerDesc

int _tDeviceCfg::iTriggerDesc

The number of trigger modes, the size of the pTriggerDesc array.

◆ iUserDataMaxLen

int _tDeviceCfg::iUserDataMaxLen

Indicates the maximum length in the camera that will be used to save the user data area. 0 means no.

◆ pAeAlmHdDesc

tSdkAeAlgorithm* _tDeviceCfg::pAeAlmHdDesc

Hardware auto-exposure algorithm description, NULL means hardware auto-exposure is not supported.

◆ pAeAlmSwDesc

tSdkAeAlgorithm* _tDeviceCfg::pAeAlmSwDesc

Software Auto Exposure Algorithm Description.

◆ pBayerDecAlmHdDesc

tSdkBayerDecodeAlgorithm* _tDeviceCfg::pBayerDecAlmHdDesc

Algorithm description of hardware Bayer converted to RGB data, not supported for NULL.

◆ pBayerDecAlmSwDesc

tSdkBayerDecodeAlgorithm* _tDeviceCfg::pBayerDecAlmSwDesc

Software Bayer algorithm for converting to RGB data.

◆ pBayerTypeDesc

tSdkBayerType* _tDeviceCfg::pBayerTypeDesc

Camera Bayer format.

◆ pClrTempDesc

tSdkColorTemperatureDes* _tDeviceCfg::pClrTempDesc

Preset color temperature mode for white balance.

◆ pFrameSpeedDesc

tSdkFrameSpeed* _tDeviceCfg::pFrameSpeedDesc

Adjustable frame rate type, corresponding to the normal high speed and super speed settings on the interface.

◆ pImageSizeDesc

tSdkImageResolution* _tDeviceCfg::pImageSizeDesc

Preset resolution selection.

◆ pMediaTypeDesc

tSdkMediaType* _tDeviceCfg::pMediaTypeDesc

Camera output image format.

◆ pPackLenDesc

tSdkPackLength* _tDeviceCfg::pPackLenDesc

Transport packet length, generally used for network devices.

◆ pPresetLutDesc

tSdkPresetLut* _tDeviceCfg::pPresetLutDesc

Camera preset LUT table.

◆ pTriggerDesc

tSdkTrigger* _tDeviceCfg::pTriggerDesc

trigger mode

◆ sContrastRange

tContrastRange _tDeviceCfg::sContrastRange

Contrast range description.

◆ sGammaContrastRange

tGammaContrastRange _tDeviceCfg::sGammaContrastRange

Gamma Contrast Range Description.

◆ sGammaRange

tGammaRange _tDeviceCfg::sGammaRange

Gamma range description.

◆ sIspCapacity

tSdkIspCapacity _tDeviceCfg::sIspCapacity

ISP Capability Description.

◆ sRgbGainRange

tRgbGainRange _tDeviceCfg::sRgbGainRange

Image Digital Gain Range Description.

◆ sSaturationRange

tSaturationRange _tDeviceCfg::sSaturationRange

Description of saturation range.

◆ sSharpnessRange

tSharpnessRange _tDeviceCfg::sSharpnessRange

Sharpening range description.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tDevInfo Struct Reference

Public Attributes | List of all members
_tDevInfo Struct Reference

Camera device information. More...

#include <CKDeviceDef.h>

Public Attributes

char | acProductSeries [32]
Product Line. More...
char | acProductName [32]
Product Name. More...
char | acFriendlyName [32]
Product nickname, user can customize the nickname, save it in the camera, used to distinguish multiple cameras at the same time, you can use the CameraSetFriendlyName interface to change the nickname, the device will take effect after restart. More...
char | acLinkName [32]
Kernel symbolic link name, internal use. More...
char | acDriverName [128]
driver name More...
char | acDriverVersion [32]
driver version More...
char | acSensorType [32]
sensor type More...
char | acPortType [32]
interface type More...
uint32_t | uInstance
The instance index number of this model camera on this computer is used to distinguish the same model multi-camera. More...
char | acSn [32]
Product unique serial number. More...
uint16_t | VendorID
Vendor ID. More...
uint16_t | DeviceDrvID
Device Driver ID. More...
uint16_t | DeviceDrvVersionID
Device Driver Version ID. More...
uint32_t | DeviceID
Device ID. More...
char | SymbolicName [128]
device label, internal use More...
char | Name [64]
device label, internal use More...
uint32_t | SensorID
Sensor ID. More...

Detailed Description

Camera device information.

Member Data Documentation

◆ acDriverName

char _tDevInfo::acDriverName[128]

driver name

◆ acDriverVersion

char _tDevInfo::acDriverVersion[32]

driver version

◆ acFriendlyName

char _tDevInfo::acFriendlyName[32]

Product nickname, user can customize the nickname, save it in the camera, used to distinguish multiple cameras at the same time, you can use the CameraSetFriendlyName interface to change the nickname, the device will take effect after restart.

◆ acLinkName

char _tDevInfo::acLinkName[32]

Kernel symbolic link name, internal use.

◆ acPortType

char _tDevInfo::acPortType[32]

interface type

◆ acProductName

char _tDevInfo::acProductName[32]

Product Name.

◆ acProductSeries

char _tDevInfo::acProductSeries[32]

Product Line.

◆ acSensorType

char _tDevInfo::acSensorType[32]

sensor type

◆ acSn

char _tDevInfo::acSn[32]

Product unique serial number.

◆ DeviceDrvID

uint16_t _tDevInfo::DeviceDrvID

Device Driver ID.

◆ DeviceDrvVersionID

uint16_t _tDevInfo::DeviceDrvVersionID

Device Driver Version ID.

◆ DeviceID

uint32_t _tDevInfo::DeviceID

Device ID.

See also
emDeviceType

◆ Name

char _tDevInfo::Name[64]

device label, internal use

◆ SensorID

uint32_t _tDevInfo::SensorID

Sensor ID.

◆ SymbolicName

char _tDevInfo::SymbolicName[128]

device label, internal use

◆ uInstance

uint32_t _tDevInfo::uInstance

The instance index number of this model camera on this computer is used to distinguish the same model multi-camera.

◆ VendorID

uint16_t _tDevInfo::VendorID

Vendor ID.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tDevLoadInfo Struct Reference

Public Attributes | List of all members
_tDevLoadInfo Struct Reference

Current mode and enumeration information for the device. More...

#include <CKDeviceDef.h>

Public Attributes

tDevEnumInfo DevEnumInfo
Enumeration information. More...
tDevLoadMode DevLoadMode
Device mode information. More...

Detailed Description

Current mode and enumeration information for the device.

Member Data Documentation

◆ DevEnumInfo

tDevEnumInfo _tDevLoadInfo::DevEnumInfo

Enumeration information.

◆ DevLoadMode

tDevLoadMode _tDevLoadInfo::DevLoadMode

Device mode information.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tDevLoadMode Struct Reference

Public Attributes | List of all members
_tDevLoadMode Struct Reference

Device loading mode information. More...

#include <CKDeviceDef.h>

Public Attributes

tIspAe sIspAe
AE parameters. More...
tIspWb sIspWb
White balance parameter. More...
uint32_t | TriggerMode
Trigger mode. More...
uint32_t | ResolutionMode
Resolution. More...
uint32_t | MediaTypeMode
Output format. More...
uint32_t | FrameSpeedMode
Frame rate. More...
uint32_t | Sharpness
Sharpness. More...
uint32_t | Saturation
Saturation. More...
uint32_t | Contrast
Contrast. More...
tIspGamma sIspGamma
Gamma parameters. More...
uint32_t | ParameterMode
Pattern of parameter. More...
uint32_t | ParameterTeam
Group of parameters. More...
uint32_t | MirrorHEn
Horizontal Mirroring Enable. More...
uint32_t | MirrorVEn
Vertical Mirror Enable. More...
uint32_t | ColorToGrayEn
Color to gray image. More...
uint32_t | BlackLevel
Black level. More...
uint8_t | EnableCorrectDeadPixel
Enable correct dead pixel. More...
uint8_t | EnableWdr
Enable WDR. More...
uint8_t | rev [2]
保留字节 More...

Detailed Description

Device loading mode information.

Member Data Documentation

◆ BlackLevel

uint32_t _tDevLoadMode::BlackLevel

Black level.

◆ ColorToGrayEn

uint32_t _tDevLoadMode::ColorToGrayEn

Color to gray image.

◆ Contrast

uint32_t _tDevLoadMode::Contrast

Contrast.

◆ EnableCorrectDeadPixel

uint8_t _tDevLoadMode::EnableCorrectDeadPixel

Enable correct dead pixel.

◆ EnableWdr

uint8_t _tDevLoadMode::EnableWdr

Enable WDR.

◆ FrameSpeedMode

uint32_t _tDevLoadMode::FrameSpeedMode

Frame rate.

◆ MediaTypeMode

uint32_t _tDevLoadMode::MediaTypeMode

Output format.

◆ MirrorHEn

uint32_t _tDevLoadMode::MirrorHEn

Horizontal Mirroring Enable.

◆ MirrorVEn

uint32_t _tDevLoadMode::MirrorVEn

Vertical Mirror Enable.

◆ ParameterMode

uint32_t _tDevLoadMode::ParameterMode

Pattern of parameter.

◆ ParameterTeam

uint32_t _tDevLoadMode::ParameterTeam

Group of parameters.

◆ ResolutionMode

uint32_t _tDevLoadMode::ResolutionMode

Resolution.

◆ rev

uint8_t _tDevLoadMode::rev[2]

保留字节

◆ Saturation

uint32_t _tDevLoadMode::Saturation

Saturation.

◆ Sharpness

uint32_t _tDevLoadMode::Sharpness

Sharpness.

◆ sIspAe

tIspAe _tDevLoadMode::sIspAe

AE parameters.

◆ sIspGamma

tIspGamma _tDevLoadMode::sIspGamma

Gamma parameters.

◆ sIspWb

tIspWb _tDevLoadMode::sIspWb

White balance parameter.

◆ TriggerMode

uint32_t _tDevLoadMode::TriggerMode

Trigger mode.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tExpose Struct Reference

Public Attributes | List of all members
_tExpose Struct Reference

Camera exposure function range definition. More...

#include <CKDeviceDef.h>

Public Attributes

uint32_t | uiTargetMin
Automatic exposure brightness target minimum. More...
uint32_t | uiTargetMax
Auto exposure brightness target maximum. More...
uint32_t | uiAnalogGainMin
The minimum value of the analog gain in multiples, then 1000 times larger. More...
uint32_t | uiAnalogGainMax
The maximum value of the analog gain in multiples, then 1000 times larger. More...
uint32_t | uiExposeTimeMin
The minimum exposure time in manual mode, in units of lines. According to CameraGetExposureLineTime, you can get the corresponding time (microseconds) of a line, so as to get the exposure time of the whole frame. More...
uint32_t | uiExposeTimeMax
Maximum value of exposure time in manual mode, unit: line. More...

Detailed Description

Camera exposure function range definition.

Member Data Documentation

◆ uiAnalogGainMax

uint32_t _tExpose::uiAnalogGainMax

The maximum value of the analog gain in multiples, then 1000 times larger.

◆ uiAnalogGainMin

uint32_t _tExpose::uiAnalogGainMin

The minimum value of the analog gain in multiples, then 1000 times larger.

◆ uiExposeTimeMax

uint32_t _tExpose::uiExposeTimeMax

Maximum value of exposure time in manual mode, unit: line.

◆ uiExposeTimeMin

uint32_t _tExpose::uiExposeTimeMin

The minimum exposure time in manual mode, in units of lines. According to CameraGetExposureLineTime, you can get the corresponding time (microseconds) of a line, so as to get the exposure time of the whole frame.

◆ uiTargetMax

uint32_t _tExpose::uiTargetMax

Auto exposure brightness target maximum.

◆ uiTargetMin

uint32_t _tExpose::uiTargetMin

Automatic exposure brightness target minimum.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tGammaContrastRange Struct Reference

Public Attributes | List of all members
_tGammaContrastRange Struct Reference

Gamma contrast setting range. More...

#include <CKDeviceDef.h>

Public Attributes

int | iMin
Minimum value. More...
int | iMax
Maximum value. More...

Detailed Description

Gamma contrast setting range.

Member Data Documentation

◆ iMax

int _tGammaContrastRange::iMax

Maximum value.

◆ iMin

int _tGammaContrastRange::iMin

Minimum value.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tGammaRange Struct Reference

Public Attributes | List of all members
_tGammaRange Struct Reference

Gamma setting range. More...

#include <CKDeviceDef.h>

Public Attributes

int | iMin
Minimum value. More...
int | iMax
Maximum value. More...

Detailed Description

Gamma setting range.

Member Data Documentation

◆ iMax

int _tGammaRange::iMax

Maximum value.

◆ iMin

int _tGammaRange::iMin

Minimum value.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tGigeNetworkInfo Struct Reference

Public Attributes | List of all members
_tGigeNetworkInfo Struct Reference

Network information of GigE camera. More...

#include <CKDeviceDef.h>

Public Attributes

char | acLocalNetCardName [64]
local NIC name More...
char | acLocalIp [16]
local NIC IP More...
char | acLocalNetmask [16]
local NIC submask More...
char | acLocalGateway [16]
local NIC gateway More...
BOOL isPersistent
Does the GigE camera use a fixed IP address? More...
char | acCameraIp [16]
GigE camera NIC IP. More...
char | acCameraNetmask [16]
GigE camera NIC submask. More...
char | acCameraGateway [16]
GigE camera NIC gateway. More...
BYTE | byMac [6]
GigE camera NIC MAC address. More...

Detailed Description

Network information of GigE camera.

Member Data Documentation

◆ acCameraGateway

char _tGigeNetworkInfo::acCameraGateway[16]

GigE camera NIC gateway.

◆ acCameraIp

char _tGigeNetworkInfo::acCameraIp[16]

GigE camera NIC IP.

◆ acCameraNetmask

char _tGigeNetworkInfo::acCameraNetmask[16]

GigE camera NIC submask.

◆ acLocalGateway

char _tGigeNetworkInfo::acLocalGateway[16]

local NIC gateway

◆ acLocalIp

char _tGigeNetworkInfo::acLocalIp[16]

local NIC IP

◆ acLocalNetCardName

char _tGigeNetworkInfo::acLocalNetCardName[64]

local NIC name

◆ acLocalNetmask

char _tGigeNetworkInfo::acLocalNetmask[16]

local NIC submask

◆ byMac

BYTE _tGigeNetworkInfo::byMac[6]

GigE camera NIC MAC address.

◆ isPersistent

BOOL _tGigeNetworkInfo::isPersistent

Does the GigE camera use a fixed IP address?

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tInitCameraParam Struct Reference

Public Attributes | List of all members
_tInitCameraParam Struct Reference

When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera. More...

#include <CKDeviceDef.h>

Public Attributes

int | nFrameSpeed
Frame rate. More...
int | nImageTransferMode
int | nSensorOutPixelFormat
int | nTriggerMode
int | nGigeTransPacketSize
int | nImageChannelMask
int | nOutputFrameQueueSize
int | nHeartbeatTimeout
int | nRes [8]

Detailed Description

When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera.

end of CK_IMAGE_FORMAT_DEFINE

Member Data Documentation

◆ nFrameSpeed

int _tInitCameraParam::nFrameSpeed

Frame rate.

◆ nGigeTransPacketSize

int _tInitCameraParam::nGigeTransPacketSize

◆ nHeartbeatTimeout

int _tInitCameraParam::nHeartbeatTimeout

◆ nImageChannelMask

int _tInitCameraParam::nImageChannelMask

◆ nImageTransferMode

int _tInitCameraParam::nImageTransferMode

◆ nOutputFrameQueueSize

int _tInitCameraParam::nOutputFrameQueueSize

◆ nRes

int _tInitCameraParam::nRes[8]

◆ nSensorOutPixelFormat

int _tInitCameraParam::nSensorOutPixelFormat

◆ nTriggerMode

int _tInitCameraParam::nTriggerMode
The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tIspAe Struct Reference

Public Attributes | List of all members
_tIspAe Struct Reference

Exposure parameters. More...

#include <CKDeviceDef.h>

Public Attributes

int | bAutoExposure
Enables auto exposure, it is enabled by default. More...
uint32_t | res1
double | ExposureTime
Set with support for manual exposure. More...
uint32_t | AnalogGain
Set with support for manual exposure. More...
uint32_t | AeTarget
AE target brightness. More...
int | AeMode
AE auto exposure mode, AE_FRAME_MODE frame rate priority, AE_EXP_MODE exposure priority. More...
uint32_t | res2
double | fMinExposureTime
Minimum exposure time in auto mode, us. More...
double | fMaxExposureTime
Maximum exposure time in auto mode, us. More...
int | iMinAnalogGain
Minimum analog gain in automatic mode. More...
int | iMaxAnalogGain
Maximum analog gain in automatic mode. More...
int | bAntiFlick
Turns off by default on the premise of auto-exposure support. More...
uint32_t | FrequencySel
Flick mode. More...
int | Left
Set window left. More...
int | Top
Setting window. More...
int | Width
Set window width. More...
int | Height
Set window height. More...

Detailed Description

Exposure parameters.

Member Data Documentation

◆ AeMode

int _tIspAe::AeMode

AE auto exposure mode, AE_FRAME_MODE frame rate priority, AE_EXP_MODE exposure priority.

◆ AeTarget

uint32_t _tIspAe::AeTarget

AE target brightness.

◆ AnalogGain

uint32_t _tIspAe::AnalogGain

Set with support for manual exposure.

◆ bAntiFlick

int _tIspAe::bAntiFlick

Turns off by default on the premise of auto-exposure support.

◆ bAutoExposure

int _tIspAe::bAutoExposure

Enables auto exposure, it is enabled by default.

◆ ExposureTime

double _tIspAe::ExposureTime

Set with support for manual exposure.

◆ fMaxExposureTime

double _tIspAe::fMaxExposureTime

Maximum exposure time in auto mode, us.

◆ fMinExposureTime

double _tIspAe::fMinExposureTime

Minimum exposure time in auto mode, us.

◆ FrequencySel

uint32_t _tIspAe::FrequencySel

Flick mode.

◆ Height

int _tIspAe::Height

Set window height.

◆ iMaxAnalogGain

int _tIspAe::iMaxAnalogGain

Maximum analog gain in automatic mode.

◆ iMinAnalogGain

int _tIspAe::iMinAnalogGain

Minimum analog gain in automatic mode.

◆ Left

int _tIspAe::Left

Set window left.

◆ res1

uint32_t _tIspAe::res1

◆ res2

uint32_t _tIspAe::res2

◆ Top

int _tIspAe::Top

Setting window.

◆ Width

int _tIspAe::Width

Set window width.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tIspGamma Struct Reference

Public Attributes | List of all members
_tIspGamma Struct Reference

Gama parameter. More...

#include <CKDeviceDef.h>

Public Attributes

uint32_t | Mode
uint32_t | Gamma
gamma value More...
uint32_t | GammaContrast
LUT contrast value. More...
uint32_t | PresetSel
int | rev [5]

Detailed Description

Gama parameter.

Member Data Documentation

◆ Gamma

uint32_t _tIspGamma::Gamma

gamma value

◆ GammaContrast

uint32_t _tIspGamma::GammaContrast

LUT contrast value.

◆ Mode

uint32_t _tIspGamma::Mode

◆ PresetSel

uint32_t _tIspGamma::PresetSel

◆ rev

int _tIspGamma::rev[5]
The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tIspWb Struct Reference

Public Attributes | List of all members
_tIspWb Struct Reference

White balance parameter. More...

#include <CKDeviceDef.h>

Public Attributes

int | bAutoWb
Turns off by default on the premise of auto white balance support. More...
uint32_t | DGainR
Red digital gain. More...
uint32_t | DGainG
Green digital gain. More...
uint32_t | DGainB
Blue digital gain. More...
int | Left
Set the left coordinate of the window. More...
int | Top
Set the coordinates on the window. More...
int | Width
Window width. More...
int | Height
Window height. More...
int | CCM [9]
Color space. More...

Detailed Description

White balance parameter.

Member Data Documentation

◆ bAutoWb

int _tIspWb::bAutoWb

Turns off by default on the premise of auto white balance support.

◆ CCM

int _tIspWb::CCM[9]

Color space.

◆ DGainB

uint32_t _tIspWb::DGainB

Blue digital gain.

◆ DGainG

uint32_t _tIspWb::DGainG

Green digital gain.

◆ DGainR

uint32_t _tIspWb::DGainR

Red digital gain.

◆ Height

int _tIspWb::Height

Window height.

◆ Left

int _tIspWb::Left

Set the left coordinate of the window.

◆ Top

int _tIspWb::Top

Set the coordinates on the window.

◆ Width

int _tIspWb::Width

Window width.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tLscCalibParam Struct Reference

Public Attributes | List of all members
_tLscCalibParam Struct Reference

LSC calibration parameter. More...

#include <CKDeviceDef.h>

Public Attributes

uint32_t | nWidth
Image width. More...
uint32_t | nHeight
Image height. More...
uint32_t | uiMediaType
Image format. More...
uint8_t * | pSrcBuf
Input data buffer. More...
uint32_t | nSrcBufLen
Input data buffer length. More...
uint8_t * | pCalibBuf
Output calibrate buffer. More...
uint32_t | nCalibBufSize
Provided calibrate buffer size(nWidth*nHeight*sizeof(short)) More...
uint32_t | nCalibBufLen
Output calibrate buffer length. More...
uint32_t | nSecNumW
Width sec number. More...
uint32_t | nSecNumH
Height sec number. More...
uint32_t | nPadCoef
Pad coef[1-5]. More...
uint32_t | nCalibMethod
Calibrate method(0-Reference by image center, 1-Reference by maximum gray value, 2-Target gray. More...
uint32_t | nTargetGray
Target gray value(Valid when the nCalibMethod is 2), 8bit,range:[0,255], 10bit,range:[0,1023], 12bit,range:[0,4095], 16bit,range[0,65535]. More...
uint32_t | nRes [8]
Reserved. More...

Detailed Description

LSC calibration parameter.

Member Data Documentation

◆ nCalibBufLen

uint32_t _tLscCalibParam::nCalibBufLen

Output calibrate buffer length.

◆ nCalibBufSize

uint32_t _tLscCalibParam::nCalibBufSize

Provided calibrate buffer size(nWidth*nHeight*sizeof(short))

◆ nCalibMethod

uint32_t _tLscCalibParam::nCalibMethod

Calibrate method(0-Reference by image center, 1-Reference by maximum gray value, 2-Target gray.

◆ nHeight

uint32_t _tLscCalibParam::nHeight

Image height.

◆ nPadCoef

uint32_t _tLscCalibParam::nPadCoef

Pad coef[1-5].

◆ nRes

uint32_t _tLscCalibParam::nRes[8]

Reserved.

◆ nSecNumH

uint32_t _tLscCalibParam::nSecNumH

Height sec number.

◆ nSecNumW

uint32_t _tLscCalibParam::nSecNumW

Width sec number.

◆ nSrcBufLen

uint32_t _tLscCalibParam::nSrcBufLen

Input data buffer length.

◆ nTargetGray

uint32_t _tLscCalibParam::nTargetGray

Target gray value(Valid when the nCalibMethod is 2), 8bit,range:[0,255], 10bit,range:[0,1023], 12bit,range:[0,4095], 16bit,range[0,65535].

◆ nWidth

uint32_t _tLscCalibParam::nWidth

Image width.

◆ pCalibBuf

uint8_t* _tLscCalibParam::pCalibBuf

Output calibrate buffer.

◆ pSrcBuf

uint8_t* _tLscCalibParam::pSrcBuf

Input data buffer.

◆ uiMediaType

uint32_t _tLscCalibParam::uiMediaType

Image format.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tLscCorrectParam Struct Reference

Public Attributes | List of all members
_tLscCorrectParam Struct Reference

LSC correction parameter. More...

#include <CKDeviceDef.h>

Public Attributes

uint32_t | nWidth
Image width. More...
uint32_t | nHeight
Image height. More...
uint32_t | uiMediaType
Image format. More...
uint8_t * | pSrcBuf
Input data buffer. More...
uint32_t | nSrcBufLen
Input data buffer length. More...
uint8_t * | pDstBuf
Output data buffer. More...
uint32_t | nDstBufSize
提供的输出缓冲区大小 Provided output buffer size More...
uint32_t | nDstBufLen
输出数据长度 Output buffer length More...
uint8_t * | pCalibBuf
输入标定表缓存 Input calibrate buffer More...
uint32_t | nCalibBufLen
输入标定表缓存长度 Input calibrate length More...
uint32_t | nRes [8]
预留 Resevered More...

Detailed Description

LSC correction parameter.

Member Data Documentation

◆ nCalibBufLen

uint32_t _tLscCorrectParam::nCalibBufLen

输入标定表缓存长度 Input calibrate length

◆ nDstBufLen

uint32_t _tLscCorrectParam::nDstBufLen

输出数据长度 Output buffer length

◆ nDstBufSize

uint32_t _tLscCorrectParam::nDstBufSize

提供的输出缓冲区大小 Provided output buffer size

◆ nHeight

uint32_t _tLscCorrectParam::nHeight

Image height.

◆ nRes

uint32_t _tLscCorrectParam::nRes[8]

预留 Resevered

◆ nSrcBufLen

uint32_t _tLscCorrectParam::nSrcBufLen

Input data buffer length.

◆ nWidth

uint32_t _tLscCorrectParam::nWidth

Image width.

◆ pCalibBuf

uint8_t* _tLscCorrectParam::pCalibBuf

输入标定表缓存 Input calibrate buffer

◆ pDstBuf

uint8_t* _tLscCorrectParam::pDstBuf

Output data buffer.

◆ pSrcBuf

uint8_t* _tLscCorrectParam::pSrcBuf

Input data buffer.

◆ uiMediaType

uint32_t _tLscCorrectParam::uiMediaType

Image format.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tResolutionRange Struct Reference

Public Attributes | List of all members
_tResolutionRange Struct Reference

Camera resolution setting range for widget UI. More...

#include <CKDeviceDef.h>

Public Attributes

int | iHeightMax
Maximum height of image. More...
int | iHeightMin
Image minimum height. More...
int | iWidthMax
Maximum width of image. More...
int | iWidthMin
Image minimum width. More...
uint32_t | uSkipModeMask
SKIP mode mask, 0, indicating that SKIP is not supported. Bit0 is 1, indicating support for SKIP 2x2; bit1 is 1, indicating support for SKIP 3x3.... More...
uint32_t | uBinSumModeMask
BIN (sum) mode mask, 0, indicating that BIN is not supported. Bit0 is 1, indicating that BIN 2x2 is supported; bit1 is 1, indicating that BIN 3x3 is supported.... More...
uint32_t | uBinAverageModeMask
BIN (average) mode mask, 0, indicating that BIN is not supported. Bit0 is 1, indicating that BIN 2x2 is supported; bit1 is 1, indicating that BIN 3x3 is supported.... More...
uint32_t | uResampleMask
Hardware resampling mask. More...

Detailed Description

Camera resolution setting range for widget UI.

Member Data Documentation

◆ iHeightMax

int _tResolutionRange::iHeightMax

Maximum height of image.

◆ iHeightMin

int _tResolutionRange::iHeightMin

Image minimum height.

◆ iWidthMax

int _tResolutionRange::iWidthMax

Maximum width of image.

◆ iWidthMin

int _tResolutionRange::iWidthMin

Image minimum width.

◆ uBinAverageModeMask

uint32_t _tResolutionRange::uBinAverageModeMask

BIN (average) mode mask, 0, indicating that BIN is not supported. Bit0 is 1, indicating that BIN 2x2 is supported; bit1 is 1, indicating that BIN 3x3 is supported....

◆ uBinSumModeMask

uint32_t _tResolutionRange::uBinSumModeMask

BIN (sum) mode mask, 0, indicating that BIN is not supported. Bit0 is 1, indicating that BIN 2x2 is supported; bit1 is 1, indicating that BIN 3x3 is supported....

◆ uResampleMask

uint32_t _tResolutionRange::uResampleMask

Hardware resampling mask.

◆ uSkipModeMask

uint32_t _tResolutionRange::uSkipModeMask

SKIP mode mask, 0, indicating that SKIP is not supported. Bit0 is 1, indicating support for SKIP 2x2; bit1 is 1, indicating support for SKIP 3x3....

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tRgbGainRange Struct Reference

Public Attributes | List of all members
_tRgbGainRange Struct Reference

RGB three-channel digital gain setting range. More...

#include <CKDeviceDef.h>

Public Attributes

int | iRGainMin
Minimum value of red gain. More...
int | iRGainMax
Maximum value of red gain. More...
int | iGGainMin
Minimum value of green gain. More...
int | iGGainMax
Maximum value of green gain. More...
int | iBGainMin
Minimum value of blue gain. More...
int | iBGainMax
Maximum blue gain. More...

Detailed Description

RGB three-channel digital gain setting range.

Member Data Documentation

◆ iBGainMax

int _tRgbGainRange::iBGainMax

Maximum blue gain.

◆ iBGainMin

int _tRgbGainRange::iBGainMin

Minimum value of blue gain.

◆ iGGainMax

int _tRgbGainRange::iGGainMax

Maximum value of green gain.

◆ iGGainMin

int _tRgbGainRange::iGGainMin

Minimum value of green gain.

◆ iRGainMax

int _tRgbGainRange::iRGainMax

Maximum value of red gain.

◆ iRGainMin

int _tRgbGainRange::iRGainMin

Minimum value of red gain.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSaturationRange Struct Reference

Public Attributes | List of all members
_tSaturationRange Struct Reference

Range of saturation setting. More...

#include <CKDeviceDef.h>

Public Attributes

int | iMin
Minimum value. More...
int | iMax
Maximum value. More...

Detailed Description

Range of saturation setting.

Member Data Documentation

◆ iMax

int _tSaturationRange::iMax

Maximum value.

◆ iMin

int _tSaturationRange::iMin

Minimum value.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkAeAlgorithm Struct Reference

Public Attributes | List of all members
_tSdkAeAlgorithm Struct Reference

AE algorithm description. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Index number. More...
char | acDescription [32]
Description information. More...

Detailed Description

AE algorithm description.

Member Data Documentation

◆ acDescription

char _tSdkAeAlgorithm::acDescription[32]

Description information.

◆ iIndex

int _tSdkAeAlgorithm::iIndex

Index number.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkBayerDecodeAlgorithm Struct Reference

Public Attributes | List of all members
_tSdkBayerDecodeAlgorithm Struct Reference

RAW to RGB algorithm description. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Algorithm index. More...
char | acDescription [32]
Description information. More...

Detailed Description

RAW to RGB algorithm description.

Member Data Documentation

◆ acDescription

char _tSdkBayerDecodeAlgorithm::acDescription[32]

Description information.

◆ iIndex

int _tSdkBayerDecodeAlgorithm::iIndex

Algorithm index.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkBayerType Struct Reference

Public Attributes | List of all members
_tSdkBayerType Struct Reference

Image data format output by the camera. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Bayer type index. More...
char | acDescription [32]
Description information. More...
uint32_t | iMediaType
The corresponding format encoding supported by sensor, such as CAMERA_MEDIA_TYPE_BAYGR8. More...

Detailed Description

Image data format output by the camera.

Member Data Documentation

◆ acDescription

char _tSdkBayerType::acDescription[32]

Description information.

◆ iIndex

int _tSdkBayerType::iIndex

Bayer type index.

◆ iMediaType

uint32_t _tSdkBayerType::iMediaType

The corresponding format encoding supported by sensor, such as CAMERA_MEDIA_TYPE_BAYGR8.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkCameraCapbility Struct Reference

Public Attributes | List of all members
_tSdkCameraCapbility Struct Reference

Camera Ability Level. More...

#include <CKDeviceDef.h>

Public Attributes

tDeviceCfg tDeviceCapbility
Device Capability Level. More...
tSensorCfg tSensorCapbility
sensor level More...

Detailed Description

Camera Ability Level.

Member Data Documentation

◆ tDeviceCapbility

tDeviceCfg _tSdkCameraCapbility::tDeviceCapbility

Device Capability Level.

◆ tSensorCapbility

tSensorCfg _tSdkCameraCapbility::tSensorCapbility

sensor level

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkColorTemperatureDes Struct Reference

Public Attributes | List of all members
_tSdkColorTemperatureDes Struct Reference

Camera white balance color temperature mode description information. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
mode index number More...
char | acDescription [32]
Description information. More...

Detailed Description

Camera white balance color temperature mode description information.

Member Data Documentation

◆ acDescription

char _tSdkColorTemperatureDes::acDescription[32]

Description information.

◆ iIndex

int _tSdkColorTemperatureDes::iIndex

mode index number

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkFrameSpeed Struct Reference

Public Attributes | List of all members
_tSdkFrameSpeed Struct Reference

Camera frame rate description information. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Frame rate index number, generally 0 corresponds to low speed mode, 1 corresponds to normal mode, 2 corresponds to high speed mode. More...
char | acDescription [32]
Description information. More...

Detailed Description

Camera frame rate description information.

Member Data Documentation

◆ acDescription

char _tSdkFrameSpeed::acDescription[32]

Description information.

◆ iIndex

int _tSdkFrameSpeed::iIndex

Frame rate index number, generally 0 corresponds to low speed mode, 1 corresponds to normal mode, 2 corresponds to high speed mode.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkImageResolution Struct Reference

Public Attributes | List of all members
_tSdkImageResolution Struct Reference

Camera resolution description. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Resolution emResolutionMode. More...
char | acDescription [32]
Description of the resolution. This information is valid only when the resolution is preset. Custom resolution ignores this information. More...
uint32_t | uBinSumMode
BIN (sum) mode, the range cannot exceed uBinSumModeMask in tSdkResolutionRange. More...
uint32_t | uBinAverageMode
BIN (average) mode, the range cannot exceed uBinAverageModeMask in tSdkResolutionRange. More...
uint32_t | uSkipMode
Whether the size of SKIP is 0 means that SKIP mode is disabled, the range cannot exceed uSkipModeMask in tSdkResolutionRange. More...
uint32_t | uResampleMask
Hardware resampling mask. More...
int | iHOffsetFOV
Captures the horizontal offset of the field of view relative to the upper left corner of the Sensor's maximum field of view, even. More...
int | iVOffsetFOV
Captures the vertical offset of the field of view relative to the upper left corner of the Sensor's maximum field of view, even. More...
int | iWidthFOV
The width of the field of view is collected and must be even. More...
int | iHeightFOV
The height of the field of view must be an even number. More...
int | iWidth
The width, even number, and 4-byte alignment of the final output image of the camera. More...
int | iHeight
The height of the image that the camera ultimately outputs, even. More...
int | iWidthZoomHd
The width of the hardware scale, the resolution of this operation is not required, this variable is set to 0. More...
int | iHeightZoomHd
The height of the hardware scaling, the resolution of this operation is not required, this variable is set to 0. More...
int | iWidthZoomSw
The width of the software scaling, the resolution of this operation is not required, this variable is set to 0. Even, and 4 bytes aligned. More...
int | iHeightZoomSw
The height of the software zoom, the resolution of this operation is not required, this variable is set to 0. Even. More...

Detailed Description

Camera resolution description.

Member Data Documentation

◆ acDescription

char _tSdkImageResolution::acDescription[32]

Description of the resolution. This information is valid only when the resolution is preset. Custom resolution ignores this information.

◆ iHeight

int _tSdkImageResolution::iHeight

The height of the image that the camera ultimately outputs, even.

◆ iHeightFOV

int _tSdkImageResolution::iHeightFOV

The height of the field of view must be an even number.

◆ iHeightZoomHd

int _tSdkImageResolution::iHeightZoomHd

The height of the hardware scaling, the resolution of this operation is not required, this variable is set to 0.

◆ iHeightZoomSw

int _tSdkImageResolution::iHeightZoomSw

The height of the software zoom, the resolution of this operation is not required, this variable is set to 0. Even.

◆ iHOffsetFOV

int _tSdkImageResolution::iHOffsetFOV

Captures the horizontal offset of the field of view relative to the upper left corner of the Sensor's maximum field of view, even.

◆ iIndex

int _tSdkImageResolution::iIndex

Resolution emResolutionMode.

◆ iVOffsetFOV

int _tSdkImageResolution::iVOffsetFOV

Captures the vertical offset of the field of view relative to the upper left corner of the Sensor's maximum field of view, even.

◆ iWidth

int _tSdkImageResolution::iWidth

The width, even number, and 4-byte alignment of the final output image of the camera.

◆ iWidthFOV

int _tSdkImageResolution::iWidthFOV

The width of the field of view is collected and must be even.

◆ iWidthZoomHd

int _tSdkImageResolution::iWidthZoomHd

The width of the hardware scale, the resolution of this operation is not required, this variable is set to 0.

◆ iWidthZoomSw

int _tSdkImageResolution::iWidthZoomSw

The width of the software scaling, the resolution of this operation is not required, this variable is set to 0. Even, and 4 bytes aligned.

◆ uBinAverageMode

uint32_t _tSdkImageResolution::uBinAverageMode

BIN (average) mode, the range cannot exceed uBinAverageModeMask in tSdkResolutionRange.

◆ uBinSumMode

uint32_t _tSdkImageResolution::uBinSumMode

BIN (sum) mode, the range cannot exceed uBinSumModeMask in tSdkResolutionRange.

◆ uResampleMask

uint32_t _tSdkImageResolution::uResampleMask

Hardware resampling mask.

◆ uSkipMode

uint32_t _tSdkImageResolution::uSkipMode

Whether the size of SKIP is 0 means that SKIP mode is disabled, the range cannot exceed uSkipModeMask in tSdkResolutionRange.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkIspCapacity Struct Reference

Public Attributes | List of all members
_tSdkIspCapacity Struct Reference

ISP module enable information. More...

#include <CKDeviceDef.h>

Public Attributes

int | bMonoSensor
Indicates whether the camera of this model is a black and white camera. If it is a black and white camera, the color related functions cannot be adjusted. More...
int | bWbOnce
Indicates whether this model supports a white balance function. More...
int | bAutoWb
Indicates whether this model supports auto white balance. More...
int | bAutoExposure
Indicates whether this model supports auto exposure. More...
int | bManualExposure
Indicates whether the camera supports manual exposure. More...
int | bAntiFlick
Indicates whether this model camera supports anti-strobe function. More...
int | bIspGamma
indicates whether this model camera supports Gamma function More...
int | bDeviceIsp
Indicates whether this model camera supports hardware ISP function. More...
int | bForceUseDeviceIsp
When both bDeviceIsp and bForceUseDeviceIsp are TRUE, it means that the hardware ISP is mandatory and cannot be canceled. More...
int | bZoomHD
Whether the camera hardware supports image scaling output (can only be reduced). More...
int | bWdr
Indicates whether this model camera supports WDR function. More...
int | rev [3]
Reserve bytes. More...

Detailed Description

ISP module enable information.

Member Data Documentation

◆ bAntiFlick

int _tSdkIspCapacity::bAntiFlick

Indicates whether this model camera supports anti-strobe function.

◆ bAutoExposure

int _tSdkIspCapacity::bAutoExposure

Indicates whether this model supports auto exposure.

◆ bAutoWb

int _tSdkIspCapacity::bAutoWb

Indicates whether this model supports auto white balance.

◆ bDeviceIsp

int _tSdkIspCapacity::bDeviceIsp

Indicates whether this model camera supports hardware ISP function.

◆ bForceUseDeviceIsp

int _tSdkIspCapacity::bForceUseDeviceIsp

When both bDeviceIsp and bForceUseDeviceIsp are TRUE, it means that the hardware ISP is mandatory and cannot be canceled.

◆ bIspGamma

int _tSdkIspCapacity::bIspGamma

indicates whether this model camera supports Gamma function

◆ bManualExposure

int _tSdkIspCapacity::bManualExposure

Indicates whether the camera supports manual exposure.

◆ bMonoSensor

int _tSdkIspCapacity::bMonoSensor

Indicates whether the camera of this model is a black and white camera. If it is a black and white camera, the color related functions cannot be adjusted.

◆ bWbOnce

int _tSdkIspCapacity::bWbOnce

Indicates whether this model supports a white balance function.

◆ bWdr

int _tSdkIspCapacity::bWdr

Indicates whether this model camera supports WDR function.

◆ bZoomHD

int _tSdkIspCapacity::bZoomHD

Whether the camera hardware supports image scaling output (can only be reduced).

◆ rev

int _tSdkIspCapacity::rev[3]

Reserve bytes.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkMediaType Struct Reference

Public Attributes | List of all members
_tSdkMediaType Struct Reference

Image data format output by the camera. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Media type number. More...
char | acDescription [32]
Description information. More...
uint32_t | iMediaType
Corresponding image format encoding, such as CAMERA_MEDIA_TYPE_BAYGR8, is defined in this document. More...

Detailed Description

Image data format output by the camera.

Member Data Documentation

◆ acDescription

char _tSdkMediaType::acDescription[32]

Description information.

◆ iIndex

int _tSdkMediaType::iIndex

Media type number.

◆ iMediaType

uint32_t _tSdkMediaType::iMediaType

Corresponding image format encoding, such as CAMERA_MEDIA_TYPE_BAYGR8, is defined in this document.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkPackLength Struct Reference

Public Attributes | List of all members
_tSdkPackLength Struct Reference

Transfer packet size description (mainly valid for web cameras) More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Sub-package size index number. More...
char | acDescription [32]
Corresponding description information. More...
uint32_t | iPackSize
packet size More...

Detailed Description

Transfer packet size description (mainly valid for web cameras)

Member Data Documentation

◆ acDescription

char _tSdkPackLength::acDescription[32]

Corresponding description information.

◆ iIndex

int _tSdkPackLength::iIndex

Sub-package size index number.

◆ iPackSize

uint32_t _tSdkPackLength::iPackSize

packet size

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkPresetLut Struct Reference

Public Attributes | List of all members
_tSdkPresetLut Struct Reference

Preset LUT table description. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
Index number. More...
char | acDescription [32]
Description information. More...

Detailed Description

Preset LUT table description.

Member Data Documentation

◆ acDescription

char _tSdkPresetLut::acDescription[32]

Description information.

◆ iIndex

int _tSdkPresetLut::iIndex

Index number.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSdkTrigger Struct Reference

Public Attributes | List of all members
_tSdkTrigger Struct Reference

Trigger Mode Description. More...

#include <CKDeviceDef.h>

Public Attributes

int | iIndex
mode index number More...
char | acDescription [32]
Description of this mode. More...

Detailed Description

Trigger Mode Description.

Member Data Documentation

◆ acDescription

char _tSdkTrigger::acDescription[32]

Description of this mode.

◆ iIndex

int _tSdkTrigger::iIndex

mode index number

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSensorCfg Struct Reference

Public Attributes | List of all members
_tSensorCfg Struct Reference

sensor level More...

#include <CKDeviceDef.h>

Public Attributes

tExpose sExposeDesc
Exposure range value. More...
tResolutionRange sResolutionRange
Resolution range description. More...
tSdkImageResolution sMaxResolution
Maximum resolution. More...

Detailed Description

sensor level

Member Data Documentation

◆ sExposeDesc

tExpose _tSensorCfg::sExposeDesc

Exposure range value.

◆ sMaxResolution

tSdkImageResolution _tSensorCfg::sMaxResolution

Maximum resolution.

◆ sResolutionRange

tResolutionRange _tSensorCfg::sResolutionRange

Resolution range description.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: _tSharpnessRange Struct Reference

Public Attributes | List of all members
_tSharpnessRange Struct Reference

Sharpening setting range. More...

#include <CKDeviceDef.h>

Public Attributes

int | iMin
Minimum value. More...
int | iMax
Maximum value. More...

Detailed Description

Sharpening setting range.

Member Data Documentation

◆ iMax

int _tSharpnessRange::iMax

Maximum value.

◆ iMin

int _tSharpnessRange::iMin

Minimum value.

The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: tagRECT Struct Reference

Public Attributes | List of all members
tagRECT Struct Reference

#include <CKDeviceDef.h>

Public Attributes

LONG left
LONG top
LONG right
LONG bottom

Member Data Documentation

◆ bottom

LONG tagRECT::bottom

◆ left

LONG tagRECT::left

◆ right

LONG tagRECT::right

◆ top

LONG tagRECT::top
The documentation for this struct was generated from the following file:
  • CKDeviceDef.h


CKCameraAPI: Class Index

Class Index
_ | t
_
_tDevLoadInfo _tIspWb _tSdkCameraCapbility _tSensorCfg
_tDevLoadMode _tLscCalibParam _tSdkColorTemperatureDes _tSharpnessRange
_DisplayWindow _tExpose _tLscCorrectParam _tSdkFrameSpeed
t
_FrameStatistic _tGammaContrastRange _tResolutionRange _tSdkImageResolution
_stImageInfo _tGammaRange _tRgbGainRange _tSdkIspCapacity tagRECT
_tContrastRange _tGigeNetworkInfo _tSaturationRange _tSdkMediaType
_tDevEnumInfo _tInitCameraParam _tSdkAeAlgorithm _tSdkPackLength
_tDeviceCfg _tIspAe _tSdkBayerDecodeAlgorithm _tSdkPresetLut
_tDevInfo _tIspGamma _tSdkBayerType _tSdkTrigger
_ | t


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • acCameraGateway : _tGigeNetworkInfo
  • acCameraIp : _tGigeNetworkInfo
  • acCameraNetmask : _tGigeNetworkInfo
  • acDescription : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • acDriverName : _tDevInfo
  • acDriverVersion : _tDevInfo
  • acFriendlyName : _tDevInfo
  • acLinkName : _tDevInfo
  • acLocalGateway : _tGigeNetworkInfo
  • acLocalIp : _tGigeNetworkInfo
  • acLocalNetCardName : _tGigeNetworkInfo
  • acLocalNetmask : _tGigeNetworkInfo
  • acPortType : _tDevInfo
  • acProductName : _tDevInfo
  • acProductSeries : _tDevInfo
  • acSensorType : _tDevInfo
  • acSn : _tDevInfo
  • AeMode : _tIspAe
  • AeTarget : _tIspAe
  • AnalogGain : _tIspAe


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- b -

  • bAntiFlick : _tIspAe , _tSdkIspCapacity
  • bAutoExposure : _tIspAe , _tSdkIspCapacity
  • bAutoWb : _tIspWb , _tSdkIspCapacity
  • bDeviceIsp : _tSdkIspCapacity
  • bDevOpen : _tDevEnumInfo
  • bForceUseDeviceIsp : _tSdkIspCapacity
  • bIspGamma : _tSdkIspCapacity
  • BlackLevel : _tDevLoadMode
  • bManualExposure : _tSdkIspCapacity
  • bMonoSensor : _tSdkIspCapacity
  • bottom : tagRECT
  • bParamInDevice : _tDeviceCfg
  • bWbOnce : _tSdkIspCapacity
  • bWdr : _tSdkIspCapacity
  • byMac : _tGigeNetworkInfo
  • bZoomHD : _tSdkIspCapacity


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- c -

  • CCM : _tIspWb
  • ColorToGrayEn : _tDevLoadMode
  • Contrast : _tDevLoadMode


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- d -

  • DevAttribute : _tDevEnumInfo
  • DevEnumInfo : _tDevLoadInfo
  • DeviceDrvID : _tDevInfo
  • DeviceDrvVersionID : _tDevInfo
  • DeviceID : _tDevInfo
  • DevLoadMode : _tDevLoadInfo
  • DGainB : _tIspWb
  • DGainG : _tIspWb
  • DGainR : _tIspWb


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- e -

  • EnableCorrectDeadPixel : _tDevLoadMode
  • EnableWdr : _tDevLoadMode
  • ExpLineTime : _stImageInfo
  • ExposureTime : _tIspAe
  • ExpTime : _stImageInfo


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- f -

  • fMaxExposureTime : _tIspAe
  • fMinExposureTime : _tIspAe
  • FrameSpeedMode : _tDevLoadMode
  • FrequencySel : _tIspAe


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- g -

  • Gain : _stImageInfo
  • Gamma : _tIspGamma
  • GammaContrast : _tIspGamma


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- h -

  • Height : _tIspAe , _tIspWb


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- i -

  • iAeAlmHdDesc : _tDeviceCfg
  • iAeAlmSwDesc : _tDeviceCfg
  • iBayerDecAlmHdDesc : _tDeviceCfg
  • iBayerDecAlmSwDesc : _tDeviceCfg
  • iBayerTypeDesc : _tDeviceCfg
  • iBGainMax : _tRgbGainRange
  • iBGainMin : _tRgbGainRange
  • iCapture : _FrameStatistic
  • iClrTempDesc : _tDeviceCfg
  • iFrameSpeedDesc : _tDeviceCfg
  • iGGainMax : _tRgbGainRange
  • iGGainMin : _tRgbGainRange
  • iHeight : _stImageInfo , _tSdkImageResolution
  • iHeightFOV : _tSdkImageResolution
  • iHeightMax : _tResolutionRange
  • iHeightMin : _tResolutionRange
  • iHeightZoomHd : _tSdkImageResolution
  • iHeightZoomSw : _tSdkImageResolution
  • iHOffsetFOV : _tSdkImageResolution
  • iImageSizeDesc : _tDeviceCfg
  • iIndex : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • iInputIoCounts : _tDeviceCfg
  • iLost : _FrameStatistic
  • ImageHeight : _DisplayWindow
  • ImageRect : _DisplayWindow
  • ImageWidth : _DisplayWindow
  • iMax : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMaxAnalogGain : _tIspAe
  • iMediaType : _tSdkBayerType , _tSdkMediaType
  • iMediaTypeDesc : _tDeviceCfg
  • iMin : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMinAnalogGain : _tIspAe
  • iOutputIoCounts : _tDeviceCfg
  • iPackLenDesc : _tDeviceCfg
  • iPackSize : _tSdkPackLength
  • iPresetLut : _tDeviceCfg
  • iRGainMax : _tRgbGainRange
  • iRGainMin : _tRgbGainRange
  • isPersistent : _tGigeNetworkInfo
  • iTotal : _FrameStatistic
  • iTriggerDesc : _tDeviceCfg
  • iUserDataMaxLen : _tDeviceCfg
  • iVOffsetFOV : _tSdkImageResolution
  • iWidth : _stImageInfo , _tSdkImageResolution
  • iWidthFOV : _tSdkImageResolution
  • iWidthMax : _tResolutionRange
  • iWidthMin : _tResolutionRange
  • iWidthZoomHd : _tSdkImageResolution
  • iWidthZoomSw : _tSdkImageResolution


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- l -

  • Left : _tIspAe , _tIspWb
  • left : tagRECT


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- m -

  • MediaTypeMode : _tDevLoadMode
  • MirrorHEn : _tDevLoadMode
  • MirrorVEn : _tDevLoadMode
  • Mode : _tIspGamma


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- n -

  • Name : _tDevInfo
  • nCalibBufLen : _tLscCalibParam , _tLscCorrectParam
  • nCalibBufSize : _tLscCalibParam
  • nCalibMethod : _tLscCalibParam
  • nDstBufLen : _tLscCorrectParam
  • nDstBufSize : _tLscCorrectParam
  • nFrameSpeed : _tInitCameraParam
  • nGigeTransPacketSize : _tInitCameraParam
  • nHeartbeatTimeout : _tInitCameraParam
  • nHeight : _tLscCalibParam , _tLscCorrectParam
  • nImageChannelMask : _tInitCameraParam
  • nImageTransferMode : _tInitCameraParam
  • nOutputFrameQueueSize : _tInitCameraParam
  • nPadCoef : _tLscCalibParam
  • nRes : _tInitCameraParam , _tLscCalibParam , _tLscCorrectParam
  • nSecNumH : _tLscCalibParam
  • nSecNumW : _tLscCalibParam
  • nSensorOutPixelFormat : _tInitCameraParam
  • nSrcBufLen : _tLscCalibParam , _tLscCorrectParam
  • nTargetGray : _tLscCalibParam
  • nTriggerMode : _tInitCameraParam
  • nWidth : _tLscCalibParam , _tLscCorrectParam


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- p -

  • pAeAlmHdDesc : _tDeviceCfg
  • pAeAlmSwDesc : _tDeviceCfg
  • ParameterMode : _tDevLoadMode
  • ParameterTeam : _tDevLoadMode
  • pBayerDecAlmHdDesc : _tDeviceCfg
  • pBayerDecAlmSwDesc : _tDeviceCfg
  • pBayerTypeDesc : _tDeviceCfg
  • pCalibBuf : _tLscCalibParam , _tLscCorrectParam
  • pClrTempDesc : _tDeviceCfg
  • pDstBuf : _tLscCorrectParam
  • pFrameSpeedDesc : _tDeviceCfg
  • pImageSizeDesc : _tDeviceCfg
  • pMediaTypeDesc : _tDeviceCfg
  • pPackLenDesc : _tDeviceCfg
  • pPresetLutDesc : _tDeviceCfg
  • PresetSel : _tIspGamma
  • pSrcBuf : _tLscCalibParam , _tLscCorrectParam
  • pTriggerDesc : _tDeviceCfg


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- r -

  • res1 : _tIspAe
  • res2 : _tIspAe
  • ResolutionMode : _tDevLoadMode
  • rev : _tDevLoadMode , _tIspGamma , _tSdkIspCapacity
  • right : tagRECT


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- s -

  • Saturation : _tDevLoadMode
  • sContrastRange : _tDeviceCfg
  • SensorID : _tDevInfo
  • sExposeDesc : _tSensorCfg
  • sGammaContrastRange : _tDeviceCfg
  • sGammaRange : _tDeviceCfg
  • Sharpness : _tDevLoadMode
  • sIspAe : _tDevLoadMode
  • sIspCapacity : _tDeviceCfg
  • sIspGamma : _tDevLoadMode
  • sIspWb : _tDevLoadMode
  • sMaxResolution : _tSensorCfg
  • sResolutionRange : _tSensorCfg
  • sRgbGainRange : _tDeviceCfg
  • sSaturationRange : _tDeviceCfg
  • sSharpnessRange : _tDeviceCfg
  • SymbolicName : _tDevInfo


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- t -

  • tDeviceCapbility : _tSdkCameraCapbility
  • Top : _tIspAe , _tIspWb
  • top : tagRECT
  • TotalBytes : _stImageInfo
  • TriggerMode : _tDevLoadMode
  • tSensorCapbility : _tSdkCameraCapbility


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- u -

  • uBinAverageMode : _tSdkImageResolution
  • uBinAverageModeMask : _tResolutionRange
  • uBinSumMode : _tSdkImageResolution
  • uBinSumModeMask : _tResolutionRange
  • uiAnalogGainMax : _tExpose
  • uiAnalogGainMin : _tExpose
  • uiExposeTimeMax : _tExpose
  • uiExposeTimeMin : _tExpose
  • uiMediaType : _stImageInfo , _tLscCalibParam , _tLscCorrectParam
  • uInstance : _tDevInfo
  • uiTargetMax : _tExpose
  • uiTargetMin : _tExpose
  • uResampleMask : _tResolutionRange , _tSdkImageResolution
  • uSkipMode : _tSdkImageResolution
  • uSkipModeMask : _tResolutionRange


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- v -

  • VendorID : _tDevInfo


CKCameraAPI: Class Members

Here is a list of all class members with links to the classes they belong to:

- w -

  • Width : _tIspAe , _tIspWb
  • WinRect : _DisplayWindow


CKCameraAPI: Class Members - Variables

- a -

  • acCameraGateway : _tGigeNetworkInfo
  • acCameraIp : _tGigeNetworkInfo
  • acCameraNetmask : _tGigeNetworkInfo
  • acDescription : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • acDriverName : _tDevInfo
  • acDriverVersion : _tDevInfo
  • acFriendlyName : _tDevInfo
  • acLinkName : _tDevInfo
  • acLocalGateway : _tGigeNetworkInfo
  • acLocalIp : _tGigeNetworkInfo
  • acLocalNetCardName : _tGigeNetworkInfo
  • acLocalNetmask : _tGigeNetworkInfo
  • acPortType : _tDevInfo
  • acProductName : _tDevInfo
  • acProductSeries : _tDevInfo
  • acSensorType : _tDevInfo
  • acSn : _tDevInfo
  • AeMode : _tIspAe
  • AeTarget : _tIspAe
  • AnalogGain : _tIspAe


CKCameraAPI: Class Members - Variables

- b -

  • bAntiFlick : _tIspAe , _tSdkIspCapacity
  • bAutoExposure : _tIspAe , _tSdkIspCapacity
  • bAutoWb : _tIspWb , _tSdkIspCapacity
  • bDeviceIsp : _tSdkIspCapacity
  • bDevOpen : _tDevEnumInfo
  • bForceUseDeviceIsp : _tSdkIspCapacity
  • bIspGamma : _tSdkIspCapacity
  • BlackLevel : _tDevLoadMode
  • bManualExposure : _tSdkIspCapacity
  • bMonoSensor : _tSdkIspCapacity
  • bottom : tagRECT
  • bParamInDevice : _tDeviceCfg
  • bWbOnce : _tSdkIspCapacity
  • bWdr : _tSdkIspCapacity
  • byMac : _tGigeNetworkInfo
  • bZoomHD : _tSdkIspCapacity


CKCameraAPI: Class Members - Variables

- c -

  • CCM : _tIspWb
  • ColorToGrayEn : _tDevLoadMode
  • Contrast : _tDevLoadMode


CKCameraAPI: Class Members - Variables

- d -

  • DevAttribute : _tDevEnumInfo
  • DevEnumInfo : _tDevLoadInfo
  • DeviceDrvID : _tDevInfo
  • DeviceDrvVersionID : _tDevInfo
  • DeviceID : _tDevInfo
  • DevLoadMode : _tDevLoadInfo
  • DGainB : _tIspWb
  • DGainG : _tIspWb
  • DGainR : _tIspWb


CKCameraAPI: Class Members - Variables

- e -

  • EnableCorrectDeadPixel : _tDevLoadMode
  • EnableWdr : _tDevLoadMode
  • ExpLineTime : _stImageInfo
  • ExposureTime : _tIspAe
  • ExpTime : _stImageInfo


CKCameraAPI: Class Members - Variables

- f -

  • fMaxExposureTime : _tIspAe
  • fMinExposureTime : _tIspAe
  • FrameSpeedMode : _tDevLoadMode
  • FrequencySel : _tIspAe


CKCameraAPI: Class Members - Variables

- g -

  • Gain : _stImageInfo
  • Gamma : _tIspGamma
  • GammaContrast : _tIspGamma


CKCameraAPI: Class Members - Variables

- h -

  • Height : _tIspAe , _tIspWb


CKCameraAPI: Class Members - Variables

- i -

  • iAeAlmHdDesc : _tDeviceCfg
  • iAeAlmSwDesc : _tDeviceCfg
  • iBayerDecAlmHdDesc : _tDeviceCfg
  • iBayerDecAlmSwDesc : _tDeviceCfg
  • iBayerTypeDesc : _tDeviceCfg
  • iBGainMax : _tRgbGainRange
  • iBGainMin : _tRgbGainRange
  • iCapture : _FrameStatistic
  • iClrTempDesc : _tDeviceCfg
  • iFrameSpeedDesc : _tDeviceCfg
  • iGGainMax : _tRgbGainRange
  • iGGainMin : _tRgbGainRange
  • iHeight : _stImageInfo , _tSdkImageResolution
  • iHeightFOV : _tSdkImageResolution
  • iHeightMax : _tResolutionRange
  • iHeightMin : _tResolutionRange
  • iHeightZoomHd : _tSdkImageResolution
  • iHeightZoomSw : _tSdkImageResolution
  • iHOffsetFOV : _tSdkImageResolution
  • iImageSizeDesc : _tDeviceCfg
  • iIndex : _tSdkAeAlgorithm , _tSdkBayerDecodeAlgorithm , _tSdkBayerType , _tSdkColorTemperatureDes , _tSdkFrameSpeed , _tSdkImageResolution , _tSdkMediaType , _tSdkPackLength , _tSdkPresetLut , _tSdkTrigger
  • iInputIoCounts : _tDeviceCfg
  • iLost : _FrameStatistic
  • ImageHeight : _DisplayWindow
  • ImageRect : _DisplayWindow
  • ImageWidth : _DisplayWindow
  • iMax : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMaxAnalogGain : _tIspAe
  • iMediaType : _tSdkBayerType , _tSdkMediaType
  • iMediaTypeDesc : _tDeviceCfg
  • iMin : _tContrastRange , _tGammaContrastRange , _tGammaRange , _tSaturationRange , _tSharpnessRange
  • iMinAnalogGain : _tIspAe
  • iOutputIoCounts : _tDeviceCfg
  • iPackLenDesc : _tDeviceCfg
  • iPackSize : _tSdkPackLength
  • iPresetLut : _tDeviceCfg
  • iRGainMax : _tRgbGainRange
  • iRGainMin : _tRgbGainRange
  • isPersistent : _tGigeNetworkInfo
  • iTotal : _FrameStatistic
  • iTriggerDesc : _tDeviceCfg
  • iUserDataMaxLen : _tDeviceCfg
  • iVOffsetFOV : _tSdkImageResolution
  • iWidth : _stImageInfo , _tSdkImageResolution
  • iWidthFOV : _tSdkImageResolution
  • iWidthMax : _tResolutionRange
  • iWidthMin : _tResolutionRange
  • iWidthZoomHd : _tSdkImageResolution
  • iWidthZoomSw : _tSdkImageResolution


CKCameraAPI: Class Members - Variables

- l -

  • Left : _tIspAe , _tIspWb
  • left : tagRECT


CKCameraAPI: Class Members - Variables

- m -

  • MediaTypeMode : _tDevLoadMode
  • MirrorHEn : _tDevLoadMode
  • MirrorVEn : _tDevLoadMode
  • Mode : _tIspGamma


CKCameraAPI: Class Members - Variables

- n -

  • Name : _tDevInfo
  • nCalibBufLen : _tLscCalibParam , _tLscCorrectParam
  • nCalibBufSize : _tLscCalibParam
  • nCalibMethod : _tLscCalibParam
  • nDstBufLen : _tLscCorrectParam
  • nDstBufSize : _tLscCorrectParam
  • nFrameSpeed : _tInitCameraParam
  • nGigeTransPacketSize : _tInitCameraParam
  • nHeartbeatTimeout : _tInitCameraParam
  • nHeight : _tLscCalibParam , _tLscCorrectParam
  • nImageChannelMask : _tInitCameraParam
  • nImageTransferMode : _tInitCameraParam
  • nOutputFrameQueueSize : _tInitCameraParam
  • nPadCoef : _tLscCalibParam
  • nRes : _tInitCameraParam , _tLscCalibParam , _tLscCorrectParam
  • nSecNumH : _tLscCalibParam
  • nSecNumW : _tLscCalibParam
  • nSensorOutPixelFormat : _tInitCameraParam
  • nSrcBufLen : _tLscCalibParam , _tLscCorrectParam
  • nTargetGray : _tLscCalibParam
  • nTriggerMode : _tInitCameraParam
  • nWidth : _tLscCalibParam , _tLscCorrectParam


CKCameraAPI: Class Members - Variables

- p -

  • pAeAlmHdDesc : _tDeviceCfg
  • pAeAlmSwDesc : _tDeviceCfg
  • ParameterMode : _tDevLoadMode
  • ParameterTeam : _tDevLoadMode
  • pBayerDecAlmHdDesc : _tDeviceCfg
  • pBayerDecAlmSwDesc : _tDeviceCfg
  • pBayerTypeDesc : _tDeviceCfg
  • pCalibBuf : _tLscCalibParam , _tLscCorrectParam
  • pClrTempDesc : _tDeviceCfg
  • pDstBuf : _tLscCorrectParam
  • pFrameSpeedDesc : _tDeviceCfg
  • pImageSizeDesc : _tDeviceCfg
  • pMediaTypeDesc : _tDeviceCfg
  • pPackLenDesc : _tDeviceCfg
  • pPresetLutDesc : _tDeviceCfg
  • PresetSel : _tIspGamma
  • pSrcBuf : _tLscCalibParam , _tLscCorrectParam
  • pTriggerDesc : _tDeviceCfg


CKCameraAPI: Class Members - Variables

- r -

  • res1 : _tIspAe
  • res2 : _tIspAe
  • ResolutionMode : _tDevLoadMode
  • rev : _tDevLoadMode , _tIspGamma , _tSdkIspCapacity
  • right : tagRECT


CKCameraAPI: Class Members - Variables

- s -

  • Saturation : _tDevLoadMode
  • sContrastRange : _tDeviceCfg
  • SensorID : _tDevInfo
  • sExposeDesc : _tSensorCfg
  • sGammaContrastRange : _tDeviceCfg
  • sGammaRange : _tDeviceCfg
  • Sharpness : _tDevLoadMode
  • sIspAe : _tDevLoadMode
  • sIspCapacity : _tDeviceCfg
  • sIspGamma : _tDevLoadMode
  • sIspWb : _tDevLoadMode
  • sMaxResolution : _tSensorCfg
  • sResolutionRange : _tSensorCfg
  • sRgbGainRange : _tDeviceCfg
  • sSaturationRange : _tDeviceCfg
  • sSharpnessRange : _tDeviceCfg
  • SymbolicName : _tDevInfo


CKCameraAPI: Class Members - Variables

- t -

  • tDeviceCapbility : _tSdkCameraCapbility
  • Top : _tIspAe , _tIspWb
  • top : tagRECT
  • TotalBytes : _stImageInfo
  • TriggerMode : _tDevLoadMode
  • tSensorCapbility : _tSdkCameraCapbility


CKCameraAPI: Class Members - Variables

- u -

  • uBinAverageMode : _tSdkImageResolution
  • uBinAverageModeMask : _tResolutionRange
  • uBinSumMode : _tSdkImageResolution
  • uBinSumModeMask : _tResolutionRange
  • uiAnalogGainMax : _tExpose
  • uiAnalogGainMin : _tExpose
  • uiExposeTimeMax : _tExpose
  • uiExposeTimeMin : _tExpose
  • uiMediaType : _stImageInfo , _tLscCalibParam , _tLscCorrectParam
  • uInstance : _tDevInfo
  • uiTargetMax : _tExpose
  • uiTargetMin : _tExpose
  • uResampleMask : _tResolutionRange , _tSdkImageResolution
  • uSkipMode : _tSdkImageResolution
  • uSkipModeMask : _tResolutionRange


CKCameraAPI: Class Members - Variables

- v -

  • VendorID : _tDevInfo


CKCameraAPI: Class Members - Variables

- w -

  • Width : _tIspAe , _tIspWb
  • WinRect : _DisplayWindow


CKCameraAPI: File List

File List
Here is a list of all files with brief descriptions:
CKCameraInterface.h
CKDeviceDef.h
UserManual.h


CKCameraAPI: CKCameraInterface.h File Reference

Macros | Typedefs | Functions
CKCameraInterface.h File Reference
#include "CKDeviceDef.h"

Go to the source code of this file.

Macros

#define | __stdcall
#define | CKSDK_API

Typedefs

typedef int | CameraSdkStatus
typedef void(__stdcall * | CAMERA_EXCEPTION_PROC) (HANDLE hCamera, emSdkExceptionType nMsgType, LPVOID lpParam)
Exception callback function definition. More...
typedef void(__stdcall * | CAMERA_SNAP_PROC) (HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)
Callback function definition for image capture. More...
typedef void(__stdcall * | CAMERA_DISPLAY_PROC) (HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
Image display callback function. More...
typedef void(__stdcall * | CAMERA_UPGRADE_PROC) (INT percent, LPVOID lpParam)
Callback function definition for image capture. More...

Functions

CKSDK_API CameraSdkStatus __stdcall | CameraEnumerateDevice (INT *pDeviceNum)
enumerates devices and builds a list of devices. This function must be called to get information about the device before calling CameraInit. More...
CKSDK_API CameraSdkStatus __stdcall | CameraEnumerateDeviceFromOpenedDevList (int *pDeviceNum, int DevNum, int fds[], int pids[], char *paths[])
CKSDK_API CameraSdkStatus __stdcall | CameraGetEnumIndexInfo (INT CameraIndex, tDevEnumInfo *pDevInfo)
Get information about the specified device. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInit (PHANDLE phCamera, INT CameraIndex)
Camera initialization. After the initialization is successful, you can call any other The camera-related operation interface defaults to the last time the parameter was exited. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx (PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx2 (PHANDLE phCamera, const char *pFriendlyName)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx3 (PHANDLE phCamera, const char *pCameraSN)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraInitEx4 (PHANDLE phCamera, const char *pCameraSN, const tInitCameraParam *pstInitCameraParam)
Camera initialization. After the initialization is successful, you can call any other Camera related operation interface. By default, the parameters used at the last exit are used. Note that you need to call CameraEnumerateDevice to enumerate the camera first. More...
CKSDK_API CameraSdkStatus __stdcall | CameraUnInit (HANDLE hCamera)
Camera reverse initialization. Release resources. More...
CKSDK_API CameraSdkStatus __stdcall | CameraRegisterExceptionCallback (HANDLE hCamera, CAMERA_EXCEPTION_PROC pExceptionCallback, LPVOID pUser)
CKSDK_API CameraSdkStatus __stdcall | CameraGetCapability (HANDLE hCamera, tSdkCameraCapbility *pCameraCap)
Get the camera's characterization structure. The structure contains a camera Range information for various parameters that can be set. Determine the parameters of the relevant function Back, can also be used to dynamically create a camera's configuration interface. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurDevInfo (HANDLE hCamera, tDevLoadInfo *pDevInfo)
Get enumerated information for the specified device. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetRawImageBuffer (HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes)
Gets a frame of image raw data. In order to improve efficiency, the SDK uses a zero copy mechanism for image capture. CameraGetRawImageBuffer is actually obtained as a buffer address in the kernel. After the function is successfully called, you must call CameraReleaseFrameHandle to let the kernel continue to use. The buffer. More...
CKSDK_API CameraSdkStatus __stdcall | CameraReleaseFrameHandle (HANDLE hCamera, HANDLE hRawBuf)
release buffer obtained by CameraGetRawImageBuffer More...
CKSDK_API BYTE *__stdcall | CameraGetImageInfo (HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo)
Get current frame image information. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageTimestamp (HANDLE hCamera, HANDLE hRawBuf, UINT64 *puTimestamp)
Gets the timestamp of the current frame in microseconds. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageBuffer (HANDLE hCamera, stImageInfo *pImgInfo, BYTE *pRawBuf, BYTE *pImgBuf)
processes the obtained camera raw output image data, superimposes saturation, Color gain and correction, noise reduction and other processing effects, the output format of the processed image Can be CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 One of them. More...
CKSDK_API BYTE *__stdcall | CameraGetImageBufferEx (HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes)
Gets a frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat After the function is called, the function returns the image data buffer. Applicable to active mode calls. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageBufferEx1 (HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT uTimes)
Gets a frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat After the function is called, the processed image data is placed in the provided buffer for active mode calls. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageBufferEx2 (HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes)
Gets one frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat. More...
CKSDK_API BYTE *__stdcall | CameraGetImageBufferEx3 (HANDLE hCamera, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes)
Gets one frame of image data. The image obtained by this interface is the processed format. This format can be set via CameraSetIspOutFormat. More...
CKSDK_API CameraSdkStatus __stdcall | CameraResetTimestamp (HANDLE hCamera)
Resets the timestamp of image acquisition, starting at 0. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCallbackFunction (HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld)
Sets the callback function for image capture. When a new image data frame is captured, the callback function pointed to by pCallBack is called. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetImageTransferMode (HANDLE hCamera, INT transferMode)
CKSDK_API CameraSdkStatus __stdcall | CameraGetImageTransferMode (HANDLE hCamera, INT *pTransferMode)
CKSDK_API CameraSdkStatus __stdcall | CameraRequestTransferImage (HANDLE hCamera)
request to transmit a frame of image buffered in the camera More...
CameraSdkStatus __stdcall | CameraRequestTransferImageEx (HANDLE hCamera, int nCmd)
Request to transfer a frame of image in the camera cache, use nCmd to specify the location of the transferred image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraPause (HANDLE hCamera)
puts the SDK into pause mode and does not receive image data from the camera. It also sends a command to let the camera pause the output and release the transmission bandwidth. In the pause mode, the camera's parameters can be configured and take effect immediately. More...
CKSDK_API CameraSdkStatus __stdcall | CameraPlay (HANDLE hCamera)
puts the SDK into working mode and starts receiving images sent from the camera Data. If the current camera is in trigger mode, you need to receive it. The image will not be updated until the frame is triggered. More...
CKSDK_API CameraSdkStatus __stdcall | CameraDisplayInit (HANDLE hCamera, HWND hWndDisplay)
Initializes the display module inside the SDK. Call CameraDisplay This function must be called before initialization. If you are in secondary development, Use your own way to display images (without calling CameraDisplay), You do not need to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayMode (HANDLE hCamera, INT iMode)
Sets the mode of display. Must call CameraDisplayInit This function can be called by initializing. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayScaleRadio (HANDLE hCamera, INT iRadio)
Sets the zoom ratio of the display. Only when the display mode is emSdkDisplayMode::DISPLAYMODE_REAL It is valid. For example, 100 is the display window and the image window is 1:1, 200 is the display window and the image window is 2:1. 50 is the display window and image window is 0.5:1, so the value is the magnification X100, must be called CameraDisplayInit is initialized to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayOffset (HANDLE hCamera, INT iOffsetX, INT iOffsetY)
Sets the starting offset value for the display. Only when the display mode is emSdkDisplayMode::DISPLAYMODE_REAL It is valid. For example, the size of the display control is 320X240, while the image The size is 640X480, then when iOffsetX = 160, iOffsetY = 120 The area shown is the center of the image at 320X240. Must be called CameraDisplayInit is initialized to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplaySize (HANDLE hCamera, INT iWidth, INT iHeight)
Sets the size of the display control. Must be called CameraDisplayInit is initialized to call this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCrossLine (HANDLE hCamera, INT iLine, INT x, INT y, UINT uColor, BOOL bVisible)
Sets the parameters for the specified crosshair. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCrossLine (HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible)
Gets the status of the specified crosshair. More...
CKSDK_API CameraSdkStatus __stdcall | CameraImageOverlay (HANDLE hCamera, BYTE *pImgBuf, const stImageInfo *pImgInfo)
superimposes the input image data on the crosshair, white balance reference window, Auto exposure reference window and other graphics. Only set to visible Crosshairs and reference windows can be superimposed. Note that the input image for this function must be in RGB format. More...
CKSDK_API CameraSdkStatus __stdcall | CameraDrawText (BYTE *pImgBuf, const stImageInfo *pImgInfo, char const *pFontFileName, UINT FontWidth, UINT FontHeight, char const *pText, INT Left, INT Top, UINT Width, UINT Height, UINT TextColor, UINT uFlags)
draws text in the input image data More...
CKSDK_API CameraSdkStatus __stdcall | CameraDisplay (HANDLE hCamera, BYTE *pImgBuf, stImageInfo *pImgInfo)
displays the image. You must call CameraDisplayInit to initialize this function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetDisplayCallbackFun (HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld)
Sets the display callback. Must be called CameraDisplayInit This function can be called by initialization, and when displaying image data frames, The callback function pointed to by pCallBack will be called. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSnapToBuffer (HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE **ppImgBuf, UINT uWaitTimeMs)
Capture an image into the buffer. The camera will enter the capture mode, and Automatically switch to the resolution of the capture mode for image capture. followed by The captured data is saved to the buffer. After the function is successfully called, you must call CameraReleaseFrameHandle Release the buffer obtained by CameraSnapToBuffer. Please refer to the specific The functional description section of the function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Sets the resolution of the camera output image in snap mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionForSnap (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Get the resolution in snap mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeState (HANDLE hCamera, BOOL bAeState)
Sets the mode in which the camera is exposed. Automatic or manual. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeState (HANDLE hCamera, BOOL *pAeState)
Gets the camera's current exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeTarget (HANDLE hCamera, WORD AeTarget)
Sets the brightness target value for auto exposure. The setting range is obtained by the CameraGetCapability function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeTarget (HANDLE hCamera, WORD *pAeTarget)
Gets the brightness target value for auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAnalogGain (HANDLE hCamera, UINT uAnalogGain)
Sets the camera's image analog gain value. Multiply this value by CameraGetCapability sExposeDesc.fAnalogGainStep in the camera property structure Obtain the actual image signal magnification. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAnalogGain (HANDLE hCamera, UINT *puAnalogGain)
Gets the analog gain value of the image signal. See CameraSetAnalogGain for details. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetExposureTime (HANDLE hCamera, double dExposureTime)
Set the exposure time. The unit is microseconds. For CMOS sensors, their exposure The unit is calculated in rows, so the exposure time is not in microseconds. The level is continuously adjustable. Instead, it will be based on the entire line. Invoking After setting the exposure time with this function, it is recommended to call CameraGetExposureTime again. To get the actual set value. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureTime (HANDLE hCamera, double *pdExposureTime)
Get the camera's exposure time. See CameraSetExposureTime Functional description. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
Sets the reference window for auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
Gets the location of the auto exposure reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeWinVisible (HANDLE hCamera, BOOL bDisplayEn)
Sets the display status of the auto exposure reference window. When setting the window status For display, after calling CameraImageOverlay, the window position can be Superimposed on the image in a rectangular pattern. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeWinVisible (HANDLE hCamera, BOOL *pbDisplayEn)
Gets the display status of the auto exposure reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAntiFlick (HANDLE hCamera, BOOL bEnable)
Sets the enable status of the anti-strobe function during auto exposure. For manual Inactive in exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAntiFlick (HANDLE hCamera, BOOL *pbEnable)
Gets the anti-strobe function enabled state during auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetLightFrequency (HANDLE hCamera, INT iFrequencySel)
Sets the frequency of the strobe flash during auto exposure. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLightFrequency (HANDLE hCamera, INT *piFrequencySel)
When auto exposure is obtained, the frequency of the strobe is selected. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetExposureLineTime (HANDLE hCamera, double *pExposureLineTime)
Get a line of exposure time, in subtle. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureMode (HANDLE hCamera, INT iMode)
Sets the exposure mode in auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureMode (HANDLE hCamera, INT *piMode)
Get exposure mode in auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeExposureRange (HANDLE hCamera, double dMinExposureTime, double dMaxExposureTime)
Sets the exposure time adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeExposureRange (HANDLE hCamera, double *pdMinExposureTime, double *pdMaxExposureTime)
Get the exposure time adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetAeAnalogGainRange (HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain)
Sets the gain adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetAeAnalogGainRange (HANDLE hCamera, INT *iMinAnalogGain, INT *iMaxAnalogGain)
Get the gain adjustment range of the auto exposure mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGain (HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB)
Sets the digital gain of the image. Setting range by CameraGetCapability The obtained sRgbGainRange member representation in the camera attribute structure. The actual magnification is the set value /100. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGain (HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB)
Gets the digital gain of image processing. See CameraSetGain for details. The functional description section. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbMode (HANDLE hCamera, BOOL bAuto)
Sets the camera white balance mode. Divided into manual and automatic two ways. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbMode (HANDLE hCamera, BOOL *pbAuto)
Get the current white balance mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOnceWB (HANDLE hCamera)
In manual white balance mode, calling this function will perform a white balance. The effective time is when the next frame of image data is received. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWindow (HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
Sets the position of the white balance reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWindow (HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
Gets the position of the white balance reference window. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetWbWinVisible (HANDLE hCamera, BOOL bDisplayEn)
Sets the white balance reference window display enable. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetWbWinVisible (HANDLE hCamera, BOOL *pDisplayEn)
Gets the white balance reference window display enable status. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetLutMode (HANDLE hCamera, INT emLutMode)
Sets the camera's look-up table conversion mode LUT mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutMode (HANDLE hCamera, INT *pemLutMode)
Gets the camera's look-up table conversion mode LUT mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetGamma (HANDLE hCamera, INT iGamma)
Sets the gamma value in the LUT dynamic generation mode. The set value will Saved inside the SDK right away, but only when the camera is dynamic The LUT mode generated by the parameter will not take effect. Please refer to CameraSetLutMode The function description section. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetGamma (HANDLE hCamera, INT *piGamma)
Gets the gamma value in LUT dynamic generation mode. Please refer to CameraSetGamma A functional description of the function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrastLut (HANDLE hCamera, INT iContrast)
Set the contrast value in LUT dynamic generation mode. The set value will Save it inside the SDK right away, but only if the camera is dynamic The LUT mode generated by the parameter will not take effect. Please refer to CameraSetLutMode The function description section. param[in] hCamera The handle of the camera, obtained by the CameraInit function. param[in] iContrast The contrast value set by iContrast. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrastLut (HANDLE hCamera, INT *piContrast)
Get the contrast value in LUT dynamic generation mode. Please refer to the functional description of the CameraSetContrastLut function. param[in] hCamera The handle of the camera, obtained by the CameraInit function. param[out] piContrast The pointer which returns the current contrast value. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSelectLutPreset (HANDLE hCamera, INT iSel)
Select the LUT table in the preset LUT mode. Must use CameraSetLutMode first set the LUT mode to the preset mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetLutPresetSel (HANDLE hCamera, INT *piSel)
Gets the LUT table index number in the default LUT mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCustomLut (HANDLE hCamera, INT iChannel, USHORT *pLut)
Sets a custom LUT table. Must use CameraSetLutMode first set the LUT mode to custom mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCustomLut (HANDLE hCamera, INT iChannel, USHORT *pLut)
Get the custom LUT table currently in use. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentLut (HANDLE hCamera, INT iChannel, USHORT *pLut)
Get the camera's current LUT table, which can be called in any LUT mode. Used to visually observe changes in the LUT curve. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetSharpness (HANDLE hCamera, INT iSharpness)
Sets the sharpening parameters for the processing of the image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSharpness (HANDLE hCamera, INT *piSharpness)
Gets the current sharpening setting. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetSaturation (HANDLE hCamera, INT iSaturation)
Sets the saturation of image processing. Not valid for black and white cameras. The setting range is obtained by CameraGetCapability. 100 means Indicates the original chroma, not enhanced. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSaturation (HANDLE hCamera, INT *piSaturation)
Gets the saturation of image processing. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetContrast (HANDLE hCamera, INT iContrast)
sets the contrast of image processing More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetContrast (HANDLE hCamera, INT *piContrast)
Gets the contrast value. Please refer to A functional description of the CameraSetContrast function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameTime (HANDLE hCamera, double *pdFrameTime)
Get the current image frame time. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFrameSpeed (HANDLE hCamera, INT iFrameSpeed)
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameSpeed (HANDLE hCamera, INT *piFrameSpeed)
Gets the frame rate selection index number of the camera output image. Specific usage reference ??The functional description section of the function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolution (HANDLE hCamera, INT iResolutionIndex)
Sets the resolution of the camera output image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolution (HANDLE hCamera, INT *piResolutionIndex)
Get the resolution of the camera output image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetResolutionEx (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Sets the resolution of the custom preview. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetResolutionEx (HANDLE hCamera, INT iResolution, tSdkImageResolution *pImageResolution)
Get the resolution of the index number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurResolution (HANDLE hCamera, tSdkImageResolution *pImageResolution)
Get the resolution of the current preview. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutImageSize (HANDLE hCamera, DWORD *pWidth, DWORD *pHeight)
Gets the size of the output image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgMode (HANDLE hCamera, INT iAlgMode)
Sets the Bayer to RGB algorithm mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBayerAlgThreshold (HANDLE hCamera, INT iAlgMode)
Sets the Bayer to RGB algorithm mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBayerAlgMode (HANDLE hCamera, INT *piAlgMode)
Get Bayer to RGB algorithm mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetIspOutFormat (HANDLE hCamera, INT iFormat)
Sets the output format of the image processing of the CameraImageProcess function, which supports CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 Five types (defined in CameraDefine.h) correspond to 8-bit grayscale images and 24RGB, 32-bit RGB, 24-bit BGR, 32-bit BGR color images. The default output is CAMERA_MEDIA_TYPE_BGR8 format. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetIspOutFormat (HANDLE hCamera, INT *piFormat)
Get the output format of CameraGetOutImageBuffer function image processing, support CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 Five types (defined in CameraDefine.h) correspond to 8-bit grayscale images and 24RGB, 32-bit RGB, 24-bit BGR, 32-bit BGR color images. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFrameStatistic (HANDLE hCamera, FrameStatistic *psFrameStatistic)
Gets statistics on the frame rate received by the camera, including error frames and dropped frames. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveImage (HANDLE hCamera, const char *lpszFileName, const BYTE *pImgBuf, const stImageInfo *pImgInfo, UINT byFileType, BYTE byQuality)
Saves the image buffer data as an image file. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetMirror (HANDLE hCamera, INT iDir, BOOL bEnable)
Sets the image mirroring operation. The mirroring operation is divided into two directions, horizontal and vertical. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMirror (HANDLE hCamera, INT iDir, BOOL *pbEnable)
Gets the mirrored state of the image. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetMonochrome (HANDLE hCamera, BOOL bEnable)
Sets the color to black and white function enable. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetMonochrome (HANDLE hCamera, BOOL *pbEnable)
Gets the enable status of the color conversion black and white function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetBlackLevel (HANDLE hCamera, INT iBlackLevel)
sets the black level reference of the image. The default value is 0. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetBlackLevel (HANDLE hCamera, INT *piBlackLevel)
Gets the black level reference of the image, the default is 0. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetSensorOutPixelFormat (HANDLE hCamera, UINT iFormat)
Set the format of the raw image data. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetSensorOutPixelFormat (HANDLE hCamera, UINT *piFormat)
Get the format of the raw image data. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetCorrectDeadPixel (HANDLE hCamera, BOOL bEnable)
Set whether to enable dead pixel correction. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCorrectDeadPixel (HANDLE hCamera, BOOL *pbEnable)
Get the status of dead pixel correction. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLscCalib (HANDLE hCamera, tLscCalibParam *pLscCalibParam)
LSC calibration. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLscCorrect (HANDLE hCamera, tLscCorrectParam *pLscCorrectParam)
LSC correction. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerMode (HANDLE hCamera, INT iTriggerModeSel)
Sets the camera's trigger mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerMode (HANDLE hCamera, INT *piTriggerModeSel)
Get the trigger mode of the camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSoftTrigger (HANDLE hCamera)
performs a soft trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraBroadcastSoftTrigger (const char *pStrNetCardIP, int nCmd)
Sends soft-trigger commands to all cameras connected to the network card. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerFrameCount (HANDLE hCamera, INT frameCount)
Sets how many pictures to take continuously when camera triggers. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerFrameCount (HANDLE hCamera, INT *pFrameCount)
Get how many pictures are taken continuously when the camera is triggered. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerDelayTime (HANDLE hCamera, UINT delayTimeUs)
Set how much time to take a photo after camera trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerDelayTime (HANDLE hCamera, UINT *pDelayTimeUs)
Set how much time to take a photo after camera trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerJitterTime (HANDLE hCamera, INT inputIOIndex, UINT jitterTimeUs)
Set the hardware to trigger the debounce time. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerJitterTime (HANDLE hCamera, INT inputIOIndex, UINT *pJitterTimeUs)
Get the hardware to trigger the debounce time. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetTriggerSignalType (HANDLE hCamera, INT inputIOIndex, INT type)
sets the hardware trigger signal type More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetTriggerSignalType (HANDLE hCamera, INT inputIOIndex, INT *pType)
Get hardware trigger signal type. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobeMode (HANDLE hCamera, INT outputIOIndex, INT mode)
Set flash mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobeMode (HANDLE hCamera, INT outputIOIndex, INT *pMode)
Get flash mode. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobeDelayTime (HANDLE hCamera, INT outputIOIndex, UINT delayTimeUs)
Set how long to delay the flash after the trigger. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobeDelayTime (HANDLE hCamera, INT outputIOIndex, UINT *pDevlayTimeUs)
Gets the delay time to illuminate the flash after triggering. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobePulseWidth (HANDLE hCamera, INT outputIOIndex, UINT pulseWidth)
sets the pulse width of the flash More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobePulseWidth (HANDLE hCamera, INT outputIOIndex, UINT *pPulseWidth)
Get the pulse width of the flash. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetStrobePolarity (HANDLE hCamera, INT outputIOIndex, INT polarity)
sets the active level of the flash More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetStrobePolarity (HANDLE hCamera, INT outputIOIndex, INT *pPolarity)
Get the active level of the flash. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOutputIOMode (HANDLE hCamera, INT outputIOIndex, INT mode)
Sets the operating mode of the output IO. The number of reserved output IOs is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutputIOMode (HANDLE hCamera, INT outputIOIndex, INT *pMode)
Get the operating mode of the output IO. The number of reserved output IOs is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetInputIOMode (HANDLE hCamera, INT inputIOIndex, INT mode)
Sets the mode of input IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInputIOMode (HANDLE hCamera, INT inputIOIndex, INT *pMode)
Get the mode of input IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOutputIOState (HANDLE hCamera, INT outputIOIndex, INT state)
Sets the level state of the specified IO. IO is the output type IO. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutputIOState (HANDLE hCamera, INT outputIOIndex, INT *pState)
Get the level state of the specified IO. IO is the output type IO. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetOutputIOPWM (HANDLE hCamera, INT outputIOIndex, UINT cycle, UINT duty)
Sets the parameters of the PWM output. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetOutputIOPWM (HANDLE hCamera, INT outputIOIndex, INT *pCycle, INT *pDuty)
Get the parameters of the PWM output. The number of programmable output IOs reserved by the camera is determined by iOutputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInputIOState (HANDLE hCamera, INT inputIOIndex, INT *pState)
Sets the level state of the specified IO. IO is the input type IO. The number of programmable output IOs reserved by the camera is determined by iInputIoCounts in tSdkCameraCapbility. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetParameterMode (HANDLE hCamera, INT iMode)
Sets the target object for parameter access. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetParameterMode (HANDLE hCamera, INT *piMode)
Get the target object for parameter access. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameter (HANDLE hCamera, INT iTeam)
Saves the current camera parameters to the specified parameter group. The camera provides A, B, C, D The four groups A, B, C, and D are used to save the parameters. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveParameterToFile (HANDLE hCamera, const char *sFileName)
Saves the current camera parameters to the specified file. The file can be copied to Other computers can be loaded by other cameras, and can also be used for parameter backup. More...
CKSDK_API CameraSdkStatus __stdcall | CameraReadParameterFromFile (HANDLE hCamera, const char *sFileName)
Loads parameters from the parameter file specified on the PC. My company camera parameters Save the file with the .config suffix on the PC, under the installation In the Camera\Configs folder. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadParameter (HANDLE hCamera, INT iTeam)
Loads the parameters of the specified group into the camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetCurrentParameterGroup (HANDLE hCamera, INT *piTeam)
Get the currently selected parameter group. More...
CKSDK_API CameraSdkStatus __stdcall | CameraWriteSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
Sets the serial number of the camera. Our company's camera serial number is divided into 3 levels. Level 0 is our company's custom camera serial number, already shipped from the factory Set well, Level 1 and Level 2 are reserved for secondary development. Sequence of each level The length of the number is 32 bytes. More...
CKSDK_API CameraSdkStatus __stdcall | CameraReadSN (HANDLE hCamera, BYTE *pbySN, INT iLevel)
Reads the serial number of the camera's specified level. Please refer to the definition of serial number. The functional description section of the function. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSaveUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
saves user-defined data to the camera's non-volatile memory. The maximum length of the user data area that each model camera may support is different. This length information can be obtained from the characterization of the device. More...
CKSDK_API CameraSdkStatus __stdcall | CameraLoadUserData (HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
reads user-defined data from the camera's non-volatile memory. The maximum length of the user data area that each model camera may support is different. This length information can be obtained from the characterization of the device. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFriendlyName (HANDLE hCamera, char *pName)
Read user-defined device nicknames. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetFriendlyName (HANDLE hCamera, char *pName)
Sets a user-defined device nickname. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSdkGetVersionString (char *pVersionString)
Get SDK version information. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCheckFwUpdate (HANDLE hCamera, BOOL *pNeedUpdate)
Detects the firmware version and needs to be upgraded. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetFirmwareVision (HANDLE hCamera, char *pVersion)
gets the firmware version of the string More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetDeviceType (HANDLE hCamera, DWORD *pDeviceID)
Get device version ID. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetInerfaceVersion (HANDLE hCamera, char *pVersion)
Get the version of the specified device interface. More...
CKSDK_API CameraSdkStatus __stdcall | CameraShowSettingPage (HANDLE hCamera, BOOL bShow)
Sets the camera property configuration window display status. You must call CameraCreateSettingPageEx to create the camera property configuration window successfully before you can call this function to display. More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetActivePage (HANDLE hCamera, LONG lActivePage, INT iDefault)
Sets the activation page of the camera configuration window. The camera configuration window has multiple sub-pages. This function can set which sub-page is active and displayed at the forefront. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCreateSettingPageEx (HANDLE hCamera)
Creates a camera configuration window. Before creating, you must first call CameraSetActivePage to set the subpage composition. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeResolution (HANDLE hCamera, tSdkImageResolution *pImageCustom)
Opens the resolution custom panel and visually configures a custom resolution. More...
CKSDK_API CameraSdkStatus __stdcall | CameraCustomizeReferWin (HANDLE hCamera, INT iWinType, INT *piHOff, INT *piVOff, INT *piWidth, INT *piHeight)
Opens the reference window custom panel. And visually get the location of a custom window. A reference window for custom white balance and auto exposure is generally used. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetIp (const char *pCameraSN, tGigeNetworkInfo *pNetworkInfo)
Set the camera's network address by camera serial number. This interface only supports GIGE cameras. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetIp (const char *pCameraSN, const tGigeNetworkInfo *pNetworkInfo)
Set the camera's network address by the camera's serial number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetTransPacketSize (HANDLE hCamera, UINT *pPacketSize)
Set the camera's network address by the camera's serial number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetTransPacketSize (HANDLE hCamera, UINT packetSize)
Get the camera's network address by the camera's serial number. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetPacketDelayTime (HANDLE hCamera, UINT *pDelayUs)
Set the delay interval for GVSP packets of GigE camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetPacketDelayTime (HANDLE hCamera, UINT delayUs)
Get the delay interval for GVSP packets of GigE camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeSetResend (HANDLE hCamera, BOOL bEnable, UINT nMaxResendPercent, UINT nResendTimeout)
Set the retransmission parameters of the Gige camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraGigeGetOptimalPacketSize (HANDLE hCamera, UINT *pOptimalPacketSize)
Get the delay interval for GVSP packets of GigE camera. More...
CKSDK_API CameraSdkStatus __stdcall | CameraStartRecord (HANDLE hCamera, const char *pstrSavePath, INT iFormat, INT iBitrate, INT iFrameRate)
start recording More...
CKSDK_API CameraSdkStatus __stdcall | CameraPushOneFrame (HANDLE hCamera, const BYTE *pFrameBuffer, const stImageInfo *pImgInfo)
Write a frame of image data to the video file. More...
CKSDK_API CameraSdkStatus __stdcall | CameraStopRecord (HANDLE hCamera)
end recording More...
CKSDK_API CameraSdkStatus __stdcall | CameraUpgrade (HANDLE hCamera, const char *pFilePath, CAMERA_UPGRADE_PROC callback, LPVOID lpParam)
upgrade camera More...
CKSDK_API CameraSdkStatus __stdcall | CameraSetIntValue (HANDLE hCamera, emSdkValueType type, INT value)
sets the shaping parameters, the parameter type is defined by emSdkValueType More...
CKSDK_API CameraSdkStatus __stdcall | CameraGetIntValue (HANDLE hCamera, emSdkValueType type, INT *pValue)
gets the shaping parameters, the parameter type is defined by emSdkValueType More...
CKSDK_API CameraSdkStatus __stdcall | CameraReboot (HANDLE hCamera)
reboot camera More...

Macro Definition Documentation

◆ __stdcall

#define __stdcall

◆ CKSDK_API

#define CKSDK_API

Typedef Documentation

◆ CAMERA_UPGRADE_PROC

typedef void(__stdcall* CAMERA_UPGRADE_PROC) (INT percent, LPVOID lpParam)

Callback function definition for image capture.

◆ CameraSdkStatus

typedef int CameraSdkStatus

Function Documentation

◆ CameraEnumerateDeviceFromOpenedDevList()

CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDeviceFromOpenedDevList | ( | int * | pDeviceNum,
 |  | int | DevNum,
 |  | int | fds[],
 |  | int | pids[],
 |  | char * | paths[]
 | ) |  |

◆ CameraUpgrade()

CKSDK_API CameraSdkStatus __stdcall CameraUpgrade | ( | HANDLE | hCamera,
 |  | const char * | pFilePath,
 |  | CAMERA_UPGRADE_PROC | callback,
 |  | LPVOID | lpParam
 | ) |  |

upgrade camera

Parameters
[in] | hCamera | camera handle, obtained by CameraInit function
[in] | pFilePath | upgrade file path
[in] | callback | Upgrade callback function to notify the current upgrade progress
[in] | lpParam | upgrade callback function parameter
Returns
Status code
Note
The upgrade function will only return when the upgrade is complete or an error occurs, so it will run for a period of time, and the upgrade progress will be returned through the callback function. Do not call other functions to control the camera during the upgrade. Do not disconnect the camera and power supply during the upgrade. Please power off and restart the camera after the upgrade is complete.


CKCameraAPI: UserManual.h File Reference

UserManual.h File Reference

Go to the source code of this file.


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- _ -

  • __stdcall : CKCameraInterface.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- a -

  • AE_EXP_MODE : CKDeviceDef.h
  • AE_FRAME_MODE : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- b -

  • BOOL : CKDeviceDef.h
  • BYTE : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- c -

  • CAMERA_DISPLAY_PROC : CKCameraInterface.h
  • CAMERA_EXCEPTION_PROC : CKCameraInterface.h
  • CAMERA_FORMAT_BAYGR12 : CKDeviceDef.h
  • CAMERA_FORMAT_BAYGR8 : CKDeviceDef.h
  • CAMERA_FORMAT_BGR : CKDeviceDef.h
  • CAMERA_FORMAT_MONO : CKDeviceDef.h
  • CAMERA_FORMAT_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGRA8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_ID_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MEDIA_FORMAT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO14 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO8_SIGNED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY10BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY12BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY16BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY1BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY24BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY2BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY32BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY4BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY8BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGBA8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YCBCR8_CBYCR : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV411_8_UYYVYY : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV422_8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV422_8_UYVY : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV8_UYV : CKDeviceDef.h
  • CAMERA_SNAP_PROC : CKCameraInterface.h
  • CAMERA_STATUS_ACCESS_DENY : CKDeviceDef.h
  • CAMERA_STATUS_BUS_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_BUSY : CKDeviceDef.h
  • CAMERA_STATUS_CAMERA_NEED_RESET : CKDeviceDef.h
  • CAMERA_STATUS_COMM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_CRITICAL_FILE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DATA_RECV_LESS : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_OPENED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_VEDIO_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_EEPROM_UPDATA : CKDeviceDef.h
  • CAMERA_STATUS_EOF_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_CREATE_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_FUNCTION_LOAD_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_GIGE_FILTER_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_GRAB_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_IIC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IN_PROCESS : CKDeviceDef.h
  • CAMERA_STATUS_INTERNAL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IO_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_DATA_CRC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_LOST_DATA : CKDeviceDef.h
  • CAMERA_STATUS_MV_TEST_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_NET_SEND_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_NO_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_MEMORY : CKDeviceDef.h
  • CAMERA_STATUS_NO_OPEN_DEVICE : CKDeviceDef.h
  • CAMERA_STATUS_NO_WRITE_EEPROM : CKDeviceDef.h
  • CAMERA_STATUS_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_NOT_SUPPORTED : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_DEVICE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_STREAM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OUT_OF_RANGE : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_OUT_OF_BOUND : CKDeviceDef.h
  • CAMERA_STATUS_PATH_NOT_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_READ_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_REGISTRY_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SENSOR_ID_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SIZE_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SOCKET_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SPI_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SUCCESS : CKDeviceDef.h
  • CAMERA_STATUS_TIME_OUT : CKDeviceDef.h
  • CAMERA_STATUS_UNENABLED : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW_SENSOR : CKDeviceDef.h
  • CAMERA_STATUS_USB_BULK_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USB_CONTROL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USER_CANCEL : CKDeviceDef.h
  • CAMERA_STATUS_WAIT : CKDeviceDef.h
  • CAMERA_STATUS_WAIT_TRIGGER : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_PROTECTED : CKDeviceDef.h
  • CAMERA_UPGRADE_PROC : CKCameraInterface.h
  • CameraBroadcastSoftTrigger() : CKCameraInterface.h
  • CameraCheckFwUpdate() : CKCameraInterface.h
  • CameraCreateSettingPageEx() : CKCameraInterface.h
  • CameraCustomizeReferWin() : CKCameraInterface.h
  • CameraCustomizeResolution() : CKCameraInterface.h
  • CameraDisplay() : CKCameraInterface.h
  • CameraDisplayInit() : CKCameraInterface.h
  • CameraDrawText() : CKCameraInterface.h
  • CameraEnumerateDevice() : CKCameraInterface.h
  • CameraEnumerateDeviceFromOpenedDevList() : CKCameraInterface.h
  • CameraGetAeAnalogGainRange() : CKCameraInterface.h
  • CameraGetAeExposureMode() : CKCameraInterface.h
  • CameraGetAeExposureRange() : CKCameraInterface.h
  • CameraGetAeState() : CKCameraInterface.h
  • CameraGetAeTarget() : CKCameraInterface.h
  • CameraGetAeWindow() : CKCameraInterface.h
  • CameraGetAeWinVisible() : CKCameraInterface.h
  • CameraGetAnalogGain() : CKCameraInterface.h
  • CameraGetAntiFlick() : CKCameraInterface.h
  • CameraGetBayerAlgMode() : CKCameraInterface.h
  • CameraGetBlackLevel() : CKCameraInterface.h
  • CameraGetCapability() : CKCameraInterface.h
  • CameraGetContrast() : CKCameraInterface.h
  • CameraGetContrastLut() : CKCameraInterface.h
  • CameraGetCorrectDeadPixel() : CKCameraInterface.h
  • CameraGetCrossLine() : CKCameraInterface.h
  • CameraGetCurDevInfo() : CKCameraInterface.h
  • CameraGetCurrentLut() : CKCameraInterface.h
  • CameraGetCurrentParameterGroup() : CKCameraInterface.h
  • CameraGetCurResolution() : CKCameraInterface.h
  • CameraGetCustomLut() : CKCameraInterface.h
  • CameraGetDeviceType() : CKCameraInterface.h
  • CameraGetEnumIndexInfo() : CKCameraInterface.h
  • CameraGetExposureLineTime() : CKCameraInterface.h
  • CameraGetExposureTime() : CKCameraInterface.h
  • CameraGetFirmwareVision() : CKCameraInterface.h
  • CameraGetFrameSpeed() : CKCameraInterface.h
  • CameraGetFrameStatistic() : CKCameraInterface.h
  • CameraGetFrameTime() : CKCameraInterface.h
  • CameraGetFriendlyName() : CKCameraInterface.h
  • CameraGetGain() : CKCameraInterface.h
  • CameraGetGamma() : CKCameraInterface.h
  • CameraGetImageBufferEx() : CKCameraInterface.h
  • CameraGetImageBufferEx1() : CKCameraInterface.h
  • CameraGetImageBufferEx2() : CKCameraInterface.h
  • CameraGetImageBufferEx3() : CKCameraInterface.h
  • CameraGetImageInfo() : CKCameraInterface.h
  • CameraGetImageTimestamp() : CKCameraInterface.h
  • CameraGetImageTransferMode() : CKCameraInterface.h
  • CameraGetInerfaceVersion() : CKCameraInterface.h
  • CameraGetInputIOMode() : CKCameraInterface.h
  • CameraGetInputIOState() : CKCameraInterface.h
  • CameraGetIntValue() : CKCameraInterface.h
  • CameraGetIspOutFormat() : CKCameraInterface.h
  • CameraGetLightFrequency() : CKCameraInterface.h
  • CameraGetLutMode() : CKCameraInterface.h
  • CameraGetLutPresetSel() : CKCameraInterface.h
  • CameraGetMirror() : CKCameraInterface.h
  • CameraGetMonochrome() : CKCameraInterface.h
  • CameraGetOutImageBuffer() : CKCameraInterface.h
  • CameraGetOutImageSize() : CKCameraInterface.h
  • CameraGetOutputIOMode() : CKCameraInterface.h
  • CameraGetOutputIOPWM() : CKCameraInterface.h
  • CameraGetOutputIOState() : CKCameraInterface.h
  • CameraGetParameterMode() : CKCameraInterface.h
  • CameraGetRawImageBuffer() : CKCameraInterface.h
  • CameraGetResolution() : CKCameraInterface.h
  • CameraGetResolutionEx() : CKCameraInterface.h
  • CameraGetResolutionForSnap() : CKCameraInterface.h
  • CameraGetSaturation() : CKCameraInterface.h
  • CameraGetSensorOutPixelFormat() : CKCameraInterface.h
  • CameraGetSharpness() : CKCameraInterface.h
  • CameraGetStrobeDelayTime() : CKCameraInterface.h
  • CameraGetStrobeMode() : CKCameraInterface.h
  • CameraGetStrobePolarity() : CKCameraInterface.h
  • CameraGetStrobePulseWidth() : CKCameraInterface.h
  • CameraGetTriggerDelayTime() : CKCameraInterface.h
  • CameraGetTriggerFrameCount() : CKCameraInterface.h
  • CameraGetTriggerJitterTime() : CKCameraInterface.h
  • CameraGetTriggerMode() : CKCameraInterface.h
  • CameraGetTriggerSignalType() : CKCameraInterface.h
  • CameraGetWbMode() : CKCameraInterface.h
  • CameraGetWbWindow() : CKCameraInterface.h
  • CameraGetWbWinVisible() : CKCameraInterface.h
  • CameraGigeGetIp() : CKCameraInterface.h
  • CameraGigeGetOptimalPacketSize() : CKCameraInterface.h
  • CameraGigeGetPacketDelayTime() : CKCameraInterface.h
  • CameraGigeGetTransPacketSize() : CKCameraInterface.h
  • CameraGigeSetIp() : CKCameraInterface.h
  • CameraGigeSetPacketDelayTime() : CKCameraInterface.h
  • CameraGigeSetResend() : CKCameraInterface.h
  • CameraGigeSetTransPacketSize() : CKCameraInterface.h
  • CameraImageOverlay() : CKCameraInterface.h
  • CameraInit() : CKCameraInterface.h
  • CameraInitEx() : CKCameraInterface.h
  • CameraInitEx2() : CKCameraInterface.h
  • CameraInitEx3() : CKCameraInterface.h
  • CameraInitEx4() : CKCameraInterface.h
  • CameraLoadParameter() : CKCameraInterface.h
  • CameraLoadUserData() : CKCameraInterface.h
  • CameraLscCalib() : CKCameraInterface.h
  • CameraLscCorrect() : CKCameraInterface.h
  • CameraPause() : CKCameraInterface.h
  • CameraPlay() : CKCameraInterface.h
  • CameraPushOneFrame() : CKCameraInterface.h
  • CameraReadParameterFromFile() : CKCameraInterface.h
  • CameraReadSN() : CKCameraInterface.h
  • CameraReboot() : CKCameraInterface.h
  • CameraRegisterExceptionCallback() : CKCameraInterface.h
  • CameraReleaseFrameHandle() : CKCameraInterface.h
  • CameraRequestTransferImage() : CKCameraInterface.h
  • CameraRequestTransferImageEx() : CKCameraInterface.h
  • CameraResetTimestamp() : CKCameraInterface.h
  • CameraSaveImage() : CKCameraInterface.h
  • CameraSaveParameter() : CKCameraInterface.h
  • CameraSaveParameterToFile() : CKCameraInterface.h
  • CameraSaveUserData() : CKCameraInterface.h
  • CameraSdkGetVersionString() : CKCameraInterface.h
  • CameraSdkStatus : CKCameraInterface.h
  • CameraSelectLutPreset() : CKCameraInterface.h
  • CameraSetActivePage() : CKCameraInterface.h
  • CameraSetAeAnalogGainRange() : CKCameraInterface.h
  • CameraSetAeExposureMode() : CKCameraInterface.h
  • CameraSetAeExposureRange() : CKCameraInterface.h
  • CameraSetAeState() : CKCameraInterface.h
  • CameraSetAeTarget() : CKCameraInterface.h
  • CameraSetAeWindow() : CKCameraInterface.h
  • CameraSetAeWinVisible() : CKCameraInterface.h
  • CameraSetAnalogGain() : CKCameraInterface.h
  • CameraSetAntiFlick() : CKCameraInterface.h
  • CameraSetBayerAlgMode() : CKCameraInterface.h
  • CameraSetBayerAlgThreshold() : CKCameraInterface.h
  • CameraSetBlackLevel() : CKCameraInterface.h
  • CameraSetCallbackFunction() : CKCameraInterface.h
  • CameraSetContrast() : CKCameraInterface.h
  • CameraSetContrastLut() : CKCameraInterface.h
  • CameraSetCorrectDeadPixel() : CKCameraInterface.h
  • CameraSetCrossLine() : CKCameraInterface.h
  • CameraSetCustomLut() : CKCameraInterface.h
  • CameraSetDisplayCallbackFun() : CKCameraInterface.h
  • CameraSetDisplayMode() : CKCameraInterface.h
  • CameraSetDisplayOffset() : CKCameraInterface.h
  • CameraSetDisplayScaleRadio() : CKCameraInterface.h
  • CameraSetDisplaySize() : CKCameraInterface.h
  • CameraSetExposureTime() : CKCameraInterface.h
  • CameraSetFrameSpeed() : CKCameraInterface.h
  • CameraSetFriendlyName() : CKCameraInterface.h
  • CameraSetGain() : CKCameraInterface.h
  • CameraSetGamma() : CKCameraInterface.h
  • CameraSetImageTransferMode() : CKCameraInterface.h
  • CameraSetInputIOMode() : CKCameraInterface.h
  • CameraSetIntValue() : CKCameraInterface.h
  • CameraSetIspOutFormat() : CKCameraInterface.h
  • CameraSetLightFrequency() : CKCameraInterface.h
  • CameraSetLutMode() : CKCameraInterface.h
  • CameraSetMirror() : CKCameraInterface.h
  • CameraSetMonochrome() : CKCameraInterface.h
  • CameraSetOnceWB() : CKCameraInterface.h
  • CameraSetOutputIOMode() : CKCameraInterface.h
  • CameraSetOutputIOPWM() : CKCameraInterface.h
  • CameraSetOutputIOState() : CKCameraInterface.h
  • CameraSetParameterMode() : CKCameraInterface.h
  • CameraSetResolution() : CKCameraInterface.h
  • CameraSetResolutionEx() : CKCameraInterface.h
  • CameraSetResolutionForSnap() : CKCameraInterface.h
  • CameraSetSaturation() : CKCameraInterface.h
  • CameraSetSensorOutPixelFormat() : CKCameraInterface.h
  • CameraSetSharpness() : CKCameraInterface.h
  • CameraSetStrobeDelayTime() : CKCameraInterface.h
  • CameraSetStrobeMode() : CKCameraInterface.h
  • CameraSetStrobePolarity() : CKCameraInterface.h
  • CameraSetStrobePulseWidth() : CKCameraInterface.h
  • CameraSetTriggerDelayTime() : CKCameraInterface.h
  • CameraSetTriggerFrameCount() : CKCameraInterface.h
  • CameraSetTriggerJitterTime() : CKCameraInterface.h
  • CameraSetTriggerMode() : CKCameraInterface.h
  • CameraSetTriggerSignalType() : CKCameraInterface.h
  • CameraSetWbMode() : CKCameraInterface.h
  • CameraSetWbWindow() : CKCameraInterface.h
  • CameraSetWbWinVisible() : CKCameraInterface.h
  • CameraShowSettingPage() : CKCameraInterface.h
  • CameraSnapToBuffer() : CKCameraInterface.h
  • CameraSoftTrigger() : CKCameraInterface.h
  • CameraStartRecord() : CKCameraInterface.h
  • CameraStopRecord() : CKCameraInterface.h
  • CameraUnInit() : CKCameraInterface.h
  • CameraUpgrade() : CKCameraInterface.h
  • CameraWriteSN() : CKCameraInterface.h
  • CKSDK_API : CKCameraInterface.h
  • CMAERA_STATUS_FPGA_CFG_ERROR : CKDeviceDef.h
  • CONTROL_FOCUS_DEFAULT_VALUE : CKDeviceDef.h
  • CONTROL_FOCUS_MAX_VALUE : CKDeviceDef.h
  • CONTROL_FOCUS_MIN_VALUE : CKDeviceDef.h
  • CONTROL_FOCUS_VALUE : CKDeviceDef.h
  • CROSSLINE_MAX_NUM : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- d -

  • DEVICE_TYPE_GIGE : CKDeviceDef.h
  • DEVICE_TYPE_UNKNOW : CKDeviceDef.h
  • DEVICE_TYPE_USB20 : CKDeviceDef.h
  • DEVICE_TYPE_USB30 : CKDeviceDef.h
  • DISPLAYMODE_REAL : CKDeviceDef.h
  • DISPLAYMODE_SCALE : CKDeviceDef.h
  • DisplayWindow : CKDeviceDef.h
  • DWORD : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- e -

  • emAeExpMode : CKDeviceDef.h
  • emDeviceType : CKDeviceDef.h
  • emExtTrigSignal : CKDeviceDef.h
  • emFileType : CKDeviceDef.h
  • emFlickerMode : CKDeviceDef.h
  • emFrameMode : CKDeviceDef.h
  • emImageTransferMode : CKDeviceDef.h
  • emMirrorMode : CKDeviceDef.h
  • emRequestTransferCmd : CKDeviceDef.h
  • emResolutionMode : CKDeviceDef.h
  • emSdkDisplayMode : CKDeviceDef.h
  • emSdkExceptionType : CKDeviceDef.h
  • emSdkInputIOMode : CKDeviceDef.h
  • emSdkLutChannel : CKDeviceDef.h
  • emSdkLutMode : CKDeviceDef.h
  • emSdkOutputIOMode : CKDeviceDef.h
  • emSdkParameterMode : CKDeviceDef.h
  • emSdkParameterTeam : CKDeviceDef.h
  • emSdkValueType : CKDeviceDef.h
  • emSettingPage : CKDeviceDef.h
  • emStatisticsMode : CKDeviceDef.h
  • emStrobeControl : CKDeviceDef.h
  • emTriggerMode : CKDeviceDef.h
  • ENABLE_WDR : CKDeviceDef.h
  • EXCEPTION_DEV_DISCONNECT : CKDeviceDef.h
  • EXCEPTION_DEV_RECONNECT : CKDeviceDef.h
  • EXCEPTION_VERSION_CHECK : CKDeviceDef.h
  • EXT_TRIG_DOUBLE_EDGE : CKDeviceDef.h
  • EXT_TRIG_HIGH_LEVEL : CKDeviceDef.h
  • EXT_TRIG_LEADING_EDGE : CKDeviceDef.h
  • EXT_TRIG_LOW_LEVEL : CKDeviceDef.h
  • EXT_TRIG_TRAILING_EDGE : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- f -

  • FALSE : CKDeviceDef.h
  • FILE_BMP : CKDeviceDef.h
  • FILE_BMP_8BIT : CKDeviceDef.h
  • FILE_JPG : CKDeviceDef.h
  • FILE_PNG : CKDeviceDef.h
  • FILE_PNG_8BIT : CKDeviceDef.h
  • FILE_RAW : CKDeviceDef.h
  • FILE_RAW_16BIT : CKDeviceDef.h
  • FIND_ME : CKDeviceDef.h
  • FRAME_OUTPUT_QUEUE_SIZE : CKDeviceDef.h
  • FRAME_SPEED_HIGH : CKDeviceDef.h
  • FRAME_SPEED_LOW : CKDeviceDef.h
  • FRAME_SPEED_MIDDLE : CKDeviceDef.h
  • FrameStatistic : CKDeviceDef.h
  • FREQ_FLICKER_MODE_50HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_60HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_NULL : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- g -

  • GAMMA_DYNAMIC_MODE : CKDeviceDef.h
  • GAMMA_PRESET_MODE : CKDeviceDef.h
  • GAMMA_USER_MODE : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- h -

  • HANDLE : CKDeviceDef.h
  • HDC : CKDeviceDef.h
  • HWND : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- i -

  • IMAGE_CHANNEL_MASK : CKDeviceDef.h
  • IMAGE_CHANNEL_NUM : CKDeviceDef.h
  • IMAGEOUT_MODE_1024X768 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X1024 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X720 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X800 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X960 : CKDeviceDef.h
  • IMAGEOUT_MODE_1296X972 : CKDeviceDef.h
  • IMAGEOUT_MODE_1424x1424 : CKDeviceDef.h
  • IMAGEOUT_MODE_1440X1080 : CKDeviceDef.h
  • IMAGEOUT_MODE_1600X1200 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1080 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1200 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1280 : CKDeviceDef.h
  • IMAGEOUT_MODE_2048X1536 : CKDeviceDef.h
  • IMAGEOUT_MODE_2304X1296 : CKDeviceDef.h
  • IMAGEOUT_MODE_2304X1728 : CKDeviceDef.h
  • IMAGEOUT_MODE_2448X2048 : CKDeviceDef.h
  • IMAGEOUT_MODE_2592X1944 : CKDeviceDef.h
  • IMAGEOUT_MODE_2736X1824 : CKDeviceDef.h
  • IMAGEOUT_MODE_2848X2848 : CKDeviceDef.h
  • IMAGEOUT_MODE_3008X3008 : CKDeviceDef.h
  • IMAGEOUT_MODE_3072X2048 : CKDeviceDef.h
  • IMAGEOUT_MODE_320X240 : CKDeviceDef.h
  • IMAGEOUT_MODE_3664X2748 : CKDeviceDef.h
  • IMAGEOUT_MODE_4000X3000 : CKDeviceDef.h
  • IMAGEOUT_MODE_4096X2160 : CKDeviceDef.h
  • IMAGEOUT_MODE_4144X2822 : CKDeviceDef.h
  • IMAGEOUT_MODE_4608X3456 : CKDeviceDef.h
  • IMAGEOUT_MODE_512X384 : CKDeviceDef.h
  • IMAGEOUT_MODE_5472X3648 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X360 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X512 : CKDeviceDef.h
  • IMAGEOUT_MODE_720X540 : CKDeviceDef.h
  • IMAGEOUT_MODE_752X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_768X576 : CKDeviceDef.h
  • IMAGEOUT_MODE_800X600 : CKDeviceDef.h
  • IMAGEOUT_MODE_960x600 : CKDeviceDef.h
  • IMAGEOUT_MODE_CUSTOM : CKDeviceDef.h
  • IMAGEOUT_MODE_NUM : CKDeviceDef.h
  • INT : CKDeviceDef.h
  • IOMODE_GP_INPUT : CKDeviceDef.h
  • IOMODE_GP_OUTPUT : CKDeviceDef.h
  • IOMODE_PWM_OUTPUT : CKDeviceDef.h
  • IOMODE_STROBE_OUTPUT : CKDeviceDef.h
  • IOMODE_TRIG_INPUT : CKDeviceDef.h
  • IS_SUPPORT_CONTROL_FOCUS : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- l -

  • LED_LIGHT : CKDeviceDef.h
  • LONG : CKDeviceDef.h
  • LPVOID : CKDeviceDef.h
  • LUT_CHANNEL_ALL : CKDeviceDef.h
  • LUT_CHANNEL_BLUE : CKDeviceDef.h
  • LUT_CHANNEL_GREEN : CKDeviceDef.h
  • LUT_CHANNEL_RED : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- m -

  • MIRROR_MODE_H : CKDeviceDef.h
  • MIRROR_MODE_V : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- p -

  • PARAM_MODE_BY_MODEL : CKDeviceDef.h
  • PARAM_MODE_BY_NAME : CKDeviceDef.h
  • PARAM_MODE_BY_SN : CKDeviceDef.h
  • PARAM_MODE_IN_DEVICE : CKDeviceDef.h
  • PARAMETER_TEAM_A : CKDeviceDef.h
  • PARAMETER_TEAM_B : CKDeviceDef.h
  • PARAMETER_TEAM_C : CKDeviceDef.h
  • PARAMETER_TEAM_D : CKDeviceDef.h
  • PARAMETER_TEAM_DEFAULT : CKDeviceDef.h
  • PHANDLE : CKDeviceDef.h
  • PstImageInfo : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- r -

  • RECT : CKDeviceDef.h
  • REQUEST_TRANSFER_CURRENT_FRAME : CKDeviceDef.h
  • REQUEST_TRANSFER_LATEST_FRAME : CKDeviceDef.h
  • REQUEST_TRANSFER_NEXT_FRAME : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- s -

  • SETTING_PAGE_ALL : CKDeviceDef.h
  • SETTING_PAGE_AWB_SETTING : CKDeviceDef.h
  • SETTING_PAGE_CROSS_LINE : CKDeviceDef.h
  • SETTING_PAGE_DEVINFO : CKDeviceDef.h
  • SETTING_PAGE_EXP_SETTING : CKDeviceDef.h
  • SETTING_PAGE_GAMMA_SETTING : CKDeviceDef.h
  • SETTING_PAGE_GIGE_SETTING : CKDeviceDef.h
  • SETTING_PAGE_IMG_SETTING : CKDeviceDef.h
  • SETTING_PAGE_OUT_SETTING : CKDeviceDef.h
  • SETTING_PAGE_REL_SETTING : CKDeviceDef.h
  • SETTING_PAGE_SPECIAL_SETTING : CKDeviceDef.h
  • STATISTICS_AVG : CKDeviceDef.h
  • STATISTICS_HIST : CKDeviceDef.h
  • STATISTICS_REFER_WINDOW : CKDeviceDef.h
  • STATISTICS_WINDOW : CKDeviceDef.h
  • stImageInfo : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_AUTO : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_MANUAL : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- t -

  • TCHAR : CKDeviceDef.h
  • tContrastRange : CKDeviceDef.h
  • tDevEnumInfo : CKDeviceDef.h
  • tDeviceCfg : CKDeviceDef.h
  • tDevInfo : CKDeviceDef.h
  • tDevLoadInfo : CKDeviceDef.h
  • tDevLoadMode : CKDeviceDef.h
  • tExpose : CKDeviceDef.h
  • tGammaContrastRange : CKDeviceDef.h
  • tGammaRange : CKDeviceDef.h
  • tGigeNetworkInfo : CKDeviceDef.h
  • tInitCameraParam : CKDeviceDef.h
  • tIspAe : CKDeviceDef.h
  • tIspGamma : CKDeviceDef.h
  • tIspWb : CKDeviceDef.h
  • tLscCalibParam : CKDeviceDef.h
  • tLscCorrectParam : CKDeviceDef.h
  • TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE : CKDeviceDef.h
  • TRANSFER_IMAGE_ON_PASSIVE_MODE : CKDeviceDef.h
  • TRANSFER_NEWEST_IMAGE : CKDeviceDef.h
  • TRANSFER_OLDEST_IMAGE : CKDeviceDef.h
  • tResolutionRange : CKDeviceDef.h
  • tRgbGainRange : CKDeviceDef.h
  • TRIGGER_MODE_CONTINUOUS : CKDeviceDef.h
  • TRIGGER_MODE_HARD : CKDeviceDef.h
  • TRIGGER_MODE_SOFT : CKDeviceDef.h
  • TRUE : CKDeviceDef.h
  • tSaturationRange : CKDeviceDef.h
  • tSdkAeAlgorithm : CKDeviceDef.h
  • tSdkBayerDecodeAlgorithm : CKDeviceDef.h
  • tSdkBayerType : CKDeviceDef.h
  • tSdkCameraCapbility : CKDeviceDef.h
  • tSdkColorTemperatureDes : CKDeviceDef.h
  • tSdkFrameSpeed : CKDeviceDef.h
  • tSdkImageResolution : CKDeviceDef.h
  • tSdkIspCapacity : CKDeviceDef.h
  • tSdkMediaType : CKDeviceDef.h
  • tSdkPackLength : CKDeviceDef.h
  • tSdkPresetLut : CKDeviceDef.h
  • tSdkTrigger : CKDeviceDef.h
  • tSensorCfg : CKDeviceDef.h
  • tSharpnessRange : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- u -

  • UINT : CKDeviceDef.h
  • UINT64 : CKDeviceDef.h
  • USHORT : CKDeviceDef.h


CKCameraAPI: File Members

Here is a list of all file members with links to the files they belong to:

- w -

  • WCHAR : CKDeviceDef.h
  • WORD : CKDeviceDef.h


CKCameraAPI: File Members

- c -

  • CameraBroadcastSoftTrigger() : CKCameraInterface.h
  • CameraCheckFwUpdate() : CKCameraInterface.h
  • CameraCreateSettingPageEx() : CKCameraInterface.h
  • CameraCustomizeReferWin() : CKCameraInterface.h
  • CameraCustomizeResolution() : CKCameraInterface.h
  • CameraDisplay() : CKCameraInterface.h
  • CameraDisplayInit() : CKCameraInterface.h
  • CameraDrawText() : CKCameraInterface.h
  • CameraEnumerateDevice() : CKCameraInterface.h
  • CameraEnumerateDeviceFromOpenedDevList() : CKCameraInterface.h
  • CameraGetAeAnalogGainRange() : CKCameraInterface.h
  • CameraGetAeExposureMode() : CKCameraInterface.h
  • CameraGetAeExposureRange() : CKCameraInterface.h
  • CameraGetAeState() : CKCameraInterface.h
  • CameraGetAeTarget() : CKCameraInterface.h
  • CameraGetAeWindow() : CKCameraInterface.h
  • CameraGetAeWinVisible() : CKCameraInterface.h
  • CameraGetAnalogGain() : CKCameraInterface.h
  • CameraGetAntiFlick() : CKCameraInterface.h
  • CameraGetBayerAlgMode() : CKCameraInterface.h
  • CameraGetBlackLevel() : CKCameraInterface.h
  • CameraGetCapability() : CKCameraInterface.h
  • CameraGetContrast() : CKCameraInterface.h
  • CameraGetContrastLut() : CKCameraInterface.h
  • CameraGetCorrectDeadPixel() : CKCameraInterface.h
  • CameraGetCrossLine() : CKCameraInterface.h
  • CameraGetCurDevInfo() : CKCameraInterface.h
  • CameraGetCurrentLut() : CKCameraInterface.h
  • CameraGetCurrentParameterGroup() : CKCameraInterface.h
  • CameraGetCurResolution() : CKCameraInterface.h
  • CameraGetCustomLut() : CKCameraInterface.h
  • CameraGetDeviceType() : CKCameraInterface.h
  • CameraGetEnumIndexInfo() : CKCameraInterface.h
  • CameraGetExposureLineTime() : CKCameraInterface.h
  • CameraGetExposureTime() : CKCameraInterface.h
  • CameraGetFirmwareVision() : CKCameraInterface.h
  • CameraGetFrameSpeed() : CKCameraInterface.h
  • CameraGetFrameStatistic() : CKCameraInterface.h
  • CameraGetFrameTime() : CKCameraInterface.h
  • CameraGetFriendlyName() : CKCameraInterface.h
  • CameraGetGain() : CKCameraInterface.h
  • CameraGetGamma() : CKCameraInterface.h
  • CameraGetImageBufferEx() : CKCameraInterface.h
  • CameraGetImageBufferEx1() : CKCameraInterface.h
  • CameraGetImageBufferEx2() : CKCameraInterface.h
  • CameraGetImageBufferEx3() : CKCameraInterface.h
  • CameraGetImageInfo() : CKCameraInterface.h
  • CameraGetImageTimestamp() : CKCameraInterface.h
  • CameraGetImageTransferMode() : CKCameraInterface.h
  • CameraGetInerfaceVersion() : CKCameraInterface.h
  • CameraGetInputIOMode() : CKCameraInterface.h
  • CameraGetInputIOState() : CKCameraInterface.h
  • CameraGetIntValue() : CKCameraInterface.h
  • CameraGetIspOutFormat() : CKCameraInterface.h
  • CameraGetLightFrequency() : CKCameraInterface.h
  • CameraGetLutMode() : CKCameraInterface.h
  • CameraGetLutPresetSel() : CKCameraInterface.h
  • CameraGetMirror() : CKCameraInterface.h
  • CameraGetMonochrome() : CKCameraInterface.h
  • CameraGetOutImageBuffer() : CKCameraInterface.h
  • CameraGetOutImageSize() : CKCameraInterface.h
  • CameraGetOutputIOMode() : CKCameraInterface.h
  • CameraGetOutputIOPWM() : CKCameraInterface.h
  • CameraGetOutputIOState() : CKCameraInterface.h
  • CameraGetParameterMode() : CKCameraInterface.h
  • CameraGetRawImageBuffer() : CKCameraInterface.h
  • CameraGetResolution() : CKCameraInterface.h
  • CameraGetResolutionEx() : CKCameraInterface.h
  • CameraGetResolutionForSnap() : CKCameraInterface.h
  • CameraGetSaturation() : CKCameraInterface.h
  • CameraGetSensorOutPixelFormat() : CKCameraInterface.h
  • CameraGetSharpness() : CKCameraInterface.h
  • CameraGetStrobeDelayTime() : CKCameraInterface.h
  • CameraGetStrobeMode() : CKCameraInterface.h
  • CameraGetStrobePolarity() : CKCameraInterface.h
  • CameraGetStrobePulseWidth() : CKCameraInterface.h
  • CameraGetTriggerDelayTime() : CKCameraInterface.h
  • CameraGetTriggerFrameCount() : CKCameraInterface.h
  • CameraGetTriggerJitterTime() : CKCameraInterface.h
  • CameraGetTriggerMode() : CKCameraInterface.h
  • CameraGetTriggerSignalType() : CKCameraInterface.h
  • CameraGetWbMode() : CKCameraInterface.h
  • CameraGetWbWindow() : CKCameraInterface.h
  • CameraGetWbWinVisible() : CKCameraInterface.h
  • CameraGigeGetIp() : CKCameraInterface.h
  • CameraGigeGetOptimalPacketSize() : CKCameraInterface.h
  • CameraGigeGetPacketDelayTime() : CKCameraInterface.h
  • CameraGigeGetTransPacketSize() : CKCameraInterface.h
  • CameraGigeSetIp() : CKCameraInterface.h
  • CameraGigeSetPacketDelayTime() : CKCameraInterface.h
  • CameraGigeSetResend() : CKCameraInterface.h
  • CameraGigeSetTransPacketSize() : CKCameraInterface.h
  • CameraImageOverlay() : CKCameraInterface.h
  • CameraInit() : CKCameraInterface.h
  • CameraInitEx() : CKCameraInterface.h
  • CameraInitEx2() : CKCameraInterface.h
  • CameraInitEx3() : CKCameraInterface.h
  • CameraInitEx4() : CKCameraInterface.h
  • CameraLoadParameter() : CKCameraInterface.h
  • CameraLoadUserData() : CKCameraInterface.h
  • CameraLscCalib() : CKCameraInterface.h
  • CameraLscCorrect() : CKCameraInterface.h
  • CameraPause() : CKCameraInterface.h
  • CameraPlay() : CKCameraInterface.h
  • CameraPushOneFrame() : CKCameraInterface.h
  • CameraReadParameterFromFile() : CKCameraInterface.h
  • CameraReadSN() : CKCameraInterface.h
  • CameraReboot() : CKCameraInterface.h
  • CameraRegisterExceptionCallback() : CKCameraInterface.h
  • CameraReleaseFrameHandle() : CKCameraInterface.h
  • CameraRequestTransferImage() : CKCameraInterface.h
  • CameraRequestTransferImageEx() : CKCameraInterface.h
  • CameraResetTimestamp() : CKCameraInterface.h
  • CameraSaveImage() : CKCameraInterface.h
  • CameraSaveParameter() : CKCameraInterface.h
  • CameraSaveParameterToFile() : CKCameraInterface.h
  • CameraSaveUserData() : CKCameraInterface.h
  • CameraSdkGetVersionString() : CKCameraInterface.h
  • CameraSelectLutPreset() : CKCameraInterface.h
  • CameraSetActivePage() : CKCameraInterface.h
  • CameraSetAeAnalogGainRange() : CKCameraInterface.h
  • CameraSetAeExposureMode() : CKCameraInterface.h
  • CameraSetAeExposureRange() : CKCameraInterface.h
  • CameraSetAeState() : CKCameraInterface.h
  • CameraSetAeTarget() : CKCameraInterface.h
  • CameraSetAeWindow() : CKCameraInterface.h
  • CameraSetAeWinVisible() : CKCameraInterface.h
  • CameraSetAnalogGain() : CKCameraInterface.h
  • CameraSetAntiFlick() : CKCameraInterface.h
  • CameraSetBayerAlgMode() : CKCameraInterface.h
  • CameraSetBayerAlgThreshold() : CKCameraInterface.h
  • CameraSetBlackLevel() : CKCameraInterface.h
  • CameraSetCallbackFunction() : CKCameraInterface.h
  • CameraSetContrast() : CKCameraInterface.h
  • CameraSetContrastLut() : CKCameraInterface.h
  • CameraSetCorrectDeadPixel() : CKCameraInterface.h
  • CameraSetCrossLine() : CKCameraInterface.h
  • CameraSetCustomLut() : CKCameraInterface.h
  • CameraSetDisplayCallbackFun() : CKCameraInterface.h
  • CameraSetDisplayMode() : CKCameraInterface.h
  • CameraSetDisplayOffset() : CKCameraInterface.h
  • CameraSetDisplayScaleRadio() : CKCameraInterface.h
  • CameraSetDisplaySize() : CKCameraInterface.h
  • CameraSetExposureTime() : CKCameraInterface.h
  • CameraSetFrameSpeed() : CKCameraInterface.h
  • CameraSetFriendlyName() : CKCameraInterface.h
  • CameraSetGain() : CKCameraInterface.h
  • CameraSetGamma() : CKCameraInterface.h
  • CameraSetImageTransferMode() : CKCameraInterface.h
  • CameraSetInputIOMode() : CKCameraInterface.h
  • CameraSetIntValue() : CKCameraInterface.h
  • CameraSetIspOutFormat() : CKCameraInterface.h
  • CameraSetLightFrequency() : CKCameraInterface.h
  • CameraSetLutMode() : CKCameraInterface.h
  • CameraSetMirror() : CKCameraInterface.h
  • CameraSetMonochrome() : CKCameraInterface.h
  • CameraSetOnceWB() : CKCameraInterface.h
  • CameraSetOutputIOMode() : CKCameraInterface.h
  • CameraSetOutputIOPWM() : CKCameraInterface.h
  • CameraSetOutputIOState() : CKCameraInterface.h
  • CameraSetParameterMode() : CKCameraInterface.h
  • CameraSetResolution() : CKCameraInterface.h
  • CameraSetResolutionEx() : CKCameraInterface.h
  • CameraSetResolutionForSnap() : CKCameraInterface.h
  • CameraSetSaturation() : CKCameraInterface.h
  • CameraSetSensorOutPixelFormat() : CKCameraInterface.h
  • CameraSetSharpness() : CKCameraInterface.h
  • CameraSetStrobeDelayTime() : CKCameraInterface.h
  • CameraSetStrobeMode() : CKCameraInterface.h
  • CameraSetStrobePolarity() : CKCameraInterface.h
  • CameraSetStrobePulseWidth() : CKCameraInterface.h
  • CameraSetTriggerDelayTime() : CKCameraInterface.h
  • CameraSetTriggerFrameCount() : CKCameraInterface.h
  • CameraSetTriggerJitterTime() : CKCameraInterface.h
  • CameraSetTriggerMode() : CKCameraInterface.h
  • CameraSetTriggerSignalType() : CKCameraInterface.h
  • CameraSetWbMode() : CKCameraInterface.h
  • CameraSetWbWindow() : CKCameraInterface.h
  • CameraSetWbWinVisible() : CKCameraInterface.h
  • CameraShowSettingPage() : CKCameraInterface.h
  • CameraSnapToBuffer() : CKCameraInterface.h
  • CameraSoftTrigger() : CKCameraInterface.h
  • CameraStartRecord() : CKCameraInterface.h
  • CameraStopRecord() : CKCameraInterface.h
  • CameraUnInit() : CKCameraInterface.h
  • CameraUpgrade() : CKCameraInterface.h
  • CameraWriteSN() : CKCameraInterface.h


CKCameraAPI: File Members

- b -

  • BOOL : CKDeviceDef.h
  • BYTE : CKDeviceDef.h

- c -

  • CAMERA_DISPLAY_PROC : CKCameraInterface.h
  • CAMERA_EXCEPTION_PROC : CKCameraInterface.h
  • CAMERA_SNAP_PROC : CKCameraInterface.h
  • CAMERA_UPGRADE_PROC : CKCameraInterface.h
  • CameraSdkStatus : CKCameraInterface.h

- d -

  • DisplayWindow : CKDeviceDef.h
  • DWORD : CKDeviceDef.h

- e -

  • emSdkExceptionType : CKDeviceDef.h
  • emSdkValueType : CKDeviceDef.h

- f -

  • FrameStatistic : CKDeviceDef.h

- h -

  • HANDLE : CKDeviceDef.h
  • HDC : CKDeviceDef.h
  • HWND : CKDeviceDef.h

- i -

  • INT : CKDeviceDef.h

- l -

  • LONG : CKDeviceDef.h
  • LPVOID : CKDeviceDef.h

- p -

  • PHANDLE : CKDeviceDef.h
  • PstImageInfo : CKDeviceDef.h

- r -

  • RECT : CKDeviceDef.h

- s -

  • stImageInfo : CKDeviceDef.h

- t -

  • TCHAR : CKDeviceDef.h
  • tContrastRange : CKDeviceDef.h
  • tDevEnumInfo : CKDeviceDef.h
  • tDeviceCfg : CKDeviceDef.h
  • tDevInfo : CKDeviceDef.h
  • tDevLoadInfo : CKDeviceDef.h
  • tDevLoadMode : CKDeviceDef.h
  • tExpose : CKDeviceDef.h
  • tGammaContrastRange : CKDeviceDef.h
  • tGammaRange : CKDeviceDef.h
  • tGigeNetworkInfo : CKDeviceDef.h
  • tInitCameraParam : CKDeviceDef.h
  • tIspAe : CKDeviceDef.h
  • tIspGamma : CKDeviceDef.h
  • tIspWb : CKDeviceDef.h
  • tLscCalibParam : CKDeviceDef.h
  • tLscCorrectParam : CKDeviceDef.h
  • tResolutionRange : CKDeviceDef.h
  • tRgbGainRange : CKDeviceDef.h
  • tSaturationRange : CKDeviceDef.h
  • tSdkAeAlgorithm : CKDeviceDef.h
  • tSdkBayerDecodeAlgorithm : CKDeviceDef.h
  • tSdkBayerType : CKDeviceDef.h
  • tSdkCameraCapbility : CKDeviceDef.h
  • tSdkColorTemperatureDes : CKDeviceDef.h
  • tSdkFrameSpeed : CKDeviceDef.h
  • tSdkImageResolution : CKDeviceDef.h
  • tSdkIspCapacity : CKDeviceDef.h
  • tSdkMediaType : CKDeviceDef.h
  • tSdkPackLength : CKDeviceDef.h
  • tSdkPresetLut : CKDeviceDef.h
  • tSdkTrigger : CKDeviceDef.h
  • tSensorCfg : CKDeviceDef.h
  • tSharpnessRange : CKDeviceDef.h

- u -

  • UINT : CKDeviceDef.h
  • UINT64 : CKDeviceDef.h
  • USHORT : CKDeviceDef.h

- w -

  • WCHAR : CKDeviceDef.h
  • WORD : CKDeviceDef.h


CKCameraAPI: File Members

  • emAeExpMode : CKDeviceDef.h
  • emDeviceType : CKDeviceDef.h
  • emExtTrigSignal : CKDeviceDef.h
  • emFileType : CKDeviceDef.h
  • emFlickerMode : CKDeviceDef.h
  • emFrameMode : CKDeviceDef.h
  • emImageTransferMode : CKDeviceDef.h
  • emMirrorMode : CKDeviceDef.h
  • emRequestTransferCmd : CKDeviceDef.h
  • emResolutionMode : CKDeviceDef.h
  • emSdkDisplayMode : CKDeviceDef.h
  • emSdkExceptionType : CKDeviceDef.h
  • emSdkInputIOMode : CKDeviceDef.h
  • emSdkLutChannel : CKDeviceDef.h
  • emSdkLutMode : CKDeviceDef.h
  • emSdkOutputIOMode : CKDeviceDef.h
  • emSdkParameterMode : CKDeviceDef.h
  • emSdkParameterTeam : CKDeviceDef.h
  • emSdkValueType : CKDeviceDef.h
  • emSettingPage : CKDeviceDef.h
  • emStatisticsMode : CKDeviceDef.h
  • emStrobeControl : CKDeviceDef.h
  • emTriggerMode : CKDeviceDef.h


CKCameraAPI: File Members

- a -

  • AE_EXP_MODE : CKDeviceDef.h
  • AE_FRAME_MODE : CKDeviceDef.h

- c -

  • CONTROL_FOCUS_DEFAULT_VALUE : CKDeviceDef.h
  • CONTROL_FOCUS_MAX_VALUE : CKDeviceDef.h
  • CONTROL_FOCUS_MIN_VALUE : CKDeviceDef.h
  • CONTROL_FOCUS_VALUE : CKDeviceDef.h

- d -

  • DEVICE_TYPE_GIGE : CKDeviceDef.h
  • DEVICE_TYPE_UNKNOW : CKDeviceDef.h
  • DEVICE_TYPE_USB20 : CKDeviceDef.h
  • DEVICE_TYPE_USB30 : CKDeviceDef.h
  • DISPLAYMODE_REAL : CKDeviceDef.h
  • DISPLAYMODE_SCALE : CKDeviceDef.h

- e -

  • ENABLE_WDR : CKDeviceDef.h
  • EXCEPTION_DEV_DISCONNECT : CKDeviceDef.h
  • EXCEPTION_DEV_RECONNECT : CKDeviceDef.h
  • EXCEPTION_VERSION_CHECK : CKDeviceDef.h
  • EXT_TRIG_DOUBLE_EDGE : CKDeviceDef.h
  • EXT_TRIG_HIGH_LEVEL : CKDeviceDef.h
  • EXT_TRIG_LEADING_EDGE : CKDeviceDef.h
  • EXT_TRIG_LOW_LEVEL : CKDeviceDef.h
  • EXT_TRIG_TRAILING_EDGE : CKDeviceDef.h

- f -

  • FILE_BMP : CKDeviceDef.h
  • FILE_BMP_8BIT : CKDeviceDef.h
  • FILE_JPG : CKDeviceDef.h
  • FILE_PNG : CKDeviceDef.h
  • FILE_PNG_8BIT : CKDeviceDef.h
  • FILE_RAW : CKDeviceDef.h
  • FILE_RAW_16BIT : CKDeviceDef.h
  • FIND_ME : CKDeviceDef.h
  • FRAME_OUTPUT_QUEUE_SIZE : CKDeviceDef.h
  • FRAME_SPEED_HIGH : CKDeviceDef.h
  • FRAME_SPEED_LOW : CKDeviceDef.h
  • FRAME_SPEED_MIDDLE : CKDeviceDef.h
  • FREQ_FLICKER_MODE_50HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_60HZ : CKDeviceDef.h
  • FREQ_FLICKER_MODE_NULL : CKDeviceDef.h

- g -

  • GAMMA_DYNAMIC_MODE : CKDeviceDef.h
  • GAMMA_PRESET_MODE : CKDeviceDef.h
  • GAMMA_USER_MODE : CKDeviceDef.h

- i -

  • IMAGE_CHANNEL_MASK : CKDeviceDef.h
  • IMAGE_CHANNEL_NUM : CKDeviceDef.h
  • IMAGEOUT_MODE_1024X768 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X1024 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X720 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X800 : CKDeviceDef.h
  • IMAGEOUT_MODE_1280X960 : CKDeviceDef.h
  • IMAGEOUT_MODE_1296X972 : CKDeviceDef.h
  • IMAGEOUT_MODE_1424x1424 : CKDeviceDef.h
  • IMAGEOUT_MODE_1440X1080 : CKDeviceDef.h
  • IMAGEOUT_MODE_1600X1200 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1080 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1200 : CKDeviceDef.h
  • IMAGEOUT_MODE_1920X1280 : CKDeviceDef.h
  • IMAGEOUT_MODE_2048X1536 : CKDeviceDef.h
  • IMAGEOUT_MODE_2304X1296 : CKDeviceDef.h
  • IMAGEOUT_MODE_2304X1728 : CKDeviceDef.h
  • IMAGEOUT_MODE_2448X2048 : CKDeviceDef.h
  • IMAGEOUT_MODE_2592X1944 : CKDeviceDef.h
  • IMAGEOUT_MODE_2736X1824 : CKDeviceDef.h
  • IMAGEOUT_MODE_2848X2848 : CKDeviceDef.h
  • IMAGEOUT_MODE_3008X3008 : CKDeviceDef.h
  • IMAGEOUT_MODE_3072X2048 : CKDeviceDef.h
  • IMAGEOUT_MODE_320X240 : CKDeviceDef.h
  • IMAGEOUT_MODE_3664X2748 : CKDeviceDef.h
  • IMAGEOUT_MODE_4000X3000 : CKDeviceDef.h
  • IMAGEOUT_MODE_4096X2160 : CKDeviceDef.h
  • IMAGEOUT_MODE_4144X2822 : CKDeviceDef.h
  • IMAGEOUT_MODE_4608X3456 : CKDeviceDef.h
  • IMAGEOUT_MODE_512X384 : CKDeviceDef.h
  • IMAGEOUT_MODE_5472X3648 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X360 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_640X512 : CKDeviceDef.h
  • IMAGEOUT_MODE_720X540 : CKDeviceDef.h
  • IMAGEOUT_MODE_752X480 : CKDeviceDef.h
  • IMAGEOUT_MODE_768X576 : CKDeviceDef.h
  • IMAGEOUT_MODE_800X600 : CKDeviceDef.h
  • IMAGEOUT_MODE_960x600 : CKDeviceDef.h
  • IMAGEOUT_MODE_CUSTOM : CKDeviceDef.h
  • IMAGEOUT_MODE_NUM : CKDeviceDef.h
  • IOMODE_GP_INPUT : CKDeviceDef.h
  • IOMODE_GP_OUTPUT : CKDeviceDef.h
  • IOMODE_PWM_OUTPUT : CKDeviceDef.h
  • IOMODE_STROBE_OUTPUT : CKDeviceDef.h
  • IOMODE_TRIG_INPUT : CKDeviceDef.h
  • IS_SUPPORT_CONTROL_FOCUS : CKDeviceDef.h

- l -

  • LED_LIGHT : CKDeviceDef.h
  • LUT_CHANNEL_ALL : CKDeviceDef.h
  • LUT_CHANNEL_BLUE : CKDeviceDef.h
  • LUT_CHANNEL_GREEN : CKDeviceDef.h
  • LUT_CHANNEL_RED : CKDeviceDef.h

- m -

  • MIRROR_MODE_H : CKDeviceDef.h
  • MIRROR_MODE_V : CKDeviceDef.h

- p -

  • PARAM_MODE_BY_MODEL : CKDeviceDef.h
  • PARAM_MODE_BY_NAME : CKDeviceDef.h
  • PARAM_MODE_BY_SN : CKDeviceDef.h
  • PARAM_MODE_IN_DEVICE : CKDeviceDef.h
  • PARAMETER_TEAM_A : CKDeviceDef.h
  • PARAMETER_TEAM_B : CKDeviceDef.h
  • PARAMETER_TEAM_C : CKDeviceDef.h
  • PARAMETER_TEAM_D : CKDeviceDef.h
  • PARAMETER_TEAM_DEFAULT : CKDeviceDef.h

- r -

  • REQUEST_TRANSFER_CURRENT_FRAME : CKDeviceDef.h
  • REQUEST_TRANSFER_LATEST_FRAME : CKDeviceDef.h
  • REQUEST_TRANSFER_NEXT_FRAME : CKDeviceDef.h

- s -

  • SETTING_PAGE_ALL : CKDeviceDef.h
  • SETTING_PAGE_AWB_SETTING : CKDeviceDef.h
  • SETTING_PAGE_CROSS_LINE : CKDeviceDef.h
  • SETTING_PAGE_DEVINFO : CKDeviceDef.h
  • SETTING_PAGE_EXP_SETTING : CKDeviceDef.h
  • SETTING_PAGE_GAMMA_SETTING : CKDeviceDef.h
  • SETTING_PAGE_GIGE_SETTING : CKDeviceDef.h
  • SETTING_PAGE_IMG_SETTING : CKDeviceDef.h
  • SETTING_PAGE_OUT_SETTING : CKDeviceDef.h
  • SETTING_PAGE_REL_SETTING : CKDeviceDef.h
  • SETTING_PAGE_SPECIAL_SETTING : CKDeviceDef.h
  • STATISTICS_AVG : CKDeviceDef.h
  • STATISTICS_HIST : CKDeviceDef.h
  • STATISTICS_REFER_WINDOW : CKDeviceDef.h
  • STATISTICS_WINDOW : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_AUTO : CKDeviceDef.h
  • STROBE_SYNC_WITH_TRIG_MANUAL : CKDeviceDef.h

- t -

  • TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE : CKDeviceDef.h
  • TRANSFER_IMAGE_ON_PASSIVE_MODE : CKDeviceDef.h
  • TRANSFER_NEWEST_IMAGE : CKDeviceDef.h
  • TRANSFER_OLDEST_IMAGE : CKDeviceDef.h
  • TRIGGER_MODE_CONTINUOUS : CKDeviceDef.h
  • TRIGGER_MODE_HARD : CKDeviceDef.h
  • TRIGGER_MODE_SOFT : CKDeviceDef.h


CKCameraAPI: File Members

- _ -

  • __stdcall : CKCameraInterface.h

- c -

  • CAMERA_FORMAT_BAYGR12 : CKDeviceDef.h
  • CAMERA_FORMAT_BAYGR8 : CKDeviceDef.h
  • CAMERA_FORMAT_BGR : CKDeviceDef.h
  • CAMERA_FORMAT_MONO : CKDeviceDef.h
  • CAMERA_FORMAT_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYBG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BAYRG8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGR8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_BGRA8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_COLOR_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_ID_MASK : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MEDIA_FORMAT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO10 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO10_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO12 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO12_PACKED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO14 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO16 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_MONO8_SIGNED : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY10BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY12BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY16BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY1BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY24BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY2BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY32BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY4BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_OCCUPY8BIT : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGB8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_RGBA8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YCBCR8_CBYCR : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV411_8_UYYVYY : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV422_8 : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV422_8_UYVY : CKDeviceDef.h
  • CAMERA_MEDIA_TYPE_YUV8_UYV : CKDeviceDef.h
  • CAMERA_STATUS_ACCESS_DENY : CKDeviceDef.h
  • CAMERA_STATUS_BUS_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_BUSY : CKDeviceDef.h
  • CAMERA_STATUS_CAMERA_NEED_RESET : CKDeviceDef.h
  • CAMERA_STATUS_COMM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_CRITICAL_FILE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DATA_RECV_LESS : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_IS_OPENED : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_LOST : CKDeviceDef.h
  • CAMERA_STATUS_DEVICE_VEDIO_CLOSED : CKDeviceDef.h
  • CAMERA_STATUS_EEPROM_UPDATA : CKDeviceDef.h
  • CAMERA_STATUS_EOF_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_CREATE_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_FILE_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_FUNCTION_LOAD_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_GIGE_FILTER_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_GRAB_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_IIC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IN_PROCESS : CKDeviceDef.h
  • CAMERA_STATUS_INTERNAL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_IO_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_DATA_CRC_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_LOST_DATA : CKDeviceDef.h
  • CAMERA_STATUS_MV_TEST_FAILED : CKDeviceDef.h
  • CAMERA_STATUS_NET_SEND_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_NO_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_NO_MEMORY : CKDeviceDef.h
  • CAMERA_STATUS_NO_OPEN_DEVICE : CKDeviceDef.h
  • CAMERA_STATUS_NO_WRITE_EEPROM : CKDeviceDef.h
  • CAMERA_STATUS_NOT_INITIALIZED : CKDeviceDef.h
  • CAMERA_STATUS_NOT_SUPPORTED : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_DEVICE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OPEN_STREAM_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_OUT_OF_RANGE : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_INVALID : CKDeviceDef.h
  • CAMERA_STATUS_PARAMETER_OUT_OF_BOUND : CKDeviceDef.h
  • CAMERA_STATUS_PATH_NOT_FOUND : CKDeviceDef.h
  • CAMERA_STATUS_READ_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_REGISTRY_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SENSOR_ID_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SIZE_DISMATCH : CKDeviceDef.h
  • CAMERA_STATUS_SOCKET_INIT_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SPI_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_SUCCESS : CKDeviceDef.h
  • CAMERA_STATUS_TIME_OUT : CKDeviceDef.h
  • CAMERA_STATUS_UNENABLED : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW : CKDeviceDef.h
  • CAMERA_STATUS_UNKNOW_SENSOR : CKDeviceDef.h
  • CAMERA_STATUS_USB_BULK_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USB_CONTROL_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_USER_CANCEL : CKDeviceDef.h
  • CAMERA_STATUS_WAIT : CKDeviceDef.h
  • CAMERA_STATUS_WAIT_TRIGGER : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_ERROR : CKDeviceDef.h
  • CAMERA_STATUS_WRITE_PROTECTED : CKDeviceDef.h
  • CKSDK_API : CKCameraInterface.h
  • CMAERA_STATUS_FPGA_CFG_ERROR : CKDeviceDef.h
  • CROSSLINE_MAX_NUM : CKDeviceDef.h

- f -

  • FALSE : CKDeviceDef.h

- t -

  • TRUE : CKDeviceDef.h


CKCameraAPI: CKCameraInterface.h Source File

CKCameraInterface.h
Go to the documentation of this file.
1
2
3 #ifndef __CK_CAMERA_INTERFACE_H__
4 #define __CK_CAMERA_INTERFACE_H__
5
6 #include "CKDeviceDef.h"
7
8
9 #ifndef CKSDK_API
10
11 #ifdef _WIN32
12 #ifdef CKCAMERADLL_EXPORTS
13 #define CKSDK_API __declspec(dllexport)
14 #else
15 #define CKSDK_API __declspec(dllimport)
16 #endif
17 #else
18 #ifndef __stdcall
19 #define __stdcall
20 #endif
21 #ifndef CKSDK_API
22 #define CKSDK_API
23 #endif
24 #endif
25
26 #endif
27
28
29
30 typedef int CameraSdkStatus;
31
32 #ifdef __cplusplus
33 extern "C" {
34 #endif
35
49 CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDevice(INT *pDeviceNum);
50
51 CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDeviceFromOpenedDevList(int *pDeviceNum, int DevNum, int fds[], int pids[], char *paths[]);
71 CKSDK_API CameraSdkStatus __stdcall CameraGetEnumIndexInfo(INT CameraIndex, tDevEnumInfo* pDevInfo);
72
100 CKSDK_API CameraSdkStatus __stdcall CameraInit(PHANDLE phCamera, INT CameraIndex);
101
143 CKSDK_API CameraSdkStatus __stdcall CameraInitEx(PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam);
144
182 CKSDK_API CameraSdkStatus __stdcall CameraInitEx2(PHANDLE phCamera, const char *pFriendlyName);
183
217 CKSDK_API CameraSdkStatus __stdcall CameraInitEx3(PHANDLE phCamera, const char *pCameraSN);
218
254 CKSDK_API CameraSdkStatus __stdcall CameraInitEx4(PHANDLE phCamera, const char *pCameraSN, const tInitCameraParam *pstInitCameraParam);
255
277 CKSDK_API CameraSdkStatus __stdcall CameraUnInit(HANDLE hCamera);
278
286 typedef void(__stdcall* CAMERA_EXCEPTION_PROC) (HANDLE hCamera, emSdkExceptionType nMsgType, LPVOID lpParam);
287
302 CKSDK_API CameraSdkStatus __stdcall CameraRegisterExceptionCallback(HANDLE hCamera, CAMERA_EXCEPTION_PROC pExceptionCallback, LPVOID pUser);
303
321 CKSDK_API CameraSdkStatus __stdcall CameraGetCapability(HANDLE hCamera, tSdkCameraCapbility* pCameraCap);
322
336 CKSDK_API CameraSdkStatus __stdcall CameraGetCurDevInfo(HANDLE hCamera, tDevLoadInfo* pDevInfo);
337
381 CKSDK_API CameraSdkStatus __stdcall CameraGetRawImageBuffer(HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes);
382
402 CKSDK_API CameraSdkStatus __stdcall CameraReleaseFrameHandle(HANDLE hCamera, HANDLE hRawBuf);
403
459 CKSDK_API BYTE* __stdcall CameraGetImageInfo(HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo);
460
479 CKSDK_API CameraSdkStatus __stdcall CameraGetImageTimestamp(HANDLE hCamera, HANDLE hRawBuf, UINT64 *puTimestamp);
480
514 CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageBuffer(HANDLE hCamera, stImageInfo *pImgInfo, BYTE *pRawBuf, BYTE *pImgBuf);
515
541 CKSDK_API BYTE* __stdcall CameraGetImageBufferEx(HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes);
542
564 CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx1(HANDLE hCamera, BYTE* pImageData, stImageInfo *pImgInfo, UINT uTimes);
565
587 CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx2(HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes);
588
608 CKSDK_API BYTE* __stdcall CameraGetImageBufferEx3(HANDLE hCamera, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes);
609
621 CKSDK_API CameraSdkStatus __stdcall CameraResetTimestamp(HANDLE hCamera);
622
626 typedef void (__stdcall* CAMERA_SNAP_PROC)(HANDLE handle, BYTE *pFrameBuffer, stImageInfo* pFrameInfo, LPVOID lpParam);
627
649 CKSDK_API CameraSdkStatus __stdcall CameraSetCallbackFunction(HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld);
650
664 CKSDK_API CameraSdkStatus __stdcall CameraSetImageTransferMode(HANDLE hCamera, INT transferMode);
665
679 CKSDK_API CameraSdkStatus __stdcall CameraGetImageTransferMode(HANDLE hCamera, INT *pTransferMode);
680
694 CKSDK_API CameraSdkStatus __stdcall CameraRequestTransferImage(HANDLE hCamera);
695
709 CameraSdkStatus __stdcall CameraRequestTransferImageEx(HANDLE hCamera, int nCmd);
710
728 CKSDK_API CameraSdkStatus __stdcall CameraPause(HANDLE hCamera);
729
747 CKSDK_API CameraSdkStatus __stdcall CameraPlay(HANDLE hCamera);
748
774 CKSDK_API CameraSdkStatus __stdcall CameraDisplayInit(HANDLE hCamera, HWND hWndDisplay);
775
793 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayMode(HANDLE hCamera, INT iMode);
794
814 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayScaleRadio(HANDLE hCamera, INT iRadio);
815
839 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayOffset(HANDLE hCamera, INT iOffsetX, INT iOffsetY);
840
858 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplaySize(HANDLE hCamera, INT iWidth, INT iHeight);
859
883 CKSDK_API CameraSdkStatus __stdcall CameraSetCrossLine(HANDLE hCamera, INT iLine, INT x, INT y, UINT uColor, BOOL bVisible);
884
906 CKSDK_API CameraSdkStatus __stdcall CameraGetCrossLine(HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible);
907
929 CKSDK_API CameraSdkStatus __stdcall CameraImageOverlay(HANDLE hCamera, BYTE* pImgBuf, const stImageInfo* pImgInfo);
930
964 CKSDK_API CameraSdkStatus __stdcall CameraDrawText(BYTE* pImgBuf, const stImageInfo* pImgInfo,
965 char const* pFontFileName,
966 UINT FontWidth,
967 UINT FontHeight,
968 char const* pText,
969 INT Left,
970 INT Top,
971 UINT Width,
972 UINT Height,
973 UINT TextColor,
974 UINT uFlags
975 );
976
992 CKSDK_API CameraSdkStatus __stdcall CameraDisplay(HANDLE hCamera, BYTE* pImgBuf, stImageInfo* pImgInfo);
993
997 typedef void (__stdcall* CAMERA_DISPLAY_PROC)(HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam);
998
1022 CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayCallbackFun(HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld);
1023
1053 CKSDK_API CameraSdkStatus __stdcall CameraSnapToBuffer(HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE** ppImgBuf, UINT uWaitTimeMs);
1054
1076 CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionForSnap(HANDLE hCamera, tSdkImageResolution* pImageResolution);
1077
1091 CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionForSnap(HANDLE hCamera, tSdkImageResolution* pImageResolution);
1092
1093
1107 CKSDK_API CameraSdkStatus __stdcall CameraSetAeState(HANDLE hCamera, BOOL bAeState);
1108
1122 CKSDK_API CameraSdkStatus __stdcall CameraGetAeState(HANDLE hCamera, BOOL *pAeState);
1123
1137 CKSDK_API CameraSdkStatus __stdcall CameraSetAeTarget(HANDLE hCamera, WORD AeTarget);
1138
1152 CKSDK_API CameraSdkStatus __stdcall CameraGetAeTarget(HANDLE hCamera, WORD *pAeTarget);
1153
1179 CKSDK_API CameraSdkStatus __stdcall CameraSetAnalogGain(HANDLE hCamera, UINT uAnalogGain);
1180
1194 CKSDK_API CameraSdkStatus __stdcall CameraGetAnalogGain(HANDLE hCamera, UINT *puAnalogGain);
1195
1229 CKSDK_API CameraSdkStatus __stdcall CameraSetExposureTime(HANDLE hCamera, double dExposureTime);
1230
1244 CKSDK_API CameraSdkStatus __stdcall CameraGetExposureTime(HANDLE hCamera, double *pdExposureTime);
1245
1265 CKSDK_API CameraSdkStatus __stdcall CameraSetAeWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight);
1266
1286 CKSDK_API CameraSdkStatus __stdcall CameraGetAeWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight);
1287
1305 CKSDK_API CameraSdkStatus __stdcall CameraSetAeWinVisible(HANDLE hCamera, BOOL bDisplayEn);
1306
1320 CKSDK_API CameraSdkStatus __stdcall CameraGetAeWinVisible(HANDLE hCamera, BOOL *pbDisplayEn);
1321
1336 CKSDK_API CameraSdkStatus __stdcall CameraSetAntiFlick(HANDLE hCamera, BOOL bEnable);
1337
1351 CKSDK_API CameraSdkStatus __stdcall CameraGetAntiFlick(HANDLE hCamera, BOOL *pbEnable);
1352
1366 CKSDK_API CameraSdkStatus __stdcall CameraSetLightFrequency(HANDLE hCamera, INT iFrequencySel);
1367
1381 CKSDK_API CameraSdkStatus __stdcall CameraGetLightFrequency(HANDLE hCamera, INT *piFrequencySel);
1382
1396 CKSDK_API CameraSdkStatus __stdcall CameraGetExposureLineTime(HANDLE hCamera, double *pExposureLineTime);
1397
1411 CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureMode(HANDLE hCamera, INT iMode);
1412
1426 CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureMode(HANDLE hCamera, INT* piMode);
1427
1443 CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureRange(HANDLE hCamera, double dMinExposureTime, double dMaxExposureTime);
1444
1460 CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureRange(HANDLE hCamera, double* pdMinExposureTime, double* pdMaxExposureTime);
1461
1477 CKSDK_API CameraSdkStatus __stdcall CameraSetAeAnalogGainRange(HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain);
1478
1494 CKSDK_API CameraSdkStatus __stdcall CameraGetAeAnalogGainRange(HANDLE hCamera, INT* iMinAnalogGain, INT* iMaxAnalogGain);
1495
1521 CKSDK_API CameraSdkStatus __stdcall CameraSetGain(HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB);
1522
1540 CKSDK_API CameraSdkStatus __stdcall CameraGetGain(HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB);
1541
1556 CKSDK_API CameraSdkStatus __stdcall CameraSetWbMode(HANDLE hCamera, BOOL bAuto);
1557
1572 CKSDK_API CameraSdkStatus __stdcall CameraGetWbMode(HANDLE hCamera, BOOL *pbAuto);
1573
1588 CKSDK_API CameraSdkStatus __stdcall CameraSetOnceWB(HANDLE hCamera);
1589
1609 CKSDK_API CameraSdkStatus __stdcall CameraSetWbWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight);
1610
1630 CKSDK_API CameraSdkStatus __stdcall CameraGetWbWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight);
1631
1645 CKSDK_API CameraSdkStatus __stdcall CameraSetWbWinVisible(HANDLE hCamera, BOOL bDisplayEn);
1646
1660 CKSDK_API CameraSdkStatus __stdcall CameraGetWbWinVisible(HANDLE hCamera, BOOL *pDisplayEn);
1661
1662
1682 CKSDK_API CameraSdkStatus __stdcall CameraSetLutMode(HANDLE hCamera, INT emLutMode);
1683
1698 CKSDK_API CameraSdkStatus __stdcall CameraGetLutMode(HANDLE hCamera, INT *pemLutMode);
1699
1719 CKSDK_API CameraSdkStatus __stdcall CameraSetGamma(HANDLE hCamera, INT iGamma);
1720
1735 CKSDK_API CameraSdkStatus __stdcall CameraGetGamma(HANDLE hCamera, INT* piGamma);
1736
1756 CKSDK_API CameraSdkStatus __stdcall CameraSetContrastLut(HANDLE hCamera, INT iContrast);
1757
1773 CKSDK_API CameraSdkStatus __stdcall CameraGetContrastLut(HANDLE hCamera, INT* piContrast);
1774
1790 CKSDK_API CameraSdkStatus __stdcall CameraSelectLutPreset(HANDLE hCamera, INT iSel);
1791
1805 CKSDK_API CameraSdkStatus __stdcall CameraGetLutPresetSel(HANDLE hCamera, INT *piSel);
1806
1829 CKSDK_API CameraSdkStatus __stdcall CameraSetCustomLut(HANDLE hCamera, INT iChannel, USHORT* pLut);
1830
1851 CKSDK_API CameraSdkStatus __stdcall CameraGetCustomLut(HANDLE hCamera, INT iChannel, USHORT* pLut);
1852
1873 CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentLut(HANDLE hCamera, INT iChannel, USHORT* pLut);
1874
1896 CKSDK_API CameraSdkStatus __stdcall CameraSetSharpness(HANDLE hCamera, INT iSharpness);
1897
1911 CKSDK_API CameraSdkStatus __stdcall CameraGetSharpness(HANDLE hCamera, INT *piSharpness);
1912
1936 CKSDK_API CameraSdkStatus __stdcall CameraSetSaturation(HANDLE hCamera, INT iSaturation);
1937
1951 CKSDK_API CameraSdkStatus __stdcall CameraGetSaturation(HANDLE hCamera, INT *piSaturation);
1952
1974 CKSDK_API CameraSdkStatus __stdcall CameraSetContrast(HANDLE hCamera, INT iContrast);
1975
1990 CKSDK_API CameraSdkStatus __stdcall CameraGetContrast(HANDLE hCamera, INT *piContrast);
1991
2005 CKSDK_API CameraSdkStatus __stdcall CameraGetFrameTime(HANDLE hCamera, double *pdFrameTime);
2006
2052 CKSDK_API CameraSdkStatus __stdcall CameraSetFrameSpeed(HANDLE hCamera, INT iFrameSpeed);
2053
2069 CKSDK_API CameraSdkStatus __stdcall CameraGetFrameSpeed(HANDLE hCamera, INT *piFrameSpeed);
2070
2088 CKSDK_API CameraSdkStatus __stdcall CameraSetResolution(HANDLE hCamera, INT iResolutionIndex);
2089
2103 CKSDK_API CameraSdkStatus __stdcall CameraGetResolution(HANDLE hCamera, INT *piResolutionIndex);
2104
2118 CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionEx(HANDLE hCamera, tSdkImageResolution* pImageResolution);
2119
2135 CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionEx(HANDLE hCamera, INT iResolution, tSdkImageResolution* pImageResolution);
2136
2150 CKSDK_API CameraSdkStatus __stdcall CameraGetCurResolution(HANDLE hCamera, tSdkImageResolution* pImageResolution);
2151
2167 CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageSize(HANDLE hCamera, DWORD *pWidth, DWORD *pHeight);
2168
2182 CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgMode(HANDLE hCamera, INT iAlgMode);
2183
2197 CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgThreshold(HANDLE hCamera, INT iAlgMode);
2198
2212 CKSDK_API CameraSdkStatus __stdcall CameraGetBayerAlgMode(HANDLE hCamera, INT *piAlgMode);
2213
2294 CKSDK_API CameraSdkStatus __stdcall CameraSetIspOutFormat(HANDLE hCamera, INT iFormat);
2295
2331 CKSDK_API CameraSdkStatus __stdcall CameraGetIspOutFormat(HANDLE hCamera, INT *piFormat);
2332
2346 CKSDK_API CameraSdkStatus __stdcall CameraGetFrameStatistic(HANDLE hCamera, FrameStatistic *psFrameStatistic);
2347
2400 CKSDK_API CameraSdkStatus __stdcall CameraSaveImage(HANDLE hCamera, const char* lpszFileName, const BYTE* pImgBuf, const stImageInfo* pImgInfo, UINT byFileType, BYTE byQuality);
2401
2417 CKSDK_API CameraSdkStatus __stdcall CameraSetMirror(HANDLE hCamera, INT iDir, BOOL bEnable);
2418
2436 CKSDK_API CameraSdkStatus __stdcall CameraGetMirror(HANDLE hCamera, INT iDir, BOOL *pbEnable);
2437
2451 CKSDK_API CameraSdkStatus __stdcall CameraSetMonochrome(HANDLE hCamera, BOOL bEnable);
2452
2467 CKSDK_API CameraSdkStatus __stdcall CameraGetMonochrome(HANDLE hCamera, BOOL *pbEnable);
2468
2482 CKSDK_API CameraSdkStatus __stdcall CameraSetBlackLevel(HANDLE hCamera, INT iBlackLevel);
2483
2497 CKSDK_API CameraSdkStatus __stdcall CameraGetBlackLevel(HANDLE hCamera, INT* piBlackLevel);
2498
2517 CKSDK_API CameraSdkStatus __stdcall CameraSetSensorOutPixelFormat(HANDLE hCamera, UINT iFormat);
2518
2534 CKSDK_API CameraSdkStatus __stdcall CameraGetSensorOutPixelFormat(HANDLE hCamera, UINT *piFormat);
2535
2549 CKSDK_API CameraSdkStatus __stdcall CameraSetCorrectDeadPixel(HANDLE hCamera, BOOL bEnable);
2550
2564 CKSDK_API CameraSdkStatus __stdcall CameraGetCorrectDeadPixel(HANDLE hCamera, BOOL *pbEnable);
2565
2579 CKSDK_API CameraSdkStatus __stdcall CameraLscCalib(HANDLE hCamera, tLscCalibParam *pLscCalibParam);
2580
2594 CKSDK_API CameraSdkStatus __stdcall CameraLscCorrect(HANDLE hCamera, tLscCorrectParam *pLscCorrectParam);
2595
2625 CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerMode(HANDLE hCamera, INT iTriggerModeSel);
2626
2640 CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerMode(HANDLE hCamera, INT *piTriggerModeSel);
2641
2685 CKSDK_API CameraSdkStatus __stdcall CameraSoftTrigger(HANDLE hCamera);
2686
2704 CKSDK_API CameraSdkStatus __stdcall CameraBroadcastSoftTrigger(const char *pStrNetCardIP, int nCmd);
2705
2723 CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerFrameCount(HANDLE hCamera, INT frameCount);
2724
2738 CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerFrameCount(HANDLE hCamera, INT *pFrameCount);
2739
2753 CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerDelayTime(HANDLE hCamera, UINT delayTimeUs);
2754
2768 CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerDelayTime(HANDLE hCamera, UINT *pDelayTimeUs);
2769
2785 CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerJitterTime(HANDLE hCamera, INT inputIOIndex, UINT jitterTimeUs);
2786
2802 CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerJitterTime(HANDLE hCamera, INT inputIOIndex, UINT *pJitterTimeUs);
2803
2819 CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerSignalType(HANDLE hCamera, INT inputIOIndex, INT type);
2820
2836 CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerSignalType(HANDLE hCamera, INT inputIOIndex, INT *pType);
2837
2853 CKSDK_API CameraSdkStatus __stdcall CameraSetStrobeMode(HANDLE hCamera, INT outputIOIndex, INT mode);
2854
2870 CKSDK_API CameraSdkStatus __stdcall CameraGetStrobeMode(HANDLE hCamera, INT outputIOIndex, INT *pMode);
2871
2887 CKSDK_API CameraSdkStatus __stdcall CameraSetStrobeDelayTime(HANDLE hCamera, INT outputIOIndex, UINT delayTimeUs);
2888
2904 CKSDK_API CameraSdkStatus __stdcall CameraGetStrobeDelayTime(HANDLE hCamera, INT outputIOIndex, UINT *pDevlayTimeUs);
2905
2921 CKSDK_API CameraSdkStatus __stdcall CameraSetStrobePulseWidth(HANDLE hCamera, INT outputIOIndex, UINT pulseWidth);
2922
2938 CKSDK_API CameraSdkStatus __stdcall CameraGetStrobePulseWidth(HANDLE hCamera, INT outputIOIndex, UINT *pPulseWidth);
2939
2955 CKSDK_API CameraSdkStatus __stdcall CameraSetStrobePolarity(HANDLE hCamera, INT outputIOIndex, INT polarity);
2956
2972 CKSDK_API CameraSdkStatus __stdcall CameraGetStrobePolarity(HANDLE hCamera, INT outputIOIndex, INT *pPolarity);
2973
2990 CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOMode(HANDLE hCamera, INT outputIOIndex, INT mode);
2991
3007 CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOMode(HANDLE hCamera, INT outputIOIndex, INT *pMode);
3008
3024 CKSDK_API CameraSdkStatus __stdcall CameraSetInputIOMode(HANDLE hCamera, INT inputIOIndex, INT mode);
3025
3041 CKSDK_API CameraSdkStatus __stdcall CameraGetInputIOMode(HANDLE hCamera, INT inputIOIndex, INT *pMode);
3042
3058 CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOState(HANDLE hCamera, INT outputIOIndex, INT state);
3059
3075 CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOState(HANDLE hCamera, INT outputIOIndex, INT *pState);
3076
3094 CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOPWM(HANDLE hCamera, INT outputIOIndex, UINT cycle, UINT duty);
3095
3113 CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOPWM(HANDLE hCamera, INT outputIOIndex, INT *pCycle, INT *pDuty);
3114
3130 CKSDK_API CameraSdkStatus __stdcall CameraGetInputIOState(HANDLE hCamera, INT inputIOIndex, INT *pState);
3131
3147 CKSDK_API CameraSdkStatus __stdcall CameraSetParameterMode(HANDLE hCamera, INT iMode);
3148
3162 CKSDK_API CameraSdkStatus __stdcall CameraGetParameterMode(HANDLE hCamera, INT* piMode);
3163
3185 CKSDK_API CameraSdkStatus __stdcall CameraSaveParameter(HANDLE hCamera, INT iTeam);
3186
3202 CKSDK_API CameraSdkStatus __stdcall CameraSaveParameterToFile(HANDLE hCamera, const char* sFileName);
3203
3221 CKSDK_API CameraSdkStatus __stdcall CameraReadParameterFromFile(HANDLE hCamera, const char* sFileName);
3222
3246 CKSDK_API CameraSdkStatus __stdcall CameraLoadParameter(HANDLE hCamera, INT iTeam);
3247
3263 CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentParameterGroup(HANDLE hCamera, INT* piTeam);
3264
3290 CKSDK_API CameraSdkStatus __stdcall CameraWriteSN(HANDLE hCamera, BYTE* pbySN, INT iLevel);
3291
3311 CKSDK_API CameraSdkStatus __stdcall CameraReadSN(HANDLE hCamera, BYTE* pbySN, INT iLevel);
3312
3331 CKSDK_API CameraSdkStatus __stdcall CameraSaveUserData(HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen);
3332
3361 CKSDK_API CameraSdkStatus __stdcall CameraLoadUserData(HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen);
3362
3380 CKSDK_API CameraSdkStatus __stdcall CameraGetFriendlyName(HANDLE hCamera, char* pName);
3381
3395 CKSDK_API CameraSdkStatus __stdcall CameraSetFriendlyName(HANDLE hCamera, char* pName);
3396
3408 CKSDK_API CameraSdkStatus __stdcall CameraSdkGetVersionString(char* pVersionString);
3409
3423 CKSDK_API CameraSdkStatus __stdcall CameraCheckFwUpdate(HANDLE hCamera, BOOL* pNeedUpdate);
3424
3438 CKSDK_API CameraSdkStatus __stdcall CameraGetFirmwareVision(HANDLE hCamera, char* pVersion);
3439
3453 CKSDK_API CameraSdkStatus __stdcall CameraGetDeviceType(HANDLE hCamera, DWORD* pDeviceID);
3454
3468 CKSDK_API CameraSdkStatus __stdcall CameraGetInerfaceVersion(HANDLE hCamera, char* pVersion);
3469
3488 CKSDK_API CameraSdkStatus __stdcall CameraShowSettingPage(HANDLE hCamera, BOOL bShow);
3489
3509 CKSDK_API CameraSdkStatus __stdcall CameraSetActivePage(HANDLE hCamera, LONG lActivePage, INT iDefault);
3510
3522 CKSDK_API CameraSdkStatus __stdcall CameraCreateSettingPageEx(HANDLE hCamera);
3523
3537 CKSDK_API CameraSdkStatus __stdcall CameraCustomizeResolution(
3538 HANDLE hCamera,
3539 tSdkImageResolution* pImageCustom
3540 );
3541
3563 CKSDK_API CameraSdkStatus __stdcall CameraCustomizeReferWin(
3564 HANDLE hCamera,
3565 INT iWinType,
3566 INT* piHOff,
3567 INT* piVOff,
3568 INT* piWidth,
3569 INT* piHeight
3570 );
3571
3587 CKSDK_API CameraSdkStatus __stdcall CameraGigeGetIp(const char *pCameraSN, tGigeNetworkInfo *pNetworkInfo);
3588
3604 CKSDK_API CameraSdkStatus __stdcall CameraGigeSetIp(const char *pCameraSN, const tGigeNetworkInfo *pNetworkInfo);
3605
3623 CKSDK_API CameraSdkStatus __stdcall CameraGigeGetTransPacketSize(HANDLE hCamera, UINT *pPacketSize);
3624
3642 CKSDK_API CameraSdkStatus __stdcall CameraGigeSetTransPacketSize(HANDLE hCamera, UINT packetSize);
3643
3661 CKSDK_API CameraSdkStatus __stdcall CameraGigeGetPacketDelayTime(HANDLE hCamera, UINT *pDelayUs);
3662
3680 CKSDK_API CameraSdkStatus __stdcall CameraGigeSetPacketDelayTime(HANDLE hCamera, UINT delayUs);
3681
3701 CKSDK_API CameraSdkStatus __stdcall CameraGigeSetResend(HANDLE hCamera, BOOL bEnable, UINT nMaxResendPercent, UINT nResendTimeout);
3702
3717 CKSDK_API CameraSdkStatus __stdcall CameraGigeGetOptimalPacketSize(HANDLE hCamera, UINT *pOptimalPacketSize);
3718
3742 CKSDK_API CameraSdkStatus __stdcall CameraStartRecord(HANDLE hCamera, const char *pstrSavePath, INT iFormat, INT iBitrate, INT iFrameRate);
3743
3763 CKSDK_API CameraSdkStatus __stdcall CameraPushOneFrame(HANDLE hCamera, const BYTE *pFrameBuffer, const stImageInfo *pImgInfo);
3764
3780 CKSDK_API CameraSdkStatus __stdcall CameraStopRecord(HANDLE hCamera);
3781
3786 typedef void(__stdcall* CAMERA_UPGRADE_PROC)(INT percent, LPVOID lpParam);
3787
3810 CKSDK_API CameraSdkStatus __stdcall CameraUpgrade(HANDLE hCamera, const char* pFilePath, CAMERA_UPGRADE_PROC callback, LPVOID lpParam);
3811
3841 CKSDK_API CameraSdkStatus __stdcall CameraSetIntValue(HANDLE hCamera, emSdkValueType type, INT value);
3842
3856 CKSDK_API CameraSdkStatus __stdcall CameraGetIntValue(HANDLE hCamera, emSdkValueType type, INT *pValue);
3857
3867 CKSDK_API CameraSdkStatus __stdcall CameraReboot(HANDLE hCamera);
3868
3869 #ifdef __cplusplus
3870 }
3871 #endif
3872
3873 #endif
CameraSetAeTarget
CKSDK_API CameraSdkStatus __stdcall CameraSetAeTarget(HANDLE hCamera, WORD AeTarget)
Sets the brightness target value for auto exposure. The setting range is obtained by the CameraGetCap...
CameraGetAeWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraGetAeWinVisible(HANDLE hCamera, BOOL *pbDisplayEn)
Gets the display status of the auto exposure reference window.
CameraSetDisplayMode
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayMode(HANDLE hCamera, INT iMode)
Sets the mode of display. Must call CameraDisplayInit This function can be called by initializing...
CameraGetTriggerMode
CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerMode(HANDLE hCamera, INT *piTriggerModeSel)
Get the trigger mode of the camera.
CameraSetBayerAlgMode
CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgMode(HANDLE hCamera, INT iAlgMode)
Sets the Bayer to RGB algorithm mode.
CameraGetImageBufferEx2
CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx2(HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes)
Gets one frame of image data. The image obtained by this interface is the processed format...
CameraSetTriggerDelayTime
CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerDelayTime(HANDLE hCamera, UINT delayTimeUs)
Set how much time to take a photo after camera trigger.
CameraGetAeExposureMode
CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureMode(HANDLE hCamera, INT *piMode)
Get exposure mode in auto exposure mode.
CameraGetMirror
CKSDK_API CameraSdkStatus __stdcall CameraGetMirror(HANDLE hCamera, INT iDir, BOOL *pbEnable)
Gets the mirrored state of the image.
CameraSdkGetVersionString
CKSDK_API CameraSdkStatus __stdcall CameraSdkGetVersionString(char *pVersionString)
Get SDK version information.
CameraSetDisplayCallbackFun
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayCallbackFun(HANDLE hCamera, CAMERA_DISPLAY_PROC pCallBack, LPVOID lpParam, CAMERA_DISPLAY_PROC *pCallbackOld)
Sets the display callback. Must be called CameraDisplayInit This function can be called by initializa...
CameraGigeSetIp
CKSDK_API CameraSdkStatus __stdcall CameraGigeSetIp(const char *pCameraSN, const tGigeNetworkInfo *pNetworkInfo)
Set the camera&#39;s network address by the camera&#39;s serial number.
CameraGetRawImageBuffer
CKSDK_API CameraSdkStatus __stdcall CameraGetRawImageBuffer(HANDLE hCamera, PHANDLE phRawBuf, UINT uTimes)
Gets a frame of image raw data. In order to improve efficiency, the SDK uses a zero copy mechanism fo...
CameraSaveParameterToFile
CKSDK_API CameraSdkStatus __stdcall CameraSaveParameterToFile(HANDLE hCamera, const char *sFileName)
Saves the current camera parameters to the specified file. The file can be copied to Other computers ...
CameraGetFrameTime
CKSDK_API CameraSdkStatus __stdcall CameraGetFrameTime(HANDLE hCamera, double *pdFrameTime)
Get the current image frame time.
CameraGetWbMode
CKSDK_API CameraSdkStatus __stdcall CameraGetWbMode(HANDLE hCamera, BOOL *pbAuto)
Get the current white balance mode.
CameraGigeSetTransPacketSize
CKSDK_API CameraSdkStatus __stdcall CameraGigeSetTransPacketSize(HANDLE hCamera, UINT packetSize)
Get the camera&#39;s network address by the camera&#39;s serial number.
CameraSetAeExposureMode
CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureMode(HANDLE hCamera, INT iMode)
Sets the exposure mode in auto exposure mode.
CameraInit
CKSDK_API CameraSdkStatus __stdcall CameraInit(PHANDLE phCamera, INT CameraIndex)
Camera initialization. After the initialization is successful, you can call any other The camera-rela...
CameraReadParameterFromFile
CKSDK_API CameraSdkStatus __stdcall CameraReadParameterFromFile(HANDLE hCamera, const char *sFileName)
Loads parameters from the parameter file specified on the PC. My company camera parameters Save the f...
CameraGetFirmwareVision
CKSDK_API CameraSdkStatus __stdcall CameraGetFirmwareVision(HANDLE hCamera, char *pVersion)
gets the firmware version of the string
CameraGetExposureLineTime
CKSDK_API CameraSdkStatus __stdcall CameraGetExposureLineTime(HANDLE hCamera, double *pExposureLineTime)
Get a line of exposure time, in subtle.
CameraResetTimestamp
CKSDK_API CameraSdkStatus __stdcall CameraResetTimestamp(HANDLE hCamera)
Resets the timestamp of image acquisition, starting at 0.
CameraSaveUserData
CKSDK_API CameraSdkStatus __stdcall CameraSaveUserData(HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
saves user-defined data to the camera&#39;s non-volatile memory. The maximum length of the user data area...
CameraGetStrobePolarity
CKSDK_API CameraSdkStatus __stdcall CameraGetStrobePolarity(HANDLE hCamera, INT outputIOIndex, INT *pPolarity)
Get the active level of the flash.
CameraGetLutPresetSel
CKSDK_API CameraSdkStatus __stdcall CameraGetLutPresetSel(HANDLE hCamera, INT *piSel)
Gets the LUT table index number in the default LUT mode.
CameraGetTriggerFrameCount
CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerFrameCount(HANDLE hCamera, INT *pFrameCount)
Get how many pictures are taken continuously when the camera is triggered.
_tSdkCameraCapbility
Camera Ability Level.
Definition: CKDeviceDef.h:1209
CameraSetFriendlyName
CKSDK_API CameraSdkStatus __stdcall CameraSetFriendlyName(HANDLE hCamera, char *pName)
Sets a user-defined device nickname.
CameraGetImageTransferMode
CKSDK_API CameraSdkStatus __stdcall CameraGetImageTransferMode(HANDLE hCamera, INT *pTransferMode)
CameraSetAeWindow
CKSDK_API CameraSdkStatus __stdcall CameraSetAeWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
Sets the reference window for auto exposure.
CameraGetCorrectDeadPixel
CKSDK_API CameraSdkStatus __stdcall CameraGetCorrectDeadPixel(HANDLE hCamera, BOOL *pbEnable)
Get the status of dead pixel correction.
CameraGetImageBufferEx1
CKSDK_API CameraSdkStatus __stdcall CameraGetImageBufferEx1(HANDLE hCamera, BYTE *pImageData, stImageInfo *pImgInfo, UINT uTimes)
Gets a frame of image data. The image obtained by this interface is the processed format...
CameraGetSharpness
CKSDK_API CameraSdkStatus __stdcall CameraGetSharpness(HANDLE hCamera, INT *piSharpness)
Gets the current sharpening setting.
CameraSoftTrigger
CKSDK_API CameraSdkStatus __stdcall CameraSoftTrigger(HANDLE hCamera)
performs a soft trigger.
CameraSetLightFrequency
CKSDK_API CameraSdkStatus __stdcall CameraSetLightFrequency(HANDLE hCamera, INT iFrequencySel)
Sets the frequency of the strobe flash during auto exposure.
UINT64
uint64_t UINT64
Definition: CKDeviceDef.h:16
CameraSetInputIOMode
CKSDK_API CameraSdkStatus __stdcall CameraSetInputIOMode(HANDLE hCamera, INT inputIOIndex, INT mode)
Sets the mode of input IO. The number of programmable output IOs reserved by the camera is determined...
CameraSetStrobeDelayTime
CKSDK_API CameraSdkStatus __stdcall CameraSetStrobeDelayTime(HANDLE hCamera, INT outputIOIndex, UINT delayTimeUs)
Set how long to delay the flash after the trigger.
CameraSetSensorOutPixelFormat
CKSDK_API CameraSdkStatus __stdcall CameraSetSensorOutPixelFormat(HANDLE hCamera, UINT iFormat)
Set the format of the raw image data.
CameraGetTriggerJitterTime
CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerJitterTime(HANDLE hCamera, INT inputIOIndex, UINT *pJitterTimeUs)
Get the hardware to trigger the debounce time.
CameraGetAeAnalogGainRange
CKSDK_API CameraSdkStatus __stdcall CameraGetAeAnalogGainRange(HANDLE hCamera, INT *iMinAnalogGain, INT *iMaxAnalogGain)
Get the gain adjustment range of the auto exposure mode.
CameraCustomizeReferWin
CKSDK_API CameraSdkStatus __stdcall CameraCustomizeReferWin(HANDLE hCamera, INT iWinType, INT *piHOff, INT *piVOff, INT *piWidth, INT *piHeight)
Opens the reference window custom panel. And visually get the location of a custom window...
CameraSetExposureTime
CKSDK_API CameraSdkStatus __stdcall CameraSetExposureTime(HANDLE hCamera, double dExposureTime)
Set the exposure time. The unit is microseconds. For CMOS sensors, their exposure The unit is calcula...
CameraGetContrast
CKSDK_API CameraSdkStatus __stdcall CameraGetContrast(HANDLE hCamera, INT *piContrast)
Gets the contrast value. Please refer to A functional description of the CameraSetContrast function...
CameraGigeGetOptimalPacketSize
CKSDK_API CameraSdkStatus __stdcall CameraGigeGetOptimalPacketSize(HANDLE hCamera, UINT *pOptimalPacketSize)
Get the delay interval for GVSP packets of GigE camera.
CameraGetCurrentLut
CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentLut(HANDLE hCamera, INT iChannel, USHORT *pLut)
Get the camera&#39;s current LUT table, which can be called in any LUT mode. Used to visually observe cha...
BOOL
int BOOL
Definition: CKDeviceDef.h:17
WORD
uint16_t WORD
Definition: CKDeviceDef.h:15
CameraSetSharpness
CKSDK_API CameraSdkStatus __stdcall CameraSetSharpness(HANDLE hCamera, INT iSharpness)
Sets the sharpening parameters for the processing of the image.
emSdkExceptionType
emSdkExceptionType
Definition: CKDeviceDef.h:548
CameraSetDisplayOffset
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayOffset(HANDLE hCamera, INT iOffsetX, INT iOffsetY)
Sets the starting offset value for the display. Only when the display mode is emSdkDisplayMode::DISPL...
CameraSaveParameter
CKSDK_API CameraSdkStatus __stdcall CameraSaveParameter(HANDLE hCamera, INT iTeam)
Saves the current camera parameters to the specified parameter group. The camera provides A...
CameraUnInit
CKSDK_API CameraSdkStatus __stdcall CameraUnInit(HANDLE hCamera)
Camera reverse initialization. Release resources.
CameraGetFriendlyName
CKSDK_API CameraSdkStatus __stdcall CameraGetFriendlyName(HANDLE hCamera, char *pName)
Read user-defined device nicknames.
CameraInitEx
CKSDK_API CameraSdkStatus __stdcall CameraInitEx(PHANDLE phCamera, INT CameraIndex, INT iParamLoadMode, INT emTeam)
Camera initialization. After the initialization is successful, you can call any other Camera related ...
CameraSetOnceWB
CKSDK_API CameraSdkStatus __stdcall CameraSetOnceWB(HANDLE hCamera)
In manual white balance mode, calling this function will perform a white balance. The effective time ...
CameraSetAntiFlick
CKSDK_API CameraSdkStatus __stdcall CameraSetAntiFlick(HANDLE hCamera, BOOL bEnable)
Sets the enable status of the anti-strobe function during auto exposure. For manual Inactive in expos...
CameraGetDeviceType
CKSDK_API CameraSdkStatus __stdcall CameraGetDeviceType(HANDLE hCamera, DWORD *pDeviceID)
Get device version ID.
CameraGetStrobePulseWidth
CKSDK_API CameraSdkStatus __stdcall CameraGetStrobePulseWidth(HANDLE hCamera, INT outputIOIndex, UINT *pPulseWidth)
Get the pulse width of the flash.
HANDLE
void * HANDLE
Definition: CKDeviceDef.h:20
CameraSetResolutionForSnap
CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionForSnap(HANDLE hCamera, tSdkImageResolution *pImageResolution)
Sets the resolution of the camera output image in snap mode.
CameraSetResolution
CKSDK_API CameraSdkStatus __stdcall CameraSetResolution(HANDLE hCamera, INT iResolutionIndex)
Sets the resolution of the camera output image.
CameraGetIntValue
CKSDK_API CameraSdkStatus __stdcall CameraGetIntValue(HANDLE hCamera, emSdkValueType type, INT *pValue)
gets the shaping parameters, the parameter type is defined by emSdkValueType
CameraGetStrobeDelayTime
CKSDK_API CameraSdkStatus __stdcall CameraGetStrobeDelayTime(HANDLE hCamera, INT outputIOIndex, UINT *pDevlayTimeUs)
Gets the delay time to illuminate the flash after triggering.
UINT
uint32_t UINT
Definition: CKDeviceDef.h:14
CameraGetAeWindow
CKSDK_API CameraSdkStatus __stdcall CameraGetAeWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
Gets the location of the auto exposure reference window.
CameraGetExposureTime
CKSDK_API CameraSdkStatus __stdcall CameraGetExposureTime(HANDLE hCamera, double *pdExposureTime)
Get the camera&#39;s exposure time. See CameraSetExposureTime Functional description. ...
HDC
void * HDC
Definition: CKDeviceDef.h:23
DWORD
uint32_t DWORD
Definition: CKDeviceDef.h:12
CameraGetInputIOMode
CKSDK_API CameraSdkStatus __stdcall CameraGetInputIOMode(HANDLE hCamera, INT inputIOIndex, INT *pMode)
Get the mode of input IO. The number of programmable output IOs reserved by the camera is determined ...
CKSDK_API
#define CKSDK_API
Definition: CKCameraInterface.h:22
CameraSaveImage
CKSDK_API CameraSdkStatus __stdcall CameraSaveImage(HANDLE hCamera, const char *lpszFileName, const BYTE *pImgBuf, const stImageInfo *pImgInfo, UINT byFileType, BYTE byQuality)
Saves the image buffer data as an image file.
LPVOID
void * LPVOID
Definition: CKDeviceDef.h:22
CameraLscCalib
CKSDK_API CameraSdkStatus __stdcall CameraLscCalib(HANDLE hCamera, tLscCalibParam *pLscCalibParam)
LSC calibration.
CameraBroadcastSoftTrigger
CKSDK_API CameraSdkStatus __stdcall CameraBroadcastSoftTrigger(const char *pStrNetCardIP, int nCmd)
Sends soft-trigger commands to all cameras connected to the network card.
CameraSetTriggerJitterTime
CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerJitterTime(HANDLE hCamera, INT inputIOIndex, UINT jitterTimeUs)
Set the hardware to trigger the debounce time.
CameraImageOverlay
CKSDK_API CameraSdkStatus __stdcall CameraImageOverlay(HANDLE hCamera, BYTE *pImgBuf, const stImageInfo *pImgInfo)
superimposes the input image data on the crosshair, white balance reference window, Auto exposure reference window and other graphics. Only set to visible Crosshairs and reference windows can be superimposed. Note that the input image for this function must be in RGB format.
CameraInitEx3
CKSDK_API CameraSdkStatus __stdcall CameraInitEx3(PHANDLE phCamera, const char *pCameraSN)
Camera initialization. After the initialization is successful, you can call any other Camera related ...
CameraSetMirror
CKSDK_API CameraSdkStatus __stdcall CameraSetMirror(HANDLE hCamera, INT iDir, BOOL bEnable)
Sets the image mirroring operation. The mirroring operation is divided into two directions, horizontal and vertical.
CameraSetSaturation
CKSDK_API CameraSdkStatus __stdcall CameraSetSaturation(HANDLE hCamera, INT iSaturation)
Sets the saturation of image processing. Not valid for black and white cameras. The setting range is ...
USHORT
unsigned short USHORT
Definition: CKDeviceDef.h:25
CameraSetResolutionEx
CKSDK_API CameraSdkStatus __stdcall CameraSetResolutionEx(HANDLE hCamera, tSdkImageResolution *pImageResolution)
Sets the resolution of the custom preview.
CameraCheckFwUpdate
CKSDK_API CameraSdkStatus __stdcall CameraCheckFwUpdate(HANDLE hCamera, BOOL *pNeedUpdate)
Detects the firmware version and needs to be upgraded.
CameraGetInerfaceVersion
CKSDK_API CameraSdkStatus __stdcall CameraGetInerfaceVersion(HANDLE hCamera, char *pVersion)
Get the version of the specified device interface.
CameraPlay
CKSDK_API CameraSdkStatus __stdcall CameraPlay(HANDLE hCamera)
puts the SDK into working mode and starts receiving images sent from the camera Data. If the current camera is in trigger mode, you need to receive it. The image will not be updated until the frame is triggered.
CameraSetTriggerMode
CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerMode(HANDLE hCamera, INT iTriggerModeSel)
Sets the camera&#39;s trigger mode.
CameraSetBayerAlgThreshold
CKSDK_API CameraSdkStatus __stdcall CameraSetBayerAlgThreshold(HANDLE hCamera, INT iAlgMode)
Sets the Bayer to RGB algorithm mode.
CameraGetImageBufferEx3
CKSDK_API BYTE *__stdcall CameraGetImageBufferEx3(HANDLE hCamera, stImageInfo *pImgInfo, UINT64 *puTimeStamp, UINT uTimes)
Gets one frame of image data. The image obtained by this interface is the processed format...
CameraGetBayerAlgMode
CKSDK_API CameraSdkStatus __stdcall CameraGetBayerAlgMode(HANDLE hCamera, INT *piAlgMode)
Get Bayer to RGB algorithm mode.
CameraSetStrobeMode
CKSDK_API CameraSdkStatus __stdcall CameraSetStrobeMode(HANDLE hCamera, INT outputIOIndex, INT mode)
Set flash mode.
CameraSetStrobePolarity
CKSDK_API CameraSdkStatus __stdcall CameraSetStrobePolarity(HANDLE hCamera, INT outputIOIndex, INT polarity)
sets the active level of the flash
CameraGetImageBufferEx
CKSDK_API BYTE *__stdcall CameraGetImageBufferEx(HANDLE hCamera, stImageInfo *pImgInfo, UINT uTimes)
Gets a frame of image data. The image obtained by this interface is the processed format...
CameraGetCustomLut
CKSDK_API CameraSdkStatus __stdcall CameraGetCustomLut(HANDLE hCamera, INT iChannel, USHORT *pLut)
Get the custom LUT table currently in use.
CameraInitEx2
CKSDK_API CameraSdkStatus __stdcall CameraInitEx2(PHANDLE phCamera, const char *pFriendlyName)
Camera initialization. After the initialization is successful, you can call any other Camera related ...
CameraReleaseFrameHandle
CKSDK_API CameraSdkStatus __stdcall CameraReleaseFrameHandle(HANDLE hCamera, HANDLE hRawBuf)
release buffer obtained by CameraGetRawImageBuffer
CameraGetCurrentParameterGroup
CKSDK_API CameraSdkStatus __stdcall CameraGetCurrentParameterGroup(HANDLE hCamera, INT *piTeam)
Get the currently selected parameter group.
CameraSetDisplaySize
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplaySize(HANDLE hCamera, INT iWidth, INT iHeight)
Sets the size of the display control. Must be called CameraDisplayInit is initialized to call this fu...
_DisplayWindow
Display window parameters.
Definition: CKDeviceDef.h:1219
CameraSelectLutPreset
CKSDK_API CameraSdkStatus __stdcall CameraSelectLutPreset(HANDLE hCamera, INT iSel)
Select the LUT table in the preset LUT mode. Must use CameraSetLutMode first set the LUT mode to the ...
_FrameStatistic
Frame rate statistics.
Definition: CKDeviceDef.h:1198
CameraStopRecord
CKSDK_API CameraSdkStatus __stdcall CameraStopRecord(HANDLE hCamera)
end recording
CameraGetOutImageBuffer
CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageBuffer(HANDLE hCamera, stImageInfo *pImgInfo, BYTE *pRawBuf, BYTE *pImgBuf)
processes the obtained camera raw output image data, superimposes saturation, Color gain and correcti...
CameraInitEx4
CKSDK_API CameraSdkStatus __stdcall CameraInitEx4(PHANDLE phCamera, const char *pCameraSN, const tInitCameraParam *pstInitCameraParam)
Camera initialization. After the initialization is successful, you can call any other Camera related ...
CameraGetBlackLevel
CKSDK_API CameraSdkStatus __stdcall CameraGetBlackLevel(HANDLE hCamera, INT *piBlackLevel)
Gets the black level reference of the image, the default is 0.
_tDevEnumInfo
Enumeration information.
Definition: CKDeviceDef.h:1232
CameraUpgrade
CKSDK_API CameraSdkStatus __stdcall CameraUpgrade(HANDLE hCamera, const char *pFilePath, CAMERA_UPGRADE_PROC callback, LPVOID lpParam)
upgrade camera
CameraCustomizeResolution
CKSDK_API CameraSdkStatus __stdcall CameraCustomizeResolution(HANDLE hCamera, tSdkImageResolution *pImageCustom)
Opens the resolution custom panel and visually configures a custom resolution.
CameraGetTriggerDelayTime
CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerDelayTime(HANDLE hCamera, UINT *pDelayTimeUs)
Set how much time to take a photo after camera trigger.
CameraRequestTransferImage
CKSDK_API CameraSdkStatus __stdcall CameraRequestTransferImage(HANDLE hCamera)
request to transmit a frame of image buffered in the camera
CameraDrawText
CKSDK_API CameraSdkStatus __stdcall CameraDrawText(BYTE *pImgBuf, const stImageInfo *pImgInfo, char const *pFontFileName, UINT FontWidth, UINT FontHeight, char const *pText, INT Left, INT Top, UINT Width, UINT Height, UINT TextColor, UINT uFlags)
draws text in the input image data
CameraSetAeState
CKSDK_API CameraSdkStatus __stdcall CameraSetAeState(HANDLE hCamera, BOOL bAeState)
Sets the mode in which the camera is exposed. Automatic or manual.
CameraSetOutputIOPWM
CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOPWM(HANDLE hCamera, INT outputIOIndex, UINT cycle, UINT duty)
Sets the parameters of the PWM output. The number of programmable output IOs reserved by the camera i...
CameraGigeSetResend
CKSDK_API CameraSdkStatus __stdcall CameraGigeSetResend(HANDLE hCamera, BOOL bEnable, UINT nMaxResendPercent, UINT nResendTimeout)
Set the retransmission parameters of the Gige camera.
CameraSetTriggerFrameCount
CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerFrameCount(HANDLE hCamera, INT frameCount)
Sets how many pictures to take continuously when camera triggers.
CameraSetLutMode
CKSDK_API CameraSdkStatus __stdcall CameraSetLutMode(HANDLE hCamera, INT emLutMode)
Sets the camera&#39;s look-up table conversion mode LUT mode.
CameraPause
CKSDK_API CameraSdkStatus __stdcall CameraPause(HANDLE hCamera)
puts the SDK into pause mode and does not receive image data from the camera. It also sends a command...
CKDeviceDef.h
emSdkValueType
emSdkValueType
Set the type of parameter.
Definition: CKDeviceDef.h:520
CameraGetResolutionForSnap
CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionForSnap(HANDLE hCamera, tSdkImageResolution *pImageResolution)
Get the resolution in snap mode.
CameraGigeGetIp
CKSDK_API CameraSdkStatus __stdcall CameraGigeGetIp(const char *pCameraSN, tGigeNetworkInfo *pNetworkInfo)
Set the camera&#39;s network address by camera serial number. This interface only supports GIGE cameras...
LONG
long LONG
Definition: CKDeviceDef.h:19
CameraSetDisplayScaleRadio
CKSDK_API CameraSdkStatus __stdcall CameraSetDisplayScaleRadio(HANDLE hCamera, INT iRadio)
Sets the zoom ratio of the display. Only when the display mode is emSdkDisplayMode::DISPLAYMODE_REAL ...
CameraStartRecord
CKSDK_API CameraSdkStatus __stdcall CameraStartRecord(HANDLE hCamera, const char *pstrSavePath, INT iFormat, INT iBitrate, INT iFrameRate)
start recording
CameraSetBlackLevel
CKSDK_API CameraSdkStatus __stdcall CameraSetBlackLevel(HANDLE hCamera, INT iBlackLevel)
sets the black level reference of the image. The default value is 0.
CameraReboot
CKSDK_API CameraSdkStatus __stdcall CameraReboot(HANDLE hCamera)
reboot camera
BYTE
uint8_t BYTE
Definition: CKDeviceDef.h:18
CameraEnumerateDevice
CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDevice(INT *pDeviceNum)
enumerates devices and builds a list of devices. This function must be called to get information abou...
CameraGetCrossLine
CKSDK_API CameraSdkStatus __stdcall CameraGetCrossLine(HANDLE hCamera, INT iLine, INT *px, INT *py, UINT *puColor, BOOL *pbVisible)
Gets the status of the specified crosshair.
CameraGetLightFrequency
CKSDK_API CameraSdkStatus __stdcall CameraGetLightFrequency(HANDLE hCamera, INT *piFrequencySel)
When auto exposure is obtained, the frequency of the strobe is selected.
CameraSetImageTransferMode
CKSDK_API CameraSdkStatus __stdcall CameraSetImageTransferMode(HANDLE hCamera, INT transferMode)
CameraGetEnumIndexInfo
CKSDK_API CameraSdkStatus __stdcall CameraGetEnumIndexInfo(INT CameraIndex, tDevEnumInfo *pDevInfo)
Get information about the specified device.
CameraSetOutputIOState
CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOState(HANDLE hCamera, INT outputIOIndex, INT state)
Sets the level state of the specified IO. IO is the output type IO. The number of programmable output...
CameraSetIspOutFormat
CKSDK_API CameraSdkStatus __stdcall CameraSetIspOutFormat(HANDLE hCamera, INT iFormat)
Sets the output format of the image processing of the CameraImageProcess function, which supports CAMERA_MEDIA_TYPE_MONO CAMERA_MEDIA_TYPE_RGB8 CAMERA_MEDIA_TYPE_RGBA8 CAMERA_MEDIA_TYPE_BGR8 CAMERA_MEDIA_TYPE_BGRA8 Five types (defined in CameraDefine.h) correspond to 8-bit grayscale images and 24RGB, 32-bit RGB, 24-bit BGR, 32-bit BGR color images. The default output is CAMERA_MEDIA_TYPE_BGR8 format.
CameraGetContrastLut
CKSDK_API CameraSdkStatus __stdcall CameraGetContrastLut(HANDLE hCamera, INT *piContrast)
Get the contrast value in LUT dynamic generation mode. Please refer to the functional description of ...
CameraSetCorrectDeadPixel
CKSDK_API CameraSdkStatus __stdcall CameraSetCorrectDeadPixel(HANDLE hCamera, BOOL bEnable)
Set whether to enable dead pixel correction.
CAMERA_SNAP_PROC
void(__stdcall * CAMERA_SNAP_PROC)(HANDLE handle, BYTE *pFrameBuffer, stImageInfo *pFrameInfo, LPVOID lpParam)
Callback function definition for image capture.
Definition: CKCameraInterface.h:626
CameraGetParameterMode
CKSDK_API CameraSdkStatus __stdcall CameraGetParameterMode(HANDLE hCamera, INT *piMode)
Get the target object for parameter access.
CameraGetTriggerSignalType
CKSDK_API CameraSdkStatus __stdcall CameraGetTriggerSignalType(HANDLE hCamera, INT inputIOIndex, INT *pType)
Get hardware trigger signal type.
CameraSetCrossLine
CKSDK_API CameraSdkStatus __stdcall CameraSetCrossLine(HANDLE hCamera, INT iLine, INT x, INT y, UINT uColor, BOOL bVisible)
Sets the parameters for the specified crosshair.
_tInitCameraParam
When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera.
Definition: CKDeviceDef.h:646
__stdcall
#define __stdcall
Definition: CKCameraInterface.h:19
CameraCreateSettingPageEx
CKSDK_API CameraSdkStatus __stdcall CameraCreateSettingPageEx(HANDLE hCamera)
Creates a camera configuration window. Before creating, you must first call CameraSetActivePage to se...
CameraGetImageInfo
CKSDK_API BYTE *__stdcall CameraGetImageInfo(HANDLE hCamera, HANDLE hRawBuf, stImageInfo *pImgInfo)
Get current frame image information.
CameraGetCurResolution
CKSDK_API CameraSdkStatus __stdcall CameraGetCurResolution(HANDLE hCamera, tSdkImageResolution *pImageResolution)
Get the resolution of the current preview.
CameraSetParameterMode
CKSDK_API CameraSdkStatus __stdcall CameraSetParameterMode(HANDLE hCamera, INT iMode)
Sets the target object for parameter access.
CameraSetIntValue
CKSDK_API CameraSdkStatus __stdcall CameraSetIntValue(HANDLE hCamera, emSdkValueType type, INT value)
sets the shaping parameters, the parameter type is defined by emSdkValueType
CameraRequestTransferImageEx
CameraSdkStatus __stdcall CameraRequestTransferImageEx(HANDLE hCamera, int nCmd)
Request to transfer a frame of image in the camera cache, use nCmd to specify the location of the tra...
CameraSdkStatus
int CameraSdkStatus
Definition: CKCameraInterface.h:30
CameraGetResolution
CKSDK_API CameraSdkStatus __stdcall CameraGetResolution(HANDLE hCamera, INT *piResolutionIndex)
Get the resolution of the camera output image.
CameraGetOutImageSize
CKSDK_API CameraSdkStatus __stdcall CameraGetOutImageSize(HANDLE hCamera, DWORD *pWidth, DWORD *pHeight)
Gets the size of the output image.
CameraSetFrameSpeed
CKSDK_API CameraSdkStatus __stdcall CameraSetFrameSpeed(HANDLE hCamera, INT iFrameSpeed)
CameraGetMonochrome
CKSDK_API CameraSdkStatus __stdcall CameraGetMonochrome(HANDLE hCamera, BOOL *pbEnable)
Gets the enable status of the color conversion black and white function.
_tDevLoadInfo
Current mode and enumeration information for the device.
Definition: CKDeviceDef.h:1241
CameraGetAntiFlick
CKSDK_API CameraSdkStatus __stdcall CameraGetAntiFlick(HANDLE hCamera, BOOL *pbEnable)
Gets the anti-strobe function enabled state during auto exposure.
CameraSetCustomLut
CKSDK_API CameraSdkStatus __stdcall CameraSetCustomLut(HANDLE hCamera, INT iChannel, USHORT *pLut)
Sets a custom LUT table. Must use CameraSetLutMode first set the LUT mode to custom mode...
CameraSetMonochrome
CKSDK_API CameraSdkStatus __stdcall CameraSetMonochrome(HANDLE hCamera, BOOL bEnable)
Sets the color to black and white function enable.
CameraSetAeAnalogGainRange
CKSDK_API CameraSdkStatus __stdcall CameraSetAeAnalogGainRange(HANDLE hCamera, INT iMinAnalogGain, INT iMaxAnalogGain)
Sets the gain adjustment range of the auto exposure mode.
CameraGetOutputIOMode
CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOMode(HANDLE hCamera, INT outputIOIndex, INT *pMode)
Get the operating mode of the output IO. The number of reserved output IOs is determined by iOutputIo...
CameraGetFrameStatistic
CKSDK_API CameraSdkStatus __stdcall CameraGetFrameStatistic(HANDLE hCamera, FrameStatistic *psFrameStatistic)
Gets statistics on the frame rate received by the camera, including error frames and dropped frames...
CAMERA_UPGRADE_PROC
void(__stdcall * CAMERA_UPGRADE_PROC)(INT percent, LPVOID lpParam)
Callback function definition for image capture.
Definition: CKCameraInterface.h:3786
CameraGetStrobeMode
CKSDK_API CameraSdkStatus __stdcall CameraGetStrobeMode(HANDLE hCamera, INT outputIOIndex, INT *pMode)
Get flash mode.
CameraGetImageTimestamp
CKSDK_API CameraSdkStatus __stdcall CameraGetImageTimestamp(HANDLE hCamera, HANDLE hRawBuf, UINT64 *puTimestamp)
Gets the timestamp of the current frame in microseconds.
CameraSetGain
CKSDK_API CameraSdkStatus __stdcall CameraSetGain(HANDLE hCamera, WORD DGainR, WORD DGainG, WORD DGainB)
Sets the digital gain of the image. Setting range by CameraGetCapability The obtained sRgbGainRange m...
_tGigeNetworkInfo
Network information of GigE camera.
Definition: CKDeviceDef.h:1250
PHANDLE
HANDLE * PHANDLE
Definition: CKDeviceDef.h:21
CameraSetActivePage
CKSDK_API CameraSdkStatus __stdcall CameraSetActivePage(HANDLE hCamera, LONG lActivePage, INT iDefault)
Sets the activation page of the camera configuration window. The camera configuration window has mult...
CameraGetOutputIOPWM
CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOPWM(HANDLE hCamera, INT outputIOIndex, INT *pCycle, INT *pDuty)
Get the parameters of the PWM output. The number of programmable output IOs reserved by the camera is...
CameraGigeGetTransPacketSize
CKSDK_API CameraSdkStatus __stdcall CameraGigeGetTransPacketSize(HANDLE hCamera, UINT *pPacketSize)
Set the camera&#39;s network address by the camera&#39;s serial number.
_tLscCalibParam
LSC calibration parameter.
Definition: CKDeviceDef.h:1273
CameraSetAnalogGain
CKSDK_API CameraSdkStatus __stdcall CameraSetAnalogGain(HANDLE hCamera, UINT uAnalogGain)
Sets the camera&#39;s image analog gain value. Multiply this value by CameraGetCapability sExposeDesc...
CameraLoadUserData
CKSDK_API CameraSdkStatus __stdcall CameraLoadUserData(HANDLE hCamera, UINT uStartAddr, BYTE *pbData, INT iLen)
reads user-defined data from the camera&#39;s non-volatile memory. The maximum length of the user data ar...
CameraSetTriggerSignalType
CKSDK_API CameraSdkStatus __stdcall CameraSetTriggerSignalType(HANDLE hCamera, INT inputIOIndex, INT type)
sets the hardware trigger signal type
CameraSnapToBuffer
CKSDK_API CameraSdkStatus __stdcall CameraSnapToBuffer(HANDLE hCamera, PHANDLE phBuf, stImageInfo *pImgInfo, BYTE **ppImgBuf, UINT uWaitTimeMs)
Capture an image into the buffer. The camera will enter the capture mode, and Automatically switch to...
CameraShowSettingPage
CKSDK_API CameraSdkStatus __stdcall CameraShowSettingPage(HANDLE hCamera, BOOL bShow)
Sets the camera property configuration window display status. You must call CameraCreateSettingPageEx...
CameraGetWbWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraGetWbWinVisible(HANDLE hCamera, BOOL *pDisplayEn)
Gets the white balance reference window display enable status.
CameraGetInputIOState
CKSDK_API CameraSdkStatus __stdcall CameraGetInputIOState(HANDLE hCamera, INT inputIOIndex, INT *pState)
Sets the level state of the specified IO. IO is the input type IO. The number of programmable output ...
CameraSetOutputIOMode
CKSDK_API CameraSdkStatus __stdcall CameraSetOutputIOMode(HANDLE hCamera, INT outputIOIndex, INT mode)
Sets the operating mode of the output IO. The number of reserved output IOs is determined by iOutputI...
CameraGetCapability
CKSDK_API CameraSdkStatus __stdcall CameraGetCapability(HANDLE hCamera, tSdkCameraCapbility *pCameraCap)
Get the camera&#39;s characterization structure. The structure contains a camera Range information for va...
CameraSetAeExposureRange
CKSDK_API CameraSdkStatus __stdcall CameraSetAeExposureRange(HANDLE hCamera, double dMinExposureTime, double dMaxExposureTime)
Sets the exposure time adjustment range of the auto exposure mode.
CameraGetSensorOutPixelFormat
CKSDK_API CameraSdkStatus __stdcall CameraGetSensorOutPixelFormat(HANDLE hCamera, UINT *piFormat)
Get the format of the raw image data.
_tSdkImageResolution
Camera resolution description.
Definition: CKDeviceDef.h:833
CameraSetStrobePulseWidth
CKSDK_API CameraSdkStatus __stdcall CameraSetStrobePulseWidth(HANDLE hCamera, INT outputIOIndex, UINT pulseWidth)
sets the pulse width of the flash
CAMERA_DISPLAY_PROC
void(__stdcall * CAMERA_DISPLAY_PROC)(HANDLE handle, HDC hdc, DisplayWindow *pDisplayWindow, LPVOID lpParam)
Image display callback function.
Definition: CKCameraInterface.h:997
HWND
void * HWND
Definition: CKDeviceDef.h:27
CameraWriteSN
CKSDK_API CameraSdkStatus __stdcall CameraWriteSN(HANDLE hCamera, BYTE *pbySN, INT iLevel)
Sets the serial number of the camera. Our company&#39;s camera serial number is divided into 3 levels...
CameraPushOneFrame
CKSDK_API CameraSdkStatus __stdcall CameraPushOneFrame(HANDLE hCamera, const BYTE *pFrameBuffer, const stImageInfo *pImgInfo)
Write a frame of image data to the video file.
CameraReadSN
CKSDK_API CameraSdkStatus __stdcall CameraReadSN(HANDLE hCamera, BYTE *pbySN, INT iLevel)
Reads the serial number of the camera&#39;s specified level. Please refer to the definition of serial num...
CameraGetIspOutFormat
CKSDK_API CameraSdkStatus __stdcall CameraGetIspOutFormat(HANDLE hCamera, INT *piFormat)
Get the output format of CameraGetOutImageBuffer function image processing, support CAMERA_MEDIA_TYPE...
CameraSetWbWindow
CKSDK_API CameraSdkStatus __stdcall CameraSetWbWindow(HANDLE hCamera, DWORD dwLeft, DWORD dwTop, DWORD dwWidth, DWORD dwHeight)
Sets the position of the white balance reference window.
CameraSetWbWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraSetWbWinVisible(HANDLE hCamera, BOOL bDisplayEn)
Sets the white balance reference window display enable.
CameraGetCurDevInfo
CKSDK_API CameraSdkStatus __stdcall CameraGetCurDevInfo(HANDLE hCamera, tDevLoadInfo *pDevInfo)
Get enumerated information for the specified device.
CameraSetCallbackFunction
CKSDK_API CameraSdkStatus __stdcall CameraSetCallbackFunction(HANDLE hCamera, CAMERA_SNAP_PROC pCallBack, LPVOID lpParam, CAMERA_SNAP_PROC *pCallbackOld)
Sets the callback function for image capture. When a new image data frame is captured, the callback function pointed to by pCallBack is called.
CameraGetLutMode
CKSDK_API CameraSdkStatus __stdcall CameraGetLutMode(HANDLE hCamera, INT *pemLutMode)
Gets the camera&#39;s look-up table conversion mode LUT mode.
CameraGetAeState
CKSDK_API CameraSdkStatus __stdcall CameraGetAeState(HANDLE hCamera, BOOL *pAeState)
Gets the camera&#39;s current exposure mode.
CAMERA_EXCEPTION_PROC
void(__stdcall * CAMERA_EXCEPTION_PROC)(HANDLE hCamera, emSdkExceptionType nMsgType, LPVOID lpParam)
Exception callback function definition.
Definition: CKCameraInterface.h:286
CameraGetSaturation
CKSDK_API CameraSdkStatus __stdcall CameraGetSaturation(HANDLE hCamera, INT *piSaturation)
Gets the saturation of image processing.
INT
int32_t INT
Definition: CKDeviceDef.h:13
CameraGetWbWindow
CKSDK_API CameraSdkStatus __stdcall CameraGetWbWindow(HANDLE hCamera, DWORD *pdwLeft, DWORD *pdwTop, DWORD *pdwWidth, DWORD *pdwHeight)
Gets the position of the white balance reference window.
CameraGetGain
CKSDK_API CameraSdkStatus __stdcall CameraGetGain(HANDLE hCamera, WORD *pDGainR, WORD *pDGainG, WORD *pDGainB)
Gets the digital gain of image processing. See CameraSetGain for details. The functional description ...
CameraGigeGetPacketDelayTime
CKSDK_API CameraSdkStatus __stdcall CameraGigeGetPacketDelayTime(HANDLE hCamera, UINT *pDelayUs)
Set the delay interval for GVSP packets of GigE camera.
CameraSetAeWinVisible
CKSDK_API CameraSdkStatus __stdcall CameraSetAeWinVisible(HANDLE hCamera, BOOL bDisplayEn)
Sets the display status of the auto exposure reference window. When setting the window status For dis...
CameraSetContrastLut
CKSDK_API CameraSdkStatus __stdcall CameraSetContrastLut(HANDLE hCamera, INT iContrast)
Set the contrast value in LUT dynamic generation mode. The set value will Save it inside the SDK righ...
CameraSetWbMode
CKSDK_API CameraSdkStatus __stdcall CameraSetWbMode(HANDLE hCamera, BOOL bAuto)
Sets the camera white balance mode. Divided into manual and automatic two ways.
CameraRegisterExceptionCallback
CKSDK_API CameraSdkStatus __stdcall CameraRegisterExceptionCallback(HANDLE hCamera, CAMERA_EXCEPTION_PROC pExceptionCallback, LPVOID pUser)
CameraGetAeExposureRange
CKSDK_API CameraSdkStatus __stdcall CameraGetAeExposureRange(HANDLE hCamera, double *pdMinExposureTime, double *pdMaxExposureTime)
Get the exposure time adjustment range of the auto exposure mode.
CameraSetGamma
CKSDK_API CameraSdkStatus __stdcall CameraSetGamma(HANDLE hCamera, INT iGamma)
Sets the gamma value in the LUT dynamic generation mode. The set value will Saved inside the SDK righ...
_stImageInfo
Frame header information.
Definition: CKDeviceDef.h:1179
CameraLscCorrect
CKSDK_API CameraSdkStatus __stdcall CameraLscCorrect(HANDLE hCamera, tLscCorrectParam *pLscCorrectParam)
LSC correction.
CameraDisplayInit
CKSDK_API CameraSdkStatus __stdcall CameraDisplayInit(HANDLE hCamera, HWND hWndDisplay)
Initializes the display module inside the SDK. Call CameraDisplay This function must be called before...
CameraGetGamma
CKSDK_API CameraSdkStatus __stdcall CameraGetGamma(HANDLE hCamera, INT *piGamma)
Gets the gamma value in LUT dynamic generation mode. Please refer to CameraSetGamma A functional desc...
CameraDisplay
CKSDK_API CameraSdkStatus __stdcall CameraDisplay(HANDLE hCamera, BYTE *pImgBuf, stImageInfo *pImgInfo)
displays the image. You must call CameraDisplayInit to initialize this function.
CameraEnumerateDeviceFromOpenedDevList
CKSDK_API CameraSdkStatus __stdcall CameraEnumerateDeviceFromOpenedDevList(int *pDeviceNum, int DevNum, int fds[], int pids[], char *paths[])
CameraGetResolutionEx
CKSDK_API CameraSdkStatus __stdcall CameraGetResolutionEx(HANDLE hCamera, INT iResolution, tSdkImageResolution *pImageResolution)
Get the resolution of the index number.
_tLscCorrectParam
LSC correction parameter.
Definition: CKDeviceDef.h:1309
CameraGetAnalogGain
CKSDK_API CameraSdkStatus __stdcall CameraGetAnalogGain(HANDLE hCamera, UINT *puAnalogGain)
Gets the analog gain value of the image signal. See CameraSetAnalogGain for details.
CameraGetOutputIOState
CKSDK_API CameraSdkStatus __stdcall CameraGetOutputIOState(HANDLE hCamera, INT outputIOIndex, INT *pState)
Get the level state of the specified IO. IO is the output type IO. The number of programmable output ...
CameraGetAeTarget
CKSDK_API CameraSdkStatus __stdcall CameraGetAeTarget(HANDLE hCamera, WORD *pAeTarget)
Gets the brightness target value for auto exposure.
CameraLoadParameter
CKSDK_API CameraSdkStatus __stdcall CameraLoadParameter(HANDLE hCamera, INT iTeam)
Loads the parameters of the specified group into the camera.
CameraSetContrast
CKSDK_API CameraSdkStatus __stdcall CameraSetContrast(HANDLE hCamera, INT iContrast)
sets the contrast of image processing
CameraGetFrameSpeed
CKSDK_API CameraSdkStatus __stdcall CameraGetFrameSpeed(HANDLE hCamera, INT *piFrameSpeed)
Gets the frame rate selection index number of the camera output image. Specific usage reference ...
CameraGigeSetPacketDelayTime
CKSDK_API CameraSdkStatus __stdcall CameraGigeSetPacketDelayTime(HANDLE hCamera, UINT delayUs)
Get the delay interval for GVSP packets of GigE camera.


CKCameraAPI: CKDeviceDef.h Source File

CKDeviceDef.h
Go to the documentation of this file.
1 #ifndef __CK_DEVICE_DEF_H__
2 #define __CK_DEVICE_DEF_H__
3
4 #include <stdint.h>
5
6 #ifdef _WIN32
7
8 #include <windows.h>
9
10 #else
11
12 typedef uint32_t DWORD;
13 typedef int32_t INT;
14 typedef uint32_t UINT;
15 typedef uint16_t WORD;
16 typedef uint64_t UINT64;
17 typedef int BOOL;
18 typedef uint8_t BYTE;
19 typedef long LONG;
20 typedef void * HANDLE;
21 typedef HANDLE * PHANDLE;
22 typedef void * LPVOID;
23 typedef void * HDC;
24 typedef uint16_t WCHAR;
25 typedef unsigned short USHORT;
26 typedef char TCHAR;
27 typedef void * HWND;
28
29 #ifndef FALSE
30 #define FALSE 0
31 #endif
32
33 #ifndef TRUE
34 #define TRUE 1
35 #endif
36
37 #pragma pack(push, 1)
38 typedef struct tagRECT
39 {
40 LONG left;
41 LONG top;
42 LONG right;
43 LONG bottom;
44
45 }RECT;
46 #pragma pack(pop)
47
48 #endif
49
50
51
52 #define CROSSLINE_MAX_NUM 9
53
60 #define CAMERA_STATUS_SUCCESS 0
61
62 #define CAMERA_STATUS_FAILED -1
63
64 #define CAMERA_STATUS_INTERNAL_ERROR -2
65
66 #define CAMERA_STATUS_UNKNOW -3
67
68 #define CAMERA_STATUS_NOT_SUPPORTED -4
69
70 #define CAMERA_STATUS_NOT_INITIALIZED -5
71
72 #define CAMERA_STATUS_PARAMETER_INVALID -6
73
74 #define CAMERA_STATUS_PARAMETER_OUT_OF_BOUND -7
75
76 #define CAMERA_STATUS_UNENABLED -8
77
78 #define CAMERA_STATUS_USER_CANCEL -9
79
80 #define CAMERA_STATUS_PATH_NOT_FOUND -10
81
82 #define CAMERA_STATUS_SIZE_DISMATCH -11
83
84 #define CAMERA_STATUS_TIME_OUT -12
85
86 #define CAMERA_STATUS_IO_ERROR -13
87
88 #define CAMERA_STATUS_COMM_ERROR -14
89
90 #define CAMERA_STATUS_BUS_ERROR -15
91
92 #define CAMERA_STATUS_NO_DEVICE_FOUND -16
93
94 #define CAMERA_STATUS_NO_LOGIC_DEVICE_FOUND -17
95
96 #define CAMERA_STATUS_DEVICE_IS_OPENED -18
97
98 #define CAMERA_STATUS_DEVICE_IS_CLOSED -19
99
100 #define CAMERA_STATUS_DEVICE_VEDIO_CLOSED -20
101
102 #define CAMERA_STATUS_NO_MEMORY -21
103
104 #define CAMERA_STATUS_FILE_CREATE_FAILED -22
105
106 #define CAMERA_STATUS_FILE_INVALID -23
107
108 #define CAMERA_STATUS_WRITE_PROTECTED -24
109
110 #define CAMERA_STATUS_GRAB_FAILED -25
111
112 #define CAMERA_STATUS_LOST_DATA -26
113
114 #define CAMERA_STATUS_EOF_ERROR -27
115
116 #define CAMERA_STATUS_BUSY -28
117
118 #define CAMERA_STATUS_WAIT -29
119
120 #define CAMERA_STATUS_IN_PROCESS -30
121
122 #define CAMERA_STATUS_IIC_ERROR -31
123
124 #define CAMERA_STATUS_SPI_ERROR -32
125
126 #define CAMERA_STATUS_USB_CONTROL_ERROR -33
127
128 #define CAMERA_STATUS_USB_BULK_ERROR -34
129
130 #define CAMERA_STATUS_SOCKET_INIT_ERROR -35
131
132 #define CAMERA_STATUS_GIGE_FILTER_INIT_ERROR -36
133
134 #define CAMERA_STATUS_NET_SEND_ERROR -37
135
136 #define CAMERA_STATUS_DEVICE_LOST -38
137
138 #define CAMERA_STATUS_DATA_RECV_LESS -39
139
140 #define CAMERA_STATUS_FUNCTION_LOAD_FAILED -40
141
142 #define CAMERA_STATUS_CRITICAL_FILE_LOST -41
143
144 #define CAMERA_STATUS_SENSOR_ID_DISMATCH -42
145
146 #define CAMERA_STATUS_OUT_OF_RANGE -43
147
148 #define CAMERA_STATUS_REGISTRY_ERROR -44
149
150 #define CAMERA_STATUS_ACCESS_DENY -45
151
152 #define CAMERA_STATUS_CAMERA_NEED_RESET -46
153
154 #define CAMERA_STATUS_ISP_MOUDLE_NOT_INITIALIZED -47
155
156 #define CAMERA_STATUS_ISP_DATA_CRC_ERROR -48
157
158 #define CAMERA_STATUS_MV_TEST_FAILED -49
159
160 #define CAMERA_STATUS_WAIT_TRIGGER -50
161
162 #define CAMERA_STATUS_EEPROM_UPDATA -51
163
164 #define CAMERA_STATUS_OPEN_DEVICE_ERROR -52
165
166 #define CAMERA_STATUS_OPEN_STREAM_ERROR -53
167
168 #define CAMERA_STATUS_READ_ERROR -54
169
170 #define CAMERA_STATUS_WRITE_ERROR -55
171
172 #define CAMERA_STATUS_NO_OPEN_DEVICE -56
173
174 #define CAMERA_STATUS_UNKNOW_SENSOR -57
175
176 #define CAMERA_STATUS_NO_WRITE_EEPROM -58
177
178 #define CMAERA_STATUS_FPGA_CFG_ERROR -59
179
188 typedef enum
189 {
190 DEVICE_TYPE_UNKNOW = 0,
191 DEVICE_TYPE_USB20 = 0x1201,
192 DEVICE_TYPE_USB30 = 0x1301,
193 DEVICE_TYPE_GIGE = 0x2001,
194 }emDeviceType;
195
197 typedef enum
198 {
200 IMAGEOUT_MODE_512X384 = 0,
202 IMAGEOUT_MODE_640X480 = 1,
204 IMAGEOUT_MODE_800X600 = 2,
206 IMAGEOUT_MODE_1024X768 = 3,
208 IMAGEOUT_MODE_1280X720 = 4,
210 IMAGEOUT_MODE_1280X960 = 5,
212 IMAGEOUT_MODE_1920X1280 = 6,
214 IMAGEOUT_MODE_2048X1536 = 7,
216 IMAGEOUT_MODE_320X240 = 8,
218 IMAGEOUT_MODE_1280X1024 = 9,
220 IMAGEOUT_MODE_1600X1200 = 10,
222 IMAGEOUT_MODE_2592X1944 = 11,
224 IMAGEOUT_MODE_752X480 = 12,
226 IMAGEOUT_MODE_768X576 = 13,
228 IMAGEOUT_MODE_3664X2748 = 14,
230 IMAGEOUT_MODE_1920X1080 = 15,
232 IMAGEOUT_MODE_2304X1296 = 16,
234 IMAGEOUT_MODE_2304X1728 = 17,
236 IMAGEOUT_MODE_4608X3456 = 18,
238 IMAGEOUT_MODE_640X360 = 19,
240 IMAGEOUT_MODE_3072X2048 = 20,
242 IMAGEOUT_MODE_1920X1200 = 21,
244 IMAGEOUT_MODE_5472X3648 = 22,
246 IMAGEOUT_MODE_2448X2048 = 23,
248 IMAGEOUT_MODE_4000X3000 = 24,
250 IMAGEOUT_MODE_3008X3008 = 25,
252 IMAGEOUT_MODE_4096X2160 = 26,
254 IMAGEOUT_MODE_2736X1824 = 27,
256 IMAGEOUT_MODE_4144X2822 = 28,
258 IMAGEOUT_MODE_720X540 = 29,
260 IMAGEOUT_MODE_1440X1080 = 30,
262 IMAGEOUT_MODE_1280X800 = 31,
264 IMAGEOUT_MODE_1296X972 = 32,
266 IMAGEOUT_MODE_960x600 = 33,
268 IMAGEOUT_MODE_2848X2848 = 34,
270 IMAGEOUT_MODE_1424x1424 = 35,
272 IMAGEOUT_MODE_640X512 = 36,
274 IMAGEOUT_MODE_NUM,
275
277 IMAGEOUT_MODE_CUSTOM = 0XFF,
278 }emResolutionMode;
279
281 typedef enum
282 {
284 FRAME_SPEED_LOW = 0,
286 FRAME_SPEED_MIDDLE,
288 FRAME_SPEED_HIGH,
289 }emFrameMode;
290
292 typedef enum
293 {
295 FREQ_FLICKER_MODE_NULL = 0,
297 FREQ_FLICKER_MODE_50HZ,
299 FREQ_FLICKER_MODE_60HZ,
300 }emFlickerMode;
301
303 typedef enum
304 {
306 FILE_JPG = 1,
308 FILE_BMP = 2, // BMP 24bit
310 FILE_RAW = 4,
312 FILE_PNG = 8,
314 FILE_BMP_8BIT = 16,
316 FILE_PNG_8BIT = 32,
318 FILE_RAW_16BIT = 64
319 }emFileType;
320
322 typedef enum
323 {
325 STATISTICS_AVG = 0,
327 STATISTICS_HIST,
329 STATISTICS_WINDOW,
331 STATISTICS_REFER_WINDOW,
332 }emStatisticsMode;
333
335 typedef enum
336 {
338 PARAM_MODE_BY_MODEL = 0,
340 PARAM_MODE_BY_NAME,
342 PARAM_MODE_BY_SN,
344 PARAM_MODE_IN_DEVICE,
345 }emSdkParameterMode;
346
348 typedef enum
349 {
350 PARAMETER_TEAM_A = 0,
351 PARAMETER_TEAM_B = 1,
352 PARAMETER_TEAM_C = 2,
353 PARAMETER_TEAM_D = 3,
354 PARAMETER_TEAM_DEFAULT = 0xff,
355 }emSdkParameterTeam;
356
358 typedef enum
359 {
361 TRIGGER_MODE_CONTINUOUS = 0,
363 TRIGGER_MODE_SOFT,
365 TRIGGER_MODE_HARD,
366 }emTriggerMode;
367
369 typedef enum
370 {
373 STROBE_SYNC_WITH_TRIG_AUTO = 0,
376 STROBE_SYNC_WITH_TRIG_MANUAL,
377 }emStrobeControl;
378
380 typedef enum
381 {
383 EXT_TRIG_LEADING_EDGE = 0,
385 EXT_TRIG_TRAILING_EDGE,
387 EXT_TRIG_HIGH_LEVEL,
389 EXT_TRIG_LOW_LEVEL,
391 EXT_TRIG_DOUBLE_EDGE,
392 }emExtTrigSignal;
393
395 typedef enum
396 {
398 MIRROR_MODE_H = 0,
400 MIRROR_MODE_V = 1,
401 }emMirrorMode;
402
404 typedef enum
405 {
407 DISPLAYMODE_SCALE = 0,
409 DISPLAYMODE_REAL,
410 }emSdkDisplayMode;
411
413 typedef enum
414 {
416 AE_EXP_MODE = 0,
418 AE_FRAME_MODE,
419 }emAeExpMode;
420
422 typedef enum
423 {
425 SETTING_PAGE_DEVINFO = 0x01,
427 SETTING_PAGE_IMG_SETTING = 0x02,
429 SETTING_PAGE_EXP_SETTING = 0x04,
431 SETTING_PAGE_AWB_SETTING = 0x08,
433 SETTING_PAGE_CROSS_LINE = 0x10,
435 SETTING_PAGE_OUT_SETTING = 0x20,
437 SETTING_PAGE_REL_SETTING = 0x40,
439 SETTING_PAGE_GAMMA_SETTING = 0x80,
441 SETTING_PAGE_GIGE_SETTING = 0x100,
443 SETTING_PAGE_SPECIAL_SETTING = 0x200,
445 SETTING_PAGE_ALL = 0xFFFFFF,
446 }emSettingPage;
447
448
449
451 typedef enum
452 {
454 LUT_CHANNEL_ALL = 0,
456 LUT_CHANNEL_RED,
458 LUT_CHANNEL_GREEN,
460 LUT_CHANNEL_BLUE,
461 }emSdkLutChannel;
462
464 typedef enum
465 {
467 GAMMA_DYNAMIC_MODE = 0,
469 GAMMA_PRESET_MODE,
471 GAMMA_USER_MODE,
472 }emSdkLutMode;
473
475 typedef enum
476 {
478 IOMODE_STROBE_OUTPUT = 0,
480 IOMODE_GP_OUTPUT,
482 IOMODE_PWM_OUTPUT,
483 }emSdkOutputIOMode;
484
486 typedef enum
487 {
489 IOMODE_TRIG_INPUT = 0,
491 IOMODE_GP_INPUT,
492 }emSdkInputIOMode;
493
495 typedef enum
496 {
498 TRANSFER_NEWEST_IMAGE = 0,
500 TRANSFER_OLDEST_IMAGE = 1,
503 TRANSFER_IMAGE_ON_PASSIVE_MODE = 2,
506 TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE = 3,
507 }emImageTransferMode;
508
509 typedef enum
510 {
512 REQUEST_TRANSFER_CURRENT_FRAME = 0,
514 REQUEST_TRANSFER_NEXT_FRAME = 1,
516 REQUEST_TRANSFER_LATEST_FRAME = 2,
517 }emRequestTransferCmd;
518
520 typedef enum emSdkValueType
521 {
524 IMAGE_CHANNEL_MASK = 0,
527 LED_LIGHT,
529 ENABLE_WDR,
531 CONTROL_FOCUS_VALUE,
533 CONTROL_FOCUS_MIN_VALUE,
535 CONTROL_FOCUS_MAX_VALUE,
537 CONTROL_FOCUS_DEFAULT_VALUE,
539 IS_SUPPORT_CONTROL_FOCUS,
541 IMAGE_CHANNEL_NUM,
543 FRAME_OUTPUT_QUEUE_SIZE,
545 FIND_ME,
546 }emSdkValueType;
547
548 typedef enum emSdkExceptionType
549 {
550 EXCEPTION_DEV_DISCONNECT = 0,
551 EXCEPTION_DEV_RECONNECT,
552 EXCEPTION_VERSION_CHECK,
553 }emSdkExceptionType;
554
560 #define CAMERA_MEDIA_TYPE_MONO 0x01000000
561 #define CAMERA_MEDIA_TYPE_RGB 0x02000000
562 #define CAMERA_MEDIA_TYPE_COLOR 0x02000000
563 #define CAMERA_MEDIA_TYPE_OCCUPY1BIT 0x00010000
564 #define CAMERA_MEDIA_TYPE_OCCUPY2BIT 0x00020000
565 #define CAMERA_MEDIA_TYPE_OCCUPY4BIT 0x00040000
566 #define CAMERA_MEDIA_TYPE_OCCUPY8BIT 0x00080000
567 #define CAMERA_MEDIA_TYPE_OCCUPY10BIT 0x000A0000
568 #define CAMERA_MEDIA_TYPE_OCCUPY12BIT 0x000C0000
569 #define CAMERA_MEDIA_TYPE_OCCUPY16BIT 0x00100000
570 #define CAMERA_MEDIA_TYPE_OCCUPY24BIT 0x00180000
571 #define CAMERA_MEDIA_TYPE_OCCUPY32BIT 0x00200000
572
573 #define CAMERA_FORMAT_BAYGR8 0x00000008
574 #define CAMERA_FORMAT_BAYGR12 0x00000010
575 #define CAMERA_FORMAT_RGB 0x00000014
576 #define CAMERA_FORMAT_BGR 0x00000015
577 #define CAMERA_FORMAT_MONO 0x00000000
578
579
580 #define CAMERA_MEDIA_TYPE_COLOR_MASK 0xFF000000
581 #define CAMERA_MEDIA_TYPE_EFFECTIVE_PIXEL_SIZE_MASK 0x00FF0000
582 #define CAMERA_MEDIA_TYPE_ID_MASK 0x0000FFFF
583 #define CAMERA_MEDIA_TYPE_MEDIA_FORMAT 0x000000FF
584 /*Bayer */
585 #define CAMERA_MEDIA_TYPE_BAYGR8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0008)
586 #define CAMERA_MEDIA_TYPE_BAYRG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0009)
587 #define CAMERA_MEDIA_TYPE_BAYGB8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000A)
588 #define CAMERA_MEDIA_TYPE_BAYBG8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x000B)
589
590 #define CAMERA_MEDIA_TYPE_BAYGR10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000C)
591 #define CAMERA_MEDIA_TYPE_BAYRG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000D)
592 #define CAMERA_MEDIA_TYPE_BAYGB10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000E)
593 #define CAMERA_MEDIA_TYPE_BAYBG10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x000F)
594
595 #define CAMERA_MEDIA_TYPE_BAYGR12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0010)
596 #define CAMERA_MEDIA_TYPE_BAYRG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0011)
597 #define CAMERA_MEDIA_TYPE_BAYGB12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0012)
598 #define CAMERA_MEDIA_TYPE_BAYBG12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0013)
599
600 #define CAMERA_MEDIA_TYPE_BAYGR10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0026)
601 #define CAMERA_MEDIA_TYPE_BAYRG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0027)
602 #define CAMERA_MEDIA_TYPE_BAYGB10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0028)
603 #define CAMERA_MEDIA_TYPE_BAYBG10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0029)
604
605 #define CAMERA_MEDIA_TYPE_BAYGR12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002A)
606 #define CAMERA_MEDIA_TYPE_BAYRG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002B)
607 #define CAMERA_MEDIA_TYPE_BAYGB12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002C)
608 #define CAMERA_MEDIA_TYPE_BAYBG12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x002D)
609
610 #define CAMERA_MEDIA_TYPE_BAYGR16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002E)
611 #define CAMERA_MEDIA_TYPE_BAYRG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x002F)
612 #define CAMERA_MEDIA_TYPE_BAYGB16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0030)
613 #define CAMERA_MEDIA_TYPE_BAYBG16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0031)
614
615 /*RGB */
616 #define CAMERA_MEDIA_TYPE_RGB8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_RGB)
617 #define CAMERA_MEDIA_TYPE_BGR8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | CAMERA_FORMAT_BGR)
618 #define CAMERA_MEDIA_TYPE_RGBA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_RGB)
619 #define CAMERA_MEDIA_TYPE_BGRA8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY32BIT | CAMERA_FORMAT_BGR)
620
621 /*YUV and YCbCr*/
622 #define CAMERA_MEDIA_TYPE_YUV411_8_UYYVYY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x001E)
623 #define CAMERA_MEDIA_TYPE_YUV422_8_UYVY (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x001F)
624 #define CAMERA_MEDIA_TYPE_YUV422_8 (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0032)
625 #define CAMERA_MEDIA_TYPE_YUV8_UYV (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x0020)
626 #define CAMERA_MEDIA_TYPE_YCBCR8_CBYCR (CAMERA_MEDIA_TYPE_COLOR | CAMERA_MEDIA_TYPE_OCCUPY24BIT | 0x003A)
627
628 /*MONO*/
629 #define CAMERA_MEDIA_TYPE_MONO8 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0000)
630 #define CAMERA_MEDIA_TYPE_MONO8_SIGNED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY8BIT | 0x0002)
631 #define CAMERA_MEDIA_TYPE_MONO10 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0003)
632 #define CAMERA_MEDIA_TYPE_MONO10_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0004)
633 #define CAMERA_MEDIA_TYPE_MONO12 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0005)
634 #define CAMERA_MEDIA_TYPE_MONO12_PACKED (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY12BIT | 0x0006)
635 #define CAMERA_MEDIA_TYPE_MONO14 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0025)
636 #define CAMERA_MEDIA_TYPE_MONO16 (CAMERA_MEDIA_TYPE_MONO | CAMERA_MEDIA_TYPE_OCCUPY16BIT | 0x0007)
637
641 #pragma pack(push, 8)
642
646 typedef struct _tInitCameraParam
647 {
649 int nFrameSpeed;
650 /* @brief @~chinese 图像传输模式 @link #emImageTransferMode @endlink
651 @~english Image Transfer Mode @link #emImageTransferMode @endlink */
652 int nImageTransferMode;
653 /* @brief @~chinese 原始图像数据的格式 @~english The format of the raw image data */
654 int nSensorOutPixelFormat;
655 /* @brief @~chinese 触发模式 @~english Trigger mode */
656 int nTriggerMode;
657 /* @brief @~chinese GIGE传输包大小 @~english GigE camera gvsp transfer packet size */
658 int nGigeTransPacketSize;
659 /* @brief @~chinese 多通道相机输出的掩码 @~english The mask of the multichannel camera output */
660 int nImageChannelMask;
661 /* @brief @~chinese 从相机接收图像缓存帧的队列大小 @~english Size of the queue that receives image frames buffer from the camera */
662 int nOutputFrameQueueSize;
663 /* @brief @~chinese 相机的心跳包间隔时间，单位毫秒 @~english Heartbeat timeout of camera, unit is millisecond */
664 int nHeartbeatTimeout;
665 /* @brief @~chinese 保留字节 @~english reverse */
666 int nRes[8];
667 }tInitCameraParam;
668
669
671 typedef struct _tIspAe
672 {
674 int bAutoExposure;
675 uint32_t res1;
677 double ExposureTime;
679 uint32_t AnalogGain;
681 uint32_t AeTarget;
683 int AeMode;
684 uint32_t res2;
686 double fMinExposureTime;
688 double fMaxExposureTime;
690 int iMinAnalogGain;
692 int iMaxAnalogGain;
694 int bAntiFlick;
696 uint32_t FrequencySel;
698 int Left;
700 int Top;
702 int Width;
704 int Height;
705 }tIspAe;
706
708 typedef struct _tIspWb
709 {
711 int bAutoWb;
713 uint32_t DGainR;
715 uint32_t DGainG;
717 uint32_t DGainB;
719 int Left;
721 int Top;
723 int Width;
725 int Height;
727 int CCM[9];
728 }tIspWb;
729
731 typedef struct _tIspGamma
732 {
733 uint32_t Mode;
735 uint32_t Gamma;
737 uint32_t GammaContrast;
738 uint32_t PresetSel;
739 int rev[5]; //保留参数
740 }tIspGamma;
741
743 typedef struct _tDevLoadMode
744 {
746 tIspAe sIspAe;
748 tIspWb sIspWb;
750 uint32_t TriggerMode;
752 uint32_t ResolutionMode;
754 uint32_t MediaTypeMode;
756 uint32_t FrameSpeedMode;
758 uint32_t Sharpness;
760 uint32_t Saturation;
762 uint32_t Contrast;
764 tIspGamma sIspGamma;
766 uint32_t ParameterMode;
768 uint32_t ParameterTeam;
770 uint32_t MirrorHEn;
772 uint32_t MirrorVEn;
774 uint32_t ColorToGrayEn;
776 uint32_t BlackLevel;
778 uint8_t EnableCorrectDeadPixel;
780 uint8_t EnableWdr;
782 uint8_t rev[2];
783 } tDevLoadMode;
784
786 typedef struct _tExpose
787 {
789 uint32_t uiTargetMin;
791 uint32_t uiTargetMax;
793 uint32_t uiAnalogGainMin;
795 uint32_t uiAnalogGainMax;
797 uint32_t uiExposeTimeMin;
799 uint32_t uiExposeTimeMax;
800 } tExpose;
801
803 typedef struct _tResolutionRange
804 {
806 int iHeightMax;
808 int iHeightMin;
810 int iWidthMax;
812 int iWidthMin;
814 uint32_t uSkipModeMask;
816 uint32_t uBinSumModeMask;
818 uint32_t uBinAverageModeMask;
820 uint32_t uResampleMask;
821 } tResolutionRange;
822
824 typedef struct _tSdkTrigger
825 {
827 int iIndex;
829 char acDescription[32];
830 } tSdkTrigger;
831
833 typedef struct _tSdkImageResolution
834 {
836 int iIndex;
838 char acDescription[32];
840 uint32_t uBinSumMode;
842 uint32_t uBinAverageMode;
844 uint32_t uSkipMode;
846 uint32_t uResampleMask;
848 int iHOffsetFOV;
850 int iVOffsetFOV;
852 int iWidthFOV;
854 int iHeightFOV;
856 int iWidth;
858 int iHeight;
860 int iWidthZoomHd;
862 int iHeightZoomHd;
864 int iWidthZoomSw;
866 int iHeightZoomSw;
867 } tSdkImageResolution;
868
870 typedef struct _tSdkColorTemperatureDes
871 {
873 int iIndex;
875 char acDescription[32];
876 } tSdkColorTemperatureDes;
877
879 typedef struct _tSdkPackLength
880 {
882 int iIndex;
884 char acDescription[32];
886 uint32_t iPackSize;
887 } tSdkPackLength;
888
890 typedef struct _tSdkPresetLut
891 {
893 int iIndex;
895 char acDescription[32];
896 } tSdkPresetLut;
897
899 typedef struct _tSdkAeAlgorithm
900 {
902 int iIndex;
904 char acDescription[32];
905 } tSdkAeAlgorithm;
906
908 typedef struct _tSdkBayerDecodeAlgorithm
909 {
911 int iIndex;
913 char acDescription[32];
914 } tSdkBayerDecodeAlgorithm;
915
917 typedef struct _tSdkMediaType
918 {
920 int iIndex;
922 char acDescription[32];
924 uint32_t iMediaType;
925 } tSdkMediaType;
926
928 typedef struct _tSdkBayerType
929 {
931 int iIndex;
933 char acDescription[32];
935 uint32_t iMediaType;
936 } tSdkBayerType;
937
939 typedef struct _tSdkFrameSpeed
940 {
942 int iIndex;
944 char acDescription[32];
945 } tSdkFrameSpeed;
946
948 typedef struct _tRgbGainRange
949 {
951 int iRGainMin;
953 int iRGainMax;
955 int iGGainMin;
957 int iGGainMax;
959 int iBGainMin;
961 int iBGainMax;
962 } tRgbGainRange;
963
965 typedef struct _tSaturationRange
966 {
968 int iMin;
970 int iMax;
971 } tSaturationRange;
972
974 typedef struct _tSharpnessRange
975 {
977 int iMin;
979 int iMax;
980 } tSharpnessRange;
981
983 typedef struct _tGammaRange
984 {
986 int iMin;
988 int iMax;
989 } tGammaRange;
990
992 typedef struct _tGammaContrastRange
993 {
995 int iMin;
997 int iMax;
998 }tGammaContrastRange;
999
1001 typedef struct _tContrastRange
1002 {
1004 int iMin;
1006 int iMax;
1007 } tContrastRange;
1008
1010 typedef struct _tSdkIspCapacity
1011 {
1013 int bMonoSensor;
1015 int bWbOnce;
1017 int bAutoWb;
1019 int bAutoExposure;
1021 int bManualExposure;
1023 int bAntiFlick;
1025 int bIspGamma;
1027 int bDeviceIsp;
1029 int bForceUseDeviceIsp;
1031 int bZoomHD;
1033 int bWdr;
1035 int rev[3];
1036 } tSdkIspCapacity;
1037
1039 typedef struct _tSensorCfg
1040 {
1042 tExpose sExposeDesc;
1044 tResolutionRange sResolutionRange;
1046 tSdkImageResolution sMaxResolution;
1047 } tSensorCfg;
1048
1050 typedef struct _tDeviceCfg
1051 {
1052
1054 tRgbGainRange sRgbGainRange;
1056 tSaturationRange sSaturationRange;
1058 tGammaRange sGammaRange;
1060 tGammaContrastRange sGammaContrastRange;
1062 tContrastRange sContrastRange;
1064 tSharpnessRange sSharpnessRange;
1066 tSdkIspCapacity sIspCapacity;
1067
1069 tSdkTrigger *pTriggerDesc;
1071 int iTriggerDesc;
1072
1074 tSdkImageResolution *pImageSizeDesc;
1076 int iImageSizeDesc;
1077
1079 tSdkColorTemperatureDes *pClrTempDesc;
1080 int iClrTempDesc;
1081
1083 tSdkBayerType *pBayerTypeDesc;
1085 int iBayerTypeDesc;
1086
1088 tSdkMediaType *pMediaTypeDesc;
1090 int iMediaTypeDesc;
1091
1093 tSdkFrameSpeed *pFrameSpeedDesc;
1095 int iFrameSpeedDesc;
1096
1098 tSdkPackLength *pPackLenDesc;
1100 int iPackLenDesc;
1101
1103 int iOutputIoCounts;
1105 int iInputIoCounts;
1106
1108 tSdkPresetLut *pPresetLutDesc;
1110 int iPresetLut;
1111
1113 int iUserDataMaxLen;
1115 int bParamInDevice;
1116
1118 tSdkAeAlgorithm *pAeAlmSwDesc;
1120 int iAeAlmSwDesc;
1121
1123 tSdkAeAlgorithm *pAeAlmHdDesc;
1125 int iAeAlmHdDesc;
1126
1128 tSdkBayerDecodeAlgorithm *pBayerDecAlmSwDesc;
1130 int iBayerDecAlmSwDesc;
1131
1133 tSdkBayerDecodeAlgorithm *pBayerDecAlmHdDesc;
1135 int iBayerDecAlmHdDesc;
1136
1137 } tDeviceCfg;
1138
1140 typedef struct _tDevInfo
1141 {
1143 char acProductSeries[32];
1145 char acProductName[32];
1147 char acFriendlyName[32];
1149 char acLinkName[32];
1151 char acDriverName[128];
1153 char acDriverVersion[32];
1155 char acSensorType[32];
1157 char acPortType[32];
1159 uint32_t uInstance;
1161 char acSn[32];
1163 uint16_t VendorID;
1165 uint16_t DeviceDrvID;
1167 uint16_t DeviceDrvVersionID;
1169 uint32_t DeviceID;
1171 char SymbolicName[128];
1173 char Name[64];
1175 uint32_t SensorID;
1176 } tDevInfo;
1177
1179 typedef struct _stImageInfo
1180 {
1182 uint32_t iWidth;
1184 uint32_t iHeight;
1186 uint32_t TotalBytes;
1188 uint32_t uiMediaType;
1190 double ExpTime;
1192 double ExpLineTime;
1194 uint32_t Gain;
1195 }stImageInfo, *PstImageInfo;
1196
1198 typedef struct _FrameStatistic
1199 {
1201 uint32_t iTotal;
1203 uint32_t iCapture;
1205 int iLost;
1206 } FrameStatistic;
1207
1209 typedef struct _tSdkCameraCapbility
1210 {
1212 tDeviceCfg tDeviceCapbility;
1214 tSensorCfg tSensorCapbility;
1215
1216 } tSdkCameraCapbility;
1217
1219 typedef struct _DisplayWindow
1220 {
1222 uint32_t ImageWidth;
1224 uint32_t ImageHeight;
1226 RECT WinRect;
1228 RECT ImageRect;
1229 }DisplayWindow;
1230
1232 typedef struct _tDevEnumInfo
1233 {
1235 tDevInfo DevAttribute;
1237 int bDevOpen;
1238 } tDevEnumInfo;
1239
1241 typedef struct _tDevLoadInfo
1242 {
1244 tDevEnumInfo DevEnumInfo;
1246 tDevLoadMode DevLoadMode;
1247 } tDevLoadInfo;
1248
1250 typedef struct _tGigeNetworkInfo
1251 {
1253 char acLocalNetCardName[64];
1255 char acLocalIp[16];
1257 char acLocalNetmask[16];
1259 char acLocalGateway[16];
1261 BOOL isPersistent;
1263 char acCameraIp[16];
1265 char acCameraNetmask[16];
1267 char acCameraGateway[16];
1269 BYTE byMac[6];
1270 }tGigeNetworkInfo;
1271
1273 typedef struct _tLscCalibParam
1274 {
1276 uint32_t nWidth;
1278 uint32_t nHeight;
1280 uint32_t uiMediaType;
1282 uint8_t *pSrcBuf;
1284 uint32_t nSrcBufLen;
1286 uint8_t *pCalibBuf;
1289 uint32_t nCalibBufSize;
1291 uint32_t nCalibBufLen;
1293 uint32_t nSecNumW;
1295 uint32_t nSecNumH;
1297 uint32_t nPadCoef;
1300 uint32_t nCalibMethod;
1303 uint32_t nTargetGray;
1305 uint32_t nRes[8];
1306 }tLscCalibParam;
1307
1309 typedef struct _tLscCorrectParam
1310 {
1312 uint32_t nWidth;
1314 uint32_t nHeight;
1316 uint32_t uiMediaType;
1318 uint8_t *pSrcBuf;
1320 uint32_t nSrcBufLen;
1322 uint8_t *pDstBuf;
1324 uint32_t nDstBufSize;
1326 uint32_t nDstBufLen;
1328 uint8_t *pCalibBuf;
1330 uint32_t nCalibBufLen;
1332 uint32_t nRes[8];
1333 }tLscCorrectParam;
1334
1335 #pragma pack(pop)
1336
1337
1338
1339 #endif
_tDeviceCfg::iAeAlmSwDesc
int iAeAlmSwDesc
Software automatic exposure algorithm number.
Definition: CKDeviceDef.h:1120
REQUEST_TRANSFER_CURRENT_FRAME
Request to retransmit the last transmitted image frame.
Definition: CKDeviceDef.h:512
tSdkMediaType
struct _tSdkMediaType tSdkMediaType
Image data format output by the camera.
_DisplayWindow::ImageHeight
uint32_t ImageHeight
Image height.
Definition: CKDeviceDef.h:1224
EXCEPTION_VERSION_CHECK
Definition: CKDeviceDef.h:552
IMAGEOUT_MODE_960x600
Resolution 960x600.
Definition: CKDeviceDef.h:266
emFlickerMode
emFlickerMode
Light strobe.
Definition: CKDeviceDef.h:292
_tDeviceCfg::iBayerTypeDesc
int iBayerTypeDesc
The number of types of camera Bayer format, the size of the pBayerTypeDesc array. ...
Definition: CKDeviceDef.h:1085
tSdkAeAlgorithm
struct _tSdkAeAlgorithm tSdkAeAlgorithm
AE algorithm description.
_tLscCorrectParam::nHeight
uint32_t nHeight
Image height.
Definition: CKDeviceDef.h:1314
_tLscCalibParam::nHeight
uint32_t nHeight
Image height.
Definition: CKDeviceDef.h:1278
tSdkFrameSpeed
struct _tSdkFrameSpeed tSdkFrameSpeed
Camera frame rate description information.
_tIspWb
White balance parameter.
Definition: CKDeviceDef.h:708
emFileType
emFileType
Save the file format of the image.
Definition: CKDeviceDef.h:303
_tExpose::uiTargetMin
uint32_t uiTargetMin
Automatic exposure brightness target minimum.
Definition: CKDeviceDef.h:789
_tDeviceCfg::sGammaRange
tGammaRange sGammaRange
Gamma range description.
Definition: CKDeviceDef.h:1058
IMAGEOUT_MODE_752X480
Resolution 752x480.
Definition: CKDeviceDef.h:224
_tDeviceCfg::iPackLenDesc
int iPackLenDesc
The number of transport packet lengths to choose from, which is the size of the pPackLenDesc array...
Definition: CKDeviceDef.h:1100
_tSdkIspCapacity
ISP module enable information.
Definition: CKDeviceDef.h:1010
_tSdkImageResolution::acDescription
char acDescription[32]
Description of the resolution. This information is valid only when the resolution is preset...
Definition: CKDeviceDef.h:838
REQUEST_TRANSFER_NEXT_FRAME
Request to transmit the next frame of the image frame that was last transmitted.
Definition: CKDeviceDef.h:514
SETTING_PAGE_CROSS_LINE
Crosshair configuration page.
Definition: CKDeviceDef.h:433
IMAGE_CHANNEL_MASK
Multichannel cameras specify which channels of images to output, bit0 for channel0 bit1 for channel1 ...
Definition: CKDeviceDef.h:524
IMAGEOUT_MODE_800X600
Resolution 800x600.
Definition: CKDeviceDef.h:204
_tDeviceCfg::sSharpnessRange
tSharpnessRange sSharpnessRange
Sharpening range description.
Definition: CKDeviceDef.h:1064
_tInitCameraParam::nFrameSpeed
int nFrameSpeed
Frame rate.
Definition: CKDeviceDef.h:649
_tGammaContrastRange::iMin
int iMin
Minimum value.
Definition: CKDeviceDef.h:995
_tDeviceCfg::pImageSizeDesc
tSdkImageResolution * pImageSizeDesc
Preset resolution selection.
Definition: CKDeviceDef.h:1074
_tDevLoadMode::Saturation
uint32_t Saturation
Saturation.
Definition: CKDeviceDef.h:760
_tSdkImageResolution::uBinSumMode
uint32_t uBinSumMode
BIN (sum) mode, the range cannot exceed uBinSumModeMask in tSdkResolutionRange.
Definition: CKDeviceDef.h:840
_tSdkPackLength
Transfer packet size description (mainly valid for web cameras)
Definition: CKDeviceDef.h:879
_tSdkBayerDecodeAlgorithm::iIndex
int iIndex
Algorithm index.
Definition: CKDeviceDef.h:911
_stImageInfo::Gain
uint32_t Gain
Gain multiple of the current image.
Definition: CKDeviceDef.h:1194
SETTING_PAGE_AWB_SETTING
White Balance Configuration Page.
Definition: CKDeviceDef.h:431
_tDevEnumInfo::DevAttribute
tDevInfo DevAttribute
Device Attribute Information.
Definition: CKDeviceDef.h:1235
TRANSFER_IMAGE_ON_PASSIVE_MANUAL_MODE
The camera does not take the initiative to send image frames, but sends them when a request is sent...
Definition: CKDeviceDef.h:506
_tDevLoadMode::sIspWb
tIspWb sIspWb
White balance parameter.
Definition: CKDeviceDef.h:748
tSensorCfg
struct _tSensorCfg tSensorCfg
sensor level
FRAME_OUTPUT_QUEUE_SIZE
Set the output cache queue length.
Definition: CKDeviceDef.h:543
_tDeviceCfg::iBayerDecAlmHdDesc
int iBayerDecAlmHdDesc
The number of algorithms that hardware Bayer converts to RGB data, 0 means not supported.
Definition: CKDeviceDef.h:1135
_tContrastRange::iMin
int iMin
Minimum value.
Definition: CKDeviceDef.h:1004
_tRgbGainRange::iBGainMin
int iBGainMin
Minimum value of blue gain.
Definition: CKDeviceDef.h:959
_tIspAe::fMinExposureTime
double fMinExposureTime
Minimum exposure time in auto mode, us.
Definition: CKDeviceDef.h:686
_tDeviceCfg::pTriggerDesc
tSdkTrigger * pTriggerDesc
trigger mode
Definition: CKDeviceDef.h:1069
_tIspAe::AeMode
int AeMode
AE auto exposure mode, AE_FRAME_MODE frame rate priority, AE_EXP_MODE exposure priority.
Definition: CKDeviceDef.h:683
_tDevLoadMode::TriggerMode
uint32_t TriggerMode
Trigger mode.
Definition: CKDeviceDef.h:750
SETTING_PAGE_IMG_SETTING
Image Parameter Configuration Page.
Definition: CKDeviceDef.h:427
IMAGE_CHANNEL_NUM
The maximum number of channel images supported by the camera.
Definition: CKDeviceDef.h:541
FILE_RAW_16BIT
Save as BMP 16BIT file format, for cameras that do not support bayer format, cannot be saved as this ...
Definition: CKDeviceDef.h:318
_tSdkColorTemperatureDes::iIndex
int iIndex
mode index number
Definition: CKDeviceDef.h:873
TRIGGER_MODE_HARD
Hardware Trigger Mode.
Definition: CKDeviceDef.h:365
GAMMA_PRESET_MODE
Preset mode.
Definition: CKDeviceDef.h:469
_tDeviceCfg::iBayerDecAlmSwDesc
int iBayerDecAlmSwDesc
Software Bayer algorithm for converting to RGB data.
Definition: CKDeviceDef.h:1130
_tDeviceCfg::pFrameSpeedDesc
tSdkFrameSpeed * pFrameSpeedDesc
Adjustable frame rate type, corresponding to the normal high speed and super speed settings on the in...
Definition: CKDeviceDef.h:1093
_tIspWb::Top
int Top
Set the coordinates on the window.
Definition: CKDeviceDef.h:721
IMAGEOUT_MODE_1280X800
Resolution 1280X800.
Definition: CKDeviceDef.h:262
_tGammaRange::iMax
int iMax
Maximum value.
Definition: CKDeviceDef.h:988
_tDeviceCfg::iUserDataMaxLen
int iUserDataMaxLen
Indicates the maximum length in the camera that will be used to save the user data area...
Definition: CKDeviceDef.h:1113
EXT_TRIG_LOW_LEVEL
Low level trigger.
Definition: CKDeviceDef.h:389
_tSdkTrigger
Trigger Mode Description.
Definition: CKDeviceDef.h:824
PARAMETER_TEAM_DEFAULT
Definition: CKDeviceDef.h:354
_DisplayWindow::ImageWidth
uint32_t ImageWidth
Image width.
Definition: CKDeviceDef.h:1222
_stImageInfo::ExpTime
double ExpTime
The exposure time of the current image in microseconds us.
Definition: CKDeviceDef.h:1190
_tIspWb::Height
int Height
Window height.
Definition: CKDeviceDef.h:725
_tInitCameraParam::nRes
int nRes[8]
Definition: CKDeviceDef.h:666
emTriggerMode
emTriggerMode
Camera Trigger Mode.
Definition: CKDeviceDef.h:358
tLscCorrectParam
struct _tLscCorrectParam tLscCorrectParam
LSC correction parameter.
LUT_CHANNEL_RED
Red channel.
Definition: CKDeviceDef.h:456
_stImageInfo::TotalBytes
uint32_t TotalBytes
Image data bytes, Total bytes.
Definition: CKDeviceDef.h:1186
_tDevLoadMode::MirrorHEn
uint32_t MirrorHEn
Horizontal Mirroring Enable.
Definition: CKDeviceDef.h:770
_tSdkBayerDecodeAlgorithm::acDescription
char acDescription[32]
Description information.
Definition: CKDeviceDef.h:913
TRIGGER_MODE_CONTINUOUS
Continuous trigger mode.
Definition: CKDeviceDef.h:361
IOMODE_GP_OUTPUT
General output.
Definition: CKDeviceDef.h:480
_tSdkMediaType::acDescription
char acDescription[32]
Description information.
Definition: CKDeviceDef.h:922
_tSdkIspCapacity::rev
int rev[3]
Reserve bytes.
Definition: CKDeviceDef.h:1035
IMAGEOUT_MODE_1920X1280
Resolution 1920x1280.
Definition: CKDeviceDef.h:212
_tDevLoadMode::sIspAe
tIspAe sIspAe
AE parameters.
Definition: CKDeviceDef.h:746
_tSdkTrigger::iIndex
int iIndex
mode index number
Definition: CKDeviceDef.h:827
IMAGEOUT_MODE_320X240
Resolution 320x240.
Definition: CKDeviceDef.h:216
_tSdkCameraCapbility
Camera Ability Level.
Definition: CKDeviceDef.h:1209
_tExpose
Camera exposure function range definition.
Definition: CKDeviceDef.h:786
tGigeNetworkInfo
struct _tGigeNetworkInfo tGigeNetworkInfo
Network information of GigE camera.
emSdkOutputIOMode
emSdkOutputIOMode
IO output mode.
Definition: CKDeviceDef.h:475
_tResolutionRange
Camera resolution setting range for widget UI.
Definition: CKDeviceDef.h:803
_tSdkBayerDecodeAlgorithm
RAW to RGB algorithm description.
Definition: CKDeviceDef.h:908
PARAMETER_TEAM_C
Definition: CKDeviceDef.h:352
_tDevInfo::acSensorType
char acSensorType[32]
sensor type
Definition: CKDeviceDef.h:1155
_FrameStatistic::iLost
int iLost
The current number of dropped frames.
Definition: CKDeviceDef.h:1205
tSdkPackLength
struct _tSdkPackLength tSdkPackLength
Transfer packet size description (mainly valid for web cameras)
_tSdkImageResolution::iWidthZoomSw
int iWidthZoomSw
The width of the software scaling, the resolution of this operation is not required, this variable is set to 0. Even, and 4 bytes aligned.
Definition: CKDeviceDef.h:864
tIspAe
struct _tIspAe tIspAe
Exposure parameters.
WCHAR
uint16_t WCHAR
Definition: CKDeviceDef.h:24
_tSdkIspCapacity::bWdr
int bWdr
Indicates whether this model camera supports WDR function.
Definition: CKDeviceDef.h:1033
IMAGEOUT_MODE_2448X2048
Resolution 2448X2048.
Definition: CKDeviceDef.h:246
_DisplayWindow::ImageRect
RECT ImageRect
Effective image rectangle.
Definition: CKDeviceDef.h:1228
tSdkCameraCapbility
struct _tSdkCameraCapbility tSdkCameraCapbility
Camera Ability Level.
_tSdkPresetLut
Preset LUT table description.
Definition: CKDeviceDef.h:890
_tSdkCameraCapbility::tSensorCapbility
tSensorCfg tSensorCapbility
sensor level
Definition: CKDeviceDef.h:1214
_tSensorCfg::sExposeDesc
tExpose sExposeDesc
Exposure range value.
Definition: CKDeviceDef.h:1042
EXT_TRIG_DOUBLE_EDGE
Bilateral edge trigger.
Definition: CKDeviceDef.h:391
PARAM_MODE_BY_SN
Loads parameters from a file based on its unique serial number. The serial number is already written ...
Definition: CKDeviceDef.h:342
_tExpose::uiAnalogGainMin
uint32_t uiAnalogGainMin
The minimum value of the analog gain in multiples, then 1000 times larger.
Definition: CKDeviceDef.h:793
_tIspGamma::Gamma
uint32_t Gamma
gamma value
Definition: CKDeviceDef.h:735
IMAGEOUT_MODE_4144X2822
Resolution 4144X2822.
Definition: CKDeviceDef.h:256
_tDevInfo::acPortType
char acPortType[32]
interface type
Definition: CKDeviceDef.h:1157
FRAME_SPEED_HIGH
Frame speed High speed.
Definition: CKDeviceDef.h:288
PARAMETER_TEAM_B
Definition: CKDeviceDef.h:351
_tSensorCfg::sResolutionRange
tResolutionRange sResolutionRange
Resolution range description.
Definition: CKDeviceDef.h:1044
DISPLAYMODE_REAL
1:1 display mode, when the image size is larger than the size of the display control, only the partial
Definition: CKDeviceDef.h:409
_tInitCameraParam::nOutputFrameQueueSize
int nOutputFrameQueueSize
Definition: CKDeviceDef.h:662
_tDevLoadMode::EnableWdr
uint8_t EnableWdr
Enable WDR.
Definition: CKDeviceDef.h:780
_tLscCorrectParam::pSrcBuf
uint8_t * pSrcBuf
Input data buffer.
Definition: CKDeviceDef.h:1318
_tLscCalibParam::nCalibBufSize
uint32_t nCalibBufSize
Provided calibrate buffer size(nWidth*nHeight*sizeof(short))
Definition: CKDeviceDef.h:1289
emSdkLutChannel
emSdkLutChannel
LUT color channel.
Definition: CKDeviceDef.h:451
emSettingPage
emSettingPage
The mask of the TAB page displayed in the device property settings dialog.
Definition: CKDeviceDef.h:422
_tLscCorrectParam::nDstBufLen
uint32_t nDstBufLen
输出数据长度 Output buffer length
Definition: CKDeviceDef.h:1326
PARAM_MODE_BY_MODEL
Loads parameters from a file based on the camera model name, such as CK-U2B300.
Definition: CKDeviceDef.h:338
UINT64
uint64_t UINT64
Definition: CKDeviceDef.h:16
AE_EXP_MODE
Auto exposure frame rate priority mode.
Definition: CKDeviceDef.h:416
IS_SUPPORT_CONTROL_FOCUS
Whether to support focusing.
Definition: CKDeviceDef.h:539
tagRECT::left
LONG left
Definition: CKDeviceDef.h:40
_tIspAe::FrequencySel
uint32_t FrequencySel
Flick mode.
Definition: CKDeviceDef.h:696
_tSaturationRange::iMin
int iMin
Minimum value.
Definition: CKDeviceDef.h:968
IMAGEOUT_MODE_1920X1200
Resolution 1920X1200.
Definition: CKDeviceDef.h:242
_tLscCalibParam::nTargetGray
uint32_t nTargetGray
Target gray value(Valid when the nCalibMethod is 2), 8bit,range:[0,255], 10bit,range:[0,1023], 12bit,range:[0,4095], 16bit,range[0,65535].
Definition: CKDeviceDef.h:1303
_tDeviceCfg::sRgbGainRange
tRgbGainRange sRgbGainRange
Image Digital Gain Range Description.
Definition: CKDeviceDef.h:1054
_tSdkIspCapacity::bWbOnce
int bWbOnce
Indicates whether this model supports a white balance function.
Definition: CKDeviceDef.h:1015
_tSdkColorTemperatureDes::acDescription
char acDescription[32]
Description information.
Definition: CKDeviceDef.h:875
_tDevInfo::DeviceID
uint32_t DeviceID
Device ID.
Definition: CKDeviceDef.h:1169
AE_FRAME_MODE
AE exposure priority mode.
Definition: CKDeviceDef.h:418
_DisplayWindow::WinRect
RECT WinRect
Display window rectangle.
Definition: CKDeviceDef.h:1226
_tIspWb::Left
int Left
Set the left coordinate of the window.
Definition: CKDeviceDef.h:719
_tDeviceCfg::iClrTempDesc
int iClrTempDesc
Definition: CKDeviceDef.h:1080
tSdkPresetLut
struct _tSdkPresetLut tSdkPresetLut
Preset LUT table description.
_tLscCalibParam::nCalibBufLen
uint32_t nCalibBufLen
Output calibrate buffer length.
Definition: CKDeviceDef.h:1291
_tSensorCfg
sensor level
Definition: CKDeviceDef.h:1039
_tRgbGainRange::iBGainMax
int iBGainMax
Maximum blue gain.
Definition: CKDeviceDef.h:961
_tDevInfo::uInstance
uint32_t uInstance
The instance index number of this model camera on this computer is used to distinguish the same model...
Definition: CKDeviceDef.h:1159
_tRgbGainRange::iGGainMin
int iGGainMin
Minimum value of green gain.
Definition: CKDeviceDef.h:955
_tIspWb::DGainG
uint32_t DGainG
Green digital gain.
Definition: CKDeviceDef.h:715
_tExpose::uiTargetMax
uint32_t uiTargetMax
Auto exposure brightness target maximum.
Definition: CKDeviceDef.h:791
_tDevInfo::DeviceDrvID
uint16_t DeviceDrvID
Device Driver ID.
Definition: CKDeviceDef.h:1165
_tDevInfo::SymbolicName
char SymbolicName[128]
device label, internal use
Definition: CKDeviceDef.h:1171
_tSdkImageResolution::uSkipMode
uint32_t uSkipMode
Whether the size of SKIP is 0 means that SKIP mode is disabled, the range cannot exceed uSkipModeMask...
Definition: CKDeviceDef.h:844
emMirrorMode
emMirrorMode
Image mirroring mode.
Definition: CKDeviceDef.h:395
_tLscCorrectParam::nCalibBufLen
uint32_t nCalibBufLen
输入标定表缓存长度 Input calibrate length
Definition: CKDeviceDef.h:1330
_tSaturationRange::iMax
int iMax
Maximum value.
Definition: CKDeviceDef.h:970
IMAGEOUT_MODE_1440X1080
Resolution 1440X1080.
Definition: CKDeviceDef.h:260
_tDeviceCfg::iTriggerDesc
int iTriggerDesc
The number of trigger modes, the size of the pTriggerDesc array.
Definition: CKDeviceDef.h:1071
BOOL
int BOOL
Definition: CKDeviceDef.h:17
IOMODE_STROBE_OUTPUT
Strobe output.
Definition: CKDeviceDef.h:478
TCHAR
char TCHAR
Definition: CKDeviceDef.h:26
WORD
uint16_t WORD
Definition: CKDeviceDef.h:15
_tDevInfo::acProductName
char acProductName[32]
Product Name.
Definition: CKDeviceDef.h:1145
_tGigeNetworkInfo::byMac
BYTE byMac[6]
GigE camera NIC MAC address.
Definition: CKDeviceDef.h:1269
emSdkExceptionType
emSdkExceptionType
Definition: CKDeviceDef.h:548
_tInitCameraParam::nHeartbeatTimeout
int nHeartbeatTimeout
Definition: CKDeviceDef.h:664
_tDeviceCfg::pAeAlmHdDesc
tSdkAeAlgorithm * pAeAlmHdDesc
Hardware auto-exposure algorithm description, NULL means hardware auto-exposure is not supported...
Definition: CKDeviceDef.h:1123
_tSdkIspCapacity::bMonoSensor
int bMonoSensor
Indicates whether the camera of this model is a black and white camera. If it is a black and white ca...
Definition: CKDeviceDef.h:1013
IMAGEOUT_MODE_720X540
Resolution 720X540.
Definition: CKDeviceDef.h:258
_tGigeNetworkInfo::acCameraGateway
char acCameraGateway[16]
GigE camera NIC gateway.
Definition: CKDeviceDef.h:1267
_tIspAe::bAntiFlick
int bAntiFlick
Turns off by default on the premise of auto-exposure support.
Definition: CKDeviceDef.h:694
_tSdkImageResolution::iWidthFOV
int iWidthFOV
The width of the field of view is collected and must be even.
Definition: CKDeviceDef.h:852
_tGigeNetworkInfo::acLocalNetCardName
char acLocalNetCardName[64]
local NIC name
Definition: CKDeviceDef.h:1253
_tSdkMediaType::iIndex
int iIndex
Media type number.
Definition: CKDeviceDef.h:920
tSdkColorTemperatureDes
struct _tSdkColorTemperatureDes tSdkColorTemperatureDes
Camera white balance color temperature mode description information.
_tIspAe::Height
int Height
Set window height.
Definition: CKDeviceDef.h:704
_tSdkColorTemperatureDes
Camera white balance color temperature mode description information.
Definition: CKDeviceDef.h:870
_tRgbGainRange::iRGainMax
int iRGainMax
Maximum value of red gain.
Definition: CKDeviceDef.h:953
_tSdkIspCapacity::bForceUseDeviceIsp
int bForceUseDeviceIsp
When both bDeviceIsp and bForceUseDeviceIsp are TRUE, it means that the hardware ISP is mandatory and...
Definition: CKDeviceDef.h:1029
PARAM_MODE_BY_NAME
Loads parameters from the file according to the device nickname (tDevInfo.acFriendlyName), such as CK-U2B300, which can be customized.
Definition: CKDeviceDef.h:340
_tIspAe::res2
uint32_t res2
Definition: CKDeviceDef.h:684
_tGammaRange
Gamma setting range.
Definition: CKDeviceDef.h:983
IMAGEOUT_MODE_4000X3000
Resolution 4000X3000.
Definition: CKDeviceDef.h:248
_tSdkPackLength::iIndex
int iIndex
Sub-package size index number.
Definition: CKDeviceDef.h:882
FILE_PNG_8BIT
Save as PNG 8BIT file format.
Definition: CKDeviceDef.h:316
_tSdkBayerType::iIndex
int iIndex
Bayer type index.
Definition: CKDeviceDef.h:931
_tLscCorrectParam::nSrcBufLen
uint32_t nSrcBufLen
Input data buffer length.
Definition: CKDeviceDef.h:1320
HANDLE
void * HANDLE
Definition: CKDeviceDef.h:20
_tLscCalibParam::nCalibMethod
uint32_t nCalibMethod
Calibrate method(0-Reference by image center, 1-Reference by maximum gray value, 2-Target gray...
Definition: CKDeviceDef.h:1300
ENABLE_WDR
Whether to enable WDR function.
Definition: CKDeviceDef.h:529
_tSdkBayerType::acDescription
char acDescription[32]
Description information.
Definition: CKDeviceDef.h:933
_tDevLoadMode::Sharpness
uint32_t Sharpness
Sharpness.
Definition: CKDeviceDef.h:758
_tSdkImageResolution::iHeightFOV
int iHeightFOV
The height of the field of view must be an even number.
Definition: CKDeviceDef.h:854
_tResolutionRange::uBinSumModeMask
uint32_t uBinSumModeMask
BIN (sum) mode mask, 0, indicating that BIN is not supported. Bit0 is 1, indicating that BIN 2x2 is s...
Definition: CKDeviceDef.h:816
_tSharpnessRange
Sharpening setting range.
Definition: CKDeviceDef.h:974
_tDeviceCfg::iInputIoCounts
int iInputIoCounts
Number of programmable input IOs.
Definition: CKDeviceDef.h:1105
_tDevLoadMode::BlackLevel
uint32_t BlackLevel
Black level.
Definition: CKDeviceDef.h:776
_tLscCalibParam::nPadCoef
uint32_t nPadCoef
Pad coef[1-5].
Definition: CKDeviceDef.h:1297
_tDeviceCfg::iImageSizeDesc
int iImageSizeDesc
The number of preset resolutions, the size of the pImageSizeDesc array.
Definition: CKDeviceDef.h:1076
_tIspAe::ExposureTime
double ExposureTime
Set with support for manual exposure.
Definition: CKDeviceDef.h:677
IMAGEOUT_MODE_1600X1200
Resolution 1600x1200.
Definition: CKDeviceDef.h:220
DISPLAYMODE_SCALE
Zoom display mode, zoom to display control size.
Definition: CKDeviceDef.h:407
tSdkBayerDecodeAlgorithm
struct _tSdkBayerDecodeAlgorithm tSdkBayerDecodeAlgorithm
RAW to RGB algorithm description.
_tIspGamma::PresetSel
uint32_t PresetSel
Definition: CKDeviceDef.h:738
_tDevInfo::acProductSeries
char acProductSeries[32]
Product Line.
Definition: CKDeviceDef.h:1143
_tDevLoadMode::MediaTypeMode
uint32_t MediaTypeMode
Output format.
Definition: CKDeviceDef.h:754
UINT
uint32_t UINT
Definition: CKDeviceDef.h:14
tLscCalibParam
struct _tLscCalibParam tLscCalibParam
LSC calibration parameter.
_tExpose::uiExposeTimeMax
uint32_t uiExposeTimeMax
Maximum value of exposure time in manual mode, unit: line.
Definition: CKDeviceDef.h:799
tSdkImageResolution
struct _tSdkImageResolution tSdkImageResolution
Camera resolution description.
_tSdkImageResolution::iWidth
int iWidth
The width, even number, and 4-byte alignment of the final output image of the camera.
Definition: CKDeviceDef.h:856
_tDeviceCfg::bParamInDevice
int bParamInDevice
Indicates whether the device supports reading and writing parameter groups from the device...
Definition: CKDeviceDef.h:1115
HDC
void * HDC
Definition: CKDeviceDef.h:23
DWORD
uint32_t DWORD
Definition: CKDeviceDef.h:12
_stImageInfo::ExpLineTime
double ExpLineTime
Line exposure time of the current image in microseconds us.
Definition: CKDeviceDef.h:1192
_tIspAe::Width
int Width
Set window width.
Definition: CKDeviceDef.h:702
_tDevInfo::VendorID
uint16_t VendorID
Vendor ID.
Definition: CKDeviceDef.h:1163
_tSdkImageResolution::iIndex
int iIndex
Resolution emResolutionMode.
Definition: CKDeviceDef.h:836
SETTING_PAGE_GAMMA_SETTING
gamma configuration interface
Definition: CKDeviceDef.h:439
_tInitCameraParam::nImageChannelMask
int nImageChannelMask
Definition: CKDeviceDef.h:660
_tResolutionRange::iWidthMax
int iWidthMax
Maximum width of image.
Definition: CKDeviceDef.h:810
_tSdkIspCapacity::bAutoWb
int bAutoWb
Indicates whether this model supports auto white balance.
Definition: CKDeviceDef.h:1017
IMAGEOUT_MODE_1280X960
Resolution 1280x960.
Definition: CKDeviceDef.h:210
STATISTICS_AVG
Mean Statistics.
Definition: CKDeviceDef.h:325
IMAGEOUT_MODE_1280X720
Resolution 1280x720.
Definition: CKDeviceDef.h:208
_tSdkImageResolution::iVOffsetFOV
int iVOffsetFOV
Captures the vertical offset of the field of view relative to the upper left corner of the Sensor&#39;s m...
Definition: CKDeviceDef.h:850
emImageTransferMode
emImageTransferMode
Camera cache frame transfer mode.
Definition: CKDeviceDef.h:495
LPVOID
void * LPVOID
Definition: CKDeviceDef.h:22
tagRECT::bottom
LONG bottom
Definition: CKDeviceDef.h:43
_tDevLoadMode::sIspGamma
tIspGamma sIspGamma
Gamma parameters.
Definition: CKDeviceDef.h:764
_tSdkImageResolution::iHeightZoomSw
int iHeightZoomSw
The height of the software zoom, the resolution of this operation is not required, this variable is set to 0. Even.
Definition: CKDeviceDef.h:866
_tIspAe
Exposure parameters.
Definition: CKDeviceDef.h:671
DEVICE_TYPE_UNKNOW
Definition: CKDeviceDef.h:190
_tResolutionRange::iHeightMin
int iHeightMin
Image minimum height.
Definition: CKDeviceDef.h:808
_stImageInfo::iWidth
uint32_t iWidth
Current image width.
Definition: CKDeviceDef.h:1182
tRgbGainRange
struct _tRgbGainRange tRgbGainRange
RGB three-channel digital gain setting range.
IMAGEOUT_MODE_2592X1944
Resolution 2592x1944.
Definition: CKDeviceDef.h:222
IMAGEOUT_MODE_1296X972
Resolution 1296x972.
Definition: CKDeviceDef.h:264
_tResolutionRange::uBinAverageModeMask
uint32_t uBinAverageModeMask
BIN (average) mode mask, 0, indicating that BIN is not supported. Bit0 is 1, indicating that BIN 2x2 ...
Definition: CKDeviceDef.h:818
_tExpose::uiAnalogGainMax
uint32_t uiAnalogGainMax
The maximum value of the analog gain in multiples, then 1000 times larger.
Definition: CKDeviceDef.h:795
_tInitCameraParam::nGigeTransPacketSize
int nGigeTransPacketSize
Definition: CKDeviceDef.h:658
_tSdkIspCapacity::bManualExposure
int bManualExposure
Indicates whether the camera supports manual exposure.
Definition: CKDeviceDef.h:1021
DisplayWindow
struct _DisplayWindow DisplayWindow
Display window parameters.
tContrastRange
struct _tContrastRange tContrastRange
Contrast setting range.
_tSdkIspCapacity::bZoomHD
int bZoomHD
Whether the camera hardware supports image scaling output (can only be reduced).
Definition: CKDeviceDef.h:1031
_tDeviceCfg::pPresetLutDesc
tSdkPresetLut * pPresetLutDesc
Camera preset LUT table.
Definition: CKDeviceDef.h:1108
USHORT
unsigned short USHORT
Definition: CKDeviceDef.h:25
_tDeviceCfg::pPackLenDesc
tSdkPackLength * pPackLenDesc
Transport packet length, generally used for network devices.
Definition: CKDeviceDef.h:1098
IMAGEOUT_MODE_512X384
Resolution 512x384.
Definition: CKDeviceDef.h:200
_tGigeNetworkInfo::isPersistent
BOOL isPersistent
Does the GigE camera use a fixed IP address?
Definition: CKDeviceDef.h:1261
EXT_TRIG_HIGH_LEVEL
High level trigger, level width determines exposure time, only some models support level trigger mode...
Definition: CKDeviceDef.h:387
_tDeviceCfg::sContrastRange
tContrastRange sContrastRange
Contrast range description.
Definition: CKDeviceDef.h:1062
_tDevLoadMode::EnableCorrectDeadPixel
uint8_t EnableCorrectDeadPixel
Enable correct dead pixel.
Definition: CKDeviceDef.h:778
_tSdkFrameSpeed::acDescription
char acDescription[32]
Description information.
Definition: CKDeviceDef.h:944
IOMODE_PWM_OUTPUT
PWM output.
Definition: CKDeviceDef.h:482
_tLscCorrectParam::pCalibBuf
uint8_t * pCalibBuf
输入标定表缓存 Input calibrate buffer
Definition: CKDeviceDef.h:1328
_tDevInfo
Camera device information.
Definition: CKDeviceDef.h:1140
CONTROL_FOCUS_MIN_VALUE
Get the minimum value of the focus value.
Definition: CKDeviceDef.h:533
_tDevLoadMode::ParameterMode
uint32_t ParameterMode
Pattern of parameter.
Definition: CKDeviceDef.h:766
_tIspGamma::rev
int rev[5]
Definition: CKDeviceDef.h:739
IMAGEOUT_MODE_NUM
SDK predefined number of resolutions.
Definition: CKDeviceDef.h:274
FILE_RAW
Save as BMP file format, for cameras that do not support bayer format, cannot be saved as this format...
Definition: CKDeviceDef.h:310
_tSdkIspCapacity::bDeviceIsp
int bDeviceIsp
Indicates whether this model camera supports hardware ISP function.
Definition: CKDeviceDef.h:1027
_tDeviceCfg::pAeAlmSwDesc
tSdkAeAlgorithm * pAeAlmSwDesc
Software Auto Exposure Algorithm Description.
Definition: CKDeviceDef.h:1118
_tSdkFrameSpeed::iIndex
int iIndex
Frame rate index number, generally 0 corresponds to low speed mode, 1 corresponds to normal mode...
Definition: CKDeviceDef.h:942
_tIspAe::AeTarget
uint32_t AeTarget
AE target brightness.
Definition: CKDeviceDef.h:681
_tDevInfo::DeviceDrvVersionID
uint16_t DeviceDrvVersionID
Device Driver Version ID.
Definition: CKDeviceDef.h:1167
_tDevLoadMode::ResolutionMode
uint32_t ResolutionMode
Resolution.
Definition: CKDeviceDef.h:752
FILE_BMP_8BIT
Save as BMP 8BIT file format.
Definition: CKDeviceDef.h:314
_FrameStatistic::iCapture
uint32_t iCapture
The number of valid frames currently being collected.
Definition: CKDeviceDef.h:1203
emSdkParameterMode
emSdkParameterMode
Parameter file loading method.
Definition: CKDeviceDef.h:335
_tIspWb::DGainB
uint32_t DGainB
Blue digital gain.
Definition: CKDeviceDef.h:717
SETTING_PAGE_DEVINFO
Device Information Configuration Page.
Definition: CKDeviceDef.h:425
EXT_TRIG_TRAILING_EDGE
Falling edge trigger.
Definition: CKDeviceDef.h:385
_tDeviceCfg::pMediaTypeDesc
tSdkMediaType * pMediaTypeDesc
Camera output image format.
Definition: CKDeviceDef.h:1088
REQUEST_TRANSFER_LATEST_FRAME
Request to transfer the latest image frame.
Definition: CKDeviceDef.h:516
_tSdkPresetLut::iIndex
int iIndex
Index number.
Definition: CKDeviceDef.h:893
_DisplayWindow
Display window parameters.
Definition: CKDeviceDef.h:1219
_tSdkIspCapacity::bAutoExposure
int bAutoExposure
Indicates whether this model supports auto exposure.
Definition: CKDeviceDef.h:1019
_FrameStatistic
Frame rate statistics.
Definition: CKDeviceDef.h:1198
SETTING_PAGE_REL_SETTING
Resolution Configuration Page.
Definition: CKDeviceDef.h:437
IMAGEOUT_MODE_1280X1024
Resolution 1280x1024.
Definition: CKDeviceDef.h:218
_tSdkMediaType::iMediaType
uint32_t iMediaType
Corresponding image format encoding, such as CAMERA_MEDIA_TYPE_BAYGR8, is defined in this document...
Definition: CKDeviceDef.h:924
IMAGEOUT_MODE_3008X3008
Resolution 3008X3008.
Definition: CKDeviceDef.h:250
TRIGGER_MODE_SOFT
Software Trigger Mode.
Definition: CKDeviceDef.h:363
TRANSFER_OLDEST_IMAGE
Read the oldest frame in the camera memory.
Definition: CKDeviceDef.h:500
_tDevEnumInfo
Enumeration information.
Definition: CKDeviceDef.h:1232
STROBE_SYNC_WITH_TRIG_MANUAL
Synchronize with the trigger signal. After the trigger, STROBE delays the specified time CameraSetStr...
Definition: CKDeviceDef.h:376
emSdkParameterTeam
emSdkParameterTeam
The camera&#39;s configuration parameters are divided into 4 groups of A, B, C, and D for saving...
Definition: CKDeviceDef.h:348
_tRgbGainRange::iGGainMax
int iGGainMax
Maximum value of green gain.
Definition: CKDeviceDef.h:957
IOMODE_TRIG_INPUT
Trigger input.
Definition: CKDeviceDef.h:489
CONTROL_FOCUS_MAX_VALUE
Get the maximum value of the focus value.
Definition: CKDeviceDef.h:535
emAeExpMode
emAeExpMode
Auto Exposure Mode.
Definition: CKDeviceDef.h:413
TRANSFER_IMAGE_ON_PASSIVE_MODE
The camera does not take the initiative to send image frames, but only sends them when a request is s...
Definition: CKDeviceDef.h:503
_tRgbGainRange
RGB three-channel digital gain setting range.
Definition: CKDeviceDef.h:948
emFrameMode
emFrameMode
frame rate
Definition: CKDeviceDef.h:281
_tDevLoadMode::rev
uint8_t rev[2]
保留字节
Definition: CKDeviceDef.h:782
FILE_BMP
Save as BMP file format.
Definition: CKDeviceDef.h:308
emExtTrigSignal
emExtTrigSignal
Type of signal triggered by hardware.
Definition: CKDeviceDef.h:380
_tIspAe::bAutoExposure
int bAutoExposure
Enables auto exposure, it is enabled by default.
Definition: CKDeviceDef.h:674
IMAGEOUT_MODE_1424x1424
Resolution 2840x2840.
Definition: CKDeviceDef.h:270
IMAGEOUT_MODE_1920X1080
Resolution 1920x1080.
Definition: CKDeviceDef.h:230
_tSaturationRange
Range of saturation setting.
Definition: CKDeviceDef.h:965
_stImageInfo::iHeight
uint32_t iHeight
Current image height.
Definition: CKDeviceDef.h:1184
tDeviceCfg
struct _tDeviceCfg tDeviceCfg
Device Capability Level.
_FrameStatistic::iTotal
uint32_t iTotal
Total number of frames currently captured (including error frames)
Definition: CKDeviceDef.h:1201
FIND_ME
Definition: CKDeviceDef.h:545
_tIspAe::Left
int Left
Set window left.
Definition: CKDeviceDef.h:698
IMAGEOUT_MODE_3664X2748
Resolution 3664x2748.
Definition: CKDeviceDef.h:228
_tSdkCameraCapbility::tDeviceCapbility
tDeviceCfg tDeviceCapbility
Device Capability Level.
Definition: CKDeviceDef.h:1212
tagRECT::top
LONG top
Definition: CKDeviceDef.h:41
_tSdkFrameSpeed
Camera frame rate description information.
Definition: CKDeviceDef.h:939
emSdkValueType
emSdkValueType
Set the type of parameter.
Definition: CKDeviceDef.h:520
_tLscCalibParam::nRes
uint32_t nRes[8]
Reserved.
Definition: CKDeviceDef.h:1305
tDevEnumInfo
struct _tDevEnumInfo tDevEnumInfo
Enumeration information.
LUT_CHANNEL_BLUE
Blue channel.
Definition: CKDeviceDef.h:460
LONG
long LONG
Definition: CKDeviceDef.h:19
MIRROR_MODE_V
Vertical Mirror.
Definition: CKDeviceDef.h:400
_tDevEnumInfo::bDevOpen
int bDevOpen
Whether the current device is turned on 0: The device is not turned on; 1: The device is already turn...
Definition: CKDeviceDef.h:1237
EXT_TRIG_LEADING_EDGE
Rising edge trigger, defaults to this mode.
Definition: CKDeviceDef.h:383
_tDevLoadMode::MirrorVEn
uint32_t MirrorVEn
Vertical Mirror Enable.
Definition: CKDeviceDef.h:772
EXCEPTION_DEV_DISCONNECT
Definition: CKDeviceDef.h:550
_tDevLoadInfo::DevLoadMode
tDevLoadMode DevLoadMode
Device mode information.
Definition: CKDeviceDef.h:1246
BYTE
uint8_t BYTE
Definition: CKDeviceDef.h:18
_tSdkImageResolution::uBinAverageMode
uint32_t uBinAverageMode
BIN (average) mode, the range cannot exceed uBinAverageModeMask in tSdkResolutionRange.
Definition: CKDeviceDef.h:842
_tIspGamma::GammaContrast
uint32_t GammaContrast
LUT contrast value.
Definition: CKDeviceDef.h:737
emRequestTransferCmd
emRequestTransferCmd
Definition: CKDeviceDef.h:509
IMAGEOUT_MODE_640X480
Resolution 640x480.
Definition: CKDeviceDef.h:202
IMAGEOUT_MODE_640X360
Resolution 640x360.
Definition: CKDeviceDef.h:238
LUT_CHANNEL_ALL
R, B, G three channels simultaneously adjust.
Definition: CKDeviceDef.h:454
_tSdkIspCapacity::bAntiFlick
int bAntiFlick
Indicates whether this model camera supports anti-strobe function.
Definition: CKDeviceDef.h:1023
emSdkInputIOMode
emSdkInputIOMode
IO input mode.
Definition: CKDeviceDef.h:486
IMAGEOUT_MODE_640X512
Resolution 640X512.
Definition: CKDeviceDef.h:272
EXCEPTION_DEV_RECONNECT
Definition: CKDeviceDef.h:551
_tSdkImageResolution::iHeight
int iHeight
The height of the image that the camera ultimately outputs, even.
Definition: CKDeviceDef.h:858
IMAGEOUT_MODE_4096X2160
Resolution 4096X2160.
Definition: CKDeviceDef.h:252
_tDeviceCfg::pBayerTypeDesc
tSdkBayerType * pBayerTypeDesc
Camera Bayer format.
Definition: CKDeviceDef.h:1083
_tResolutionRange::iWidthMin
int iWidthMin
Image minimum width.
Definition: CKDeviceDef.h:812
_tIspWb::CCM
int CCM[9]
Color space.
Definition: CKDeviceDef.h:727
_tDeviceCfg
Device Capability Level.
Definition: CKDeviceDef.h:1050
STATISTICS_HIST
Histogram statistics.
Definition: CKDeviceDef.h:327
emResolutionMode
emResolutionMode
Image resolution.
Definition: CKDeviceDef.h:197
tResolutionRange
struct _tResolutionRange tResolutionRange
Camera resolution setting range for widget UI.
_tDeviceCfg::sGammaContrastRange
tGammaContrastRange sGammaContrastRange
Gamma Contrast Range Description.
Definition: CKDeviceDef.h:1060
_tDeviceCfg::iOutputIoCounts
int iOutputIoCounts
Number of programmable output IOs.
Definition: CKDeviceDef.h:1103
_tDevLoadMode::Contrast
uint32_t Contrast
Contrast.
Definition: CKDeviceDef.h:762
_tDevInfo::Name
char Name[64]
device label, internal use
Definition: CKDeviceDef.h:1173
tagRECT
Definition: CKDeviceDef.h:38
_tIspAe::Top
int Top
Setting window.
Definition: CKDeviceDef.h:700
_tGigeNetworkInfo::acLocalGateway
char acLocalGateway[16]
local NIC gateway
Definition: CKDeviceDef.h:1259
_tDeviceCfg::pBayerDecAlmHdDesc
tSdkBayerDecodeAlgorithm * pBayerDecAlmHdDesc
Algorithm description of hardware Bayer converted to RGB data, not supported for NULL.
Definition: CKDeviceDef.h:1133
DEVICE_TYPE_USB30
Definition: CKDeviceDef.h:192
emStatisticsMode
emStatisticsMode
Exposure Algorithm.
Definition: CKDeviceDef.h:322
_tInitCameraParam
When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera.
Definition: CKDeviceDef.h:646
_tIspAe::iMinAnalogGain
int iMinAnalogGain
Minimum analog gain in automatic mode.
Definition: CKDeviceDef.h:690
tDevInfo
struct _tDevInfo tDevInfo
Camera device information.
CONTROL_FOCUS_DEFAULT_VALUE
Get the default value of the focus value.
Definition: CKDeviceDef.h:537
FRAME_SPEED_MIDDLE
Frame rate Medium speed.
Definition: CKDeviceDef.h:286
_tLscCalibParam::pSrcBuf
uint8_t * pSrcBuf
Input data buffer.
Definition: CKDeviceDef.h:1282
tSdkBayerType
struct _tSdkBayerType tSdkBayerType
Image data format output by the camera.
tGammaRange
struct _tGammaRange tGammaRange
Gamma setting range.
stImageInfo
struct _stImageInfo stImageInfo
Frame header information.
_tDeviceCfg::iAeAlmHdDesc
int iAeAlmHdDesc
Number of hardware auto-exposure algorithms, 0 means hardware auto-exposure is not supported...
Definition: CKDeviceDef.h:1125
_tDevLoadMode::ColorToGrayEn
uint32_t ColorToGrayEn
Color to gray image.
Definition: CKDeviceDef.h:774
_tInitCameraParam::nSensorOutPixelFormat
int nSensorOutPixelFormat
Definition: CKDeviceDef.h:654
tIspGamma
struct _tIspGamma tIspGamma
Gama parameter.
tIspWb
struct _tIspWb tIspWb
White balance parameter.
_tSdkMediaType
Image data format output by the camera.
Definition: CKDeviceDef.h:917
_tDevLoadMode::ParameterTeam
uint32_t ParameterTeam
Group of parameters.
Definition: CKDeviceDef.h:768
_tLscCalibParam::uiMediaType
uint32_t uiMediaType
Image format.
Definition: CKDeviceDef.h:1280
_tGigeNetworkInfo::acCameraNetmask
char acCameraNetmask[16]
GigE camera NIC submask.
Definition: CKDeviceDef.h:1265
_tDevLoadInfo
Current mode and enumeration information for the device.
Definition: CKDeviceDef.h:1241
SETTING_PAGE_EXP_SETTING
Exposure configuration page.
Definition: CKDeviceDef.h:429
_tDevInfo::acLinkName
char acLinkName[32]
Kernel symbolic link name, internal use.
Definition: CKDeviceDef.h:1149
_tDevInfo::acDriverName
char acDriverName[128]
driver name
Definition: CKDeviceDef.h:1151
GAMMA_DYNAMIC_MODE
Dynamic mode.
Definition: CKDeviceDef.h:467
_tSdkImageResolution::iHeightZoomHd
int iHeightZoomHd
The height of the hardware scaling, the resolution of this operation is not required, this variable is set to 0.
Definition: CKDeviceDef.h:862
IMAGEOUT_MODE_768X576
Resolution 768x576.
Definition: CKDeviceDef.h:226
_tSdkIspCapacity::bIspGamma
int bIspGamma
indicates whether this model camera supports Gamma function
Definition: CKDeviceDef.h:1025
_tIspAe::iMaxAnalogGain
int iMaxAnalogGain
Maximum analog gain in automatic mode.
Definition: CKDeviceDef.h:692
IMAGEOUT_MODE_2048X1536
Resolution 2048x1536.
Definition: CKDeviceDef.h:214
_tDevInfo::acSn
char acSn[32]
Product unique serial number.
Definition: CKDeviceDef.h:1161
LED_LIGHT
For U2BMT120C-GW model, control the LED output light.
Definition: CKDeviceDef.h:527
IMAGEOUT_MODE_5472X3648
Resolution 5472X3648.
Definition: CKDeviceDef.h:244
emDeviceType
emDeviceType
device type
Definition: CKDeviceDef.h:188
_tDevInfo::acDriverVersion
char acDriverVersion[32]
driver version
Definition: CKDeviceDef.h:1153
_tSharpnessRange::iMax
int iMax
Maximum value.
Definition: CKDeviceDef.h:979
_tIspGamma
Gama parameter.
Definition: CKDeviceDef.h:731
GAMMA_USER_MODE
Custom mode.
Definition: CKDeviceDef.h:471
tagRECT::right
LONG right
Definition: CKDeviceDef.h:42
_tIspGamma::Mode
uint32_t Mode
Definition: CKDeviceDef.h:733
_tLscCalibParam::nSecNumH
uint32_t nSecNumH
Height sec number.
Definition: CKDeviceDef.h:1295
_tRgbGainRange::iRGainMin
int iRGainMin
Minimum value of red gain.
Definition: CKDeviceDef.h:951
_tGammaRange::iMin
int iMin
Minimum value.
Definition: CKDeviceDef.h:986
_tGigeNetworkInfo
Network information of GigE camera.
Definition: CKDeviceDef.h:1250
PHANDLE
HANDLE * PHANDLE
Definition: CKDeviceDef.h:21
_tDeviceCfg::iMediaTypeDesc
int iMediaTypeDesc
The number of types of camera output image formats, the size of the pMediaTypeDesc array...
Definition: CKDeviceDef.h:1090
IMAGEOUT_MODE_2304X1296
Resolution 2304x1296.
Definition: CKDeviceDef.h:232
_tLscCalibParam::nSecNumW
uint32_t nSecNumW
Width sec number.
Definition: CKDeviceDef.h:1293
_tSdkPackLength::acDescription
char acDescription[32]
Corresponding description information.
Definition: CKDeviceDef.h:884
_tDeviceCfg::sIspCapacity
tSdkIspCapacity sIspCapacity
ISP Capability Description.
Definition: CKDeviceDef.h:1066
_tLscCalibParam
LSC calibration parameter.
Definition: CKDeviceDef.h:1273
FRAME_SPEED_LOW
Frame rate Low speed.
Definition: CKDeviceDef.h:284
FREQ_FLICKER_MODE_NULL
Prohibits the elimination of strobes.
Definition: CKDeviceDef.h:295
IOMODE_GP_INPUT
General input.
Definition: CKDeviceDef.h:491
_tDevLoadInfo::DevEnumInfo
tDevEnumInfo DevEnumInfo
Enumeration information.
Definition: CKDeviceDef.h:1244
emSdkLutMode
emSdkLutMode
LUT mode.
Definition: CKDeviceDef.h:464
_tLscCalibParam::nWidth
uint32_t nWidth
Image width.
Definition: CKDeviceDef.h:1276
_tInitCameraParam::nTriggerMode
int nTriggerMode
Definition: CKDeviceDef.h:656
_tSdkPresetLut::acDescription
char acDescription[32]
Description information.
Definition: CKDeviceDef.h:895
LUT_CHANNEL_GREEN
Green channel.
Definition: CKDeviceDef.h:458
_tSdkAeAlgorithm::acDescription
char acDescription[32]
Description information.
Definition: CKDeviceDef.h:904
_tSdkBayerType::iMediaType
uint32_t iMediaType
The corresponding format encoding supported by sensor, such as CAMERA_MEDIA_TYPE_BAYGR8.
Definition: CKDeviceDef.h:935
_tDeviceCfg::pBayerDecAlmSwDesc
tSdkBayerDecodeAlgorithm * pBayerDecAlmSwDesc
Software Bayer algorithm for converting to RGB data.
Definition: CKDeviceDef.h:1128
IMAGEOUT_MODE_CUSTOM
Custom Resolution.
Definition: CKDeviceDef.h:277
TRANSFER_NEWEST_IMAGE
Read the newest frame in the camera memory.
Definition: CKDeviceDef.h:498
_tLscCalibParam::pCalibBuf
uint8_t * pCalibBuf
Output calibrate buffer.
Definition: CKDeviceDef.h:1286
_tIspWb::bAutoWb
int bAutoWb
Turns off by default on the premise of auto white balance support.
Definition: CKDeviceDef.h:711
STROBE_SYNC_WITH_TRIG_AUTO
Synchronize with the trigger signal. When triggered, the STROBE signal is automatically generated whe...
Definition: CKDeviceDef.h:373
_tSdkImageResolution::iWidthZoomHd
int iWidthZoomHd
The width of the hardware scale, the resolution of this operation is not required, this variable is set to 0.
Definition: CKDeviceDef.h:860
_tIspAe::AnalogGain
uint32_t AnalogGain
Set with support for manual exposure.
Definition: CKDeviceDef.h:679
tDevLoadMode
struct _tDevLoadMode tDevLoadMode
Device loading mode information.
_tSdkAeAlgorithm::iIndex
int iIndex
Index number.
Definition: CKDeviceDef.h:902
_tSdkImageResolution::uResampleMask
uint32_t uResampleMask
Hardware resampling mask.
Definition: CKDeviceDef.h:846
_tResolutionRange::uResampleMask
uint32_t uResampleMask
Hardware resampling mask.
Definition: CKDeviceDef.h:820
IMAGEOUT_MODE_3072X2048
Resolution 3072X2048.
Definition: CKDeviceDef.h:240
DEVICE_TYPE_USB20
Definition: CKDeviceDef.h:191
_tSdkImageResolution
Camera resolution description.
Definition: CKDeviceDef.h:833
_tResolutionRange::uSkipModeMask
uint32_t uSkipModeMask
SKIP mode mask, 0, indicating that SKIP is not supported. Bit0 is 1, indicating support for SKIP 2x2;...
Definition: CKDeviceDef.h:814
_tIspWb::Width
int Width
Window width.
Definition: CKDeviceDef.h:723
_tDeviceCfg::iPresetLut
int iPresetLut
The number of LUT tables preset by the camera, the size of the pPresetLutDesc array.
Definition: CKDeviceDef.h:1110
tSaturationRange
struct _tSaturationRange tSaturationRange
Range of saturation setting.
HWND
void * HWND
Definition: CKDeviceDef.h:27
CONTROL_FOCUS_VALUE
Set and get focus value of adjustable focus lens.
Definition: CKDeviceDef.h:531
_tSdkTrigger::acDescription
char acDescription[32]
Description of this mode.
Definition: CKDeviceDef.h:829
_tSdkBayerType
Image data format output by the camera.
Definition: CKDeviceDef.h:928
tDevLoadInfo
struct _tDevLoadInfo tDevLoadInfo
Current mode and enumeration information for the device.
tSdkIspCapacity
struct _tSdkIspCapacity tSdkIspCapacity
ISP module enable information.
_tLscCorrectParam::pDstBuf
uint8_t * pDstBuf
Output data buffer.
Definition: CKDeviceDef.h:1322
_stImageInfo::uiMediaType
uint32_t uiMediaType
Image format.
Definition: CKDeviceDef.h:1188
DEVICE_TYPE_GIGE
Definition: CKDeviceDef.h:193
FILE_JPG
Save as JPEG file format.
Definition: CKDeviceDef.h:306
_tSdkAeAlgorithm
AE algorithm description.
Definition: CKDeviceDef.h:899
IMAGEOUT_MODE_2736X1824
Resolution 2736X1824.
Definition: CKDeviceDef.h:254
_tLscCorrectParam::nWidth
uint32_t nWidth
Image width.
Definition: CKDeviceDef.h:1312
_tGammaContrastRange
Gamma contrast setting range.
Definition: CKDeviceDef.h:992
emSdkDisplayMode
emSdkDisplayMode
SDK internal display interface display mode.
Definition: CKDeviceDef.h:404
_tSdkPackLength::iPackSize
uint32_t iPackSize
packet size
Definition: CKDeviceDef.h:886
SETTING_PAGE_GIGE_SETTING
GigE camera configuration page, only GigE camera is valid.
Definition: CKDeviceDef.h:441
RECT
struct tagRECT RECT
IMAGEOUT_MODE_1024X768
Resolution 1024x768.
Definition: CKDeviceDef.h:206
IMAGEOUT_MODE_4608X3456
Resolution 4608x3456.
Definition: CKDeviceDef.h:236
tSharpnessRange
struct _tSharpnessRange tSharpnessRange
Sharpening setting range.
INT
int32_t INT
Definition: CKDeviceDef.h:13
_tLscCorrectParam::nDstBufSize
uint32_t nDstBufSize
提供的输出缓冲区大小 Provided output buffer size
Definition: CKDeviceDef.h:1324
_tLscCorrectParam::nRes
uint32_t nRes[8]
预留 Resevered
Definition: CKDeviceDef.h:1332
_tIspWb::DGainR
uint32_t DGainR
Red digital gain.
Definition: CKDeviceDef.h:713
tGammaContrastRange
struct _tGammaContrastRange tGammaContrastRange
Gamma contrast setting range.
tExpose
struct _tExpose tExpose
Camera exposure function range definition.
STATISTICS_WINDOW
Statistical method with weight 3x3.
Definition: CKDeviceDef.h:329
_tContrastRange::iMax
int iMax
Maximum value.
Definition: CKDeviceDef.h:1006
_stImageInfo
Frame header information.
Definition: CKDeviceDef.h:1179
SETTING_PAGE_OUT_SETTING
Video Output Configuration Page.
Definition: CKDeviceDef.h:435
_tGigeNetworkInfo::acLocalNetmask
char acLocalNetmask[16]
local NIC submask
Definition: CKDeviceDef.h:1257
PARAM_MODE_IN_DEVICE
Loads parameters from the device&#39;s solid state memory. Not all models support reading and writing par...
Definition: CKDeviceDef.h:344
_tGigeNetworkInfo::acCameraIp
char acCameraIp[16]
GigE camera NIC IP.
Definition: CKDeviceDef.h:1263
_tSharpnessRange::iMin
int iMin
Minimum value.
Definition: CKDeviceDef.h:977
IMAGEOUT_MODE_2304X1728
Resolution 2304x1728.
Definition: CKDeviceDef.h:234
_tDevInfo::SensorID
uint32_t SensorID
Sensor ID.
Definition: CKDeviceDef.h:1175
MIRROR_MODE_H
horizontal mirroring
Definition: CKDeviceDef.h:398
PARAMETER_TEAM_A
Definition: CKDeviceDef.h:350
_tInitCameraParam::nImageTransferMode
int nImageTransferMode
Definition: CKDeviceDef.h:652
_tIspAe::res1
uint32_t res1
Definition: CKDeviceDef.h:675
_tDevLoadMode::FrameSpeedMode
uint32_t FrameSpeedMode
Frame rate.
Definition: CKDeviceDef.h:756
SETTING_PAGE_SPECIAL_SETTING
Special parameter settings.
Definition: CKDeviceDef.h:443
_tExpose::uiExposeTimeMin
uint32_t uiExposeTimeMin
The minimum exposure time in manual mode, in units of lines. According to CameraGetExposureLineTime, you can get the corresponding time (microseconds) of a line, so as to get the exposure time of the whole frame.
Definition: CKDeviceDef.h:797
FREQ_FLICKER_MODE_60HZ
Eliminate 60hz strobe.
Definition: CKDeviceDef.h:299
_tDeviceCfg::pClrTempDesc
tSdkColorTemperatureDes * pClrTempDesc
Preset color temperature mode for white balance.
Definition: CKDeviceDef.h:1079
_tLscCorrectParam
LSC correction parameter.
Definition: CKDeviceDef.h:1309
tInitCameraParam
struct _tInitCameraParam tInitCameraParam
When initializing the camera, if the camera is initialized through this structure, it is no longer necessary to set the parameters separately after opening the camera.
_tLscCorrectParam::uiMediaType
uint32_t uiMediaType
Image format.
Definition: CKDeviceDef.h:1316
_tDevInfo::acFriendlyName
char acFriendlyName[32]
Product nickname, user can customize the nickname, save it in the camera, used to distinguish multipl...
Definition: CKDeviceDef.h:1147
_tGammaContrastRange::iMax
int iMax
Maximum value.
Definition: CKDeviceDef.h:997
emStrobeControl
emStrobeControl
Strobe signal control method.
Definition: CKDeviceDef.h:369
_tSensorCfg::sMaxResolution
tSdkImageResolution sMaxResolution
Maximum resolution.
Definition: CKDeviceDef.h:1046
PstImageInfo
struct _stImageInfo * PstImageInfo
FILE_PNG
Save as PNG 24BIT file format.
Definition: CKDeviceDef.h:312
SETTING_PAGE_ALL
Show all property pages.
Definition: CKDeviceDef.h:445
_tDeviceCfg::iFrameSpeedDesc
int iFrameSpeedDesc
Adjusts the number of frame rate types, which is the size of the pFrameSpeedDesc array.
Definition: CKDeviceDef.h:1095
_tGigeNetworkInfo::acLocalIp
char acLocalIp[16]
local NIC IP
Definition: CKDeviceDef.h:1255
_tResolutionRange::iHeightMax
int iHeightMax
Maximum height of image.
Definition: CKDeviceDef.h:806
FREQ_FLICKER_MODE_50HZ
Eliminate 50hz strobe.
Definition: CKDeviceDef.h:297
_tIspAe::fMaxExposureTime
double fMaxExposureTime
Maximum exposure time in auto mode, us.
Definition: CKDeviceDef.h:688
PARAMETER_TEAM_D
Definition: CKDeviceDef.h:353
IMAGEOUT_MODE_2848X2848
Resolution 2840x2840.
Definition: CKDeviceDef.h:268
_tDeviceCfg::sSaturationRange
tSaturationRange sSaturationRange
Description of saturation range.
Definition: CKDeviceDef.h:1056
_tSdkImageResolution::iHOffsetFOV
int iHOffsetFOV
Captures the horizontal offset of the field of view relative to the upper left corner of the Sensor&#39;s...
Definition: CKDeviceDef.h:848
_tLscCalibParam::nSrcBufLen
uint32_t nSrcBufLen
Input data buffer length.
Definition: CKDeviceDef.h:1284
FrameStatistic
struct _FrameStatistic FrameStatistic
Frame rate statistics.
_tContrastRange
Contrast setting range.
Definition: CKDeviceDef.h:1001
tSdkTrigger
struct _tSdkTrigger tSdkTrigger
Trigger Mode Description.
STATISTICS_REFER_WINDOW
Reference window statistics.
Definition: CKDeviceDef.h:331
_tDevLoadMode
Device loading mode information.
Definition: CKDeviceDef.h:743


CKCameraAPI: UserManual.h Source File

UserManual.h
Go to the documentation of this file.
1
253
264
297
300
309
316
320
360
368
372
508
519
553
556
565
572
576
616
624
628


CKCameraAPI: Member List

_DisplayWindow Member List

This is the complete list of members for _DisplayWindow, including all inherited members.

ImageHeight | _DisplayWindow
ImageRect | _DisplayWindow
ImageWidth | _DisplayWindow
WinRect | _DisplayWindow


CKCameraAPI: Member List

_FrameStatistic Member List

This is the complete list of members for _FrameStatistic, including all inherited members.

iCapture | _FrameStatistic
iLost | _FrameStatistic
iTotal | _FrameStatistic


CKCameraAPI: Member List

_stImageInfo Member List

This is the complete list of members for _stImageInfo, including all inherited members.

ExpLineTime | _stImageInfo
ExpTime | _stImageInfo
Gain | _stImageInfo
iHeight | _stImageInfo
iWidth | _stImageInfo
TotalBytes | _stImageInfo
uiMediaType | _stImageInfo


CKCameraAPI: Member List

_tContrastRange Member List

This is the complete list of members for _tContrastRange, including all inherited members.

iMax | _tContrastRange
iMin | _tContrastRange


CKCameraAPI: Member List

_tDevEnumInfo Member List

This is the complete list of members for _tDevEnumInfo, including all inherited members.

bDevOpen | _tDevEnumInfo
DevAttribute | _tDevEnumInfo


CKCameraAPI: Member List

_tDevInfo Member List

This is the complete list of members for _tDevInfo, including all inherited members.

acDriverName | _tDevInfo
acDriverVersion | _tDevInfo
acFriendlyName | _tDevInfo
acLinkName | _tDevInfo
acPortType | _tDevInfo
acProductName | _tDevInfo
acProductSeries | _tDevInfo
acSensorType | _tDevInfo
acSn | _tDevInfo
DeviceDrvID | _tDevInfo
DeviceDrvVersionID | _tDevInfo
DeviceID | _tDevInfo
Name | _tDevInfo
SensorID | _tDevInfo
SymbolicName | _tDevInfo
uInstance | _tDevInfo
VendorID | _tDevInfo


CKCameraAPI: Member List

_tDevLoadInfo Member List

This is the complete list of members for _tDevLoadInfo, including all inherited members.

DevEnumInfo | _tDevLoadInfo
DevLoadMode | _tDevLoadInfo


CKCameraAPI: Member List

_tDevLoadMode Member List

This is the complete list of members for _tDevLoadMode, including all inherited members.

BlackLevel | _tDevLoadMode
ColorToGrayEn | _tDevLoadMode
Contrast | _tDevLoadMode
EnableCorrectDeadPixel | _tDevLoadMode
EnableWdr | _tDevLoadMode
FrameSpeedMode | _tDevLoadMode
MediaTypeMode | _tDevLoadMode
MirrorHEn | _tDevLoadMode
MirrorVEn | _tDevLoadMode
ParameterMode | _tDevLoadMode
ParameterTeam | _tDevLoadMode
ResolutionMode | _tDevLoadMode
rev | _tDevLoadMode
Saturation | _tDevLoadMode
Sharpness | _tDevLoadMode
sIspAe | _tDevLoadMode
sIspGamma | _tDevLoadMode
sIspWb | _tDevLoadMode
TriggerMode | _tDevLoadMode


CKCameraAPI: Member List

_tDeviceCfg Member List

This is the complete list of members for _tDeviceCfg, including all inherited members.

bParamInDevice | _tDeviceCfg
iAeAlmHdDesc | _tDeviceCfg
iAeAlmSwDesc | _tDeviceCfg
iBayerDecAlmHdDesc | _tDeviceCfg
iBayerDecAlmSwDesc | _tDeviceCfg
iBayerTypeDesc | _tDeviceCfg
iClrTempDesc | _tDeviceCfg
iFrameSpeedDesc | _tDeviceCfg
iImageSizeDesc | _tDeviceCfg
iInputIoCounts | _tDeviceCfg
iMediaTypeDesc | _tDeviceCfg
iOutputIoCounts | _tDeviceCfg
iPackLenDesc | _tDeviceCfg
iPresetLut | _tDeviceCfg
iTriggerDesc | _tDeviceCfg
iUserDataMaxLen | _tDeviceCfg
pAeAlmHdDesc | _tDeviceCfg
pAeAlmSwDesc | _tDeviceCfg
pBayerDecAlmHdDesc | _tDeviceCfg
pBayerDecAlmSwDesc | _tDeviceCfg
pBayerTypeDesc | _tDeviceCfg
pClrTempDesc | _tDeviceCfg
pFrameSpeedDesc | _tDeviceCfg
pImageSizeDesc | _tDeviceCfg
pMediaTypeDesc | _tDeviceCfg
pPackLenDesc | _tDeviceCfg
pPresetLutDesc | _tDeviceCfg
pTriggerDesc | _tDeviceCfg
sContrastRange | _tDeviceCfg
sGammaContrastRange | _tDeviceCfg
sGammaRange | _tDeviceCfg
sIspCapacity | _tDeviceCfg
sRgbGainRange | _tDeviceCfg
sSaturationRange | _tDeviceCfg
sSharpnessRange | _tDeviceCfg


CKCameraAPI: Member List

_tExpose Member List

This is the complete list of members for _tExpose, including all inherited members.

uiAnalogGainMax | _tExpose
uiAnalogGainMin | _tExpose
uiExposeTimeMax | _tExpose
uiExposeTimeMin | _tExpose
uiTargetMax | _tExpose
uiTargetMin | _tExpose


CKCameraAPI: Member List

_tGammaContrastRange Member List

This is the complete list of members for _tGammaContrastRange, including all inherited members.

iMax | _tGammaContrastRange
iMin | _tGammaContrastRange


CKCameraAPI: Member List

_tGammaRange Member List

This is the complete list of members for _tGammaRange, including all inherited members.

iMax | _tGammaRange
iMin | _tGammaRange


CKCameraAPI: Member List

_tGigeNetworkInfo Member List

This is the complete list of members for _tGigeNetworkInfo, including all inherited members.

acCameraGateway | _tGigeNetworkInfo
acCameraIp | _tGigeNetworkInfo
acCameraNetmask | _tGigeNetworkInfo
acLocalGateway | _tGigeNetworkInfo
acLocalIp | _tGigeNetworkInfo
acLocalNetCardName | _tGigeNetworkInfo
acLocalNetmask | _tGigeNetworkInfo
byMac | _tGigeNetworkInfo
isPersistent | _tGigeNetworkInfo


CKCameraAPI: Member List

_tInitCameraParam Member List

This is the complete list of members for _tInitCameraParam, including all inherited members.

nFrameSpeed | _tInitCameraParam
nGigeTransPacketSize | _tInitCameraParam
nHeartbeatTimeout | _tInitCameraParam
nImageChannelMask | _tInitCameraParam
nImageTransferMode | _tInitCameraParam
nOutputFrameQueueSize | _tInitCameraParam
nRes | _tInitCameraParam
nSensorOutPixelFormat | _tInitCameraParam
nTriggerMode | _tInitCameraParam


CKCameraAPI: Member List

_tIspAe Member List

This is the complete list of members for _tIspAe, including all inherited members.

AeMode | _tIspAe
AeTarget | _tIspAe
AnalogGain | _tIspAe
bAntiFlick | _tIspAe
bAutoExposure | _tIspAe
ExposureTime | _tIspAe
fMaxExposureTime | _tIspAe
fMinExposureTime | _tIspAe
FrequencySel | _tIspAe
Height | _tIspAe
iMaxAnalogGain | _tIspAe
iMinAnalogGain | _tIspAe
Left | _tIspAe
res1 | _tIspAe
res2 | _tIspAe
Top | _tIspAe
Width | _tIspAe


CKCameraAPI: Member List

_tIspGamma Member List

This is the complete list of members for _tIspGamma, including all inherited members.

Gamma | _tIspGamma
GammaContrast | _tIspGamma
Mode | _tIspGamma
PresetSel | _tIspGamma
rev | _tIspGamma


CKCameraAPI: Member List

_tIspWb Member List

This is the complete list of members for _tIspWb, including all inherited members.

bAutoWb | _tIspWb
CCM | _tIspWb
DGainB | _tIspWb
DGainG | _tIspWb
DGainR | _tIspWb
Height | _tIspWb
Left | _tIspWb
Top | _tIspWb
Width | _tIspWb


CKCameraAPI: Member List

_tLscCalibParam Member List

This is the complete list of members for _tLscCalibParam, including all inherited members.

nCalibBufLen | _tLscCalibParam
nCalibBufSize | _tLscCalibParam
nCalibMethod | _tLscCalibParam
nHeight | _tLscCalibParam
nPadCoef | _tLscCalibParam
nRes | _tLscCalibParam
nSecNumH | _tLscCalibParam
nSecNumW | _tLscCalibParam
nSrcBufLen | _tLscCalibParam
nTargetGray | _tLscCalibParam
nWidth | _tLscCalibParam
pCalibBuf | _tLscCalibParam
pSrcBuf | _tLscCalibParam
uiMediaType | _tLscCalibParam


CKCameraAPI: Member List

_tLscCorrectParam Member List

This is the complete list of members for _tLscCorrectParam, including all inherited members.

nCalibBufLen | _tLscCorrectParam
nDstBufLen | _tLscCorrectParam
nDstBufSize | _tLscCorrectParam
nHeight | _tLscCorrectParam
nRes | _tLscCorrectParam
nSrcBufLen | _tLscCorrectParam
nWidth | _tLscCorrectParam
pCalibBuf | _tLscCorrectParam
pDstBuf | _tLscCorrectParam
pSrcBuf | _tLscCorrectParam
uiMediaType | _tLscCorrectParam


CKCameraAPI: Member List

_tResolutionRange Member List

This is the complete list of members for _tResolutionRange, including all inherited members.

iHeightMax | _tResolutionRange
iHeightMin | _tResolutionRange
iWidthMax | _tResolutionRange
iWidthMin | _tResolutionRange
uBinAverageModeMask | _tResolutionRange
uBinSumModeMask | _tResolutionRange
uResampleMask | _tResolutionRange
uSkipModeMask | _tResolutionRange


CKCameraAPI: Member List

_tRgbGainRange Member List

This is the complete list of members for _tRgbGainRange, including all inherited members.

iBGainMax | _tRgbGainRange
iBGainMin | _tRgbGainRange
iGGainMax | _tRgbGainRange
iGGainMin | _tRgbGainRange
iRGainMax | _tRgbGainRange
iRGainMin | _tRgbGainRange


CKCameraAPI: Member List

_tSaturationRange Member List

This is the complete list of members for _tSaturationRange, including all inherited members.

iMax | _tSaturationRange
iMin | _tSaturationRange


CKCameraAPI: Member List

_tSdkAeAlgorithm Member List

This is the complete list of members for _tSdkAeAlgorithm, including all inherited members.

acDescription | _tSdkAeAlgorithm
iIndex | _tSdkAeAlgorithm


CKCameraAPI: Member List

_tSdkBayerDecodeAlgorithm Member List

This is the complete list of members for _tSdkBayerDecodeAlgorithm, including all inherited members.

acDescription | _tSdkBayerDecodeAlgorithm
iIndex | _tSdkBayerDecodeAlgorithm


CKCameraAPI: Member List

_tSdkBayerType Member List

This is the complete list of members for _tSdkBayerType, including all inherited members.

acDescription | _tSdkBayerType
iIndex | _tSdkBayerType
iMediaType | _tSdkBayerType


CKCameraAPI: Member List

_tSdkCameraCapbility Member List

This is the complete list of members for _tSdkCameraCapbility, including all inherited members.

tDeviceCapbility | _tSdkCameraCapbility
tSensorCapbility | _tSdkCameraCapbility


CKCameraAPI: Member List

_tSdkColorTemperatureDes Member List

This is the complete list of members for _tSdkColorTemperatureDes, including all inherited members.

acDescription | _tSdkColorTemperatureDes
iIndex | _tSdkColorTemperatureDes


CKCameraAPI: Member List

_tSdkFrameSpeed Member List

This is the complete list of members for _tSdkFrameSpeed, including all inherited members.

acDescription | _tSdkFrameSpeed
iIndex | _tSdkFrameSpeed


CKCameraAPI: Member List

_tSdkImageResolution Member List

This is the complete list of members for _tSdkImageResolution, including all inherited members.

acDescription | _tSdkImageResolution
iHeight | _tSdkImageResolution
iHeightFOV | _tSdkImageResolution
iHeightZoomHd | _tSdkImageResolution
iHeightZoomSw | _tSdkImageResolution
iHOffsetFOV | _tSdkImageResolution
iIndex | _tSdkImageResolution
iVOffsetFOV | _tSdkImageResolution
iWidth | _tSdkImageResolution
iWidthFOV | _tSdkImageResolution
iWidthZoomHd | _tSdkImageResolution
iWidthZoomSw | _tSdkImageResolution
uBinAverageMode | _tSdkImageResolution
uBinSumMode | _tSdkImageResolution
uResampleMask | _tSdkImageResolution
uSkipMode | _tSdkImageResolution


CKCameraAPI: Member List

_tSdkIspCapacity Member List

This is the complete list of members for _tSdkIspCapacity, including all inherited members.

bAntiFlick | _tSdkIspCapacity
bAutoExposure | _tSdkIspCapacity
bAutoWb | _tSdkIspCapacity
bDeviceIsp | _tSdkIspCapacity
bForceUseDeviceIsp | _tSdkIspCapacity
bIspGamma | _tSdkIspCapacity
bManualExposure | _tSdkIspCapacity
bMonoSensor | _tSdkIspCapacity
bWbOnce | _tSdkIspCapacity
bWdr | _tSdkIspCapacity
bZoomHD | _tSdkIspCapacity
rev | _tSdkIspCapacity


CKCameraAPI: Member List

_tSdkMediaType Member List

This is the complete list of members for _tSdkMediaType, including all inherited members.

acDescription | _tSdkMediaType
iIndex | _tSdkMediaType
iMediaType | _tSdkMediaType


CKCameraAPI: Member List

_tSdkPackLength Member List

This is the complete list of members for _tSdkPackLength, including all inherited members.

acDescription | _tSdkPackLength
iIndex | _tSdkPackLength
iPackSize | _tSdkPackLength


CKCameraAPI: Member List

_tSdkPresetLut Member List

This is the complete list of members for _tSdkPresetLut, including all inherited members.

acDescription | _tSdkPresetLut
iIndex | _tSdkPresetLut


CKCameraAPI: Member List

_tSdkTrigger Member List

This is the complete list of members for _tSdkTrigger, including all inherited members.

acDescription | _tSdkTrigger
iIndex | _tSdkTrigger


CKCameraAPI: Member List

_tSensorCfg Member List

This is the complete list of members for _tSensorCfg, including all inherited members.

sExposeDesc | _tSensorCfg
sMaxResolution | _tSensorCfg
sResolutionRange | _tSensorCfg


CKCameraAPI: Member List

_tSharpnessRange Member List

This is the complete list of members for _tSharpnessRange, including all inherited members.

iMax | _tSharpnessRange
iMin | _tSharpnessRange


CKCameraAPI: Member List

tagRECT Member List

This is the complete list of members for tagRECT, including all inherited members.

bottom | tagRECT
left | tagRECT
right | tagRECT
top | tagRECT